Genesyslab.Enterprise.Agent Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Agent Namespace
Send Feedback

Interfaces

Interface | Description
IAgent | Agent interface.

Enumerations

Enumeration | Description
AgentStateType | Agent status.
Generated on

Copyright (c) 2009-2012 Genesys Telecommunications Laboratories, Inc. All rights reserved.


AgentStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentStateType Enumeration
See Also Send Feedback
Agent status.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum AgentStateType
Visual Basic (Declaration)
Public Enumeration AgentStateType
Visual C++
public enum class AgentStateType

Members

Member name | Description
Unknown | The agent state is unknown.
LoggedOut | The agent state is logged out.
LoggedIn | The agent state is logged in.
Ready | The agent state is ready.
NotReady | The agent state is not ready.
AfterCallWork | The agent state is aftercallwork.
Busy | The agent state is busy.
OutOfService | The agent state is out of service.

See Also

Genesyslab.Enterprise.Agent Namespace


IAgent Interface

[image]

Enterprise SDK 8.0 Reference API
IAgent Interface
Members See Also Send Feedback
Agent interface.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAgent : IIdentity, IRoleable,
    ISerializable, IConfigurable, IShallowCopy<IAgent>, IDeepCopy<IAgent>
Visual Basic (Declaration)
Public Interface IAgent _
    Implements IIdentity, IRoleable, ISerializable, IConfigurable,  _
    IShallowCopy(Of IAgent), IDeepCopy(Of IAgent)
Visual C++
public interface class IAgent : IIdentity,
    IRoleable, ISerializable, IConfigurable, IShallowCopy<IAgent^>,
    IDeepCopy<IAgent^>

See Also

IAgent Members
Genesyslab.Enterprise.Agent Namespace


IAgent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Members
IAgent Interface Methods Properties See Also Send Feedback

The IAgent type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
DeepCopy
Full copy of an object.
(Inherited from IDeepCopy<(Of <(T>)>).)
DndState | Overloaded.
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
ForwardDestination | Overloaded.
ForwardMode | Overloaded.
ForwardNumber | Overloaded.
ForwardState | Overloaded.
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)
HasAgentInfo
Report if a device contains some agent data
(Inherited from IIdentity.)
LastUpdateQueue
Queue modified from the last server update received
Queues
Gets the list of Queues on which the agent is logged-in.
ReasonState
Get the last known reason for the current agent state
ShallowCopy
Partial copy of an object.
(Inherited from IShallowCopy<(Of <(T>)>).)
State | Overloaded.
WorkModeType | Overloaded.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity. (Inherited from IIdentity.)
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device (Inherited from IIdentity.)
FQName | Fully Qualified Name (Unique ID for this object). (Inherited from IIdentity.)
Group | Groups of identities. (Inherited from IIdentity.)
IdentityBase | Gets the Base identity of this identity. (Inherited from IIdentity.)
Item | Gets the property according to its key.
Name | Identity name. (Inherited from IIdentity.)
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity. (Inherited from IIdentity.)

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


IAgent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Methods
IAgent Interface See Also Send Feedback

The IAgent type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
DeepCopy
Full copy of an object.
(Inherited from IDeepCopy<(Of <(T>)>).)
DndState | Overloaded.
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
ForwardDestination | Overloaded.
ForwardMode | Overloaded.
ForwardNumber | Overloaded.
ForwardState | Overloaded.
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)
HasAgentInfo
Report if a device contains some agent data
(Inherited from IIdentity.)
LastUpdateQueue
Queue modified from the last server update received
Queues
Gets the list of Queues on which the agent is logged-in.
ReasonState
Get the last known reason for the current agent state
ShallowCopy
Partial copy of an object.
(Inherited from IShallowCopy<(Of <(T>)>).)
State | Overloaded.
WorkModeType | Overloaded.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Controller Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.Controller Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
Controller()()() | Gets the Controller of this object. (Inherited from IIdentity.)
Controller(String) | Gets the Controller of this object. (Inherited from IIdentity.)

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


DndState Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
DndState(IClientChannel) | Gets the Do Not Disturb state of the agent according to the channel.
DndState(IDevice) | Gets the Do Not Disturb state of the agent according to the device.
DndState(IClientChannel, MediaType) | Gets the Do Not Disturb state of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


DndState Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the Do Not Disturb state of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool DndState(
    IClientChannel channel
)
Visual Basic (Declaration)
Function DndState ( _
    channel As IClientChannel _
) As Boolean
Visual C++
bool DndState(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the Do Not Disturb state of this agent.

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


DndState Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the Do Not Disturb state of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool DndState(
    IDevice device
)
Visual Basic (Declaration)
Function DndState ( _
    device As IDevice _
) As Boolean
Visual C++
bool DndState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the Do Not Disturb state of this agent.

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


DndState Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.DndState Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the Do Not Disturb state of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool DndState(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function DndState ( _
    channel As IClientChannel, _
    media As MediaType _
) As Boolean
Visual C++
bool DndState(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the Do Not Disturb state of this agent.

See Also

IAgent Interface
DndState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardDestination(IClientChannel) | Obsolete.
ForwardDestination(IDevice) | Obsolete.
ForwardDestination(IClientChannel, MediaType) | Obsolete.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IClientChannel)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use ForwardNumber instead")]
string ForwardDestination(
    IClientChannel channel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use ForwardNumber instead")> _
Function ForwardDestination ( _
    channel As IClientChannel _
) As String
Visual C++
[ObsoleteAttribute(L"Use ForwardNumber instead")]
String^ ForwardDestination(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IDevice)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use ForwardNumber instead")]
string ForwardDestination(
    IDevice device
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use ForwardNumber instead")> _
Function ForwardDestination ( _
    device As IDevice _
) As String
Visual C++
[ObsoleteAttribute(L"Use ForwardNumber instead")]
String^ ForwardDestination(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Device.IDevice)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardDestination Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardDestination Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use ForwardNumber instead")]
string ForwardDestination(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use ForwardNumber instead")> _
Function ForwardDestination ( _
    channel As IClientChannel, _
    media As MediaType _
) As String
Visual C++
[ObsoleteAttribute(L"Use ForwardNumber instead")]
String^ ForwardDestination(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType

[Missing <param name="media"/> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Agent.IAgent.ForwardDestination(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Protocol.MediaType)"]

See Also

IAgent Interface
ForwardDestination Overload
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardMode(IClientChannel) | Gets the ForwardMode of the agent according to the channel.
ForwardMode(IDevice) | Gets the ForwardMode of the agent according to the device.
ForwardMode(IClientChannel, MediaType) | Gets the ForwardMode of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the ForwardMode of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ForwardModeType ForwardMode(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardMode ( _
    channel As IClientChannel _
) As ForwardModeType
Visual C++
ForwardModeType ForwardMode(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the ForwardMode type of this agent.

See Also

IAgent Interface
ForwardMode Overload
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the ForwardMode of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ForwardModeType ForwardMode(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardMode ( _
    device As IDevice _
) As ForwardModeType
Visual C++
ForwardModeType ForwardMode(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the ForwardMode type of this agent.

See Also

IAgent Interface
ForwardMode Overload
Genesyslab.Enterprise.Agent Namespace


ForwardMode Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardMode Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the ForwardMode of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ForwardModeType ForwardMode(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardMode ( _
    channel As IClientChannel, _
    media As MediaType _
) As ForwardModeType
Visual C++
ForwardModeType ForwardMode(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the ForwardMode type of this agent.

See Also

IAgent Interface
ForwardMode Overload
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardNumber(IClientChannel) | Gets the Forward number of the agent according to the channel.
ForwardNumber(IDevice) | Gets the Forward number of the agent according to the device.
ForwardNumber(IClientChannel, MediaType) | Gets the Forward number of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the Forward number of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ForwardNumber(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardNumber ( _
    channel As IClientChannel _
) As String
Visual C++
String^ ForwardNumber(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the Forward number of this agent.

See Also

IAgent Interface
ForwardNumber Overload
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the Forward number of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ForwardNumber(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardNumber ( _
    device As IDevice _
) As String
Visual C++
String^ ForwardNumber(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the Forward number of this agent.

See Also

IAgent Interface
ForwardNumber Overload
Genesyslab.Enterprise.Agent Namespace


ForwardNumber Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardNumber Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the Forward number of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ForwardNumber(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardNumber ( _
    channel As IClientChannel, _
    media As MediaType _
) As String
Visual C++
String^ ForwardNumber(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the Forward number of this agent.

See Also

IAgent Interface
ForwardNumber Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
ForwardState(IClientChannel) | Gets the ForwardState of the agent according to the channel.
ForwardState(IDevice) | Gets the ForwardState of the agent according to the device.
ForwardState(IClientChannel, MediaType) | Gets the ForwardState of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the ForwardState of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ForwardState(
    IClientChannel channel
)
Visual Basic (Declaration)
Function ForwardState ( _
    channel As IClientChannel _
) As Boolean
Visual C++
bool ForwardState(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the ForwardState of this agent.

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the ForwardState of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ForwardState(
    IDevice device
)
Visual Basic (Declaration)
Function ForwardState ( _
    device As IDevice _
) As Boolean
Visual C++
bool ForwardState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the ForwardState of this agent.

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


ForwardState Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ForwardState Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the ForwardState of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ForwardState(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function ForwardState ( _
    channel As IClientChannel, _
    media As MediaType _
) As Boolean
Visual C++
bool ForwardState(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the ForwardState of this agent.

See Also

IAgent Interface
ForwardState Overload
Genesyslab.Enterprise.Agent Namespace


LastUpdateQueue Method

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.LastUpdateQueue Method
IAgent Interface See Also Send Feedback
Queue modified from the last server update received

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string LastUpdateQueue(
    IClientChannel channel
)
Visual Basic (Declaration)
Function LastUpdateQueue ( _
    channel As IClientChannel _
) As String
Visual C++
String^ LastUpdateQueue(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

string

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Queues Method

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.Queues Method
IAgent Interface See Also Send Feedback
Gets the list of Queues on which the agent is logged-in.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] Queues(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Queues ( _
    channel As IClientChannel _
) As String()
Visual C++
array<String^>^ Queues(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

List of queues.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


ReasonState Method

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.ReasonState Method
IAgent Interface See Also Send Feedback
Get the last known reason for the current agent state

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ReasonState(
    IDevice device
)
Visual Basic (Declaration)
Function ReasonState ( _
    device As IDevice _
) As String
Visual C++
String^ ReasonState(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Agent state on the specified device

Return Value

string

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


State Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
State(IClientChannel) | Gets the AgentState type of the agent according to the channel.
State(IDevice) | Gets the AgentState type of the agent according to the device.
State(IClientChannel, MediaType) | Gets the AgentState type of the agent according to the channel and the media.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


State Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the AgentState type of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
AgentStateType State(
    IClientChannel channel
)
Visual Basic (Declaration)
Function State ( _
    channel As IClientChannel _
) As AgentStateType
Visual C++
AgentStateType State(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the AgentState type of this agent.

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


State Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the AgentState type of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
AgentStateType State(
    IDevice device
)
Visual Basic (Declaration)
Function State ( _
    device As IDevice _
) As AgentStateType
Visual C++
AgentStateType State(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the AgentState type of this agent.

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


State Method (IClientChannel, MediaType)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.State Method (IClientChannel, MediaType)
IAgent Interface See Also Send Feedback
Gets the AgentState type of the agent according to the channel and the media.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
AgentStateType State(
    IClientChannel channel,
    MediaType media
)
Visual Basic (Declaration)
Function State ( _
    channel As IClientChannel, _
    media As MediaType _
) As AgentStateType
Visual C++
AgentStateType State(
    IClientChannel^ channel,
    MediaType media
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.
media
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
a media used by this agent.

Return Value

the AgentState type of this agent.

See Also

IAgent Interface
State Overload
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method
IAgent Interface See Also Send Feedback

Overload List

Name | Description
WorkModeType(IClientChannel) | Gets the WorkMode type of the agent according to the channel.
WorkModeType(IDevice) | Gets the WorkMode type of the agent according to the device.

See Also

IAgent Interface
IAgent Members
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method (IClientChannel)
IAgent Interface See Also Send Feedback
Gets the WorkMode type of the agent according to the channel.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
WorkMode WorkModeType(
    IClientChannel channel
)
Visual Basic (Declaration)
Function WorkModeType ( _
    channel As IClientChannel _
) As WorkMode
Visual C++
WorkMode WorkModeType(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
a channel used by this agent.

Return Value

the WorkMode type of this agent.

See Also

IAgent Interface
WorkModeType Overload
Genesyslab.Enterprise.Agent Namespace


WorkModeType Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.WorkModeType Method (IDevice)
IAgent Interface See Also Send Feedback
Gets the WorkMode type of the agent according to the device.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
WorkMode WorkModeType(
    IDevice device
)
Visual Basic (Declaration)
Function WorkModeType ( _
    device As IDevice _
) As WorkMode
Visual C++
WorkMode WorkModeType(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
a device of the agent.

Return Value

the WorkMode type of this agent.

See Also

IAgent Interface
WorkModeType Overload
Genesyslab.Enterprise.Agent Namespace


IAgent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAgent Properties
IAgent Interface See Also Send Feedback

The IAgent type exposes the following members.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity. (Inherited from IIdentity.)
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device (Inherited from IIdentity.)
FQName | Fully Qualified Name (Unique ID for this object). (Inherited from IIdentity.)
Group | Groups of identities. (Inherited from IIdentity.)
IdentityBase | Gets the Base identity of this identity. (Inherited from IIdentity.)
Item | Gets the property according to its key.
Name | Identity name. (Inherited from IIdentity.)
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity. (Inherited from IIdentity.)

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IAgent..::.Item Property
IAgent Interface See Also Send Feedback
Gets the property according to its key.

Namespace: Genesyslab.Enterprise.Agent
Assembly: Genesyslab.Enterprise.Agent (in Genesyslab.Enterprise.Agent.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As Object
Visual C++
property Object^ default[String^ key] {
    Object^ get (String^ key);
}

Parameters

key
Type: System..::.String
the key.

Return Value

the property as object.

See Also

IAgent Interface
Genesyslab.Enterprise.Agent Namespace


Genesyslab.Enterprise.Commons Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Commons Namespace
Send Feedback

Interfaces

Interface | Description
IDeepCopy<(Of <(T>)>) | Creates a full copy of an object instance.
IShallowCopy<(Of <(T>)>) | Hanldes a partial copy of the given object.


IDeepCopy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Interface
Members See Also Send Feedback
Creates a full copy of an object instance.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDeepCopy<T>
Visual Basic (Declaration)
Public Interface IDeepCopy(Of T)
Visual C++
generic<typename T>
public interface class IDeepCopy

Type Parameters

T
the type of data.

See Also

IDeepCopy<(Of <(T>)>) Members
Genesyslab.Enterprise.Commons Namespace


IDeepCopy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Members
IDeepCopy<(Of <(T>)>) Interface Methods See Also Send Feedback

The IDeepCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object.

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IDeepCopy(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>) Methods
IDeepCopy<(Of <(T>)>) Interface See Also Send Feedback

The IDeepCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object.

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


DeepCopy Method

[image]

Enterprise SDK 8.0 Reference API
IDeepCopy<(Of <(T>)>)..::.DeepCopy Method
IDeepCopy<(Of <(T>)>) Interface See Also Send Feedback
Full copy of an object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T DeepCopy()
Visual Basic (Declaration)
Function DeepCopy As T
Visual C++
T DeepCopy()

Return Value

Full copy of this object.

See Also

IDeepCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Interface
Members See Also Send Feedback
Hanldes a partial copy of the given object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IShallowCopy<T>
Visual Basic (Declaration)
Public Interface IShallowCopy(Of T)
Visual C++
generic<typename T>
public interface class IShallowCopy

Type Parameters

T
Object type.

See Also

IShallowCopy<(Of <(T>)>) Members
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Members
IShallowCopy<(Of <(T>)>) Interface Methods See Also Send Feedback

The IShallowCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ShallowCopy | Partial copy of an object.

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


IShallowCopy(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>) Methods
IShallowCopy<(Of <(T>)>) Interface See Also Send Feedback

The IShallowCopy<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ShallowCopy | Partial copy of an object.

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


ShallowCopy Method

[image]

Enterprise SDK 8.0 Reference API
IShallowCopy<(Of <(T>)>)..::.ShallowCopy Method
IShallowCopy<(Of <(T>)>) Interface See Also Send Feedback
Partial copy of an object.

Namespace: Genesyslab.Enterprise.Commons
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T ShallowCopy()
Visual Basic (Declaration)
Function ShallowCopy As T
Visual C++
T ShallowCopy()

Return Value

Shallow copy of this object.

See Also

IShallowCopy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Commons Namespace


Genesyslab.Enterprise.Core Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Core Namespace
Send Feedback

Interfaces

Interface | Description
IDN | Interface for Directory Numbers.

Enumerations

Enumeration | Description
DnAdressType |
HookStateType |
MuteModeType |


DnAdressType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DnAdressType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Core.DnAdressType"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum DnAdressType
Visual Basic (Declaration)
Public Enumeration DnAdressType
Visual C++
public enum class DnAdressType

Members

Member name | Description
Unknown |
Extension |
Position |

See Also

Genesyslab.Enterprise.Core Namespace


HookStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
HookStateType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Core.HookStateType"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum HookStateType
Visual Basic (Declaration)
Public Enumeration HookStateType
Visual C++
public enum class HookStateType

Members

Member name | Description
Unknown |
OnHook |
OffHook |

See Also

Genesyslab.Enterprise.Core Namespace


IDN Interface

[image]

Enterprise SDK 8.0 Reference API
IDN Interface
Members See Also Send Feedback
Interface for Directory Numbers.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDN : IDevice, ISerializable,
    IConfigurable, IShallowCopy<IDN>, IDeepCopy<IDN>
Visual Basic (Declaration)
Public Interface IDN _
    Implements IDevice, ISerializable, IConfigurable, IShallowCopy(Of IDN),  _
    IDeepCopy(Of IDN)
Visual C++
public interface class IDN : IDevice,
    ISerializable, IConfigurable, IShallowCopy<IDN^>, IDeepCopy<IDN^>

See Also

IDN Members
Genesyslab.Enterprise.Core Namespace


IDN Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Members
IDN Interface Methods Properties See Also Send Feedback

The IDN type exposes the following members.

Methods

Name Description
DeepCopy
Full copy of an object.
(Inherited from IDeepCopy<(Of <(T>)>).)
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)
ShallowCopy
Partial copy of an object.
(Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling (Inherited from IDevice.)
ActiveChannels | List of active channels for this device. (Inherited from IDevice.)
Attributes | Gets the attributes of the device. (Inherited from IDevice.)
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail. (Inherited from IDevice.)
Controller | Returns the state controller of the object. (Inherited from IDevice.)
DnAdress | Gets the DnAddress type of the IDN.
DndState | Gets the Do Not Disturb state of the IDN.
ForwardMode | Gets the ForwardMode type of the IDN.
ForwardNumber | Gets the Forward number of the IDN.
ForwardState | Gets the ForwardState of the IDN.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name. (Inherited from IDevice.)
Group | Group of subdevices which compose this device. (Inherited from IDevice.)
HookState | Gets the HookState of the IDN.
Identity | Identity in relation with the device. (Inherited from IDevice.)
IsComposite | Gets the composition status of the IDN.
Item | Gets a property according to its key.
MuteMode | Gets the MuteMode of the IDN.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations. (Inherited from IDevice.)
ProtocolRule | Get the switch policy linked to this object
State | Device status. (Inherited from IDevice.)
Strategy | List of stategies handled by the object. (Inherited from IDevice.)
Tenant | Gets the tenant of the IDN.

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IDN Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Methods
IDN Interface See Also Send Feedback

The IDN type exposes the following members.

Methods

Name Description
DeepCopy
Full copy of an object.
(Inherited from IDeepCopy<(Of <(T>)>).)
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.
(Inherited from IConfigurable.)
GetObjectData
Populates a SerializationInfo with the data needed to serialize the target object.
(Inherited from ISerializable.)
ShallowCopy
Partial copy of an object.
(Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IDN Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDN Properties
IDN Interface See Also Send Feedback

The IDN type exposes the following members.

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling (Inherited from IDevice.)
ActiveChannels | List of active channels for this device. (Inherited from IDevice.)
Attributes | Gets the attributes of the device. (Inherited from IDevice.)
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail. (Inherited from IDevice.)
Controller | Returns the state controller of the object. (Inherited from IDevice.)
DnAdress | Gets the DnAddress type of the IDN.
DndState | Gets the Do Not Disturb state of the IDN.
ForwardMode | Gets the ForwardMode type of the IDN.
ForwardNumber | Gets the Forward number of the IDN.
ForwardState | Gets the ForwardState of the IDN.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name. (Inherited from IDevice.)
Group | Group of subdevices which compose this device. (Inherited from IDevice.)
HookState | Gets the HookState of the IDN.
Identity | Identity in relation with the device. (Inherited from IDevice.)
IsComposite | Gets the composition status of the IDN.
Item | Gets a property according to its key.
MuteMode | Gets the MuteMode of the IDN.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations. (Inherited from IDevice.)
ProtocolRule | Get the switch policy linked to this object
State | Device status. (Inherited from IDevice.)
Strategy | List of stategies handled by the object. (Inherited from IDevice.)
Tenant | Gets the tenant of the IDN.

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


DnAdress Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.DnAdress Property
IDN Interface See Also Send Feedback
Gets the DnAddress type of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DnAdressType DnAdress { get; }
Visual Basic (Declaration)
ReadOnly Property DnAdress As DnAdressType
Visual C++
property DnAdressType DnAdress {
    DnAdressType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


DndState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.DndState Property
IDN Interface See Also Send Feedback
Gets the Do Not Disturb state of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool DndState { get; }
Visual Basic (Declaration)
ReadOnly Property DndState As Boolean
Visual C++
property bool DndState {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardMode Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardMode Property
IDN Interface See Also Send Feedback
Gets the ForwardMode type of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ForwardModeType ForwardMode { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardMode As ForwardModeType
Visual C++
property ForwardModeType ForwardMode {
    ForwardModeType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardNumber Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardNumber Property
IDN Interface See Also Send Feedback
Gets the Forward number of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ForwardNumber { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardNumber As String
Visual C++
property String^ ForwardNumber {
    String^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ForwardState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ForwardState Property
IDN Interface See Also Send Feedback
Gets the ForwardState of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ForwardState { get; }
Visual Basic (Declaration)
ReadOnly Property ForwardState As Boolean
Visual C++
property bool ForwardState {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


HookState Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.HookState Property
IDN Interface See Also Send Feedback
Gets the HookState of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
HookStateType HookState { get; }
Visual Basic (Declaration)
ReadOnly Property HookState As HookStateType
Visual C++
property HookStateType HookState {
    HookStateType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


IsComposite Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.IsComposite Property
IDN Interface See Also Send Feedback
Gets the composition status of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsComposite { get; }
Visual Basic (Declaration)
ReadOnly Property IsComposite As Boolean
Visual C++
property bool IsComposite {
    bool get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.Item Property
IDN Interface See Also Send Feedback
Gets a property according to its key.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As Object
Visual C++
property Object^ default[String^ key] {
    Object^ get (String^ key);
}

Parameters

key
Type: System..::.String
the key.

Return Value

the object property of the key.

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


MuteMode Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.MuteMode Property
IDN Interface See Also Send Feedback
Gets the MuteMode of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MuteModeType MuteMode { get; }
Visual Basic (Declaration)
ReadOnly Property MuteMode As MuteModeType
Visual C++
property MuteModeType MuteMode {
    MuteModeType get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


ProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.ProtocolRule Property
IDN Interface See Also Send Feedback
Get the switch policy linked to this object

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRule ProtocolRule { get; }
Visual Basic (Declaration)
ReadOnly Property ProtocolRule As IProtocolRule
Visual C++
property IProtocolRule^ ProtocolRule {
    IProtocolRule^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


Tenant Property

[image]

Enterprise SDK 8.0 Reference API
IDN..::.Tenant Property
IDN Interface See Also Send Feedback
Gets the tenant of the IDN.

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Tenant { get; }
Visual Basic (Declaration)
ReadOnly Property Tenant As String
Visual C++
property String^ Tenant {
    String^ get ();
}

See Also

IDN Interface
Genesyslab.Enterprise.Core Namespace


MuteModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MuteModeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Core.MuteModeType"]

Namespace: Genesyslab.Enterprise.Core
Assembly: Genesyslab.Enterprise.Core (in Genesyslab.Enterprise.Core.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MuteModeType
Visual Basic (Declaration)
Public Enumeration MuteModeType
Visual C++
public enum class MuteModeType

Members

Member name | Description
Unknown |
MuteOn |
MuteOff |

See Also

Genesyslab.Enterprise.Core Namespace


Genesyslab.Enterprise.Exceptions.Channel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Channel Namespace
Send Feedback

Enumerations

Enumeration | Description
ChannelExceptionType | Enumerate for Channel Exception Type.


ChannelExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChannelExceptionType Enumeration
See Also Send Feedback
Enumerate for Channel Exception Type.

Namespace: Genesyslab.Enterprise.Exceptions.Channel
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ChannelExceptionType
Visual Basic (Declaration)
Public Enumeration ChannelExceptionType
Visual C++
public enum class ChannelExceptionType

Members

Member name | Description
ChannelUnknownError | Unknown Error.
ChannelConnectionFailed | Connection Failed.
ChannelDoesNotExist | Channel does not exist.
ChannelNotInitializedProperly | Channel is not initialized.
ChannelInvalidTimeout | Invalid Time-out.
ChannelClosingFailed | Closing channel failed.
ChannelSendFailed | Send request failed.
ChannelInvalidProtocol | Invalid protocol for this channel.

See Also

Genesyslab.Enterprise.Exceptions.Channel Namespace


Genesyslab.Enterprise.Exceptions.Protocol Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Protocol Namespace
Send Feedback

Enumerations

Enumeration | Description
ProtocolExceptionType | Enumerate for Protocol Exception type.


ProtocolExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProtocolExceptionType Enumeration
See Also Send Feedback
Enumerate for Protocol Exception type.

Namespace: Genesyslab.Enterprise.Exceptions.Protocol
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ProtocolExceptionType
Visual Basic (Declaration)
Public Enumeration ProtocolExceptionType
Visual C++
public enum class ProtocolExceptionType

Members

Member name | Description
InvalidParameter | Invalid parameter.
MissingParameter | Missing parameter in protocol.
InvalidObjectState | Invalid object state for this protocol action.
ProtocolUnknownError | Unknown Error.
MissingProtocol | Missing protocol

See Also

Genesyslab.Enterprise.Exceptions.Protocol Namespace


Genesyslab.Enterprise.Exceptions.Strategy Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Exceptions.Strategy Namespace
Send Feedback

Enumerations

Enumeration | Description
StrategyExceptionType |


StrategyExceptionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StrategyExceptionType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Exceptions.Strategy.StrategyExceptionType"]

Namespace: Genesyslab.Enterprise.Exceptions.Strategy
Assembly: Genesyslab.Enterprise.Exceptions (in Genesyslab.Enterprise.Exceptions.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum StrategyExceptionType
Visual Basic (Declaration)
Public Enumeration StrategyExceptionType
Visual C++
public enum class StrategyExceptionType

Members

Member name | Description
UnknownError |
StrategyType |
StrategyNotDefined |
StrategyNotSupported |

See Also

Genesyslab.Enterprise.Exceptions.Strategy Namespace


Genesyslab.Enterprise.Extensions Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Extensions Namespace
Send Feedback

Interfaces

Interface | Description
IThreadSafeDictionary<(Of <(TKey, TValue>)>) |


IThreadSafeDictionary(TKey, TValue) Interface

[image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Utility (in Genesyslab.Enterprise.Utility.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IThreadSafeDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable
Visual Basic (Declaration)
Public Interface IThreadSafeDictionary(Of TKey, TValue) _
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),  _
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
Visual C++
generic<typename TKey, typename TValue>
public interface class IThreadSafeDictionary : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2"]

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Extensions Namespace


IThreadSafeDictionary(TKey, TValue) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Members
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface Methods Properties See Also Send Feedback

The IThreadSafeDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
ContainsKey | Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key. (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
GetEnumerator | Overloaded.
MergeSafe |
Remove | Overloaded.
RemoveSafe | This is a blind remove. Prevents the need to check for existence first.
TryGetValue | Gets the value associated with the specified key. (Inherited from IDictionary <(Of <( TKey, TValue >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
Item | Gets or sets the element with the specified key. (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
Keys | Gets an ICollection<(Of <(T>)>) containing the keys of the IDictionary<(Of <(TKey, TValue>)>). (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
Values | Gets an ICollection<(Of <(T>)>) containing the values in the IDictionary<(Of <(TKey, TValue>)>). (Inherited from IDictionary <(Of <( TKey, TValue >)>).)

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
Genesyslab.Enterprise.Extensions Namespace


IThreadSafeDictionary(TKey, TValue) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Methods
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback

The IThreadSafeDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
ContainsKey | Determines whether the IDictionary<(Of <(TKey, TValue>)>) contains an element with the specified key. (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
GetEnumerator | Overloaded.
MergeSafe |
Remove | Overloaded.
RemoveSafe | This is a blind remove. Prevents the need to check for existence first.
TryGetValue | Gets the value associated with the specified key. (Inherited from IDictionary <(Of <( TKey, TValue >)>).)

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
Genesyslab.Enterprise.Extensions Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>)..::.Add Method
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback

Overload List

Name | Description
Add(T) | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
Add(TKey, TValue) | Adds an element with the provided key and value to the IDictionary<(Of <(TKey, TValue>)>). (Inherited from IDictionary <(Of <( TKey, TValue >)>).)

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Extensions Namespace


GetEnumerator Method

[image] [image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>)..::.GetEnumerator Method
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Extensions Namespace


MergeSafe Method

[image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>)..::.MergeSafe Method
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2.MergeSafe(`0,`1)"]

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Utility (in Genesyslab.Enterprise.Utility.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void MergeSafe(
    TKey key,
    TValue newValue
)
Visual Basic (Declaration)
Sub MergeSafe ( _
    key As TKey, _
    newValue As TValue _
)
Visual C++
void MergeSafe(
    TKey key,
    TValue newValue
)

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2.MergeSafe(`0,`1)"]

newValue
Type: TValue

[Missing <param name="newValue"/> documentation for "M:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2.MergeSafe(`0,`1)"]

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
Genesyslab.Enterprise.Extensions Namespace


Remove Method

[image] [image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>)..::.Remove Method
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback

Overload List

Name | Description
Remove(TKey) | Removes the element with the specified key from the IDictionary<(Of <(TKey, TValue>)>). (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
Remove(T) | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Extensions Namespace


RemoveSafe Method

[image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>)..::.RemoveSafe Method
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback
This is a blind remove. Prevents the need to check for existence first.

Namespace: Genesyslab.Enterprise.Extensions
Assembly: Genesyslab.Enterprise.Utility (in Genesyslab.Enterprise.Utility.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveSafe(
    TKey key
)
Visual Basic (Declaration)
Sub RemoveSafe ( _
    key As TKey _
)
Visual C++
void RemoveSafe(
    TKey key
)

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Extensions.IThreadSafeDictionary`2.RemoveSafe(`0)"]

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
Genesyslab.Enterprise.Extensions Namespace


IThreadSafeDictionary(TKey, TValue) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Properties
IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface See Also Send Feedback

The IThreadSafeDictionary<(Of <(TKey, TValue>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection <(Of <( KeyValuePair <(Of <( TKey, TValue >)>)>)>).)
Item | Gets or sets the element with the specified key. (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
Keys | Gets an ICollection<(Of <(T>)>) containing the keys of the IDictionary<(Of <(TKey, TValue>)>). (Inherited from IDictionary <(Of <( TKey, TValue >)>).)
Values | Gets an ICollection<(Of <(T>)>) containing the values in the IDictionary<(Of <(TKey, TValue>)>). (Inherited from IDictionary <(Of <( TKey, TValue >)>).)

See Also

IThreadSafeDictionary<(Of <(TKey, TValue>)>) Interface
Genesyslab.Enterprise.Extensions Namespace


Genesyslab.Enterprise.Framework.Container.Unity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Framework.Container.Unity Namespace
Send Feedback

Interfaces

Interface | Description
ICreationParametersPolicy |


ICreationParametersPolicy Interface

[image]

Enterprise SDK 8.0 Reference API
ICreationParametersPolicy Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.Container.Unity.ICreationParametersPolicy"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICreationParametersPolicy : IBuilderPolicy
Visual Basic (Declaration)
Public Interface ICreationParametersPolicy _
    Implements IBuilderPolicy
Visual C++
public interface class ICreationParametersPolicy : IBuilderPolicy

See Also

ICreationParametersPolicy Members
Genesyslab.Enterprise.Framework.Container.Unity Namespace


ICreationParametersPolicy Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICreationParametersPolicy Members
ICreationParametersPolicy Interface Properties See Also Send Feedback

The ICreationParametersPolicy type exposes the following members.

Properties

Name | Description
Parameters |

See Also

ICreationParametersPolicy Interface
Genesyslab.Enterprise.Framework.Container.Unity Namespace


ICreationParametersPolicy Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICreationParametersPolicy Properties
ICreationParametersPolicy Interface See Also Send Feedback

The ICreationParametersPolicy type exposes the following members.

Properties

Name | Description
Parameters |

See Also

ICreationParametersPolicy Interface
Genesyslab.Enterprise.Framework.Container.Unity Namespace


Parameters Property

[image]

Enterprise SDK 8.0 Reference API
ICreationParametersPolicy..::.Parameters Property
ICreationParametersPolicy Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.Container.Unity.ICreationParametersPolicy.Parameters"]

Namespace: Genesyslab.Enterprise.Framework.Container.Unity
Assembly: Genesyslab.Enterprise.Framework (in Genesyslab.Enterprise.Framework.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object[] Parameters { get; }
Visual Basic (Declaration)
ReadOnly Property Parameters As Object()
Visual C++
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

See Also

ICreationParametersPolicy Interface
Genesyslab.Enterprise.Framework.Container.Unity Namespace


Genesyslab.Enterprise.Framework.StateMachine Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Framework.StateMachine Namespace
Send Feedback

Interfaces

Interface | Description
IStateMachine |
IStateMachineBuilder |
IStateMachineComponent |
IStateMachineContext |
IStateMachineEvent |
IStateMachineService | State machine repository
IStateMachineState |
IStateMachineStateBuilder |
IStateTransition |
IStateTransitionAction |
IStateTransitionActionManager |

Enumerations

Enumeration | Description
ControllerResponse |
StateTransitionPhase |


ControllerResponse Enumeration

[image]

Enterprise SDK 8.0 Reference API
ControllerResponse Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.ControllerResponse"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ControllerResponse
Visual Basic (Declaration)
Public Enumeration ControllerResponse
Visual C++
public enum class ControllerResponse

Members

Member name | Description
EventNotRegistered |
EventNotInScope |
TransitionCanceled |
TransitionComplete |

See Also

Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachine Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachine Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachine"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachine : IStateMachineBuilder,
    IStateTransitionActionManager
Visual Basic (Declaration)
Public Interface IStateMachine _
    Implements IStateMachineBuilder, IStateTransitionActionManager
Visual C++
public interface class IStateMachine : IStateMachineBuilder,
    IStateTransitionActionManager

See Also

IStateMachine Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachine Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachine Members
IStateMachine Interface Methods Properties See Also Send Feedback

The IStateMachine type exposes the following members.

Methods

Name | Description
AddNewEvent | Adds the new event. (Inherited from IStateMachineBuilder.)
AddNewState | Adds the new obj. (Inherited from IStateMachineBuilder.)
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)

Properties

Name | Description
Events | Gets the events.
Name | Gets the name.
States | Gets the states.
StateTransitionActions | Gets the obj transition actions.
Tag | Gets or sets the tag.

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachine Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachine Methods
IStateMachine Interface See Also Send Feedback

The IStateMachine type exposes the following members.

Methods

Name | Description
AddNewEvent | Adds the new event. (Inherited from IStateMachineBuilder.)
AddNewState | Adds the new obj. (Inherited from IStateMachineBuilder.)
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachine Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachine Properties
IStateMachine Interface See Also Send Feedback

The IStateMachine type exposes the following members.

Properties

Name | Description
Events | Gets the events.
Name | Gets the name.
States | Gets the states.
StateTransitionActions | Gets the obj transition actions.
Tag | Gets or sets the tag.

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Events Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachine..::.Events Property
IStateMachine Interface See Also Send Feedback
Gets the events.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineEvent[] Events { get; }
Visual Basic (Declaration)
ReadOnly Property Events As IStateMachineEvent()
Visual C++
property array<IStateMachineEvent^>^ Events {
    array<IStateMachineEvent^>^ get ();
}

Field Value

The events

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachine..::.Name Property
IStateMachine Interface See Also Send Feedback
Gets the name.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

Field Value

The name

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


States Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachine..::.States Property
IStateMachine Interface See Also Send Feedback
Gets the states.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineState[] States { get; }
Visual Basic (Declaration)
ReadOnly Property States As IStateMachineState()
Visual C++
property array<IStateMachineState^>^ States {
    array<IStateMachineState^>^ get ();
}

Field Value

The states

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateTransitionActions Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachine..::.StateTransitionActions Property
IStateMachine Interface See Also Send Feedback
Gets the obj transition actions.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateTransitionAction[] StateTransitionActions { get; }
Visual Basic (Declaration)
ReadOnly Property StateTransitionActions As IStateTransitionAction()
Visual C++
property array<IStateTransitionAction^>^ StateTransitionActions {
    array<IStateTransitionAction^>^ get ();
}

Field Value

The obj transition actions.

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Tag Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachine..::.Tag Property
IStateMachine Interface See Also Send Feedback
Gets or sets the tag.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Tag { get; set; }
Visual Basic (Declaration)
Property Tag As Object
Visual C++
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Field Value

The tag.

See Also

IStateMachine Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineBuilder Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineBuilder Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineBuilder"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineBuilder : IStateTransitionActionManager
Visual Basic (Declaration)
Public Interface IStateMachineBuilder _
    Implements IStateTransitionActionManager
Visual C++
public interface class IStateMachineBuilder : IStateTransitionActionManager

See Also

IStateMachineBuilder Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineBuilder Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineBuilder Members
IStateMachineBuilder Interface Methods See Also Send Feedback

The IStateMachineBuilder type exposes the following members.

Methods

Name | Description
AddNewEvent | Adds the new event.
AddNewState | Adds the new obj.
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)

See Also

IStateMachineBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineBuilder Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineBuilder Methods
IStateMachineBuilder Interface See Also Send Feedback

The IStateMachineBuilder type exposes the following members.

Methods

Name | Description
AddNewEvent | Adds the new event.
AddNewState | Adds the new obj.
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)

See Also

IStateMachineBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


AddNewEvent Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineBuilder..::.AddNewEvent Method
IStateMachineBuilder Interface See Also Send Feedback
Adds the new event.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineEvent AddNewEvent(
    string stateEvent,
    Object eventIdentifier
)
Visual Basic (Declaration)
Function AddNewEvent ( _
    stateEvent As String, _
    eventIdentifier As Object _
) As IStateMachineEvent
Visual C++
IStateMachineEvent^ AddNewEvent(
    String^ stateEvent,
    Object^ eventIdentifier
)

Parameters

stateEvent
Type: System..::.String
The obj event.
eventIdentifier
Type: System..::.Object
The event identifier.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineBuilder.AddNewEvent(System.String,System.Object)"]

See Also

IStateMachineBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


AddNewState Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineBuilder..::.AddNewState Method
IStateMachineBuilder Interface See Also Send Feedback
Adds the new obj.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineState AddNewState(
    string stateName,
    Object stateIdentifier
)
Visual Basic (Declaration)
Function AddNewState ( _
    stateName As String, _
    stateIdentifier As Object _
) As IStateMachineState
Visual C++
IStateMachineState^ AddNewState(
    String^ stateName,
    Object^ stateIdentifier
)

Parameters

stateName
Type: System..::.String
Name of the obj.
stateIdentifier
Type: System..::.Object
The obj identifier.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineBuilder.AddNewState(System.String,System.Object)"]

See Also

IStateMachineBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineComponent Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineComponent Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineComponent"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineComponent
Visual Basic (Declaration)
Public Interface IStateMachineComponent
Visual C++
public interface class IStateMachineComponent

See Also

IStateMachineComponent Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineComponent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineComponent Members
IStateMachineComponent Interface Properties See Also Send Feedback

The IStateMachineComponent type exposes the following members.

Properties

Name | Description
StateMachine |

See Also

IStateMachineComponent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineComponent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineComponent Properties
IStateMachineComponent Interface See Also Send Feedback

The IStateMachineComponent type exposes the following members.

Properties

Name | Description
StateMachine |

See Also

IStateMachineComponent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateMachine Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineComponent..::.StateMachine Property
IStateMachineComponent Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineComponent.StateMachine"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachine StateMachine { get; }
Visual Basic (Declaration)
ReadOnly Property StateMachine As IStateMachine
Visual C++
property IStateMachine^ StateMachine {
    IStateMachine^ get ();
}

See Also

IStateMachineComponent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineContext Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineContext : IStateMachineComponent
Visual Basic (Declaration)
Public Interface IStateMachineContext _
    Implements IStateMachineComponent
Visual C++
public interface class IStateMachineContext : IStateMachineComponent

See Also

IStateMachineContext Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineContext Members
IStateMachineContext Interface Methods Properties Events See Also Send Feedback

The IStateMachineContext type exposes the following members.

Methods

Name | Description
HandleEvent |
SetState |
Start | Overloaded.

Properties

Name | Description
CurrentState |
DomainContext |
Id |
IsComplete |
IsStarted |
StateMachine | (Inherited from IStateMachineComponent.)

Events

Name | Description
AfterStateChanged |
BeforeStateChanged |
StateFinalized |
StateInitialized |
StateMachineComplete |
StateMachineStarted |

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineContext Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineContext Methods
IStateMachineContext Interface See Also Send Feedback

The IStateMachineContext type exposes the following members.

Methods

Name | Description
HandleEvent |
SetState |
Start | Overloaded.

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


HandleEvent Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.HandleEvent Method
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.HandleEvent(System.Object)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ControllerResponse HandleEvent(
    Object eventIdentifier
)
Visual Basic (Declaration)
Function HandleEvent ( _
    eventIdentifier As Object _
) As ControllerResponse
Visual C++
ControllerResponse HandleEvent(
    Object^ eventIdentifier
)

Parameters

eventIdentifier
Type: System..::.Object

[Missing <param name="eventIdentifier"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.HandleEvent(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.HandleEvent(System.Object)"]

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


SetState Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.SetState Method
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.SetState(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineContext SetState(
    IStateMachineState targetState
)
Visual Basic (Declaration)
Function SetState ( _
    targetState As IStateMachineState _
) As IStateMachineContext
Visual C++
IStateMachineContext^ SetState(
    IStateMachineState^ targetState
)

Parameters

targetState
Type: Genesyslab.Enterprise.Framework.StateMachine..::.IStateMachineState

[Missing <param name="targetState"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.SetState(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.SetState(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Start Method

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.Start Method
IStateMachineContext Interface See Also Send Feedback

Overload List

Name | Description
Start()()() |
Start(IStateMachineState) |

See Also

IStateMachineContext Interface
IStateMachineContext Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


Start Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.Start Method
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.Start"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Start()
Visual Basic (Declaration)
Sub Start
Visual C++
void Start()

See Also

IStateMachineContext Interface
Start Overload
Genesyslab.Enterprise.Framework.StateMachine Namespace


Start Method (IStateMachineState)

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.Start Method (IStateMachineState)
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.Start(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Start(
    IStateMachineState targetState
)
Visual Basic (Declaration)
Sub Start ( _
    targetState As IStateMachineState _
)
Visual C++
void Start(
    IStateMachineState^ targetState
)

Parameters

targetState
Type: Genesyslab.Enterprise.Framework.StateMachine..::.IStateMachineState

[Missing <param name="targetState"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.Start(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

See Also

IStateMachineContext Interface
Start Overload
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineContext Properties
IStateMachineContext Interface See Also Send Feedback

The IStateMachineContext type exposes the following members.

Properties

Name | Description
CurrentState |
DomainContext |
Id |
IsComplete |
IsStarted |
StateMachine | (Inherited from IStateMachineComponent.)

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


CurrentState Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.CurrentState Property
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.CurrentState"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineState CurrentState { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentState As IStateMachineState
Visual C++
property IStateMachineState^ CurrentState {
    IStateMachineState^ get ();
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


DomainContext Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.DomainContext Property
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.DomainContext"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object DomainContext { get; }
Visual Basic (Declaration)
ReadOnly Property DomainContext As Object
Visual C++
property Object^ DomainContext {
    Object^ get ();
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.Id Property
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.Id"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Guid Id { get; set; }
Visual Basic (Declaration)
Property Id As Guid
Visual C++
property Guid Id {
    Guid get ();
    void set (Guid value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IsComplete Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.IsComplete Property
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.IsComplete"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsComplete { get; }
Visual Basic (Declaration)
ReadOnly Property IsComplete As Boolean
Visual C++
property bool IsComplete {
    bool get ();
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IsStarted Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.IsStarted Property
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.IsStarted"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsStarted { get; }
Visual Basic (Declaration)
ReadOnly Property IsStarted As Boolean
Visual C++
property bool IsStarted {
    bool get ();
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineContext Events

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineContext Events
IStateMachineContext Interface See Also Send Feedback

The IStateMachineContext type exposes the following members.

Events

Name | Description
AfterStateChanged |
BeforeStateChanged |
StateFinalized |
StateInitialized |
StateMachineComplete |
StateMachineStarted |

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


AfterStateChanged Event

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.AfterStateChanged Event
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.AfterStateChanged"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler<StateChangedEventArgs> AfterStateChanged
Visual Basic (Declaration)
Event AfterStateChanged As EventHandler(Of StateChangedEventArgs)
Visual C++
 event EventHandler<StateChangedEventArgs^>^ AfterStateChanged {
    void add (EventHandler<StateChangedEventArgs^>^ value);
    void remove (EventHandler<StateChangedEventArgs^>^ value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


BeforeStateChanged Event

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.BeforeStateChanged Event
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.BeforeStateChanged"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler<StateChangingEventArgs> BeforeStateChanged
Visual Basic (Declaration)
Event BeforeStateChanged As EventHandler(Of StateChangingEventArgs)
Visual C++
 event EventHandler<StateChangingEventArgs^>^ BeforeStateChanged {
    void add (EventHandler<StateChangingEventArgs^>^ value);
    void remove (EventHandler<StateChangingEventArgs^>^ value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateFinalized Event

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.StateFinalized Event
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.StateFinalized"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler<StateTransitionEventArgs> StateFinalized
Visual Basic (Declaration)
Event StateFinalized As EventHandler(Of StateTransitionEventArgs)
Visual C++
 event EventHandler<StateTransitionEventArgs^>^ StateFinalized {
    void add (EventHandler<StateTransitionEventArgs^>^ value);
    void remove (EventHandler<StateTransitionEventArgs^>^ value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateInitialized Event

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.StateInitialized Event
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.StateInitialized"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler<StateTransitionEventArgs> StateInitialized
Visual Basic (Declaration)
Event StateInitialized As EventHandler(Of StateTransitionEventArgs)
Visual C++
 event EventHandler<StateTransitionEventArgs^>^ StateInitialized {
    void add (EventHandler<StateTransitionEventArgs^>^ value);
    void remove (EventHandler<StateTransitionEventArgs^>^ value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateMachineComplete Event

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.StateMachineComplete Event
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.StateMachineComplete"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler<StateTransitionEventArgs> StateMachineComplete
Visual Basic (Declaration)
Event StateMachineComplete As EventHandler(Of StateTransitionEventArgs)
Visual C++
 event EventHandler<StateTransitionEventArgs^>^ StateMachineComplete {
    void add (EventHandler<StateTransitionEventArgs^>^ value);
    void remove (EventHandler<StateTransitionEventArgs^>^ value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateMachineStarted Event

[image]

Enterprise SDK 8.0 Reference API
IStateMachineContext..::.StateMachineStarted Event
IStateMachineContext Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext.StateMachineStarted"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler<StateTransitionEventArgs> StateMachineStarted
Visual Basic (Declaration)
Event StateMachineStarted As EventHandler(Of StateTransitionEventArgs)
Visual C++
 event EventHandler<StateTransitionEventArgs^>^ StateMachineStarted {
    void add (EventHandler<StateTransitionEventArgs^>^ value);
    void remove (EventHandler<StateTransitionEventArgs^>^ value);
}

See Also

IStateMachineContext Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineEvent Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineEvent : IStateMachineComponent
Visual Basic (Declaration)
Public Interface IStateMachineEvent _
    Implements IStateMachineComponent
Visual C++
public interface class IStateMachineEvent : IStateMachineComponent

See Also

IStateMachineEvent Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent Members
IStateMachineEvent Interface Methods Properties See Also Send Feedback

The IStateMachineEvent type exposes the following members.

Methods

Name | Description
Matches |

Properties

Name | Description
EventIdentifier |
EventName |
StateMachine | (Inherited from IStateMachineComponent.)

See Also

IStateMachineEvent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent Methods
IStateMachineEvent Interface See Also Send Feedback

The IStateMachineEvent type exposes the following members.

Methods

Name | Description
Matches |

See Also

IStateMachineEvent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Matches Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent..::.Matches Method
IStateMachineEvent Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent.Matches(System.Object)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Matches(
    Object eventIdentifier
)
Visual Basic (Declaration)
Function Matches ( _
    eventIdentifier As Object _
) As Boolean
Visual C++
bool Matches(
    Object^ eventIdentifier
)

Parameters

eventIdentifier
Type: System..::.Object

[Missing <param name="eventIdentifier"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent.Matches(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent.Matches(System.Object)"]

See Also

IStateMachineEvent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent Properties
IStateMachineEvent Interface See Also Send Feedback

The IStateMachineEvent type exposes the following members.

Properties

Name | Description
EventIdentifier |
EventName |
StateMachine | (Inherited from IStateMachineComponent.)

See Also

IStateMachineEvent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


EventIdentifier Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent..::.EventIdentifier Property
IStateMachineEvent Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent.EventIdentifier"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object EventIdentifier { get; }
Visual Basic (Declaration)
ReadOnly Property EventIdentifier As Object
Visual C++
property Object^ EventIdentifier {
    Object^ get ();
}

See Also

IStateMachineEvent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


EventName Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineEvent..::.EventName Property
IStateMachineEvent Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent.EventName"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string EventName { get; }
Visual Basic (Declaration)
ReadOnly Property EventName As String
Visual C++
property String^ EventName {
    String^ get ();
}

See Also

IStateMachineEvent Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineService Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineService Interface
Members See Also Send Feedback
State machine repository

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineService
Visual Basic (Declaration)
Public Interface IStateMachineService
Visual C++
public interface class IStateMachineService

See Also

IStateMachineService Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineService Members
IStateMachineService Interface Methods See Also Send Feedback

The IStateMachineService type exposes the following members.

Methods

Name | Description
CreateStateMachine | Creates the obj machine.

See Also

IStateMachineService Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineService Methods
IStateMachineService Interface See Also Send Feedback

The IStateMachineService type exposes the following members.

Methods

Name | Description
CreateStateMachine | Creates the obj machine.

See Also

IStateMachineService Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


CreateStateMachine Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineService..::.CreateStateMachine Method
IStateMachineService Interface See Also Send Feedback
Creates the obj machine.

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachine CreateStateMachine(
    string stateMachineName
)
Visual Basic (Declaration)
Function CreateStateMachine ( _
    stateMachineName As String _
) As IStateMachine
Visual C++
IStateMachine^ CreateStateMachine(
    String^ stateMachineName
)

Parameters

stateMachineName
Type: System..::.String
Name of the obj machine.

Return Value

The obj machine

See Also

IStateMachineService Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineState Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineState Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineState : IStateMachineStateBuilder,
    IStateTransitionActionManager
Visual Basic (Declaration)
Public Interface IStateMachineState _
    Implements IStateMachineStateBuilder, IStateTransitionActionManager
Visual C++
public interface class IStateMachineState : IStateMachineStateBuilder,
    IStateTransitionActionManager

See Also

IStateMachineState Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineState Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineState Members
IStateMachineState Interface Methods Properties See Also Send Feedback

The IStateMachineState type exposes the following members.

Methods

Name | Description
AddNewTransition | (Inherited from IStateMachineStateBuilder.)
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)
Matches |

Properties

Name | Description
StateIdentifier |
StateName |
StateTransitionActions |
Transitions |

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineState Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineState Methods
IStateMachineState Interface See Also Send Feedback

The IStateMachineState type exposes the following members.

Methods

Name | Description
AddNewTransition | (Inherited from IStateMachineStateBuilder.)
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)
Matches |

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Matches Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineState..::.Matches Method
IStateMachineState Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.Matches(System.Object)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Matches(
    Object stateIdentifier
)
Visual Basic (Declaration)
Function Matches ( _
    stateIdentifier As Object _
) As Boolean
Visual C++
bool Matches(
    Object^ stateIdentifier
)

Parameters

stateIdentifier
Type: System..::.Object

[Missing <param name="stateIdentifier"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.Matches(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.Matches(System.Object)"]

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineState Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineState Properties
IStateMachineState Interface See Also Send Feedback

The IStateMachineState type exposes the following members.

Properties

Name | Description
StateIdentifier |
StateName |
StateTransitionActions |
Transitions |

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateIdentifier Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineState..::.StateIdentifier Property
IStateMachineState Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.StateIdentifier"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object StateIdentifier { get; }
Visual Basic (Declaration)
ReadOnly Property StateIdentifier As Object
Visual C++
property Object^ StateIdentifier {
    Object^ get ();
}

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateName Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineState..::.StateName Property
IStateMachineState Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.StateName"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string StateName { get; }
Visual Basic (Declaration)
ReadOnly Property StateName As String
Visual C++
property String^ StateName {
    String^ get ();
}

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateTransitionActions Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineState..::.StateTransitionActions Property
IStateMachineState Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.StateTransitionActions"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateTransitionAction[] StateTransitionActions { get; }
Visual Basic (Declaration)
ReadOnly Property StateTransitionActions As IStateTransitionAction()
Visual C++
property array<IStateTransitionAction^>^ StateTransitionActions {
    array<IStateTransitionAction^>^ get ();
}

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Transitions Property

[image]

Enterprise SDK 8.0 Reference API
IStateMachineState..::.Transitions Property
IStateMachineState Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState.Transitions"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateTransition[] Transitions { get; }
Visual Basic (Declaration)
ReadOnly Property Transitions As IStateTransition()
Visual C++
property array<IStateTransition^>^ Transitions {
    array<IStateTransition^>^ get ();
}

See Also

IStateMachineState Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineStateBuilder Interface

[image]

Enterprise SDK 8.0 Reference API
IStateMachineStateBuilder Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineStateBuilder"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateMachineStateBuilder : IStateTransitionActionManager
Visual Basic (Declaration)
Public Interface IStateMachineStateBuilder _
    Implements IStateTransitionActionManager
Visual C++
public interface class IStateMachineStateBuilder : IStateTransitionActionManager

See Also

IStateMachineStateBuilder Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineStateBuilder Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineStateBuilder Members
IStateMachineStateBuilder Interface Methods See Also Send Feedback

The IStateMachineStateBuilder type exposes the following members.

Methods

Name | Description
AddNewTransition |
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)

See Also

IStateMachineStateBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateMachineStateBuilder Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateMachineStateBuilder Methods
IStateMachineStateBuilder Interface See Also Send Feedback

The IStateMachineStateBuilder type exposes the following members.

Methods

Name | Description
AddNewTransition |
AddNewTransitionAction | (Inherited from IStateTransitionActionManager.)

See Also

IStateMachineStateBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


AddNewTransition Method

[image]

Enterprise SDK 8.0 Reference API
IStateMachineStateBuilder..::.AddNewTransition Method
IStateMachineStateBuilder Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineStateBuilder.AddNewTransition(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateTransition AddNewTransition(
    IStateMachineEvent triggerEvent,
    IStateMachineState targetState
)
Visual Basic (Declaration)
Function AddNewTransition ( _
    triggerEvent As IStateMachineEvent, _
    targetState As IStateMachineState _
) As IStateTransition
Visual C++
IStateTransition^ AddNewTransition(
    IStateMachineEvent^ triggerEvent,
    IStateMachineState^ targetState
)

Parameters

triggerEvent
Type: Genesyslab.Enterprise.Framework.StateMachine..::.IStateMachineEvent

[Missing <param name="triggerEvent"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineStateBuilder.AddNewTransition(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

targetState
Type: Genesyslab.Enterprise.Framework.StateMachine..::.IStateMachineState

[Missing <param name="targetState"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineStateBuilder.AddNewTransition(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateMachineStateBuilder.AddNewTransition(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineEvent,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineState)"]

See Also

IStateMachineStateBuilder Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransition Interface

[image]

Enterprise SDK 8.0 Reference API
IStateTransition Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateTransition : IStateMachineComponent
Visual Basic (Declaration)
Public Interface IStateTransition _
    Implements IStateMachineComponent
Visual C++
public interface class IStateTransition : IStateMachineComponent

See Also

IStateTransition Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransition Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransition Members
IStateTransition Interface Methods Properties See Also Send Feedback

The IStateTransition type exposes the following members.

Methods

Name | Description
Matches |

Properties

Name | Description
ParentState |
StateMachine | (Inherited from IStateMachineComponent.)
TargetState |
TriggerEvent |

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransition Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransition Methods
IStateTransition Interface See Also Send Feedback

The IStateTransition type exposes the following members.

Methods

Name | Description
Matches |

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Matches Method

[image]

Enterprise SDK 8.0 Reference API
IStateTransition..::.Matches Method
IStateTransition Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.Matches(System.Object,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Matches(
    Object eventIdentifier,
    IStateMachineContext context
)
Visual Basic (Declaration)
Function Matches ( _
    eventIdentifier As Object, _
    context As IStateMachineContext _
) As Boolean
Visual C++
bool Matches(
    Object^ eventIdentifier,
    IStateMachineContext^ context
)

Parameters

eventIdentifier
Type: System..::.Object

[Missing <param name="eventIdentifier"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.Matches(System.Object,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext)"]

context
Type: Genesyslab.Enterprise.Framework.StateMachine..::.IStateMachineContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.Matches(System.Object,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.Matches(System.Object,Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext)"]

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransition Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransition Properties
IStateTransition Interface See Also Send Feedback

The IStateTransition type exposes the following members.

Properties

Name | Description
ParentState |
StateMachine | (Inherited from IStateMachineComponent.)
TargetState |
TriggerEvent |

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


ParentState Property

[image]

Enterprise SDK 8.0 Reference API
IStateTransition..::.ParentState Property
IStateTransition Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.ParentState"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineState ParentState { get; }
Visual Basic (Declaration)
ReadOnly Property ParentState As IStateMachineState
Visual C++
property IStateMachineState^ ParentState {
    IStateMachineState^ get ();
}

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


TargetState Property

[image]

Enterprise SDK 8.0 Reference API
IStateTransition..::.TargetState Property
IStateTransition Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.TargetState"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineState TargetState { get; }
Visual Basic (Declaration)
ReadOnly Property TargetState As IStateMachineState
Visual C++
property IStateMachineState^ TargetState {
    IStateMachineState^ get ();
}

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


TriggerEvent Property

[image]

Enterprise SDK 8.0 Reference API
IStateTransition..::.TriggerEvent Property
IStateTransition Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateTransition.TriggerEvent"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineEvent TriggerEvent { get; }
Visual Basic (Declaration)
ReadOnly Property TriggerEvent As IStateMachineEvent
Visual C++
property IStateMachineEvent^ TriggerEvent {
    IStateMachineEvent^ get ();
}

See Also

IStateTransition Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionAction Interface

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateTransitionAction : IStateMachineComponent
Visual Basic (Declaration)
Public Interface IStateTransitionAction _
    Implements IStateMachineComponent
Visual C++
public interface class IStateTransitionAction : IStateMachineComponent

See Also

IStateTransitionAction Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionAction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction Members
IStateTransitionAction Interface Methods Properties See Also Send Feedback

The IStateTransitionAction type exposes the following members.

Methods

Name | Description
Execute |
Matches |

Properties

Name | Description
ActionArgs |
ActionName |
StateMachine | (Inherited from IStateMachineComponent.)
TargetPhase |

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionAction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction Methods
IStateTransitionAction Interface See Also Send Feedback

The IStateTransitionAction type exposes the following members.

Methods

Name | Description
Execute |
Matches |

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Execute Method

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction..::.Execute Method
IStateTransitionAction Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Execute(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineActionContext)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Execute(
    IStateMachineActionContext context
)
Visual Basic (Declaration)
Function Execute ( _
    context As IStateMachineActionContext _
) As Object
Visual C++
Object^ Execute(
    IStateMachineActionContext^ context
)

Parameters

context
Type: IStateMachineActionContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Execute(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineActionContext)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Execute(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineActionContext)"]

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


Matches Method

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction..::.Matches Method
IStateTransitionAction Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Matches(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase)"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Matches(
    IStateMachineContext context,
    StateTransitionPhase phase
)
Visual Basic (Declaration)
Function Matches ( _
    context As IStateMachineContext, _
    phase As StateTransitionPhase _
) As Boolean
Visual C++
bool Matches(
    IStateMachineContext^ context,
    StateTransitionPhase phase
)

Parameters

context
Type: Genesyslab.Enterprise.Framework.StateMachine..::.IStateMachineContext

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Matches(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase)"]

phase
Type: Genesyslab.Enterprise.Framework.StateMachine..::.StateTransitionPhase

[Missing <param name="phase"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Matches(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.Matches(Genesyslab.Enterprise.Framework.StateMachine.IStateMachineContext,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase)"]

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionAction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction Properties
IStateTransitionAction Interface See Also Send Feedback

The IStateTransitionAction type exposes the following members.

Properties

Name | Description
ActionArgs |
ActionName |
StateMachine | (Inherited from IStateMachineComponent.)
TargetPhase |

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


ActionArgs Property

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction..::.ActionArgs Property
IStateTransitionAction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.ActionArgs"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object[] ActionArgs { get; }
Visual Basic (Declaration)
ReadOnly Property ActionArgs As Object()
Visual C++
property array<Object^>^ ActionArgs {
    array<Object^>^ get ();
}

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


ActionName Property

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction..::.ActionName Property
IStateTransitionAction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.ActionName"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ActionName { get; }
Visual Basic (Declaration)
ReadOnly Property ActionName As String
Visual C++
property String^ ActionName {
    String^ get ();
}

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


TargetPhase Property

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionAction..::.TargetPhase Property
IStateTransitionAction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionAction.TargetPhase"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StateTransitionPhase TargetPhase { get; }
Visual Basic (Declaration)
ReadOnly Property TargetPhase As StateTransitionPhase
Visual C++
property StateTransitionPhase TargetPhase {
    StateTransitionPhase get ();
}

See Also

IStateTransitionAction Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionActionManager Interface

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionActionManager Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionActionManager"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStateTransitionActionManager
Visual Basic (Declaration)
Public Interface IStateTransitionActionManager
Visual C++
public interface class IStateTransitionActionManager

See Also

IStateTransitionActionManager Members
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionActionManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransitionActionManager Members
IStateTransitionActionManager Interface Methods See Also Send Feedback

The IStateTransitionActionManager type exposes the following members.

Methods

Name | Description
AddNewTransitionAction |

See Also

IStateTransitionActionManager Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


IStateTransitionActionManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStateTransitionActionManager Methods
IStateTransitionActionManager Interface See Also Send Feedback

The IStateTransitionActionManager type exposes the following members.

Methods

Name | Description
AddNewTransitionAction |

See Also

IStateTransitionActionManager Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


AddNewTransitionAction Method

[image]

Enterprise SDK 8.0 Reference API
IStateTransitionActionManager..::.AddNewTransitionAction Method
IStateTransitionActionManager Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionActionManager.AddNewTransitionAction(System.String,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase,System.Object[])"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateTransitionAction AddNewTransitionAction(
    string actionTaskName,
    StateTransitionPhase targetPhase,
    params Object[] args
)
Visual Basic (Declaration)
Function AddNewTransitionAction ( _
    actionTaskName As String, _
    targetPhase As StateTransitionPhase, _
    ParamArray args As Object() _
) As IStateTransitionAction
Visual C++
IStateTransitionAction^ AddNewTransitionAction(
    String^ actionTaskName,
    StateTransitionPhase targetPhase,
    ... array<Object^>^ args
)

Parameters

actionTaskName
Type: System..::.String

[Missing <param name="actionTaskName"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionActionManager.AddNewTransitionAction(System.String,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase,System.Object[])"]

targetPhase
Type: Genesyslab.Enterprise.Framework.StateMachine..::.StateTransitionPhase

[Missing <param name="targetPhase"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionActionManager.AddNewTransitionAction(System.String,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase,System.Object[])"]

args
Type: array< System..::.Object >[]()[]

[Missing <param name="args"/> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionActionManager.AddNewTransitionAction(System.String,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase,System.Object[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Framework.StateMachine.IStateTransitionActionManager.AddNewTransitionAction(System.String,Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase,System.Object[])"]

See Also

IStateTransitionActionManager Interface
Genesyslab.Enterprise.Framework.StateMachine Namespace


StateTransitionPhase Enumeration

[image]

Enterprise SDK 8.0 Reference API
StateTransitionPhase Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Framework.StateMachine.StateTransitionPhase"]

Namespace: Genesyslab.Enterprise.Framework.StateMachine
Assembly: Genesyslab.Enterprise.Framework.StateMachine (in Genesyslab.Enterprise.Framework.StateMachine.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum StateTransitionPhase
Visual Basic (Declaration)
Public Enumeration StateTransitionPhase
Visual C++
public enum class StateTransitionPhase

Members

Member name | Description
StateInitialization |
StateFinalization |
StateMachineStarting |
StateMachineComplete |
All |

See Also

Genesyslab.Enterprise.Framework.StateMachine Namespace


Genesyslab.Enterprise.Model.Attributes Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Attributes Namespace
Send Feedback

Interfaces

Interface | Description
IEnterpriseAttributeInfo | Information about Enterprise SDK attributes.


IEnterpriseAttributeInfo Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseAttributeInfo Interface
Members See Also Send Feedback
Information about Enterprise SDK attributes.

Namespace: Genesyslab.Enterprise.Model.Attributes
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEnterpriseAttributeInfo
Visual Basic (Declaration)
Public Interface IEnterpriseAttributeInfo
Visual C++
public interface class IEnterpriseAttributeInfo

See Also

IEnterpriseAttributeInfo Members
Genesyslab.Enterprise.Model.Attributes Namespace


IEnterpriseAttributeInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseAttributeInfo Members
IEnterpriseAttributeInfo Interface Properties See Also Send Feedback

The IEnterpriseAttributeInfo type exposes the following members.

Properties

Name | Description
Filter | Filters for this
Uid | The globally unique identifier (GUID).

See Also

IEnterpriseAttributeInfo Interface
Genesyslab.Enterprise.Model.Attributes Namespace


IEnterpriseAttributeInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseAttributeInfo Properties
IEnterpriseAttributeInfo Interface See Also Send Feedback

The IEnterpriseAttributeInfo type exposes the following members.

Properties

Name | Description
Filter | Filters for this
Uid | The globally unique identifier (GUID).

See Also

IEnterpriseAttributeInfo Interface
Genesyslab.Enterprise.Model.Attributes Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseAttributeInfo..::.Filter Property
IEnterpriseAttributeInfo Interface See Also Send Feedback
Filters for this

Namespace: Genesyslab.Enterprise.Model.Attributes
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] Filter { get; }
Visual Basic (Declaration)
ReadOnly Property Filter As String()
Visual C++
property array<String^>^ Filter {
    array<String^>^ get ();
}

See Also

IEnterpriseAttributeInfo Interface
Genesyslab.Enterprise.Model.Attributes Namespace


Uid Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseAttributeInfo..::.Uid Property
IEnterpriseAttributeInfo Interface See Also Send Feedback
The globally unique identifier (GUID).

Namespace: Genesyslab.Enterprise.Model.Attributes
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Guid Uid { get; }
Visual Basic (Declaration)
ReadOnly Property Uid As Guid
Visual C++
property Guid Uid {
    Guid get ();
}

See Also

IEnterpriseAttributeInfo Interface
Genesyslab.Enterprise.Model.Attributes Namespace


Genesyslab.Enterprise.Model.Channel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Channel Namespace
Send Feedback

Interfaces

Interface | Description
IChannelManager | Manages channel information.
IClientChannel | Describes a client channel.
IProtocolConfiguration | Define the configuration of channel.
IProtocolManager | Manages protocol information in the up-level channel.

Enumerations

Enumeration | Description
ChannelModeType | Describes the mode assigned to this channel: primary, backup, or none.


ChannelModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChannelModeType Enumeration
See Also Send Feedback
Describes the mode assigned to this channel: primary, backup, or none.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ChannelModeType
Visual Basic (Declaration)
Public Enumeration ChannelModeType
Visual C++
public enum class ChannelModeType

Members

Member name | Description
None |
Primary |
Backup |

See Also

Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelManager Interface
Members See Also Send Feedback
Manages channel information.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChannelManager : IStrategyManager<IClientChannel>
Visual Basic (Declaration)
Public Interface IChannelManager _
    Implements IStrategyManager(Of IClientChannel)
Visual C++
public interface class IChannelManager : IStrategyManager<IClientChannel^>

See Also

IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager Members
IChannelManager Interface Methods See Also Send Feedback

The IChannelManager type exposes the following members.

Methods

Name | Description
AddChannel | Adds the given channel.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel.
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SendMessage | Sends a message to the given channel.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IChannelManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager Methods
IChannelManager Interface See Also Send Feedback

The IChannelManager type exposes the following members.

Methods

Name | Description
AddChannel | Adds the given channel.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel.
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SendMessage | Sends a message to the given channel.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.AddChannel Method
IChannelManager Interface See Also Send Feedback
Adds the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager AddChannel(
    IClientChannel channel,
    ProtocolConfiguration config
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel, _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ AddChannel(
    IClientChannel^ channel,
    ProtocolConfiguration^ config
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel name.
config
Type: ProtocolConfiguration
Configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
Connect()()() | Connects all the channels. Note: This method is asynchronous.
Connect(IClientChannel) | Connects the given channel. Note: This method is asynchronous.
Connect(Int32) | Connects all the channels. Note: This method is synchronous.
Connect(String) | Connects the given channel. Note: This method is asynchronous.
Connect(IClientChannel, Int32) | Connects the given channel. Note: This method is synchronous.
Connect(String, Int32) | Connects the given channel. Note: This method is synchronous.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method
IChannelManager Interface See Also Send Feedback
Connects all the channels. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Connect()
Visual Basic (Declaration)
Function Connect As IChannelManager
Visual C++
IChannelManager^ Connect()

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (IClientChannel)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Connect(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Connect ( _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (Int32)
IChannelManager Interface See Also Send Feedback
Connects all the channels. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Connect(
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (String)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Connect(
    string channelName
)
Visual Basic (Declaration)
Function Connect ( _
    channelName As String _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (IClientChannel, Int32)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Connect(
    IClientChannel channel,
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    channel As IClientChannel, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    IClientChannel^ channel,
    int milliseconds
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Connect Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Connect Method (String, Int32)
IChannelManager Interface See Also Send Feedback
Connects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Connect(
    string channelName,
    int milliseconds
)
Visual Basic (Declaration)
Function Connect ( _
    channelName As String, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Connect(
    String^ channelName,
    int milliseconds
)

Parameters

channelName
Type: System..::.String
Channel name.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Connect Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
CreateChannel(ProtocolConfiguration) | Obsolete. Creates a channel based on a user configuration instance without a switch abstraction.
CreateChannel(ProtocolConfiguration, SwitchModelType) | Obsolete. Creates a channel based on the given user configuration and switch type.
CreateChannel(ProtocolConfiguration, String) | Obsolete. Creates a channel based on the given configuration instance.
CreateChannel(String, IProtocolConfiguration) | Creates a channel without switch asbtraction capability.
CreateChannel(String, ProtocolConfiguration) | Obsolete. Creates a channel without switch asbtraction capability.
CreateChannel(String, IProtocol) | Creates a channel based on already existing connection
CreateChannel(String, ProtocolConfiguration, SwitchModelType) | Obsolete. Creates a named channel, with the given user configuration and switch abstraction capability.
CreateChannel(String, ProtocolConfiguration, String) | Obsolete. Creates a channel, with the given user configuration and switch abstraction capability.
CreateChannel(String, IProtocol, SwitchModelType) | Obsolete. Creates a channel based on already existing connection and switch type.
CreateChannel(String, IProtocol, String) | Obsolete. Creates a channel based on already existing connection and switch type.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method ()

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method ()
IChannelManager Interface See Also Send Feedback
Creates a channel based on a user configuration instance without a switch abstraction.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IChannelManager CreateChannel(
    ProtocolConfiguration config
)
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Function CreateChannel ( _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config
)

Parameters

config
Type: ProtocolConfiguration
Custom configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (, SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (, SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a channel based on the given user configuration and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IChannelManager CreateChannel(
    ProtocolConfiguration config,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Function CreateChannel ( _
    config As ProtocolConfiguration, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config,
    SwitchModelType switchModel
)

Parameters

config
Type: ProtocolConfiguration
User configuration.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (, String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (, String)
IChannelManager Interface See Also Send Feedback
Creates a channel based on the given configuration instance.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IChannelManager CreateChannel(
    ProtocolConfiguration config,
    string switchType
)
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Function CreateChannel ( _
    config As ProtocolConfiguration, _
    switchType As String _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
IChannelManager^ CreateChannel(
    ProtocolConfiguration^ config,
    String^ switchType
)

Parameters

config
Type: ProtocolConfiguration
Custom configuration instance.
switchType
Type: System..::.String
Switch entry as defined in the Switch Policy Library (SPL). Valid values are :
  • LucentDefinityG3
  • AlcatelA4400DHS3::Classic
  • AlcatelA4400DHS3::Substitute
  • SIPSwitch
  • NortelDMS100
  • NortelMeridianCallCenter

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, IProtocolConfiguration)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, IProtocolConfiguration)
IChannelManager Interface See Also Send Feedback
Creates a channel without switch asbtraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    IProtocolConfiguration protocolConfiguration
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    protocolConfiguration As IProtocolConfiguration _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    IProtocolConfiguration^ protocolConfiguration
)

Parameters

name
Type: System..::.String
Channel name.
protocolConfiguration
Type: Genesyslab.Enterprise.Model.Channel..::.IProtocolConfiguration
User configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, )

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, )
IChannelManager Interface See Also Send Feedback
Creates a channel without switch asbtraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config
)
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config
)

Parameters

name
Type: System..::.String
Channel name.
config
Type: ProtocolConfiguration
User configuration instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, )

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, )
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager CreateChannel(
    string name,
    IProtocol protocol
)
Visual Basic (Declaration)
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol _
) As IChannelManager
Visual C++
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol
)

Parameters

name
Type: System..::.String
the channel name.
protocol
Type: IProtocol
the channel protocol.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a named channel, with the given user configuration and switch abstraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config,
    SwitchModelType switchModel
)

Parameters

name
Type: System..::.String
Channel name.
config
Type: ProtocolConfiguration
Configruation instance.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch model.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , String)
IChannelManager Interface See Also Send Feedback
Creates a channel, with the given user configuration and switch abstraction capability.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IChannelManager CreateChannel(
    string name,
    ProtocolConfiguration config,
    string switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Function CreateChannel ( _
    name As String, _
    config As ProtocolConfiguration, _
    switchModel As String _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
IChannelManager^ CreateChannel(
    String^ name,
    ProtocolConfiguration^ config,
    String^ switchModel
)

Parameters

name
Type: System..::.String
Channel name
config
Type: ProtocolConfiguration
Configruation instance
switchModel
Type: System..::.String
Switch entry as defined in the Switch Policy Library (SPL). Valid values are :
  • LucentDefinityG3
  • AlcatelA4400DHS3::Classic
  • AlcatelA4400DHS3::Substitute
  • SIPSwitch
  • NortelDMS100
  • NortelMeridianCallCenter

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Channel.IChannelManager.CreateChannel(System.String,Genesyslab.Platform.ApplicationBlocks.Commons.Protocols.ProtocolConfiguration,System.String)"]

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , SwitchModelType)
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Will be removed in next release")]
IChannelManager CreateChannel(
    string name,
    IProtocol protocol,
    SwitchModelType switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Will be removed in next release")> _
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol, _
    switchModel As SwitchModelType _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Will be removed in next release")]
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol,
    SwitchModelType switchModel
)

Parameters

name
Type: System..::.String
the channel name.
protocol
Type: IProtocol
the channel protocol.
switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
the model of the switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


CreateChannel Method (String, , String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.CreateChannel Method (String, , String)
IChannelManager Interface See Also Send Feedback
Creates a channel based on already existing connection and switch type.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Will be removed in next release")]
IChannelManager CreateChannel(
    string name,
    IProtocol protocol,
    string switchModel
)
Visual Basic (Declaration)
<ObsoleteAttribute("Will be removed in next release")> _
Function CreateChannel ( _
    name As String, _
    protocol As IProtocol, _
    switchModel As String _
) As IChannelManager
Visual C++
[ObsoleteAttribute(L"Will be removed in next release")]
IChannelManager^ CreateChannel(
    String^ name,
    IProtocol^ protocol,
    String^ switchModel
)

Parameters

name
Type: System..::.String
the channel name.
protocol
Type: IProtocol
the channel protocol.
switchModel
Type: System..::.String
the model of the switch.

Return Value

IChannelManager

See Also

IChannelManager Interface
CreateChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


DeleteChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.DeleteChannel Method
IChannelManager Interface See Also Send Feedback
Deletes the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager DeleteChannel(
    string name
)
Visual Basic (Declaration)
Function DeleteChannel ( _
    name As String _
) As IChannelManager
Visual C++
IChannelManager^ DeleteChannel(
    String^ name
)

Parameters

name
Type: System..::.String
Channel name.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
Disconnect()()() | Disconnects all the channels.
Disconnect(IClientChannel) | Disconnects the given channel instance. Note: This method is asynchronous.
Disconnect(String) | Disconnects the given channel. Note: This method is asynchronous.
Disconnect(IClientChannel, Int32) | Disconnects the given channel. Note: This method is synchronous.
Disconnect(String, Int32) | Disconnects the given channel. Note: This method is synchronous.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method
IChannelManager Interface See Also Send Feedback
Disconnects all the channels.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Disconnect()
Visual Basic (Declaration)
Function Disconnect As IChannelManager
Visual C++
IChannelManager^ Disconnect()

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (IClientChannel)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel instance. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Disconnect(
    IClientChannel channel
)
Visual Basic (Declaration)
Function Disconnect ( _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (String)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Disconnect(
    string channelName
)
Visual Basic (Declaration)
Function Disconnect ( _
    channelName As String _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (IClientChannel, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (IClientChannel, Int32)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Disconnect(
    IClientChannel channel,
    int milliseconds
)
Visual Basic (Declaration)
Function Disconnect ( _
    channel As IClientChannel, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    IClientChannel^ channel,
    int milliseconds
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


Disconnect Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.Disconnect Method (String, Int32)
IChannelManager Interface See Also Send Feedback
Disconnects the given channel. Note: This method is synchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager Disconnect(
    string channelName,
    int milliseconds
)
Visual Basic (Declaration)
Function Disconnect ( _
    channelName As String, _
    milliseconds As Integer _
) As IChannelManager
Visual C++
IChannelManager^ Disconnect(
    String^ channelName,
    int milliseconds
)

Parameters

channelName
Type: System..::.String
Channel name.
milliseconds
Type: System..::.Int32
Maximum time to wait in milliseconds.

Return Value

IChannelManager

See Also

IChannelManager Interface
Disconnect Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
GetChannel(IDevice) | Returns a channel object from a device
GetChannel(String) | Returns a channel object.
GetChannel(Uri) | Returns the channel with the given URI.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (IDevice)
IChannelManager Interface See Also Send Feedback
Returns a channel object from a device

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel GetChannel(
    IDevice device
)
Visual Basic (Declaration)
Function GetChannel ( _
    device As IDevice _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (String)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (String)
IChannelManager Interface See Also Send Feedback
Returns a channel object.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel GetChannel(
    string channel
)
Visual Basic (Declaration)
Function GetChannel ( _
    channel As String _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    String^ channel
)

Parameters

channel
Type: System..::.String
Channel name.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


GetChannel Method (Uri)

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.GetChannel Method (Uri)
IChannelManager Interface See Also Send Feedback
Returns the channel with the given URI.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel GetChannel(
    Uri name
)
Visual Basic (Declaration)
Function GetChannel ( _
    name As Uri _
) As IClientChannel
Visual C++
IClientChannel^ GetChannel(
    Uri^ name
)

Parameters

name
Type: System..::.Uri
URI to retrieve from the service registry.

Return Value

IClientChannel

See Also

IChannelManager Interface
GetChannel Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels Method
IChannelManager Interface See Also Send Feedback

Overload List

Name | Description
ListChannels<(Of <(T>)>)()()() | Lists the channels registered in the service.
ListChannels()()() | Lists all the channels registered in the service.

See Also

IChannelManager Interface
IChannelManager Members
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels(T) Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels<(Of <(T>)>) Method
IChannelManager Interface See Also Send Feedback
Lists the channels registered in the service.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel[] ListChannels<T>()
Visual Basic (Declaration)
Function ListChannels(Of T) As IClientChannel()
Visual C++
generic<typename T>
array<IClientChannel^>^ ListChannels()

Type Parameters

T
Protocol type that is being listed

Return Value

IClientChannel []

See Also

IChannelManager Interface
ListChannels Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListChannels Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListChannels Method
IChannelManager Interface See Also Send Feedback
Lists all the channels registered in the service.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel[] ListChannels()
Visual Basic (Declaration)
Function ListChannels As IClientChannel()
Visual C++
array<IClientChannel^>^ ListChannels()

Return Value

IClientChannel []

See Also

IChannelManager Interface
ListChannels Overload
Genesyslab.Enterprise.Model.Channel Namespace


ListDevices Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.ListDevices Method
IChannelManager Interface See Also Send Feedback
Lists the devices of a specific channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] ListDevices(
    string channelName
)
Visual Basic (Declaration)
Function ListDevices ( _
    channelName As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    String^ channelName
)

Parameters

channelName
Type: System..::.String
Channel name.

Return Value

IDevice[]

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


SendMessage Method

[image]

Enterprise SDK 8.0 Reference API
IChannelManager..::.SendMessage Method
IChannelManager Interface See Also Send Feedback
Sends a message to the given channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager SendMessage(
    IClientChannel channel,
    IMessage msg
)
Visual Basic (Declaration)
Function SendMessage ( _
    channel As IClientChannel, _
    msg As IMessage _
) As IChannelManager
Visual C++
IChannelManager^ SendMessage(
    IClientChannel^ channel,
    IMessage^ msg
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel instance.
msg
Type: IMessage
Message instance.

Return Value

IChannelManager

See Also

IChannelManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Interface

[image]

Enterprise SDK 8.0 Reference API
IClientChannel Interface
Members See Also Send Feedback
Describes a client channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IClientChannel : IShallowCopy<IClientChannel>,
    IDeepCopy<IClientChannel>, IDisposable
Visual Basic (Declaration)
Public Interface IClientChannel _
    Implements IShallowCopy(Of IClientChannel), IDeepCopy(Of IClientChannel),  _
    IDisposable
Visual C++
public interface class IClientChannel : IShallowCopy<IClientChannel^>,
    IDeepCopy<IClientChannel^>, IDisposable

See Also

IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Members

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Members
IClientChannel Interface Methods Properties Events See Also Send Feedback

The IClientChannel type exposes the following members.

Methods

Name | Description
Close | Overloaded.
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Open | Overloaded.
OpenStraightWay |
Send | Sends a request through the communication channel to the connected server. Note: This method is asynchronous Returns a correlation Id when sending is successfull. If not, method returns a negative value
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Endpoint | Get the Channel Endpoint
EnterpriseProtocols | Get access to the Protocol management interface
FQName | Get a Fully Qualified Name (unique ID).
GetProtocolRule | Returns the protocol rule assigned to the channel
IsDisposed | Gets a value indicating whether this instance is disposed.
Mode | Channel Mode.
Name | Get channel Name.
Protocol | Protocol associated with this channel.
RawSubscriber | Retrieve the low level subscriber object
Receiver | Obsolete. Message receiver.
Requests | Returns requests currenlty handled by the channel object
State | Get channel Status.
Strategy | Channel strategies.

Events

Name | Description
Closed | Fired, when channel is closed.
Error | An error has occurred.
Opened | Fired, when channel is opened
SwitchedOver | Fired, when channel is switched over.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Methods
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Methods

Name | Description
Close | Overloaded.
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Open | Overloaded.
OpenStraightWay |
Send | Sends a request through the communication channel to the connected server. Note: This method is asynchronous Returns a correlation Id when sending is successfull. If not, method returns a negative value
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Close Method

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method
IClientChannel Interface See Also Send Feedback

Overload List

Name | Description
Close()()() | Closes the communication channel. Note: This method is asynchronous.
Close(Int32) | Closes the communication channel. Note: This method is synchronous

See Also

IClientChannel Interface
IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


Close Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method
IClientChannel Interface See Also Send Feedback
Closes the communication channel. Note: This method is asynchronous.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Close()
Visual Basic (Declaration)
Sub Close
Visual C++
void Close()

See Also

IClientChannel Interface
Close Overload
Genesyslab.Enterprise.Model.Channel Namespace


Close Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Close Method (Int32)
IClientChannel Interface See Also Send Feedback
Closes the communication channel. Note: This method is synchronous

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Close(
    int milliseconds
)
Visual Basic (Declaration)
Sub Close ( _
    milliseconds As Integer _
)
Visual C++
void Close(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Timeout in milliseconds. Must be greater than 0

See Also

IClientChannel Interface
Close Overload
Genesyslab.Enterprise.Model.Channel Namespace


Open Method

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Open Method
IClientChannel Interface See Also Send Feedback

Overload List

Name | Description
Open()()() | Open channel connection Note: This method is asynchronous. Register to the channel object to be notified of object state change
Open(Int32) | Open channel conenction Note: This method is synchronous

See Also

IClientChannel Interface
IClientChannel Members
Genesyslab.Enterprise.Model.Channel Namespace


Open Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Open Method
IClientChannel Interface See Also Send Feedback
Open channel connection Note: This method is asynchronous. Register to the channel object to be notified of object state change

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Open()
Visual Basic (Declaration)
Sub Open
Visual C++
void Open()

See Also

IClientChannel Interface
Open Overload
Genesyslab.Enterprise.Model.Channel Namespace


Open Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Open Method (Int32)
IClientChannel Interface See Also Send Feedback
Open channel conenction Note: This method is synchronous

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Open(
    int milliseconds
)
Visual Basic (Declaration)
Sub Open ( _
    milliseconds As Integer _
)
Visual C++
void Open(
    int milliseconds
)

Parameters

milliseconds
Type: System..::.Int32
Timeout in milliseconds. Must be greater than 0

See Also

IClientChannel Interface
Open Overload
Genesyslab.Enterprise.Model.Channel Namespace


OpenStraightWay Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.OpenStraightWay Method
IClientChannel Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.Channel.IClientChannel.OpenStraightWay"]

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void OpenStraightWay()
Visual Basic (Declaration)
Sub OpenStraightWay
Visual C++
void OpenStraightWay()

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Send Method

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Send Method
IClientChannel Interface See Also Send Feedback
Sends a request through the communication channel to the connected server. Note: This method is asynchronous Returns a correlation Id when sending is successfull. If not, method returns a negative value

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Send(
    IRequest request
)
Visual Basic (Declaration)
Function Send ( _
    request As IRequest _
) As Integer
Visual C++
int Send(
    IRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRequest
Request to be sent to the back end server

Return Value

int

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Properties
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Properties

Name | Description
Endpoint | Get the Channel Endpoint
EnterpriseProtocols | Get access to the Protocol management interface
FQName | Get a Fully Qualified Name (unique ID).
GetProtocolRule | Returns the protocol rule assigned to the channel
IsDisposed | Gets a value indicating whether this instance is disposed.
Mode | Channel Mode.
Name | Get channel Name.
Protocol | Protocol associated with this channel.
RawSubscriber | Retrieve the low level subscriber object
Receiver | Obsolete. Message receiver.
Requests | Returns requests currenlty handled by the channel object
State | Get channel Status.
Strategy | Channel strategies.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Endpoint Property
IClientChannel Interface See Also Send Feedback
Get the Channel Endpoint

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Uri Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Uri
Visual C++
property Uri^ Endpoint {
    Uri^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


EnterpriseProtocols Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.EnterpriseProtocols Property
IClientChannel Interface See Also Send Feedback
Get access to the Protocol management interface

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolManager EnterpriseProtocols { get; }
Visual Basic (Declaration)
ReadOnly Property EnterpriseProtocols As IProtocolManager
Visual C++
property IProtocolManager^ EnterpriseProtocols {
    IProtocolManager^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.FQName Property
IClientChannel Interface See Also Send Feedback
Get a Fully Qualified Name (unique ID).

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


GetProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.GetProtocolRule Property
IClientChannel Interface See Also Send Feedback
Returns the protocol rule assigned to the channel

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetProtocolRule { get; }
Visual Basic (Declaration)
ReadOnly Property GetProtocolRule As Object
Visual C++
property Object^ GetProtocolRule {
    Object^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IsDisposed Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.IsDisposed Property
IClientChannel Interface See Also Send Feedback
Gets a value indicating whether this instance is disposed.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsDisposed { get; }
Visual Basic (Declaration)
ReadOnly Property IsDisposed As Boolean
Visual C++
property bool IsDisposed {
    bool get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Mode Property
IClientChannel Interface See Also Send Feedback
Channel Mode.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ChannelModeType Mode { get; }
Visual Basic (Declaration)
ReadOnly Property Mode As ChannelModeType
Visual C++
property ChannelModeType Mode {
    ChannelModeType get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Name Property
IClientChannel Interface See Also Send Feedback
Get channel Name.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Protocol Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Protocol Property
IClientChannel Interface See Also Send Feedback
Protocol associated with this channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocol Protocol { get; }
Visual Basic (Declaration)
ReadOnly Property Protocol As IProtocol
Visual C++
property IProtocol^ Protocol {
    IProtocol^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


RawSubscriber Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.RawSubscriber Property
IClientChannel Interface See Also Send Feedback
Retrieve the low level subscriber object

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IServiceSubscriber<IMessage> RawSubscriber { get; }
Visual Basic (Declaration)
ReadOnly Property RawSubscriber As IServiceSubscriber(Of IMessage)
Visual C++
property IServiceSubscriber<IMessage^>^ RawSubscriber {
    IServiceSubscriber<IMessage^>^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Receiver Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Receiver Property
IClientChannel Interface See Also Send Feedback
Message receiver.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.4")]
IMessageReceiver Receiver { get; set; }
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.4")> _
Property Receiver As IMessageReceiver
Visual C++
[ObsoleteAttribute(L"Since 8.1.4")]
property IMessageReceiver^ Receiver {
    IMessageReceiver^ get ();
    void set (IMessageReceiver^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Requests Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Requests Property
IClientChannel Interface See Also Send Feedback
Returns requests currenlty handled by the channel object

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRequestManager Requests { get; }
Visual Basic (Declaration)
ReadOnly Property Requests As IRequestManager
Visual C++
property IRequestManager^ Requests {
    IRequestManager^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.State Property
IClientChannel Interface See Also Send Feedback
Get channel Status.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ChannelState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As ChannelState
Visual C++
property ChannelState State {
    ChannelState get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Strategy Property
IClientChannel Interface See Also Send Feedback
Channel strategies.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IClientChannel Events

[image] [image]

Enterprise SDK 8.0 Reference API
IClientChannel Events
IClientChannel Interface See Also Send Feedback

The IClientChannel type exposes the following members.

Events

Name | Description
Closed | Fired, when channel is closed.
Error | An error has occurred.
Opened | Fired, when channel is opened
SwitchedOver | Fired, when channel is switched over.

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Closed Event

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Closed Event
IClientChannel Interface See Also Send Feedback
Fired, when channel is closed.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler Closed
Visual Basic (Declaration)
Event Closed As EventHandler
Visual C++
 event EventHandler^ Closed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Error Event

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Error Event
IClientChannel Interface See Also Send Feedback
An error has occurred.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler Error
Visual Basic (Declaration)
Event Error As EventHandler
Visual C++
 event EventHandler^ Error {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


Opened Event

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.Opened Event
IClientChannel Interface See Also Send Feedback
Fired, when channel is opened

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler Opened
Visual Basic (Declaration)
Event Opened As EventHandler
Visual C++
 event EventHandler^ Opened {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


SwitchedOver Event

[image]

Enterprise SDK 8.0 Reference API
IClientChannel..::.SwitchedOver Event
IClientChannel Interface See Also Send Feedback
Fired, when channel is switched over.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EventHandler SwitchedOver
Visual Basic (Declaration)
Event SwitchedOver As EventHandler
Visual C++
 event EventHandler^ SwitchedOver {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

See Also

IClientChannel Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolConfiguration Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration Interface
Members See Also Send Feedback
Define the configuration of channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IProtocolConfiguration
Visual Basic (Declaration)
Public Interface IProtocolConfiguration
Visual C++
public interface class IProtocolConfiguration

See Also

IProtocolConfiguration Members
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolConfiguration Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration Members
IProtocolConfiguration Interface Properties See Also Send Feedback

The IProtocolConfiguration type exposes the following members.

Properties

Name | Description
FaultTolerance |
KeyValueConfiguration | Gets or sets the key value configuration.
Name | Gets or sets the name.
ProtocolAssemblyName | Gets or sets the name of the protocol assembly.
ProtocolInformation | Gets or sets the protocol information.
ProtocolType | Gets or sets the type of the protocol.
Uri | Gets or sets the URI of endpoint.
WarmStandbyAttempts | Gets/Sets the number of reconnection attempts for Warm Standby.
WarmStandbySwitchovers | Gets/Sets the number of primary/backup switchovers allowed for Warm Standby. If this parameter is not set, or if it is set to null, then an unlimited number of switchovers are allowed. If this parameter is set to 0 then switchover will not happen.
WarmStandbyTimeout | Gets/Sets the timeout (in milliseconds) between the reconnection attempts for Warm Standby.
WarmStandbyUri | Gets/Sets the standby URI for Warm Standby.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolConfiguration Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration Properties
IProtocolConfiguration Interface See Also Send Feedback

The IProtocolConfiguration type exposes the following members.

Properties

Name | Description
FaultTolerance |
KeyValueConfiguration | Gets or sets the key value configuration.
Name | Gets or sets the name.
ProtocolAssemblyName | Gets or sets the name of the protocol assembly.
ProtocolInformation | Gets or sets the protocol information.
ProtocolType | Gets or sets the type of the protocol.
Uri | Gets or sets the URI of endpoint.
WarmStandbyAttempts | Gets/Sets the number of reconnection attempts for Warm Standby.
WarmStandbySwitchovers | Gets/Sets the number of primary/backup switchovers allowed for Warm Standby. If this parameter is not set, or if it is set to null, then an unlimited number of switchovers are allowed. If this parameter is set to 0 then switchover will not happen.
WarmStandbyTimeout | Gets/Sets the timeout (in milliseconds) between the reconnection attempts for Warm Standby.
WarmStandbyUri | Gets/Sets the standby URI for Warm Standby.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


FaultTolerance Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.FaultTolerance Property
IProtocolConfiguration Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Channel.IProtocolConfiguration.FaultTolerance"]

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<FaultToleranceMode> FaultTolerance { get; set; }
Visual Basic (Declaration)
Property FaultTolerance As Nullable(Of FaultToleranceMode)
Visual C++
property Nullable<FaultToleranceMode> FaultTolerance {
    Nullable<FaultToleranceMode> get ();
    void set (Nullable<FaultToleranceMode> value);
}

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


KeyValueConfiguration Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.KeyValueConfiguration Property
IProtocolConfiguration Interface See Also Send Feedback
Gets or sets the key value configuration.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueConfiguration KeyValueConfiguration { get; set; }
Visual Basic (Declaration)
Property KeyValueConfiguration As KeyValueConfiguration
Visual C++
property KeyValueConfiguration^ KeyValueConfiguration {
    KeyValueConfiguration^ get ();
    void set (KeyValueConfiguration^ value);
}

Field Value

The key value configuration.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.Name Property
IProtocolConfiguration Interface See Also Send Feedback
Gets or sets the name.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Field Value

The name.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


ProtocolAssemblyName Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.ProtocolAssemblyName Property
IProtocolConfiguration Interface See Also Send Feedback
Gets or sets the name of the protocol assembly.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ProtocolAssemblyName { get; set; }
Visual Basic (Declaration)
Property ProtocolAssemblyName As String
Visual C++
property String^ ProtocolAssemblyName {
    String^ get ();
    void set (String^ value);
}

Field Value

The name of the protocol assembly.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


ProtocolInformation Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.ProtocolInformation Property
IProtocolConfiguration Interface See Also Send Feedback
Gets or sets the protocol information.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, Object> ProtocolInformation { get; set; }
Visual Basic (Declaration)
Property ProtocolInformation As IDictionary(Of String, Object)
Visual C++
property IDictionary<String^, Object^>^ ProtocolInformation {
    IDictionary<String^, Object^>^ get ();
    void set (IDictionary<String^, Object^>^ value);
}

Field Value

The protocol information.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


ProtocolType Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.ProtocolType Property
IProtocolConfiguration Interface See Also Send Feedback
Gets or sets the type of the protocol.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ProtocolType { get; set; }
Visual Basic (Declaration)
Property ProtocolType As String
Visual C++
property String^ ProtocolType {
    String^ get ();
    void set (String^ value);
}

Field Value

The type of the protocol.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


Uri Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.Uri Property
IProtocolConfiguration Interface See Also Send Feedback
Gets or sets the URI of endpoint.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Uri Uri { get; set; }
Visual Basic (Declaration)
Property Uri As Uri
Visual C++
property Uri^ Uri {
    Uri^ get ();
    void set (Uri^ value);
}

Field Value

The URI.

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


WarmStandbyAttempts Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.WarmStandbyAttempts Property
IProtocolConfiguration Interface See Also Send Feedback
Gets/Sets the number of reconnection attempts for Warm Standby.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<short> WarmStandbyAttempts { get; set; }
Visual Basic (Declaration)
Property WarmStandbyAttempts As Nullable(Of Short)
Visual C++
property Nullable<short> WarmStandbyAttempts {
    Nullable<short> get ();
    void set (Nullable<short> value);
}

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


WarmStandbySwitchovers Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.WarmStandbySwitchovers Property
IProtocolConfiguration Interface See Also Send Feedback
Gets/Sets the number of primary/backup switchovers allowed for Warm Standby. If this parameter is not set, or if it is set to null, then an unlimited number of switchovers are allowed. If this parameter is set to 0 then switchover will not happen.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<short> WarmStandbySwitchovers { get; set; }
Visual Basic (Declaration)
Property WarmStandbySwitchovers As Nullable(Of Short)
Visual C++
property Nullable<short> WarmStandbySwitchovers {
    Nullable<short> get ();
    void set (Nullable<short> value);
}

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


WarmStandbyTimeout Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.WarmStandbyTimeout Property
IProtocolConfiguration Interface See Also Send Feedback
Gets/Sets the timeout (in milliseconds) between the reconnection attempts for Warm Standby.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> WarmStandbyTimeout { get; set; }
Visual Basic (Declaration)
Property WarmStandbyTimeout As Nullable(Of Integer)
Visual C++
property Nullable<int> WarmStandbyTimeout {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


WarmStandbyUri Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolConfiguration..::.WarmStandbyUri Property
IProtocolConfiguration Interface See Also Send Feedback
Gets/Sets the standby URI for Warm Standby.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Uri WarmStandbyUri { get; set; }
Visual Basic (Declaration)
Property WarmStandbyUri As Uri
Visual C++
property Uri^ WarmStandbyUri {
    Uri^ get ();
    void set (Uri^ value);
}

See Also

IProtocolConfiguration Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager Interface
Members See Also Send Feedback
Manages protocol information in the up-level channel.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IProtocolManager
Visual Basic (Declaration)
Public Interface IProtocolManager
Visual C++
public interface class IProtocolManager

See Also

IProtocolManager Members
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Members
IProtocolManager Interface Methods Properties See Also Send Feedback

The IProtocolManager type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all the registered protocols.
ContainsKey | Returns true if the given protocol name exists.
List | Lists all the registered protocols.
Remove | Removes the given protocol.

Properties

Name | Description
Item | Gets a property according to its key.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Methods
IProtocolManager Interface See Also Send Feedback

The IProtocolManager type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all the registered protocols.
ContainsKey | Returns true if the given protocol name exists.
List | Lists all the registered protocols.
Remove | Removes the given protocol.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method
IProtocolManager Interface See Also Send Feedback

Overload List

Name | Description
Add(String, IEnterpriseProtocol) | Adds the given communication protocol. Note: The protocol's switch policy must match the channel's switch policy.
Add(String, MediaType, IEnumerable<(Of <(IProtocolRequest>)>)) | Adds the given communication protocol using the channel's switch policy.

See Also

IProtocolManager Interface
IProtocolManager Members
Genesyslab.Enterprise.Model.Channel Namespace


Add Method (String, IEnterpriseProtocol)

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method (String, IEnterpriseProtocol)
IProtocolManager Interface See Also Send Feedback
Adds the given communication protocol. Note: The protocol's switch policy must match the channel's switch policy.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Add(
    string name,
    IEnterpriseProtocol protocol
)
Visual Basic (Declaration)
Sub Add ( _
    name As String, _
    protocol As IEnterpriseProtocol _
)
Visual C++
void Add(
    String^ name,
    IEnterpriseProtocol^ protocol
)

Parameters

name
Type: System..::.String
the protocol name.
protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IEnterpriseProtocol
the protocol object.

See Also

IProtocolManager Interface
Add Overload
Genesyslab.Enterprise.Model.Channel Namespace


Add Method (String, MediaType, IEnumerable(IProtocolRequest))

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Add Method (String, MediaType, IEnumerable<(Of <(IProtocolRequest>)>))
IProtocolManager Interface See Also Send Feedback
Adds the given communication protocol using the channel's switch policy.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Add(
    string name,
    MediaType mediaType,
    IEnumerable<IProtocolRequest> listCommands
)
Visual Basic (Declaration)
Sub Add ( _
    name As String, _
    mediaType As MediaType, _
    listCommands As IEnumerable(Of IProtocolRequest) _
)
Visual C++
void Add(
    String^ name,
    MediaType mediaType,
    IEnumerable<IProtocolRequest^>^ listCommands
)

Parameters

name
Type: System..::.String
Protocol name.
mediaType
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaType
Communication type.
listCommands
Type: System.Collections.Generic..::.IEnumerable <(Of <( IProtocolRequest >)>)
Commands.

See Also

IProtocolManager Interface
Add Overload
Genesyslab.Enterprise.Model.Channel Namespace


Clear Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Clear Method
IProtocolManager Interface See Also Send Feedback
Deletes all the registered protocols.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear
Visual C++
void Clear()

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.ContainsKey Method
IProtocolManager Interface See Also Send Feedback
Returns true if the given protocol name exists.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String
the protocol name

Return Value

true if the name is already registered.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


List Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.List Method
IProtocolManager Interface See Also Send Feedback
Lists all the registered protocols.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerator<IEnterpriseProtocol> List()
Visual Basic (Declaration)
Function List As IEnumerator(Of IEnterpriseProtocol)
Visual C++
IEnumerator<IEnterpriseProtocol^>^ List()

Return Value

Collection of protocols.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Remove Method
IProtocolManager Interface See Also Send Feedback
Removes the given protocol.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Remove(
    string key
)
Visual Basic (Declaration)
Function Remove ( _
    key As String _
) As Boolean
Visual C++
bool Remove(
    String^ key
)

Parameters

key
Type: System..::.String
the protocol name

Return Value

true if the protocol is succesfully unregistered.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


IProtocolManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolManager Properties
IProtocolManager Interface See Also Send Feedback

The IProtocolManager type exposes the following members.

Properties

Name | Description
Item | Gets a property according to its key.

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolManager..::.Item Property
IProtocolManager Interface See Also Send Feedback
Gets a property according to its key.

Namespace: Genesyslab.Enterprise.Model.Channel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseProtocol this[
    string name
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As IEnterpriseProtocol
Visual C++
property IEnterpriseProtocol^ default[String^ name] {
    IEnterpriseProtocol^ get (String^ name);
}

Parameters

name
Type: System..::.String

Return Value

See Also

IProtocolManager Interface
Genesyslab.Enterprise.Model.Channel Namespace


Genesyslab.Enterprise.Model.Chat Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Chat Namespace
Send Feedback

Interfaces

Interface | Description
IChatEvent | Describes a chat event, such as changes in the parties and new chat messages.
IChatMessage | The chat message.
IChatParty | Represents a party of the chat interaction (see IChatInteraction).
INewParty | Information about the new party of a chat interaction ([!:IChatInteraction]).
INoticeInfo | Information for the chat notice.
IPartyLeft | Information about the left party of a chat interaction ([!:IChatInteraction]).
IReenterInfo | Information about a party who reenters in the chat interaction.

Enumerations

Enumeration | Description
NoticeType | Enumerates the type of notices.
UserStatus | Status of the reenter message.


IChatEvent Interface

[image]

Enterprise SDK 8.0 Reference API
IChatEvent Interface
Members See Also Send Feedback
Describes a chat event, such as changes in the parties and new chat messages.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChatEvent : IShallowCopy<IChatEvent>,
    IDeepCopy<IChatEvent>
Visual Basic (Declaration)
Public Interface IChatEvent _
    Implements IShallowCopy(Of IChatEvent), IDeepCopy(Of IChatEvent)
Visual C++
public interface class IChatEvent : IShallowCopy<IChatEvent^>,
    IDeepCopy<IChatEvent^>

See Also

IChatEvent Members
Genesyslab.Enterprise.Model.Chat Namespace


IChatEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChatEvent Members
IChatEvent Interface Methods Properties See Also Send Feedback

The IChatEvent type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1
Party | The party associated with the chat event (read only).
TimeShift | The time shift for this event (read only).
UserId | The user of this event (read only).
Visibility | The visibility of the event (read only).

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChatEvent Methods
IChatEvent Interface See Also Send Feedback

The IChatEvent type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChatEvent Properties
IChatEvent Interface See Also Send Feedback

The IChatEvent type exposes the following members.

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1
Party | The party associated with the chat event (read only).
TimeShift | The time shift for this event (read only).
UserId | The user of this event (read only).
Visibility | The visibility of the event (read only).

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


EventId Property

[image]

Enterprise SDK 8.0 Reference API
IChatEvent..::.EventId Property
IChatEvent Interface See Also Send Feedback
Get the corresponding chat Id. From Psdk 8.1

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int EventId { get; }
Visual Basic (Declaration)
ReadOnly Property EventId As Integer
Visual C++
property int EventId {
    int get ();
}

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


Party Property

[image]

Enterprise SDK 8.0 Reference API
IChatEvent..::.Party Property
IChatEvent Interface See Also Send Feedback
The party associated with the chat event (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParty Party { get; }
Visual Basic (Declaration)
ReadOnly Property Party As IParty
Visual C++
property IParty^ Party {
    IParty^ get ();
}

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


TimeShift Property

[image]

Enterprise SDK 8.0 Reference API
IChatEvent..::.TimeShift Property
IChatEvent Interface See Also Send Feedback
The time shift for this event (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TimeShift { get; }
Visual Basic (Declaration)
ReadOnly Property TimeShift As Integer
Visual C++
property int TimeShift {
    int get ();
}

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


UserId Property

[image]

Enterprise SDK 8.0 Reference API
IChatEvent..::.UserId Property
IChatEvent Interface See Also Send Feedback
The user of this event (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string UserId { get; }
Visual Basic (Declaration)
ReadOnly Property UserId As String
Visual C++
property String^ UserId {
    String^ get ();
}

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IChatEvent..::.Visibility Property
IChatEvent Interface See Also Send Feedback
The visibility of the event (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Visibility Visibility { get; }
Visual Basic (Declaration)
ReadOnly Property Visibility As Visibility
Visual C++
property Visibility Visibility {
    Visibility get ();
}

See Also

IChatEvent Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatMessage Interface

[image]

Enterprise SDK 8.0 Reference API
IChatMessage Interface
Members See Also Send Feedback
The chat message.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChatMessage : IChatEvent,
    IShallowCopy<IChatEvent>, IDeepCopy<IChatEvent>
Visual Basic (Declaration)
Public Interface IChatMessage _
    Implements IChatEvent, IShallowCopy(Of IChatEvent),  _
    IDeepCopy(Of IChatEvent)
Visual C++
public interface class IChatMessage : IChatEvent,
    IShallowCopy<IChatEvent^>, IDeepCopy<IChatEvent^>

See Also

IChatMessage Members
Genesyslab.Enterprise.Model.Chat Namespace


IChatMessage Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChatMessage Members
IChatMessage Interface Methods Properties See Also Send Feedback

The IChatMessage type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Encoding |
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageName | The message name (read only).
MessageText | The message text (read only).
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
TreatAs | The type of message (read only).
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatMessage Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChatMessage Methods
IChatMessage Interface See Also Send Feedback

The IChatMessage type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatMessage Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChatMessage Properties
IChatMessage Interface See Also Send Feedback

The IChatMessage type exposes the following members.

Properties

Name | Description
Encoding |
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageName | The message name (read only).
MessageText | The message text (read only).
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
TreatAs | The type of message (read only).
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


Encoding Property

[image]

Enterprise SDK 8.0 Reference API
IChatMessage..::.Encoding Property
IChatMessage Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Chat.IChatMessage.Encoding"]

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
EncodingType Encoding { get; }
Visual Basic (Declaration)
ReadOnly Property Encoding As EncodingType
Visual C++
property EncodingType Encoding {
    EncodingType get ();
}

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


MessageName Property

[image]

Enterprise SDK 8.0 Reference API
IChatMessage..::.MessageName Property
IChatMessage Interface See Also Send Feedback
The message name (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageName { get; }
Visual Basic (Declaration)
ReadOnly Property MessageName As String
Visual C++
property String^ MessageName {
    String^ get ();
}

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


MessageText Property

[image]

Enterprise SDK 8.0 Reference API
IChatMessage..::.MessageText Property
IChatMessage Interface See Also Send Feedback
The message text (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageText { get; }
Visual Basic (Declaration)
ReadOnly Property MessageText As String
Visual C++
property String^ MessageText {
    String^ get ();
}

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


TreatAs Property

[image]

Enterprise SDK 8.0 Reference API
IChatMessage..::.TreatAs Property
IChatMessage Interface See Also Send Feedback
The type of message (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string TreatAs { get; }
Visual Basic (Declaration)
ReadOnly Property TreatAs As String
Visual C++
property String^ TreatAs {
    String^ get ();
}

See Also

IChatMessage Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatParty Interface

[image]

Enterprise SDK 8.0 Reference API
IChatParty Interface
Members See Also Send Feedback
Represents a party of the chat interaction (see IChatInteraction).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChatParty : IChatEvent,
    IShallowCopy<IChatEvent>, IDeepCopy<IChatEvent>, IShallowCopy<IChatParty>,
    IDeepCopy<IChatParty>
Visual Basic (Declaration)
Public Interface IChatParty _
    Implements IChatEvent, IShallowCopy(Of IChatEvent),  _
    IDeepCopy(Of IChatEvent), IShallowCopy(Of IChatParty), IDeepCopy(Of IChatParty)
Visual C++
public interface class IChatParty : IChatEvent,
    IShallowCopy<IChatEvent^>, IDeepCopy<IChatEvent^>, IShallowCopy<IChatParty^>,
    IDeepCopy<IChatParty^>

See Also

IChatParty Members
Genesyslab.Enterprise.Model.Chat Namespace


IChatParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChatParty Members
IChatParty Interface Properties See Also Send Feedback

The IChatParty type exposes the following members.

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
Nickname | Party nickname for the chat interaction.
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
PersonId | The person identifier of this party.
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
Type | Party type for the chat interaction.
UserData | The user data attached to the chat interaction.
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatParty Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChatParty Methods
IChatParty Interface See Also Send Feedback

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


IChatParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChatParty Properties
IChatParty Interface See Also Send Feedback

The IChatParty type exposes the following members.

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
Nickname | Party nickname for the chat interaction.
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
PersonId | The person identifier of this party.
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
Type | Party type for the chat interaction.
UserData | The user data attached to the chat interaction.
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


Nickname Property

[image]

Enterprise SDK 8.0 Reference API
IChatParty..::.Nickname Property
IChatParty Interface See Also Send Feedback
Party nickname for the chat interaction.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Nickname { get; }
Visual Basic (Declaration)
ReadOnly Property Nickname As String
Visual C++
property String^ Nickname {
    String^ get ();
}

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


PersonId Property

[image]

Enterprise SDK 8.0 Reference API
IChatParty..::.PersonId Property
IChatParty Interface See Also Send Feedback
The person identifier of this party.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PersonId { get; }
Visual Basic (Declaration)
ReadOnly Property PersonId As String
Visual C++
property String^ PersonId {
    String^ get ();
}

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
IChatParty..::.Type Property
IChatParty Interface See Also Send Feedback
Party type for the chat interaction.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
PartyType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As PartyType
Visual C++
property PartyType Type {
    PartyType get ();
}

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


UserData Property

[image]

Enterprise SDK 8.0 Reference API
IChatParty..::.UserData Property
IChatParty Interface See Also Send Feedback
The user data attached to the chat interaction.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection UserData { get; }
Visual Basic (Declaration)
ReadOnly Property UserData As KeyValueCollection
Visual C++
property KeyValueCollection^ UserData {
    KeyValueCollection^ get ();
}

See Also

IChatParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


INewParty Interface

[image]

Enterprise SDK 8.0 Reference API
INewParty Interface
Members See Also Send Feedback
Information about the new party of a chat interaction ([!:IChatInteraction]).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface INewParty : IChatParty,
    IChatEvent, IShallowCopy<IChatEvent>, IDeepCopy<IChatEvent>,
    IShallowCopy<IChatParty>, IDeepCopy<IChatParty>
Visual Basic (Declaration)
Public Interface INewParty _
    Implements IChatParty, IChatEvent, IShallowCopy(Of IChatEvent),  _
    IDeepCopy(Of IChatEvent), IShallowCopy(Of IChatParty), IDeepCopy(Of IChatParty)
Visual C++
public interface class INewParty : IChatParty,
    IChatEvent, IShallowCopy<IChatEvent^>, IDeepCopy<IChatEvent^>,
    IShallowCopy<IChatParty^>, IDeepCopy<IChatParty^>

See Also

INewParty Members
Genesyslab.Enterprise.Model.Chat Namespace


INewParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
INewParty Members
INewParty Interface Properties See Also Send Feedback

The INewParty type exposes the following members.

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
Nickname | Party nickname for the chat interaction. (Inherited from IChatParty.)
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
PersonId | The person identifier of this party. (Inherited from IChatParty.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
Type | Party type for the chat interaction. (Inherited from IChatParty.)
UserData | The user data attached to the chat interaction. (Inherited from IChatParty.)
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

INewParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


INewParty Methods

[image] [image]

Enterprise SDK 8.0 Reference API
INewParty Methods
INewParty Interface See Also Send Feedback

See Also

INewParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


INewParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
INewParty Properties
INewParty Interface See Also Send Feedback

The INewParty type exposes the following members.

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
Nickname | Party nickname for the chat interaction. (Inherited from IChatParty.)
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
PersonId | The person identifier of this party. (Inherited from IChatParty.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
Type | Party type for the chat interaction. (Inherited from IChatParty.)
UserData | The user data attached to the chat interaction. (Inherited from IChatParty.)
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

INewParty Interface
Genesyslab.Enterprise.Model.Chat Namespace


INoticeInfo Interface

[image]

Enterprise SDK 8.0 Reference API
INoticeInfo Interface
Members See Also Send Feedback
Information for the chat notice.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface INoticeInfo : IChatEvent,
    IShallowCopy<IChatEvent>, IDeepCopy<IChatEvent>
Visual Basic (Declaration)
Public Interface INoticeInfo _
    Implements IChatEvent, IShallowCopy(Of IChatEvent),  _
    IDeepCopy(Of IChatEvent)
Visual C++
public interface class INoticeInfo : IChatEvent,
    IShallowCopy<IChatEvent^>, IDeepCopy<IChatEvent^>

See Also

INoticeInfo Members
Genesyslab.Enterprise.Model.Chat Namespace


INoticeInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
INoticeInfo Members
INoticeInfo Interface Methods Properties See Also Send Feedback

The INoticeInfo type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageText | The message text (read only).
NoticeText | Returns the text of the notice.
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
TreatAs | Type of the message (read only).
Type | The type of the notice (read only).
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


INoticeInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
INoticeInfo Methods
INoticeInfo Interface See Also Send Feedback

The INoticeInfo type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


INoticeInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
INoticeInfo Properties
INoticeInfo Interface See Also Send Feedback

The INoticeInfo type exposes the following members.

Properties

Name | Description
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageText | The message text (read only).
NoticeText | Returns the text of the notice.
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
TreatAs | Type of the message (read only).
Type | The type of the notice (read only).
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


MessageText Property

[image]

Enterprise SDK 8.0 Reference API
INoticeInfo..::.MessageText Property
INoticeInfo Interface See Also Send Feedback
The message text (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageText { get; }
Visual Basic (Declaration)
ReadOnly Property MessageText As String
Visual C++
property String^ MessageText {
    String^ get ();
}

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


NoticeText Property

[image]

Enterprise SDK 8.0 Reference API
INoticeInfo..::.NoticeText Property
INoticeInfo Interface See Also Send Feedback
Returns the text of the notice.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string NoticeText { get; }
Visual Basic (Declaration)
ReadOnly Property NoticeText As String
Visual C++
property String^ NoticeText {
    String^ get ();
}

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


TreatAs Property

[image]

Enterprise SDK 8.0 Reference API
INoticeInfo..::.TreatAs Property
INoticeInfo Interface See Also Send Feedback
Type of the message (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string TreatAs { get; }
Visual Basic (Declaration)
ReadOnly Property TreatAs As String
Visual C++
property String^ TreatAs {
    String^ get ();
}

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
INoticeInfo..::.Type Property
INoticeInfo Interface See Also Send Feedback
The type of the notice (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
NoticeType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As NoticeType
Visual C++
property NoticeType Type {
    NoticeType get ();
}

See Also

INoticeInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


IPartyLeft Interface

[image]

Enterprise SDK 8.0 Reference API
IPartyLeft Interface
Members See Also Send Feedback
Information about the left party of a chat interaction ([!:IChatInteraction]).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPartyLeft : IChatParty,
    IChatEvent, IShallowCopy<IChatEvent>, IDeepCopy<IChatEvent>,
    IShallowCopy<IChatParty>, IDeepCopy<IChatParty>
Visual Basic (Declaration)
Public Interface IPartyLeft _
    Implements IChatParty, IChatEvent, IShallowCopy(Of IChatEvent),  _
    IDeepCopy(Of IChatEvent), IShallowCopy(Of IChatParty), IDeepCopy(Of IChatParty)
Visual C++
public interface class IPartyLeft : IChatParty,
    IChatEvent, IShallowCopy<IChatEvent^>, IDeepCopy<IChatEvent^>,
    IShallowCopy<IChatParty^>, IDeepCopy<IChatParty^>

See Also

IPartyLeft Members
Genesyslab.Enterprise.Model.Chat Namespace


IPartyLeft Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPartyLeft Members
IPartyLeft Interface Properties See Also Send Feedback

The IPartyLeft type exposes the following members.

Properties

Name | Description
AskerId | The party who left (read only).
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageText | The message text (read only).
Nickname | Party nickname for the chat interaction. (Inherited from IChatParty.)
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
PersonId | The person identifier of this party. (Inherited from IChatParty.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
TreatAs | Returns the type of the message (read only).
Type | Party type for the chat interaction. (Inherited from IChatParty.)
UserData | The user data attached to the chat interaction. (Inherited from IChatParty.)
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IPartyLeft Interface
Genesyslab.Enterprise.Model.Chat Namespace


IPartyLeft Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPartyLeft Methods
IPartyLeft Interface See Also Send Feedback

See Also

IPartyLeft Interface
Genesyslab.Enterprise.Model.Chat Namespace


IPartyLeft Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPartyLeft Properties
IPartyLeft Interface See Also Send Feedback

The IPartyLeft type exposes the following members.

Properties

Name | Description
AskerId | The party who left (read only).
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageText | The message text (read only).
Nickname | Party nickname for the chat interaction. (Inherited from IChatParty.)
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
PersonId | The person identifier of this party. (Inherited from IChatParty.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
TreatAs | Returns the type of the message (read only).
Type | Party type for the chat interaction. (Inherited from IChatParty.)
UserData | The user data attached to the chat interaction. (Inherited from IChatParty.)
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IPartyLeft Interface
Genesyslab.Enterprise.Model.Chat Namespace


AskerId Property

[image]

Enterprise SDK 8.0 Reference API
IPartyLeft..::.AskerId Property
IPartyLeft Interface See Also Send Feedback
The party who left (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AskerId { get; }
Visual Basic (Declaration)
ReadOnly Property AskerId As String
Visual C++
property String^ AskerId {
    String^ get ();
}

See Also

IPartyLeft Interface
Genesyslab.Enterprise.Model.Chat Namespace


MessageText Property

[image]

Enterprise SDK 8.0 Reference API
IPartyLeft..::.MessageText Property
IPartyLeft Interface See Also Send Feedback
The message text (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageText { get; }
Visual Basic (Declaration)
ReadOnly Property MessageText As String
Visual C++
property String^ MessageText {
    String^ get ();
}

See Also

IPartyLeft Interface
Genesyslab.Enterprise.Model.Chat Namespace


TreatAs Property

[image]

Enterprise SDK 8.0 Reference API
IPartyLeft..::.TreatAs Property
IPartyLeft Interface See Also Send Feedback
Returns the type of the message (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string TreatAs { get; }
Visual Basic (Declaration)
ReadOnly Property TreatAs As String
Visual C++
property String^ TreatAs {
    String^ get ();
}

See Also

IPartyLeft Interface
Genesyslab.Enterprise.Model.Chat Namespace


IReenterInfo Interface

[image]

Enterprise SDK 8.0 Reference API
IReenterInfo Interface
Members See Also Send Feedback
Information about a party who reenters in the chat interaction.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IReenterInfo : IChatEvent,
    IShallowCopy<IChatEvent>, IDeepCopy<IChatEvent>
Visual Basic (Declaration)
Public Interface IReenterInfo _
    Implements IChatEvent, IShallowCopy(Of IChatEvent),  _
    IDeepCopy(Of IChatEvent)
Visual C++
public interface class IReenterInfo : IChatEvent,
    IShallowCopy<IChatEvent^>, IDeepCopy<IChatEvent^>

See Also

IReenterInfo Members
Genesyslab.Enterprise.Model.Chat Namespace


IReenterInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
IReenterInfo Members
IReenterInfo Interface Methods Properties See Also Send Feedback

The IReenterInfo type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Agents | The agent status (read only).
Clients | The clients' status (read only).
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageText | The message (read only).
MessageType | The message type (read only).
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


IReenterInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IReenterInfo Methods
IReenterInfo Interface See Also Send Feedback

The IReenterInfo type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


IReenterInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IReenterInfo Properties
IReenterInfo Interface See Also Send Feedback

The IReenterInfo type exposes the following members.

Properties

Name | Description
Agents | The agent status (read only).
Clients | The clients' status (read only).
EventId | Get the corresponding chat Id. From Psdk 8.1 (Inherited from IChatEvent.)
MessageText | The message (read only).
MessageType | The message type (read only).
Party | The party associated with the chat event (read only). (Inherited from IChatEvent.)
TimeShift | The time shift for this event (read only). (Inherited from IChatEvent.)
UserId | The user of this event (read only). (Inherited from IChatEvent.)
Visibility | The visibility of the event (read only). (Inherited from IChatEvent.)

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


Agents Property

[image]

Enterprise SDK 8.0 Reference API
IReenterInfo..::.Agents Property
IReenterInfo Interface See Also Send Feedback
The agent status (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
UserStatus Agents { get; }
Visual Basic (Declaration)
ReadOnly Property Agents As UserStatus
Visual C++
property UserStatus Agents {
    UserStatus get ();
}

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


Clients Property

[image]

Enterprise SDK 8.0 Reference API
IReenterInfo..::.Clients Property
IReenterInfo Interface See Also Send Feedback
The clients' status (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
UserStatus Clients { get; }
Visual Basic (Declaration)
ReadOnly Property Clients As UserStatus
Visual C++
property UserStatus Clients {
    UserStatus get ();
}

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


MessageText Property

[image]

Enterprise SDK 8.0 Reference API
IReenterInfo..::.MessageText Property
IReenterInfo Interface See Also Send Feedback
The message (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageText { get; }
Visual Basic (Declaration)
ReadOnly Property MessageText As String
Visual C++
property String^ MessageText {
    String^ get ();
}

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


MessageType Property

[image]

Enterprise SDK 8.0 Reference API
IReenterInfo..::.MessageType Property
IReenterInfo Interface See Also Send Feedback
The message type (read only).

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageType { get; }
Visual Basic (Declaration)
ReadOnly Property MessageType As String
Visual C++
property String^ MessageType {
    String^ get ();
}

See Also

IReenterInfo Interface
Genesyslab.Enterprise.Model.Chat Namespace


NoticeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
NoticeType Enumeration
See Also Send Feedback
Enumerates the type of notices.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum NoticeType
Visual Basic (Declaration)
Public Enumeration NoticeType
Visual C++
public enum class NoticeType

Members

Member name | Description
None | No type.
PushUrl | Push URL.
TypingStarted | Party is typing.
TypingStopped | Party stops typing.
Custom | Custom type.
UpdateUserData | Update user Data.
SaveTranscript | Save transcript.
Reserved | Reserved.

See Also

Genesyslab.Enterprise.Model.Chat Namespace


UserStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
UserStatus Enumeration
See Also Send Feedback
Status of the reenter message.

Namespace: Genesyslab.Enterprise.Model.Chat
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum UserStatus
Visual Basic (Declaration)
Public Enumeration UserStatus
Visual C++
public enum class UserStatus

Members

Member name | Description
On | Status is on.
Off | Status is off.
Keep | Status is keep.
Unknown | Status is unknown.

See Also

Genesyslab.Enterprise.Model.Chat Namespace


Genesyslab.Enterprise.Model.ComponentModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.ComponentModel Namespace
Send Feedback

Interfaces

Interface | Description
IAttributeService | Interface for getting and setting attributes.
IBrokerFilter | Interface for managing Message Broker filters.
IBrokerManager | Interface for managing publisher/subscriber pattern.
IBrokerManager<(Of <(T>)>) | Interface for managing publisher/subscriber pattern.
IBrokerPublisher | Interface for managing event publisher to subscribers.
IBrokerSubscriber | Interface for managing event subscription.
IBrokerSubscriber<(Of <(T>)>) | Interface for managing event subscription.
ICapability | Interface for managing capability.
ICategoryManager | Interface for managing the categories of data bag.
IConfigurable | Interface for managing object from Configuration Layer.
IContext | Interface for managing context of an object (Party, Channel, DN, etc).
IContextable |
IController | Interface for managing state machine controller pattern.
IDataBag<(Of <(T>)>) | Interface for managing data set.
IDelegateSubscriber<(Of <(T>)>) | Interface for managing Broker subscriber.
IDynamicAttribute | Interface for managing dynamic attributes.
IFilter | Interface for managing Filter for Broker Message.
IPersistable<(Of <(T>)>) | Interface for managing the persistency of objects.
IPredicatable<(Of <(T>)>) | Interface defines contract for using a predicate
IPublishable<(Of <(T>)>) | Interface for publishing typed events to subscribers.
IRequest | Interface for managing request that are sent.
IRequestManager | Interface for managing requests.
IRole | Role interface.
IRoleable | Classes that want to play role should implement this Role based interface
IRoleManager<(Of <(T>)>) | Interface for managing the roles.
IServiceSubscriber | Obsolete.
IServiceSubscriber<(Of <(T>)>) | Interface defines subscriber contract for Publish/Subscribe pattern.
ISubscribeable<(Of <(T>)>) | Defines a subscriber contract for Publish/Subscribe pattern.
ITransformer<(Of <(TTarget, TSource>)>) | Objects transformer.

Enumerations

Enumeration | Description
ItemLocation | Enumerate for location of subscribers.
PartyType | Lists the possible party types.
StateType | Enumerate the state type of ICapability.
Visibility | Lists the possible values for the party's visibility.


IAttributeService Interface

[image]

Enterprise SDK 8.0 Reference API
IAttributeService Interface
Members See Also Send Feedback
Interface for getting and setting attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAttributeService
Visual Basic (Declaration)
Public Interface IAttributeService
Visual C++
public interface class IAttributeService

See Also

IAttributeService Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService Members
IAttributeService Interface Methods See Also Send Feedback

The IAttributeService type exposes the following members.

Methods

Name | Description
GetAttributes | Gets Attributes.
SetAttributes | Overloaded.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IAttributeService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService Methods
IAttributeService Interface See Also Send Feedback

The IAttributeService type exposes the following members.

Methods

Name | Description
GetAttributes | Gets Attributes.
SetAttributes | Overloaded.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetAttributes Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.GetAttributes Method
IAttributeService Interface See Also Send Feedback
Gets Attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDynamicAttribute> GetAttributes(
    string name
)
Visual Basic (Declaration)
Function GetAttributes ( _
    name As String _
) As IDictionary(Of String, IDynamicAttribute)
Visual C++
IDictionary<String^, IDynamicAttribute^>^ GetAttributes(
    String^ name
)

Parameters

name
Type: System..::.String
the key of the attributes.

Return Value

the dictionary of attributes.

See Also

IAttributeService Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method
IAttributeService Interface See Also Send Feedback

Overload List

Name | Description
SetAttributes(String, IDynamicAttribute) | Sets attributes from another IDynamicAttribute instance.
SetAttributes(String, IDictionary<(Of <(String, IDynamicAttribute>)>)) | Sets attributes from a dictionary instance.

See Also

IAttributeService Interface
IAttributeService Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method (String, IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method (String, IDynamicAttribute)
IAttributeService Interface See Also Send Feedback
Sets attributes from another IDynamicAttribute instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeService SetAttributes(
    string name,
    IDynamicAttribute attribute
)
Visual Basic (Declaration)
Function SetAttributes ( _
    name As String, _
    attribute As IDynamicAttribute _
) As IAttributeService
Visual C++
IAttributeService^ SetAttributes(
    String^ name,
    IDynamicAttribute^ attribute
)

Parameters

name
Type: System..::.String
the key of the dynamic attribute.
attribute
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the dynamic attribute value.

Return Value

IAttributeService.

See Also

IAttributeService Interface
SetAttributes Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


SetAttributes Method (String, IDictionary(String, IDynamicAttribute))

[image]

Enterprise SDK 8.0 Reference API
IAttributeService..::.SetAttributes Method (String, IDictionary<(Of <(String, IDynamicAttribute>)>))
IAttributeService Interface See Also Send Feedback
Sets attributes from a dictionary instance.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeService SetAttributes(
    string name,
    IDictionary<string, IDynamicAttribute> attributes
)
Visual Basic (Declaration)
Function SetAttributes ( _
    name As String, _
    attributes As IDictionary(Of String, IDynamicAttribute) _
) As IAttributeService
Visual C++
IAttributeService^ SetAttributes(
    String^ name,
    IDictionary<String^, IDynamicAttribute^>^ attributes
)

Parameters

name
Type: System..::.String
the key of the attributes.
attributes
Type: System.Collections.Generic..::.IDictionary <(Of <( String, IDynamicAttribute >)>)
the dictionary of attributes values.

Return Value

IAttributeService.

See Also

IAttributeService Interface
SetAttributes Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Interface
Members See Also Send Feedback
Interface for managing Message Broker filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IBrokerFilter
Visual Basic (Declaration)
Public Interface IBrokerFilter
Visual C++
public interface class IBrokerFilter

See Also

IBrokerFilter Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Members
IBrokerFilter Interface Methods See Also Send Feedback

The IBrokerFilter type exposes the following members.

Methods

Name | Description
Filters<(Of <(T>)>) | Gets the Collection of Message Broker Filters.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerFilter Methods
IBrokerFilter Interface See Also Send Feedback

The IBrokerFilter type exposes the following members.

Methods

Name | Description
Filters<(Of <(T>)>) | Gets the Collection of Message Broker Filters.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filters(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerFilter..::.Filters<(Of <(T>)>) Method
IBrokerFilter Interface See Also Send Feedback
Gets the Collection of Message Broker Filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<T> Filters<T>()
Visual Basic (Declaration)
Function Filters(Of T) As ICollection(Of T)
Visual C++
generic<typename T>
ICollection<T>^ Filters()

Type Parameters

T
the object type to filter.

Return Value

the filter collection for the object type.

See Also

IBrokerFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager Interface
Members See Also Send Feedback
Interface for managing publisher/subscriber pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IBrokerManager : IServiceSubscriber,
    IBrokerSubscriber, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Interface IBrokerManager _
    Implements IServiceSubscriber, IBrokerSubscriber, IBrokerPublisher, IDisposable
Visual C++
public interface class IBrokerManager : IServiceSubscriber,
    IBrokerSubscriber, IBrokerPublisher, IDisposable

See Also

IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Members
IBrokerManager Interface Methods Properties See Also Send Feedback

The IBrokerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber<(Of <(T>)>) | Gets the subscription service.
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object. (Inherited from IBrokerSubscriber.)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Methods
IBrokerManager Interface See Also Send Feedback

The IBrokerManager type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber<(Of <(T>)>) | Gets the subscription service.
Unregister | Overloaded.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber.)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(T) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList<(Of <(T>)>) Method (ItemLocation)
IBrokerManager Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> GetList<T>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of T) ( _
    flag As ItemLocation _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

T
the subscriber type.

Return Value

the enumeration.

See Also

IBrokerManager Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.GetList Method (Type, ItemLocation)
IBrokerManager Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the subscriber type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

Implements

IBrokerSubscriber..::.GetList(Type, ItemLocation)

See Also

IBrokerManager Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Register Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Register<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing (Inherited from IServiceSubscriber.)
Register<(Of <(T>)>)(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs (Inherited from IServiceSubscriber.)
Register<(Of <(T>)>)(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events (Inherited from IServiceSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Subscriber<(Of <(T>)>) Method
IBrokerManager Interface See Also Send Feedback
Gets the subscription service.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IServiceSubscriber Subscriber<T>()
Visual Basic (Declaration)
Function Subscriber(Of T) As IServiceSubscriber
Visual C++
generic<typename T>
IServiceSubscriber^ Subscriber()

Type Parameters

T
the subscriber type.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager.Subscriber``1"]

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Unregister Method
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Unregister<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities (Inherited from IServiceSubscriber.)
Unregister<(Of <(T>)>)(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events (Inherited from IServiceSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager Properties
IBrokerManager Interface See Also Send Feedback

The IBrokerManager type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object. (Inherited from IBrokerSubscriber.)
Parent | Gets and sets the parent of the Broker Manager.

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.BrokerType Property
IBrokerManager Interface See Also Send Feedback
Gets the type of broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type BrokerType { get; }
Visual Basic (Declaration)
ReadOnly Property BrokerType As Type
Visual C++
property Type^ BrokerType {
    Type^ get ();
}

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Count Property
IBrokerManager Interface See Also Send Feedback

Overload List

Name | Description
Count | Gets the number of subscribers.
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber.)

See Also

IBrokerManager Interface
IBrokerManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Count Property
IBrokerManager Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

Implements

IBrokerSubscriber..::.Count

See Also

IBrokerManager Interface
Count Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager..::.Parent Property
IBrokerManager Interface See Also Send Feedback
Gets and sets the parent of the Broker Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IBrokerManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing publisher/subscriber pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IBrokerManager<T> : IServiceSubscriber<T>,
    IBrokerSubscriber<T>, IBrokerPublisher, IDisposable
Visual Basic (Declaration)
Public Interface IBrokerManager(Of T) _
    Implements IServiceSubscriber(Of T), IBrokerSubscriber(Of T),  _
    IBrokerPublisher, IDisposable
Visual C++
generic<typename T>
public interface class IBrokerManager : IServiceSubscriber<T>,
    IBrokerSubscriber<T>, IBrokerPublisher, IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IBrokerManager`1"]

See Also

IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Members
IBrokerManager<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber | Gets the subscription service.
Unregister | Overloaded.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Parent | Gets and sets the parent of the Broker Manager.
SubscriptionBroker | Get raw subscriber (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Methods
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
GetList | Overloaded.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Register | Overloaded.
Subscriber | Gets the subscription service.
Unregister | Overloaded.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
generic<typename U>
IEnumerable<U>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

U
the subscriber type.

Return Value

the enumeration.

See Also

IBrokerManager<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the subscriber type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

Implements

IBrokerSubscriber<(Of <(T>)>)..::.GetList(Type, ItemLocation)

See Also

IBrokerManager<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Register Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing (Inherited from IServiceSubscriber<(Of <(T>)>).)
Register(Action<(Of <(T>)>)) | Registers an action to be performed when a publishing event occurs (Inherited from IServiceSubscriber<(Of <(T>)>).)
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Subscriber Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Subscriber Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the subscription service.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IServiceSubscriber<T> Subscriber()
Visual Basic (Declaration)
Function Subscriber As IServiceSubscriber(Of T)
Visual C++
IServiceSubscriber<T>^ Subscriber()

Return Value

The IServiceSubscriber.

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Unregister Method
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities (Inherited from IServiceSubscriber<(Of <(T>)>).)
Unregister(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>) Properties
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
BrokerType | Gets the type of broker.
Count | Overloaded.
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Parent | Gets and sets the parent of the Broker Manager.
SubscriptionBroker | Get raw subscriber (Inherited from IServiceSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


BrokerType Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.BrokerType Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the type of broker.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type BrokerType { get; }
Visual Basic (Declaration)
ReadOnly Property BrokerType As Type
Visual C++
property Type^ BrokerType {
    Type^ get ();
}

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Count Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Count | Gets the number of subscribers.
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IBrokerManager<(Of <(T>)>) Interface
IBrokerManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Count Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

Implements

IBrokerSubscriber<(Of <(T>)>)..::.Count

See Also

IBrokerManager<(Of <(T>)>) Interface
Count Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerManager<(Of <(T>)>)..::.Parent Property
IBrokerManager<(Of <(T>)>) Interface See Also Send Feedback
Gets and sets the parent of the Broker Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IBrokerManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Interface
Members See Also Send Feedback
Interface for managing event publisher to subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IBrokerPublisher
Visual Basic (Declaration)
Public Interface IBrokerPublisher
Visual C++
public interface class IBrokerPublisher

See Also

IBrokerPublisher Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Members
IBrokerPublisher Interface Methods See Also Send Feedback

The IBrokerPublisher type exposes the following members.

Methods

Name | Description
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerPublisher Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher Methods
IBrokerPublisher Interface See Also Send Feedback

The IBrokerPublisher type exposes the following members.

Methods

Name | Description
Publish<(Of <(T>)>) | Publishes an object to listening subscribers.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish(T) Method

[image]

Enterprise SDK 8.0 Reference API
IBrokerPublisher..::.Publish<(Of <(T>)>) Method
IBrokerPublisher Interface See Also Send Feedback
Publishes an object to listening subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IBrokerPublisher Publish<T>(
    T obj
)
Visual Basic (Declaration)
Function Publish(Of T) ( _
    obj As T _
) As IBrokerPublisher
Visual C++
generic<typename T>
IBrokerPublisher^ Publish(
    T obj
)

Parameters

obj
Type: T
the object instance.

Type Parameters

T
the object type.

Return Value

IBrokerPublisher.

See Also

IBrokerPublisher Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Interface
Members See Also Send Feedback
Interface for managing event subscription.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IBrokerSubscriber
Visual Basic (Declaration)
Public Interface IBrokerSubscriber
Visual C++
public interface class IBrokerSubscriber

See Also

IBrokerSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Members
IBrokerSubscriber Interface Methods Properties See Also Send Feedback

The IBrokerSubscriber type exposes the following members.

Methods

Name | Description
GetList | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Methods
IBrokerSubscriber Interface See Also Send Feedback

Methods

Name | Description
GetList | Overloaded.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList Method
IBrokerSubscriber Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(T>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.

See Also

IBrokerSubscriber Interface
IBrokerSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(T) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList<(Of <(T>)>) Method (ItemLocation)
IBrokerSubscriber Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> GetList<T>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of T) ( _
    flag As ItemLocation _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

T
the object type.

Return Value

the enumeration.

See Also

IBrokerSubscriber Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.GetList Method (Type, ItemLocation)
IBrokerSubscriber Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the object type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

See Also

IBrokerSubscriber Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber Properties
IBrokerSubscriber Interface See Also Send Feedback

The IBrokerSubscriber type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object.

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.Count Property
IBrokerSubscriber Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber..::.EventSubscription Property
IBrokerSubscriber Interface See Also Send Feedback
Gets the subscriber object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IServiceSubscriber EventSubscription { get; }
Visual Basic (Declaration)
ReadOnly Property EventSubscription As IServiceSubscriber
Visual C++
property IServiceSubscriber^ EventSubscription {
    IServiceSubscriber^ get ();
}

See Also

IBrokerSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing event subscription.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IBrokerSubscriber<T>
Visual Basic (Declaration)
Public Interface IBrokerSubscriber(Of T)
Visual C++
generic<typename T>
public interface class IBrokerSubscriber

Type Parameters

T
the subscriber object type.

See Also

IBrokerSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Members
IBrokerSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IBrokerSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetList | Overloaded.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object of type T.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Methods
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
GetList | Overloaded.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList Method
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag.
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
IBrokerSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList(U) Method (ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList<(Of <(U>)>) Method (ItemLocation)
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<U> GetList<U>(
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList(Of U) ( _
    flag As ItemLocation _
) As IEnumerable(Of U)
Visual C++
generic<typename U>
IEnumerable<U>^ GetList(
    ItemLocation flag
)

Parameters

flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Type Parameters

U
the object type.

Return Value

the enumeration.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetList Method (Type, ItemLocation)

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.GetList Method (Type, ItemLocation)
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of subscribers according to target and location flag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable GetList(
    Type targetObject,
    ItemLocation flag
)
Visual Basic (Declaration)
Function GetList ( _
    targetObject As Type, _
    flag As ItemLocation _
) As IEnumerable
Visual C++
IEnumerable^ GetList(
    Type^ targetObject,
    ItemLocation flag
)

Parameters

targetObject
Type: System..::.Type
the object type.
flag
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ItemLocation
the item location flag.

Return Value

the enumeration.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
GetList Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IBrokerSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>) Properties
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IBrokerSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers.
EventSubscription | Gets the subscriber object of type T.

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.Count Property
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the number of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


EventSubscription Property

[image]

Enterprise SDK 8.0 Reference API
IBrokerSubscriber<(Of <(T>)>)..::.EventSubscription Property
IBrokerSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the subscriber object of type T.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IServiceSubscriber<T> EventSubscription { get; }
Visual Basic (Declaration)
ReadOnly Property EventSubscription As IServiceSubscriber(Of T)
Visual C++
property IServiceSubscriber<T>^ EventSubscription {
    IServiceSubscriber<T>^ get ();
}

See Also

IBrokerSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Interface

[image]

Enterprise SDK 8.0 Reference API
ICapability Interface
Members See Also Send Feedback
Interface for managing capability.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICapability
Visual Basic (Declaration)
Public Interface ICapability
Visual C++
public interface class ICapability

See Also

ICapability Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICapability Members
ICapability Interface Properties See Also Send Feedback

The ICapability type exposes the following members.

Properties

Name | Description
Description | Get capability description
Name | Get capability name
State | Get or set capability state : Inactive, , Disabled or Enabled
Value | Get or set task value (task is ON or OFF)

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICapability Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICapability Properties
ICapability Interface See Also Send Feedback

The ICapability type exposes the following members.

Properties

Name | Description
Description | Get capability description
Name | Get capability name
State | Get or set capability state : Inactive, , Disabled or Enabled
Value | Get or set task value (task is ON or OFF)

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Description Property
ICapability Interface See Also Send Feedback
Get capability description

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Name Property
ICapability Interface See Also Send Feedback
Get capability name

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.State Property
ICapability Interface See Also Send Feedback
Get or set capability state : Inactive, , Disabled or Enabled

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StateType State { get; set; }
Visual Basic (Declaration)
Property State As StateType
Visual C++
property StateType State {
    StateType get ();
    void set (StateType value);
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
ICapability..::.Value Property
ICapability Interface See Also Send Feedback
Get or set task value (task is ON or OFF)

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Value { get; set; }
Visual Basic (Declaration)
Property Value As Boolean
Visual C++
property bool Value {
    bool get ();
    void set (bool value);
}

See Also

ICapability Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Interface

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager Interface
Members See Also Send Feedback
Interface for managing the categories of data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICategoryManager
Visual Basic (Declaration)
Public Interface ICategoryManager
Visual C++
public interface class ICategoryManager

See Also

ICategoryManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Members
ICategoryManager Interface Methods Properties See Also Send Feedback

The ICategoryManager type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag.
RemoveCategory | Removes a category in a data bag.

Properties

Name | Description
ListCategories | Gets the list of categories in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Methods
ICategoryManager Interface See Also Send Feedback

The ICategoryManager type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag.
RemoveCategory | Removes a category in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


CreateCategory Method

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.CreateCategory Method
ICategoryManager Interface See Also Send Feedback
Creates a category in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool CreateCategory(
    string section,
    string category
)
Visual Basic (Declaration)
Function CreateCategory ( _
    section As String, _
    category As String _
) As Boolean
Visual C++
bool CreateCategory(
    String^ section,
    String^ category
)

Parameters

section
Type: System..::.String
the section of the category.
category
Type: System..::.String
the category name.

Return Value

true if operation is successful.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RemoveCategory Method

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.RemoveCategory Method
ICategoryManager Interface See Also Send Feedback
Removes a category in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool RemoveCategory(
    string section
)
Visual Basic (Declaration)
Function RemoveCategory ( _
    section As String _
) As Boolean
Visual C++
bool RemoveCategory(
    String^ section
)

Parameters

section
Type: System..::.String
the section of the category.

Return Value

true if operation is successful.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ICategoryManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICategoryManager Properties
ICategoryManager Interface See Also Send Feedback

The ICategoryManager type exposes the following members.

Properties

Name | Description
ListCategories | Gets the list of categories in a data bag.

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListCategories Property

[image]

Enterprise SDK 8.0 Reference API
ICategoryManager..::.ListCategories Property
ICategoryManager Interface See Also Send Feedback
Gets the list of categories in a data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable ListCategories { get; }
Visual Basic (Declaration)
ReadOnly Property ListCategories As IEnumerable
Visual C++
property IEnumerable^ ListCategories {
    IEnumerable^ get ();
}

See Also

ICategoryManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IConfigurable Interface

[image]

Enterprise SDK 8.0 Reference API
IConfigurable Interface
Members See Also Send Feedback
Interface for managing object from Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IConfigurable
Visual Basic (Declaration)
Public Interface IConfigurable
Visual C++
public interface class IConfigurable

See Also

IConfigurable Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IConfigurable Members

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurable Members
IConfigurable Interface Methods See Also Send Feedback

The IConfigurable type exposes the following members.

Methods

Name Description
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.

See Also

IConfigurable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IConfigurable Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IConfigurable Methods
IConfigurable Interface See Also Send Feedback

The IConfigurable type exposes the following members.

Methods

Name Description
Exists
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.

See Also

IConfigurable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Exists Method

[image]

Enterprise SDK 8.0 Reference API
IConfigurable..::.Exists Method
IConfigurable Interface See Also Send Feedback
Returns
CopyC#
true
 if this object really exists in the Configuration Layer. When this method returns
CopyC#
false
, it means that the object has been deleted in the Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Exists()
Visual Basic (Declaration)
Function Exists As Boolean
Visual C++
bool Exists()

Return Value

true if object exists in Configuration Layer.

See Also

IConfigurable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Interface

[image]

Enterprise SDK 8.0 Reference API
IContext Interface
Members See Also Send Feedback
Interface for managing context of an object (Party, Channel, DN, etc).

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContext
Visual Basic (Declaration)
Public Interface IContext
Visual C++
public interface class IContext

See Also

IContext Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContext Members
IContext Interface Properties See Also Send Feedback

The IContext type exposes the following members.

Properties

Name | Description
Application | Gets the name of the application.
Description | Gets the description of the context.
Location | Gets the name of the Location.

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContext Properties
IContext Interface See Also Send Feedback

The IContext type exposes the following members.

Properties

Name | Description
Application | Gets the name of the application.
Description | Gets the description of the context.
Location | Gets the name of the Location.

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Application Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Application Property
IContext Interface See Also Send Feedback
Gets the name of the application.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Application { get; }
Visual Basic (Declaration)
ReadOnly Property Application As String
Visual C++
property String^ Application {
    String^ get ();
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Description Property
IContext Interface See Also Send Feedback
Gets the description of the context.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Location Property

[image]

Enterprise SDK 8.0 Reference API
IContext..::.Location Property
IContext Interface See Also Send Feedback
Gets the name of the Location.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Location { get; }
Visual Basic (Declaration)
ReadOnly Property Location As String
Visual C++
property String^ Location {
    String^ get ();
}

See Also

IContext Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContextable Interface

[image]

Enterprise SDK 8.0 Reference API
IContextable Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IContextable"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContextable
Visual Basic (Declaration)
Public Interface IContextable
Visual C++
public interface class IContextable

See Also

IContextable Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContextable Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContextable Members
IContextable Interface Properties See Also Send Feedback

The IContextable type exposes the following members.

Properties

Name | Description
ClientId |
Context |
SupervisorClientId |

See Also

IContextable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IContextable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContextable Properties
IContextable Interface See Also Send Feedback

The IContextable type exposes the following members.

Properties

Name | Description
ClientId |
Context |
SupervisorClientId |

See Also

IContextable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ClientId Property

[image]

Enterprise SDK 8.0 Reference API
IContextable..::.ClientId Property
IContextable Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.IContextable.ClientId"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ClientId { get; set; }
Visual Basic (Declaration)
Property ClientId As Integer
Visual C++
property int ClientId {
    int get ();
    void set (int value);
}

See Also

IContextable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Context Property

[image]

Enterprise SDK 8.0 Reference API
IContextable..::.Context Property
IContextable Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.IContextable.Context"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContext Context { get; set; }
Visual Basic (Declaration)
Property Context As IContext
Visual C++
property IContext^ Context {
    IContext^ get ();
    void set (IContext^ value);
}

See Also

IContextable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SupervisorClientId Property

[image]

Enterprise SDK 8.0 Reference API
IContextable..::.SupervisorClientId Property
IContextable Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.IContextable.SupervisorClientId"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int SupervisorClientId { get; set; }
Visual Basic (Declaration)
Property SupervisorClientId As Integer
Visual C++
property int SupervisorClientId {
    int get ();
    void set (int value);
}

See Also

IContextable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Interface

[image]

Enterprise SDK 8.0 Reference API
IController Interface
Members See Also Send Feedback
Interface for managing state machine controller pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IController
Visual Basic (Declaration)
Public Interface IController
Visual C++
public interface class IController

See Also

IController Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Members

[image] [image]

Enterprise SDK 8.0 Reference API
IController Members
IController Interface Methods Properties See Also Send Feedback

The IController type exposes the following members.

Methods

Name | Description
HandleEvent | Calls the state machine with an event transition for changing the state.

Properties

Name | Description
State | Gets the state machine of this controller.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IController Methods
IController Interface See Also Send Feedback

The IController type exposes the following members.

Methods

Name | Description
HandleEvent | Calls the state machine with an event transition for changing the state.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


HandleEvent Method

[image]

Enterprise SDK 8.0 Reference API
IController..::.HandleEvent Method
IController Interface See Also Send Feedback
Calls the state machine with an event transition for changing the state.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ControllerResponse HandleEvent(
    string eventName
)
Visual Basic (Declaration)
Function HandleEvent ( _
    eventName As String _
) As ControllerResponse
Visual C++
ControllerResponse HandleEvent(
    String^ eventName
)

Parameters

eventName
Type: System..::.String
the event name.

Return Value

the ControllerResponse.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IController Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IController Properties
IController Interface See Also Send Feedback

The IController type exposes the following members.

Properties

Name | Description
State | Gets the state machine of this controller.

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IController..::.State Property
IController Interface See Also Send Feedback
Gets the state machine of this controller.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStateMachineState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As IStateMachineState
Visual C++
property IStateMachineState^ State {
    IStateMachineState^ get ();
}

See Also

IController Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing data set.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDataBag<T> : ICategoryManager
Visual Basic (Declaration)
Public Interface IDataBag(Of T) _
    Implements ICategoryManager
Visual C++
generic<typename T>
public interface class IDataBag : ICategoryManager

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IDataBag`1"]

See Also

IDataBag<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Members
IDataBag<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag. (Inherited from ICategoryManager.)
RemoveCategory | Removes a category in a data bag. (Inherited from ICategoryManager.)

Properties

Name | Description
Item | Gets or Sets the value for a section.
ListCategories | Gets the list of categories in a data bag. (Inherited from ICategoryManager.)
ListSections | Gets the list of section of this data bag.
Owner | Gets the owner instance (any instance of any class) of this data.

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Methods
IDataBag<(Of <(T>)>) Interface See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
CreateCategory | Creates a category in a data bag. (Inherited from ICategoryManager.)
RemoveCategory | Removes a category in a data bag. (Inherited from ICategoryManager.)

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDataBag(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>) Properties
IDataBag<(Of <(T>)>) Interface See Also Send Feedback

The IDataBag<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Item | Gets or Sets the value for a section.
ListCategories | Gets the list of categories in a data bag. (Inherited from ICategoryManager.)
ListSections | Gets the list of section of this data bag.
Owner | Gets the owner instance (any instance of any class) of this data.

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.Item Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets or Sets the value for a section.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T this[
    string section
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    section As String _
) As T
Visual C++
property T default[String^ section] {
    T get (String^ section);
    void set (String^ section, T value);
}

Parameters

section
Type: System..::.String
the section name.

Return Value

the value

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListSections Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.ListSections Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of section of this data bag.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] ListSections { get; }
Visual Basic (Declaration)
ReadOnly Property ListSections As String()
Visual C++
property array<String^>^ ListSections {
    array<String^>^ get ();
}

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IDataBag<(Of <(T>)>)..::.Owner Property
IDataBag<(Of <(T>)>) Interface See Also Send Feedback
Gets the owner instance (any instance of any class) of this data.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As Object
Visual C++
property Object^ Owner {
    Object^ get ();
}

See Also

IDataBag<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing Broker subscriber.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDelegateSubscriber<T> : ISubscriber<T>
Visual Basic (Declaration)
Public Interface IDelegateSubscriber(Of T) _
    Implements ISubscriber(Of T)
Visual C++
generic<typename T>
public interface class IDelegateSubscriber : ISubscriber<T>

Type Parameters

T
The subscriber object type.

See Also

IDelegateSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Members
IDelegateSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | (Inherited from ISubscriber<(Of <( T >)>).)

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( T >)>).)
Handler | Gets the handler that manages event.

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Methods
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | (Inherited from ISubscriber<(Of <( T >)>).)

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDelegateSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>) Properties
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IDelegateSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Filter | (Inherited from ISubscriber<(Of <( T >)>).)
Handler | Gets the handler that manages event.

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handler Property

[image]

Enterprise SDK 8.0 Reference API
IDelegateSubscriber<(Of <(T>)>)..::.Handler Property
IDelegateSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Gets the handler that manages event.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Action<T> Handler { get; }
Visual Basic (Declaration)
ReadOnly Property Handler As Action(Of T)
Visual C++
property Action<T>^ Handler {
    Action<T>^ get ();
}

See Also

IDelegateSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Interface

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Interface
Members See Also Send Feedback
Interface for managing dynamic attributes.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDynamicAttribute : IShallowCopy<IDynamicAttribute>,
    IDeepCopy<IDynamicAttribute>
Visual Basic (Declaration)
Public Interface IDynamicAttribute _
    Implements IShallowCopy(Of IDynamicAttribute), IDeepCopy(Of IDynamicAttribute)
Visual C++
public interface class IDynamicAttribute : IShallowCopy<IDynamicAttribute^>,
    IDeepCopy<IDynamicAttribute^>

See Also

IDynamicAttribute Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Members
IDynamicAttribute Interface Methods Properties See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ContentType | Gets or sets the content type of the value.
ContentTypeVersion | Gets or set the content type version.
ExpiresAt | Gets or sets the expire date of the attribute validity.
Key | Gets the key value of the attribute.
ReadOnly | Gets or sets the read-only flag on the attribute.
Value | Gets or vets the value of the attribute.

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Methods
IDynamicAttribute Interface See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IDynamicAttribute Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute Properties
IDynamicAttribute Interface See Also Send Feedback

The IDynamicAttribute type exposes the following members.

Properties

Name | Description
ContentType | Gets or sets the content type of the value.
ContentTypeVersion | Gets or set the content type version.
ExpiresAt | Gets or sets the expire date of the attribute validity.
Key | Gets the key value of the attribute.
ReadOnly | Gets or sets the read-only flag on the attribute.
Value | Gets or vets the value of the attribute.

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContentType Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ContentType Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the content type of the value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContentType { get; set; }
Visual Basic (Declaration)
Property ContentType As String
Visual C++
property String^ ContentType {
    String^ get ();
    void set (String^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContentTypeVersion Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ContentTypeVersion Property
IDynamicAttribute Interface See Also Send Feedback
Gets or set the content type version.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContentTypeVersion { get; set; }
Visual Basic (Declaration)
Property ContentTypeVersion As String
Visual C++
property String^ ContentTypeVersion {
    String^ get ();
    void set (String^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ExpiresAt Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ExpiresAt Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the expire date of the attribute validity.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
long ExpiresAt { get; set; }
Visual Basic (Declaration)
Property ExpiresAt As Long
Visual C++
property long long ExpiresAt {
    long long get ();
    void set (long long value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Key Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.Key Property
IDynamicAttribute Interface See Also Send Feedback
Gets the key value of the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Key { get; }
Visual Basic (Declaration)
ReadOnly Property Key As String
Visual C++
property String^ Key {
    String^ get ();
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ReadOnly Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.ReadOnly Property
IDynamicAttribute Interface See Also Send Feedback
Gets or sets the read-only flag on the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ReadOnly { get; set; }
Visual Basic (Declaration)
Property ReadOnly As Boolean
Visual C++
property bool ReadOnly {
    bool get ();
    void set (bool value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
IDynamicAttribute..::.Value Property
IDynamicAttribute Interface See Also Send Feedback
Gets or vets the value of the attribute.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Value { get; set; }
Visual Basic (Declaration)
Property Value As Object
Visual C++
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

IDynamicAttribute Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Interface

[image]

Enterprise SDK 8.0 Reference API
IFilter Interface
Members See Also Send Feedback
Interface for managing Filter for Broker Message.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IFilter
Visual Basic (Declaration)
Public Interface IFilter
Visual C++
public interface class IFilter

See Also

IFilter Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Members
IFilter Interface Methods Properties See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
GetFilters | Gets the filters.

Properties

Name | Description
Key | Gets the key of the filter.
Target | Gets the target type on which filter is applied.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Methods
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Methods

Name | Description
GetFilters | Gets the filters.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetFilters Method

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.GetFilters Method
IFilter Interface See Also Send Feedback
Gets the filters.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetFilters()
Visual Basic (Declaration)
Function GetFilters As Object
Visual C++
Object^ GetFilters()

Return Value

the object that contains the filters.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IFilter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IFilter Properties
IFilter Interface See Also Send Feedback

The IFilter type exposes the following members.

Properties

Name | Description
Key | Gets the key of the filter.
Target | Gets the target type on which filter is applied.

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Key Property

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.Key Property
IFilter Interface See Also Send Feedback
Gets the key of the filter.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Key { get; }
Visual Basic (Declaration)
ReadOnly Property Key As String
Visual C++
property String^ Key {
    String^ get ();
}

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
IFilter..::.Target Property
IFilter Interface See Also Send Feedback
Gets the target type on which filter is applied.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type Target { get; }
Visual Basic (Declaration)
ReadOnly Property Target As Type
Visual C++
property Type^ Target {
    Type^ get ();
}

See Also

IFilter Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the persistency of objects.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPersistable<T>
Visual Basic (Declaration)
Public Interface IPersistable(Of T)
Visual C++
generic<typename T>
public interface class IPersistable

Type Parameters

T
the persistent object type.

See Also

IPersistable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Members
IPersistable<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
IsDirty |
Save | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Methods
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
IsDirty |
Save | Overloaded.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsDirty Method

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.IsDirty Method
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.IsDirty"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsDirty()
Visual Basic (Declaration)
Function IsDirty As Boolean
Visual C++
bool IsDirty()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.IsDirty"]

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server.
Save(T, IStrategy) | Save data by executing the specified strategy

See Also

IPersistable<(Of <(T>)>) Interface
IPersistable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method (T)

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method (T)
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Saves the object into the Contact Server.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Save(
    T data
)
Visual Basic (Declaration)
Function Save ( _
    data As T _
) As Boolean
Visual C++
bool Save(
    T data
)

Parameters

data
Type: T

[Missing <param name="data"/> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ComponentModel.IPersistable`1.Save(`0)"]

See Also

IPersistable<(Of <(T>)>) Interface
Save Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Save Method (T, IStrategy)

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.Save Method (T, IStrategy)
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Save data by executing the specified strategy

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Save(
    T data,
    IStrategy strategy
)
Visual Basic (Declaration)
Function Save ( _
    data As T, _
    strategy As IStrategy _
) As Boolean
Visual C++
bool Save(
    T data,
    IStrategy^ strategy
)

Parameters

data
Type: T
the interaction of type T.
strategy
Type: Genesyslab.Enterprise.Model.Strategy..::.IStrategy
the persistence strategy.

Return Value

true if operation is successful.

See Also

IPersistable<(Of <(T>)>) Interface
Save Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPersistable(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>) Properties
IPersistable<(Of <(T>)>) Interface See Also Send Feedback

The IPersistable<(Of <(T>)>) type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ContactServerId Property

[image]

Enterprise SDK 8.0 Reference API
IPersistable<(Of <(T>)>)..::.ContactServerId Property
IPersistable<(Of <(T>)>) Interface See Also Send Feedback
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContactServerId { get; }
Visual Basic (Declaration)
ReadOnly Property ContactServerId As String
Visual C++
property String^ ContactServerId {
    String^ get ();
}

Return Value

string

See Also

IPersistable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface defines contract for using a predicate

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPredicatable<T>
Visual Basic (Declaration)
Public Interface IPredicatable(Of T)
Visual C++
generic<typename T>
public interface class IPredicatable

Type Parameters

T
Type of data

See Also

IPredicatable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Members
IPredicatable<(Of <(T>)>) Interface Methods See Also Send Feedback

The IPredicatable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Invoke | Object to be used for checking the predicate condition

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPredicatable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>) Methods
IPredicatable<(Of <(T>)>) Interface See Also Send Feedback

The IPredicatable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Invoke | Object to be used for checking the predicate condition

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Invoke Method

[image]

Enterprise SDK 8.0 Reference API
IPredicatable<(Of <(T>)>)..::.Invoke Method
IPredicatable<(Of <(T>)>) Interface See Also Send Feedback
Object to be used for checking the predicate condition

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Invoke(
    T obj
)
Visual Basic (Declaration)
Function Invoke ( _
    obj As T _
) As Boolean
Visual C++
bool Invoke(
    T obj
)

Parameters

obj
Type: T
Represents the truth or false of the predicate's condition

Return Value

bool

See Also

IPredicatable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for publishing typed events to subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPublishable<T>
Visual Basic (Declaration)
Public Interface IPublishable(Of T)
Visual C++
generic<typename T>
public interface class IPublishable

Type Parameters

T
the type of data.

See Also

IPublishable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Members
IPublishable<(Of <(T>)>) Interface Methods See Also Send Feedback

The IPublishable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Publish | Publishes an event to listening subscribers.

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IPublishable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>) Methods
IPublishable<(Of <(T>)>) Interface See Also Send Feedback

The IPublishable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Publish | Publishes an event to listening subscribers.

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Publish Method

[image]

Enterprise SDK 8.0 Reference API
IPublishable<(Of <(T>)>)..::.Publish Method
IPublishable<(Of <(T>)>) Interface See Also Send Feedback
Publishes an event to listening subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IPublishable<T> Publish(
    T obj
)
Visual Basic (Declaration)
Function Publish ( _
    obj As T _
) As IPublishable(Of T)
Visual C++
IPublishable<T>^ Publish(
    T obj
)

Parameters

obj
Type: T
Object to publish

Return Value

IPublishable

See Also

IPublishable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Interface

[image]

Enterprise SDK 8.0 Reference API
IRequest Interface
Members See Also Send Feedback
Interface for managing request that are sent.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IRequest : ISerializable,
    IShallowCopy<IRequest>, IDeepCopy<IRequest>
Visual Basic (Declaration)
Public Interface IRequest _
    Implements ISerializable, IShallowCopy(Of IRequest),  _
    IDeepCopy(Of IRequest)
Visual C++
public interface class IRequest : ISerializable,
    IShallowCopy<IRequest^>, IDeepCopy<IRequest^>

See Also

IRequest Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Members
IRequest Interface Methods Properties See Also Send Feedback

The IRequest type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
CorrelatorData | User defined data
Endpoint | Gets the request End-point.
ExpiresAt | Gets or sets the expire date of the request.
Guidance |
IsOriginating | Gets or sets the originating value.
Msg | Gets the IMessage that is sent.
ParentRequestId | Gets the parent request identifier.
RequestId | Gets the unique request identifier.
RequestResult | Gets or sets the request result value.
SourceName | Gets the source name.
SourceUid | Gets the source unique identifier.
TimeStampCreation | Gets the time stamp of request creation.
TimeStampRcv | Gets or sets the time stamp of request return.
TimeStampTx | Gets or sets the time stamp of request transmit.

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Methods
IRequest Interface See Also Send Feedback

The IRequest type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRequest Properties
IRequest Interface See Also Send Feedback

The IRequest type exposes the following members.

Properties

Name | Description
CorrelatorData | User defined data
Endpoint | Gets the request End-point.
ExpiresAt | Gets or sets the expire date of the request.
Guidance |
IsOriginating | Gets or sets the originating value.
Msg | Gets the IMessage that is sent.
ParentRequestId | Gets the parent request identifier.
RequestId | Gets the unique request identifier.
RequestResult | Gets or sets the request result value.
SourceName | Gets the source name.
SourceUid | Gets the source unique identifier.
TimeStampCreation | Gets the time stamp of request creation.
TimeStampRcv | Gets or sets the time stamp of request return.
TimeStampTx | Gets or sets the time stamp of request transmit.

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


CorrelatorData Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.CorrelatorData Property
IRequest Interface See Also Send Feedback
User defined data

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CorrelatorData { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelatorData As String
Visual C++
property String^ CorrelatorData {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Endpoint Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Endpoint Property
IRequest Interface See Also Send Feedback
Gets the request End-point.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Uri Endpoint { get; }
Visual Basic (Declaration)
ReadOnly Property Endpoint As Uri
Visual C++
property Uri^ Endpoint {
    Uri^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ExpiresAt Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.ExpiresAt Property
IRequest Interface See Also Send Feedback
Gets or sets the expire date of the request.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
long ExpiresAt { get; }
Visual Basic (Declaration)
ReadOnly Property ExpiresAt As Long
Visual C++
property long long ExpiresAt {
    long long get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Guidance Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Guidance Property
IRequest Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.ComponentModel.IRequest.Guidance"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Guidance { get; }
Visual Basic (Declaration)
ReadOnly Property Guidance As Object
Visual C++
property Object^ Guidance {
    Object^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IsOriginating Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.IsOriginating Property
IRequest Interface See Also Send Feedback
Gets or sets the originating value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsOriginating { get; set; }
Visual Basic (Declaration)
Property IsOriginating As Boolean
Visual C++
property bool IsOriginating {
    bool get ();
    void set (bool value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Msg Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.Msg Property
IRequest Interface See Also Send Feedback
Gets the IMessage that is sent.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IMessage Msg { get; }
Visual Basic (Declaration)
ReadOnly Property Msg As IMessage
Visual C++
property IMessage^ Msg {
    IMessage^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ParentRequestId Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.ParentRequestId Property
IRequest Interface See Also Send Feedback
Gets the parent request identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ParentRequestId { get; }
Visual Basic (Declaration)
ReadOnly Property ParentRequestId As Integer
Visual C++
property int ParentRequestId {
    int get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RequestId Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.RequestId Property
IRequest Interface See Also Send Feedback
Gets the unique request identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int RequestId { get; }
Visual Basic (Declaration)
ReadOnly Property RequestId As Integer
Visual C++
property int RequestId {
    int get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RequestResult Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.RequestResult Property
IRequest Interface See Also Send Feedback
Gets or sets the request result value.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool RequestResult { get; set; }
Visual Basic (Declaration)
Property RequestResult As Boolean
Visual C++
property bool RequestResult {
    bool get ();
    void set (bool value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SourceName Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.SourceName Property
IRequest Interface See Also Send Feedback
Gets the source name.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SourceName { get; }
Visual Basic (Declaration)
ReadOnly Property SourceName As String
Visual C++
property String^ SourceName {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SourceUid Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.SourceUid Property
IRequest Interface See Also Send Feedback
Gets the source unique identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SourceUid { get; }
Visual Basic (Declaration)
ReadOnly Property SourceUid As String
Visual C++
property String^ SourceUid {
    String^ get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampCreation Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampCreation Property
IRequest Interface See Also Send Feedback
Gets the time stamp of request creation.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
long TimeStampCreation { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStampCreation As Long
Visual C++
property long long TimeStampCreation {
    long long get ();
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampRcv Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampRcv Property
IRequest Interface See Also Send Feedback
Gets or sets the time stamp of request return.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
long TimeStampRcv { get; set; }
Visual Basic (Declaration)
Property TimeStampRcv As Long
Visual C++
property long long TimeStampRcv {
    long long get ();
    void set (long long value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


TimeStampTx Property

[image]

Enterprise SDK 8.0 Reference API
IRequest..::.TimeStampTx Property
IRequest Interface See Also Send Feedback
Gets or sets the time stamp of request transmit.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
long TimeStampTx { get; set; }
Visual Basic (Declaration)
Property TimeStampTx As Long
Visual C++
property long long TimeStampTx {
    long long get ();
    void set (long long value);
}

See Also

IRequest Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Interface

[image]

Enterprise SDK 8.0 Reference API
IRequestManager Interface
Members See Also Send Feedback
Interface for managing requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IRequestManager
Visual Basic (Declaration)
Public Interface IRequestManager
Visual C++
public interface class IRequestManager

See Also

IRequestManager Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Members
IRequestManager Interface Methods Properties See Also Send Feedback

The IRequestManager type exposes the following members.

Methods

Name | Description
Count | Gets the number of requests.
DeleteRequestById | Delete a single request
GetInitialRequest | Gets the request by its initial request.
GetRequestById | Gets the request by its identifier.
GetRequestByMsg | Gets the request by its IMessage.
ListRequests | Gets the list of requests.

Properties

Name | Description
Parent | Gets the parent object.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Methods
IRequestManager Interface See Also Send Feedback

The IRequestManager type exposes the following members.

Methods

Name | Description
Count | Gets the number of requests.
DeleteRequestById | Delete a single request
GetInitialRequest | Gets the request by its initial request.
GetRequestById | Gets the request by its identifier.
GetRequestByMsg | Gets the request by its IMessage.
ListRequests | Gets the list of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Count Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.Count Method
IRequestManager Interface See Also Send Feedback
Gets the number of requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Count()
Visual Basic (Declaration)
Function Count As Integer
Visual C++
int Count()

Return Value

the number of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


DeleteRequestById Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.DeleteRequestById Method
IRequestManager Interface See Also Send Feedback
Delete a single request

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool DeleteRequestById(
    int id
)
Visual Basic (Declaration)
Function DeleteRequestById ( _
    id As Integer _
) As Boolean
Visual C++
bool DeleteRequestById(
    int id
)

Parameters

id
Type: System..::.Int32
Request Id

Return Value

bool

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetInitialRequest Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetInitialRequest Method
IRequestManager Interface See Also Send Feedback
Gets the request by its initial request.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRequest GetInitialRequest(
    IRequest request
)
Visual Basic (Declaration)
Function GetInitialRequest ( _
    request As IRequest _
) As IRequest
Visual C++
IRequest^ GetInitialRequest(
    IRequest^ request
)

Parameters

request
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRequest
the initial request.

Return Value

the associated request.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestById Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestById Method
IRequestManager Interface See Also Send Feedback
Gets the request by its identifier.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRequest GetRequestById(
    int id
)
Visual Basic (Declaration)
Function GetRequestById ( _
    id As Integer _
) As IRequest
Visual C++
IRequest^ GetRequestById(
    int id
)

Parameters

id
Type: System..::.Int32
the request ID.

Return Value

the request.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetRequestByMsg Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.GetRequestByMsg Method
IRequestManager Interface See Also Send Feedback
Gets the request by its IMessage.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRequest GetRequestByMsg(
    IMessage msg
)
Visual Basic (Declaration)
Function GetRequestByMsg ( _
    msg As IMessage _
) As IRequest
Visual C++
IRequest^ GetRequestByMsg(
    IMessage^ msg
)

Parameters

msg
Type: IMessage
the message.

Return Value

the request.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRequests Method

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.ListRequests Method
IRequestManager Interface See Also Send Feedback
Gets the list of requests.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRequest[] ListRequests()
Visual Basic (Declaration)
Function ListRequests As IRequest()
Visual C++
array<IRequest^>^ ListRequests()

Return Value

the array of requests.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRequestManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRequestManager Properties
IRequestManager Interface See Also Send Feedback

The IRequestManager type exposes the following members.

Properties

Name | Description
Parent | Gets the parent object.

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IRequestManager..::.Parent Property
IRequestManager Interface See Also Send Feedback
Gets the parent object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Parent { get; }
Visual Basic (Declaration)
ReadOnly Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
}

See Also

IRequestManager Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Interface

[image]

Enterprise SDK 8.0 Reference API
IRole Interface
Members See Also Send Feedback
Role interface.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IRole
Visual Basic (Declaration)
Public Interface IRole
Visual C++
public interface class IRole

See Also

IRole Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRole Members
IRole Interface Properties See Also Send Feedback

The IRole type exposes the following members.

Properties

Name | Description
Capabilities | Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.
Description | Role description.
Name | Role name.
Parameters | Returns the parameters associated with the role.
RoleProfile | Role profile: custom or system.
Visibility | Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRole Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRole Properties
IRole Interface See Also Send Feedback

The IRole type exposes the following members.

Properties

Name | Description
Capabilities | Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.
Description | Role description.
Name | Role name.
Parameters | Returns the parameters associated with the role.
RoleProfile | Role profile: custom or system.
Visibility | Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Capabilities Property
IRole Interface See Also Send Feedback
Returns the capabilities for this role (for instance, the tasks assigned.) See the RBac features in the Configuration Manager.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Description Property
IRole Interface See Also Send Feedback
Role description.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Name Property
IRole Interface See Also Send Feedback
Role name.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Parameters Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Parameters Property
IRole Interface See Also Send Feedback
Returns the parameters associated with the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object[] Parameters { get; }
Visual Basic (Declaration)
ReadOnly Property Parameters As Object()
Visual C++
property array<Object^>^ Parameters {
    array<Object^>^ get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RoleProfile Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.RoleProfile Property
IRole Interface See Also Send Feedback
Role profile: custom or system.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
PartyType RoleProfile { get; }
Visual Basic (Declaration)
ReadOnly Property RoleProfile As PartyType
Visual C++
property PartyType RoleProfile {
    PartyType get ();
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IRole..::.Visibility Property
IRole Interface See Also Send Feedback
Visibility type. Example: Status in a dialog (monitoring, coaching, and so on.)

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Visibility Visibility { get; set; }
Visual Basic (Declaration)
Property Visibility As Visibility
Visual C++
property Visibility Visibility {
    Visibility get ();
    void set (Visibility value);
}

See Also

IRole Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Interface

[image]

Enterprise SDK 8.0 Reference API
IRoleable Interface
Members See Also Send Feedback
Classes that want to play role should implement this Role based interface

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IRoleable
Visual Basic (Declaration)
Public Interface IRoleable
Visual C++
public interface class IRoleable

See Also

IRoleable Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleable Members
IRoleable Interface Properties See Also Send Feedback

The IRoleable type exposes the following members.

Properties

Name | Description
Role | Gets or sets the role of an object.

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleable Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleable Properties
IRoleable Interface See Also Send Feedback

The IRoleable type exposes the following members.

Properties

Name | Description
Role | Gets or sets the role of an object.

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Role Property

[image]

Enterprise SDK 8.0 Reference API
IRoleable..::.Role Property
IRoleable Interface See Also Send Feedback
Gets or sets the role of an object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRole Role { get; }
Visual Basic (Declaration)
ReadOnly Property Role As IRole
Visual C++
property IRole^ Role {
    IRole^ get ();
}

See Also

IRoleable Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the roles.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IRoleManager<T>
where T : IRoleable
Visual Basic (Declaration)
Public Interface IRoleManager(Of T As IRoleable)
Visual C++
generic<typename T>
where T : IRoleable
public interface class IRoleManager

Type Parameters

T
the type of role.

See Also

IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Members
IRoleManager<(Of <(T>)>) Interface Methods See Also Send Feedback

The IRoleManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetActionsRole | Overloaded.
GetObjectRole | Overloaded.
HasRole | Overloaded.
ListRoles | Overloaded.
RegisterActionsForRole | Registers actions available for a role.
RegisterObjectRole | Registers Role available for an object type.
UnregisterActionsForRole | Unregisters actions available for a role.
UnregisterObjectRole | Unregisters Role.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IRoleManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>) Methods
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

The IRoleManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetActionsRole | Overloaded.
GetObjectRole | Overloaded.
HasRole | Overloaded.
ListRoles | Overloaded.
RegisterActionsForRole | Registers actions available for a role.
RegisterObjectRole | Registers Role available for an object type.
UnregisterActionsForRole | Unregisters actions available for a role.
UnregisterObjectRole | Unregisters Role.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role.
GetActionsRole<(Of <(U>)>)(PartyType) | Gets the actions of a role profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole(U) Method (IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole<(Of <(U>)>) Method (IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the actions of a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
U GetActionsRole<U>(
    IRole role
)
Visual Basic (Declaration)
Function GetActionsRole(Of U) ( _
    role As IRole _
) As U
Visual C++
generic<typename U>
U GetActionsRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Type Parameters

U
the type of data.

Return Value

The actions.

See Also

IRoleManager<(Of <(T>)>) Interface
GetActionsRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetActionsRole(U) Method (PartyType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetActionsRole<(Of <(U>)>) Method (PartyType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the actions of a role profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
U GetActionsRole<U>(
    PartyType role
)
Visual Basic (Declaration)
Function GetActionsRole(Of U) ( _
    role As PartyType _
) As U
Visual C++
generic<typename U>
U GetActionsRole(
    PartyType role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the profile type of the role.

Type Parameters

U
the type of data.

Return Value

The actions.

See Also

IRoleManager<(Of <(T>)>) Interface
GetActionsRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role.
GetObjectRole(T, PartyType) | Gets the Role for an object according to the profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method (T, IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method (T, IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role for an object according to the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T GetObjectRole(
    T baseObject,
    IRole role
)
Visual Basic (Declaration)
Function GetObjectRole ( _
    baseObject As T, _
    role As IRole _
) As T
Visual C++
T GetObjectRole(
    T baseObject,
    IRole^ role
)

Parameters

baseObject
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

The role.

See Also

IRoleManager<(Of <(T>)>) Interface
GetObjectRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


GetObjectRole Method (T, PartyType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.GetObjectRole Method (T, PartyType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role for an object according to the profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T GetObjectRole(
    T baseObject,
    PartyType role
)
Visual Basic (Declaration)
Function GetObjectRole ( _
    baseObject As T, _
    role As PartyType _
) As T
Visual C++
T GetObjectRole(
    T baseObject,
    PartyType role
)

Parameters

baseObject
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the profile type of the role.

Return Value

The role.

See Also

IRoleManager<(Of <(T>)>) Interface
GetObjectRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role.
HasRole(T, PartyType) | Gets the Role availability for an object type according to the profile type.
HasRole(T, Type) | Gets the Role availability for an object type according to the action.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, IRole)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, IRole)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool HasRole(
    T target,
    IRole role
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    role As IRole _
) As Boolean
Visual C++
bool HasRole(
    T target,
    IRole^ role
)

Parameters

target
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

true if the object has the role.

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, PartyType)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, PartyType)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the profile type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool HasRole(
    T target,
    PartyType role
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    role As PartyType _
) As Boolean
Visual C++
bool HasRole(
    T target,
    PartyType role
)

Parameters

target
Type: T
the object type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.PartyType
the profile type of the role.

Return Value

true if the object has the role profile type.

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


HasRole Method (T, Type)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.HasRole Method (T, Type)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the Role availability for an object type according to the action.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool HasRole(
    T target,
    Type ActionRole
)
Visual Basic (Declaration)
Function HasRole ( _
    target As T, _
    ActionRole As Type _
) As Boolean
Visual C++
bool HasRole(
    T target,
    Type^ ActionRole
)

Parameters

target
Type: T
the object type.
ActionRole
Type: System..::.Type
the action of the role.

Return Value

true if the object has the action role.

See Also

IRoleManager<(Of <(T>)>) Interface
HasRole Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role.
ListRoles(T) | Gets the list of Role available for an object type.

See Also

IRoleManager<(Of <(T>)>) Interface
IRoleManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of Role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRole[] ListRoles()
Visual Basic (Declaration)
Function ListRoles As IRole()
Visual C++
array<IRole^>^ ListRoles()

Return Value

the list of Role.

See Also

IRoleManager<(Of <(T>)>) Interface
ListRoles Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


ListRoles Method (T)

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.ListRoles Method (T)
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of Role available for an object type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRole[] ListRoles(
    T target
)
Visual Basic (Declaration)
Function ListRoles ( _
    target As T _
) As IRole()
Visual C++
array<IRole^>^ ListRoles(
    T target
)

Parameters

target
Type: T
the object type.

Return Value

the array of Role.

See Also

IRoleManager<(Of <(T>)>) Interface
ListRoles Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


RegisterActionsForRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.RegisterActionsForRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Registers actions available for a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRoleManager<T> RegisterActionsForRole(
    Type abstractActionRole,
    Type concreteActionRole,
    IRole role
)
Visual Basic (Declaration)
Function RegisterActionsForRole ( _
    abstractActionRole As Type, _
    concreteActionRole As Type, _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ RegisterActionsForRole(
    Type^ abstractActionRole,
    Type^ concreteActionRole,
    IRole^ role
)

Parameters

abstractActionRole
Type: System..::.Type
the abstract action role type.
concreteActionRole
Type: System..::.Type
the concrete action role type.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


RegisterObjectRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.RegisterObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Registers Role available for an object type.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRoleManager<T> RegisterObjectRole(
    Type abstractObjectRole,
    Type concreteObjectRole,
    IRole role
)
Visual Basic (Declaration)
Function RegisterObjectRole ( _
    abstractObjectRole As Type, _
    concreteObjectRole As Type, _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ RegisterObjectRole(
    Type^ abstractObjectRole,
    Type^ concreteObjectRole,
    IRole^ role
)

Parameters

abstractObjectRole
Type: System..::.Type
the abstract object role.
concreteObjectRole
Type: System..::.Type
the concrete object role.
role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


UnregisterActionsForRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.UnregisterActionsForRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Unregisters actions available for a role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRoleManager<T> UnregisterActionsForRole(
    IRole role
)
Visual Basic (Declaration)
Function UnregisterActionsForRole ( _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ UnregisterActionsForRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


UnregisterObjectRole Method

[image]

Enterprise SDK 8.0 Reference API
IRoleManager<(Of <(T>)>)..::.UnregisterObjectRole Method
IRoleManager<(Of <(T>)>) Interface See Also Send Feedback
Unregisters Role.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRoleManager<T> UnregisterObjectRole(
    IRole role
)
Visual Basic (Declaration)
Function UnregisterObjectRole ( _
    role As IRole _
) As IRoleManager(Of T)
Visual C++
IRoleManager<T>^ UnregisterObjectRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role.

Return Value

the IRoleManager.

See Also

IRoleManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Interface

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ComponentModel.IServiceSubscriber"]

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use typed interface")]
public interface IServiceSubscriber
Visual Basic (Declaration)
<ObsoleteAttribute("Use typed interface")> _
Public Interface IServiceSubscriber
Visual C++
[ObsoleteAttribute(L"Use typed interface")]
public interface class IServiceSubscriber

See Also

IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Members

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Members
IServiceSubscriber Interface Methods See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber Methods
IServiceSubscriber Interface See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register Method
IServiceSubscriber Interface See Also Send Feedback

Overload List

Name | Description
Register<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing
Register<(Of <(T>)>)(Action<(Of <(T>)>)) | Registeres an action to be performed when a publishing event occurs
Register<(Of <(T>)>)(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events

See Also

IServiceSubscriber Interface
IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Interface of subscriber object being registered. To be used for publishing activities processing

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Register<T>(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
generic<typename T>
void Register(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <(T>)>)
Object that should receive events

Type Parameters

T
Type of parameter

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (Action<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Registeres an action to be performed when a publishing event occurs

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Register<T>(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    handler As Action(Of T) _
)
Visual C++
generic<typename T>
void Register(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <(T>)>)
Represents the method that performs an action on the specified object when a publishing event occurs

Type Parameters

T
Type of parameter

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register(T) Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Register<(Of <(T>)>) Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Register a callback method for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Register<T>(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Sub Register(Of T) ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
generic<typename T>
void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
)

Parameters

handler
Type: System..::.Action <(Of <(T>)>)
Function that performs an action on the specified object T when a publishing event occurs
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <(T>)>)
filter predicate that allows checking whether publishing event should be processed or ignored

Type Parameters

T
Type of data to handle

See Also

IServiceSubscriber Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister Method
IServiceSubscriber Interface See Also Send Feedback

Overload List

Name | Description
Unregister<(Of <(T>)>)(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities
Unregister<(Of <(T>)>)(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events

See Also

IServiceSubscriber Interface
IServiceSubscriber Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister(T) Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister<(Of <(T>)>) Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Unregisters a subscriber (instance) from notifications about publishing activities

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Unregister<T>(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Unregister(Of T) ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
generic<typename T>
void Unregister(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <(T>)>)
Interface of subscriber object being unregistered

Type Parameters

T
Type of data to handle.

See Also

IServiceSubscriber Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister(T) Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber..::.Unregister<(Of <(T>)>) Method (Action<(Of <(T>)>))
IServiceSubscriber Interface See Also Send Feedback
Unregister a subscriber (method) previously registered for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Unregister<T>(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Unregister(Of T) ( _
    handler As Action(Of T) _
)
Visual C++
generic<typename T>
void Unregister(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <(T>)>)
Function that performs an action on the specified object T when a publishing event occurs.

Type Parameters

T
Type of data to handle.

See Also

IServiceSubscriber Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface defines subscriber contract for Publish/Subscribe pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IServiceSubscriber<T>
Visual Basic (Declaration)
Public Interface IServiceSubscriber(Of T)
Visual C++
generic<typename T>
public interface class IServiceSubscriber

Type Parameters

T
the type of data.

See Also

IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Members
IServiceSubscriber<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IServiceSubscriber<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

Properties

Name | Description
SubscriptionBroker | Get raw subscriber

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Methods
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
Register | Overloaded.
Unregister | Overloaded.

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Register(ISubscribeable<(Of <(T>)>)) | Interface of subscriber object being registered. To be used for publishing activities processing
Register(Action<(Of <(T>)>)) | Registers an action to be performed when a publishing event occurs
Register(Action<(Of <(T>)>), IPredicatable<(Of <(T>)>)) | Register a callback method for consumming events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Interface of subscriber object being registered. To be used for publishing activities processing

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Register(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Register ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
void Register(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
Object that should receive events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Registers an action to be performed when a publishing event occurs

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Register(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Register ( _
    handler As Action(Of T) _
)
Visual C++
void Register(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <( T >)>)
Represents the method that performs an action on the specified object when a publishing event occurs

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Register Method (Action(T), IPredicatable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Register Method (Action<(Of <(T>)>), IPredicatable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Register a callback method for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Register(
    Action<T> handler,
    IPredicatable<T> filter
)
Visual Basic (Declaration)
Sub Register ( _
    handler As Action(Of T), _
    filter As IPredicatable(Of T) _
)
Visual C++
void Register(
    Action<T>^ handler,
    IPredicatable<T>^ filter
)

Parameters

handler
Type: System..::.Action <(Of <( T >)>)
Function that performs an action on the specified object T when a publishing event occurs
filter
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IPredicatable <(Of <( T >)>)
filter predicate that allows checking whether publishing event should be processed or ignored

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Register Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Unregister(ISubscribeable<(Of <(T>)>)) | Unregisters a subscriber (instance) from notifications about publishing activities
Unregister(Action<(Of <(T>)>)) | Unregister a subscriber (method) previously registered for consumming events

See Also

IServiceSubscriber<(Of <(T>)>) Interface
IServiceSubscriber<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (ISubscribeable(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method (ISubscribeable<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Unregisters a subscriber (instance) from notifications about publishing activities

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Unregister(
    ISubscribeable<T> subscriber
)
Visual Basic (Declaration)
Sub Unregister ( _
    subscriber As ISubscribeable(Of T) _
)
Visual C++
void Unregister(
    ISubscribeable<T>^ subscriber
)

Parameters

subscriber
Type: Genesyslab.Enterprise.Model.ComponentModel..::.ISubscribeable <(Of <( T >)>)
Interface of subscriber object being unregistered

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


Unregister Method (Action(T))

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.Unregister Method (Action<(Of <(T>)>))
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Unregister a subscriber (method) previously registered for consumming events

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Unregister(
    Action<T> handler
)
Visual Basic (Declaration)
Sub Unregister ( _
    handler As Action(Of T) _
)
Visual C++
void Unregister(
    Action<T>^ handler
)

Parameters

handler
Type: System..::.Action <(Of <( T >)>)
Function that performs an action on the specified object T when a publishing event occurs.

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Unregister Overload
Genesyslab.Enterprise.Model.ComponentModel Namespace


IServiceSubscriber(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>) Properties
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback

The IServiceSubscriber<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
SubscriptionBroker | Get raw subscriber

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


SubscriptionBroker Property

[image]

Enterprise SDK 8.0 Reference API
IServiceSubscriber<(Of <(T>)>)..::.SubscriptionBroker Property
IServiceSubscriber<(Of <(T>)>) Interface See Also Send Feedback
Get raw subscriber

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISubscriptionService SubscriptionBroker { get; }
Visual Basic (Declaration)
ReadOnly Property SubscriptionBroker As ISubscriptionService
Visual C++
property ISubscriptionService^ SubscriptionBroker {
    ISubscriptionService^ get ();
}

See Also

IServiceSubscriber<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Interface

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Interface
Members See Also Send Feedback
Defines a subscriber contract for Publish/Subscribe pattern.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISubscribeable<T>
Visual Basic (Declaration)
Public Interface ISubscribeable(Of T)
Visual C++
generic<typename T>
public interface class ISubscribeable

Type Parameters

T
Type of data

See Also

ISubscribeable<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Members
ISubscribeable<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | Processes a publishing event.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Methods
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Handle | Processes a publishing event.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Handle Method

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>)..::.Handle Method
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback
Processes a publishing event.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Handle(
    T obj
)
Visual Basic (Declaration)
Sub Handle ( _
    obj As T _
)
Visual C++
void Handle(
    T obj
)

Parameters

obj
Type: T
Event that the subscribers can process.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ISubscribeable(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>) Properties
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback

The ISubscribeable<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored.

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
ISubscribeable<(Of <(T>)>)..::.Filter Property
ISubscribeable<(Of <(T>)>) Interface See Also Send Feedback
Returns the filter predicate which indicates whether publishing event should be processed or ignored.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IPredicatable<T> Filter { get; }
Visual Basic (Declaration)
ReadOnly Property Filter As IPredicatable(Of T)
Visual C++
property IPredicatable<T>^ Filter {
    IPredicatable<T>^ get ();
}

See Also

ISubscribeable<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ItemLocation Enumeration

[image]

Enterprise SDK 8.0 Reference API
ItemLocation Enumeration
See Also Send Feedback
Enumerate for location of subscribers.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[FlagsAttribute]
public enum ItemLocation
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ItemLocation
Visual C++
[FlagsAttribute]
public enum class ItemLocation

Members

Member name | Description
Internal |
External |
All |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Interface

[image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Interface
Members See Also Send Feedback
Objects transformer.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ITransformer<TTarget, TSource>
Visual Basic (Declaration)
Public Interface ITransformer(Of TTarget, TSource)
Visual C++
generic<typename TTarget, typename TSource>
public interface class ITransformer

Type Parameters

TTarget
Target type.
TSource
Source type.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Members
Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Members
ITransformer<(Of <(TTarget, TSource>)>) Interface Methods See Also Send Feedback

The ITransformer<(Of <(TTarget, TSource>)>) type exposes the following members.

Methods

Name | Description
Transform | Thransforms the source object to target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


ITransformer(TTarget, TSource) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>) Methods
ITransformer<(Of <(TTarget, TSource>)>) Interface See Also Send Feedback

The ITransformer<(Of <(TTarget, TSource>)>) type exposes the following members.

Methods

Name | Description
Transform | Thransforms the source object to target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


Transform Method

[image]

Enterprise SDK 8.0 Reference API
ITransformer<(Of <(TTarget, TSource>)>)..::.Transform Method
ITransformer<(Of <(TTarget, TSource>)>) Interface See Also Send Feedback
Thransforms the source object to target object.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
TTarget Transform(
    TSource source
)
Visual Basic (Declaration)
Function Transform ( _
    source As TSource _
) As TTarget
Visual C++
TTarget Transform(
    TSource source
)

Parameters

source
Type: TSource
The object to transform.

Return Value

Target object.

See Also

ITransformer<(Of <(TTarget, TSource>)>) Interface
Genesyslab.Enterprise.Model.ComponentModel Namespace


PartyType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyType Enumeration
See Also Send Feedback
Lists the possible party types.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum PartyType
Visual Basic (Declaration)
Public Enumeration PartyType
Visual C++
public enum class PartyType

Members

Member name | Description
Unknown | Constant for unknown type.
Client | Constant for client type.
Agent | Constant for agent type.
Supervisor | Constant for supervisor type.
External | Constant for external type.

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


StateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StateType Enumeration
See Also Send Feedback
Enumerate the state type of ICapability.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum StateType
Visual Basic (Declaration)
Public Enumeration StateType
Visual C++
public enum class StateType

Members

Member name | Description
Inactive |
Disabled |
Enabled |

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


Visibility Enumeration

[image]

Enterprise SDK 8.0 Reference API
Visibility Enumeration
See Also Send Feedback
Lists the possible values for the party's visibility.

Namespace: Genesyslab.Enterprise.Model.ComponentModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum Visibility
Visual Basic (Declaration)
Public Enumeration Visibility
Visual C++
public enum class Visibility

Members

Member name | Description
Unknown | Constant for unknown visibility.
All | Constant for all visibility (conference).
Int | Constant for internal visibility (coaching).
Vip | Constant for secrete intrusion visibility (monitor).

See Also

Genesyslab.Enterprise.Model.ComponentModel Namespace


Genesyslab.Enterprise.Model.Contact Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Contact Namespace
Send Feedback

Interfaces

Interface | Description
IAttachment | Attachment.
ICategory | Category for standard responses.
IContact | Describes a contact. It contains the attributes and interactions associated with the contact ID.
IContactAttribute | Contact Attribute. Contains the list of one or more values for this attribute. For instance, if the contact attribute is "E-mail Address", it can contains several e-mail addresses.
IContactAttributeList | List of contact attributes.
IContactAttributeValue | Value of a contact attribute.
IContactAttributeValueList | List of the possible values for a contact attribute.
IContactObject |
IStandardResponse | Describes a Standard Response.

Enumerations

Enumeration | Description
ResponseType | Enumerates the possible response types for standard responses.
StandardResponseUsageType |


IAttachment Interface

[image]

Enterprise SDK 8.0 Reference API
IAttachment Interface
Members See Also Send Feedback
Attachment.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAttachment : IContactObject
Visual Basic (Declaration)
Public Interface IAttachment _
    Implements IContactObject
Visual C++
public interface class IAttachment : IContactObject

See Also

IAttachment Members
Genesyslab.Enterprise.Model.Contact Namespace


IAttachment Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttachment Members
IAttachment Interface Properties See Also Send Feedback

The IAttachment type exposes the following members.

Properties

Name | Description
Content | Byte content (see MimeType.)
Description | Description of the attachment.
Id | ID of the attachment.
MimeType | Mime type
Name | Name.
Size | Attachment size.

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


IAttachment Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAttachment Properties
IAttachment Interface See Also Send Feedback

The IAttachment type exposes the following members.

Properties

Name | Description
Content | Byte content (see MimeType.)
Description | Description of the attachment.
Id | ID of the attachment.
MimeType | Mime type
Name | Name.
Size | Attachment size.

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


Content Property

[image]

Enterprise SDK 8.0 Reference API
IAttachment..::.Content Property
IAttachment Interface See Also Send Feedback
Byte content (see MimeType.)

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
byte[] Content { get; }
Visual Basic (Declaration)
ReadOnly Property Content As Byte()
Visual C++
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
}

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IAttachment..::.Description Property
IAttachment Interface See Also Send Feedback
Description of the attachment.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IAttachment..::.Id Property
IAttachment Interface See Also Send Feedback
ID of the attachment.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


MimeType Property

[image]

Enterprise SDK 8.0 Reference API
IAttachment..::.MimeType Property
IAttachment Interface See Also Send Feedback
Mime type

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MimeType { get; }
Visual Basic (Declaration)
ReadOnly Property MimeType As String
Visual C++
property String^ MimeType {
    String^ get ();
}

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IAttachment..::.Name Property
IAttachment Interface See Also Send Feedback
Name.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


Size Property

[image]

Enterprise SDK 8.0 Reference API
IAttachment..::.Size Property
IAttachment Interface See Also Send Feedback
Attachment size.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> Size { get; }
Visual Basic (Declaration)
ReadOnly Property Size As Nullable(Of Integer)
Visual C++
property Nullable<int> Size {
    Nullable<int> get ();
}

See Also

IAttachment Interface
Genesyslab.Enterprise.Model.Contact Namespace


ICategory Interface

[image]

Enterprise SDK 8.0 Reference API
ICategory Interface
Members See Also Send Feedback
Category for standard responses.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICategory : IContactObject
Visual Basic (Declaration)
Public Interface ICategory _
    Implements IContactObject
Visual C++
public interface class ICategory : IContactObject

See Also

ICategory Members
Genesyslab.Enterprise.Model.Contact Namespace


ICategory Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICategory Members
ICategory Interface Properties See Also Send Feedback

The ICategory type exposes the following members.

Properties

Name | Description
CategoryId | Category ID.
ChildrenCategories | Array of the children categories.
Description | Category description.
IsComplete | true if completed.
Language |
ModifiedDate | Lastest modification.
Name | Category name.
ParentCategory | Name of the parent category if it exists, or null.
StandardResponses | Standard responses which are part of this category.
Status | Category status.
TenantId | Tenant.

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


ICategory Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICategory Properties
ICategory Interface See Also Send Feedback

The ICategory type exposes the following members.

Properties

Name | Description
CategoryId | Category ID.
ChildrenCategories | Array of the children categories.
Description | Category description.
IsComplete | true if completed.
Language |
ModifiedDate | Lastest modification.
Name | Category name.
ParentCategory | Name of the parent category if it exists, or null.
StandardResponses | Standard responses which are part of this category.
Status | Category status.
TenantId | Tenant.

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


CategoryId Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.CategoryId Property
ICategory Interface See Also Send Feedback
Category ID.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CategoryId { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryId As String
Visual C++
property String^ CategoryId {
    String^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


ChildrenCategories Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.ChildrenCategories Property
ICategory Interface See Also Send Feedback
Array of the children categories.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory[] ChildrenCategories { get; }
Visual Basic (Declaration)
ReadOnly Property ChildrenCategories As ICategory()
Visual C++
property array<ICategory^>^ ChildrenCategories {
    array<ICategory^>^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.Description Property
ICategory Interface See Also Send Feedback
Category description.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


IsComplete Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.IsComplete Property
ICategory Interface See Also Send Feedback
true if completed.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsComplete { get; }
Visual Basic (Declaration)
ReadOnly Property IsComplete As Boolean
Visual C++
property bool IsComplete {
    bool get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


Language Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.Language Property
ICategory Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.ICategory.Language"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Language { get; set; }
Visual Basic (Declaration)
Property Language As String
Visual C++
property String^ Language {
    String^ get ();
    void set (String^ value);
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


ModifiedDate Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.ModifiedDate Property
ICategory Interface See Also Send Feedback
Lastest modification.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime ModifiedDate { get; }
Visual Basic (Declaration)
ReadOnly Property ModifiedDate As DateTime
Visual C++
property DateTime ModifiedDate {
    DateTime get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.Name Property
ICategory Interface See Also Send Feedback
Category name.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


ParentCategory Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.ParentCategory Property
ICategory Interface See Also Send Feedback
Name of the parent category if it exists, or null.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ParentCategory { get; }
Visual Basic (Declaration)
ReadOnly Property ParentCategory As String
Visual C++
property String^ ParentCategory {
    String^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


StandardResponses Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.StandardResponses Property
ICategory Interface See Also Send Feedback
Standard responses which are part of this category.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse[] StandardResponses { get; }
Visual Basic (Declaration)
ReadOnly Property StandardResponses As IStandardResponse()
Visual C++
property array<IStandardResponse^>^ StandardResponses {
    array<IStandardResponse^>^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.Status Property
ICategory Interface See Also Send Feedback
Category status.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As String
Visual C++
property String^ Status {
    String^ get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


TenantId Property

[image]

Enterprise SDK 8.0 Reference API
ICategory..::.TenantId Property
ICategory Interface See Also Send Feedback
Tenant.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TenantId { get; }
Visual Basic (Declaration)
ReadOnly Property TenantId As Integer
Visual C++
property int TenantId {
    int get ();
}

See Also

ICategory Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContact Interface

[image]

Enterprise SDK 8.0 Reference API
IContact Interface
Members See Also Send Feedback
Describes a contact. It contains the attributes and interactions associated with the contact ID.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContact : IContactObject
Visual Basic (Declaration)
Public Interface IContact _
    Implements IContactObject
Visual C++
public interface class IContact : IContactObject

See Also

IContact Members
Genesyslab.Enterprise.Model.Contact Namespace


IContact Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContact Members
IContact Interface Properties See Also Send Feedback

The IContact type exposes the following members.

Properties

Name | Description
Attributes |
ContactId |
Interactions |

See Also

IContact Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContact Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContact Properties
IContact Interface See Also Send Feedback

The IContact type exposes the following members.

Properties

Name | Description
Attributes |
ContactId |
Interactions |

See Also

IContact Interface
Genesyslab.Enterprise.Model.Contact Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IContact..::.Attributes Property
IContact Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContact.Attributes"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContactAttributeList Attributes { get; set; }
Visual Basic (Declaration)
Property Attributes As IContactAttributeList
Visual C++
property IContactAttributeList^ Attributes {
    IContactAttributeList^ get ();
    void set (IContactAttributeList^ value);
}

See Also

IContact Interface
Genesyslab.Enterprise.Model.Contact Namespace


ContactId Property

[image]

Enterprise SDK 8.0 Reference API
IContact..::.ContactId Property
IContact Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContact.ContactId"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContactId { get; set; }
Visual Basic (Declaration)
Property ContactId As String
Visual C++
property String^ ContactId {
    String^ get ();
    void set (String^ value);
}

See Also

IContact Interface
Genesyslab.Enterprise.Model.Contact Namespace


Interactions Property

[image]

Enterprise SDK 8.0 Reference API
IContact..::.Interactions Property
IContact Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContact.Interactions"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
List<IInteraction> Interactions { get; }
Visual Basic (Declaration)
ReadOnly Property Interactions As List(Of IInteraction)
Visual C++
property List<IInteraction^>^ Interactions {
    List<IInteraction^>^ get ();
}

See Also

IContact Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttribute Interface

[image]

Enterprise SDK 8.0 Reference API
IContactAttribute Interface
Members See Also Send Feedback
Contact Attribute. Contains the list of one or more values for this attribute. For instance, if the contact attribute is "E-mail Address", it can contains several e-mail addresses.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactAttribute
Visual Basic (Declaration)
Public Interface IContactAttribute
Visual C++
public interface class IContactAttribute

See Also

IContactAttribute Members
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttribute Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttribute Members
IContactAttribute Interface Properties See Also Send Feedback

The IContactAttribute type exposes the following members.

Properties

Name | Description
Name |
Values |

See Also

IContactAttribute Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttribute Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttribute Properties
IContactAttribute Interface See Also Send Feedback

The IContactAttribute type exposes the following members.

Properties

Name | Description
Name |
Values |

See Also

IContactAttribute Interface
Genesyslab.Enterprise.Model.Contact Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IContactAttribute..::.Name Property
IContactAttribute Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContactAttribute.Name"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IContactAttribute Interface
Genesyslab.Enterprise.Model.Contact Namespace


Values Property

[image]

Enterprise SDK 8.0 Reference API
IContactAttribute..::.Values Property
IContactAttribute Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContactAttribute.Values"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContactAttributeValueList Values { get; set; }
Visual Basic (Declaration)
Property Values As IContactAttributeValueList
Visual C++
property IContactAttributeValueList^ Values {
    IContactAttributeValueList^ get ();
    void set (IContactAttributeValueList^ value);
}

See Also

IContactAttribute Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeList Interface

[image]

Enterprise SDK 8.0 Reference API
IContactAttributeList Interface
Members See Also Send Feedback
List of contact attributes.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactAttributeList : IList<IContactAttribute>,
    ICollection<IContactAttribute>, IEnumerable<IContactAttribute>, IEnumerable
Visual Basic (Declaration)
Public Interface IContactAttributeList _
    Implements IList(Of IContactAttribute), ICollection(Of IContactAttribute),  _
    IEnumerable(Of IContactAttribute), IEnumerable
Visual C++
public interface class IContactAttributeList : IList<IContactAttribute^>,
    ICollection<IContactAttribute^>, IEnumerable<IContactAttribute^>, IEnumerable

See Also

IContactAttributeList Members
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeList Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeList Members
IContactAttributeList Interface Methods Properties See Also Send Feedback

The IContactAttributeList type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection <(Of <( IContactAttribute >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <( IContactAttribute >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList <(Of <( IContactAttribute >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList <(Of <( IContactAttribute >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList <(Of <( IContactAttribute >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection <(Of <( IContactAttribute >)>).)
Item | Overloaded.

See Also

IContactAttributeList Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeList Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeList Methods
IContactAttributeList Interface See Also Send Feedback

The IContactAttributeList type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection <(Of <( IContactAttribute >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <( IContactAttribute >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList <(Of <( IContactAttribute >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList <(Of <( IContactAttribute >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList <(Of <( IContactAttribute >)>).)

See Also

IContactAttributeList Interface
Genesyslab.Enterprise.Model.Contact Namespace


GetEnumerator Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeList..::.GetEnumerator Method
IContactAttributeList Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <( IContactAttribute >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IContactAttributeList Interface
IContactAttributeList Members
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeList Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeList Properties
IContactAttributeList Interface See Also Send Feedback

The IContactAttributeList type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttribute >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection <(Of <( IContactAttribute >)>).)
Item | Overloaded.

See Also

IContactAttributeList Interface
Genesyslab.Enterprise.Model.Contact Namespace


Item Property

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeList..::.Item Property
IContactAttributeList Interface See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from IList <(Of <( IContactAttribute >)>).)
Item[([(String])]) |

See Also

IContactAttributeList Interface
IContactAttributeList Members
Genesyslab.Enterprise.Model.Contact Namespace


Item Property (String)

[image]

Enterprise SDK 8.0 Reference API
IContactAttributeList..::.Item Property (String)
IContactAttributeList Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContactAttributeList.Item(System.String)"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContactAttribute this[
    string name
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    name As String _
) As IContactAttribute
Visual C++
property IContactAttribute^ default[String^ name] {
    IContactAttribute^ get (String^ name);
    void set (String^ name, IContactAttribute^ value);
}

Parameters

name
Type: System..::.String

See Also

IContactAttributeList Interface
Item Overload
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValue Interface

[image]

Enterprise SDK 8.0 Reference API
IContactAttributeValue Interface
Members See Also Send Feedback
Value of a contact attribute.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactAttributeValue
Visual Basic (Declaration)
Public Interface IContactAttributeValue
Visual C++
public interface class IContactAttributeValue

See Also

IContactAttributeValue Members
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValue Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeValue Members
IContactAttributeValue Interface Properties See Also Send Feedback

The IContactAttributeValue type exposes the following members.

Properties

Name | Description
Id |
Value |

See Also

IContactAttributeValue Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValue Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeValue Properties
IContactAttributeValue Interface See Also Send Feedback

The IContactAttributeValue type exposes the following members.

Properties

Name | Description
Id |
Value |

See Also

IContactAttributeValue Interface
Genesyslab.Enterprise.Model.Contact Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IContactAttributeValue..::.Id Property
IContactAttributeValue Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContactAttributeValue.Id"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Id { get; set; }
Visual Basic (Declaration)
Property Id As String
Visual C++
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

IContactAttributeValue Interface
Genesyslab.Enterprise.Model.Contact Namespace


Value Property

[image]

Enterprise SDK 8.0 Reference API
IContactAttributeValue..::.Value Property
IContactAttributeValue Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IContactAttributeValue.Value"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Value { get; set; }
Visual Basic (Declaration)
Property Value As Object
Visual C++
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}

See Also

IContactAttributeValue Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValueList Interface

[image]

Enterprise SDK 8.0 Reference API
IContactAttributeValueList Interface
Members See Also Send Feedback
List of the possible values for a contact attribute.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactAttributeValueList : IList<IContactAttributeValue>,
    ICollection<IContactAttributeValue>, IEnumerable<IContactAttributeValue>, IEnumerable
Visual Basic (Declaration)
Public Interface IContactAttributeValueList _
    Implements IList(Of IContactAttributeValue), ICollection(Of IContactAttributeValue),  _
    IEnumerable(Of IContactAttributeValue), IEnumerable
Visual C++
public interface class IContactAttributeValueList : IList<IContactAttributeValue^>,
    ICollection<IContactAttributeValue^>, IEnumerable<IContactAttributeValue^>, IEnumerable

See Also

IContactAttributeValueList Members
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValueList Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeValueList Members
IContactAttributeValueList Interface Methods Properties See Also Send Feedback

The IContactAttributeValueList type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList <(Of <( IContactAttributeValue >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList <(Of <( IContactAttributeValue >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList <(Of <( IContactAttributeValue >)>).)

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList <(Of <( IContactAttributeValue >)>).)

See Also

IContactAttributeValueList Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValueList Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeValueList Methods
IContactAttributeValueList Interface See Also Send Feedback

The IContactAttributeValueList type exposes the following members.

Methods

Name | Description
Add | Adds an item to the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
Clear | Removes all items from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
Contains | Determines whether the ICollection<(Of <(T>)>) contains a specific value. (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
CopyTo | Copies the elements of the ICollection<(Of <(T>)>) to an Array, starting at a particular Array index. (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
GetEnumerator | Overloaded.
IndexOf | Determines the index of a specific item in the IList<(Of <(T>)>). (Inherited from IList <(Of <( IContactAttributeValue >)>).)
Insert | Inserts an item to the IList<(Of <(T>)>) at the specified index. (Inherited from IList <(Of <( IContactAttributeValue >)>).)
Remove | Removes the first occurrence of a specific object from the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
RemoveAt | Removes the IList<(Of <(T>)>) item at the specified index. (Inherited from IList <(Of <( IContactAttributeValue >)>).)

See Also

IContactAttributeValueList Interface
Genesyslab.Enterprise.Model.Contact Namespace


GetEnumerator Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeValueList..::.GetEnumerator Method
IContactAttributeValueList Interface See Also Send Feedback

Overload List

Name | Description
GetEnumerator()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable <(Of <( IContactAttributeValue >)>).)
GetEnumerator()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)

See Also

IContactAttributeValueList Interface
IContactAttributeValueList Members
Genesyslab.Enterprise.Model.Contact Namespace


IContactAttributeValueList Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContactAttributeValueList Properties
IContactAttributeValueList Interface See Also Send Feedback

The IContactAttributeValueList type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ICollection<(Of <(T>)>). (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
IsReadOnly | Gets a value indicating whether the ICollection<(Of <(T>)>) is read-only. (Inherited from ICollection <(Of <( IContactAttributeValue >)>).)
Item | Gets or sets the element at the specified index. (Inherited from IList <(Of <( IContactAttributeValue >)>).)

See Also

IContactAttributeValueList Interface
Genesyslab.Enterprise.Model.Contact Namespace


IContactObject Interface

[image]

Enterprise SDK 8.0 Reference API
IContactObject Interface
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Contact.IContactObject"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactObject
Visual Basic (Declaration)
Public Interface IContactObject
Visual C++
public interface class IContactObject

See Also

Genesyslab.Enterprise.Model.Contact Namespace


IStandardResponse Interface

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse Interface
Members See Also Send Feedback
Describes a Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStandardResponse : IContactObject
Visual Basic (Declaration)
Public Interface IStandardResponse _
    Implements IContactObject
Visual C++
public interface class IStandardResponse : IContactObject

See Also

IStandardResponse Members
Genesyslab.Enterprise.Model.Contact Namespace


IStandardResponse Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStandardResponse Members
IStandardResponse Interface Properties See Also Send Feedback

The IStandardResponse type exposes the following members.

Properties

Name | Description
AckUsageType |
AgentDesktopUsageType |
Attachments | Array of the Standard Response's attachments.
AutoRespUsageType |
Body | The body text of the Standard Response. Note: This body text may contain field codes to render with agent, interaction, and custom information.
CategoryId | The ID of the category associated with the Standard Response.
CustomFieldCodes | Returns the custom field codes as an array of string.
Description | Description of the Standard Response.
ExpirationDate | Expiration date of the StandardResponse
HasAttachments | true if this Standard Response has attached files.
Id | ID of the Standard Response.
IsActive | true if the Standard Response is active.
Lang | The language of the Standard Response.
ModifiedDate | Date at which the Standard Response was modified.
Name | Returns the name.
OwnerId | Owner of the Standard Response.
StartDate | Start date of the StandardResponse
Status | Status of the Standard Response.
StructuredBody | The structured body contains the body text with the field codes replaced by their values.
Subject | Returns the subject of the Standard Response.
Version | Version number.

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


IStandardResponse Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStandardResponse Properties
IStandardResponse Interface See Also Send Feedback

The IStandardResponse type exposes the following members.

Properties

Name | Description
AckUsageType |
AgentDesktopUsageType |
Attachments | Array of the Standard Response's attachments.
AutoRespUsageType |
Body | The body text of the Standard Response. Note: This body text may contain field codes to render with agent, interaction, and custom information.
CategoryId | The ID of the category associated with the Standard Response.
CustomFieldCodes | Returns the custom field codes as an array of string.
Description | Description of the Standard Response.
ExpirationDate | Expiration date of the StandardResponse
HasAttachments | true if this Standard Response has attached files.
Id | ID of the Standard Response.
IsActive | true if the Standard Response is active.
Lang | The language of the Standard Response.
ModifiedDate | Date at which the Standard Response was modified.
Name | Returns the name.
OwnerId | Owner of the Standard Response.
StartDate | Start date of the StandardResponse
Status | Status of the Standard Response.
StructuredBody | The structured body contains the body text with the field codes replaced by their values.
Subject | Returns the subject of the Standard Response.
Version | Version number.

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


AckUsageType Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.AckUsageType Property
IStandardResponse Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IStandardResponse.AckUsageType"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StandardResponseUsageType AckUsageType { get; }
Visual Basic (Declaration)
ReadOnly Property AckUsageType As StandardResponseUsageType
Visual C++
property StandardResponseUsageType AckUsageType {
    StandardResponseUsageType get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


AgentDesktopUsageType Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.AgentDesktopUsageType Property
IStandardResponse Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IStandardResponse.AgentDesktopUsageType"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StandardResponseUsageType AgentDesktopUsageType { get; }
Visual Basic (Declaration)
ReadOnly Property AgentDesktopUsageType As StandardResponseUsageType
Visual C++
property StandardResponseUsageType AgentDesktopUsageType {
    StandardResponseUsageType get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Attachments Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Attachments Property
IStandardResponse Interface See Also Send Feedback
Array of the Standard Response's attachments.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttachment[] Attachments { get; }
Visual Basic (Declaration)
ReadOnly Property Attachments As IAttachment()
Visual C++
property array<IAttachment^>^ Attachments {
    array<IAttachment^>^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


AutoRespUsageType Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.AutoRespUsageType Property
IStandardResponse Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Contact.IStandardResponse.AutoRespUsageType"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StandardResponseUsageType AutoRespUsageType { get; }
Visual Basic (Declaration)
ReadOnly Property AutoRespUsageType As StandardResponseUsageType
Visual C++
property StandardResponseUsageType AutoRespUsageType {
    StandardResponseUsageType get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Body Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Body Property
IStandardResponse Interface See Also Send Feedback
The body text of the Standard Response.
Note: This body text may contain field codes to render with agent, interaction, and custom information.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Body { get; }
Visual Basic (Declaration)
ReadOnly Property Body As String
Visual C++
property String^ Body {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


CategoryId Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.CategoryId Property
IStandardResponse Interface See Also Send Feedback
The ID of the category associated with the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CategoryId { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryId As String
Visual C++
property String^ CategoryId {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


CustomFieldCodes Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.CustomFieldCodes Property
IStandardResponse Interface See Also Send Feedback
Returns the custom field codes as an array of string.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] CustomFieldCodes { get; }
Visual Basic (Declaration)
ReadOnly Property CustomFieldCodes As String()
Visual C++
property array<String^>^ CustomFieldCodes {
    array<String^>^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Description Property
IStandardResponse Interface See Also Send Feedback
Description of the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


ExpirationDate Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.ExpirationDate Property
IStandardResponse Interface See Also Send Feedback
Expiration date of the StandardResponse

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<DateTime> ExpirationDate { get; }
Visual Basic (Declaration)
ReadOnly Property ExpirationDate As Nullable(Of DateTime)
Visual C++
property Nullable<DateTime> ExpirationDate {
    Nullable<DateTime> get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


HasAttachments Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.HasAttachments Property
IStandardResponse Interface See Also Send Feedback
true if this Standard Response has attached files.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool HasAttachments { get; }
Visual Basic (Declaration)
ReadOnly Property HasAttachments As Boolean
Visual C++
property bool HasAttachments {
    bool get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Id Property
IStandardResponse Interface See Also Send Feedback
ID of the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


IsActive Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.IsActive Property
IStandardResponse Interface See Also Send Feedback
true if the Standard Response is active.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsActive { get; }
Visual Basic (Declaration)
ReadOnly Property IsActive As Boolean
Visual C++
property bool IsActive {
    bool get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Lang Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Lang Property
IStandardResponse Interface See Also Send Feedback
The language of the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Lang { get; }
Visual Basic (Declaration)
ReadOnly Property Lang As String
Visual C++
property String^ Lang {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


ModifiedDate Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.ModifiedDate Property
IStandardResponse Interface See Also Send Feedback
Date at which the Standard Response was modified.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime ModifiedDate { get; }
Visual Basic (Declaration)
ReadOnly Property ModifiedDate As DateTime
Visual C++
property DateTime ModifiedDate {
    DateTime get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Name Property
IStandardResponse Interface See Also Send Feedback
Returns the name.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


OwnerId Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.OwnerId Property
IStandardResponse Interface See Also Send Feedback
Owner of the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string OwnerId { get; }
Visual Basic (Declaration)
ReadOnly Property OwnerId As String
Visual C++
property String^ OwnerId {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.StartDate Property
IStandardResponse Interface See Also Send Feedback
Start date of the StandardResponse

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<DateTime> StartDate { get; }
Visual Basic (Declaration)
ReadOnly Property StartDate As Nullable(Of DateTime)
Visual C++
property Nullable<DateTime> StartDate {
    Nullable<DateTime> get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Status Property
IStandardResponse Interface See Also Send Feedback
Status of the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As String
Visual C++
property String^ Status {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


StructuredBody Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.StructuredBody Property
IStandardResponse Interface See Also Send Feedback
The structured body contains the body text with the field codes replaced by their values.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string StructuredBody { get; }
Visual Basic (Declaration)
ReadOnly Property StructuredBody As String
Visual C++
property String^ StructuredBody {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Subject Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Subject Property
IStandardResponse Interface See Also Send Feedback
Returns the subject of the Standard Response.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Subject { get; }
Visual Basic (Declaration)
ReadOnly Property Subject As String
Visual C++
property String^ Subject {
    String^ get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


Version Property

[image]

Enterprise SDK 8.0 Reference API
IStandardResponse..::.Version Property
IStandardResponse Interface See Also Send Feedback
Version number.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Version { get; }
Visual Basic (Declaration)
ReadOnly Property Version As Integer
Visual C++
property int Version {
    int get ();
}

See Also

IStandardResponse Interface
Genesyslab.Enterprise.Model.Contact Namespace


ResponseType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ResponseType Enumeration
See Also Send Feedback
Enumerates the possible response types for standard responses.

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ResponseType
Visual Basic (Declaration)
Public Enumeration ResponseType
Visual C++
public enum class ResponseType

Members

Member name | Description
SuggestedResponsesIgnored |
SystemAutoResponse |
SuggestedResponseChoosen |
SuggestedResponseNotReceived |
AdministratorResponse |

See Also

Genesyslab.Enterprise.Model.Contact Namespace


StandardResponseUsageType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StandardResponseUsageType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Contact.StandardResponseUsageType"]

Namespace: Genesyslab.Enterprise.Model.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum StandardResponseUsageType
Visual Basic (Declaration)
Public Enumeration StandardResponseUsageType
Visual C++
public enum class StandardResponseUsageType

Members

Member name | Description
NOT_USED |
MANUAL | may be used, but not active (not showed by default on agent desktop, unless agent specifically ask for it)
AUTOMATIC | active

See Also

Genesyslab.Enterprise.Model.Contact Namespace


Genesyslab.Enterprise.Model.Device Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Device Namespace
Send Feedback

Interfaces

Interface | Description
IDevice | Describes a device. To learn how to create a device, or how to register for its events, see the summary descriptions and examples of [!:Genesyslab.Enterprise.Services.IDeviceService].

Enumerations

Enumeration | Description
DeviceStateType | Enumeration for the possible states of a device.
DeviceType | Enumeration for the device types that you can find in the supported switches.
ForwardModeType | Enumeration types for the forward mode.


DeviceStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceStateType Enumeration
See Also Send Feedback
Enumeration for the possible states of a device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[SerializableAttribute]
public enum DeviceStateType
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration DeviceStateType
Visual C++
[SerializableAttribute]
public enum class DeviceStateType

Members

Member name | Description
Unknown |
OutOfService |
Registering |
Registered |
NotRegistered |
Unavailable |

See Also

Genesyslab.Enterprise.Model.Device Namespace


DeviceType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceType Enumeration
See Also Send Feedback
Enumeration for the device types that you can find in the supported switches.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum DeviceType
Visual Basic (Declaration)
Public Enumeration DeviceType
Visual C++
public enum class DeviceType

Members

Member name | Description
Unknown |
Acdposition |
Extension |
Multimedia |
Place |
VirtualDevice |

See Also

Genesyslab.Enterprise.Model.Device Namespace


ForwardModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ForwardModeType Enumeration
See Also Send Feedback
Enumeration types for the forward mode.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ForwardModeType
Visual Basic (Declaration)
Public Enumeration ForwardModeType
Visual C++
public enum class ForwardModeType

Members

Member name | Description
Unknown |
None |
Unconditional |
OnBusy |
OnNoAnswer |
OnBusyAndNoAnswer |
SendAllCalls |

See Also

Genesyslab.Enterprise.Model.Device Namespace


IDevice Interface

[image]

Enterprise SDK 8.0 Reference API
IDevice Interface
Members See Also Send Feedback
Describes a device. To learn how to create a device, or how to register for its events, see the summary descriptions and examples of [!:Genesyslab.Enterprise.Services.IDeviceService].

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDevice : ISerializable
Visual Basic (Declaration)
Public Interface IDevice _
    Implements ISerializable
Visual C++
public interface class IDevice : ISerializable

See Also

IDevice Members
Genesyslab.Enterprise.Model.Device Namespace


IDevice Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Members
IDevice Interface Methods Properties See Also Send Feedback

The IDevice type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling
ActiveChannels | List of active channels for this device.
Attributes | Gets the attributes of the device.
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.
Controller | Returns the state controller of the object.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.
Group | Group of subdevices which compose this device.
Identity | Identity in relation with the device.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.
State | Device status.
Strategy | List of stategies handled by the object.

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


IDevice Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Methods
IDevice Interface See Also Send Feedback

The IDevice type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


IDevice Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDevice Properties
IDevice Interface See Also Send Feedback

The IDevice type exposes the following members.

Properties

Name | Description
ActionsTransitions | The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling
ActiveChannels | List of active channels for this device.
Attributes | Gets the attributes of the device.
Capabilities | Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.
Controller | Returns the state controller of the object.
FQName | Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.
Group | Group of subdevices which compose this device.
Identity | Identity in relation with the device.
Name | Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.
State | Device status.
Strategy | List of stategies handled by the object.

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


ActionsTransitions Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.ActionsTransitions Property
IDevice Interface See Also Send Feedback
The list of actions that the application can do with the device. According to events, strategies, and capabilities, this property updates. Some action transitions can be temporarily unavailable according to the object status. For instance, if the device is configured in the CME to accept a single call, and if the device is already busy, you can't create a new call on this device. handling

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool[] ActionsTransitions { get; }
Visual Basic (Declaration)
ReadOnly Property ActionsTransitions As Boolean()
Visual C++
property array<bool>^ ActionsTransitions {
    array<bool>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


ActiveChannels Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.ActiveChannels Property
IDevice Interface See Also Send Feedback
List of active channels for this device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Uri[] ActiveChannels { get; }
Visual Basic (Declaration)
ReadOnly Property ActiveChannels As Uri()
Visual C++
property array<Uri^>^ ActiveChannels {
    array<Uri^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Attributes Property
IDevice Interface See Also Send Feedback
Gets the attributes of the device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Attributes {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Capabilities Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Capabilities Property
IDevice Interface See Also Send Feedback
Capabilities of the device. These capabilities list the features that you can use on the device, for instance sms, fax, e-mail.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, ICapability> Capabilities { get; }
Visual Basic (Declaration)
ReadOnly Property Capabilities As IDictionary(Of String, ICapability)
Visual C++
property IDictionary<String^, ICapability^>^ Capabilities {
    IDictionary<String^, ICapability^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Controller Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Controller Property
IDevice Interface See Also Send Feedback
Returns the state controller of the object.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Controller { get; }
Visual Basic (Declaration)
ReadOnly Property Controller As Object
Visual C++
property Object^ Controller {
    Object^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.FQName Property
IDevice Interface See Also Send Feedback

Fully Qualified Name. This is the unique identifier of the object instance. In the device's particular case, the FQ name follows this syntax: dn@switch_name.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Group Property
IDevice Interface See Also Send Feedback
Group of subdevices which compose this device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDevice> Group { get; }
Visual Basic (Declaration)
ReadOnly Property Group As IDictionary(Of String, IDevice)
Visual C++
property IDictionary<String^, IDevice^>^ Group {
    IDictionary<String^, IDevice^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Identity Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Identity Property
IDevice Interface See Also Send Feedback
Identity in relation with the device.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IIdentity> Identity { get; }
Visual Basic (Declaration)
ReadOnly Property Identity As IDictionary(Of String, IIdentity)
Visual C++
property IDictionary<String^, IIdentity^>^ Identity {
    IDictionary<String^, IIdentity^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Name Property
IDevice Interface See Also Send Feedback
Name of the object. This name is not always unique, for instance, in multi-tenant configurations, or in multiple switch configurations.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.State Property
IDevice Interface See Also Send Feedback
Device status.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DeviceStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As DeviceStateType
Visual C++
property DeviceStateType State {
    DeviceStateType get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IDevice..::.Strategy Property
IDevice Interface See Also Send Feedback
List of stategies handled by the object.

Namespace: Genesyslab.Enterprise.Model.Device
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IDevice Interface
Genesyslab.Enterprise.Model.Device Namespace


Genesyslab.Enterprise.Model.Envelope Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Envelope Namespace
Send Feedback

Interfaces

Interface Description
IDeviceResolver
IEnvelope<(Of <(T>)>)
Describes the event that occurred on the related published object, and contains the updated copy of this object.

This container is divided into two parts:

  • Header Details the event information.
  • BodyCopy of the published object.
Note: Make sure that you use the returned object copy to update accordingly your application and in further calls to Enterprise SDK methods. Do not keep a reference on a deprecated copy: if a new event occurs

IHeader
Describes the event which occurred on a published object. This interface details what happened to this object (modification if State value is 0, else this is an error) and provides its context as the list of the related protocol messages which resulted in this E-SDK event.
  • The last protocol message is available in CurrentContext.
  • Other related messages are available in the ContextByIndex(Int32).
IPayLoadContext
Describes an event and its associated event/request protocol message (msg).

Enumerations

Enumeration | Description
EnvelopeStateType | Status of the envelope.


EnvelopeStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
EnvelopeStateType Enumeration
See Also Send Feedback
Status of the envelope.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum EnvelopeStateType
Visual Basic (Declaration)
Public Enumeration EnvelopeStateType
Visual C++
public enum class EnvelopeStateType

Members

Member name | Description
Unknown | Unknown.
Created | Creation.
Complete | Complete.
Read | Read.
Written | Written.
Copied | Copied.
Closed | Closed.

See Also

Genesyslab.Enterprise.Model.Envelope Namespace


IDeviceResolver Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceResolver Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Envelope.IDeviceResolver"]

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDeviceResolver
Visual Basic (Declaration)
Public Interface IDeviceResolver
Visual C++
public interface class IDeviceResolver

See Also

IDeviceResolver Members
Genesyslab.Enterprise.Model.Envelope Namespace


IDeviceResolver Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceResolver Members
IDeviceResolver Interface Methods See Also Send Feedback

The IDeviceResolver type exposes the following members.

Methods

Name | Description
FindDevice | Find source event

See Also

IDeviceResolver Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IDeviceResolver Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceResolver Methods
IDeviceResolver Interface See Also Send Feedback

The IDeviceResolver type exposes the following members.

Methods

Name | Description
FindDevice | Find source event

See Also

IDeviceResolver Interface
Genesyslab.Enterprise.Model.Envelope Namespace


FindDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceResolver..::.FindDevice Method
IDeviceResolver Interface See Also Send Feedback
Find source event

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice FindDevice()
Visual Basic (Declaration)
Function FindDevice As IDevice
Visual C++
IDevice^ FindDevice()

Return Value

IDevice

See Also

IDeviceResolver Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Interface
Members See Also Send Feedback
Describes the event that occurred on the related published object, and contains the updated copy of this object.

This container is divided into two parts:

  • Header Details the event information.
  • BodyCopy of the published object.
Note: Make sure that you use the returned object copy to update accordingly your application and in further calls to Enterprise SDK methods. Do not keep a reference on a deprecated copy: if a new event occurs

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEnvelope<T> : IShallowCopy<IEnvelope<T>>,
    IDeepCopy<IEnvelope<T>>
Visual Basic (Declaration)
Public Interface IEnvelope(Of T) _
    Implements IShallowCopy(Of IEnvelope(Of T)), IDeepCopy(Of IEnvelope(Of T))
Visual C++
generic<typename T>
public interface class IEnvelope : IShallowCopy<IEnvelope<T>^>,
    IDeepCopy<IEnvelope<T>^>

Type Parameters

T
Type of the published object.

Remarks

To receive events, your application must register a callback method with the service. For instance, see the IChannelService description to read an example of callback registration on a given channel.

See Also

IEnvelope<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Members
IEnvelope<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Body | Returns the copy of the published object.
EnvelopeState | Status of this envelope.
Header | Details the event information.

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Methods
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IEnvelope(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>) Properties
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback

The IEnvelope<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Body | Returns the copy of the published object.
EnvelopeState | Status of this envelope.
Header | Details the event information.

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Body Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.Body Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Returns the copy of the published object.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T Body { get; }
Visual Basic (Declaration)
ReadOnly Property Body As T
Visual C++
property T Body {
    T get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


EnvelopeState Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.EnvelopeState Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Status of this envelope.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
EnvelopeStateType EnvelopeState { get; }
Visual Basic (Declaration)
ReadOnly Property EnvelopeState As EnvelopeStateType
Visual C++
property EnvelopeStateType EnvelopeState {
    EnvelopeStateType get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Header Property

[image]

Enterprise SDK 8.0 Reference API
IEnvelope<(Of <(T>)>)..::.Header Property
IEnvelope<(Of <(T>)>) Interface See Also Send Feedback
Details the event information.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IHeader Header { get; }
Visual Basic (Declaration)
ReadOnly Property Header As IHeader
Visual C++
property IHeader^ Header {
    IHeader^ get ();
}

See Also

IEnvelope<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Interface

[image]

Enterprise SDK 8.0 Reference API
IHeader Interface
Members See Also Send Feedback
Describes the event which occurred on a published object. This interface details what happened to this object (modification if State value is 0, else this is an error) and provides its context as the list of the related protocol messages which resulted in this E-SDK event.
  • The last protocol message is available in CurrentContext.
  • Other related messages are available in the ContextByIndex(Int32).

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IHeader : IShallowCopy<IHeader>,
    IDeepCopy<IHeader>
Visual Basic (Declaration)
Public Interface IHeader _
    Implements IShallowCopy(Of IHeader), IDeepCopy(Of IHeader)
Visual C++
public interface class IHeader : IShallowCopy<IHeader^>,
    IDeepCopy<IHeader^>

See Also

IHeader Members
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Members

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Members
IHeader Interface Methods Properties See Also Send Feedback

The IHeader type exposes the following members.

Methods

Name | Description
ContextByIndex | Returns the related protocol message with the given index.
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name Description
CorrelationId
ID of the request associated with this event.
CorrelatorData
Get the related customer defined information
Count
Number of protocol messages associated with this event message.
CurrentContext
Returns the context of the last protocol message.
Message
Error message if State > 0.
SourceName
Name of the source object which published the event.
SourceUid
FQName of the source object which published the event.
State
Event state.
  • State=0: modification.
  • State>0: error code

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Methods
IHeader Interface See Also Send Feedback

The IHeader type exposes the following members.

Methods

Name | Description
ContextByIndex | Returns the related protocol message with the given index.
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


ContextByIndex Method

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.ContextByIndex Method
IHeader Interface See Also Send Feedback
Returns the related protocol message with the given index.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IPayLoadContext ContextByIndex(
    int index
)
Visual Basic (Declaration)
Function ContextByIndex ( _
    index As Integer _
) As IPayLoadContext
Visual C++
IPayLoadContext^ ContextByIndex(
    int index
)

Parameters

index
Type: System..::.Int32
Index of the message (range: 0-count)

Return Value

the IPayLoadContext that contains the message.

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IHeader Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IHeader Properties
IHeader Interface See Also Send Feedback

The IHeader type exposes the following members.

Properties

Name Description
CorrelationId
ID of the request associated with this event.
CorrelatorData
Get the related customer defined information
Count
Number of protocol messages associated with this event message.
CurrentContext
Returns the context of the last protocol message.
Message
Error message if State > 0.
SourceName
Name of the source object which published the event.
SourceUid
FQName of the source object which published the event.
State
Event state.
  • State=0: modification.
  • State>0: error code

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CorrelationId Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CorrelationId Property
IHeader Interface See Also Send Feedback
ID of the request associated with this event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int CorrelationId { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelationId As Integer
Visual C++
property int CorrelationId {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CorrelatorData Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CorrelatorData Property
IHeader Interface See Also Send Feedback
Get the related customer defined information

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CorrelatorData { get; }
Visual Basic (Declaration)
ReadOnly Property CorrelatorData As String
Visual C++
property String^ CorrelatorData {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Count Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.Count Property
IHeader Interface See Also Send Feedback
Number of protocol messages associated with this event message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer
Visual C++
property int Count {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


CurrentContext Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.CurrentContext Property
IHeader Interface See Also Send Feedback
Returns the context of the last protocol message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IPayLoadContext CurrentContext { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentContext As IPayLoadContext
Visual C++
property IPayLoadContext^ CurrentContext {
    IPayLoadContext^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Message Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.Message Property
IHeader Interface See Also Send Feedback
Error message if State > 0.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Message { get; }
Visual Basic (Declaration)
ReadOnly Property Message As String
Visual C++
property String^ Message {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


SourceName Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.SourceName Property
IHeader Interface See Also Send Feedback
Name of the source object which published the event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SourceName { get; }
Visual Basic (Declaration)
ReadOnly Property SourceName As String
Visual C++
property String^ SourceName {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


SourceUid Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.SourceUid Property
IHeader Interface See Also Send Feedback
FQName of the source object which published the event.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SourceUid { get; }
Visual Basic (Declaration)
ReadOnly Property SourceUid As String
Visual C++
property String^ SourceUid {
    String^ get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IHeader..::.State Property
IHeader Interface See Also Send Feedback
Event state.
  • State=0: modification.
  • State>0: error code

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int State { get; }
Visual Basic (Declaration)
ReadOnly Property State As Integer
Visual C++
property int State {
    int get ();
}

See Also

IHeader Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Interface

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Interface
Members See Also Send Feedback
Describes an event and its associated event/request protocol message (msg).

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPayLoadContext : IShallowCopy<IPayLoadContext>,
    IDeepCopy<IPayLoadContext>
Visual Basic (Declaration)
Public Interface IPayLoadContext _
    Implements IShallowCopy(Of IPayLoadContext), IDeepCopy(Of IPayLoadContext)
Visual C++
public interface class IPayLoadContext : IShallowCopy<IPayLoadContext^>,
    IDeepCopy<IPayLoadContext^>

See Also

IPayLoadContext Members
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Members
IPayLoadContext Interface Methods Properties See Also Send Feedback

The IPayLoadContext type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name Description
ContextState
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error
msg
Returns the raw associated PSDK EVENT message.
RawRequest
Returns the raw associated PSDK REQUEST message.
Reason
Returns the reason of this event update.
TimeStamp
Returns the time stamp of the object creation.

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Methods
IPayLoadContext Interface See Also Send Feedback

The IPayLoadContext type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


IPayLoadContext Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IPayLoadContext Properties
IPayLoadContext Interface See Also Send Feedback

The IPayLoadContext type exposes the following members.

Properties

Name Description
ContextState
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error
msg
Returns the raw associated PSDK EVENT message.
RawRequest
Returns the raw associated PSDK REQUEST message.
Reason
Returns the reason of this event update.
TimeStamp
Returns the time stamp of the object creation.

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


ContextState Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.ContextState Property
IPayLoadContext Interface See Also Send Feedback
Returns the state type of this event:
  • Unknown
  • Created
  • Updated
  • Merged
  • Deleted
  • Error

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ContextStateType ContextState { get; }
Visual Basic (Declaration)
ReadOnly Property ContextState As ContextStateType
Visual C++
property ContextStateType ContextState {
    ContextStateType get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


msg Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.msg Property
IPayLoadContext Interface See Also Send Feedback
Returns the raw associated PSDK EVENT message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IMessage msg { get; }
Visual Basic (Declaration)
ReadOnly Property msg As IMessage
Visual C++
property IMessage^ msg {
    IMessage^ get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


RawRequest Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.RawRequest Property
IPayLoadContext Interface See Also Send Feedback
Returns the raw associated PSDK REQUEST message.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IMessage RawRequest { get; }
Visual Basic (Declaration)
ReadOnly Property RawRequest As IMessage
Visual C++
property IMessage^ RawRequest {
    IMessage^ get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Reason Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.Reason Property
IPayLoadContext Interface See Also Send Feedback
Returns the reason of this event update.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ReasonTypes Reason { get; }
Visual Basic (Declaration)
ReadOnly Property Reason As ReasonTypes
Visual C++
property ReasonTypes Reason {
    ReasonTypes get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


TimeStamp Property

[image]

Enterprise SDK 8.0 Reference API
IPayLoadContext..::.TimeStamp Property
IPayLoadContext Interface See Also Send Feedback
Returns the time stamp of the object creation.

Namespace: Genesyslab.Enterprise.Model.Envelope
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
long TimeStamp { get; }
Visual Basic (Declaration)
ReadOnly Property TimeStamp As Long
Visual C++
property long long TimeStamp {
    long long get ();
}

See Also

IPayLoadContext Interface
Genesyslab.Enterprise.Model.Envelope Namespace


Genesyslab.Enterprise.Model.Identity Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Identity Namespace
Send Feedback

Interfaces

Interface | Description
IAlias | Describes an alias associated with an identity.
IAliasManager | Manages the aliases of an existing identity.
ICredential | Describes credentials.
IEntity | Describes a person as an entity (first name, last name, IDs) with associated business values.
IIdentity | Describes an identity.
IIdentityType | Identity type.

Enumerations

Enumeration | Description
WorkMode | Describes the agent's workmode.


IAlias Interface

[image]

Enterprise SDK 8.0 Reference API
IAlias Interface
Members See Also Send Feedback
Describes an alias associated with an identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAlias
Visual Basic (Declaration)
Public Interface IAlias
Visual C++
public interface class IAlias

See Also

IAlias Members
Genesyslab.Enterprise.Model.Identity Namespace


IAlias Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAlias Members
IAlias Interface Properties See Also Send Feedback

The IAlias type exposes the following members.

Properties

Name | Description
Name | Alias name.

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAlias Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAlias Properties
IAlias Interface See Also Send Feedback

The IAlias type exposes the following members.

Properties

Name | Description
Name | Alias name.

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IAlias..::.Name Property
IAlias Interface See Also Send Feedback
Alias name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IAlias Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Interface

[image]

Enterprise SDK 8.0 Reference API
IAliasManager Interface
Members See Also Send Feedback
Manages the aliases of an existing identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAliasManager
Visual Basic (Declaration)
Public Interface IAliasManager
Visual C++
public interface class IAliasManager

See Also

IAliasManager Members
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager Members
IAliasManager Interface Methods See Also Send Feedback

The IAliasManager type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias.
ListAliases | Returns the list of aliases asscoiated with the given identity.
LookupByAlias | Searches for an alias.
RemoveAlias | Overloaded.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


IAliasManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager Methods
IAliasManager Interface See Also Send Feedback

The IAliasManager type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias.
ListAliases | Returns the list of aliases asscoiated with the given identity.
LookupByAlias | Searches for an alias.
RemoveAlias | Overloaded.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


AddAlias Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.AddAlias Method
IAliasManager Interface See Also Send Feedback
Adds an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAliasManager AddAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function AddAlias ( _
    identityAlias As IAlias _
) As IAliasManager
Visual C++
IAliasManager^ AddAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias
the alias to add.

Return Value

the IAliasManager.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


ListAliases Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.ListAliases Method
IAliasManager Interface See Also Send Feedback
Returns the list of aliases asscoiated with the given identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAlias[] ListAliases(
    string name
)
Visual Basic (Declaration)
Function ListAliases ( _
    name As String _
) As IAlias()
Visual C++
array<IAlias^>^ ListAliases(
    String^ name
)

Parameters

name
Type: System..::.String
the identity name.

Return Value

the list of aliases associated with the given identity.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


LookupByAlias Method

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.LookupByAlias Method
IAliasManager Interface See Also Send Feedback
Searches for an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity LookupByAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function LookupByAlias ( _
    identityAlias As IAlias _
) As IIdentity
Visual C++
IIdentity^ LookupByAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias
the alias to lookup.

Return Value

returns the identity associated with the alias.

See Also

IAliasManager Interface
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method
IAliasManager Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias.
RemoveAlias(String) | Removes an alias.

See Also

IAliasManager Interface
IAliasManager Members
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method (IAlias)

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method (IAlias)
IAliasManager Interface See Also Send Feedback
Removes an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAliasManager RemoveAlias(
    IAlias identityAlias
)
Visual Basic (Declaration)
Function RemoveAlias ( _
    identityAlias As IAlias _
) As IAliasManager
Visual C++
IAliasManager^ RemoveAlias(
    IAlias^ identityAlias
)

Parameters

identityAlias
Type: Genesyslab.Enterprise.Model.Identity..::.IAlias
the alias to remove.

Return Value

the IAliasManager.

See Also

IAliasManager Interface
RemoveAlias Overload
Genesyslab.Enterprise.Model.Identity Namespace


RemoveAlias Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAliasManager..::.RemoveAlias Method (String)
IAliasManager Interface See Also Send Feedback
Removes an alias.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAliasManager RemoveAlias(
    string identityAlias
)
Visual Basic (Declaration)
Function RemoveAlias ( _
    identityAlias As String _
) As IAliasManager
Visual C++
IAliasManager^ RemoveAlias(
    String^ identityAlias
)

Parameters

identityAlias
Type: System..::.String
the alias to remove.

Return Value

the IAliasManager.

See Also

IAliasManager Interface
RemoveAlias Overload
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Interface

[image]

Enterprise SDK 8.0 Reference API
ICredential Interface
Members See Also Send Feedback
Describes credentials.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICredential
Visual Basic (Declaration)
Public Interface ICredential
Visual C++
public interface class ICredential

See Also

ICredential Members
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICredential Members
ICredential Interface Properties See Also Send Feedback

The ICredential type exposes the following members.

Properties

Name | Description
Password | Password.

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


ICredential Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICredential Properties
ICredential Interface See Also Send Feedback

The ICredential type exposes the following members.

Properties

Name | Description
Password | Password.

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


Password Property

[image]

Enterprise SDK 8.0 Reference API
ICredential..::.Password Property
ICredential Interface See Also Send Feedback
Password.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Password { get; set; }
Visual Basic (Declaration)
Property Password As String
Visual C++
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

ICredential Interface
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Interface

[image]

Enterprise SDK 8.0 Reference API
IEntity Interface
Members See Also Send Feedback
Describes a person as an entity (first name, last name, IDs) with associated business values.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEntity
Visual Basic (Declaration)
Public Interface IEntity
Visual C++
public interface class IEntity

See Also

IEntity Members
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEntity Members
IEntity Interface Properties See Also Send Feedback

The IEntity type exposes the following members.

Properties

Name | Description
Agent | Returns the agent IDs associated with this person.
Attributes | Entity attributes.
Email | Returns the person's e-mail.
EmployeeId | Returns the employee ID of this person.
ExternalUserId | Returns the external user ID.
FirstName | Returns the first name of this person.
FQName | Fully Qualified Name associated with the object instance.
IsAgent | Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.
IsEnabled | Returns true if this person is activated in the Configuration Layer.
LastName | Returns the last name of this person.
UserName | Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IEntity Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEntity Properties
IEntity Interface See Also Send Feedback

The IEntity type exposes the following members.

Properties

Name | Description
Agent | Returns the agent IDs associated with this person.
Attributes | Entity attributes.
Email | Returns the person's e-mail.
EmployeeId | Returns the employee ID of this person.
ExternalUserId | Returns the external user ID.
FirstName | Returns the first name of this person.
FQName | Fully Qualified Name associated with the object instance.
IsAgent | Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.
IsEnabled | Returns true if this person is activated in the Configuration Layer.
LastName | Returns the last name of this person.
UserName | Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Agent Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Agent Property
IEntity Interface See Also Send Feedback
Returns the agent IDs associated with this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IIdentity> Agent { get; }
Visual Basic (Declaration)
ReadOnly Property Agent As ICollection(Of IIdentity)
Visual C++
property ICollection<IIdentity^>^ Agent {
    ICollection<IIdentity^>^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Attributes Property
IEntity Interface See Also Send Feedback
Entity attributes.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Email Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.Email Property
IEntity Interface See Also Send Feedback
Returns the person's e-mail.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Email { get; }
Visual Basic (Declaration)
ReadOnly Property Email As String
Visual C++
property String^ Email {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


EmployeeId Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.EmployeeId Property
IEntity Interface See Also Send Feedback
Returns the employee ID of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string EmployeeId { get; }
Visual Basic (Declaration)
ReadOnly Property EmployeeId As String
Visual C++
property String^ EmployeeId {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


ExternalUserId Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.ExternalUserId Property
IEntity Interface See Also Send Feedback
Returns the external user ID.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ExternalUserId { get; }
Visual Basic (Declaration)
ReadOnly Property ExternalUserId As String
Visual C++
property String^ ExternalUserId {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FirstName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.FirstName Property
IEntity Interface See Also Send Feedback
Returns the first name of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FirstName { get; }
Visual Basic (Declaration)
ReadOnly Property FirstName As String
Visual C++
property String^ FirstName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.FQName Property
IEntity Interface See Also Send Feedback
Fully Qualified Name associated with the object instance.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IsAgent Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.IsAgent Property
IEntity Interface See Also Send Feedback
Returns true if this Person is an agent. In this case, the object can be casted onto {@link Agent} in order to access agent-related methods.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsAgent { get; }
Visual Basic (Declaration)
ReadOnly Property IsAgent As Boolean
Visual C++
property bool IsAgent {
    bool get ();
}

Return Value

bool

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IsEnabled Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.IsEnabled Property
IEntity Interface See Also Send Feedback
Returns true if this person is activated in the Configuration Layer.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsEnabled { get; }
Visual Basic (Declaration)
ReadOnly Property IsEnabled As Boolean
Visual C++
property bool IsEnabled {
    bool get ();
}

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


LastName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.LastName Property
IEntity Interface See Also Send Feedback
Returns the last name of this person.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string LastName { get; }
Visual Basic (Declaration)
ReadOnly Property LastName As String
Visual C++
property String^ LastName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


UserName Property

[image]

Enterprise SDK 8.0 Reference API
IEntity..::.UserName Property
IEntity Interface See Also Send Feedback
Returns the user name of this person. The user name is another name for the ID. Returns the same value than GetUID.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string UserName { get; }
Visual Basic (Declaration)
ReadOnly Property UserName As String
Visual C++
property String^ UserName {
    String^ get ();
}

Return Value

string

See Also

IEntity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentity Interface
Members See Also Send Feedback
Describes an identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIdentity : IRoleable,
    ISerializable
Visual Basic (Declaration)
Public Interface IIdentity _
    Implements IRoleable, ISerializable
Visual C++
public interface class IIdentity : IRoleable,
    ISerializable

See Also

IIdentity Members
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Members
IIdentity Interface Methods Properties See Also Send Feedback

The IIdentity type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
HasAgentInfo | Report if a device contains some agent data

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity.
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device
FQName | Fully Qualified Name (Unique ID for this object).
Group | Groups of identities.
IdentityBase | Gets the Base identity of this identity.
Name | Identity name.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity.

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Methods
IIdentity Interface See Also Send Feedback

The IIdentity type exposes the following members.

Methods

Name | Description
Controller | Overloaded.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
HasAgentInfo | Report if a device contains some agent data

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method
IIdentity Interface See Also Send Feedback

Overload List

Name | Description
Controller()()() | Gets the Controller of this object.
Controller(String) | Gets the Controller of this object.

See Also

IIdentity Interface
IIdentity Members
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method
IIdentity Interface See Also Send Feedback
Gets the Controller of this object.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Controller()
Visual Basic (Declaration)
Function Controller As Object
Visual C++
Object^ Controller()

Return Value

an object for the controller.

See Also

IIdentity Interface
Controller Overload
Genesyslab.Enterprise.Model.Identity Namespace


Controller Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Controller Method (String)
IIdentity Interface See Also Send Feedback
Gets the Controller of this object.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Controller(
    string deviceName
)
Visual Basic (Declaration)
Function Controller ( _
    deviceName As String _
) As Object
Visual C++
Object^ Controller(
    String^ deviceName
)

Parameters

deviceName
Type: System..::.String
the name of the device.

Return Value

an object for the controller.

See Also

IIdentity Interface
Controller Overload
Genesyslab.Enterprise.Model.Identity Namespace


HasAgentInfo Method

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.HasAgentInfo Method
IIdentity Interface See Also Send Feedback
Report if a device contains some agent data

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool HasAgentInfo(
    IDevice device
)
Visual Basic (Declaration)
Function HasAgentInfo ( _
    device As IDevice _
) As Boolean
Visual C++
bool HasAgentInfo(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Model.Identity.IIdentity.HasAgentInfo(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

bool

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentity Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentity Properties
IIdentity Interface See Also Send Feedback

The IIdentity type exposes the following members.

Properties

Name | Description
Attributes | Dynamic and static data defined for this identity.
Devices | Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device
FQName | Fully Qualified Name (Unique ID for this object).
Group | Groups of identities.
IdentityBase | Gets the Base identity of this identity.
Name | Identity name.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)
Strategy | Strategies for this identity.

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Attributes Property
IIdentity Interface See Also Send Feedback
Dynamic and static data defined for this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Attributes {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Devices Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Devices Property
IIdentity Interface See Also Send Feedback
Collection of associated devices (single or groups). Use IdentityService.SetDevice to associate Device

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDevice> Devices { get; }
Visual Basic (Declaration)
ReadOnly Property Devices As IDictionary(Of String, IDevice)
Visual C++
property IDictionary<String^, IDevice^>^ Devices {
    IDictionary<String^, IDevice^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.FQName Property
IIdentity Interface See Also Send Feedback
Fully Qualified Name (Unique ID for this object).

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Group Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Group Property
IIdentity Interface See Also Send Feedback
Groups of identities.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IIdentity> Group { get; }
Visual Basic (Declaration)
ReadOnly Property Group As IDictionary(Of String, IIdentity)
Visual C++
property IDictionary<String^, IIdentity^>^ Group {
    IDictionary<String^, IIdentity^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IdentityBase Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.IdentityBase Property
IIdentity Interface See Also Send Feedback
Gets the Base identity of this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity IdentityBase { get; }
Visual Basic (Declaration)
ReadOnly Property IdentityBase As IIdentity
Visual C++
property IIdentity^ IdentityBase {
    IIdentity^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Name Property
IIdentity Interface See Also Send Feedback
Identity name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IIdentity..::.Strategy Property
IIdentity Interface See Also Send Feedback
Strategies for this identity.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IIdentity Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityType Interface
Members See Also Send Feedback
Identity type.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIdentityType
Visual Basic (Declaration)
Public Interface IIdentityType
Visual C++
public interface class IIdentityType

See Also

IIdentityType Members
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityType Members
IIdentityType Interface Properties See Also Send Feedback

The IIdentityType type exposes the following members.

Properties

Name | Description
Name | Type name.

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


IIdentityType Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityType Properties
IIdentityType Interface See Also Send Feedback

The IIdentityType type exposes the following members.

Properties

Name | Description
Name | Type name.

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IIdentityType..::.Name Property
IIdentityType Interface See Also Send Feedback
Type name.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IIdentityType Interface
Genesyslab.Enterprise.Model.Identity Namespace


WorkMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
WorkMode Enumeration
See Also Send Feedback
Describes the agent's workmode.

Namespace: Genesyslab.Enterprise.Model.Identity
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum WorkMode
Visual Basic (Declaration)
Public Enumeration WorkMode
Visual C++
public enum class WorkMode

Members

Member name | Description
Unknown | Unknown.
ManualIn | Manual in.
AutoIn | Auto in.
LegalGuard | Legar guard.
AfterCallWork | After call work.
AuxWork | Auxiliary work.
NoCallDisconnect | No call disconnect.
WalkAway | Walk away (absent).
ReturnBack | Return back.

See Also

Genesyslab.Enterprise.Model.Identity Namespace


Genesyslab.Enterprise.Model.Interaction Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Interaction Namespace
Send Feedback

Interfaces

Interface Description
IAttributeDataManager<(Of <(T>)>)
Manages attribute data.
ICallbackInteraction
Describes a callback request interaction.
ICampaign
Describes an outbound Campaign.

The outbound campaign sets up a list of outbound chains and records which are processed by the agents registered for the given campaign. To get details about the registration, see ICampaignService.

The campaign dialing modes determine how an agent, or a group of agents, participates in an outbound campaign. This affects the outbound event flow, and also agent actions to be performed when participating in the campaign. For details about the campaign modes, see CampaignMode.

To access outbound campaign, you deal with the ICampaignService. This service enables you to register listeners for getting events about current campaigns, and access to IChainRecord objects with the outbound service ICampaignService.

IChainRecord
Describes a chained records object associated with a given interaction.

The chained records contain contact information used to process the outbound interaction.

You can use the GetChainRecord(IInteraction) method to retrieve the chain associated with a given interaction or to check whether this interaction is part of a progressive or predictive campaign.

Remarks

In ASM mode, when your application receives the outbound interaction, the contact is not known yet. The application receives records later when getting an interaction event for ATTACHED DATA CHANGED. When getting this event, your application should retrieve the ChainRecord by calling the GetChainRecord(IInteraction) method.
IChatInteraction
Describes a chat interaction. The chat interaction handles the chat instant messaging session. Chat messages and notification about chat parties are available through Transcript.
IEmailInteraction
Describes an e-mail interaction.
IExtension
Describes the interaction's extension.
IIMEvent
Describes a new event during an instant messaging session.
IIMInteraction
Describes an Instant Messaging session.
IIMMessage
Represents a message during an Instant Messaging session.
IIMParty
Represents a party of the Instant Messaging session.
IIMPartyJoined
Occurs during an Instant Messaging session if a party joined.
IIMPartyLeft
Occurs during an Instant Messaging session if a party left.
IIMPartyReenter
Occurs during an Instant Messaging session if a party reentered.
IIMTranscript
Represents the update of the transcript in an Instant Messaging session.
IInteraction
Describes an interaction.
IInteractionQueueSnapshot
Describes an interaction queue snapshot.
IInteractionType
Describes the interaction type:
  • Media content.
  • Media direction.
  • The interaction's subtype.
  • Internality.
IMonitoredInfo
IMonitoredInteraction
IOpenMediaInteraction
Describes an open media interaction.
IOutboundField
Describes a CustomField (from Configuration).
IOutboundPreviewInteraction
Describes an outbound interaction.
IParty
Describes one party of a device or a call.
IPreviewInteraction
Describes a preview interaction.
IRecord
Describes a Record.
  • Added
  • Cancelled
  • Do Not Call
  • Updated
  • Rescheduled
ISMSInfo
Interface for SMS data container
ISMSInteraction
Describes an SMS interaction.
IWorkbin
Describes a Workbin.

Enumerations

Enumeration | Description
ActorType | Enumerates the actor types for workbins.
CallbackStatus |
CallbackType |
CampaignMode | Enumerates for the campaign mode. for further details, refer to the Outbound Contact 8.1 Deployment Guide.
CampaignState | Enumerates for the campaign state.
ContextStateType | State of the Interaction Context.
EncodingType | SMS encoding schemes supported
InteractionOperation | Enumerates the operations which modify the interactions in the workbin.
InteractionStateType | Lists the possible types for interactions state.
IxnServerInteractionState | Enumerates the profile types.
MakeCallType | Enumerates the possible call types for voice interactions.
MediaContentType | Enumerates the media content types.
MonitorState |
PartyInfoType | Enumerates the party types.
PartyTranslationType |
ProfileType | Enumerates the profile types.
ReasonTypes |
WorkbinOperation | Enumerates the operations which modify the workbin.


ActorType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ActorType Enumeration
See Also Send Feedback
Enumerates the actor types for workbins.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ActorType
Visual Basic (Declaration)
Public Enumeration ActorType
Visual C++
public enum class ActorType

Members

Member name | Description
Strategy | Strategy Actor.
Agent | Agent Actor.
MediaServer | MediaServer.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


CallbackStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
CallbackStatus Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.CallbackStatus"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum CallbackStatus
Visual Basic (Declaration)
Public Enumeration CallbackStatus
Visual C++
public enum class CallbackStatus

Members

Member name | Description
ACTIVE |
COMPLETED |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


CallbackType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CallbackType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.CallbackType"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum CallbackType
Visual Basic (Declaration)
Public Enumeration CallbackType
Visual C++
public enum class CallbackType

Members

Member name | Description
ASAP |
SCHEDULED |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


CampaignMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
CampaignMode Enumeration
See Also Send Feedback
Enumerates for the campaign mode. for further details, refer to the Outbound Contact 8.1 Deployment Guide.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum CampaignMode
Visual Basic (Declaration)
Public Enumeration CampaignMode
Visual C++
public enum class CampaignMode

Members

Member name | Description
PREVIEW | The Campaign mode is Preview. In preview dialing mode, an agent requests one or several records from the OCS, previews the record(s), and decides to process one of them by creating a new outbound interaction.
PREDICTIVE | The Campaign mode is Predictive. The OCS predicts agent availability and dials a record. Your agent application gets a dialing outbound voice interaction and an outbound chain.
PROGRESSIVE | The Campaign mode is Progressive. The OCS dials a record in the list as soon as an agent is available.
ENGAGED_PREDICTIVE | The Campaign mode is Engaged Predictive. The OCS predicts when the agent is available and engaged, and creates a dialing outbound voice interaction to dial a record in the list.Your agent application gets a dialing outbound voice interaction and an outbound chain.
ENGAGED_PROGRESSIVE | The Campaign mode is Engaged Progressive. The OCS creates a voice interaction to dial a record in the list when an agent is available and engaged. Your agent application gets a dialing outbound voice interaction and an outbound chain.
POWER | The Campaign mode is Power.
PUSH_PREVIEW | The Campaign mode is Push Preview. (Also called proactive) In push preview mode, the agent does not need to request the record to preview the record. He or she gets this and subsequent records through a new open media interaction. To process the record, the agent creates a new outbound interaction.
ENGAGED_POWER | The Campaign mode is Engaged Power.
PROGRESSIVE_GVP | The Campaign mode is Progressive GVP. This is one of the two proactive Contact Dialing Modes. The predictive algorithm calculates the number of dial requests (dialing or established) as the total number of ports available for the Campaign Group. It may be restricted by the Number of CPD Ports property of the Campaign Group. The total number of ports is equal to the total ports configured for the Campaign Group trunk group as reported by SIP Server.
PREDICTIVE_GVP | The Campaign mode is Predictive GVP.
POWER_GVP | The Campaign mode is Power GVP. This is one of the two proactive Contact Dialing Modes. The predictive algorithm calculates the number of dial requests (dialing or established) using the Campaign Group Max Queue Size parameter.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


CampaignState Enumeration

[image]

Enterprise SDK 8.0 Reference API
CampaignState Enumeration
See Also Send Feedback
Enumerates for the campaign state.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum CampaignState
Visual Basic (Declaration)
Public Enumeration CampaignState
Visual C++
public enum class CampaignState

Members

Member name | Description
ACTIVE | The campaign is Active.
RUNNING | The campaign is Running.
STOPPED | The campaign is Stopped.
UNKNOWN | The campaign state is Unknown.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ContextStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ContextStateType Enumeration
See Also Send Feedback
State of the Interaction Context.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ContextStateType
Visual Basic (Declaration)
Public Enumeration ContextStateType
Visual C++
public enum class ContextStateType

Members

Member name | Description
Unknown | Unknown state of the context.
Created | The context is created.
Updated | The context is updated.
Merged | The context is merged with another context (conference).
Deleted | The context is deleted.
Error | Error state of the context.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


EncodingType Enumeration

[image]

Enterprise SDK 8.0 Reference API
EncodingType Enumeration
See Also Send Feedback
SMS encoding schemes supported

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum EncodingType
Visual Basic (Declaration)
Public Enumeration EncodingType
Visual C++
public enum class EncodingType

Members

Member name | Description
Unknown | Encoding not known
UTF7 | 7 bits encoding
UTF8 | 8 bits encoding
UCS2 | 16 bits encoding

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Manages attribute data.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAttributeDataManager<T>
Visual Basic (Declaration)
Public Interface IAttributeDataManager(Of T)
Visual C++
generic<typename T>
public interface class IAttributeDataManager

Type Parameters

T
The type of the data.

See Also

IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Members
IAttributeDataManager<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
AddElement | Overloaded.
AllValues | All the values.
ContainsKey | True if contains the given key.
GetAsPSDKCollection | Returns this manager's content as a Platform SDK collection.
GetElementAsBinary | Returns the element associated with the given key as a byte array.
GetElementAsCollection | Returns the element associated with the given key as a collection.
GetElementAsDynamicAttribute | Overloaded.
GetElementAsInt | Returns the element associated with the given key as int.
GetElementAsObject | Returns the element associated with the given key as an object.
GetElementAsString | Returns the element associated with the given key as a string.
GetElementType | Returns the type for the element associated with the given key.
IsElementACollection | Overloaded.
IsSynchronized | True if the manager is synchronized.
RemoveAll | Removes all the elements.
RemoveElement | Removes the element associated with the given key.
SetElement | Overloaded.
SetElementAsDynamicAttribute | Overloaded.

Properties

Name | Description
AllKeys | All the keys.
Item | Overloaded.
Owner | Returns the owner of this object.
Section | Returns the section name.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Methods
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
AddElement | Overloaded.
AllValues | All the values.
ContainsKey | True if contains the given key.
GetAsPSDKCollection | Returns this manager's content as a Platform SDK collection.
GetElementAsBinary | Returns the element associated with the given key as a byte array.
GetElementAsCollection | Returns the element associated with the given key as a collection.
GetElementAsDynamicAttribute | Overloaded.
GetElementAsInt | Returns the element associated with the given key as int.
GetElementAsObject | Returns the element associated with the given key as an object.
GetElementAsString | Returns the element associated with the given key as a string.
GetElementType | Returns the type for the element associated with the given key.
IsElementACollection | Overloaded.
IsSynchronized | True if the manager is synchronized.
RemoveAll | Removes all the elements.
RemoveElement | Removes the element associated with the given key.
SetElement | Overloaded.
SetElementAsDynamicAttribute | Overloaded.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AddElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AddElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
AddElement(IDynamicAttribute) | Add a new element (may be already existing).
AddElement(String, IAttributeDataManager<(Of <(T>)>)) | Add a new element (may be already existing).

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


AddElement Method (IDynamicAttribute)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AddElement Method (IDynamicAttribute)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Add a new element (may be already existing).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> AddElement(
    IDynamicAttribute value
)
Visual Basic (Declaration)
Function AddElement ( _
    value As IDynamicAttribute _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ AddElement(
    IDynamicAttribute^ value
)

Parameters

value
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IDynamicAttribute
the value of the dynamic attribute to add.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
AddElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


AddElement Method (String, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AddElement Method (String, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Add a new element (may be already existing).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> AddElement(
    string key,
    IAttributeDataManager<T> list
)
Visual Basic (Declaration)
Function AddElement ( _
    key As String, _
    list As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ AddElement(
    String^ key,
    IAttributeDataManager<T>^ list
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute to add.
list
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)
the list of attributes.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
AddElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


AllValues Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AllValues Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
All the values.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T[] AllValues()
Visual Basic (Declaration)
Function AllValues As T()
Visual C++
array<T>^ AllValues()

Return Value

All the values as an array.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContainsKey Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.ContainsKey Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if contains the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ContainsKey(
    string key
)
Visual Basic (Declaration)
Function ContainsKey ( _
    key As String _
) As Boolean
Visual C++
bool ContainsKey(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

True if contains the given key.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetAsPSDKCollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetAsPSDKCollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns this manager's content as a Platform SDK collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection GetAsPSDKCollection()
Visual Basic (Declaration)
Function GetAsPSDKCollection As KeyValueCollection
Visual C++
KeyValueCollection^ GetAsPSDKCollection()

Return Value

the KeyValueCollection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsBinary Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsBinary Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a byte array.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
byte[] GetElementAsBinary(
    string key
)
Visual Basic (Declaration)
Function GetElementAsBinary ( _
    key As String _
) As Byte()
Visual C++
array<unsigned char>^ GetElementAsBinary(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as a byte array.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsCollection Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsCollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> GetElementAsCollection(
    string key
)
Visual Basic (Declaration)
Function GetElementAsCollection ( _
    key As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ GetElementAsCollection(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as an IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetElementAsDynamicAttribute(Int32) | Returns the element associated with the given index as a dynamic attribute.
GetElementAsDynamicAttribute(String) | Returns the element associated with the given key as a dynamic attribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method (Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given index as a dynamic attribute.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T GetElementAsDynamicAttribute(
    int key
)
Visual Basic (Declaration)
Function GetElementAsDynamicAttribute ( _
    key As Integer _
) As T
Visual C++
T GetElementAsDynamicAttribute(
    int key
)

Parameters

key
Type: System..::.Int32
the index of the dynamic attribute.

Return Value

The element as DynamicAttribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
GetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsDynamicAttribute Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsDynamicAttribute Method (String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a dynamic attribute.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T GetElementAsDynamicAttribute(
    string key
)
Visual Basic (Declaration)
Function GetElementAsDynamicAttribute ( _
    key As String _
) As T
Visual C++
T GetElementAsDynamicAttribute(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

The element as DynamicAttribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
GetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsInt Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsInt Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as int.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> GetElementAsInt(
    string key
)
Visual Basic (Declaration)
Function GetElementAsInt ( _
    key As String _
) As Nullable(Of Integer)
Visual C++
Nullable<int> GetElementAsInt(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as int.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsObject Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsObject Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as an object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetElementAsObject(
    string key
)
Visual Basic (Declaration)
Function GetElementAsObject ( _
    key As String _
) As Object
Visual C++
Object^ GetElementAsObject(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as a object.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementAsString Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementAsString Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the element associated with the given key as a string.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string GetElementAsString(
    string key
)
Visual Basic (Declaration)
Function GetElementAsString ( _
    key As String _
) As String
Visual C++
String^ GetElementAsString(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the element as a string.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetElementType Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.GetElementType Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the type for the element associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type GetElementType(
    string key
)
Visual Basic (Declaration)
Function GetElementType ( _
    key As String _
) As Type
Visual C++
Type^ GetElementType(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

The type of the element.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
IsElementACollection(Int32) | True if the value associated with the given index is a collection.
IsElementACollection(String) | True if the value associated with the given key is a collection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method (Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method (Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the value associated with the given index is a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsElementACollection(
    int index
)
Visual Basic (Declaration)
Function IsElementACollection ( _
    index As Integer _
) As Boolean
Visual C++
bool IsElementACollection(
    int index
)

Parameters

index
Type: System..::.Int32
the index of the dynamic attribute.

Return Value

True if the value associated with the given index is a collection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IsElementACollection Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IsElementACollection Method (String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsElementACollection Method (String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the value associated with the given key is a collection.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsElementACollection(
    string key
)
Visual Basic (Declaration)
Function IsElementACollection ( _
    key As String _
) As Boolean
Visual C++
bool IsElementACollection(
    String^ key
)

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

True if the value associated with the given key is a collection.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IsElementACollection Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IsSynchronized Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.IsSynchronized Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
True if the manager is synchronized.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsSynchronized(
    string key
)
Visual Basic (Declaration)
Function IsSynchronized ( _
    key As String _
) As Boolean
Visual C++
bool IsSynchronized(
    String^ key
)

Parameters

key
Type: System..::.String
the key.

Return Value

True if the manager is synchronized.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RemoveAll Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.RemoveAll Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Removes all the elements.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveAll()
Visual Basic (Declaration)
Sub RemoveAll
Visual C++
void RemoveAll()

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RemoveElement Method

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.RemoveElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Removes the element associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool RemoveElement(
    string key
)
Visual Basic (Declaration)
Function RemoveElement ( _
    key As String _
) As Boolean
Visual C++
bool RemoveElement(
    String^ key
)

Parameters

key
Type: System..::.String
the key to remove.

Return Value

True if the operation is successful.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
SetElement(T) | Sets an existing element.
SetElement(String, IAttributeDataManager<(Of <(T>)>)) | Sets an element.
SetElement(String, array<Byte>[]()[]) | Sets an element.
SetElement(String, Int32) | Sets an element.
SetElement(String, Object) | Sets an element.
SetElement(String, String) | Sets an element.
SetElement(String, array<Byte>[]()[], String, String) | Sets an element.
SetElement(String, Object, String, String) | Sets an element.
SetElement(String, String, String, String) | Sets an element.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (T)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (T)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an existing element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    T value
)
Visual Basic (Declaration)
Function SetElement ( _
    value As T _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    T value
)

Parameters

value
Type: T
the value to add.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    IAttributeDataManager<T> value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    IAttributeDataManager<T>^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Byte[])

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, array<Byte>[]()[])
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    byte[] value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Byte() _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    array<unsigned char>^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: array< System..::.Byte >[]()[]
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    int value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Integer _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    int value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Int32
the value as int.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Object)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Object _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Object
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    string value
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    String^ value
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.String
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Byte[], String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, array<Byte>[]()[], String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    byte[] value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Byte(), _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    array<unsigned char>^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: array< System..::.Byte >[]()[]
the value.
contentType
Type: System..::.String
the content type of the value.
contentTypeVersion
Type: System..::.String
the content type version.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, Object, String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, Object, String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    Object value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As Object, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    Object^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.Object
the value.
contentType
Type: System..::.String
the content type of the value.
contentTypeVersion
Type: System..::.String
the content type version.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElement Method (String, String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElement Method (String, String, String, String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElement(
    string key,
    string value,
    string contentType,
    string contentTypeVersion
)
Visual Basic (Declaration)
Function SetElement ( _
    key As String, _
    value As String, _
    contentType As String, _
    contentTypeVersion As String _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElement(
    String^ key,
    String^ value,
    String^ contentType,
    String^ contentTypeVersion
)

Parameters

key
Type: System..::.String
the key of the value.
value
Type: System..::.String
the value.
contentType
Type: System..::.String
the content type of the value.
contentTypeVersion
Type: System..::.String
the content type version.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElement Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElementAsDynamicAttribute Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute Method
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
SetElementAsDynamicAttribute(Int32, IAttributeDataManager<(Of <(T>)>)) | Sets a collection from index
SetElementAsDynamicAttribute(Int32, T) | Sets an element from index

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


SetElementAsDynamicAttribute Method (Int32, IAttributeDataManager(T))

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute Method (Int32, IAttributeDataManager<(Of <(T>)>))
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets a collection from index

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElementAsDynamicAttribute(
    int index,
    IAttributeDataManager<T> list
)
Visual Basic (Declaration)
Function SetElementAsDynamicAttribute ( _
    index As Integer, _
    list As IAttributeDataManager(Of T) _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElementAsDynamicAttribute(
    int index,
    IAttributeDataManager<T>^ list
)

Parameters

index
Type: System..::.Int32
the index.
list
Type: Genesyslab.Enterprise.Model.Interaction..::.IAttributeDataManager <(Of <( T >)>)
the list of dynamic attribute.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


SetElementAsDynamicAttribute Method (Int32, T)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.SetElementAsDynamicAttribute Method (Int32, T)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Sets an element from index

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttributeDataManager<T> SetElementAsDynamicAttribute(
    int index,
    T data
)
Visual Basic (Declaration)
Function SetElementAsDynamicAttribute ( _
    index As Integer, _
    data As T _
) As IAttributeDataManager(Of T)
Visual C++
IAttributeDataManager<T>^ SetElementAsDynamicAttribute(
    int index,
    T data
)

Parameters

index
Type: System..::.Int32
the index.
data
Type: T
the value.

Return Value

the IAttributeDataManager.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
SetElementAsDynamicAttribute Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IAttributeDataManager(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>) Properties
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

The IAttributeDataManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
AllKeys | All the keys.
Item | Overloaded.
Owner | Returns the owner of this object.
Section | Returns the section name.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AllKeys Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.AllKeys Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
All the keys.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] AllKeys { get; }
Visual Basic (Declaration)
ReadOnly Property AllKeys As String()
Visual C++
property array<String^>^ AllKeys {
    array<String^>^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property

[image] [image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Returns the value associated with the given index.
Item[([(String])]) | Returns the value associated with the given key.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
IAttributeDataManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property (Int32)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property (Int32)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the value associated with the given index.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T this[
    int index
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    index As Integer _
) As T
Visual C++
property T default[int index] {
    T get (int index);
}

Parameters

index
Type: System..::.Int32
the given index.

Return Value

the value.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Item Overload
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property (String)

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Item Property (String)
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the value associated with the given key.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T this[
    string key
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    key As String _
) As T
Visual C++
property T default[String^ key] {
    T get (String^ key);
}

Parameters

key
Type: System..::.String
the key of the dynamic attribute.

Return Value

the value of the dynamic attribute.

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Item Overload
Genesyslab.Enterprise.Model.Interaction Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Owner Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the owner of this object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As Object
Visual C++
property Object^ Owner {
    Object^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Section Property

[image]

Enterprise SDK 8.0 Reference API
IAttributeDataManager<(Of <(T>)>)..::.Section Property
IAttributeDataManager<(Of <(T>)>) Interface See Also Send Feedback
Returns the section name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Section { get; }
Visual Basic (Declaration)
ReadOnly Property Section As String
Visual C++
property String^ Section {
    String^ get ();
}

See Also

IAttributeDataManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ICallbackInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction Interface
Members See Also Send Feedback
Describes a callback request interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICallbackInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction>, IDeepCopy<IInteraction>,
    ISerializable
Visual Basic (Declaration)
Public Interface ICallbackInteraction _
    Implements IOpenMediaInteraction, IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class ICallbackInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>,
    ISerializable

See Also

ICallbackInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


ICallbackInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction Members
ICallbackInteraction Interface Methods Properties See Also Send Feedback

The ICallbackInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
CbCallResult
CbCustomerSessionId
CbDoEmailNotification
CbEndTime
CbNbAttempts
CbNotificationEmail
CbPhoneNumber
Gets the phone number to callback
CbStartTime
CbStatus
CbTimeShift
CbType
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ICallbackInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction Methods
ICallbackInteraction Interface See Also Send Feedback

The ICallbackInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ICallbackInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction Properties
ICallbackInteraction Interface See Also Send Feedback

The ICallbackInteraction type exposes the following members.

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
CbCallResult
CbCustomerSessionId
CbDoEmailNotification
CbEndTime
CbNbAttempts
CbNotificationEmail
CbPhoneNumber
Gets the phone number to callback
CbStartTime
CbStatus
CbTimeShift
CbType
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbCallResult Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbCallResult Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbCallResult"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CbCallResult { get; set; }
Visual Basic (Declaration)
Property CbCallResult As String
Visual C++
property String^ CbCallResult {
    String^ get ();
    void set (String^ value);
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbCustomerSessionId Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbCustomerSessionId Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbCustomerSessionId"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CbCustomerSessionId { get; }
Visual Basic (Declaration)
ReadOnly Property CbCustomerSessionId As String
Visual C++
property String^ CbCustomerSessionId {
    String^ get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbDoEmailNotification Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbDoEmailNotification Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbDoEmailNotification"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool CbDoEmailNotification { get; }
Visual Basic (Declaration)
ReadOnly Property CbDoEmailNotification As Boolean
Visual C++
property bool CbDoEmailNotification {
    bool get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbEndTime Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbEndTime Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbEndTime"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime CbEndTime { get; }
Visual Basic (Declaration)
ReadOnly Property CbEndTime As DateTime
Visual C++
property DateTime CbEndTime {
    DateTime get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbNbAttempts Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbNbAttempts Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbNbAttempts"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int CbNbAttempts { get; }
Visual Basic (Declaration)
ReadOnly Property CbNbAttempts As Integer
Visual C++
property int CbNbAttempts {
    int get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbNotificationEmail Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbNotificationEmail Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbNotificationEmail"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CbNotificationEmail { get; }
Visual Basic (Declaration)
ReadOnly Property CbNotificationEmail As String
Visual C++
property String^ CbNotificationEmail {
    String^ get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbPhoneNumber Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbPhoneNumber Property
ICallbackInteraction Interface See Also Send Feedback
Gets the phone number to callback

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CbPhoneNumber { get; }
Visual Basic (Declaration)
ReadOnly Property CbPhoneNumber As String
Visual C++
property String^ CbPhoneNumber {
    String^ get ();
}

Return Value

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbStartTime Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbStartTime Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbStartTime"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime CbStartTime { get; }
Visual Basic (Declaration)
ReadOnly Property CbStartTime As DateTime
Visual C++
property DateTime CbStartTime {
    DateTime get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbStatus Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbStatus Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbStatus"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
CallbackStatus CbStatus { get; }
Visual Basic (Declaration)
ReadOnly Property CbStatus As CallbackStatus
Visual C++
property CallbackStatus CbStatus {
    CallbackStatus get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbTimeShift Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbTimeShift Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbTimeShift"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int CbTimeShift { get; }
Visual Basic (Declaration)
ReadOnly Property CbTimeShift As Integer
Visual C++
property int CbTimeShift {
    int get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CbType Property

[image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.CbType Property
ICallbackInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction.CbType"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
CallbackType CbType { get; }
Visual Basic (Declaration)
ReadOnly Property CbType As CallbackType
Visual C++
property CallbackType CbType {
    CallbackType get ();
}

See Also

ICallbackInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackInteraction..::.Queue Property
ICallbackInteraction Interface See Also Send Feedback

Overload List

Name | Description
Queue | Queues associated with the interaction. (Inherited from IInteraction.)
Queue | If the interaction is in a queue, the Queue where the interaction is stored. (Inherited from IOpenMediaInteraction.)

See Also

ICallbackInteraction Interface
ICallbackInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


ICampaign Interface

[image]

Enterprise SDK 8.0 Reference API
ICampaign Interface
Members See Also Send Feedback
Describes an outbound Campaign.

The outbound campaign sets up a list of outbound chains and records which are processed by the agents registered for the given campaign. To get details about the registration, see ICampaignService.

The campaign dialing modes determine how an agent, or a group of agents, participates in an outbound campaign. This affects the outbound event flow, and also agent actions to be performed when participating in the campaign. For details about the campaign modes, see CampaignMode.

To access outbound campaign, you deal with the ICampaignService. This service enables you to register listeners for getting events about current campaigns, and access to IChainRecord objects with the outbound service ICampaignService.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICampaign : IShallowCopy<ICampaign>,
    IDeepCopy<ICampaign>, ISerializable
Visual Basic (Declaration)
Public Interface ICampaign _
    Implements IShallowCopy(Of ICampaign), IDeepCopy(Of ICampaign),  _
    ISerializable
Visual C++
public interface class ICampaign : IShallowCopy<ICampaign^>,
    IDeepCopy<ICampaign^>, ISerializable

See Also

ICampaign Members
Genesyslab.Enterprise.Model.Interaction Namespace


ICampaign Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaign Members
ICampaign Interface Methods Properties See Also Send Feedback

The ICampaign type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ApplicationID | Application ID of the campaign.
CampaignAgentRequestType | Agent Request Type of the campaign in case of event error.
CampaignEvent | UserEvent action of the campaign. CampaignLoaded, CampaignStarted, CampaignStopped, CompaignUnloaded.
Description | Description of the campaign.
DescriptionGroupName | Description of the campaign group.
device | The device.
GroupDBID | Gets the DBID of the campaign group.
GroupName | Name of the campaign group.
LogoutTime | Gets Logout Time when request logout.
Mode | Mode of the campaign.
Name | Name of the campaign.
State | Gets the campaign state.
SwitchDBID | Gets the DBID of the switch that is involved in the campaign.

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ICampaign Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaign Methods
ICampaign Interface See Also Send Feedback

The ICampaign type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ICampaign Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaign Properties
ICampaign Interface See Also Send Feedback

The ICampaign type exposes the following members.

Properties

Name | Description
ApplicationID | Application ID of the campaign.
CampaignAgentRequestType | Agent Request Type of the campaign in case of event error.
CampaignEvent | UserEvent action of the campaign. CampaignLoaded, CampaignStarted, CampaignStopped, CompaignUnloaded.
Description | Description of the campaign.
DescriptionGroupName | Description of the campaign group.
device | The device.
GroupDBID | Gets the DBID of the campaign group.
GroupName | Name of the campaign group.
LogoutTime | Gets Logout Time when request logout.
Mode | Mode of the campaign.
Name | Name of the campaign.
State | Gets the campaign state.
SwitchDBID | Gets the DBID of the switch that is involved in the campaign.

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ApplicationID Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.ApplicationID Property
ICampaign Interface See Also Send Feedback
Application ID of the campaign.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ApplicationID { get; }
Visual Basic (Declaration)
ReadOnly Property ApplicationID As Integer
Visual C++
property int ApplicationID {
    int get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CampaignAgentRequestType Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.CampaignAgentRequestType Property
ICampaign Interface See Also Send Feedback
Agent Request Type of the campaign in case of event error.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CampaignAgentRequestType { get; }
Visual Basic (Declaration)
ReadOnly Property CampaignAgentRequestType As String
Visual C++
property String^ CampaignAgentRequestType {
    String^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CampaignEvent Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.CampaignEvent Property
ICampaign Interface See Also Send Feedback
UserEvent action of the campaign. CampaignLoaded, CampaignStarted, CampaignStopped, CompaignUnloaded.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CampaignEvent { get; }
Visual Basic (Declaration)
ReadOnly Property CampaignEvent As String
Visual C++
property String^ CampaignEvent {
    String^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.Description Property
ICampaign Interface See Also Send Feedback
Description of the campaign.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DescriptionGroupName Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.DescriptionGroupName Property
ICampaign Interface See Also Send Feedback
Description of the campaign group.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string DescriptionGroupName { get; }
Visual Basic (Declaration)
ReadOnly Property DescriptionGroupName As String
Visual C++
property String^ DescriptionGroupName {
    String^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


device Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.device Property
ICampaign Interface See Also Send Feedback
The device.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice device { get; }
Visual Basic (Declaration)
ReadOnly Property device As IDevice
Visual C++
property IDevice^ device {
    IDevice^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GroupDBID Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.GroupDBID Property
ICampaign Interface See Also Send Feedback
Gets the DBID of the campaign group.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> GroupDBID { get; }
Visual Basic (Declaration)
ReadOnly Property GroupDBID As Nullable(Of Integer)
Visual C++
property Nullable<int> GroupDBID {
    Nullable<int> get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GroupName Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.GroupName Property
ICampaign Interface See Also Send Feedback
Name of the campaign group.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string GroupName { get; }
Visual Basic (Declaration)
ReadOnly Property GroupName As String
Visual C++
property String^ GroupName {
    String^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


LogoutTime Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.LogoutTime Property
ICampaign Interface See Also Send Feedback
Gets Logout Time when request logout.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> LogoutTime { get; }
Visual Basic (Declaration)
ReadOnly Property LogoutTime As Nullable(Of Integer)
Visual C++
property Nullable<int> LogoutTime {
    Nullable<int> get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Mode Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.Mode Property
ICampaign Interface See Also Send Feedback
Mode of the campaign.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<CampaignMode> Mode { get; }
Visual Basic (Declaration)
ReadOnly Property Mode As Nullable(Of CampaignMode)
Visual C++
property Nullable<CampaignMode> Mode {
    Nullable<CampaignMode> get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.Name Property
ICampaign Interface See Also Send Feedback
Name of the campaign.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.State Property
ICampaign Interface See Also Send Feedback
Gets the campaign state.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
CampaignState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As CampaignState
Visual C++
property CampaignState State {
    CampaignState get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SwitchDBID Property

[image]

Enterprise SDK 8.0 Reference API
ICampaign..::.SwitchDBID Property
ICampaign Interface See Also Send Feedback
Gets the DBID of the switch that is involved in the campaign.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> SwitchDBID { get; }
Visual Basic (Declaration)
ReadOnly Property SwitchDBID As Nullable(Of Integer)
Visual C++
property Nullable<int> SwitchDBID {
    Nullable<int> get ();
}

See Also

ICampaign Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IChainRecord Interface

[image]

Enterprise SDK 8.0 Reference API
IChainRecord Interface
Members See Also Send Feedback
Describes a chained records object associated with a given interaction.

The chained records contain contact information used to process the outbound interaction.

You can use the GetChainRecord(IInteraction) method to retrieve the chain associated with a given interaction or to check whether this interaction is part of a progressive or predictive campaign.

Remarks

In ASM mode, when your application receives the outbound interaction, the contact is not known yet. The application receives records later when getting an interaction event for ATTACHED DATA CHANGED. When getting this event, your application should retrieve the ChainRecord by calling the GetChainRecord(IInteraction) method.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChainRecord : IShallowCopy<IChainRecord>,
    IDeepCopy<IChainRecord>, ISerializable
Visual Basic (Declaration)
Public Interface IChainRecord _
    Implements IShallowCopy(Of IChainRecord), IDeepCopy(Of IChainRecord),  _
    ISerializable
Visual C++
public interface class IChainRecord : IShallowCopy<IChainRecord^>,
    IDeepCopy<IChainRecord^>, ISerializable

See Also

IChainRecord Members
Genesyslab.Enterprise.Model.Interaction Namespace


IChainRecord Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChainRecord Members
IChainRecord Interface Methods Properties See Also Send Feedback

The IChainRecord type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActiveChannel | The active channel (read only).
CallingListName | Gets the Calling List name.
CampaignName | Gets The Campaign name.
ChainID | Gets the Chain Identifier.
Device | Gets the associated device of the chain.
InteractionID | Gets the interaction ID related to this Chain Record.
Records | Gets the collection of records (ChainedRecord) for this interaction.
UserData | Gets the original user data for processing chain record.

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IChainRecord Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChainRecord Methods
IChainRecord Interface See Also Send Feedback

The IChainRecord type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IChainRecord Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChainRecord Properties
IChainRecord Interface See Also Send Feedback

The IChainRecord type exposes the following members.

Properties

Name | Description
ActiveChannel | The active channel (read only).
CallingListName | Gets the Calling List name.
CampaignName | Gets The Campaign name.
ChainID | Gets the Chain Identifier.
Device | Gets the associated device of the chain.
InteractionID | Gets the interaction ID related to this Chain Record.
Records | Gets the collection of records (ChainedRecord) for this interaction.
UserData | Gets the original user data for processing chain record.

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActiveChannel Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.ActiveChannel Property
IChainRecord Interface See Also Send Feedback
The active channel (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel ActiveChannel { get; }
Visual Basic (Declaration)
ReadOnly Property ActiveChannel As IClientChannel
Visual C++
property IClientChannel^ ActiveChannel {
    IClientChannel^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CallingListName Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.CallingListName Property
IChainRecord Interface See Also Send Feedback
Gets the Calling List name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CallingListName { get; }
Visual Basic (Declaration)
ReadOnly Property CallingListName As String
Visual C++
property String^ CallingListName {
    String^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CampaignName Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.CampaignName Property
IChainRecord Interface See Also Send Feedback
Gets The Campaign name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CampaignName { get; }
Visual Basic (Declaration)
ReadOnly Property CampaignName As String
Visual C++
property String^ CampaignName {
    String^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ChainID Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.ChainID Property
IChainRecord Interface See Also Send Feedback
Gets the Chain Identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ChainID { get; }
Visual Basic (Declaration)
ReadOnly Property ChainID As Integer
Visual C++
property int ChainID {
    int get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Device Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.Device Property
IChainRecord Interface See Also Send Feedback
Gets the associated device of the chain.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice Device { get; }
Visual Basic (Declaration)
ReadOnly Property Device As IDevice
Visual C++
property IDevice^ Device {
    IDevice^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionID Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.InteractionID Property
IChainRecord Interface See Also Send Feedback
Gets the interaction ID related to this Chain Record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string InteractionID { get; }
Visual Basic (Declaration)
ReadOnly Property InteractionID As String
Visual C++
property String^ InteractionID {
    String^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Records Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.Records Property
IChainRecord Interface See Also Send Feedback
Gets the collection of records (ChainedRecord) for this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IRecord> Records { get; }
Visual Basic (Declaration)
ReadOnly Property Records As ICollection(Of IRecord)
Visual C++
property ICollection<IRecord^>^ Records {
    ICollection<IRecord^>^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


UserData Property

[image]

Enterprise SDK 8.0 Reference API
IChainRecord..::.UserData Property
IChainRecord Interface See Also Send Feedback
Gets the original user data for processing chain record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection UserData { get; }
Visual Basic (Declaration)
ReadOnly Property UserData As KeyValueCollection
Visual C++
property KeyValueCollection^ UserData {
    KeyValueCollection^ get ();
}

See Also

IChainRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IChatInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction Interface
Members See Also Send Feedback
Describes a chat interaction. The chat interaction handles the chat instant messaging session. Chat messages and notification about chat parties are available through Transcript.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChatInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction>, IDeepCopy<IInteraction>,
    ISerializable
Visual Basic (Declaration)
Public Interface IChatInteraction _
    Implements IOpenMediaInteraction, IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class IChatInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>,
    ISerializable

See Also

IChatInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IChatInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChatInteraction Members
IChatInteraction Interface Methods Properties See Also Send Feedback

The IChatInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Duration
The duration of the chat session (read only).
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected | Overloaded.
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
IsSMS
true if the chat interaction is related to a SMS session.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Nickname
The nickname of the agent.
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
SessionStartDate
The start date of the chat session.
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Transcript
Collection of messages for this interaction.
UserId
The user identifier of the chat session.
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IChatInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChatInteraction Methods
IChatInteraction Interface See Also Send Feedback

The IChatInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IChatInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChatInteraction Properties
IChatInteraction Interface See Also Send Feedback

The IChatInteraction type exposes the following members.

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Duration
The duration of the chat session (read only).
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected | Overloaded.
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
IsSMS
true if the chat interaction is related to a SMS session.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Nickname
The nickname of the agent.
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
SessionStartDate
The start date of the chat session.
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Transcript
Collection of messages for this interaction.
UserId
The user identifier of the chat session.
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Duration Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.Duration Property
IChatInteraction Interface See Also Send Feedback
The duration of the chat session (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Duration { get; }
Visual Basic (Declaration)
ReadOnly Property Duration As Integer
Visual C++
property int Duration {
    int get ();
}

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsConnected Property

[image] [image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.IsConnected Property
IChatInteraction Interface See Also Send Feedback

Overload List

Name | Description
IsConnected | true if connected with the media chat channel (read only).
IsConnected | true if the associated media is connected (read only). (Inherited from IOpenMediaInteraction.)

See Also

IChatInteraction Interface
IChatInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IsConnected Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.IsConnected Property
IChatInteraction Interface See Also Send Feedback
true if connected with the media chat channel (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsConnected { get; }
Visual Basic (Declaration)
ReadOnly Property IsConnected As Boolean
Visual C++
property bool IsConnected {
    bool get ();
}

Implements

IOpenMediaInteraction..::.IsConnected

See Also

IChatInteraction Interface
IsConnected Overload
Genesyslab.Enterprise.Model.Interaction Namespace


IsSMS Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.IsSMS Property
IChatInteraction Interface See Also Send Feedback
true if the chat interaction is related to a SMS session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsSMS { get; }
Visual Basic (Declaration)
ReadOnly Property IsSMS As Boolean
Visual C++
property bool IsSMS {
    bool get ();
}

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Nickname Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.Nickname Property
IChatInteraction Interface See Also Send Feedback
The nickname of the agent.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Nickname { get; set; }
Visual Basic (Declaration)
Property Nickname As String
Visual C++
property String^ Nickname {
    String^ get ();
    void set (String^ value);
}

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image] [image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.Queue Property
IChatInteraction Interface See Also Send Feedback

Overload List

Name | Description
Queue | Queues associated with the interaction. (Inherited from IInteraction.)
Queue | If the interaction is in a queue, the Queue where the interaction is stored. (Inherited from IOpenMediaInteraction.)

See Also

IChatInteraction Interface
IChatInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


SessionStartDate Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.SessionStartDate Property
IChatInteraction Interface See Also Send Feedback
The start date of the chat session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime SessionStartDate { get; set; }
Visual Basic (Declaration)
Property SessionStartDate As DateTime
Visual C++
property DateTime SessionStartDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Transcript Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.Transcript Property
IChatInteraction Interface See Also Send Feedback
Collection of messages for this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IChatEvent> Transcript { get; }
Visual Basic (Declaration)
ReadOnly Property Transcript As ICollection(Of IChatEvent)
Visual C++
property ICollection<IChatEvent^>^ Transcript {
    ICollection<IChatEvent^>^ get ();
}

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


UserId Property

[image]

Enterprise SDK 8.0 Reference API
IChatInteraction..::.UserId Property
IChatInteraction Interface See Also Send Feedback
The user identifier of the chat session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string UserId { get; set; }
Visual Basic (Declaration)
Property UserId As String
Visual C++
property String^ UserId {
    String^ get ();
    void set (String^ value);
}

See Also

IChatInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IEmailInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction Interface
Members See Also Send Feedback
Describes an e-mail interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEmailInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction>, IDeepCopy<IInteraction>,
    ISerializable
Visual Basic (Declaration)
Public Interface IEmailInteraction _
    Implements IOpenMediaInteraction, IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class IEmailInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>,
    ISerializable

See Also

IEmailInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IEmailInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailInteraction Members
IEmailInteraction Interface Methods Properties See Also Send Feedback

The IEmailInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
Bcc
Bcc e-mail addresses (for outbound e-mails only).
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
Cc
Cc e-mail addresses.
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
ContactID
The Contact identifier of the e-mail.
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
From
From e-mail address.
FromPersonal
The From Personal header of the e-mail.
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Mailbox
The source mailbox of the e-mail (read only).
MessageText
The text message of the e-mail.
MimeMessage
The MIME message of the e-mail.
MimeMessageType
The MIME message type of the e-mail.
Notepad
The comment of the e-mail.
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
ReplyTo
Reply-To e-mail address of the interaction.
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
StructuredText
The structured text message of the e-mail (HTML).
StructuredTextMimeType
The MIME structured text message type of the e-mail.
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
To
To e-mail addresses.
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IEmailInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailInteraction Methods
IEmailInteraction Interface See Also Send Feedback

The IEmailInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IEmailInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailInteraction Properties
IEmailInteraction Interface See Also Send Feedback

The IEmailInteraction type exposes the following members.

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
Bcc
Bcc e-mail addresses (for outbound e-mails only).
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
Cc
Cc e-mail addresses.
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
ContactID
The Contact identifier of the e-mail.
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
From
From e-mail address.
FromPersonal
The From Personal header of the e-mail.
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Mailbox
The source mailbox of the e-mail (read only).
MessageText
The text message of the e-mail.
MimeMessage
The MIME message of the e-mail.
MimeMessageType
The MIME message type of the e-mail.
Notepad
The comment of the e-mail.
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
ReplyTo
Reply-To e-mail address of the interaction.
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
StructuredText
The structured text message of the e-mail (HTML).
StructuredTextMimeType
The MIME structured text message type of the e-mail.
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
To
To e-mail addresses.
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Bcc Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.Bcc Property
IEmailInteraction Interface See Also Send Feedback
Bcc e-mail addresses (for outbound e-mails only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] Bcc { get; set; }
Visual Basic (Declaration)
Property Bcc As String()
Visual C++
property array<String^>^ Bcc {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Cc Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.Cc Property
IEmailInteraction Interface See Also Send Feedback
Cc e-mail addresses.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] Cc { get; set; }
Visual Basic (Declaration)
Property Cc As String()
Visual C++
property array<String^>^ Cc {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContactID Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.ContactID Property
IEmailInteraction Interface See Also Send Feedback
The Contact identifier of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContactID { get; set; }
Visual Basic (Declaration)
Property ContactID As String
Visual C++
property String^ ContactID {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


From Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.From Property
IEmailInteraction Interface See Also Send Feedback
From e-mail address.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string From { get; set; }
Visual Basic (Declaration)
Property From As String
Visual C++
property String^ From {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


FromPersonal Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.FromPersonal Property
IEmailInteraction Interface See Also Send Feedback
The From Personal header of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FromPersonal { get; set; }
Visual Basic (Declaration)
Property FromPersonal As String
Visual C++
property String^ FromPersonal {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Mailbox Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.Mailbox Property
IEmailInteraction Interface See Also Send Feedback
The source mailbox of the e-mail (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Mailbox { get; }
Visual Basic (Declaration)
ReadOnly Property Mailbox As String
Visual C++
property String^ Mailbox {
    String^ get ();
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MessageText Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.MessageText Property
IEmailInteraction Interface See Also Send Feedback
The text message of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MessageText { get; set; }
Visual Basic (Declaration)
Property MessageText As String
Visual C++
property String^ MessageText {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MimeMessage Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.MimeMessage Property
IEmailInteraction Interface See Also Send Feedback
The MIME message of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
byte[] MimeMessage { get; set; }
Visual Basic (Declaration)
Property MimeMessage As Byte()
Visual C++
property array<unsigned char>^ MimeMessage {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MimeMessageType Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.MimeMessageType Property
IEmailInteraction Interface See Also Send Feedback
The MIME message type of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MimeMessageType { get; set; }
Visual Basic (Declaration)
Property MimeMessageType As String
Visual C++
property String^ MimeMessageType {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Notepad Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.Notepad Property
IEmailInteraction Interface See Also Send Feedback
The comment of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Notepad { get; set; }
Visual Basic (Declaration)
Property Notepad As String
Visual C++
property String^ Notepad {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.Queue Property
IEmailInteraction Interface See Also Send Feedback

Overload List

Name | Description
Queue | Queues associated with the interaction. (Inherited from IInteraction.)
Queue | If the interaction is in a queue, the Queue where the interaction is stored. (Inherited from IOpenMediaInteraction.)

See Also

IEmailInteraction Interface
IEmailInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


ReplyTo Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.ReplyTo Property
IEmailInteraction Interface See Also Send Feedback
Reply-To e-mail address of the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ReplyTo { get; set; }
Visual Basic (Declaration)
Property ReplyTo As String
Visual C++
property String^ ReplyTo {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


StructuredText Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.StructuredText Property
IEmailInteraction Interface See Also Send Feedback
The structured text message of the e-mail (HTML).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string StructuredText { get; set; }
Visual Basic (Declaration)
Property StructuredText As String
Visual C++
property String^ StructuredText {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


StructuredTextMimeType Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.StructuredTextMimeType Property
IEmailInteraction Interface See Also Send Feedback
The MIME structured text message type of the e-mail.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string StructuredTextMimeType { get; set; }
Visual Basic (Declaration)
Property StructuredTextMimeType As String
Visual C++
property String^ StructuredTextMimeType {
    String^ get ();
    void set (String^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


To Property

[image]

Enterprise SDK 8.0 Reference API
IEmailInteraction..::.To Property
IEmailInteraction Interface See Also Send Feedback
To e-mail addresses.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] To { get; set; }
Visual Basic (Declaration)
Property To As String()
Visual C++
property array<String^>^ To {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

See Also

IEmailInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Interface

[image]

Enterprise SDK 8.0 Reference API
IExtension Interface
Members See Also Send Feedback
Describes the interaction's extension.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IExtension
Visual Basic (Declaration)
Public Interface IExtension
Visual C++
public interface class IExtension

See Also

IExtension Members
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Members

[image] [image]

Enterprise SDK 8.0 Reference API
IExtension Members
IExtension Interface Properties See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Attributes | Content of the extension (dynamic attributes).
Description | Description of the extension's content.
Name | Extension name.

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IExtension Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IExtension Properties
IExtension Interface See Also Send Feedback

The IExtension type exposes the following members.

Properties

Name | Description
Attributes | Content of the extension (dynamic attributes).
Description | Description of the extension's content.
Name | Extension name.

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Attributes Property
IExtension Interface See Also Send Feedback
Content of the extension (dynamic attributes).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Description Property
IExtension Interface See Also Send Feedback
Description of the extension's content.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IExtension..::.Name Property
IExtension Interface See Also Send Feedback
Extension name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IExtension Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Interface

[image]

Enterprise SDK 8.0 Reference API
IIMEvent Interface
Members See Also Send Feedback
Describes a new event during an instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMEvent : IShallowCopy<IIMEvent>,
    IDeepCopy<IIMEvent>
Visual Basic (Declaration)
Public Interface IIMEvent _
    Implements IShallowCopy(Of IIMEvent), IDeepCopy(Of IIMEvent)
Visual C++
public interface class IIMEvent : IShallowCopy<IIMEvent^>,
    IDeepCopy<IIMEvent^>

See Also

IIMEvent Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Members
IIMEvent Interface Methods Properties See Also Send Feedback

The IIMEvent type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Date | Returns the date of this IM event.
Party | Returns the party of this IM event

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Methods
IIMEvent Interface See Also Send Feedback

The IIMEvent type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMEvent Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMEvent Properties
IIMEvent Interface See Also Send Feedback

The IIMEvent type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event.
Party | Returns the party of this IM event

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Date Property

[image]

Enterprise SDK 8.0 Reference API
IIMEvent..::.Date Property
IIMEvent Interface See Also Send Feedback
Returns the date of this IM event.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime Date { get; }
Visual Basic (Declaration)
ReadOnly Property Date As DateTime
Visual C++
property DateTime Date {
    DateTime get ();
}

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Party Property

[image]

Enterprise SDK 8.0 Reference API
IIMEvent..::.Party Property
IIMEvent Interface See Also Send Feedback
Returns the party of this IM event

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIMParty Party { get; }
Visual Basic (Declaration)
ReadOnly Property Party As IIMParty
Visual C++
property IIMParty^ Party {
    IIMParty^ get ();
}

See Also

IIMEvent Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction Interface
Members See Also Send Feedback
Describes an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMInteraction : IInteraction,
    IShallowCopy<IInteraction>, IDeepCopy<IInteraction>, ISerializable
Visual Basic (Declaration)
Public Interface IIMInteraction _
    Implements IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class IIMInteraction : IInteraction,
    IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>, ISerializable

See Also

IIMInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Members
IIMInteraction Interface Methods Properties See Also Send Feedback

The IIMInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
IMEvent
Returns the events of the instant messaging session.
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue
Queues associated with the interaction.
(Inherited from IInteraction.)
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
Transcript
Returns the transcript of the instant messaging session.

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Methods
IIMInteraction Interface See Also Send Feedback

The IIMInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMInteraction Properties
IIMInteraction Interface See Also Send Feedback

The IIMInteraction type exposes the following members.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
IMEvent
Returns the events of the instant messaging session.
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue
Queues associated with the interaction.
(Inherited from IInteraction.)
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
Transcript
Returns the transcript of the instant messaging session.

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMEvent Property

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction..::.IMEvent Property
IIMInteraction Interface See Also Send Feedback
Returns the events of the instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IIMEvent> IMEvent { get; }
Visual Basic (Declaration)
ReadOnly Property IMEvent As ICollection(Of IIMEvent)
Visual C++
property ICollection<IIMEvent^>^ IMEvent {
    ICollection<IIMEvent^>^ get ();
}

Return Value

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Transcript Property

[image]

Enterprise SDK 8.0 Reference API
IIMInteraction..::.Transcript Property
IIMInteraction Interface See Also Send Feedback
Returns the transcript of the instant messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IIMEvent> Transcript { get; }
Visual Basic (Declaration)
ReadOnly Property Transcript As ICollection(Of IIMEvent)
Visual C++
property ICollection<IIMEvent^>^ Transcript {
    ICollection<IIMEvent^>^ get ();
}

Return Value

See Also

IIMInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Interface

[image]

Enterprise SDK 8.0 Reference API
IIMMessage Interface
Members See Also Send Feedback
Represents a message during an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMMessage : IIMEvent,
    IShallowCopy<IIMEvent>, IDeepCopy<IIMEvent>
Visual Basic (Declaration)
Public Interface IIMMessage _
    Implements IIMEvent, IShallowCopy(Of IIMEvent),  _
    IDeepCopy(Of IIMEvent)
Visual C++
public interface class IIMMessage : IIMEvent,
    IShallowCopy<IIMEvent^>, IDeepCopy<IIMEvent^>

See Also

IIMMessage Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Members
IIMMessage Interface Methods Properties See Also Send Feedback

The IIMMessage type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name Description
Content
Returns the text of this message.
ContentType
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".
Date
Returns the date of this IM event.
(Inherited from IIMEvent.)
Party
Returns the party of this IM event
(Inherited from IIMEvent.)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Methods
IIMMessage Interface See Also Send Feedback

The IIMMessage type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMMessage Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMMessage Properties
IIMMessage Interface See Also Send Feedback

The IIMMessage type exposes the following members.

Properties

Name Description
Content
Returns the text of this message.
ContentType
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".
Date
Returns the date of this IM event.
(Inherited from IIMEvent.)
Party
Returns the party of this IM event
(Inherited from IIMEvent.)

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Content Property

[image]

Enterprise SDK 8.0 Reference API
IIMMessage..::.Content Property
IIMMessage Interface See Also Send Feedback
Returns the text of this message.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Content { get; }
Visual Basic (Declaration)
ReadOnly Property Content As String
Visual C++
property String^ Content {
    String^ get ();
}

Return Value

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContentType Property

[image]

Enterprise SDK 8.0 Reference API
IIMMessage..::.ContentType Property
IIMMessage Interface See Also Send Feedback
Returns the
CopyC#
ContentType
 of this message. Possible values are "text/plain" and "text/html".

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContentType { get; }
Visual Basic (Declaration)
ReadOnly Property ContentType As String
Visual C++
property String^ ContentType {
    String^ get ();
}

Return Value

"text/plain" or "text/html"

See Also

IIMMessage Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Interface

[image]

Enterprise SDK 8.0 Reference API
IIMParty Interface
Members See Also Send Feedback
Represents a party of the Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMParty : IShallowCopy<IIMParty>,
    IDeepCopy<IIMParty>
Visual Basic (Declaration)
Public Interface IIMParty _
    Implements IShallowCopy(Of IIMParty), IDeepCopy(Of IIMParty)
Visual C++
public interface class IIMParty : IShallowCopy<IIMParty^>,
    IDeepCopy<IIMParty^>

See Also

IIMParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Members
IIMParty Interface Methods Properties See Also Send Feedback

The IIMParty type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Nickname | Returns the nickname of this party.
Type | Returns the type of this party.
Visibility | Returns the visibility of this party.

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Methods
IIMParty Interface See Also Send Feedback

The IIMParty type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMParty Properties
IIMParty Interface See Also Send Feedback

The IIMParty type exposes the following members.

Properties

Name | Description
Nickname | Returns the nickname of this party.
Type | Returns the type of this party.
Visibility | Returns the visibility of this party.

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Nickname Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Nickname Property
IIMParty Interface See Also Send Feedback
Returns the nickname of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Nickname { get; }
Visual Basic (Declaration)
ReadOnly Property Nickname As String
Visual C++
property String^ Nickname {
    String^ get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Type Property
IIMParty Interface See Also Send Feedback
Returns the type of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
PartyType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As PartyType
Visual C++
property PartyType Type {
    PartyType get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Visibility Property

[image]

Enterprise SDK 8.0 Reference API
IIMParty..::.Visibility Property
IIMParty Interface See Also Send Feedback
Returns the visibility of this party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Visibility Visibility { get; }
Visual Basic (Declaration)
ReadOnly Property Visibility As Visibility
Visual C++
property Visibility Visibility {
    Visibility get ();
}

Return Value

See Also

IIMParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party joined.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMPartyJoined : IIMEvent,
    IShallowCopy<IIMEvent>, IDeepCopy<IIMEvent>
Visual Basic (Declaration)
Public Interface IIMPartyJoined _
    Implements IIMEvent, IShallowCopy(Of IIMEvent),  _
    IDeepCopy(Of IIMEvent)
Visual C++
public interface class IIMPartyJoined : IIMEvent,
    IShallowCopy<IIMEvent^>, IDeepCopy<IIMEvent^>

See Also

IIMPartyJoined Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Members
IIMPartyJoined Interface Methods Properties See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Methods
IIMPartyJoined Interface See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyJoined Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyJoined Properties
IIMPartyJoined Interface See Also Send Feedback

The IIMPartyJoined type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyJoined Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party left.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMPartyLeft : IIMEvent,
    IShallowCopy<IIMEvent>, IDeepCopy<IIMEvent>
Visual Basic (Declaration)
Public Interface IIMPartyLeft _
    Implements IIMEvent, IShallowCopy(Of IIMEvent),  _
    IDeepCopy(Of IIMEvent)
Visual C++
public interface class IIMPartyLeft : IIMEvent,
    IShallowCopy<IIMEvent^>, IDeepCopy<IIMEvent^>

See Also

IIMPartyLeft Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Members
IIMPartyLeft Interface Methods Properties See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Methods
IIMPartyLeft Interface See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyLeft Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyLeft Properties
IIMPartyLeft Interface See Also Send Feedback

The IIMPartyLeft type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyLeft Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Interface

[image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Interface
Members See Also Send Feedback
Occurs during an Instant Messaging session if a party reentered.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMPartyReenter : IIMEvent,
    IShallowCopy<IIMEvent>, IDeepCopy<IIMEvent>
Visual Basic (Declaration)
Public Interface IIMPartyReenter _
    Implements IIMEvent, IShallowCopy(Of IIMEvent),  _
    IDeepCopy(Of IIMEvent)
Visual C++
public interface class IIMPartyReenter : IIMEvent,
    IShallowCopy<IIMEvent^>, IDeepCopy<IIMEvent^>

See Also

IIMPartyReenter Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Members
IIMPartyReenter Interface Methods Properties See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Methods
IIMPartyReenter Interface See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMPartyReenter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMPartyReenter Properties
IIMPartyReenter Interface See Also Send Feedback

The IIMPartyReenter type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)

See Also

IIMPartyReenter Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Interface

[image]

Enterprise SDK 8.0 Reference API
IIMTranscript Interface
Members See Also Send Feedback
Represents the update of the transcript in an Instant Messaging session.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMTranscript : IIMEvent,
    IShallowCopy<IIMEvent>, IDeepCopy<IIMEvent>
Visual Basic (Declaration)
Public Interface IIMTranscript _
    Implements IIMEvent, IShallowCopy(Of IIMEvent),  _
    IDeepCopy(Of IIMEvent)
Visual C++
public interface class IIMTranscript : IIMEvent,
    IShallowCopy<IIMEvent^>, IDeepCopy<IIMEvent^>

See Also

IIMTranscript Members
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMTranscript Members
IIMTranscript Interface Methods Properties See Also Send Feedback

The IIMTranscript type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)
Transcript | Returns the updated transcript of this IM chat session as a Collection of IIMEvent.

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMTranscript Methods
IIMTranscript Interface See Also Send Feedback

The IIMTranscript type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IIMTranscript Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMTranscript Properties
IIMTranscript Interface See Also Send Feedback

The IIMTranscript type exposes the following members.

Properties

Name | Description
Date | Returns the date of this IM event. (Inherited from IIMEvent.)
Party | Returns the party of this IM event (Inherited from IIMEvent.)
Transcript | Returns the updated transcript of this IM chat session as a Collection of IIMEvent.

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Transcript Property

[image]

Enterprise SDK 8.0 Reference API
IIMTranscript..::.Transcript Property
IIMTranscript Interface See Also Send Feedback
Returns the updated transcript of this IM chat session as a Collection of IIMEvent.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IIMEvent> Transcript { get; }
Visual Basic (Declaration)
ReadOnly Property Transcript As ICollection(Of IIMEvent)
Visual C++
property ICollection<IIMEvent^>^ Transcript {
    ICollection<IIMEvent^>^ get ();
}

Return Value

See Also

IIMTranscript Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IInteraction Interface
Members See Also Send Feedback
Describes an interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IInteraction : IShallowCopy<IInteraction>,
    IDeepCopy<IInteraction>, ISerializable
Visual Basic (Declaration)
Public Interface IInteraction _
    Implements IShallowCopy(Of IInteraction), IDeepCopy(Of IInteraction),  _
    ISerializable
Visual C++
public interface class IInteraction : IShallowCopy<IInteraction^>,
    IDeepCopy<IInteraction^>, ISerializable

See Also

IInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Members
IInteraction Interface Methods Properties See Also Send Feedback

The IInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible.
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name Description
ActionsTransitions
Get IsPossible feature
ActiveChannel
Returns the active channel.
Channels
Returns the channels associated with this interaction.
Controller
Controller.
Customer
Returns the customer party.
Data
Returns the data associated with the interaction.
EndDate
Interaction end data. Same as server end date.
FQName
Returns the interaction's Fully Qualified Name (unique Id).
Id
Returns the interaction's identifier.
IdType
Returns the interaction type.
IsArchive
Returns true if the interaction is not active (part of a History.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
Originator
Returns the originting party when interaction is transfered
Owner
Returns the party who owns this interaction.
Parties
Returns all the parties involved wihtin the interaction.
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
Queue
Queues associated with the interaction.
RelatedId
Returns the related interaction IDs.
StartDate
Interaction start data. Same as the server date.
State
Returns the interaction status.
Strategy
Returns the strategies associated with the interaction.
Target
Returns the target party when interaction is transfered

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Methods
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible.
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsDone Method

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IsDone Method
IInteraction Interface See Also Send Feedback
Returns true if the interaction is disabled. When done, further state changes are impossible.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsDone()
Visual Basic (Declaration)
Function IsDone As Boolean
Visual C++
bool IsDone()

Return Value

bool

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteraction Properties
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Properties

Name Description
ActionsTransitions
Get IsPossible feature
ActiveChannel
Returns the active channel.
Channels
Returns the channels associated with this interaction.
Controller
Controller.
Customer
Returns the customer party.
Data
Returns the data associated with the interaction.
EndDate
Interaction end data. Same as server end date.
FQName
Returns the interaction's Fully Qualified Name (unique Id).
Id
Returns the interaction's identifier.
IdType
Returns the interaction type.
IsArchive
Returns true if the interaction is not active (part of a History.
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
Originator
Returns the originting party when interaction is transfered
Owner
Returns the party who owns this interaction.
Parties
Returns all the parties involved wihtin the interaction.
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
Queue
Queues associated with the interaction.
RelatedId
Returns the related interaction IDs.
StartDate
Interaction start data. Same as the server date.
State
Returns the interaction status.
Strategy
Returns the strategies associated with the interaction.
Target
Returns the target party when interaction is transfered

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActionsTransitions Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.ActionsTransitions Property
IInteraction Interface See Also Send Feedback
Get IsPossible feature

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool[] ActionsTransitions { get; }
Visual Basic (Declaration)
ReadOnly Property ActionsTransitions As Boolean()
Visual C++
property array<bool>^ ActionsTransitions {
    array<bool>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActiveChannel Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.ActiveChannel Property
IInteraction Interface See Also Send Feedback
Returns the active channel.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel ActiveChannel { get; set; }
Visual Basic (Declaration)
Property ActiveChannel As IClientChannel
Visual C++
property IClientChannel^ ActiveChannel {
    IClientChannel^ get ();
    void set (IClientChannel^ value);
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Channels Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Channels Property
IInteraction Interface See Also Send Feedback
Returns the channels associated with this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IClientChannel> Channels { get; }
Visual Basic (Declaration)
ReadOnly Property Channels As IDictionary(Of String, IClientChannel)
Visual C++
property IDictionary<String^, IClientChannel^>^ Channels {
    IDictionary<String^, IClientChannel^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Controller Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Controller Property
IInteraction Interface See Also Send Feedback
Controller.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Controller { get; }
Visual Basic (Declaration)
ReadOnly Property Controller As Object
Visual C++
property Object^ Controller {
    Object^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Customer Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Customer Property
IInteraction Interface See Also Send Feedback
Returns the customer party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParty Customer { get; }
Visual Basic (Declaration)
ReadOnly Property Customer As IParty
Visual C++
property IParty^ Customer {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Data Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Data Property
IInteraction Interface See Also Send Feedback
Returns the data associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDataBag<IAttributeDataManager<IDynamicAttribute>> Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As IDataBag(Of IAttributeDataManager(Of IDynamicAttribute))
Visual C++
property IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ Data {
    IDataBag<IAttributeDataManager<IDynamicAttribute^>^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


EndDate Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.EndDate Property
IInteraction Interface See Also Send Feedback
Interaction end data. Same as server end date.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime EndDate { get; }
Visual Basic (Declaration)
ReadOnly Property EndDate As DateTime
Visual C++
property DateTime EndDate {
    DateTime get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.FQName Property
IInteraction Interface See Also Send Feedback
Returns the interaction's Fully Qualified Name (unique Id).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Id Property
IInteraction Interface See Also Send Feedback
Returns the interaction's identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IdType Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IdType Property
IInteraction Interface See Also Send Feedback
Returns the interaction type.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionType IdType { get; }
Visual Basic (Declaration)
ReadOnly Property IdType As IInteractionType
Visual C++
property IInteractionType^ IdType {
    IInteractionType^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsArchive Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.IsArchive Property
IInteraction Interface See Also Send Feedback
Returns true if the interaction is not active (part of a History.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsArchive { get; }
Visual Basic (Declaration)
ReadOnly Property IsArchive As Boolean
Visual C++
property bool IsArchive {
    bool get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Item Property
IInteraction Interface See Also Send Feedback
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object this[
    string name
] { get; }
Visual Basic (Declaration)
ReadOnly Default Property Item ( _
    name As String _
) As Object
Visual C++
property Object^ default[String^ name] {
    Object^ get (String^ name);
}

Parameters

name
Type: System..::.String

Return Value

object

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Originator Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Originator Property
IInteraction Interface See Also Send Feedback
Returns the originting party when interaction is transfered

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParty Originator { get; }
Visual Basic (Declaration)
ReadOnly Property Originator As IParty
Visual C++
property IParty^ Originator {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Owner Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Owner Property
IInteraction Interface See Also Send Feedback
Returns the party who owns this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParty Owner { get; }
Visual Basic (Declaration)
ReadOnly Property Owner As IParty
Visual C++
property IParty^ Owner {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Parties Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Parties Property
IInteraction Interface See Also Send Feedback
Returns all the parties involved wihtin the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParty[] Parties { get; }
Visual Basic (Declaration)
ReadOnly Property Parties As IParty()
Visual C++
property array<IParty^>^ Parties {
    array<IParty^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Profile Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Profile Property
IInteraction Interface See Also Send Feedback
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ProfileType Profile { get; }
Visual Basic (Declaration)
ReadOnly Property Profile As ProfileType
Visual C++
property ProfileType Profile {
    ProfileType get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Queue Property
IInteraction Interface See Also Send Feedback
Queues associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] Queue { get; }
Visual Basic (Declaration)
ReadOnly Property Queue As String()
Visual C++
property array<String^>^ Queue {
    array<String^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RelatedId Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.RelatedId Property
IInteraction Interface See Also Send Feedback
Returns the related interaction IDs.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] RelatedId { get; }
Visual Basic (Declaration)
ReadOnly Property RelatedId As String()
Visual C++
property array<String^>^ RelatedId {
    array<String^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


StartDate Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.StartDate Property
IInteraction Interface See Also Send Feedback
Interaction start data. Same as the server date.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime StartDate { get; }
Visual Basic (Declaration)
ReadOnly Property StartDate As DateTime
Visual C++
property DateTime StartDate {
    DateTime get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.State Property
IInteraction Interface See Also Send Feedback
Returns the interaction status.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
InteractionStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As InteractionStateType
Visual C++
property InteractionStateType State {
    InteractionStateType get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Strategy Property
IInteraction Interface See Also Send Feedback
Returns the strategies associated with the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Target Property

[image]

Enterprise SDK 8.0 Reference API
IInteraction..::.Target Property
IInteraction Interface See Also Send Feedback
Returns the target party when interaction is transfered

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParty Target { get; }
Visual Basic (Declaration)
ReadOnly Property Target As IParty
Visual C++
property IParty^ Target {
    IParty^ get ();
}

See Also

IInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionQueueSnapshot Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot Interface
Members See Also Send Feedback
Describes an interaction queue snapshot.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IInteractionQueueSnapshot : IShallowCopy<IInteractionQueueSnapshot>,
    IDeepCopy<IInteractionQueueSnapshot>, ISerializable
Visual Basic (Declaration)
Public Interface IInteractionQueueSnapshot _
    Implements IShallowCopy(Of IInteractionQueueSnapshot), IDeepCopy(Of IInteractionQueueSnapshot),  _
    ISerializable
Visual C++
public interface class IInteractionQueueSnapshot : IShallowCopy<IInteractionQueueSnapshot^>,
    IDeepCopy<IInteractionQueueSnapshot^>, ISerializable

See Also

IInteractionQueueSnapshot Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionQueueSnapshot Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot Members
IInteractionQueueSnapshot Interface Methods Properties See Also Send Feedback

The IInteractionQueueSnapshot type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActiveChannel | The active channel (read only).
CheckInteractionState | a boolean indicating if the state of the interactions is checked while taking this snapshot. Default value for this option is True. Possible values are: False (include interactions in all state in the snapshot) and True (Include only queued interactions in the snapshot)
Condition |
HaveMoreInteractions | Boolean indicating if there are more available interactions in this snapshot
InteractionIDList | The IDs of the interactions in this interaction queue snapashot (read only).
Interactions | The interactions in this interaction queue snapshot (read only). Key is the interaction ID.
Lock | a boolean indicating if the interactions are locked by this snapshot or not. Only queued interactions can be locked. If interaction can not be locked by Interaction Server it is still included in snapshot, but the lock is not placed on the interaction. If interaction is locked, it is not submitted into strategy as it would in the normal course of workflow processing.
NumberOfInteraction | Contains the number of interactions in the snapshot
Order | Specifies order of interactions in the snapshot. If not specified, default order is 'received_at, id'. Snapshot orders are added to 'order by' clause of the SQL 'select' statement generated by Interaction Server. It is possible to use interaction property names and custom property names in order. Property names are automatically translated to field names.
SnapshotId | Unique ID of the interaction queue snapshot (read only). If specified, should represent an identifier of the snapshot that client has taken before. The new snapshot will inherit all the locks that the older snapshot held. The identifier of the new snapshot is the same as the old snapshot. Old snapshot is automatically released
SnapshotMaxInteractions | Specifies the maximum number of interactions that will be included in the snapshot.
Strategy | The strategies associated with the workbin (read only).
ViewId | Identifier of the interaction queue view to pull interactions from(read only). The view should be defined for the tenant. The special _system_ view allows pulling of the specific interaction by its identifier.

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionQueueSnapshot Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot Methods
IInteractionQueueSnapshot Interface See Also Send Feedback

The IInteractionQueueSnapshot type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionQueueSnapshot Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot Properties
IInteractionQueueSnapshot Interface See Also Send Feedback

The IInteractionQueueSnapshot type exposes the following members.

Properties

Name | Description
ActiveChannel | The active channel (read only).
CheckInteractionState | a boolean indicating if the state of the interactions is checked while taking this snapshot. Default value for this option is True. Possible values are: False (include interactions in all state in the snapshot) and True (Include only queued interactions in the snapshot)
Condition |
HaveMoreInteractions | Boolean indicating if there are more available interactions in this snapshot
InteractionIDList | The IDs of the interactions in this interaction queue snapashot (read only).
Interactions | The interactions in this interaction queue snapshot (read only). Key is the interaction ID.
Lock | a boolean indicating if the interactions are locked by this snapshot or not. Only queued interactions can be locked. If interaction can not be locked by Interaction Server it is still included in snapshot, but the lock is not placed on the interaction. If interaction is locked, it is not submitted into strategy as it would in the normal course of workflow processing.
NumberOfInteraction | Contains the number of interactions in the snapshot
Order | Specifies order of interactions in the snapshot. If not specified, default order is 'received_at, id'. Snapshot orders are added to 'order by' clause of the SQL 'select' statement generated by Interaction Server. It is possible to use interaction property names and custom property names in order. Property names are automatically translated to field names.
SnapshotId | Unique ID of the interaction queue snapshot (read only). If specified, should represent an identifier of the snapshot that client has taken before. The new snapshot will inherit all the locks that the older snapshot held. The identifier of the new snapshot is the same as the old snapshot. Old snapshot is automatically released
SnapshotMaxInteractions | Specifies the maximum number of interactions that will be included in the snapshot.
Strategy | The strategies associated with the workbin (read only).
ViewId | Identifier of the interaction queue view to pull interactions from(read only). The view should be defined for the tenant. The special _system_ view allows pulling of the specific interaction by its identifier.

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActiveChannel Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.ActiveChannel Property
IInteractionQueueSnapshot Interface See Also Send Feedback
The active channel (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel ActiveChannel { get; }
Visual Basic (Declaration)
ReadOnly Property ActiveChannel As IClientChannel
Visual C++
property IClientChannel^ ActiveChannel {
    IClientChannel^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CheckInteractionState Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.CheckInteractionState Property
IInteractionQueueSnapshot Interface See Also Send Feedback
a boolean indicating if the state of the interactions is checked while taking this snapshot. Default value for this option is True. Possible values are: False (include interactions in all state in the snapshot) and True (Include only queued interactions in the snapshot)

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool CheckInteractionState { get; }
Visual Basic (Declaration)
ReadOnly Property CheckInteractionState As Boolean
Visual C++
property bool CheckInteractionState {
    bool get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Condition Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.Condition Property
IInteractionQueueSnapshot Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.IInteractionQueueSnapshot.Condition"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Condition { get; }
Visual Basic (Declaration)
ReadOnly Property Condition As String
Visual C++
property String^ Condition {
    String^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


HaveMoreInteractions Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.HaveMoreInteractions Property
IInteractionQueueSnapshot Interface See Also Send Feedback
Boolean indicating if there are more available interactions in this snapshot

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool HaveMoreInteractions { get; }
Visual Basic (Declaration)
ReadOnly Property HaveMoreInteractions As Boolean
Visual C++
property bool HaveMoreInteractions {
    bool get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionIDList Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.InteractionIDList Property
IInteractionQueueSnapshot Interface See Also Send Feedback
The IDs of the interactions in this interaction queue snapashot (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> InteractionIDList { get; }
Visual Basic (Declaration)
ReadOnly Property InteractionIDList As ICollection(Of String)
Visual C++
property ICollection<String^>^ InteractionIDList {
    ICollection<String^>^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Interactions Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.Interactions Property
IInteractionQueueSnapshot Interface See Also Send Feedback
The interactions in this interaction queue snapshot (read only). Key is the interaction ID.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IOpenMediaInteraction> Interactions { get; }
Visual Basic (Declaration)
ReadOnly Property Interactions As IDictionary(Of String, IOpenMediaInteraction)
Visual C++
property IDictionary<String^, IOpenMediaInteraction^>^ Interactions {
    IDictionary<String^, IOpenMediaInteraction^>^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Lock Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.Lock Property
IInteractionQueueSnapshot Interface See Also Send Feedback
a boolean indicating if the interactions are locked by this snapshot or not. Only queued interactions can be locked. If interaction can not be locked by Interaction Server it is still included in snapshot, but the lock is not placed on the interaction. If interaction is locked, it is not submitted into strategy as it would in the normal course of workflow processing.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Lock { get; }
Visual Basic (Declaration)
ReadOnly Property Lock As Boolean
Visual C++
property bool Lock {
    bool get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


NumberOfInteraction Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.NumberOfInteraction Property
IInteractionQueueSnapshot Interface See Also Send Feedback
Contains the number of interactions in the snapshot

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int NumberOfInteraction { get; }
Visual Basic (Declaration)
ReadOnly Property NumberOfInteraction As Integer
Visual C++
property int NumberOfInteraction {
    int get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Order Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.Order Property
IInteractionQueueSnapshot Interface See Also Send Feedback
Specifies order of interactions in the snapshot. If not specified, default order is 'received_at, id'. Snapshot orders are added to 'order by' clause of the SQL 'select' statement generated by Interaction Server. It is possible to use interaction property names and custom property names in order. Property names are automatically translated to field names.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Order { get; }
Visual Basic (Declaration)
ReadOnly Property Order As String
Visual C++
property String^ Order {
    String^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SnapshotId Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.SnapshotId Property
IInteractionQueueSnapshot Interface See Also Send Feedback
Unique ID of the interaction queue snapshot (read only). If specified, should represent an identifier of the snapshot that client has taken before. The new snapshot will inherit all the locks that the older snapshot held. The identifier of the new snapshot is the same as the old snapshot. Old snapshot is automatically released

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> SnapshotId { get; }
Visual Basic (Declaration)
ReadOnly Property SnapshotId As Nullable(Of Integer)
Visual C++
property Nullable<int> SnapshotId {
    Nullable<int> get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SnapshotMaxInteractions Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.SnapshotMaxInteractions Property
IInteractionQueueSnapshot Interface See Also Send Feedback
Specifies the maximum number of interactions that will be included in the snapshot.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> SnapshotMaxInteractions { get; }
Visual Basic (Declaration)
ReadOnly Property SnapshotMaxInteractions As Nullable(Of Integer)
Visual C++
property Nullable<int> SnapshotMaxInteractions {
    Nullable<int> get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.Strategy Property
IInteractionQueueSnapshot Interface See Also Send Feedback
The strategies associated with the workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ViewId Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueSnapshot..::.ViewId Property
IInteractionQueueSnapshot Interface See Also Send Feedback
Identifier of the interaction queue view to pull interactions from(read only). The view should be defined for the tenant. The special _system_ view allows pulling of the specific interaction by its identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ViewId { get; }
Visual Basic (Declaration)
ReadOnly Property ViewId As String
Visual C++
property String^ ViewId {
    String^ get ();
}

See Also

IInteractionQueueSnapshot Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionType Interface
Members See Also Send Feedback
Describes the interaction type:
  • Media content.
  • Media direction.
  • The interaction's subtype.
  • Internality.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IInteractionType : IShallowCopy<IInteractionType>,
    IDeepCopy<IInteractionType>
Visual Basic (Declaration)
Public Interface IInteractionType _
    Implements IShallowCopy(Of IInteractionType), IDeepCopy(Of IInteractionType)
Visual C++
public interface class IInteractionType : IShallowCopy<IInteractionType^>,
    IDeepCopy<IInteractionType^>

See Also

IInteractionType Members
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Members
IInteractionType Interface Methods Properties See Also Send Feedback

The IInteractionType type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Direction | Media direction.
Internal | True if the interaction is internal. False if interaction is external Null is interaction type is not known
MediaType | Type for the media content.
SubMediaType | Gets media type of the open media interaction.
Subtype | Interaction subtype (string).

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Methods
IInteractionType Interface See Also Send Feedback

The IInteractionType type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IInteractionType Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionType Properties
IInteractionType Interface See Also Send Feedback

The IInteractionType type exposes the following members.

Properties

Name | Description
Direction | Media direction.
Internal | True if the interaction is internal. False if interaction is external Null is interaction type is not known
MediaType | Type for the media content.
SubMediaType | Gets media type of the open media interaction.
Subtype | Interaction subtype (string).

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Direction Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Direction Property
IInteractionType Interface See Also Send Feedback
Media direction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MediaDirectionType Direction { get; }
Visual Basic (Declaration)
ReadOnly Property Direction As MediaDirectionType
Visual C++
property MediaDirectionType Direction {
    MediaDirectionType get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Internal Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Internal Property
IInteractionType Interface See Also Send Feedback
True if the interaction is internal. False if interaction is external Null is interaction type is not known

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<bool> Internal { get; }
Visual Basic (Declaration)
ReadOnly Property Internal As Nullable(Of Boolean)
Visual C++
property Nullable<bool> Internal {
    Nullable<bool> get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.MediaType Property
IInteractionType Interface See Also Send Feedback
Type for the media content.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MediaContentType MediaType { get; }
Visual Basic (Declaration)
ReadOnly Property MediaType As MediaContentType
Visual C++
property MediaContentType MediaType {
    MediaContentType get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SubMediaType Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.SubMediaType Property
IInteractionType Interface See Also Send Feedback
Gets media type of the open media interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SubMediaType { get; }
Visual Basic (Declaration)
ReadOnly Property SubMediaType As String
Visual C++
property String^ SubMediaType {
    String^ get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Subtype Property

[image]

Enterprise SDK 8.0 Reference API
IInteractionType..::.Subtype Property
IInteractionType Interface See Also Send Feedback
Interaction subtype (string).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Subtype { get; }
Visual Basic (Declaration)
ReadOnly Property Subtype As String
Visual C++
property String^ Subtype {
    String^ get ();
}

See Also

IInteractionType Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInfo Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.IMonitoredInfo"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitoredInfo : ISerializable
Visual Basic (Declaration)
Public Interface IMonitoredInfo _
    Implements ISerializable
Visual C++
public interface class IMonitoredInfo : ISerializable

See Also

IMonitoredInfo Members
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo Members
IMonitoredInfo Interface Methods Properties See Also Send Feedback

The IMonitoredInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
AgentId | Returns the agent Id of the monitored object.
PlaceId | Gets the place id.
State | Returns the monitoring status for the associated object (Monitored, NotMonitored).
TenantId | The tenant id of the monitored object

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo Methods
IMonitoredInfo Interface See Also Send Feedback

The IMonitoredInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo Properties
IMonitoredInfo Interface See Also Send Feedback

The IMonitoredInfo type exposes the following members.

Properties

Name | Description
AgentId | Returns the agent Id of the monitored object.
PlaceId | Gets the place id.
State | Returns the monitoring status for the associated object (Monitored, NotMonitored).
TenantId | The tenant id of the monitored object

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AgentId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo..::.AgentId Property
IMonitoredInfo Interface See Also Send Feedback
Returns the agent Id of the monitored object.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AgentId { get; }
Visual Basic (Declaration)
ReadOnly Property AgentId As String
Visual C++
property String^ AgentId {
    String^ get ();
}

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PlaceId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo..::.PlaceId Property
IMonitoredInfo Interface See Also Send Feedback
Gets the place id.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PlaceId { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceId As String
Visual C++
property String^ PlaceId {
    String^ get ();
}

Field Value

The place id.

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo..::.State Property
IMonitoredInfo Interface See Also Send Feedback
Returns the monitoring status for the associated object (Monitored, NotMonitored).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MonitorState State { get; }
Visual Basic (Declaration)
ReadOnly Property State As MonitorState
Visual C++
property MonitorState State {
    MonitorState get ();
}

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


TenantId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInfo..::.TenantId Property
IMonitoredInfo Interface See Also Send Feedback
The tenant id of the monitored object

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TenantId { get; }
Visual Basic (Declaration)
ReadOnly Property TenantId As Integer
Visual C++
property int TenantId {
    int get ();
}

See Also

IMonitoredInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.IMonitoredInteraction"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitoredInteraction : ISerializable
Visual Basic (Declaration)
Public Interface IMonitoredInteraction _
    Implements ISerializable
Visual C++
public interface class IMonitoredInteraction : ISerializable

See Also

IMonitoredInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction Members
IMonitoredInteraction Interface Methods Properties See Also Send Feedback

The IMonitoredInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
ContactId | Gets the contactId of the interaction
InitialDuration |
InteractionId | Gets the interaction id.
MediaType | Gets the type of the media.
PlaceId | Gets the place id.
ProxyClientId | Gets the proxy client id.
ReceivedDate |
UserData | The attached data of the interaction

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction Methods
IMonitoredInteraction Interface See Also Send Feedback

The IMonitoredInteraction type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IMonitoredInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction Properties
IMonitoredInteraction Interface See Also Send Feedback

The IMonitoredInteraction type exposes the following members.

Properties

Name | Description
ContactId | Gets the contactId of the interaction
InitialDuration |
InteractionId | Gets the interaction id.
MediaType | Gets the type of the media.
PlaceId | Gets the place id.
ProxyClientId | Gets the proxy client id.
ReceivedDate |
UserData | The attached data of the interaction

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContactId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.ContactId Property
IMonitoredInteraction Interface See Also Send Feedback
Gets the contactId of the interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContactId { get; }
Visual Basic (Declaration)
ReadOnly Property ContactId As String
Visual C++
property String^ ContactId {
    String^ get ();
}

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InitialDuration Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.InitialDuration Property
IMonitoredInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.IMonitoredInteraction.InitialDuration"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
TimeSpan InitialDuration { get; }
Visual Basic (Declaration)
ReadOnly Property InitialDuration As TimeSpan
Visual C++
property TimeSpan InitialDuration {
    TimeSpan get ();
}

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.InteractionId Property
IMonitoredInteraction Interface See Also Send Feedback
Gets the interaction id.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string InteractionId { get; }
Visual Basic (Declaration)
ReadOnly Property InteractionId As String
Visual C++
property String^ InteractionId {
    String^ get ();
}

Field Value

The interaction id.

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.MediaType Property
IMonitoredInteraction Interface See Also Send Feedback
Gets the type of the media.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MediaType { get; }
Visual Basic (Declaration)
ReadOnly Property MediaType As String
Visual C++
property String^ MediaType {
    String^ get ();
}

Field Value

The type of the media.

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PlaceId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.PlaceId Property
IMonitoredInteraction Interface See Also Send Feedback
Gets the place id.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PlaceId { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceId As String
Visual C++
property String^ PlaceId {
    String^ get ();
}

Field Value

The place id.

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ProxyClientId Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.ProxyClientId Property
IMonitoredInteraction Interface See Also Send Feedback
Gets the proxy client id.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ProxyClientId { get; }
Visual Basic (Declaration)
ReadOnly Property ProxyClientId As Integer
Visual C++
property int ProxyClientId {
    int get ();
}

Field Value

The proxy client id.

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ReceivedDate Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.ReceivedDate Property
IMonitoredInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.IMonitoredInteraction.ReceivedDate"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime ReceivedDate { get; }
Visual Basic (Declaration)
ReadOnly Property ReceivedDate As DateTime
Visual C++
property DateTime ReceivedDate {
    DateTime get ();
}

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


UserData Property

[image]

Enterprise SDK 8.0 Reference API
IMonitoredInteraction..::.UserData Property
IMonitoredInteraction Interface See Also Send Feedback
The attached data of the interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection UserData { get; }
Visual Basic (Declaration)
ReadOnly Property UserData As KeyValueCollection
Visual C++
property KeyValueCollection^ UserData {
    KeyValueCollection^ get ();
}

See Also

IMonitoredInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionOperation Enumeration

[image]

Enterprise SDK 8.0 Reference API
InteractionOperation Enumeration
See Also Send Feedback
Enumerates the operations which modify the interactions in the workbin.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum InteractionOperation
Visual Basic (Declaration)
Public Enumeration InteractionOperation
Visual C++
public enum class InteractionOperation

Members

Member name | Description
Unknown | Unknown Interaction Operation.
Transfer | An interaction was transferred.
Conference | An interaction changed due to a conference.
Intrude | An interaction changed due to an intrude operation.
Route | An interaction changes due to a routing operation.
Pull | An interaction was pulled.
Create | An interaction was created.
Reject | An interaction was rejected.
Timeout | An interaction timed out.
Leave | An interaction left.
Stop | An interaction was stopped.
PlaceInWorkbin | An interaction was placed in the workbin.
PlaceInQueue | An interaction was placed in the queue.
PartyDisconnect | A party disconnected.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


InteractionStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
InteractionStateType Enumeration
See Also Send Feedback
Lists the possible types for interactions state.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum InteractionStateType
Visual Basic (Declaration)
Public Enumeration InteractionStateType
Visual C++
public enum class InteractionStateType

Members

Member name | Description
Unknown |
PresentedIn |
PresentedOut |
Connected |
Held |
Ended |
Dropped |
Queued |
Abandonned |
Redirected |
HeldPresentedIn |
HeldPresentedOut |
Preview |
Busy |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


IOpenMediaInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction Interface
Members See Also Send Feedback
Describes an open media interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOpenMediaInteraction : IInteraction,
    IShallowCopy<IInteraction>, IDeepCopy<IInteraction>, ISerializable
Visual Basic (Declaration)
Public Interface IOpenMediaInteraction _
    Implements IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class IOpenMediaInteraction : IInteraction,
    IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>, ISerializable

See Also

IOpenMediaInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IOpenMediaInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction Members
IOpenMediaInteraction Interface Methods Properties See Also Send Feedback

The IOpenMediaInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
AgentId
The Agent Id of the interaction
AllAttributes
AssignedTo
The Agent who is assigned to this interaction
CategoryId
The identifier of the Category that is assigned to this interaction.
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
IsInWorkflow
true if the interaction is still in the workflow (read only).
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
ParentID
The parent interaction identifier.
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
PlaceId
The Place Id of the interaction
Priority
The priority of the interaction (read only).
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
TimeShift
The time shift of the interaction (read only).
VisibilityMode
The visibility mode (read only).
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOpenMediaInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction Methods
IOpenMediaInteraction Interface See Also Send Feedback

The IOpenMediaInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetAttributeInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.GetAttributeInteraction Method
IOpenMediaInteraction Interface See Also Send Feedback
Gets the additional attributes of the interaction that are not in attached data.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetAttributeInteraction(
    string attributeKey
)
Visual Basic (Declaration)
Function GetAttributeInteraction ( _
    attributeKey As String _
) As Object
Visual C++
Object^ GetAttributeInteraction(
    String^ attributeKey
)

Parameters

attributeKey
Type: System..::.String
attribute key found in InteractionKeyProperties array.

Return Value

object

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOpenMediaInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction Properties
IOpenMediaInteraction Interface See Also Send Feedback

The IOpenMediaInteraction type exposes the following members.

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
AgentId
The Agent Id of the interaction
AllAttributes
AssignedTo
The Agent who is assigned to this interaction
CategoryId
The identifier of the Category that is assigned to this interaction.
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
IsInWorkflow
true if the interaction is still in the workflow (read only).
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
ParentID
The parent interaction identifier.
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
PlaceId
The Place Id of the interaction
Priority
The priority of the interaction (read only).
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
TimeShift
The time shift of the interaction (read only).
VisibilityMode
The visibility mode (read only).
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AgentGroupId Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.AgentGroupId Property
IOpenMediaInteraction Interface See Also Send Feedback
The Agent Group Id of the interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AgentGroupId { get; }
Visual Basic (Declaration)
ReadOnly Property AgentGroupId As String
Visual C++
property String^ AgentGroupId {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AgentId Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.AgentId Property
IOpenMediaInteraction Interface See Also Send Feedback
The Agent Id of the interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AgentId { get; }
Visual Basic (Declaration)
ReadOnly Property AgentId As String
Visual C++
property String^ AgentId {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AllAttributes Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.AllAttributes Property
IOpenMediaInteraction Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.IOpenMediaInteraction.AllAttributes"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection AllAttributes { get; }
Visual Basic (Declaration)
ReadOnly Property AllAttributes As KeyValueCollection
Visual C++
property KeyValueCollection^ AllAttributes {
    KeyValueCollection^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AssignedTo Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.AssignedTo Property
IOpenMediaInteraction Interface See Also Send Feedback
The Agent who is assigned to this interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AssignedTo { get; }
Visual Basic (Declaration)
ReadOnly Property AssignedTo As String
Visual C++
property String^ AssignedTo {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CategoryId Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.CategoryId Property
IOpenMediaInteraction Interface See Also Send Feedback
The identifier of the Category that is assigned to this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CategoryId { get; set; }
Visual Basic (Declaration)
Property CategoryId As String
Visual C++
property String^ CategoryId {
    String^ get ();
    void set (String^ value);
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CategoryRelevancy Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.CategoryRelevancy Property
IOpenMediaInteraction Interface See Also Send Feedback
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CategoryRelevancy { get; }
Visual Basic (Declaration)
ReadOnly Property CategoryRelevancy As String
Visual C++
property String^ CategoryRelevancy {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DatePlaceInQueue Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.DatePlaceInQueue Property
IOpenMediaInteraction Interface See Also Send Feedback
The PlaceInQueue date of the interaction (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DateTime DatePlaceInQueue { get; }
Visual Basic (Declaration)
ReadOnly Property DatePlaceInQueue As DateTime
Visual C++
property DateTime DatePlaceInQueue {
    DateTime get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InputQueues Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.InputQueues Property
IOpenMediaInteraction Interface See Also Send Feedback
The input queues of the interaction (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> InputQueues { get; }
Visual Basic (Declaration)
ReadOnly Property InputQueues As ICollection(Of String)
Visual C++
property ICollection<String^>^ InputQueues {
    ICollection<String^>^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsConnected Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.IsConnected Property
IOpenMediaInteraction Interface See Also Send Feedback
true if the associated media is connected (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsConnected { get; }
Visual Basic (Declaration)
ReadOnly Property IsConnected As Boolean
Visual C++
property bool IsConnected {
    bool get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsInWorkflow Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.IsInWorkflow Property
IOpenMediaInteraction Interface See Also Send Feedback
true if the interaction is still in the workflow (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsInWorkflow { get; }
Visual Basic (Declaration)
ReadOnly Property IsInWorkflow As Boolean
Visual C++
property bool IsInWorkflow {
    bool get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsOnline Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.IsOnline Property
IOpenMediaInteraction Interface See Also Send Feedback
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsOnline { get; }
Visual Basic (Declaration)
ReadOnly Property IsOnline As Boolean
Visual C++
property bool IsOnline {
    bool get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IxnServerInteractionState Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.IxnServerInteractionState Property
IOpenMediaInteraction Interface See Also Send Feedback
The Interaction State of this interaction (information from Interaction Server)

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IxnServerInteractionState IxnServerInteractionState { get; }
Visual Basic (Declaration)
ReadOnly Property IxnServerInteractionState As IxnServerInteractionState
Visual C++
property IxnServerInteractionState IxnServerInteractionState {
    IxnServerInteractionState get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


OutputQueues Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.OutputQueues Property
IOpenMediaInteraction Interface See Also Send Feedback
The output queues of the interaction (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> OutputQueues { get; }
Visual Basic (Declaration)
ReadOnly Property OutputQueues As ICollection(Of String)
Visual C++
property ICollection<String^>^ OutputQueues {
    ICollection<String^>^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


OwnerID Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.OwnerID Property
IOpenMediaInteraction Interface See Also Send Feedback
The interaction's owner identifier (DBID).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int OwnerID { get; set; }
Visual Basic (Declaration)
Property OwnerID As Integer
Visual C++
property int OwnerID {
    int get ();
    void set (int value);
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ParentID Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.ParentID Property
IOpenMediaInteraction Interface See Also Send Feedback
The parent interaction identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ParentID { get; set; }
Visual Basic (Declaration)
Property ParentID As String
Visual C++
property String^ ParentID {
    String^ get ();
    void set (String^ value);
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PlaceGroupId Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.PlaceGroupId Property
IOpenMediaInteraction Interface See Also Send Feedback
The Place Group Id of the interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PlaceGroupId { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceGroupId As String
Visual C++
property String^ PlaceGroupId {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PlaceId Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.PlaceId Property
IOpenMediaInteraction Interface See Also Send Feedback
The Place Id of the interaction

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PlaceId { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceId As String
Visual C++
property String^ PlaceId {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Priority Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.Priority Property
IOpenMediaInteraction Interface See Also Send Feedback
The priority of the interaction (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Priority { get; }
Visual Basic (Declaration)
ReadOnly Property Priority As Integer
Visual C++
property int Priority {
    int get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.Queue Property
IOpenMediaInteraction Interface See Also Send Feedback

Overload List

Name | Description
Queue | Queues associated with the interaction. (Inherited from IInteraction.)
Queue | If the interaction is in a queue, the Queue where the interaction is stored.

See Also

IOpenMediaInteraction Interface
IOpenMediaInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.Queue Property
IOpenMediaInteraction Interface See Also Send Feedback
If the interaction is in a queue, the Queue where the interaction is stored.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Queue { get; }
Visual Basic (Declaration)
ReadOnly Property Queue As String
Visual C++
property String^ Queue {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Queue Overload
Genesyslab.Enterprise.Model.Interaction Namespace


Subject Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.Subject Property
IOpenMediaInteraction Interface See Also Send Feedback
Subject of the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Subject { get; set; }
Visual Basic (Declaration)
Property Subject As String
Visual C++
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SuggestedCategories Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.SuggestedCategories Property
IOpenMediaInteraction Interface See Also Send Feedback
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, string> SuggestedCategories { get; }
Visual Basic (Declaration)
ReadOnly Property SuggestedCategories As IDictionary(Of String, String)
Visual C++
property IDictionary<String^, String^>^ SuggestedCategories {
    IDictionary<String^, String^>^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ThreadID Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.ThreadID Property
IOpenMediaInteraction Interface See Also Send Feedback
The thread identifier of the interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ThreadID { get; set; }
Visual Basic (Declaration)
Property ThreadID As String
Visual C++
property String^ ThreadID {
    String^ get ();
    void set (String^ value);
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


TimeShift Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.TimeShift Property
IOpenMediaInteraction Interface See Also Send Feedback
The time shift of the interaction (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TimeShift { get; }
Visual Basic (Declaration)
ReadOnly Property TimeShift As Integer
Visual C++
property int TimeShift {
    int get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


VisibilityMode Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.VisibilityMode Property
IOpenMediaInteraction Interface See Also Send Feedback
The visibility mode (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Visibility VisibilityMode { get; }
Visual Basic (Declaration)
ReadOnly Property VisibilityMode As Visibility
Visual C++
property Visibility VisibilityMode {
    Visibility get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Workbin Property

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaInteraction..::.Workbin Property
IOpenMediaInteraction Interface See Also Send Feedback
If the interaction is in a workbin, the Workbin where the interaction is stored.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Workbin { get; }
Visual Basic (Declaration)
ReadOnly Property Workbin As String
Visual C++
property String^ Workbin {
    String^ get ();
}

See Also

IOpenMediaInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundField Interface

[image]

Enterprise SDK 8.0 Reference API
IOutboundField Interface
Members See Also Send Feedback
Describes a CustomField (from Configuration).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOutboundField : IShallowCopy<IOutboundField>,
    IDeepCopy<IOutboundField>, ISerializable
Visual Basic (Declaration)
Public Interface IOutboundField _
    Implements IShallowCopy(Of IOutboundField), IDeepCopy(Of IOutboundField),  _
    ISerializable
Visual C++
public interface class IOutboundField : IShallowCopy<IOutboundField^>,
    IDeepCopy<IOutboundField^>, ISerializable

See Also

IOutboundField Members
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundField Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundField Members
IOutboundField Interface Methods Properties See Also Send Feedback

The IOutboundField type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
CustomType | Gets the type of the outbound field.
IsMandatory | Returns true if the outbound field is mandatory.
Name | Gets the name of the outbound field.
TenantDBID | Gets the tenant DBID.

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundField Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundField Methods
IOutboundField Interface See Also Send Feedback

The IOutboundField type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundField Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundField Properties
IOutboundField Interface See Also Send Feedback

The IOutboundField type exposes the following members.

Properties

Name | Description
CustomType | Gets the type of the outbound field.
IsMandatory | Returns true if the outbound field is mandatory.
Name | Gets the name of the outbound field.
TenantDBID | Gets the tenant DBID.

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CustomType Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundField..::.CustomType Property
IOutboundField Interface See Also Send Feedback
Gets the type of the outbound field.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type CustomType { get; set; }
Visual Basic (Declaration)
Property CustomType As Type
Visual C++
property Type^ CustomType {
    Type^ get ();
    void set (Type^ value);
}

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsMandatory Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundField..::.IsMandatory Property
IOutboundField Interface See Also Send Feedback
Returns true if the outbound field is mandatory.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsMandatory { get; set; }
Visual Basic (Declaration)
Property IsMandatory As Boolean
Visual C++
property bool IsMandatory {
    bool get ();
    void set (bool value);
}

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundField..::.Name Property
IOutboundField Interface See Also Send Feedback
Gets the name of the outbound field.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


TenantDBID Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundField..::.TenantDBID Property
IOutboundField Interface See Also Send Feedback
Gets the tenant DBID.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TenantDBID { get; set; }
Visual Basic (Declaration)
Property TenantDBID As Integer
Visual C++
property int TenantDBID {
    int get ();
    void set (int value);
}

See Also

IOutboundField Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundPreviewInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction Interface
Members See Also Send Feedback
Describes an outbound interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOutboundPreviewInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction>, IDeepCopy<IInteraction>,
    ISerializable
Visual Basic (Declaration)
Public Interface IOutboundPreviewInteraction _
    Implements IOpenMediaInteraction, IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class IOutboundPreviewInteraction : IOpenMediaInteraction,
    IInteraction, IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>,
    ISerializable

See Also

IOutboundPreviewInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundPreviewInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction Members
IOutboundPreviewInteraction Interface Methods Properties See Also Send Feedback

The IOutboundPreviewInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CallingListName
Gets the Calling List name.
CampaignName
Gets The Campaign name.
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
ChainID
Gets the Chain Identifier.
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
Records
Gets the collection of records (ChainedRecord) for this interaction.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundPreviewInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction Methods
IOutboundPreviewInteraction Interface See Also Send Feedback

The IOutboundPreviewInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IOutboundPreviewInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction Properties
IOutboundPreviewInteraction Interface See Also Send Feedback

The IOutboundPreviewInteraction type exposes the following members.

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CallingListName
Gets the Calling List name.
CampaignName
Gets The Campaign name.
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
ChainID
Gets the Chain Identifier.
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
Records
Gets the collection of records (ChainedRecord) for this interaction.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CallingListName Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction..::.CallingListName Property
IOutboundPreviewInteraction Interface See Also Send Feedback
Gets the Calling List name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CallingListName { get; }
Visual Basic (Declaration)
ReadOnly Property CallingListName As String
Visual C++
property String^ CallingListName {
    String^ get ();
}

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CampaignName Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction..::.CampaignName Property
IOutboundPreviewInteraction Interface See Also Send Feedback
Gets The Campaign name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CampaignName { get; }
Visual Basic (Declaration)
ReadOnly Property CampaignName As String
Visual C++
property String^ CampaignName {
    String^ get ();
}

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ChainID Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction..::.ChainID Property
IOutboundPreviewInteraction Interface See Also Send Feedback
Gets the Chain Identifier.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ChainID { get; }
Visual Basic (Declaration)
ReadOnly Property ChainID As Integer
Visual C++
property int ChainID {
    int get ();
}

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction..::.Queue Property
IOutboundPreviewInteraction Interface See Also Send Feedback

Overload List

Name | Description
Queue | Queues associated with the interaction. (Inherited from IInteraction.)
Queue | If the interaction is in a queue, the Queue where the interaction is stored. (Inherited from IOpenMediaInteraction.)

See Also

IOutboundPreviewInteraction Interface
IOutboundPreviewInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


Records Property

[image]

Enterprise SDK 8.0 Reference API
IOutboundPreviewInteraction..::.Records Property
IOutboundPreviewInteraction Interface See Also Send Feedback
Gets the collection of records (ChainedRecord) for this interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IRecord> Records { get; }
Visual Basic (Declaration)
ReadOnly Property Records As ICollection(Of IRecord)
Visual C++
property ICollection<IRecord^>^ Records {
    ICollection<IRecord^>^ get ();
}

See Also

IOutboundPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Interface

[image]

Enterprise SDK 8.0 Reference API
IParty Interface
Members See Also Send Feedback
Describes one party of a device or a call.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IParty : IRoleable, IShallowCopy<IParty>,
    IDeepCopy<IParty>
Visual Basic (Declaration)
Public Interface IParty _
    Implements IRoleable, IShallowCopy(Of IParty),  _
    IDeepCopy(Of IParty)
Visual C++
public interface class IParty : IRoleable,
    IShallowCopy<IParty^>, IDeepCopy<IParty^>

See Also

IParty Members
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Members

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Members
IParty Interface Methods Properties See Also Send Feedback

The IParty type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)
Translate | Get the translation of a party

Properties

Name | Description
Attributes | Dynamic/static data of the party.
Context | Context of the party.
Device | Linked devices to the party.
DisplayName | Name displayed to the user
Extensions | Extensions of the party instance.
Interaction | Linked interaction to the party.
IsIdentified | True if the party could be identified
IsMonitored | True if the party is monitored.
IsOwner | True if this party is the interaction's owner.
Name | Name of the party.
PartyType | Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Methods
IParty Interface See Also Send Feedback

The IParty type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)
Translate | Get the translation of a party

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Translate Method

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Translate Method
IParty Interface See Also Send Feedback
Get the translation of a party

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Translate(
    PartyTranslationType description
)
Visual Basic (Declaration)
Function Translate ( _
    description As PartyTranslationType _
) As String
Visual C++
String^ Translate(
    PartyTranslationType description
)

Parameters

description
Type: Genesyslab.Enterprise.Model.Interaction..::.PartyTranslationType

[Missing <param name="description"/> documentation for "M:Genesyslab.Enterprise.Model.Interaction.IParty.Translate(Genesyslab.Enterprise.Model.Interaction.PartyTranslationType)"]

Return Value

string

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IParty Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IParty Properties
IParty Interface See Also Send Feedback

The IParty type exposes the following members.

Properties

Name | Description
Attributes | Dynamic/static data of the party.
Context | Context of the party.
Device | Linked devices to the party.
DisplayName | Name displayed to the user
Extensions | Extensions of the party instance.
Interaction | Linked interaction to the party.
IsIdentified | True if the party could be identified
IsMonitored | True if the party is monitored.
IsOwner | True if this party is the interaction's owner.
Name | Name of the party.
PartyType | Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.
Role | Gets or sets the role of an object. (Inherited from IRoleable.)

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Attributes Property
IParty Interface See Also Send Feedback
Dynamic/static data of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDynamicAttribute> Attributes { get; }
Visual Basic (Declaration)
ReadOnly Property Attributes As IDictionary(Of String, IDynamicAttribute)
Visual C++
property IDictionary<String^, IDynamicAttribute^>^ Attributes {
    IDictionary<String^, IDynamicAttribute^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Context Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Context Property
IParty Interface See Also Send Feedback
Context of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContext Context { get; }
Visual Basic (Declaration)
ReadOnly Property Context As IContext
Visual C++
property IContext^ Context {
    IContext^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Device Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Device Property
IParty Interface See Also Send Feedback
Linked devices to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] Device { get; }
Visual Basic (Declaration)
ReadOnly Property Device As IDevice()
Visual C++
property array<IDevice^>^ Device {
    array<IDevice^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DisplayName Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.DisplayName Property
IParty Interface See Also Send Feedback
Name displayed to the user

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string DisplayName { get; }
Visual Basic (Declaration)
ReadOnly Property DisplayName As String
Visual C++
property String^ DisplayName {
    String^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Extensions Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Extensions Property
IParty Interface See Also Send Feedback
Extensions of the party instance.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IExtension> Extensions { get; }
Visual Basic (Declaration)
ReadOnly Property Extensions As IDictionary(Of String, IExtension)
Visual C++
property IDictionary<String^, IExtension^>^ Extensions {
    IDictionary<String^, IExtension^>^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Interaction Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Interaction Property
IParty Interface See Also Send Feedback
Linked interaction to the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction Interaction { get; }
Visual Basic (Declaration)
ReadOnly Property Interaction As IInteraction
Visual C++
property IInteraction^ Interaction {
    IInteraction^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsIdentified Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsIdentified Property
IParty Interface See Also Send Feedback
True if the party could be identified

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsIdentified { get; }
Visual Basic (Declaration)
ReadOnly Property IsIdentified As Boolean
Visual C++
property bool IsIdentified {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsMonitored Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsMonitored Property
IParty Interface See Also Send Feedback
True if the party is monitored.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsMonitored { get; }
Visual Basic (Declaration)
ReadOnly Property IsMonitored As Boolean
Visual C++
property bool IsMonitored {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsOwner Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.IsOwner Property
IParty Interface See Also Send Feedback
True if this party is the interaction's owner.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsOwner { get; }
Visual Basic (Declaration)
ReadOnly Property IsOwner As Boolean
Visual C++
property bool IsOwner {
    bool get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.Name Property
IParty Interface See Also Send Feedback
Name of the party.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PartyType Property

[image]

Enterprise SDK 8.0 Reference API
IParty..::.PartyType Property
IParty Interface See Also Send Feedback
Party type. Indicates whether this party is the caller, the callee, or a third party for instance during a transfer.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
PartyInfoType PartyType { get; }
Visual Basic (Declaration)
ReadOnly Property PartyType As PartyInfoType
Visual C++
property PartyInfoType PartyType {
    PartyInfoType get ();
}

See Also

IParty Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Interface
Members See Also Send Feedback
Describes a preview interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPreviewInteraction : IShallowCopy<IPreviewInteraction>,
    IDeepCopy<IPreviewInteraction>, ISerializable
Visual Basic (Declaration)
Public Interface IPreviewInteraction _
    Implements IShallowCopy(Of IPreviewInteraction), IDeepCopy(Of IPreviewInteraction),  _
    ISerializable
Visual C++
public interface class IPreviewInteraction : IShallowCopy<IPreviewInteraction^>,
    IDeepCopy<IPreviewInteraction^>, ISerializable

See Also

IPreviewInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Members
IPreviewInteraction Interface Methods See Also Send Feedback

The IPreviewInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IPreviewInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewInteraction Methods
IPreviewInteraction Interface See Also Send Feedback

The IPreviewInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IPreviewInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IRecord Interface

[image]

Enterprise SDK 8.0 Reference API
IRecord Interface
Members See Also Send Feedback
Describes a Record.
  • Added
  • Cancelled
  • Do Not Call
  • Updated
  • Rescheduled

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IRecord : IShallowCopy<IRecord>,
    IDeepCopy<IRecord>, ISerializable
Visual Basic (Declaration)
Public Interface IRecord _
    Implements IShallowCopy(Of IRecord), IDeepCopy(Of IRecord),  _
    ISerializable
Visual C++
public interface class IRecord : IShallowCopy<IRecord^>,
    IDeepCopy<IRecord^>, ISerializable

See Also

IRecord Members
Genesyslab.Enterprise.Model.Interaction Namespace


IRecord Members

[image] [image]

Enterprise SDK 8.0 Reference API
IRecord Members
IRecord Interface Methods Properties See Also Send Feedback

The IRecord type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
GetRecordProperty | Obsolete. Gets Record property by name.
SetRecordProperty | Obsolete. Sets Record Property by name.
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
AgentID | Gets the Agent ID of the record.
Attempts | Gets the number of attempts for the record.
CallAttemptGUID | Gets the Call GUID of the record.
CallingListName | Gets the CallingList name;
CallResult | Gets/sets the CallResult of the record. Could be null.
CampaignInfo | Gets the campaign info.
ChainID | Gets the Chain ID of the record.
ContactMediaType | Gets the Contact Media type.
CustomFields | Gets/sets the Customer Fields dictionary.
DailyFrom | Gets/sets the daily from of the record.
DailyUntil | Gets/sets the daily until of the record.
IsScheduled | Gets if the record is already scheduled.
IsSolicited | False when record is a scheduled call push by the server True when record has been requested by the client (record may be also a scheduled call !) See option predictive_callback in OCS options
PhoneNumber | Gets/sets the phone number of the record.
PhoneNumberType | Gets/sets the phone number type of the record.
RecordHandle | Gets the record handle.
RecordID | Gets the Chain Number of the record.
ScheduledMode | Get the call back type when a record is (re)scheduled
SystemFields | Gets/sets the System Fields dictionary.
TenantDBID | Gets the tenant DBID of the record.
TimeZone | Gets/sets the time zone of the record.
TimeZoneOffset | Gets/sets the time zone offset of the record.
UserData | Gets the original user data for processing record.

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IRecord Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IRecord Methods
IRecord Interface See Also Send Feedback

The IRecord type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
GetRecordProperty | Obsolete. Gets Record property by name.
SetRecordProperty | Obsolete. Sets Record Property by name.
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


GetRecordProperty Method

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.GetRecordProperty Method
IRecord Interface See Also Send Feedback
Gets Record property by name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not used. Will be removed. Use SystemFields instead")]
Object GetRecordProperty(
    string key
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not used. Will be removed. Use SystemFields instead")> _
Function GetRecordProperty ( _
    key As String _
) As Object
Visual C++
[ObsoleteAttribute(L"Do not used. Will be removed. Use SystemFields instead")]
Object^ GetRecordProperty(
    String^ key
)

Parameters

key
Type: System..::.String
The name of the property.

Return Value

an object

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SetRecordProperty Method

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.SetRecordProperty Method
IRecord Interface See Also Send Feedback
Sets Record Property by name.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not used. Will be removed. Use SystemFields instead")]
bool SetRecordProperty(
    string key,
    Object value
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not used. Will be removed. Use SystemFields instead")> _
Function SetRecordProperty ( _
    key As String, _
    value As Object _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not used. Will be removed. Use SystemFields instead")]
bool SetRecordProperty(
    String^ key,
    Object^ value
)

Parameters

key
Type: System..::.String
The name of the property.
value
Type: System..::.Object
The value of the property.

Return Value

true if set action succed.

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IRecord Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IRecord Properties
IRecord Interface See Also Send Feedback

The IRecord type exposes the following members.

Properties

Name | Description
AgentID | Gets the Agent ID of the record.
Attempts | Gets the number of attempts for the record.
CallAttemptGUID | Gets the Call GUID of the record.
CallingListName | Gets the CallingList name;
CallResult | Gets/sets the CallResult of the record. Could be null.
CampaignInfo | Gets the campaign info.
ChainID | Gets the Chain ID of the record.
ContactMediaType | Gets the Contact Media type.
CustomFields | Gets/sets the Customer Fields dictionary.
DailyFrom | Gets/sets the daily from of the record.
DailyUntil | Gets/sets the daily until of the record.
IsScheduled | Gets if the record is already scheduled.
IsSolicited | False when record is a scheduled call push by the server True when record has been requested by the client (record may be also a scheduled call !) See option predictive_callback in OCS options
PhoneNumber | Gets/sets the phone number of the record.
PhoneNumberType | Gets/sets the phone number type of the record.
RecordHandle | Gets the record handle.
RecordID | Gets the Chain Number of the record.
ScheduledMode | Get the call back type when a record is (re)scheduled
SystemFields | Gets/sets the System Fields dictionary.
TenantDBID | Gets the tenant DBID of the record.
TimeZone | Gets/sets the time zone of the record.
TimeZoneOffset | Gets/sets the time zone offset of the record.
UserData | Gets the original user data for processing record.

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


AgentID Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.AgentID Property
IRecord Interface See Also Send Feedback
Gets the Agent ID of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AgentID { get; }
Visual Basic (Declaration)
ReadOnly Property AgentID As String
Visual C++
property String^ AgentID {
    String^ get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Attempts Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.Attempts Property
IRecord Interface See Also Send Feedback
Gets the number of attempts for the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int Attempts { get; }
Visual Basic (Declaration)
ReadOnly Property Attempts As Integer
Visual C++
property int Attempts {
    int get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CallAttemptGUID Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.CallAttemptGUID Property
IRecord Interface See Also Send Feedback
Gets the Call GUID of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CallAttemptGUID { get; }
Visual Basic (Declaration)
ReadOnly Property CallAttemptGUID As String
Visual C++
property String^ CallAttemptGUID {
    String^ get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CallingListName Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.CallingListName Property
IRecord Interface See Also Send Feedback
Gets the CallingList name;

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string CallingListName { get; }
Visual Basic (Declaration)
ReadOnly Property CallingListName As String
Visual C++
property String^ CallingListName {
    String^ get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CallResult Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.CallResult Property
IRecord Interface See Also Send Feedback
Gets/sets the CallResult of the record. Could be null.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<CallResult> CallResult { get; set; }
Visual Basic (Declaration)
Property CallResult As Nullable(Of CallResult)
Visual C++
property Nullable<CallResult> CallResult {
    Nullable<CallResult> get ();
    void set (Nullable<CallResult> value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CampaignInfo Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.CampaignInfo Property
IRecord Interface See Also Send Feedback
Gets the campaign info.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaign CampaignInfo { get; }
Visual Basic (Declaration)
ReadOnly Property CampaignInfo As ICampaign
Visual C++
property ICampaign^ CampaignInfo {
    ICampaign^ get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ChainID Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.ChainID Property
IRecord Interface See Also Send Feedback
Gets the Chain ID of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ChainID { get; }
Visual Basic (Declaration)
ReadOnly Property ChainID As Integer
Visual C++
property int ChainID {
    int get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ContactMediaType Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.ContactMediaType Property
IRecord Interface See Also Send Feedback
Gets the Contact Media type.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ContactMediaType { get; set; }
Visual Basic (Declaration)
Property ContactMediaType As String
Visual C++
property String^ ContactMediaType {
    String^ get ();
    void set (String^ value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


CustomFields Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.CustomFields Property
IRecord Interface See Also Send Feedback
Gets/sets the Customer Fields dictionary.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, Object> CustomFields { get; set; }
Visual Basic (Declaration)
Property CustomFields As IDictionary(Of String, Object)
Visual C++
property IDictionary<String^, Object^>^ CustomFields {
    IDictionary<String^, Object^>^ get ();
    void set (IDictionary<String^, Object^>^ value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DailyFrom Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.DailyFrom Property
IRecord Interface See Also Send Feedback
Gets/sets the daily from of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int DailyFrom { get; set; }
Visual Basic (Declaration)
Property DailyFrom As Integer
Visual C++
property int DailyFrom {
    int get ();
    void set (int value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DailyUntil Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.DailyUntil Property
IRecord Interface See Also Send Feedback
Gets/sets the daily until of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int DailyUntil { get; set; }
Visual Basic (Declaration)
Property DailyUntil As Integer
Visual C++
property int DailyUntil {
    int get ();
    void set (int value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsScheduled Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.IsScheduled Property
IRecord Interface See Also Send Feedback
Gets if the record is already scheduled.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsScheduled { get; }
Visual Basic (Declaration)
ReadOnly Property IsScheduled As Boolean
Visual C++
property bool IsScheduled {
    bool get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsSolicited Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.IsSolicited Property
IRecord Interface See Also Send Feedback
False when record is a scheduled call push by the server True when record has been requested by the client (record may be also a scheduled call !) See option predictive_callback in OCS options

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsSolicited { get; }
Visual Basic (Declaration)
ReadOnly Property IsSolicited As Boolean
Visual C++
property bool IsSolicited {
    bool get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PhoneNumber Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.PhoneNumber Property
IRecord Interface See Also Send Feedback
Gets/sets the phone number of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PhoneNumber { get; set; }
Visual Basic (Declaration)
Property PhoneNumber As String
Visual C++
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


PhoneNumberType Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.PhoneNumberType Property
IRecord Interface See Also Send Feedback
Gets/sets the phone number type of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
PhoneType PhoneNumberType { get; set; }
Visual Basic (Declaration)
Property PhoneNumberType As PhoneType
Visual C++
property PhoneType PhoneNumberType {
    PhoneType get ();
    void set (PhoneType value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RecordHandle Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.RecordHandle Property
IRecord Interface See Also Send Feedback
Gets the record handle.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int RecordHandle { get; }
Visual Basic (Declaration)
ReadOnly Property RecordHandle As Integer
Visual C++
property int RecordHandle {
    int get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


RecordID Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.RecordID Property
IRecord Interface See Also Send Feedback
Gets the Chain Number of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int RecordID { get; }
Visual Basic (Declaration)
ReadOnly Property RecordID As Integer
Visual C++
property int RecordID {
    int get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ScheduledMode Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.ScheduledMode Property
IRecord Interface See Also Send Feedback
Get the call back type when a record is (re)scheduled

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
CallBackType ScheduledMode { get; }
Visual Basic (Declaration)
ReadOnly Property ScheduledMode As CallBackType
Visual C++
property CallBackType ScheduledMode {
    CallBackType get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SystemFields Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.SystemFields Property
IRecord Interface See Also Send Feedback
Gets/sets the System Fields dictionary.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, Object> SystemFields { get; set; }
Visual Basic (Declaration)
Property SystemFields As IDictionary(Of String, Object)
Visual C++
property IDictionary<String^, Object^>^ SystemFields {
    IDictionary<String^, Object^>^ get ();
    void set (IDictionary<String^, Object^>^ value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


TenantDBID Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.TenantDBID Property
IRecord Interface See Also Send Feedback
Gets the tenant DBID of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TenantDBID { get; }
Visual Basic (Declaration)
ReadOnly Property TenantDBID As Integer
Visual C++
property int TenantDBID {
    int get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


TimeZone Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.TimeZone Property
IRecord Interface See Also Send Feedback
Gets/sets the time zone of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string TimeZone { get; set; }
Visual Basic (Declaration)
Property TimeZone As String
Visual C++
property String^ TimeZone {
    String^ get ();
    void set (String^ value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


TimeZoneOffset Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.TimeZoneOffset Property
IRecord Interface See Also Send Feedback
Gets/sets the time zone offset of the record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int TimeZoneOffset { get; set; }
Visual Basic (Declaration)
Property TimeZoneOffset As Integer
Visual C++
property int TimeZoneOffset {
    int get ();
    void set (int value);
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


UserData Property

[image]

Enterprise SDK 8.0 Reference API
IRecord..::.UserData Property
IRecord Interface See Also Send Feedback
Gets the original user data for processing record.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection UserData { get; }
Visual Basic (Declaration)
ReadOnly Property UserData As KeyValueCollection
Visual C++
property KeyValueCollection^ UserData {
    KeyValueCollection^ get ();
}

See Also

IRecord Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInfo Interface

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo Interface
Members See Also Send Feedback
Interface for SMS data container

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISMSInfo
Visual Basic (Declaration)
Public Interface ISMSInfo
Visual C++
public interface class ISMSInfo

See Also

ISMSInfo Members
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSInfo Members
ISMSInfo Interface Properties See Also Send Feedback

The ISMSInfo type exposes the following members.

Properties

Name | Description
Encoding | Get the encoding type of the SMS received
From | sender identifier
IsMultiPart | Obsolete.
SubjectHeader | SMS Subject
To | Receiver identifier
Transcript | Get the SMS message received

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSInfo Properties
ISMSInfo Interface See Also Send Feedback

The ISMSInfo type exposes the following members.

Properties

Name | Description
Encoding | Get the encoding type of the SMS received
From | sender identifier
IsMultiPart | Obsolete.
SubjectHeader | SMS Subject
To | Receiver identifier
Transcript | Get the SMS message received

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Encoding Property

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo..::.Encoding Property
ISMSInfo Interface See Also Send Feedback
Get the encoding type of the SMS received

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
EncodingType Encoding { get; }
Visual Basic (Declaration)
ReadOnly Property Encoding As EncodingType
Visual C++
property EncodingType Encoding {
    EncodingType get ();
}

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


From Property

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo..::.From Property
ISMSInfo Interface See Also Send Feedback
sender identifier

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string From { get; }
Visual Basic (Declaration)
ReadOnly Property From As String
Visual C++
property String^ From {
    String^ get ();
}

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsMultiPart Property

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo..::.IsMultiPart Property
ISMSInfo Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Model.Interaction.ISMSInfo.IsMultiPart"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Since 8.1.3")]
bool IsMultiPart { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Since 8.1.3")> _
ReadOnly Property IsMultiPart As Boolean
Visual C++
[ObsoleteAttribute(L"Since 8.1.3")]
property bool IsMultiPart {
    bool get ();
}

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


SubjectHeader Property

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo..::.SubjectHeader Property
ISMSInfo Interface See Also Send Feedback
SMS Subject

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SubjectHeader { get; }
Visual Basic (Declaration)
ReadOnly Property SubjectHeader As String
Visual C++
property String^ SubjectHeader {
    String^ get ();
}

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


To Property

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo..::.To Property
ISMSInfo Interface See Also Send Feedback
Receiver identifier

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string To { get; }
Visual Basic (Declaration)
ReadOnly Property To As String
Visual C++
property String^ To {
    String^ get ();
}

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Transcript Property

[image]

Enterprise SDK 8.0 Reference API
ISMSInfo..::.Transcript Property
ISMSInfo Interface See Also Send Feedback
Get the SMS message received

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Transcript { get; }
Visual Basic (Declaration)
ReadOnly Property Transcript As String
Visual C++
property String^ Transcript {
    String^ get ();
}

See Also

ISMSInfo Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInteraction Interface

[image]

Enterprise SDK 8.0 Reference API
ISMSInteraction Interface
Members See Also Send Feedback
Describes an SMS interaction.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISMSInteraction : ISMSInfo,
    IOpenMediaInteraction, IInteraction, IShallowCopy<IInteraction>, IDeepCopy<IInteraction>,
    ISerializable
Visual Basic (Declaration)
Public Interface ISMSInteraction _
    Implements ISMSInfo, IOpenMediaInteraction, IInteraction, IShallowCopy(Of IInteraction),  _
    IDeepCopy(Of IInteraction), ISerializable
Visual C++
public interface class ISMSInteraction : ISMSInfo,
    IOpenMediaInteraction, IInteraction, IShallowCopy<IInteraction^>, IDeepCopy<IInteraction^>,
    ISerializable

See Also

ISMSInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInteraction Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSInteraction Members
ISMSInteraction Interface Methods Properties See Also Send Feedback

The ISMSInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Encoding
Get the encoding type of the SMS received
(Inherited from ISMSInfo.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
From
sender identifier
(Inherited from ISMSInfo.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsMultiPart | Obsolete. (Inherited from ISMSInfo.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SubjectHeader
SMS Subject
(Inherited from ISMSInfo.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
To
Receiver identifier
(Inherited from ISMSInfo.)
Transcript
Get the SMS message received
(Inherited from ISMSInfo.)
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

ISMSInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInteraction Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSInteraction Methods
ISMSInteraction Interface See Also Send Feedback

The ISMSInteraction type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetAttributeInteraction | Gets the additional attributes of the interaction that are not in attached data. (Inherited from IOpenMediaInteraction.)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
IsDone | Returns true if the interaction is disabled. When done, further state changes are impossible. (Inherited from IInteraction.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

ISMSInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ISMSInteraction Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSInteraction Properties
ISMSInteraction Interface See Also Send Feedback

The ISMSInteraction type exposes the following members.

Properties

Name | Description
ActionsTransitions
Get IsPossible feature
(Inherited from IInteraction.)
ActiveChannel
Returns the active channel.
(Inherited from IInteraction.)
AgentGroupId
The Agent Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
AgentId
The Agent Id of the interaction
(Inherited from IOpenMediaInteraction.)
AllAttributes | (Inherited from IOpenMediaInteraction.)
AssignedTo
The Agent who is assigned to this interaction
(Inherited from IOpenMediaInteraction.)
CategoryId
The identifier of the Category that is assigned to this interaction.
(Inherited from IOpenMediaInteraction.)
CategoryRelevancy
The relevancy of the assigned CategoryId (read only). The string value can be an integer or a float value.
(Inherited from IOpenMediaInteraction.)
Channels
Returns the channels associated with this interaction.
(Inherited from IInteraction.)
Controller
Controller.
(Inherited from IInteraction.)
Customer
Returns the customer party.
(Inherited from IInteraction.)
Data
Returns the data associated with the interaction.
(Inherited from IInteraction.)
DatePlaceInQueue
The PlaceInQueue date of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Encoding
Get the encoding type of the SMS received
(Inherited from ISMSInfo.)
EndDate
Interaction end data. Same as server end date.
(Inherited from IInteraction.)
FQName
Returns the interaction's Fully Qualified Name (unique Id).
(Inherited from IInteraction.)
From
sender identifier
(Inherited from ISMSInfo.)
Id
Returns the interaction's identifier.
(Inherited from IInteraction.)
IdType
Returns the interaction type.
(Inherited from IInteraction.)
InputQueues
The input queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
IsArchive
Returns true if the interaction is not active (part of a History.
(Inherited from IInteraction.)
IsConnected
true if the associated media is connected (read only).
(Inherited from IOpenMediaInteraction.)
IsInWorkflow
true if the interaction is still in the workflow (read only).
(Inherited from IOpenMediaInteraction.)
IsMultiPart | Obsolete. (Inherited from ISMSInfo.)
IsOnline
true if customer is connected from the Interaction Server's point of view (read only). the associated Media may be on line or not
(Inherited from IOpenMediaInteraction.)
Item
Returns the inner properties (low level PSDK message properties; see the Platform SDK documentation for further details).
(Inherited from IInteraction.)
IxnServerInteractionState
The Interaction State of this interaction (information from Interaction Server)
(Inherited from IOpenMediaInteraction.)
Originator
Returns the originting party when interaction is transfered
(Inherited from IInteraction.)
OutputQueues
The output queues of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Owner
Returns the party who owns this interaction.
(Inherited from IInteraction.)
OwnerID
The interaction's owner identifier (DBID).
(Inherited from IOpenMediaInteraction.)
ParentID
The parent interaction identifier.
(Inherited from IOpenMediaInteraction.)
Parties
Returns all the parties involved wihtin the interaction.
(Inherited from IInteraction.)
PlaceGroupId
The Place Group Id of the interaction
(Inherited from IOpenMediaInteraction.)
PlaceId
The Place Id of the interaction
(Inherited from IOpenMediaInteraction.)
Priority
The priority of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
Profile
Returns the interaction profile :
  • Unknown,
  • Primary,
  • PrimaryInConf,
  • Transfered,
  • TransferedInConf,
  • ConsultInConf,
  • Consult
(Inherited from IInteraction.)
Queue | Overloaded.
RelatedId
Returns the related interaction IDs.
(Inherited from IInteraction.)
StartDate
Interaction start data. Same as the server date.
(Inherited from IInteraction.)
State
Returns the interaction status.
(Inherited from IInteraction.)
Strategy
Returns the strategies associated with the interaction.
(Inherited from IInteraction.)
Subject
Subject of the interaction.
(Inherited from IOpenMediaInteraction.)
SubjectHeader
SMS Subject
(Inherited from ISMSInfo.)
SuggestedCategories
Map of the suggested categories for this interaction (read only).
  • stringCategory ID
stringrelevancy, the value can be an integer or a float value
(Inherited from IOpenMediaInteraction.)
Target
Returns the target party when interaction is transfered
(Inherited from IInteraction.)
ThreadID
The thread identifier of the interaction.
(Inherited from IOpenMediaInteraction.)
TimeShift
The time shift of the interaction (read only).
(Inherited from IOpenMediaInteraction.)
To
Receiver identifier
(Inherited from ISMSInfo.)
Transcript
Get the SMS message received
(Inherited from ISMSInfo.)
VisibilityMode
The visibility mode (read only).
(Inherited from IOpenMediaInteraction.)
Workbin
If the interaction is in a workbin, the Workbin where the interaction is stored.
(Inherited from IOpenMediaInteraction.)

See Also

ISMSInteraction Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Queue Property

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSInteraction..::.Queue Property
ISMSInteraction Interface See Also Send Feedback

Overload List

Name | Description
Queue | Queues associated with the interaction. (Inherited from IInteraction.)
Queue | If the interaction is in a queue, the Queue where the interaction is stored. (Inherited from IOpenMediaInteraction.)

See Also

ISMSInteraction Interface
ISMSInteraction Members
Genesyslab.Enterprise.Model.Interaction Namespace


IWorkbin Interface

[image]

Enterprise SDK 8.0 Reference API
IWorkbin Interface
Members See Also Send Feedback
Describes a Workbin.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IWorkbin : IShallowCopy<IWorkbin>,
    IDeepCopy<IWorkbin>, ISerializable
Visual Basic (Declaration)
Public Interface IWorkbin _
    Implements IShallowCopy(Of IWorkbin), IDeepCopy(Of IWorkbin),  _
    ISerializable
Visual C++
public interface class IWorkbin : IShallowCopy<IWorkbin^>,
    IDeepCopy<IWorkbin^>, ISerializable

See Also

IWorkbin Members
Genesyslab.Enterprise.Model.Interaction Namespace


IWorkbin Members

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbin Members
IWorkbin Interface Methods Properties See Also Send Feedback

The IWorkbin type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ActiveChannel | The active channel (read only).
Actor | The type of the actor who changed the workbin (read only).
ActorID | The ID of the actor (read only).
Conditions | The conditions of the workbin (read only).
DevicePlace | The associated device of type place (read only).
ID | Unique ID of the workbin (read only).
InteractionId | The Interaction ID (read only).
InteractionIDList | The IDs of the interactions in this workbin (read only).
Interactions | The interactions in this workbin (read only). Key is the interaction ID.
IsActive | true if the workbin is active in the Interaction Server (read only).
Name | Name of the workbin.
Operation | The interaction operation (read only).
Parameter | The parameter of the workbin (read only).
Strategy | The strategies associated with the workbin (read only).
Type | Type of the workbin(read only).
WorkbinContentOperation | The workbin operation (read only).
WorkbinInfoType | The raw of the WorkbinType in the Interaction Server's configuration (read only).
WorkbinView | The workbin view/queue (read only).

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IWorkbin Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbin Methods
IWorkbin Interface See Also Send Feedback

The IWorkbin type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IWorkbin Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbin Properties
IWorkbin Interface See Also Send Feedback

The IWorkbin type exposes the following members.

Properties

Name | Description
ActiveChannel | The active channel (read only).
Actor | The type of the actor who changed the workbin (read only).
ActorID | The ID of the actor (read only).
Conditions | The conditions of the workbin (read only).
DevicePlace | The associated device of type place (read only).
ID | Unique ID of the workbin (read only).
InteractionId | The Interaction ID (read only).
InteractionIDList | The IDs of the interactions in this workbin (read only).
Interactions | The interactions in this workbin (read only). Key is the interaction ID.
IsActive | true if the workbin is active in the Interaction Server (read only).
Name | Name of the workbin.
Operation | The interaction operation (read only).
Parameter | The parameter of the workbin (read only).
Strategy | The strategies associated with the workbin (read only).
Type | Type of the workbin(read only).
WorkbinContentOperation | The workbin operation (read only).
WorkbinInfoType | The raw of the WorkbinType in the Interaction Server's configuration (read only).
WorkbinView | The workbin view/queue (read only).

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActiveChannel Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.ActiveChannel Property
IWorkbin Interface See Also Send Feedback
The active channel (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel ActiveChannel { get; }
Visual Basic (Declaration)
ReadOnly Property ActiveChannel As IClientChannel
Visual C++
property IClientChannel^ ActiveChannel {
    IClientChannel^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Actor Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Actor Property
IWorkbin Interface See Also Send Feedback
The type of the actor who changed the workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ActorType Actor { get; }
Visual Basic (Declaration)
ReadOnly Property Actor As ActorType
Visual C++
property ActorType Actor {
    ActorType get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ActorID Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.ActorID Property
IWorkbin Interface See Also Send Feedback
The ID of the actor (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ActorID { get; }
Visual Basic (Declaration)
ReadOnly Property ActorID As String
Visual C++
property String^ ActorID {
    String^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Conditions Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Conditions Property
IWorkbin Interface See Also Send Feedback
The conditions of the workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Conditions { get; }
Visual Basic (Declaration)
ReadOnly Property Conditions As String
Visual C++
property String^ Conditions {
    String^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


DevicePlace Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.DevicePlace Property
IWorkbin Interface See Also Send Feedback
The associated device of type place (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice DevicePlace { get; }
Visual Basic (Declaration)
ReadOnly Property DevicePlace As IDevice
Visual C++
property IDevice^ DevicePlace {
    IDevice^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


ID Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.ID Property
IWorkbin Interface See Also Send Feedback
Unique ID of the workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ID { get; }
Visual Basic (Declaration)
ReadOnly Property ID As String
Visual C++
property String^ ID {
    String^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionId Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.InteractionId Property
IWorkbin Interface See Also Send Feedback
The Interaction ID (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string InteractionId { get; }
Visual Basic (Declaration)
ReadOnly Property InteractionId As String
Visual C++
property String^ InteractionId {
    String^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


InteractionIDList Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.InteractionIDList Property
IWorkbin Interface See Also Send Feedback
The IDs of the interactions in this workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> InteractionIDList { get; }
Visual Basic (Declaration)
ReadOnly Property InteractionIDList As ICollection(Of String)
Visual C++
property ICollection<String^>^ InteractionIDList {
    ICollection<String^>^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Interactions Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Interactions Property
IWorkbin Interface See Also Send Feedback
The interactions in this workbin (read only). Key is the interaction ID.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IOpenMediaInteraction> Interactions { get; }
Visual Basic (Declaration)
ReadOnly Property Interactions As IDictionary(Of String, IOpenMediaInteraction)
Visual C++
property IDictionary<String^, IOpenMediaInteraction^>^ Interactions {
    IDictionary<String^, IOpenMediaInteraction^>^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IsActive Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.IsActive Property
IWorkbin Interface See Also Send Feedback
true if the workbin is active in the Interaction Server (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsActive { get; }
Visual Basic (Declaration)
ReadOnly Property IsActive As Boolean
Visual C++
property bool IsActive {
    bool get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Name Property
IWorkbin Interface See Also Send Feedback
Name of the workbin.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; set; }
Visual Basic (Declaration)
Property Name As String
Visual C++
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Operation Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Operation Property
IWorkbin Interface See Also Send Feedback
The interaction operation (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
InteractionOperation Operation { get; }
Visual Basic (Declaration)
ReadOnly Property Operation As InteractionOperation
Visual C++
property InteractionOperation Operation {
    InteractionOperation get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Parameter Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Parameter Property
IWorkbin Interface See Also Send Feedback
The parameter of the workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Parameter { get; }
Visual Basic (Declaration)
ReadOnly Property Parameter As String
Visual C++
property String^ Parameter {
    String^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Strategy Property
IWorkbin Interface See Also Send Feedback
The strategies associated with the workbin (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IStrategy> Strategy { get; }
Visual Basic (Declaration)
ReadOnly Property Strategy As ICollection(Of IStrategy)
Visual C++
property ICollection<IStrategy^>^ Strategy {
    ICollection<IStrategy^>^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


Type Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.Type Property
IWorkbin Interface See Also Send Feedback
Type of the workbin(read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
WorkbinType Type { get; }
Visual Basic (Declaration)
ReadOnly Property Type As WorkbinType
Visual C++
property WorkbinType Type {
    WorkbinType get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


WorkbinContentOperation Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.WorkbinContentOperation Property
IWorkbin Interface See Also Send Feedback
The workbin operation (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
WorkbinOperation WorkbinContentOperation { get; }
Visual Basic (Declaration)
ReadOnly Property WorkbinContentOperation As WorkbinOperation
Visual C++
property WorkbinOperation WorkbinContentOperation {
    WorkbinOperation get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


WorkbinInfoType Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.WorkbinInfoType Property
IWorkbin Interface See Also Send Feedback
The raw of the WorkbinType in the Interaction Server's configuration (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int WorkbinInfoType { get; }
Visual Basic (Declaration)
ReadOnly Property WorkbinInfoType As Integer
Visual C++
property int WorkbinInfoType {
    int get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


WorkbinView Property

[image]

Enterprise SDK 8.0 Reference API
IWorkbin..::.WorkbinView Property
IWorkbin Interface See Also Send Feedback
The workbin view/queue (read only).

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string WorkbinView { get; }
Visual Basic (Declaration)
ReadOnly Property WorkbinView As String
Visual C++
property String^ WorkbinView {
    String^ get ();
}

See Also

IWorkbin Interface
Genesyslab.Enterprise.Model.Interaction Namespace


IxnServerInteractionState Enumeration

[image]

Enterprise SDK 8.0 Reference API
IxnServerInteractionState Enumeration
See Also Send Feedback
Enumerates the profile types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum IxnServerInteractionState
Visual Basic (Declaration)
Public Enumeration IxnServerInteractionState
Visual C++
public enum class IxnServerInteractionState

Members

Member name | Description
Unknown |
Queued |
Cached |
Routing |
Handling |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


MakeCallType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MakeCallType Enumeration
See Also Send Feedback
Enumerates the possible call types for voice interactions.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MakeCallType
Visual Basic (Declaration)
Public Enumeration MakeCallType
Visual C++
public enum class MakeCallType

Members

Member name | Description
Regular |
DirectAgent |
SupervisorAssist |
Priority |
DirectPriority |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


MediaContentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaContentType Enumeration
See Also Send Feedback
Enumerates the media content types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MediaContentType
Visual Basic (Declaration)
Public Enumeration MediaContentType
Visual C++
public enum class MediaContentType

Members

Member name | Description
MediaVoice |
MediaIM |
Multimedia |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


MonitorState Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorState Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.MonitorState"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MonitorState
Visual Basic (Declaration)
Public Enumeration MonitorState
Visual C++
public enum class MonitorState

Members

Member name | Description
Monitored |
NotMonitored |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


PartyInfoType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyInfoType Enumeration
See Also Send Feedback
Enumerates the party types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum PartyInfoType
Visual Basic (Declaration)
Public Enumeration PartyInfoType
Visual C++
public enum class PartyInfoType

Members

Member name | Description
Unknown |
Caller |
Callee |
ConferenceMember |
ConferenceMaster |
Supervisor |
Originator |
Target |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


PartyTranslationType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PartyTranslationType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.PartyTranslationType"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum PartyTranslationType
Visual Basic (Declaration)
Public Enumeration PartyTranslationType
Visual C++
public enum class PartyTranslationType

Members

Member name | Description
Unknown |
Physical |
AgentLogin |
PersonId |
UserId |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ProfileType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProfileType Enumeration
See Also Send Feedback
Enumerates the profile types.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ProfileType
Visual Basic (Declaration)
Public Enumeration ProfileType
Visual C++
public enum class ProfileType

Members

Member name | Description
Unknown |
Primary |
PrimaryInConf |
Transfered |
TransferedInConf |
Consult |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


ReasonTypes Enumeration

[image]

Enterprise SDK 8.0 Reference API
ReasonTypes Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Interaction.ReasonTypes"]

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[FlagsAttribute]
public enum ReasonTypes
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration ReasonTypes
Visual C++
[FlagsAttribute]
public enum class ReasonTypes

Members

Member name | Description
None |
ObjectState |
ObjectComposition |
ObjectSubscriber |
ObjectListener |
ObjectContainer |
ObjectForwardMode |
ObjectDndMode |
ObjectAttribute |
StrategyAttribute |
ContextAttribute |
CapableAttribute |
AliasAttribute |
RoleAttribute |
MediaProtocolAttribute |
ConfigurableAttribute |
FilterAttribute |
ControllerAttribute |
CredentialAttribute |
ExtensionAttribute |
PartyAttribute |
SubscriberAttribute |
CustomDataAttribute |
SubSystem |
ReasonState |
ForcedAgentState |
ALL |

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


WorkbinOperation Enumeration

[image]

Enterprise SDK 8.0 Reference API
WorkbinOperation Enumeration
See Also Send Feedback
Enumerates the operations which modify the workbin.

Namespace: Genesyslab.Enterprise.Model.Interaction
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum WorkbinOperation
Visual Basic (Declaration)
Public Enumeration WorkbinOperation
Visual C++
public enum class WorkbinOperation

Members

Member name | Description
Unknown | Unknown Workbin Operation.
TakenOut | An interaction was taken out.
PlacedIn | An interaction was placed in the workbin.
PropertiesChanged | Interaction Properties were changed.

See Also

Genesyslab.Enterprise.Model.Interaction Namespace


Genesyslab.Enterprise.Model.Media Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Media Namespace
Send Feedback

Enumerations

Enumeration | Description
NoticeType | The type of notice for Chat/SMS sessions.
UserType | The user type of a Chat/SMS session.


NoticeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
NoticeType Enumeration
See Also Send Feedback
The type of notice for Chat/SMS sessions.

Namespace: Genesyslab.Enterprise.Model.Media
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum NoticeType
Visual Basic (Declaration)
Public Enumeration NoticeType
Visual C++
public enum class NoticeType

Members

Member name | Description
PushUrl | The Push URL notice.
TypingStarted | The "typing is started" notice.
TypingStopped | The "typing is stopped" notice.
UpdateUserData | The user data update notice.

See Also

Genesyslab.Enterprise.Model.Media Namespace


UserType Enumeration

[image]

Enterprise SDK 8.0 Reference API
UserType Enumeration
See Also Send Feedback
The user type of a Chat/SMS session.

Namespace: Genesyslab.Enterprise.Model.Media
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum UserType
Visual Basic (Declaration)
Public Enumeration UserType
Visual C++
public enum class UserType

Members

Member name | Description
Client | The client user type.
Agent | The agent user type.
Supervisor | The supervisor user type.
External | The external/system user type.

See Also

Genesyslab.Enterprise.Model.Media Namespace


Genesyslab.Enterprise.Model.Protocol Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Protocol Namespace
Send Feedback

Interfaces

Interface | Description
IEnterpriseProtocol | Interface for handling Media protocol.
IParam | Interface for managing protocol parameters.
IProtocolRequest | Interface for managing protocol.
ISwitchPolicy<(Of <(T>)>) | Interface for managing the switch policy.

Enumerations

Enumeration | Description
Action |
MediaDirectionType | Enumerates the media direction types.
MediaType | Enumerates for the media types.
SwitchModelType | Enumerates the switch model types.


Action Enumeration

[image]

Enterprise SDK 8.0 Reference API
Action Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.Protocol.Action"]

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum Action
Visual Basic (Declaration)
Public Enumeration Action
Visual C++
public enum class Action

Members

Member name | Description
KeepAlive |
CloseIfNoAgents |
ForceClose |

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Interface
Members See Also Send Feedback
Interface for handling Media protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEnterpriseProtocol
Visual Basic (Declaration)
Public Interface IEnterpriseProtocol
Visual C++
public interface class IEnterpriseProtocol

See Also

IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Members
IEnterpriseProtocol Interface Methods Properties See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Methods

Name | Description
Add | Overloaded.
GetProtocolRequest | Overloaded.
Remove | Removes a protocol.

Properties

Name | Description
ListProtocols | Gets the list of media protocols.
MediaSupport | Gets the media type of the protocol.
Name | Gets the name of the protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Methods
IEnterpriseProtocol Interface See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Methods

Name | Description
Add | Overloaded.
GetProtocolRequest | Overloaded.
Remove | Removes a protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method
IEnterpriseProtocol Interface See Also Send Feedback

Overload List

Name | Description
Add(IProtocolRequest) | Adds a protocol.
Add(IEnumerable<(Of <(IProtocolRequest>)>)) | Adds a list of protocols.

See Also

IEnterpriseProtocol Interface
IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method (IProtocolRequest)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method (IProtocolRequest)
IEnterpriseProtocol Interface See Also Send Feedback
Adds a protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseProtocol Add(
    IProtocolRequest protocol
)
Visual Basic (Declaration)
Function Add ( _
    protocol As IProtocolRequest _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Add(
    IProtocolRequest^ protocol
)

Parameters

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IProtocolRequest
the protocol to add.

Return Value

the IEnterpriseProtocol.

See Also

IEnterpriseProtocol Interface
Add Overload
Genesyslab.Enterprise.Model.Protocol Namespace


Add Method (IEnumerable(IProtocolRequest))

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Add Method (IEnumerable<(Of <(IProtocolRequest>)>))
IEnterpriseProtocol Interface See Also Send Feedback
Adds a list of protocols.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseProtocol Add(
    IEnumerable<IProtocolRequest> protocols
)
Visual Basic (Declaration)
Function Add ( _
    protocols As IEnumerable(Of IProtocolRequest) _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Add(
    IEnumerable<IProtocolRequest^>^ protocols
)

Parameters

protocols
Type: System.Collections.Generic..::.IEnumerable <(Of <( IProtocolRequest >)>)
the list of protocols.

Return Value

the IEnterpriseProtocol.

See Also

IEnterpriseProtocol Interface
Add Overload
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method
IEnterpriseProtocol Interface See Also Send Feedback

Overload List

Name | Description
GetProtocolRequest(String) | Gets a protocol by its name.
GetProtocolRequest(String, Boolean) | Gets a protocol by name and switch abstraction flag.

See Also

IEnterpriseProtocol Interface
IEnterpriseProtocol Members
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method (String)
IEnterpriseProtocol Interface See Also Send Feedback
Gets a protocol by its name.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest GetProtocolRequest(
    string name
)
Visual Basic (Declaration)
Function GetProtocolRequest ( _
    name As String _
) As IProtocolRequest
Visual C++
IProtocolRequest^ GetProtocolRequest(
    String^ name
)

Parameters

name
Type: System..::.String
the name of the protocol.

Return Value

the IProtocolRequest.

See Also

IEnterpriseProtocol Interface
GetProtocolRequest Overload
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRequest Method (String, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.GetProtocolRequest Method (String, Boolean)
IEnterpriseProtocol Interface See Also Send Feedback
Gets a protocol by name and switch abstraction flag.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest GetProtocolRequest(
    string name,
    bool enableSwitchAbstraction
)
Visual Basic (Declaration)
Function GetProtocolRequest ( _
    name As String, _
    enableSwitchAbstraction As Boolean _
) As IProtocolRequest
Visual C++
IProtocolRequest^ GetProtocolRequest(
    String^ name,
    bool enableSwitchAbstraction
)

Parameters

name
Type: System..::.String
the name of the protocol.
enableSwitchAbstraction
Type: System..::.Boolean
the switch abstraction flag, true if switch abstraction is enabled.

Return Value

the IProtocolRequest.

See Also

IEnterpriseProtocol Interface
GetProtocolRequest Overload
Genesyslab.Enterprise.Model.Protocol Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Remove Method
IEnterpriseProtocol Interface See Also Send Feedback
Removes a protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseProtocol Remove(
    IProtocolRequest protocol
)
Visual Basic (Declaration)
Function Remove ( _
    protocol As IProtocolRequest _
) As IEnterpriseProtocol
Visual C++
IEnterpriseProtocol^ Remove(
    IProtocolRequest^ protocol
)

Parameters

protocol
Type: Genesyslab.Enterprise.Model.Protocol..::.IProtocolRequest
the protocol to remove.

Return Value

the IEnterpriseProtocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IEnterpriseProtocol Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol Properties
IEnterpriseProtocol Interface See Also Send Feedback

The IEnterpriseProtocol type exposes the following members.

Properties

Name | Description
ListProtocols | Gets the list of media protocols.
MediaSupport | Gets the media type of the protocol.
Name | Gets the name of the protocol.

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ListProtocols Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.ListProtocols Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the list of media protocols.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IProtocolRequest> ListProtocols { get; }
Visual Basic (Declaration)
ReadOnly Property ListProtocols As ICollection(Of IProtocolRequest)
Visual C++
property ICollection<IProtocolRequest^>^ ListProtocols {
    ICollection<IProtocolRequest^>^ get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


MediaSupport Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.MediaSupport Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the media type of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MediaType MediaSupport { get; }
Visual Basic (Declaration)
ReadOnly Property MediaSupport As MediaType
Visual C++
property MediaType MediaSupport {
    MediaType get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseProtocol..::.Name Property
IEnterpriseProtocol Interface See Also Send Feedback
Gets the name of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IEnterpriseProtocol Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Interface

[image]

Enterprise SDK 8.0 Reference API
IParam Interface
Members See Also Send Feedback
Interface for managing protocol parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IParam
Visual Basic (Declaration)
Public Interface IParam
Visual C++
public interface class IParam

See Also

IParam Members
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Members

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Members
IParam Interface Methods Properties See Also Send Feedback

The IParam type exposes the following members.

Methods

Name | Description
Get | Gets the object.
ParamType | Gets the type of parameter.
Set | Sets an object as parameter.

Properties

Name | Description
Name | Gets the name of the parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Methods
IParam Interface See Also Send Feedback

The IParam type exposes the following members.

Methods

Name | Description
Get | Gets the object.
ParamType | Gets the type of parameter.
Set | Sets an object as parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Get Method
IParam Interface See Also Send Feedback
Gets the object.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Get()
Visual Basic (Declaration)
Function Get As Object
Visual C++
Object^ Get()

Return Value

returns the object.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ParamType Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.ParamType Method
IParam Interface See Also Send Feedback
Gets the type of parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type ParamType()
Visual Basic (Declaration)
Function ParamType As Type
Visual C++
Type^ ParamType()

Return Value

the Type.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Set Method

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Set Method
IParam Interface See Also Send Feedback
Sets an object as parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IParam Set(
    Object data
)
Visual Basic (Declaration)
Function Set ( _
    data As Object _
) As IParam
Visual C++
IParam^ Set(
    Object^ data
)

Parameters

data
Type: System..::.Object
the object.

Return Value

the IParam.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IParam Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IParam Properties
IParam Interface See Also Send Feedback

The IParam type exposes the following members.

Properties

Name | Description
Name | Gets the name of the parameter.

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IParam..::.Name Property
IParam Interface See Also Send Feedback
Gets the name of the parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IParam Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Interface
Members See Also Send Feedback
Interface for managing protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IProtocolRequest
Visual Basic (Declaration)
Public Interface IProtocolRequest
Visual C++
public interface class IProtocolRequest

See Also

IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Members
IProtocolRequest Interface Methods Properties See Also Send Feedback

The IProtocolRequest type exposes the following members.

Methods

Name | Description
AddParam | Adds a parameter to this protocol.
CreateCommands | Creates a command for this protocol.
Get | Gets a parameter.
GetCommands | Returns the list of commands for this protocol.
GetParams | Returns all the parameters of the protocol.
RemoveParam | Removes a parameter from this protocol.
To | Overloaded.
With | Overloaded.

Properties

Name | Description
Description | Gets the description of the protocol.
IsSynchronized | Returns true if the protocol is synchronized.
Name | Returns the name of the procotol.
SwitchPolicy | Gets or sets the switch policy which applies to this protocol and switch.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Methods
IProtocolRequest Interface See Also Send Feedback

The IProtocolRequest type exposes the following members.

Methods

Name | Description
AddParam | Adds a parameter to this protocol.
CreateCommands | Creates a command for this protocol.
Get | Gets a parameter.
GetCommands | Returns the list of commands for this protocol.
GetParams | Returns all the parameters of the protocol.
RemoveParam | Removes a parameter from this protocol.
To | Overloaded.
With | Overloaded.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


AddParam Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.AddParam Method
IProtocolRequest Interface See Also Send Feedback
Adds a parameter to this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest AddParam(
    IParam item
)
Visual Basic (Declaration)
Function AddParam ( _
    item As IParam _
) As IProtocolRequest
Visual C++
IProtocolRequest^ AddParam(
    IParam^ item
)

Parameters

item
Type: Genesyslab.Enterprise.Model.Protocol..::.IParam
the item to add.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


CreateCommands Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.CreateCommands Method
IProtocolRequest Interface See Also Send Feedback
Creates a command for this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IProtocolRequest> CreateCommands()
Visual Basic (Declaration)
Function CreateCommands As ICollection(Of IProtocolRequest)
Visual C++
ICollection<IProtocolRequest^>^ CreateCommands()

Return Value

the collection of ProtocolRquests.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Get Method
IProtocolRequest Interface See Also Send Feedback
Gets a parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Get(
    string name
)
Visual Basic (Declaration)
Function Get ( _
    name As String _
) As Object
Visual C++
Object^ Get(
    String^ name
)

Parameters

name
Type: System..::.String
the parameter name.

Return Value

the object.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetCommands Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.GetCommands Method
IProtocolRequest Interface See Also Send Feedback
Returns the list of commands for this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> GetCommands()
Visual Basic (Declaration)
Function GetCommands As ICollection(Of String)
Visual C++
ICollection<String^>^ GetCommands()

Return Value

Collection of protocol commands.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetParams Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.GetParams Method
IProtocolRequest Interface See Also Send Feedback
Returns all the parameters of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IParam> GetParams()
Visual Basic (Declaration)
Function GetParams As IDictionary(Of String, IParam)
Visual C++
IDictionary<String^, IParam^>^ GetParams()

Return Value

the dictionary of protocols.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


RemoveParam Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.RemoveParam Method
IProtocolRequest Interface See Also Send Feedback
Removes a parameter from this protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest RemoveParam(
    IParam item
)
Visual Basic (Declaration)
Function RemoveParam ( _
    item As IParam _
) As IProtocolRequest
Visual C++
IProtocolRequest^ RemoveParam(
    IParam^ item
)

Parameters

item
Type: Genesyslab.Enterprise.Model.Protocol..::.IParam
the item to remove.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


To Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method
IProtocolRequest Interface See Also Send Feedback

Overload List

Name | Description
To(IClientChannel) | Sets the channel where to send the request and all parameters.
To(IClientChannel, String) | Sets the channel where to send the request and all parameters.

See Also

IProtocolRequest Interface
IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


To Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method (IClientChannel)
IProtocolRequest Interface See Also Send Feedback
Sets the channel where to send the request and all parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int To(
    IClientChannel channel
)
Visual Basic (Declaration)
Function To ( _
    channel As IClientChannel _
) As Integer
Visual C++
int To(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.

Return Value

the request ID.

See Also

IProtocolRequest Interface
To Overload
Genesyslab.Enterprise.Model.Protocol Namespace


To Method (IClientChannel, String)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.To Method (IClientChannel, String)
IProtocolRequest Interface See Also Send Feedback
Sets the channel where to send the request and all parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int To(
    IClientChannel channel,
    string correlatorData
)
Visual Basic (Declaration)
Function To ( _
    channel As IClientChannel, _
    correlatorData As String _
) As Integer
Visual C++
int To(
    IClientChannel^ channel,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Target channelUser defined data
correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Model.Protocol.IProtocolRequest.To(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

Return Value

the request ID.

See Also

IProtocolRequest Interface
To Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method
IProtocolRequest Interface See Also Send Feedback

Overload List

Name | Description
With(array<Object>[]()[]) | Sets a list of parameters.
With(String, Int32) | Sets an integer parameter.
With(String, Object) | Sets an object parameter.
With(String, String) | Sets a string parameter.

See Also

IProtocolRequest Interface
IProtocolRequest Members
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (Object[])

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (array<Object>[]()[])
IProtocolRequest Interface See Also Send Feedback
Sets a list of parameters.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest With(
    params Object[] list
)
Visual Basic (Declaration)
Function With ( _
    ParamArray list As Object() _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    ... array<Object^>^ list
)

Parameters

list
Type: array< System..::.Object >[]()[]
list of parameters.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, Int32)
IProtocolRequest Interface See Also Send Feedback
Sets an integer parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest With(
    string name,
    int value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As Integer _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    int value
)

Parameters

name
Type: System..::.String
the parameter name.
value
Type: System..::.Int32
the parameter value.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, Object)
IProtocolRequest Interface See Also Send Feedback
Sets an object parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest With(
    string name,
    Object value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As Object _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    Object^ value
)

Parameters

name
Type: System..::.String
the parameter name.
value
Type: System..::.Object
the parameter value.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


With Method (String, String)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.With Method (String, String)
IProtocolRequest Interface See Also Send Feedback
Sets a string parameter.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IProtocolRequest With(
    string name,
    string value
)
Visual Basic (Declaration)
Function With ( _
    name As String, _
    value As String _
) As IProtocolRequest
Visual C++
IProtocolRequest^ With(
    String^ name,
    String^ value
)

Parameters

name
Type: System..::.String
the parameter name.
value
Type: System..::.String
the parameter value.

Return Value

the IProtocolRequest.

See Also

IProtocolRequest Interface
With Overload
Genesyslab.Enterprise.Model.Protocol Namespace


IProtocolRequest Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRequest Properties
IProtocolRequest Interface See Also Send Feedback

The IProtocolRequest type exposes the following members.

Properties

Name | Description
Description | Gets the description of the protocol.
IsSynchronized | Returns true if the protocol is synchronized.
Name | Returns the name of the procotol.
SwitchPolicy | Gets or sets the switch policy which applies to this protocol and switch.

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Description Property
IProtocolRequest Interface See Also Send Feedback
Gets the description of the protocol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


IsSynchronized Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.IsSynchronized Property
IProtocolRequest Interface See Also Send Feedback
Returns true if the protocol is synchronized.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsSynchronized { get; }
Visual Basic (Declaration)
ReadOnly Property IsSynchronized As Boolean
Visual C++
property bool IsSynchronized {
    bool get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.Name Property
IProtocolRequest Interface See Also Send Feedback
Returns the name of the procotol.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


SwitchPolicy Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRequest..::.SwitchPolicy Property
IProtocolRequest Interface See Also Send Feedback
Gets or sets the switch policy which applies to this protocol and switch.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object SwitchPolicy { get; set; }
Visual Basic (Declaration)
Property SwitchPolicy As Object
Visual C++
property Object^ SwitchPolicy {
    Object^ get ();
    void set (Object^ value);
}

See Also

IProtocolRequest Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Interface

[image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing the switch policy.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISwitchPolicy<T>
Visual Basic (Declaration)
Public Interface ISwitchPolicy(Of T)
Visual C++
generic<typename T>
public interface class ISwitchPolicy

Type Parameters

T
Type.

See Also

ISwitchPolicy<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Members
ISwitchPolicy<(Of <(T>)>) Interface Properties See Also Send Feedback

The ISwitchPolicy<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
GetProtocolRule | Gets the rules that manages a protocol according to a switch.

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


ISwitchPolicy(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>) Properties
ISwitchPolicy<(Of <(T>)>) Interface See Also Send Feedback

The ISwitchPolicy<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
GetProtocolRule | Gets the rules that manages a protocol according to a switch.

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


GetProtocolRule Property

[image]

Enterprise SDK 8.0 Reference API
ISwitchPolicy<(Of <(T>)>)..::.GetProtocolRule Property
ISwitchPolicy<(Of <(T>)>) Interface See Also Send Feedback
Gets the rules that manages a protocol according to a switch.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T GetProtocolRule { get; set; }
Visual Basic (Declaration)
Property GetProtocolRule As T
Visual C++
property T GetProtocolRule {
    T get ();
    void set (T value);
}

See Also

ISwitchPolicy<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Protocol Namespace


MediaDirectionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaDirectionType Enumeration
See Also Send Feedback
Enumerates the media direction types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MediaDirectionType
Visual Basic (Declaration)
Public Enumeration MediaDirectionType
Visual C++
public enum class MediaDirectionType

Members

Member name | Description
Unknown | Unknown direction.
In | Inbound direction.
Out | Outbound direction.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


MediaType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaType Enumeration
See Also Send Feedback
Enumerates for the media types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[FlagsAttribute]
public enum MediaType
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration MediaType
Visual C++
[FlagsAttribute]
public enum class MediaType

Members

Member name | Description
Unknown | Media type not specified
Voice | Voice media.
Chat | Chat, Instant Messaging media.
Custom | Custom media.
All | All media.

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


SwitchModelType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SwitchModelType Enumeration
See Also Send Feedback
Enumerates the switch model types.

Namespace: Genesyslab.Enterprise.Model.Protocol
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum SwitchModelType
Visual Basic (Declaration)
Public Enumeration SwitchModelType
Visual C++
public enum class SwitchModelType

Members

Member name | Description
Unknown | Unknown Switch.
AlcatelOxeClassic | Alcatel Oxe in Classic Mode Switch.
AlcatelOxeSubstitute | Alcatel Oxe in Substitute Mode Switch.
AlcatelOxeEmulated | Alcatel Oxe in Emulated Mode Switch.
LucentDefinityG3 | Lucent G3 Switch.
NortelDMS100 | Nortel DMS 100 Switch (Nortel Communication Server 2000/2001)
GenesysSip | Genesys SIP Server Soft Switch.
AspectCallCenter | Aspect switch
CiscoCM | Cisco Call Manager before v8
IntecomIBX80 | EADS Telecom Intecom M6880 Point Span
EricssonMD110 | Ericsson MD110
NortelDMS100PDNMode | Nortel DMS 100 Switch with PDN mode (Nortel Communication Server 2000/2001)
NortelSymposium | Nortel CS1000 with Symposium
NortelMeridian | Nortel CS1000 with meridian link
NortelMeridianCallCenter | Nortel CS 1000 with meridian link
NEC | Nec switches ( NEC Small TDM, Small Hybrid, Large Hybrid, Large TDM )
NECSV7000 | NEC SV7000
RockwellSpectrum | Spcctrum
SiemensHicom300E | Siemens Hicom300 E
SiemensHicom300H | Siemens Hicom 300 H
SiemensHiPath4000 | Siemens HiPath 4000
GenesysSip_804 | Genesys SIP Server Soft Switch v8.0.4
CiscoCM_8 | Cisco Call Manager v8

See Also

Genesyslab.Enterprise.Model.Protocol Namespace


Genesyslab.Enterprise.Model.ServiceModel Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.ServiceModel Namespace
Send Feedback

Interfaces

Interface Description
IContainerBase
IEnterpriseServiceProvider

Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

IService
Service data.


IContainerBase Interface

[image]

Enterprise SDK 8.0 Reference API
IContainerBase Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Model.ServiceModel.IContainerBase"]

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContainerBase : IService,
    IEnterpriseServiceProvider, IDisposable
Visual Basic (Declaration)
Public Interface IContainerBase _
    Implements IService, IEnterpriseServiceProvider, IDisposable
Visual C++
public interface class IContainerBase : IService,
    IEnterpriseServiceProvider, IDisposable

See Also

IContainerBase Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IContainerBase Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase Members
IContainerBase Interface Methods Properties See Also Send Feedback

The IContainerBase type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container. (Inherited from IEnterpriseServiceProvider.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container. (Inherited from IEnterpriseServiceProvider.)
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances. (Inherited from IEnterpriseServiceProvider.)

Properties

Name | Description
Container | Container. (Inherited from IService.)
Description | Service description. (Inherited from IService.)
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll (Inherited from IEnterpriseServiceProvider.)
FQName | Fully Qualified Name. (Inherited from IService.)
LifeTimeManager | Life time manager. (Inherited from IService.)
ParentContainer | Parent container. (Inherited from IService.)
Provider | ¨ESDK provider. (Inherited from IEnterpriseServiceProvider.)
ServiceName | Overloaded.

See Also

IContainerBase Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IContainerBase Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase Methods
IContainerBase Interface See Also Send Feedback

The IContainerBase type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container. (Inherited from IEnterpriseServiceProvider.)
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container. (Inherited from IEnterpriseServiceProvider.)
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances. (Inherited from IEnterpriseServiceProvider.)

See Also

IContainerBase Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase..::.Evaluate Method
IContainerBase Interface See Also Send Feedback

Overload List

Name | Description
Evaluate<(Of <(T>)>)(T) | Applies the strategies of the container to objects built externally. (Inherited from IEnterpriseServiceProvider.)
Evaluate<(Of <(T>)>)(T, String) | Applies the strategies of the container to objects built externally. (Inherited from IEnterpriseServiceProvider.)

See Also

IContainerBase Interface
IContainerBase Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase..::.Load Method
IContainerBase Interface See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method. (Inherited from IEnterpriseServiceProvider.)
Load(Assembly) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method. (Inherited from IEnterpriseServiceProvider.)
Load(String) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method. (Inherited from IEnterpriseServiceProvider.)

See Also

IContainerBase Interface
IContainerBase Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase..::.RegisterType Method
IContainerBase Interface See Also Send Feedback

Overload List

Name | Description
RegisterType<(Of <(T>)>)()()() | Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type. (Inherited from IEnterpriseServiceProvider.)
RegisterType(Type, Type) | Registers a type mapping with the container, where the created instances will use the provided LifetimeManager. (Inherited from IEnterpriseServiceProvider.)
RegisterType(Type, Type, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager. (Inherited from IEnterpriseServiceProvider.)
RegisterType(Type, Type, String) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager. (Inherited from IEnterpriseServiceProvider.)
RegisterType(Type, Type, String, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager. (Inherited from IEnterpriseServiceProvider.)

See Also

IContainerBase Interface
IContainerBase Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase..::.Resolve Method
IContainerBase Interface See Also Send Feedback

Overload List

Name | Description
Resolve<(Of <(T>)>)()()() | Resolves an instance of the requested type. (Inherited from IEnterpriseServiceProvider.)
Resolve<(Of <(T>)>)(String) | Resolves an instance. (Inherited from IEnterpriseServiceProvider.)
Resolve(Type) | Resolves an instance of the requested type. (Inherited from IEnterpriseServiceProvider.)
Resolve(Type, String) | Resolves an instance of the requested type with the given name. (Inherited from IEnterpriseServiceProvider.)

See Also

IContainerBase Interface
IContainerBase Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IContainerBase Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase Properties
IContainerBase Interface See Also Send Feedback

The IContainerBase type exposes the following members.

Properties

Name | Description
Container | Container. (Inherited from IService.)
Description | Service description. (Inherited from IService.)
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll (Inherited from IEnterpriseServiceProvider.)
FQName | Fully Qualified Name. (Inherited from IService.)
LifeTimeManager | Life time manager. (Inherited from IService.)
ParentContainer | Parent container. (Inherited from IService.)
Provider | ¨ESDK provider. (Inherited from IEnterpriseServiceProvider.)
ServiceName | Overloaded.

See Also

IContainerBase Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image] [image]

Enterprise SDK 8.0 Reference API
IContainerBase..::.ServiceName Property
IContainerBase Interface See Also Send Feedback

Overload List

Name | Description
ServiceName | Name. (Inherited from IEnterpriseServiceProvider.)
ServiceName | Name of the service. (Inherited from IService.)

See Also

IContainerBase Interface
IContainerBase Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Interface

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Interface
Members See Also Send Feedback

Entry point of the Enterprise SDK.

As a start, create an instance of this interface. From that point, use it to retrieve ESDK services.

The following code snippet creates a new instance, passing a Unity container.

CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);

Then, you can retrieve the services implemented by the Enterprise SDK. For instance, you get a instance of a channel service by passing its type as a string.

CopyC#
channelService = EsdkService.Resolve<IChannelService>("channelService");

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEnterpriseServiceProvider : IDisposable
Visual Basic (Declaration)
Public Interface IEnterpriseServiceProvider _
    Implements IDisposable
Visual C++
public interface class IEnterpriseServiceProvider : IDisposable

See Also

IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Members
IEnterpriseServiceProvider Interface Methods Properties See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances.

Properties

Name | Description
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
Provider | ¨ESDK provider.
ServiceName | Name.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Methods
IEnterpriseServiceProvider Interface See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Methods

Name | Description
CreateChildContainer | Creates a child container for the current container.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Evaluate | Overloaded.
Load | Overloaded.
RegisterInstance<(Of <(TInterface>)>) | Registers an instance with the container.
RegisterType | Overloaded.
Resolve | Overloaded.
ResolveAll<(Of <(T>)>) | Resolves all the instances.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


CreateChildContainer Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.CreateChildContainer Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Creates a child container for the current container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider CreateChildContainer()
Visual Basic (Declaration)
Function CreateChildContainer As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ CreateChildContainer()

Return Value

the IEnterpriseServiceProvider.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Evaluate<(Of <(T>)>)(T) | Applies the strategies of the container to objects built externally.
Evaluate<(Of <(T>)>)(T, String) | Applies the strategies of the container to objects built externally.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate(T) Method (T)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T)
IEnterpriseServiceProvider Interface See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider Evaluate<T>(
    T data
)
Visual Basic (Declaration)
Function Evaluate(Of T) ( _
    data As T _
) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ Evaluate(
    T data
)

Parameters

data
Type: T
Data.

Type Parameters

T
Data type.

Return Value

Provider.

See Also

IEnterpriseServiceProvider Interface
Evaluate Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Evaluate(T) Method (T, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Evaluate<(Of <(T>)>) Method (T, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Applies the strategies of the container to objects built externally.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider Evaluate<T>(
    T data,
    string name
)
Visual Basic (Declaration)
Function Evaluate(Of T) ( _
    data As T, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ Evaluate(
    T data,
    String^ name
)

Parameters

data
Type: T
Data.
name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Evaluate``1(``0,System.String)"]

Type Parameters

T
Data type.

Return Value

Provider.

See Also

IEnterpriseServiceProvider Interface
Evaluate Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Load()()() | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.
Load(Assembly) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.
Load(String) | Loads the services. Use it to force the loading of the services. By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Load()
Visual Basic (Declaration)
Function Load As Boolean
Visual C++
bool Load()

Return Value

True if the services are loaded.

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method (Assembly)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method (Assembly)
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Load(
    Assembly asssembly
)
Visual Basic (Declaration)
Function Load ( _
    asssembly As Assembly _
) As Boolean
Visual C++
bool Load(
    Assembly^ asssembly
)

Parameters

asssembly
Type: System.Reflection..::.Assembly
Assembly which describes the services.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Load(System.Reflection.Assembly)"]

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Load Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Load Method (String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Loads the services. Use it to force the loading of the services.

By default, ESDK loads service at the application's startup. To change the init phase, your application must derivate this interface, overload the [!:#] method, and call this Load() method.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Load(
    string filename
)
Visual Basic (Declaration)
Function Load ( _
    filename As String _
) As Boolean
Visual C++
bool Load(
    String^ filename
)

Parameters

filename
Type: System..::.String
XML file which describes the services.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Load(System.String)"]

See Also

IEnterpriseServiceProvider Interface
Load Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterInstance(TInterface) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterInstance<(Of <(TInterface>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers an instance with the container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider RegisterInstance<TInterface>(
    string name,
    TInterface instance
)
Visual Basic (Declaration)
Function RegisterInstance(Of TInterface) ( _
    name As String, _
    instance As TInterface _
) As IEnterpriseServiceProvider
Visual C++
generic<typename TInterface>
IEnterpriseServiceProvider^ RegisterInstance(
    String^ name,
    TInterface instance
)

Parameters

name
Type: System..::.String
Name for the new instance.
instance
Type: TInterface
Instance to register.

Type Parameters

TInterface
Type.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
RegisterType<(Of <(T>)>)()()() | Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.
RegisterType(Type, Type) | Registers a type mapping with the container, where the created instances will use the provided LifetimeManager.
RegisterType(Type, Type, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.
RegisterType(Type, Type, String, array<Object>[]()[]) | Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a LifetimeManager for the given type with the container. No type mapping is performed for this type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider RegisterType<T>()
Visual Basic (Declaration)
Function RegisterType(Of T) As IEnterpriseServiceProvider
Visual C++
generic<typename T>
IEnterpriseServiceProvider^ RegisterType()

Type Parameters

T
the type of data.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type)
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances will use the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, Object[])

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, array<Object>[]()[])
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    params Object[] list
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    ParamArray list As Object() _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    ... array<Object^>^ list
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
list
Type: array< System..::.Object >[]()[]
The parameters list of the instance for the instance creation.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
name
Type: System..::.String
The name of the instance.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


RegisterType Method (Type, Type, String, Object[])

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.RegisterType Method (Type, Type, String, array<Object>[]()[])
IEnterpriseServiceProvider Interface See Also Send Feedback
Registers a type mapping with the container, where the created instances uses the provided LifetimeManager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider RegisterType(
    Type from,
    Type to,
    string name,
    params Object[] list
)
Visual Basic (Declaration)
Function RegisterType ( _
    from As Type, _
    to As Type, _
    name As String, _
    ParamArray list As Object() _
) As IEnterpriseServiceProvider
Visual C++
IEnterpriseServiceProvider^ RegisterType(
    Type^ from,
    Type^ to,
    String^ name,
    ... array<Object^>^ list
)

Parameters

from
Type: System..::.Type
Interface to register.
to
Type: System..::.Type
Concrete class to map.
name
Type: System..::.String
The name of the instance.
list
Type: array< System..::.Object >[]()[]
The parameters list of the instance for the instance creation.

Return Value

IEnterpriseServiceProvider

See Also

IEnterpriseServiceProvider Interface
RegisterType Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method
IEnterpriseServiceProvider Interface See Also Send Feedback

Overload List

Name | Description
Resolve<(Of <(T>)>)()()() | Resolves an instance of the requested type.
Resolve<(Of <(T>)>)(String) | Resolves an instance.
Resolve(Type) | Resolves an instance of the requested type.
Resolve(Type, String) | Resolves an instance of the requested type with the given name.

See Also

IEnterpriseServiceProvider Interface
IEnterpriseServiceProvider Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T Resolve<T>()
Visual Basic (Declaration)
Function Resolve(Of T) As T
Visual C++
generic<typename T>
T Resolve()

Type Parameters

T
Type.

Return Value

an instance of the type.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve(T) Method (String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve<(Of <(T>)>) Method (String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
T Resolve<T>(
    string name
)
Visual Basic (Declaration)
Function Resolve(Of T) ( _
    name As String _
) As T
Visual C++
generic<typename T>
T Resolve(
    String^ name
)

Parameters

name
Type: System..::.String
Name of the service to resolve.

Type Parameters

T
Type.

Return Value

an instance of the type.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method (Type)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Resolve(
    Type t
)
Visual Basic (Declaration)
Function Resolve ( _
    t As Type _
) As Object
Visual C++
Object^ Resolve(
    Type^ t
)

Parameters

t
Type: System..::.Type
Type to resolve.

Return Value

Instance.

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


Resolve Method (Type, String)

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Resolve Method (Type, String)
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves an instance of the requested type with the given name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Resolve(
    Type t,
    string name
)
Visual Basic (Declaration)
Function Resolve ( _
    t As Type, _
    name As String _
) As Object
Visual C++
Object^ Resolve(
    Type^ t,
    String^ name
)

Parameters

t
Type: System..::.Type
Type to resolve.
name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.Resolve(System.Type,System.String)"]

Return Value

object

See Also

IEnterpriseServiceProvider Interface
Resolve Overload
Genesyslab.Enterprise.Model.ServiceModel Namespace


ResolveAll(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.ResolveAll<(Of <(T>)>) Method
IEnterpriseServiceProvider Interface See Also Send Feedback
Resolves all the instances.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ResolveAll<T>()
Visual Basic (Declaration)
Function ResolveAll(Of T) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ResolveAll()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Model.ServiceModel.IEnterpriseServiceProvider.ResolveAll``1"]

Return Value

the enumeration of all instances.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IEnterpriseServiceProvider Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider Properties
IEnterpriseServiceProvider Interface See Also Send Feedback

The IEnterpriseServiceProvider type exposes the following members.

Properties

Name | Description
Filter | Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll
Provider | ¨ESDK provider.
ServiceName | Name.

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Filter Property
IEnterpriseServiceProvider Interface See Also Send Feedback
Define filter for plugin loading * - match zero or more characters ? - match any one character [abc] - match one character if it's in the characters inside the brackets. All other characters in the glob are literals. Example: *.dll

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Filter { get; set; }
Visual Basic (Declaration)
Property Filter As String
Visual C++
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Provider Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.Provider Property
IEnterpriseServiceProvider Interface See Also Send Feedback
¨ESDK provider.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnterpriseServiceProvider Provider { get; }
Visual Basic (Declaration)
ReadOnly Property Provider As IEnterpriseServiceProvider
Visual C++
property IEnterpriseServiceProvider^ Provider {
    IEnterpriseServiceProvider^ get ();
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
IEnterpriseServiceProvider..::.ServiceName Property
IEnterpriseServiceProvider Interface See Also Send Feedback
Name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ServiceName { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceName As String
Visual C++
property String^ ServiceName {
    String^ get ();
}

See Also

IEnterpriseServiceProvider Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Interface

[image]

Enterprise SDK 8.0 Reference API
IService Interface
Members See Also Send Feedback
Service data.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IService : IDisposable
Visual Basic (Declaration)
Public Interface IService _
    Implements IDisposable
Visual C++
public interface class IService : IDisposable

See Also

IService Members
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IService Members
IService Interface Methods Properties See Also Send Feedback

The IService type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

Properties

Name | Description
Container | Container.
Description | Service description.
FQName | Fully Qualified Name.
LifeTimeManager | Life time manager.
ParentContainer | Parent container.
ServiceName | Name of the service.

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IService Methods
IService Interface See Also Send Feedback

The IService type exposes the following members.

Methods

Name | Description
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


IService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IService Properties
IService Interface See Also Send Feedback

The IService type exposes the following members.

Properties

Name | Description
Container | Container.
Description | Service description.
FQName | Fully Qualified Name.
LifeTimeManager | Life time manager.
ParentContainer | Parent container.
ServiceName | Name of the service.

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Container Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.Container Property
IService Interface See Also Send Feedback
Container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Container { get; }
Visual Basic (Declaration)
ReadOnly Property Container As Object
Visual C++
property Object^ Container {
    Object^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.Description Property
IService Interface See Also Send Feedback
Service description.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


FQName Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.FQName Property
IService Interface See Also Send Feedback
Fully Qualified Name.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FQName { get; }
Visual Basic (Declaration)
ReadOnly Property FQName As String
Visual C++
property String^ FQName {
    String^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


LifeTimeManager Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.LifeTimeManager Property
IService Interface See Also Send Feedback
Life time manager.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type LifeTimeManager { get; }
Visual Basic (Declaration)
ReadOnly Property LifeTimeManager As Type
Visual C++
property Type^ LifeTimeManager {
    Type^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ParentContainer Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.ParentContainer Property
IService Interface See Also Send Feedback
Parent container.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object ParentContainer { get; }
Visual Basic (Declaration)
ReadOnly Property ParentContainer As Object
Visual C++
property Object^ ParentContainer {
    Object^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


ServiceName Property

[image]

Enterprise SDK 8.0 Reference API
IService..::.ServiceName Property
IService Interface See Also Send Feedback
Name of the service.

Namespace: Genesyslab.Enterprise.Model.ServiceModel
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string ServiceName { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceName As String
Visual C++
property String^ ServiceName {
    String^ get ();
}

See Also

IService Interface
Genesyslab.Enterprise.Model.ServiceModel Namespace


Genesyslab.Enterprise.Model.Strategy Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Model.Strategy Namespace
Send Feedback

Interfaces

Interface | Description
IStrategy | Interface for handling strategy.
IStrategyManager<(Of <(T>)>) | Interface for managing strategies.

Enumerations

Enumeration | Description
StrategyStateType | Enumerate to describe the internal result of the strategy Sucess or failure
StrategyType | Enumerate the type of strategy.


IStrategy Interface

[image]

Enterprise SDK 8.0 Reference API
IStrategy Interface
Members See Also Send Feedback
Interface for handling strategy.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStrategy : IShallowCopy<IStrategy>,
    IDeepCopy<IStrategy>
Visual Basic (Declaration)
Public Interface IStrategy _
    Implements IShallowCopy(Of IStrategy), IDeepCopy(Of IStrategy)
Visual C++
public interface class IStrategy : IShallowCopy<IStrategy^>,
    IDeepCopy<IStrategy^>

See Also

IStrategy Members
Genesyslab.Enterprise.Model.Strategy Namespace


IStrategy Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategy Members
IStrategy Interface Methods Properties See Also Send Feedback

The IStrategy type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
Evaluate<(Of <(D, T>)>) | Evaluate objects throught the strategy
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
Description | Strategu description
Enabled | Strategy state. enabled or disabled
EventAllowed | Strategy event mode
ExitOnError | boolean to stop or not other strategy execution User defined. Used to control how strategy behaves
Name | Strategy name
Reasons | Description of fields updated wihtin the strategy Result is combination of binary fields
Spawn | Strategy spawn mode True: a new instance of the strategy is created False: the same instance of strategy is used (singleton mode)
State | State of the strategy when done: Failure or success
TargetStrategy | Specifies if strategy wxorks on events (Action mode) or if strategy works on filters (filter mode)

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


IStrategy Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategy Methods
IStrategy Interface See Also Send Feedback

The IStrategy type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
Evaluate<(Of <(D, T>)>) | Evaluate objects throught the strategy
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


Evaluate(D, T) Method

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.Evaluate<(Of <(D, T>)>) Method
IStrategy Interface See Also Send Feedback
Evaluate objects throught the strategy

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Evaluate<D, T>(
    D data,
    T item
)
Visual Basic (Declaration)
Function Evaluate(Of D, T) ( _
    data As D, _
    item As T _
) As Boolean
Visual C++
generic<typename D, typename T>
bool Evaluate(
    D data,
    T item
)

Parameters

data
Type: D
data instance
item
Type: T
item instance

Type Parameters

D
Type of data
T
Type of item

Return Value

bool

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


IStrategy Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategy Properties
IStrategy Interface See Also Send Feedback

The IStrategy type exposes the following members.

Properties

Name | Description
Description | Strategu description
Enabled | Strategy state. enabled or disabled
EventAllowed | Strategy event mode
ExitOnError | boolean to stop or not other strategy execution User defined. Used to control how strategy behaves
Name | Strategy name
Reasons | Description of fields updated wihtin the strategy Result is combination of binary fields
Spawn | Strategy spawn mode True: a new instance of the strategy is created False: the same instance of strategy is used (singleton mode)
State | State of the strategy when done: Failure or success
TargetStrategy | Specifies if strategy wxorks on events (Action mode) or if strategy works on filters (filter mode)

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.Description Property
IStrategy Interface See Also Send Feedback
Strategu description

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; set; }
Visual Basic (Declaration)
Property Description As String
Visual C++
property String^ Description {
    String^ get ();
    void set (String^ value);
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


Enabled Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.Enabled Property
IStrategy Interface See Also Send Feedback
Strategy state. enabled or disabled

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Enabled { get; set; }
Visual Basic (Declaration)
Property Enabled As Boolean
Visual C++
property bool Enabled {
    bool get ();
    void set (bool value);
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


EventAllowed Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.EventAllowed Property
IStrategy Interface See Also Send Feedback
Strategy event mode

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool EventAllowed { get; }
Visual Basic (Declaration)
ReadOnly Property EventAllowed As Boolean
Visual C++
property bool EventAllowed {
    bool get ();
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


ExitOnError Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.ExitOnError Property
IStrategy Interface See Also Send Feedback
boolean to stop or not other strategy execution User defined. Used to control how strategy behaves

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool ExitOnError { get; }
Visual Basic (Declaration)
ReadOnly Property ExitOnError As Boolean
Visual C++
property bool ExitOnError {
    bool get ();
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.Name Property
IStrategy Interface See Also Send Feedback
Strategy name

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.Reasons Property
IStrategy Interface See Also Send Feedback
Description of fields updated wihtin the strategy Result is combination of binary fields

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ReasonTypes Reasons { get; }
Visual Basic (Declaration)
ReadOnly Property Reasons As ReasonTypes
Visual C++
property ReasonTypes Reasons {
    ReasonTypes get ();
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


Spawn Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.Spawn Property
IStrategy Interface See Also Send Feedback
Strategy spawn mode True: a new instance of the strategy is created False: the same instance of strategy is used (singleton mode)

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Spawn { get; set; }
Visual Basic (Declaration)
Property Spawn As Boolean
Visual C++
property bool Spawn {
    bool get ();
    void set (bool value);
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


State Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.State Property
IStrategy Interface See Also Send Feedback
State of the strategy when done: Failure or success

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StrategyStateType State { get; }
Visual Basic (Declaration)
ReadOnly Property State As StrategyStateType
Visual C++
property StrategyStateType State {
    StrategyStateType get ();
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


TargetStrategy Property

[image]

Enterprise SDK 8.0 Reference API
IStrategy..::.TargetStrategy Property
IStrategy Interface See Also Send Feedback
Specifies if strategy wxorks on events (Action mode) or if strategy works on filters (filter mode)

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
StrategyType TargetStrategy { get; }
Visual Basic (Declaration)
ReadOnly Property TargetStrategy As StrategyType
Visual C++
property StrategyType TargetStrategy {
    StrategyType get ();
}

See Also

IStrategy Interface
Genesyslab.Enterprise.Model.Strategy Namespace


IStrategyManager(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>) Interface
Members See Also Send Feedback
Interface for managing strategies.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStrategyManager<T>
Visual Basic (Declaration)
Public Interface IStrategyManager(Of T)
Visual C++
generic<typename T>
public interface class IStrategyManager

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1"]

See Also

IStrategyManager<(Of <(T>)>) Members
Genesyslab.Enterprise.Model.Strategy Namespace


IStrategyManager(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>) Members
IStrategyManager<(Of <(T>)>) Interface Methods See Also Send Feedback

The IStrategyManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ListStrategies | Gets the list of strategies for an object.
RemoveAllStrategies | Removes all strategies.
RemoveStrategy | Removes a strategy of an object.
SetStrategy | Sets a strategy to an object.

See Also

IStrategyManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Strategy Namespace


IStrategyManager(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>) Methods
IStrategyManager<(Of <(T>)>) Interface See Also Send Feedback

The IStrategyManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ListStrategies | Gets the list of strategies for an object.
RemoveAllStrategies | Removes all strategies.
RemoveStrategy | Removes a strategy of an object.
SetStrategy | Sets a strategy to an object.

See Also

IStrategyManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Strategy Namespace


ListStrategies Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>)..::.ListStrategies Method
IStrategyManager<(Of <(T>)>) Interface See Also Send Feedback
Gets the list of strategies for an object.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStrategy[] ListStrategies(
    T targetObject
)
Visual Basic (Declaration)
Function ListStrategies ( _
    targetObject As T _
) As IStrategy()
Visual C++
array<IStrategy^>^ ListStrategies(
    T targetObject
)

Parameters

targetObject
Type: T

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.ListStrategies(`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.ListStrategies(`0)"]

See Also

IStrategyManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Strategy Namespace


RemoveAllStrategies Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>)..::.RemoveAllStrategies Method
IStrategyManager<(Of <(T>)>) Interface See Also Send Feedback
Removes all strategies.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStrategyManager<T> RemoveAllStrategies()
Visual Basic (Declaration)
Function RemoveAllStrategies As IStrategyManager(Of T)
Visual C++
IStrategyManager<T>^ RemoveAllStrategies()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.RemoveAllStrategies"]

See Also

IStrategyManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Strategy Namespace


RemoveStrategy Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>)..::.RemoveStrategy Method
IStrategyManager<(Of <(T>)>) Interface See Also Send Feedback
Removes a strategy of an object.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStrategyManager<T> RemoveStrategy(
    T targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Function RemoveStrategy ( _
    targetObject As T, _
    strategy As IStrategy _
) As IStrategyManager(Of T)
Visual C++
IStrategyManager<T>^ RemoveStrategy(
    T targetObject,
    IStrategy^ strategy
)

Parameters

targetObject
Type: T

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.RemoveStrategy(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: Genesyslab.Enterprise.Model.Strategy..::.IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.RemoveStrategy(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.RemoveStrategy(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

IStrategyManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Strategy Namespace


SetStrategy Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyManager<(Of <(T>)>)..::.SetStrategy Method
IStrategyManager<(Of <(T>)>) Interface See Also Send Feedback
Sets a strategy to an object.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStrategyManager<T> SetStrategy(
    T targetObject,
    IStrategy strategy
)
Visual Basic (Declaration)
Function SetStrategy ( _
    targetObject As T, _
    strategy As IStrategy _
) As IStrategyManager(Of T)
Visual C++
IStrategyManager<T>^ SetStrategy(
    T targetObject,
    IStrategy^ strategy
)

Parameters

targetObject
Type: T

[Missing <param name="targetObject"/> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.SetStrategy(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

strategy
Type: Genesyslab.Enterprise.Model.Strategy..::.IStrategy

[Missing <param name="strategy"/> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.SetStrategy(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Model.Strategy.IStrategyManager`1.SetStrategy(`0,Genesyslab.Enterprise.Model.Strategy.IStrategy)"]

See Also

IStrategyManager<(Of <(T>)>) Interface
Genesyslab.Enterprise.Model.Strategy Namespace


StrategyStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StrategyStateType Enumeration
See Also Send Feedback
Enumerate to describe the internal result of the strategy Sucess or failure

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum StrategyStateType
Visual Basic (Declaration)
Public Enumeration StrategyStateType
Visual C++
public enum class StrategyStateType

Members

Member name | Description
Success |
Failure |

See Also

Genesyslab.Enterprise.Model.Strategy Namespace


StrategyType Enumeration

[image]

Enterprise SDK 8.0 Reference API
StrategyType Enumeration
See Also Send Feedback
Enumerate the type of strategy.

Namespace: Genesyslab.Enterprise.Model.Strategy
Assembly: Genesyslab.Enterprise.Model (in Genesyslab.Enterprise.Model.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum StrategyType
Visual Basic (Declaration)
Public Enumeration StrategyType
Visual C++
public enum class StrategyType

Members

Member name | Description
Action | Event Strategy Type.
Filter | Filter Strategy Type.
Request | Request strategy type

See Also

Genesyslab.Enterprise.Model.Strategy Namespace


Genesyslab.Enterprise.Services Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services Namespace
Send Feedback

Interfaces

Interface Description
IAgentService
Interface for Agent management.
ICallbackDomain
Manages the data of callback contact.
ICallbackService
Manages callback and filters related to outbound contact events.
ICampaignDomain
Manages the campaign of outbound contacts.
ICampaignService
IChannelMonitor<(Of <(D>)>)
IChannelService
Interface for managing channels.

With this interface, you declare and declare new communication channels, one for each media connection (for instance a switch.)

IChatDomain
Interface for the Chat domain.
IChatService
Manages callback and filters related to chat interaction events.
IContactService
Manages information related to contacts such as interaction history, attachments, interaction content, and standard responses.
IDeviceDomain
Manages device data.
IDeviceService
Manages handlers and filters on devices.
IEmailDomain
Enables your application to manage the e-mail interactions.
IEmailService
Manages the callback and filters related to the e-mail interaction events.
IEntityDomain
Manages entities and identities for groups and persons.
IEventManager<(Of <(D, T>)>)
Event Manager.
IIdentityDomain
Manages the identity domain.
IIdentityService
Manages the identities.
Note: To use an agent with a device, create a link between these objects with the IIdentityService.SetDevice() method.
IIMDomain
Manages Instant Messaging data.
IIMService
Manages the instant messaging features.
IInteractionDomain
Enables your application to manage interactions.
IInteractionQueueService
Manages the Workbin features.
IMonitorService
Connects to the Statistics Server to monitor the objects' presence. With this service, your application can determine if an agent is available or if a media is in a given status.
IOpenMediaDomain
Manages the data of open media interactions. Open media interactions are used for the customization of your application with other media than chat, voice, and e-mail.
IOpenMediaService
Manages callback and filters related to open media interaction events.
  • ReasonName Key associated with a string value.
  • ReasonDescription Key associated with a string value.
  • ReasonCode Key associated with an integer value (deprecated in interaction server).
IOutboundDomain
Manages the data of outbound contacts.
IOutboundService
IPreviewDomain
Preview Interaction domain.
IPreviewService
Manages the Preview Interaction features.
IPSTService
Provides Possible State Transition (PST) information. The isPossible methods of this service use the loaded stategies and the given objects' data (including its own status and strategies) to determine whether a requested action can be processed. The isCapable methods of this service use the loaded strategies to indicate whether the feature is available regardless of the object status. For instance, if your switch does not provide a mute feature, the isCapable methods return false for the ProtocolAction.MuteOn action.
ISMSDomain
Interface for the SMS domain.
ISMSService
Manages callback and filters related to chat interaction events.
ISupervisorDomain
Actions part of the monitoring domain
ISupervisorInfo
Describes the monitoring information of the object which is identified by the Id member. The MonitorObject member identifies the type of the monitored object (possible types are enumerated in SupervisorObjectType: agent, interaction, device, and so on.)
ISupervisorService
Manages actions and events related to monitoring events.
IVoiceService
Manages callback and filters related to interaction events.
IWorkbinDomain
Enables your application to manage workbins.
IWorkbinService
Manages the Workbin features.

Enumerations

Enumeration | Description
AgentAction | Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.
BuildDeviceModeType |
CallBackType | Enumerates for the callback type.
CallResult | Enumerates for the call result.
ChainAttribute | Enumerates for the chain attribute type.
DataSourceType |
DeviceAction | Enumerates the actions that are possible on this device. To be used in the methods of IsPossible.
ForwardAction | Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.
MessageContentType | Enumerates the content type of the message.
MonitorNotificationMode | Statistics Notification mode. Event notification mode for subscribed statistics.
MonitorObjectType | Enumerates the statistics object types.
PhoneType | Enumerates for the outbound phone type.
ProtocolAction | Enumerates the actions that are possible on this interaction. To be used in the methods of IsPossible.
RecordStatus | Enumerates for the outbound record status.
RecordType | Enumerates for the outbound record types.
SmsProperty | List of properties that can be accessed within an SMS object
SupervisorModeType | Enumerates the monitor modes.
SupervisorObjectType | Enumerates the types of objects involved in monitoring.
SupervisorStateType | Enumerates the monitor statuses.
Treatment | Enumerates for the outbound treatment types.
WorkbinType | Enumerates the workbin types.


AgentAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum AgentAction
Visual Basic (Declaration)
Public Enumeration AgentAction
Visual C++
public enum class AgentAction

Members

Member name | Description
Login | Login this device.
Logout | Logout this device.
NotReady | Sets not ready this device.
Ready | Sets this device ready.

See Also

Genesyslab.Enterprise.Services Namespace


BuildDeviceModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
BuildDeviceModeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.BuildDeviceModeType"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum BuildDeviceModeType
Visual Basic (Declaration)
Public Enumeration BuildDeviceModeType
Visual C++
public enum class BuildDeviceModeType

Members

Member name | Description
Strict |
Relaxed |

See Also

Genesyslab.Enterprise.Services Namespace


CallBackType Enumeration

[image]

Enterprise SDK 8.0 Reference API
CallBackType Enumeration
See Also Send Feedback
Enumerates for the callback type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum CallBackType
Visual Basic (Declaration)
Public Enumeration CallBackType
Visual C++
public enum class CallBackType

Members

Member name | Description
Unknown | Unknown mode
Personal | Personal.
Campaign | Campaign.

See Also

Genesyslab.Enterprise.Services Namespace


CallResult Enumeration

[image]

Enterprise SDK 8.0 Reference API
CallResult Enumeration
See Also Send Feedback
Enumerates for the call result.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum CallResult
Visual Basic (Declaration)
Public Enumeration CallResult
Visual C++
public enum class CallResult

Members

Member name | Description
OK | OK.
GENERAL_ERROR | General Error.
SYSTEM_ERROR | System Error.
BUSY | Busy.
NO_ANSWER | No Answer.
SIT_DETECTED | SIT Detected.
ANSWERING_MACHINE | Answering Machine.
ALL_TRUNKS_BUSY | All Trunks Busy.
SIT_INVALID_NUM | SIT Invalid Number.
SIT_VACANT | SIT Vacant.
SIT_OPERINTERCEPT | SIT Operator Intercept.
SIT_UNKNOWN | SIT unknown.
SIT_NO_CIRCUIT | SIT No Circuit.
SIT_REORDER | SIT Reorder.
FAXDETECTED | FAX Detected.
ABANDONED | Abandonned.
DROPPED | Dropped.
DROPPED_NO_ANSWER | Dropped No Answer.
UNKNOWN | Unknown.
SILENCE | Silence.
ANSWER | Answer.
NUTONE | Nutone.
NO_DIAL_TONE | No Dial Tone.
NO_PROGRESS | No Progress.
NO_RINGBACK | No Ringback.
NO_ESTABLISHED | No Established.
PAGER_DETECTED | Pager Detected.
WRONG_PARTY | Wrong Party.
DIAL_ERROR | Dial Error.
CALL_DROP_ERROR | Call Drop Error.
SWITCH_ERROR | Switch Error.
NO_FREE_PORT_ERROR | No Free Port Error.
TRANSFER_ERROR | Transfer Error.
STALE | Stale/
AGENT_CALLBACK_ERROR | Agent Callback Error.
GROUP_CALLBACK_ERROR | Group Callback Error.
DO_NOT_CALL | Do Not Call.
CANCEL_RECORD | Cancel Record.
WRONG_NUMBER | Wrong Number.

See Also

Genesyslab.Enterprise.Services Namespace


ChainAttribute Enumeration

[image]

Enterprise SDK 8.0 Reference API
ChainAttribute Enumeration
See Also Send Feedback
Enumerates for the chain attribute type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ChainAttribute
Visual Basic (Declaration)
Public Enumeration ChainAttribute
Visual C++
public enum class ChainAttribute

Members

Member name | Description
ALLCHAIN | All Chain.
RECORDONLY | Record Only.

See Also

Genesyslab.Enterprise.Services Namespace


DataSourceType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DataSourceType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.DataSourceType"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum DataSourceType
Visual Basic (Declaration)
Public Enumeration DataSourceType
Visual C++
public enum class DataSourceType

Members

Member name | Description
Main |
Archive |

See Also

Genesyslab.Enterprise.Services Namespace


DeviceAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this device. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum DeviceAction
Visual Basic (Declaration)
Public Enumeration DeviceAction
Visual C++
public enum class DeviceAction

Members

Member name | Description
CancelForward | Sets the Forwarding feature to Off.
Login | Login this device.
Logout | Logout this device.
NotReady | Sets not ready this device.
Ready | Sets this device ready.
SetDNDOff | Deactivates the Do-Not-Disturb (DND) mode.
SetDNDOn | Activates the Do-Not-Disturb (DND) mode.
SetForward | Sets the Forwarding feature to On.

See Also

Genesyslab.Enterprise.Services Namespace


ForwardAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
ForwardAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this agent. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ForwardAction
Visual Basic (Declaration)
Public Enumeration ForwardAction
Visual C++
public enum class ForwardAction

Members

Member name | Description
CancelForward | Sets the Forwarding feature to Off.
SetForward | Sets the Forwarding feature to On.

See Also

Genesyslab.Enterprise.Services Namespace


IAgentService Interface

[image]

Enterprise SDK 8.0 Reference API
IAgentService Interface
Members See Also Send Feedback
Interface for Agent management.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAgentService
Visual Basic (Declaration)
Public Interface IAgentService
Visual C++
public interface class IAgentService

See Also

IAgentService Members
Genesyslab.Enterprise.Services Namespace


IAgentService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService Members
IAgentService Interface Methods See Also Send Feedback

The IAgentService type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel |
EndCallForwardSet |
EndLogin |
EndLogout |
EndNotReady |
EndReady |
EndSetDNDOff |
EndSetDNDOn |
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


IAgentService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService Methods
IAgentService Interface See Also Send Feedback

The IAgentService type exposes the following members.

Methods

Name | Description
BeginCallForwardCancel | Overloaded.
BeginCallForwardSet | Overloaded.
BeginLogin | Overloaded.
BeginLogout | Overloaded.
BeginNotReady | Overloaded.
BeginReady | Overloaded.
BeginSetDNDOff | Overloaded.
BeginSetDNDOn | Overloaded.
CallForwardCancel | Overloaded.
CallForwardSet | Overloaded.
EndCallForwardCancel |
EndCallForwardSet |
EndLogin |
EndLogout |
EndNotReady |
EndReady |
EndSetDNDOff |
EndSetDNDOn |
Login | Overloaded.
Logout | Overloaded.
NotReady | Overloaded.
Ready | Overloaded.
SetDNDOff | Overloaded.
SetDNDOn | Overloaded.

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginCallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginCallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginCallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginCallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginCallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginCallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


BeginLogin Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginLogin(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginLogin(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginLogin(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogin ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogin(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogin Overload
Genesyslab.Enterprise.Services Namespace


BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogin Method (IAgent, IClientChannel, String, WorkMode, String, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginLogin(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogin ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogin(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogin(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogin Overload
Genesyslab.Enterprise.Services Namespace


BeginLogout Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginLogout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginLogout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginLogout Method (IAgent, IClientChannel, String, String, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method (IAgent, IClientChannel, String, String, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginLogout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogout Overload
Genesyslab.Enterprise.Services Namespace


BeginLogout Method (IAgent, IClientChannel, String, String, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginLogout Method (IAgent, IClientChannel, String, String, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginLogout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginLogout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginLogout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginLogout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginLogout Overload
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginNotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginNotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginNotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginNotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginNotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginNotReady Overload
Genesyslab.Enterprise.Services Namespace


BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginNotReady Method (IAgent, IClientChannel, String, WorkMode, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginNotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginNotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginNotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginNotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginNotReady Overload
Genesyslab.Enterprise.Services Namespace


BeginReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |
BeginReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginReady Method (IAgent, IClientChannel, String, WorkMode, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method (IAgent, IClientChannel, String, WorkMode, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginReady Overload
Genesyslab.Enterprise.Services Namespace


BeginReady Method (IAgent, IClientChannel, String, WorkMode, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginReady Method (IAgent, IClientChannel, String, WorkMode, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginReady Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method (IAgent, IClientChannel, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method (IAgent, IClientChannel, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginSetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOff Method (IAgent, IClientChannel, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOff Method (IAgent, IClientChannel, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginSetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
BeginSetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, AsyncCallback, Object, String) |
BeginSetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, AsyncCallback, Object, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method (IAgent, IClientChannel, , , AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method (IAgent, IClientChannel, , , AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginSetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


BeginSetDNDOn Method (IAgent, IClientChannel, , , Int32, AsyncCallback, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.BeginSetDNDOn Method (IAgent, IClientChannel, , , Int32, AsyncCallback, Object, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginSetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    AsyncCallback callBack,
    Object context,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginSetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    callBack As AsyncCallback, _
    context As Object, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginSetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    AsyncCallback^ callBack,
    Object^ context,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.BeginSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.AsyncCallback,System.Object,System.String)"]

See Also

IAgentService Interface
BeginSetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
CallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardCancel(IAgent, IClientChannel, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> CallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
CallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardCancel Method (IAgent, IClientChannel, ForwardModeType, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> CallForwardCancel(
    IAgent agent,
    IClientChannel channel,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardCancel ( _
    agent As IAgent, _
    channel As IClientChannel, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardCancel(
    IAgent^ agent,
    IClientChannel^ channel,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
CallForwardCancel Overload
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
CallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, String) |
CallForwardSet(IAgent, IClientChannel, String, ForwardModeType, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> CallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
CallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.CallForwardSet Method (IAgent, IClientChannel, String, ForwardModeType, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> CallForwardSet(
    IAgent agent,
    IClientChannel channel,
    string number,
    ForwardModeType forwardMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function CallForwardSet ( _
    agent As IAgent, _
    channel As IClientChannel, _
    number As String, _
    forwardMode As ForwardModeType, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ CallForwardSet(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ number,
    ForwardModeType forwardMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

number
Type: System..::.String

[Missing <param name="number"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

forwardMode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="forwardMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.CallForwardSet(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Device.ForwardModeType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
CallForwardSet Overload
Genesyslab.Enterprise.Services Namespace


EndCallForwardCancel Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndCallForwardCancel Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndCallForwardCancel(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCallForwardCancel ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndCallForwardCancel(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardCancel(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndCallForwardSet Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndCallForwardSet Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndCallForwardSet(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCallForwardSet ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndCallForwardSet(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndCallForwardSet(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndLogin Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndLogin Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndLogin(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndLogin ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndLogin(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogin(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndLogout Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndLogout Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndLogout(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndLogout ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndLogout(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndLogout(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndNotReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndNotReady Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndNotReady(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndNotReady ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndNotReady(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndNotReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndReady Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndReady Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndReady(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndReady ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndReady(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndReady(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndSetDNDOff Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndSetDNDOff Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndSetDNDOff(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndSetDNDOff ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndSetDNDOff(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOff(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


EndSetDNDOn Method

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.EndSetDNDOn Method
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> EndSetDNDOn(
    IAgent agent,
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndSetDNDOn ( _
    agent As IAgent, _
    aResult As IAsyncResult _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ EndSetDNDOn(
    IAgent^ agent,
    IAsyncResult^ aResult
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.EndSetDNDOn(Genesyslab.Enterprise.Agent.IAgent,System.IAsyncResult)"]

See Also

IAgentService Interface
Genesyslab.Enterprise.Services Namespace


Login Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Login(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, String) |
Login(IAgent, IClientChannel, String, WorkMode, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Login Method (IAgent, IClientChannel, String, WorkMode, String, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method (IAgent, IClientChannel, String, WorkMode, String, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> Login(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Login ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Login(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
Login Overload
Genesyslab.Enterprise.Services Namespace


Login Method (IAgent, IClientChannel, String, WorkMode, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Login Method (IAgent, IClientChannel, String, WorkMode, String, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> Login(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function Login ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Login(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Login(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
Login Overload
Genesyslab.Enterprise.Services Namespace


Logout Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Logout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, String) |
Logout(IAgent, IClientChannel, String, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Logout Method (IAgent, IClientChannel, String, String, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method (IAgent, IClientChannel, String, String, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> Logout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Logout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Logout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
Logout Overload
Genesyslab.Enterprise.Services Namespace


Logout Method (IAgent, IClientChannel, String, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Logout Method (IAgent, IClientChannel, String, String, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> Logout(
    IAgent agent,
    IClientChannel channel,
    string queue,
    string password,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function Logout ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    password As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Logout(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    String^ password,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

password
Type: System..::.String

[Missing <param name="password"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Logout(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
Logout Overload
Genesyslab.Enterprise.Services Namespace


NotReady Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
NotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) |
NotReady(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


NotReady Method (IAgent, IClientChannel, String, WorkMode, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method (IAgent, IClientChannel, String, WorkMode, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> NotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function NotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ NotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
NotReady Overload
Genesyslab.Enterprise.Services Namespace


NotReady Method (IAgent, IClientChannel, String, WorkMode, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.NotReady Method (IAgent, IClientChannel, String, WorkMode, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> NotReady(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function NotReady ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ NotReady(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.NotReady(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
NotReady Overload
Genesyslab.Enterprise.Services Namespace


Ready Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
Ready(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, String) |
Ready(IAgent, IClientChannel, String, WorkMode, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


Ready Method (IAgent, IClientChannel, String, WorkMode, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method (IAgent, IClientChannel, String, WorkMode, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> Ready(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Ready ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Ready(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
Ready Overload
Genesyslab.Enterprise.Services Namespace


Ready Method (IAgent, IClientChannel, String, WorkMode, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.Ready Method (IAgent, IClientChannel, String, WorkMode, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> Ready(
    IAgent agent,
    IClientChannel channel,
    string queue,
    WorkMode workMode,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function Ready ( _
    agent As IAgent, _
    channel As IClientChannel, _
    queue As String, _
    workMode As WorkMode, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ Ready(
    IAgent^ agent,
    IClientChannel^ channel,
    String^ queue,
    WorkMode workMode,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

workMode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="workMode"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.Ready(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Identity.WorkMode,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
Ready Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
SetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String) |
SetDNDOff(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method (IAgent, IClientChannel, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method (IAgent, IClientChannel, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> SetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
SetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOff Method (IAgent, IClientChannel, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOff Method (IAgent, IClientChannel, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> SetDNDOff(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOff ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOff(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOff(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
SetDNDOff Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method
IAgentService Interface See Also Send Feedback

Overload List

Name | Description
SetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, String) |
SetDNDOn(IAgent, IClientChannel, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IAgentService Interface
IAgentService Members
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method (IAgent, IClientChannel, , , String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method (IAgent, IClientChannel, , , String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> SetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

IAgentService Interface
SetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


SetDNDOn Method (IAgent, IClientChannel, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IAgentService..::.SetDNDOn Method (IAgent, IClientChannel, , , Int32, String)
IAgentService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IAgent> SetDNDOn(
    IAgent agent,
    IClientChannel channel,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Function SetDNDOn ( _
    agent As IAgent, _
    channel As IClientChannel, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
) As IEnvelope(Of IAgent)
Visual C++
IEnvelope<IAgent^>^ SetDNDOn(
    IAgent^ agent,
    IClientChannel^ channel,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    int timeOut,
    String^ correlatorData
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeOut
Type: System..::.Int32

[Missing <param name="timeOut"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IAgentService.SetDNDOn(Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IAgentService Interface
SetDNDOn Overload
Genesyslab.Enterprise.Services Namespace


ICallbackDomain Interface

[image]

Enterprise SDK 8.0 Reference API
ICallbackDomain Interface
Members See Also Send Feedback
Manages the data of callback contact.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICallbackDomain : IStrategyManager<ICallbackInteraction>
Visual Basic (Declaration)
Public Interface ICallbackDomain _
    Implements IStrategyManager(Of ICallbackInteraction)
Visual C++
public interface class ICallbackDomain : IStrategyManager<ICallbackInteraction^>

See Also

ICallbackDomain Members
Genesyslab.Enterprise.Services Namespace


ICallbackDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackDomain Members
ICallbackDomain Interface Methods See Also Send Feedback

The ICallbackDomain type exposes the following members.

Methods

Name | Description
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

ICallbackDomain Interface
Genesyslab.Enterprise.Services Namespace


ICallbackDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackDomain Methods
ICallbackDomain Interface See Also Send Feedback

The ICallbackDomain type exposes the following members.

Methods

Name | Description
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

ICallbackDomain Interface
Genesyslab.Enterprise.Services Namespace


ICallbackService Interface

[image]

Enterprise SDK 8.0 Reference API
ICallbackService Interface
Members See Also Send Feedback
Manages callback and filters related to outbound contact events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICallbackService : ICallbackDomain,
    IStrategyManager<ICallbackInteraction>, IEventManager<ICallbackService, IEnvelope<IInteraction>>,
    IEventManager<ICallbackService, IEnvelope<ICallbackInteraction>>, IChannelMonitor<ICallbackService>,
    IBrokerSubscriber<IEnvelope<IInteraction>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>,
    IPersistable<ICallbackInteraction>
Visual Basic (Declaration)
Public Interface ICallbackService _
    Implements ICallbackDomain, IStrategyManager(Of ICallbackInteraction),  _
    IEventManager(Of ICallbackService, IEnvelope(Of IInteraction)), IEventManager(Of ICallbackService, IEnvelope(Of ICallbackInteraction)),  _
    IChannelMonitor(Of ICallbackService), IBrokerSubscriber(Of IEnvelope(Of IInteraction)),  _
    IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)), IPersistable(Of ICallbackInteraction)
Visual C++
public interface class ICallbackService : ICallbackDomain,
    IStrategyManager<ICallbackInteraction^>, IEventManager<ICallbackService^, IEnvelope<IInteraction^>^>,
    IEventManager<ICallbackService^, IEnvelope<ICallbackInteraction^>^>, IChannelMonitor<ICallbackService^>,
    IBrokerSubscriber<IEnvelope<IInteraction^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>,
    IPersistable<ICallbackInteraction^>

See Also

ICallbackService Members
Genesyslab.Enterprise.Services Namespace


ICallbackService Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackService Members
ICallbackService Interface Methods Properties See Also Send Feedback

The ICallbackService type exposes the following members.

Methods

Name | Description
AcceptCallback | Accepts the callback request.
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CallbackProcessed | Marks the callback request as processed/completed. Call Result is set in the request.
CancelCallback | Cancels the callback request.
CustomerSessionActive |
CustomerSessionCompleted |
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RejectCallback | Rejects the callback request.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RescheduledCallback | Re-schedules the callback request.
Save | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


ICallbackService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackService Methods
ICallbackService Interface See Also Send Feedback

The ICallbackService type exposes the following members.

Methods

Name | Description
AcceptCallback | Accepts the callback request.
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CallbackProcessed | Marks the callback request as processed/completed. Call Result is set in the request.
CancelCallback | Cancels the callback request.
CustomerSessionActive |
CustomerSessionCompleted |
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RejectCallback | Rejects the callback request.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RescheduledCallback | Re-schedules the callback request.
Save | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


AcceptCallback Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.AcceptCallback Method
ICallbackService Interface See Also Send Feedback
Accepts the callback request.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AcceptCallback(
    ICallbackInteraction interaction,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub AcceptCallback ( _
    interaction As ICallbackInteraction, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void AcceptCallback(
    ICallbackInteraction^ interaction,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.AcceptCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extension
Type: KeyValueCollection

[Missing <param name="extension"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.AcceptCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.AcceptCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


CallbackProcessed Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.CallbackProcessed Method
ICallbackService Interface See Also Send Feedback
Marks the callback request as processed/completed. Call Result is set in the request.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void CallbackProcessed(
    ICallbackInteraction interaction,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub CallbackProcessed ( _
    interaction As ICallbackInteraction, _
    queue As String, _
    reasons As KeyValueCollection, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void CallbackProcessed(
    ICallbackInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CallbackProcessed(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CallbackProcessed(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CallbackProcessed(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extension
Type: KeyValueCollection

[Missing <param name="extension"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CallbackProcessed(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CallbackProcessed(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


CancelCallback Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.CancelCallback Method
ICallbackService Interface See Also Send Feedback
Cancels the callback request.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void CancelCallback(
    ICallbackInteraction interaction,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub CancelCallback ( _
    interaction As ICallbackInteraction, _
    queue As String, _
    reasons As KeyValueCollection, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void CancelCallback(
    ICallbackInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CancelCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CancelCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CancelCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extension
Type: KeyValueCollection

[Missing <param name="extension"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CancelCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CancelCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


CustomerSessionActive Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.CustomerSessionActive Method
ICallbackService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CustomerSessionActive(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void CustomerSessionActive(
    ICallbackInteraction callbackInteraction
)
Visual Basic (Declaration)
Sub CustomerSessionActive ( _
    callbackInteraction As ICallbackInteraction _
)
Visual C++
void CustomerSessionActive(
    ICallbackInteraction^ callbackInteraction
)

Parameters

callbackInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="callbackInteraction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CustomerSessionActive(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


CustomerSessionCompleted Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.CustomerSessionCompleted Method
ICallbackService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CustomerSessionCompleted(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void CustomerSessionCompleted(
    ICallbackInteraction callbackInteraction
)
Visual Basic (Declaration)
Sub CustomerSessionCompleted ( _
    callbackInteraction As ICallbackInteraction _
)
Visual C++
void CustomerSessionCompleted(
    ICallbackInteraction^ callbackInteraction
)

Parameters

callbackInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="callbackInteraction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.CustomerSessionCompleted(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.GetList Method
ICallbackService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

ICallbackService Interface
ICallbackService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.ListFilter<(Of <(T>)>) Method
ICallbackService Interface See Also Send Feedback
Lists the filters registered for the given interaction instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    ICallbackInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As ICallbackInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    ICallbackInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction
Target interaction object.

Type Parameters

T
Type of data handled in filter object

Return Value

IEnumerable<T>

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.RegisterEvents Method
ICallbackService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

ICallbackService Interface
ICallbackService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.RegisterFilter<(Of <(T>)>) Method
ICallbackService Interface See Also Send Feedback
Registers a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICallbackService RegisterFilter<T>(
    ICallbackInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As ICallbackInteraction, _
    filter As T _
) As ICallbackService
Visual C++
generic<typename T>
ICallbackService^ RegisterFilter(
    ICallbackInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction
Interaction.
filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,``0)"]

Type Parameters

T
Filter type.

Return Value

ICallbackService

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


RejectCallback Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.RejectCallback Method
ICallbackService Interface See Also Send Feedback
Rejects the callback request.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RejectCallback(
    ICallbackInteraction interaction,
    KeyValueCollection reasons,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RejectCallback ( _
    interaction As ICallbackInteraction, _
    reasons As KeyValueCollection, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RejectCallback(
    ICallbackInteraction^ interaction,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RejectCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RejectCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extension
Type: KeyValueCollection

[Missing <param name="extension"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RejectCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RejectCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


RescheduledCallback Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.RescheduledCallback Method
ICallbackService Interface See Also Send Feedback
Re-schedules the callback request.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RescheduledCallback(
    ICallbackInteraction interaction,
    DateTime startDate,
    DateTime endDate,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RescheduledCallback ( _
    interaction As ICallbackInteraction, _
    startDate As DateTime, _
    endDate As DateTime, _
    queue As String, _
    reasons As KeyValueCollection, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RescheduledCallback(
    ICallbackInteraction^ interaction,
    DateTime startDate,
    DateTime endDate,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

startDate
Type: System..::.DateTime

[Missing <param name="startDate"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

endDate
Type: System..::.DateTime

[Missing <param name="endDate"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

reasons
Type: KeyValueCollection

[Missing <param name="reasons"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

extension
Type: KeyValueCollection

[Missing <param name="extension"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.ICallbackService.RescheduledCallback(Genesyslab.Enterprise.Model.Interaction.ICallbackInteraction,System.DateTime,System.DateTime,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String)"]

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.Save Method
ICallbackService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

ICallbackService Interface
ICallbackService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ICallbackService..::.UnRegisterFilter<(Of <(T>)>) Method
ICallbackService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Callback (in Genesyslab.Enterprise.Services.Callback.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICallbackService UnRegisterFilter<T>(
    ICallbackInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As ICallbackInteraction, _
    filter As T _
) As ICallbackService
Visual C++
generic<typename T>
ICallbackService^ UnRegisterFilter(
    ICallbackInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ICallbackInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

ICallbackService

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


ICallbackService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICallbackService Properties
ICallbackService Interface See Also Send Feedback

The ICallbackService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ICallbackService Interface
Genesyslab.Enterprise.Services Namespace


ICampaignDomain Interface

[image]

Enterprise SDK 8.0 Reference API
ICampaignDomain Interface
Members See Also Send Feedback
Manages the campaign of outbound contacts.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICampaignDomain : IStrategyManager<ICampaign>
Visual Basic (Declaration)
Public Interface ICampaignDomain _
    Implements IStrategyManager(Of ICampaign)
Visual C++
public interface class ICampaignDomain : IStrategyManager<ICampaign^>

See Also

ICampaignDomain Members
Genesyslab.Enterprise.Services Namespace


ICampaignDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaignDomain Members
ICampaignDomain Interface Methods See Also Send Feedback

The ICampaignDomain type exposes the following members.

Methods

Name | Description
GetAllCampaigns | Gets all the campaigns.
GetCampaign | Gets a campaign.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

ICampaignDomain Interface
Genesyslab.Enterprise.Services Namespace


ICampaignDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaignDomain Methods
ICampaignDomain Interface See Also Send Feedback

The ICampaignDomain type exposes the following members.

Methods

Name | Description
GetAllCampaigns | Gets all the campaigns.
GetCampaign | Gets a campaign.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

ICampaignDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAllCampaigns Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignDomain..::.GetAllCampaigns Method
ICampaignDomain Interface See Also Send Feedback
Gets all the campaigns.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, ICampaign> GetAllCampaigns()
Visual Basic (Declaration)
Function GetAllCampaigns As IDictionary(Of String, ICampaign)
Visual C++
IDictionary<String^, ICampaign^>^ GetAllCampaigns()

Return Value

The dictionary of campaign by campaign name.

See Also

ICampaignDomain Interface
Genesyslab.Enterprise.Services Namespace


GetCampaign Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignDomain..::.GetCampaign Method
ICampaignDomain Interface See Also Send Feedback
Gets a campaign.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaign GetCampaign(
    string aCampaignName
)
Visual Basic (Declaration)
Function GetCampaign ( _
    aCampaignName As String _
) As ICampaign
Visual C++
ICampaign^ GetCampaign(
    String^ aCampaignName
)

Parameters

aCampaignName
Type: System..::.String
the campaign name.

Return Value

A campaign or null if not found.

See Also

ICampaignDomain Interface
Genesyslab.Enterprise.Services Namespace


ICampaignService Interface

[image]

Enterprise SDK 8.0 Reference API
ICampaignService Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.ICampaignService"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ICampaignService : ICampaignDomain,
    IStrategyManager<ICampaign>, ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface ICampaignService _
    Implements ICampaignDomain, IStrategyManager(Of ICampaign),  _
    ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class ICampaignService : ICampaignDomain,
    IStrategyManager<ICampaign^>, ISubscribeable<IEnvelope<IRequest^>^>

See Also

ICampaignService Members
Genesyslab.Enterprise.Services Namespace


ICampaignService Members

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaignService Members
ICampaignService Interface Methods Properties See Also Send Feedback

The ICampaignService type exposes the following members.

Methods

Name | Description
GetAllCampaigns | Gets all the campaigns. (Inherited from ICampaignDomain.)
GetCampaign | Gets a campaign. (Inherited from ICampaignDomain.)
GetPreviewRecord | Gets a Preview Record. This method is available if supported by the current campaign mode.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given campaign instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given campaign.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RequestCampaignStatus | Gets all campaign statuses.
RequestLogout | Requests a logout on a campaign.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
StartPreviewMode | Starts Preview Mode.
StopPreviewMode | Stops Preview Mode.
UnRegisterEvents | Unregisters the given handler for the given device.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given campaign.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


ICampaignService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaignService Methods
ICampaignService Interface See Also Send Feedback

The ICampaignService type exposes the following members.

Methods

Name | Description
GetAllCampaigns | Gets all the campaigns. (Inherited from ICampaignDomain.)
GetCampaign | Gets a campaign. (Inherited from ICampaignDomain.)
GetPreviewRecord | Gets a Preview Record. This method is available if supported by the current campaign mode.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given campaign instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given campaign.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RequestCampaignStatus | Gets all campaign statuses.
RequestLogout | Requests a logout on a campaign.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
StartPreviewMode | Starts Preview Mode.
StopPreviewMode | Stops Preview Mode.
UnRegisterEvents | Unregisters the given handler for the given device.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given campaign.

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


GetPreviewRecord Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.GetPreviewRecord Method
ICampaignService Interface See Also Send Feedback
Gets a Preview Record. This method is available if supported by the current campaign mode.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService GetPreviewRecord(
    ICampaign campaign,
    string correlatorData
)
Visual Basic (Declaration)
Function GetPreviewRecord ( _
    campaign As ICampaign, _
    correlatorData As String _
) As ICampaignService
Visual C++
ICampaignService^ GetPreviewRecord(
    ICampaign^ campaign,
    String^ correlatorData
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
The campaign.
correlatorData
Type: System..::.String
The Correlator Data.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.ListFilter<(Of <(T>)>) Method
ICampaignService Interface See Also Send Feedback
Lists the filters registered for the given campaign instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    ICampaign campaign
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    campaign As ICampaign _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    ICampaign^ campaign
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
Target interaction object.

Type Parameters

T
Type of data handled in filter object

Return Value

IEnumerable<T>

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.RegisterEvents Method
ICampaignService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(ICampaign>)>)>)>)) | Registers the given handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(ICampaign>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers the given handler for the given device.

See Also

ICampaignService Interface
ICampaignService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(ICampaign)))

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(ICampaign>)>)>)>))
ICampaignService Interface See Also Send Feedback
Registers the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService RegisterEvents(
    IDevice device,
    Action<IEnvelope<ICampaign>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of ICampaign)) _
) As ICampaignService
Visual C++
ICampaignService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<ICampaign^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The DN device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ICampaign >)>)>)>)
The Campaign Event handler.

Return Value

ICampaignService

See Also

ICampaignService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(ICampaign)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(ICampaign>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
ICampaignService Interface See Also Send Feedback
Registers the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService RegisterEvents(
    IDevice device,
    Action<IEnvelope<ICampaign>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of ICampaign)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As ICampaignService
Visual C++
ICampaignService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<ICampaign^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The DN device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ICampaign >)>)>)>)
The Campaign Event handler.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategies list.
filterList
Type: array< System..::.Attribute >[]()[]
Filter List.

Return Value

ICampaignService

See Also

ICampaignService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.RegisterFilter<(Of <(T>)>) Method
ICampaignService Interface See Also Send Feedback
Registers a filter for a given campaign.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService RegisterFilter<T>(
    ICampaign campaign,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    campaign As ICampaign, _
    filter As T _
) As ICampaignService
Visual C++
generic<typename T>
ICampaignService^ RegisterFilter(
    ICampaign^ campaign,
    T filter
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
Interaction.
filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.ICampaignService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.ICampaign,``0)"]

Type Parameters

T
Filter type.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


RequestCampaignStatus Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.RequestCampaignStatus Method
ICampaignService Interface See Also Send Feedback
Gets all campaign statuses.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService RequestCampaignStatus(
    IDevice dn,
    string correlatorData
)
Visual Basic (Declaration)
Function RequestCampaignStatus ( _
    dn As IDevice, _
    correlatorData As String _
) As ICampaignService
Visual C++
ICampaignService^ RequestCampaignStatus(
    IDevice^ dn,
    String^ correlatorData
)

Parameters

dn
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The DN Device.
correlatorData
Type: System..::.String
The Correlator Data.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


RequestLogout Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.RequestLogout Method
ICampaignService Interface See Also Send Feedback
Requests a logout on a campaign.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService RequestLogout(
    ICampaign campaign,
    string correlatorData
)
Visual Basic (Declaration)
Function RequestLogout ( _
    campaign As ICampaign, _
    correlatorData As String _
) As ICampaignService
Visual C++
ICampaignService^ RequestLogout(
    ICampaign^ campaign,
    String^ correlatorData
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
The campaign.
correlatorData
Type: System..::.String
The Correlator Data.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


StartPreviewMode Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.StartPreviewMode Method
ICampaignService Interface See Also Send Feedback
Starts Preview Mode.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService StartPreviewMode(
    ICampaign campaign,
    string correlatorData
)
Visual Basic (Declaration)
Function StartPreviewMode ( _
    campaign As ICampaign, _
    correlatorData As String _
) As ICampaignService
Visual C++
ICampaignService^ StartPreviewMode(
    ICampaign^ campaign,
    String^ correlatorData
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
The campaign.
correlatorData
Type: System..::.String
The Correlator Data.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


StopPreviewMode Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.StopPreviewMode Method
ICampaignService Interface See Also Send Feedback
Stops Preview Mode.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService StopPreviewMode(
    ICampaign campaign,
    string correlatorData
)
Visual Basic (Declaration)
Function StopPreviewMode ( _
    campaign As ICampaign, _
    correlatorData As String _
) As ICampaignService
Visual C++
ICampaignService^ StopPreviewMode(
    ICampaign^ campaign,
    String^ correlatorData
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
The campaign.
correlatorData
Type: System..::.String
The Correlator Data.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.UnRegisterEvents Method
ICampaignService Interface See Also Send Feedback
Unregisters the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService UnRegisterEvents(
    IDevice device,
    Action<IEnvelope<ICampaign>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of ICampaign)) _
) As ICampaignService
Visual C++
ICampaignService^ UnRegisterEvents(
    IDevice^ device,
    Action<IEnvelope<ICampaign^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The DN device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( ICampaign >)>)>)>)
The Campaign Event handler.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ICampaignService..::.UnRegisterFilter<(Of <(T>)>) Method
ICampaignService Interface See Also Send Feedback
Unregisters a filter for a given campaign.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICampaignService UnRegisterFilter<T>(
    ICampaign campaign,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    campaign As ICampaign, _
    filter As T _
) As ICampaignService
Visual C++
generic<typename T>
ICampaignService^ UnRegisterFilter(
    ICampaign^ campaign,
    T filter
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

ICampaignService

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


ICampaignService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ICampaignService Properties
ICampaignService Interface See Also Send Feedback

The ICampaignService type exposes the following members.

Properties

Name | Description
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ICampaignService Interface
Genesyslab.Enterprise.Services Namespace


IChannelMonitor(D) Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelMonitor<(Of <(D>)>) Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.IChannelMonitor`1"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChannelMonitor<D>
Visual Basic (Declaration)
Public Interface IChannelMonitor(Of D)
Visual C++
generic<typename D>
public interface class IChannelMonitor

Type Parameters

D

[Missing <typeparam name="D"/> documentation for "T:Genesyslab.Enterprise.Services.IChannelMonitor`1"]

See Also

IChannelMonitor<(Of <(D>)>) Members
Genesyslab.Enterprise.Services Namespace


IChannelMonitor(D) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelMonitor<(Of <(D>)>) Members
IChannelMonitor<(Of <(D>)>) Interface Methods See Also Send Feedback

The IChannelMonitor<(Of <(D>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events.
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel.

See Also

IChannelMonitor<(Of <(D>)>) Interface
Genesyslab.Enterprise.Services Namespace


IChannelMonitor(D) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelMonitor<(Of <(D>)>) Methods
IChannelMonitor<(Of <(D>)>) Interface See Also Send Feedback

The IChannelMonitor<(Of <(D>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events.
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel.

See Also

IChannelMonitor<(Of <(D>)>) Interface
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelMonitor<(Of <(D>)>)..::.AddChannel Method
IChannelMonitor<(Of <(D>)>) Interface See Also Send Feedback
Enables the monitoring of the given channel. Note: This method does not fire events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D AddChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AddChannel ( _
    channel As IClientChannel _
) As D
Visual C++
D AddChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object

Return Value

D

See Also

IChannelMonitor<(Of <(D>)>) Interface
Genesyslab.Enterprise.Services Namespace


RemoveChannel Method

[image]

Enterprise SDK 8.0 Reference API
IChannelMonitor<(Of <(D>)>)..::.RemoveChannel Method
IChannelMonitor<(Of <(D>)>) Interface See Also Send Feedback
Removes the given channel from the monitoring list. No events are received anymore for this channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D RemoveChannel(
    IClientChannel channel
)
Visual Basic (Declaration)
Function RemoveChannel ( _
    channel As IClientChannel _
) As D
Visual C++
D RemoveChannel(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel object

Return Value

D

See Also

IChannelMonitor<(Of <(D>)>) Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Interface

[image]

Enterprise SDK 8.0 Reference API
IChannelService Interface
Members Example See Also Send Feedback
Interface for managing channels.

With this interface, you declare and declare new communication channels, one for each media connection (for instance a switch.)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChannelService : IChannelManager,
    IStrategyManager<IClientChannel>, IEventManager<IChannelService, IClientChannel>,
    IChannelMonitor<IChannelService>
Visual Basic (Declaration)
Public Interface IChannelService _
    Implements IChannelManager, IStrategyManager(Of IClientChannel),  _
    IEventManager(Of IChannelService, IClientChannel), IChannelMonitor(Of IChannelService)
Visual C++
public interface class IChannelService : IChannelManager,
    IStrategyManager<IClientChannel^>, IEventManager<IChannelService^, IClientChannel^>,
    IChannelMonitor<IChannelService^>

Examples

This code sample show how to create and register a channel:
CopyC#
IChannelService channelService = EsdkService.Resolve<IChannelService>("channelService");
TServerConfiguration conf = new TServerConfiguration("Label name");
//Identify the client in TServer
conf.ClientName = "Channel Name";
conf.Uri = new Uri("tcp://hostname:port_value");
conf.WarmStandbyAttempts = 10;
conf.WarmStandbyTimeout = 5;
conf.WarmStandbyUri = new Uri("tcp://hostname:19345");
conf.UseAddp = false;

channelService.CreateChannel("Label name", conf, SwitchModelType.LucentDefinityG3 );
Genesyslab.Enterprise.Model.Channel.IClientChannel channel = channelService.GetChannel("Label name");

Then you can register a method for channel events:

CopyC#
//Register for Channel events
channelService.RegisterEvents<Genesyslab.Enterprise.Model.Channel.IClientChannel>(channel, new Action<Genesyslab.Enterprise.Model.Channel.IClientChannel>(ChannelEvent));

Do not forget to declare a ChannelEvent method somewhere else in your code, as shown below:

CopyC#
protected void ChannelEvent(Genesyslab.Enterprise.Model.Channel.IClientChannel channel)
{
        System.Console.Write("[ChannelEvent] Status="+ channel.State));
}

Then, you can bind devices with channels. In the following code snippet, DeviceA is a reference of type IDevice.

CopyC#
channelService.BindDevice(deviceA, channel);
 Note: See IDeviceService for further details about creating and managing devices.

See Also

IChannelService Members
Genesyslab.Enterprise.Services Namespace


IChannelService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Members
IChannelService Interface Methods Properties See Also Send Feedback

The IChannelService type exposes the following members.

Methods

Name | Description
AddChannel | Overloaded.
BindDevice | Overloaded.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel. (Inherited from IChannelManager.)
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel. (Inherited from IChannelManager.)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SendMessage | Sends a message to the given channel. (Inherited from IChannelManager.)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnbindDevice | Unbinds a device.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

Properties

Name | Description
ProtocolManager | Returns the associated protocol manager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Methods
IChannelService Interface See Also Send Feedback

The IChannelService type exposes the following members.

Methods

Name | Description
AddChannel | Overloaded.
BindDevice | Overloaded.
Connect | Overloaded.
CreateChannel | Overloaded.
DeleteChannel | Deletes the given channel. (Inherited from IChannelManager.)
Disconnect | Overloaded.
GetChannel | Overloaded.
ListChannels | Overloaded.
ListDevices | Lists the devices of a specific channel. (Inherited from IChannelManager.)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SendMessage | Sends a message to the given channel. (Inherited from IChannelManager.)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnbindDevice | Unbinds a device.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


AddChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.AddChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
AddChannel(IClientChannel) | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
AddChannel(IClientChannel, ProtocolConfiguration) | Adds the given channel. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


BindDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.BindDevice Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
BindDevice(IDevice, IClientChannel) | Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().
BindDevice(IDevice, IClientChannel, KeyValueCollection) | Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


BindDevice Method (IDevice, IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.BindDevice Method (IDevice, IClientChannel)
IChannelService Interface See Also Send Feedback
Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager BindDevice(
    IDevice device,
    IClientChannel channel
)
Visual Basic (Declaration)
Function BindDevice ( _
    device As IDevice, _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ BindDevice(
    IDevice^ device,
    IClientChannel^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to bind with the channel.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.

Return Value

the IChannelManager.

Remarks

See also this service description for code examples.

See Also

IChannelService Interface
BindDevice Overload
Genesyslab.Enterprise.Services Namespace
Genesyslab.Enterprise.Services..::.IDeviceService


BindDevice Method (IDevice, IClientChannel, )

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.BindDevice Method (IDevice, IClientChannel, )
IChannelService Interface See Also Send Feedback
Binds a device with a channel. Before you bind the device with the channel, you must first register your channel in the channel service, and your device in the device service ().

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager BindDevice(
    IDevice device,
    IClientChannel channel,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function BindDevice ( _
    device As IDevice, _
    channel As IClientChannel, _
    extensions As KeyValueCollection _
) As IChannelManager
Visual C++
IChannelManager^ BindDevice(
    IDevice^ device,
    IClientChannel^ channel,
    KeyValueCollection^ extensions
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to bind with the channel.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.
extensions
Type: KeyValueCollection
Extensions.

Return Value

the IChannelManager.

Remarks

See also this service description for code examples.

See Also

IChannelService Interface
BindDevice Overload
Genesyslab.Enterprise.Services Namespace
Genesyslab.Enterprise.Services..::.IDeviceService


Connect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.Connect Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
Connect()()() | Connects all the channels. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(IClientChannel) | Connects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(Int32) | Connects all the channels. Note: This method is synchronous. (Inherited from IChannelManager.)
Connect(String) | Connects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Connect(IClientChannel, Int32) | Connects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)
Connect(String, Int32) | Connects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


CreateChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.CreateChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
CreateChannel(ProtocolConfiguration) | Obsolete. Creates a channel based on a user configuration instance without a switch abstraction. (Inherited from IChannelManager.)
CreateChannel(ProtocolConfiguration, SwitchModelType) | Obsolete. Creates a channel based on the given user configuration and switch type. (Inherited from IChannelManager.)
CreateChannel(ProtocolConfiguration, String) | Obsolete. Creates a channel based on the given configuration instance. (Inherited from IChannelManager.)
CreateChannel(String, IProtocolConfiguration) | Creates a channel without switch asbtraction capability. (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration) | Obsolete. Creates a channel without switch asbtraction capability. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol) | Creates a channel based on already existing connection (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration, SwitchModelType) | Obsolete. Creates a named channel, with the given user configuration and switch abstraction capability. (Inherited from IChannelManager.)
CreateChannel(String, ProtocolConfiguration, String) | Obsolete. Creates a channel, with the given user configuration and switch abstraction capability. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol, SwitchModelType) | Obsolete. Creates a channel based on already existing connection and switch type. (Inherited from IChannelManager.)
CreateChannel(String, IProtocol, String) | Obsolete. Creates a channel based on already existing connection and switch type. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


Disconnect Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.Disconnect Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
Disconnect()()() | Disconnects all the channels. (Inherited from IChannelManager.)
Disconnect(IClientChannel) | Disconnects the given channel instance. Note: This method is asynchronous. (Inherited from IChannelManager.)
Disconnect(String) | Disconnects the given channel. Note: This method is asynchronous. (Inherited from IChannelManager.)
Disconnect(IClientChannel, Int32) | Disconnects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)
Disconnect(String, Int32) | Disconnects the given channel. Note: This method is synchronous. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


GetChannel Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.GetChannel Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
GetChannel(IDevice) | Returns a channel object from a device (Inherited from IChannelManager.)
GetChannel(String) | Returns a channel object. (Inherited from IChannelManager.)
GetChannel(Uri) | Returns the channel with the given URI. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


ListChannels Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.ListChannels Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
ListChannels<(Of <(T>)>)()()() | Lists the channels registered in the service. (Inherited from IChannelManager.)
ListChannels()()() | Lists all the channels registered in the service. (Inherited from IChannelManager.)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService..::.RegisterEvents Method
IChannelService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChannelService Interface
IChannelService Members
Genesyslab.Enterprise.Services Namespace


UnbindDevice Method

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.UnbindDevice Method
IChannelService Interface See Also Send Feedback
Unbinds a device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChannelManager UnbindDevice(
    IDevice device,
    IClientChannel channel
)
Visual Basic (Declaration)
Function UnbindDevice ( _
    device As IDevice, _
    channel As IClientChannel _
) As IChannelManager
Visual C++
IChannelManager^ UnbindDevice(
    IDevice^ device,
    IClientChannel^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to unbind.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel.

Return Value

the IChannelManager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChannelService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChannelService Properties
IChannelService Interface See Also Send Feedback

The IChannelService type exposes the following members.

Properties

Name | Description
ProtocolManager | Returns the associated protocol manager.

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


ProtocolManager Property

[image]

Enterprise SDK 8.0 Reference API
IChannelService..::.ProtocolManager Property
IChannelService Interface See Also Send Feedback
Returns the associated protocol manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object ProtocolManager { get; }
Visual Basic (Declaration)
ReadOnly Property ProtocolManager As Object
Visual C++
property Object^ ProtocolManager {
    Object^ get ();
}

See Also

IChannelService Interface
Genesyslab.Enterprise.Services Namespace


IChatDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IChatDomain Interface
Members See Also Send Feedback
Interface for the Chat domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChatDomain : IStrategyManager<IChatInteraction>
Visual Basic (Declaration)
Public Interface IChatDomain _
    Implements IStrategyManager(Of IChatInteraction)
Visual C++
public interface class IChatDomain : IStrategyManager<IChatInteraction^>

See Also

IChatDomain Members
Genesyslab.Enterprise.Services Namespace


IChatDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChatDomain Members
IChatDomain Interface Methods See Also Send Feedback

The IChatDomain type exposes the following members.

Methods

Name | Description
GetInteractions | Gets the Chat interactions.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IChatDomain Interface
Genesyslab.Enterprise.Services Namespace


IChatDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChatDomain Methods
IChatDomain Interface See Also Send Feedback

The IChatDomain type exposes the following members.

Methods

Name | Description
GetInteractions | Gets the Chat interactions.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IChatDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IChatDomain..::.GetInteractions Method
IChatDomain Interface See Also Send Feedback
Gets the Chat interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChatInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IChatInteraction()
Visual C++
array<IChatInteraction^>^ GetInteractions()

Return Value

The Chat interaction list.

See Also

IChatDomain Interface
Genesyslab.Enterprise.Services Namespace


IChatService Interface

[image]

Enterprise SDK 8.0 Reference API
IChatService Interface
Members See Also Send Feedback
Manages callback and filters related to chat interaction events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IChatService : IChatDomain,
    IStrategyManager<IChatInteraction>, IEventManager<IChatService, IEnvelope<IInteraction>>,
    IChannelMonitor<IChatService>, IBrokerSubscriber<IEnvelope<IInteraction>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IChatInteraction>
Visual Basic (Declaration)
Public Interface IChatService _
    Implements IChatDomain, IStrategyManager(Of IChatInteraction),  _
    IEventManager(Of IChatService, IEnvelope(Of IInteraction)), IChannelMonitor(Of IChatService),  _
    IBrokerSubscriber(Of IEnvelope(Of IInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IChatInteraction)
Visual C++
public interface class IChatService : IChatDomain,
    IStrategyManager<IChatInteraction^>, IEventManager<IChatService^, IEnvelope<IInteraction^>^>,
    IChannelMonitor<IChatService^>, IBrokerSubscriber<IEnvelope<IInteraction^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IChatInteraction^>

See Also

IChatService Members
Genesyslab.Enterprise.Services Namespace


IChatService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService Members
IChatService Interface Methods Properties See Also Send Feedback

The IChatService type exposes the following members.

Methods

Name | Description
Accept | Overloaded.
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginConferenceAgent | Overloaded.
BeginConferencePlace | Overloaded.
BeginInitConsultation |
BeginTransferAgent | Overloaded.
BeginTransferPlace | Overloaded.
BeginTransferQueue | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
ConferenceAgent | Overloaded.
ConferencePlace | Overloaded.
Decline | Rejects the processing of the given chat interaction.
Disconnect | Disconnects the media server.
EndCompleteConference |
EndCompleteTransfer |
EndConferenceAgent |
EndConferencePlace |
EndInitConsultation |
EndTransferAgent |
EndTransferPlace |
EndTransferQueue |
GetInteractions | Gets the Chat interactions. (Inherited from IChatDomain.)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
InitConsultation | Overloaded.
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
PlaceInQueue | Places the chat interaction in the given queue.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
PushUrl | Sends a push URL notification.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveInteraction | Saves the chat interaction.
SendMessage | Sends a message.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
TransferAgent | Overloaded.
TransferPlace | Overloaded.
TransferQueue | Overloaded.
TypingStarted | Starts typing notification.
TypingStopped | Stops typing notification.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


IChatService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService Methods
IChatService Interface See Also Send Feedback

The IChatService type exposes the following members.

Methods

Name | Description
Accept | Overloaded.
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
BeginCompleteConference | Overloaded.
BeginCompleteTransfer | Overloaded.
BeginConferenceAgent | Overloaded.
BeginConferencePlace | Overloaded.
BeginInitConsultation |
BeginTransferAgent | Overloaded.
BeginTransferPlace | Overloaded.
BeginTransferQueue | Overloaded.
CompleteConference | Overloaded.
CompleteTransfer | Overloaded.
ConferenceAgent | Overloaded.
ConferencePlace | Overloaded.
Decline | Rejects the processing of the given chat interaction.
Disconnect | Disconnects the media server.
EndCompleteConference |
EndCompleteTransfer |
EndConferenceAgent |
EndConferencePlace |
EndInitConsultation |
EndTransferAgent |
EndTransferPlace |
EndTransferQueue |
GetInteractions | Gets the Chat interactions. (Inherited from IChatDomain.)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
InitConsultation | Overloaded.
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
PlaceInQueue | Places the chat interaction in the given queue.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
PushUrl | Sends a push URL notification.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveInteraction | Saves the chat interaction.
SendMessage | Sends a message.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
TransferAgent | Overloaded.
TransferPlace | Overloaded.
TransferQueue | Overloaded.
TypingStarted | Starts typing notification.
TypingStopped | Stops typing notification.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


Accept Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.Accept Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
Accept(IClientChannel, IChatInteraction) | Accepts the given chat interaction on the Interaction Server side and joins the chat session on the Chat Server. This request throws 2 events on client's side: - EventAck from the Interaction Server. - EventJoined from Chat Server. The related Chat data (for instance parties) must be processed inside the registered ChatService call-back method.
Accept(IClientChannel, IChatInteraction, Visibility) | Accepts the given chat interaction on the Interaction Server side and joins the chat session on the Chat Server. This request throws 2 events on client's side: - EventAck from the Interaction Server. - EventJoined from Chat Server. The related Chat data (for instance parties) must be processed inside the registered ChatService call-back method. Chat related parties (customer...) will be visible only on EventJoined event from Chat Server.

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


Accept Method (IClientChannel, IChatInteraction)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.Accept Method (IClientChannel, IChatInteraction)
IChatService Interface See Also Send Feedback
Accepts the given chat interaction on the Interaction Server side and joins the chat session on the Chat Server.

This request throws 2 events on client's side:

- EventAck from the Interaction Server.

- EventJoined from Chat Server.

The related Chat data (for instance parties) must be processed inside the registered ChatService call-back method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChatInteraction> Accept(
    IClientChannel chatServerChannel,
    IChatInteraction interaction
)
Visual Basic (Declaration)
Function Accept ( _
    chatServerChannel As IClientChannel, _
    interaction As IChatInteraction _
) As IEnvelope(Of IChatInteraction)
Visual C++
IEnvelope<IChatInteraction^>^ Accept(
    IClientChannel^ chatServerChannel,
    IChatInteraction^ interaction
)

Parameters

chatServerChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Chat Server Channel.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
Interaction.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
Accept Overload
Genesyslab.Enterprise.Services Namespace


Accept Method (IClientChannel, IChatInteraction, Visibility)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.Accept Method (IClientChannel, IChatInteraction, Visibility)
IChatService Interface See Also Send Feedback
Accepts the given chat interaction on the Interaction Server side and joins the chat session on the Chat Server.

This request throws 2 events on client's side:

- EventAck from the Interaction Server.

- EventJoined from Chat Server.

The related Chat data (for instance parties) must be processed inside the registered ChatService call-back method. Chat related parties (customer...) will be visible only on EventJoined event from Chat Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChatInteraction> Accept(
    IClientChannel chatServerChannel,
    IChatInteraction interaction,
    Visibility visibility
)
Visual Basic (Declaration)
Function Accept ( _
    chatServerChannel As IClientChannel, _
    interaction As IChatInteraction, _
    visibility As Visibility _
) As IEnvelope(Of IChatInteraction)
Visual C++
IEnvelope<IChatInteraction^>^ Accept(
    IClientChannel^ chatServerChannel,
    IChatInteraction^ interaction,
    Visibility visibility
)

Parameters

chatServerChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Chat Server Channel.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
Interaction.
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility
Visibility of the Agent.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
Accept Overload
Genesyslab.Enterprise.Services Namespace


BeginCompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginCompleteConference Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginCompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32) |
BeginCompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginCompleteConference Method (IChatInteraction, String, , , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginCompleteConference Method (IChatInteraction, String, , , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCompleteConference(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginCompleteConference ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCompleteConference(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginCompleteConference Overload
Genesyslab.Enterprise.Services Namespace


BeginCompleteConference Method (IChatInteraction, String, , , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginCompleteConference Method (IChatInteraction, String, , , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCompleteConference(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCompleteConference ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCompleteConference(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginCompleteConference Overload
Genesyslab.Enterprise.Services Namespace


BeginCompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginCompleteTransfer Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginCompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32) |
BeginCompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginCompleteTransfer Method (IChatInteraction, String, , , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginCompleteTransfer Method (IChatInteraction, String, , , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCompleteTransfer(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginCompleteTransfer ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCompleteTransfer(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Services Namespace


BeginCompleteTransfer Method (IChatInteraction, String, , , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginCompleteTransfer Method (IChatInteraction, String, , , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginCompleteTransfer(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginCompleteTransfer ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginCompleteTransfer(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginCompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginCompleteTransfer Overload
Genesyslab.Enterprise.Services Namespace


BeginConferenceAgent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginConferenceAgent Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginConferenceAgent(IChatInteraction, String, Visibility, KeyValueCollection, AsyncCallback, Int32) |
BeginConferenceAgent(IChatInteraction, String, Visibility, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginConferenceAgent Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginConferenceAgent Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginConferenceAgent(
    IChatInteraction interaction,
    string agent,
    Visibility visibility,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginConferenceAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginConferenceAgent(
    IChatInteraction^ interaction,
    String^ agent,
    Visibility visibility,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginConferenceAgent Overload
Genesyslab.Enterprise.Services Namespace


BeginConferenceAgent Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginConferenceAgent Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginConferenceAgent(
    IChatInteraction interaction,
    string agent,
    Visibility visibility,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginConferenceAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginConferenceAgent(
    IChatInteraction^ interaction,
    String^ agent,
    Visibility visibility,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginConferenceAgent Overload
Genesyslab.Enterprise.Services Namespace


BeginConferencePlace Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginConferencePlace Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginConferencePlace(IChatInteraction, String, Visibility, KeyValueCollection, AsyncCallback, Int32) |
BeginConferencePlace(IChatInteraction, String, Visibility, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginConferencePlace Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginConferencePlace Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginConferencePlace(
    IChatInteraction interaction,
    string place,
    Visibility visibility,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginConferencePlace ( _
    interaction As IChatInteraction, _
    place As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginConferencePlace(
    IChatInteraction^ interaction,
    String^ place,
    Visibility visibility,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginConferencePlace Overload
Genesyslab.Enterprise.Services Namespace


BeginConferencePlace Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginConferencePlace Method (IChatInteraction, String, Visibility, , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginConferencePlace(
    IChatInteraction interaction,
    string place,
    Visibility visibility,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginConferencePlace ( _
    interaction As IChatInteraction, _
    place As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginConferencePlace(
    IChatInteraction^ interaction,
    String^ place,
    Visibility visibility,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginConferencePlace Overload
Genesyslab.Enterprise.Services Namespace


BeginInitConsultation Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginInitConsultation Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginInitConsultation(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginInitConsultation ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginInitConsultation(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginInitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


BeginTransferAgent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferAgent Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginTransferAgent(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32) |
BeginTransferAgent(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginTransferAgent Method (IChatInteraction, String, , , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferAgent Method (IChatInteraction, String, , , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginTransferAgent(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginTransferAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginTransferAgent(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginTransferAgent Overload
Genesyslab.Enterprise.Services Namespace


BeginTransferAgent Method (IChatInteraction, String, , , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferAgent Method (IChatInteraction, String, , , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginTransferAgent(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginTransferAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginTransferAgent(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginTransferAgent Overload
Genesyslab.Enterprise.Services Namespace


BeginTransferPlace Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferPlace Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginTransferPlace(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32) |
BeginTransferPlace(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginTransferPlace Method (IChatInteraction, String, , , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferPlace Method (IChatInteraction, String, , , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginTransferPlace(
    IChatInteraction interaction,
    string place,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginTransferPlace ( _
    interaction As IChatInteraction, _
    place As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginTransferPlace(
    IChatInteraction^ interaction,
    String^ place,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginTransferPlace Overload
Genesyslab.Enterprise.Services Namespace


BeginTransferPlace Method (IChatInteraction, String, , , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferPlace Method (IChatInteraction, String, , , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginTransferPlace(
    IChatInteraction interaction,
    string place,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginTransferPlace ( _
    interaction As IChatInteraction, _
    place As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginTransferPlace(
    IChatInteraction^ interaction,
    String^ place,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginTransferPlace Overload
Genesyslab.Enterprise.Services Namespace


BeginTransferQueue Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferQueue Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
BeginTransferQueue(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32) |
BeginTransferQueue(IChatInteraction, String, KeyValueCollection, KeyValueCollection, AsyncCallback, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


BeginTransferQueue Method (IChatInteraction, String, , , AsyncCallback, Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferQueue Method (IChatInteraction, String, , , AsyncCallback, Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginTransferQueue(
    IChatInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout
)
Visual Basic (Declaration)
Function BeginTransferQueue ( _
    interaction As IChatInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginTransferQueue(
    IChatInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32)"]

See Also

IChatService Interface
BeginTransferQueue Overload
Genesyslab.Enterprise.Services Namespace


BeginTransferQueue Method (IChatInteraction, String, , , AsyncCallback, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.BeginTransferQueue Method (IChatInteraction, String, , , AsyncCallback, Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginTransferQueue(
    IChatInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    AsyncCallback callBack,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function BeginTransferQueue ( _
    interaction As IChatInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    callBack As AsyncCallback, _
    timeout As Integer, _
    correlatorData As String _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginTransferQueue(
    IChatInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    AsyncCallback^ callBack,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

callBack
Type: System..::.AsyncCallback

[Missing <param name="callBack"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.BeginTransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.AsyncCallback,System.Int32,System.String)"]

See Also

IChatService Interface
BeginTransferQueue Overload
Genesyslab.Enterprise.Services Namespace


CompleteConference Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteConference Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
CompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection) | Turns the chat consultation into a conference.
CompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
CompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


CompleteConference Method (IChatInteraction, String, , )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteConference Method (IChatInteraction, String, , )
IChatService Interface See Also Send Feedback
Turns the chat consultation into a conference.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> CompleteConference(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function CompleteConference ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ CompleteConference(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
Chat interaction to conference
agent
Type: System..::.String
Target agent Id (PersonId)
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
Extensions

Return Value

IEnvelope<OpenMediaInteraction>

See Also

IChatService Interface
CompleteConference Overload
Genesyslab.Enterprise.Services Namespace


CompleteConference Method (IChatInteraction, String, , , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteConference Method (IChatInteraction, String, , , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> CompleteConference(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function CompleteConference ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ CompleteConference(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
CompleteConference Overload
Genesyslab.Enterprise.Services Namespace


CompleteConference Method (IChatInteraction, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteConference Method (IChatInteraction, String, , , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> CompleteConference(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function CompleteConference ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ CompleteConference(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteConference(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
CompleteConference Overload
Genesyslab.Enterprise.Services Namespace


CompleteTransfer Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteTransfer Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
CompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection) | Stops the chat consultation and transfers the interaction to the given agent.
CompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
CompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


CompleteTransfer Method (IChatInteraction, String, , )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteTransfer Method (IChatInteraction, String, , )
IChatService Interface See Also Send Feedback
Stops the chat consultation and transfers the interaction to the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> CompleteTransfer(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function CompleteTransfer ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ CompleteTransfer(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
Chat interaction to transfer.
agent
Type: System..::.String
Target agent Id (PersonId).
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
Extensions

Return Value

IEnvelope<OpenMediaInteraction>

See Also

IChatService Interface
CompleteTransfer Overload
Genesyslab.Enterprise.Services Namespace


CompleteTransfer Method (IChatInteraction, String, , , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteTransfer Method (IChatInteraction, String, , , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> CompleteTransfer(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function CompleteTransfer ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ CompleteTransfer(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
CompleteTransfer Overload
Genesyslab.Enterprise.Services Namespace


CompleteTransfer Method (IChatInteraction, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.CompleteTransfer Method (IChatInteraction, String, , , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> CompleteTransfer(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function CompleteTransfer ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ CompleteTransfer(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.CompleteTransfer(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
CompleteTransfer Overload
Genesyslab.Enterprise.Services Namespace


ConferenceAgent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferenceAgent Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
ConferenceAgent(IChatInteraction, String, Visibility, KeyValueCollection) |
ConferenceAgent(IChatInteraction, String, Visibility, KeyValueCollection, Int32) |
ConferenceAgent(IChatInteraction, String, Visibility, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


ConferenceAgent Method (IChatInteraction, String, Visibility, )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferenceAgent Method (IChatInteraction, String, Visibility, )
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> ConferenceAgent(
    IChatInteraction interaction,
    string agent,
    Visibility visibility,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function ConferenceAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ ConferenceAgent(
    IChatInteraction^ interaction,
    String^ agent,
    Visibility visibility,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IChatService Interface
ConferenceAgent Overload
Genesyslab.Enterprise.Services Namespace


ConferenceAgent Method (IChatInteraction, String, Visibility, , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferenceAgent Method (IChatInteraction, String, Visibility, , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> ConferenceAgent(
    IChatInteraction interaction,
    string agent,
    Visibility visibility,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function ConferenceAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ ConferenceAgent(
    IChatInteraction^ interaction,
    String^ agent,
    Visibility visibility,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
ConferenceAgent Overload
Genesyslab.Enterprise.Services Namespace


ConferenceAgent Method (IChatInteraction, String, Visibility, , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferenceAgent Method (IChatInteraction, String, Visibility, , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> ConferenceAgent(
    IChatInteraction interaction,
    string agent,
    Visibility visibility,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function ConferenceAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ ConferenceAgent(
    IChatInteraction^ interaction,
    String^ agent,
    Visibility visibility,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferenceAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
ConferenceAgent Overload
Genesyslab.Enterprise.Services Namespace


ConferencePlace Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferencePlace Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
ConferencePlace(IChatInteraction, String, Visibility, KeyValueCollection) | Sets up a conference with another place for this chat interaction.
ConferencePlace(IChatInteraction, String, Visibility, KeyValueCollection, Int32) |
ConferencePlace(IChatInteraction, String, Visibility, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


ConferencePlace Method (IChatInteraction, String, Visibility, )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferencePlace Method (IChatInteraction, String, Visibility, )
IChatService Interface See Also Send Feedback
Sets up a conference with another place for this chat interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> ConferencePlace(
    IChatInteraction interaction,
    string place,
    Visibility visibility,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function ConferencePlace ( _
    interaction As IChatInteraction, _
    place As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ ConferencePlace(
    IChatInteraction^ interaction,
    String^ place,
    Visibility visibility,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
place
Type: System..::.String
the place name.
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility
visibility.
extensions
Type: KeyValueCollection
the extensions.

Return Value

IEnvelope<IOpenMediaInteraction>

See Also

IChatService Interface
ConferencePlace Overload
Genesyslab.Enterprise.Services Namespace


ConferencePlace Method (IChatInteraction, String, Visibility, , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferencePlace Method (IChatInteraction, String, Visibility, , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> ConferencePlace(
    IChatInteraction interaction,
    string place,
    Visibility visibility,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function ConferencePlace ( _
    interaction As IChatInteraction, _
    place As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ ConferencePlace(
    IChatInteraction^ interaction,
    String^ place,
    Visibility visibility,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
ConferencePlace Overload
Genesyslab.Enterprise.Services Namespace


ConferencePlace Method (IChatInteraction, String, Visibility, , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ConferencePlace Method (IChatInteraction, String, Visibility, , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> ConferencePlace(
    IChatInteraction interaction,
    string place,
    Visibility visibility,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function ConferencePlace ( _
    interaction As IChatInteraction, _
    place As String, _
    visibility As Visibility, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ ConferencePlace(
    IChatInteraction^ interaction,
    String^ place,
    Visibility visibility,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility

[Missing <param name="visibility"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.ConferencePlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Model.ComponentModel.Visibility,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
ConferencePlace Overload
Genesyslab.Enterprise.Services Namespace


Decline Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.Decline Method
IChatService Interface See Also Send Feedback
Rejects the processing of the given chat interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> Decline(
    IChatInteraction interaction,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Decline ( _
    interaction As IChatInteraction, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ Decline(
    IChatInteraction^ interaction,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

IEnvelope<IOpenMediaInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


Disconnect Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.Disconnect Method
IChatService Interface See Also Send Feedback
Disconnects the media server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> Disconnect(
    IChatInteraction interaction
)
Visual Basic (Declaration)
Function Disconnect ( _
    interaction As IChatInteraction _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ Disconnect(
    IChatInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.

Return Value

IEnvelope<IOpenMediaInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndCompleteConference Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndCompleteConference Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndCompleteConference(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndCompleteConference(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCompleteConference ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndCompleteConference(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndCompleteConference(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndCompleteConference(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndCompleteTransfer Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndCompleteTransfer Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndCompleteTransfer(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndCompleteTransfer(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndCompleteTransfer ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndCompleteTransfer(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndCompleteTransfer(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndCompleteTransfer(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndConferenceAgent Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndConferenceAgent Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndConferenceAgent(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndConferenceAgent(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndConferenceAgent ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndConferenceAgent(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndConferenceAgent(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndConferenceAgent(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndConferencePlace Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndConferencePlace Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndConferencePlace(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndConferencePlace(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndConferencePlace ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndConferencePlace(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndConferencePlace(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndConferencePlace(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndInitConsultation Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndInitConsultation Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndInitConsultation(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndInitConsultation(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndInitConsultation ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndInitConsultation(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndInitConsultation(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndInitConsultation(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndTransferAgent Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndTransferAgent Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferAgent(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndTransferAgent(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndTransferAgent ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndTransferAgent(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferAgent(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferAgent(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndTransferPlace Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndTransferPlace Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferPlace(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndTransferPlace(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndTransferPlace ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndTransferPlace(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferPlace(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferPlace(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


EndTransferQueue Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.EndTransferQueue Method
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferQueue(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> EndTransferQueue(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndTransferQueue ( _
    aResult As IAsyncResult _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ EndTransferQueue(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferQueue(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.EndTransferQueue(System.IAsyncResult)"]

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.GetList Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


InitConsultation Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.InitConsultation Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
InitConsultation(IChatInteraction, String, KeyValueCollection, KeyValueCollection) | Initiates a consultation to another agent. You can end the consultation by transferring the chat interaction to the agent with CompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection), or you can turn it into a conference with CompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection).
InitConsultation(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


InitConsultation Method (IChatInteraction, String, , )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.InitConsultation Method (IChatInteraction, String, , )
IChatService Interface See Also Send Feedback
Initiates a consultation to another agent. You can end the consultation by transferring the chat interaction to the agent with CompleteTransfer(IChatInteraction, String, KeyValueCollection, KeyValueCollection), or you can turn it into a conference with CompleteConference(IChatInteraction, String, KeyValueCollection, KeyValueCollection).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> InitConsultation(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function InitConsultation ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ InitConsultation(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
Chat interaction to transfer.
agent
Type: System..::.String
Target agent Id (PersonId)
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
Extensions.

Return Value

IEnvelope<OpenMediaInteraction>

See Also

IChatService Interface
InitConsultation Overload
Genesyslab.Enterprise.Services Namespace


InitConsultation Method (IChatInteraction, String, , , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.InitConsultation Method (IChatInteraction, String, , , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> InitConsultation(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function InitConsultation ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ InitConsultation(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.InitConsultation(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
InitConsultation Overload
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.ListFilter<(Of <(T>)>) Method
IChatService Interface See Also Send Feedback
Lists the filters registered for the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IChatInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As IChatInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IChatInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.

Type Parameters

T
type of data handled in filter object

Return Value

Filters.

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


PlaceInQueue Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.PlaceInQueue Method
IChatService Interface See Also Send Feedback
Places the chat interaction in the given queue.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> PlaceInQueue(
    IChatInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function PlaceInQueue ( _
    interaction As IChatInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ PlaceInQueue(
    IChatInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
the interaction.
queue
Type: System..::.String
the queue name.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

IEnvelope<IOpenMediaInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


PushUrl Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.PushUrl Method
IChatService Interface See Also Send Feedback
Sends a push URL notification.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChatInteraction> PushUrl(
    IChatInteraction interaction,
    string url,
    Visibility visibility
)
Visual Basic (Declaration)
Function PushUrl ( _
    interaction As IChatInteraction, _
    url As String, _
    visibility As Visibility _
) As IEnvelope(Of IChatInteraction)
Visual C++
IEnvelope<IChatInteraction^>^ PushUrl(
    IChatInteraction^ interaction,
    String^ url,
    Visibility visibility
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
the chat interaction.
url
Type: System..::.String
the URL.
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility
visibility.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.RegisterEvents Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.RegisterFilter<(Of <(T>)>) Method
IChatService Interface See Also Send Feedback
Registers a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChatService RegisterFilter<T>(
    IChatInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As IChatInteraction, _
    filter As T _
) As IChatService
Visual C++
generic<typename T>
IChatService^ RegisterFilter(
    IChatInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,``0)"]

Type Parameters

T
filter type.

Return Value

IChatService

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.Save Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.SaveInteraction Method
IChatService Interface See Also Send Feedback
Saves the chat interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool SaveInteraction(
    IChatInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IChatInteraction _
) As Boolean
Visual C++
bool SaveInteraction(
    IChatInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.

Return Value

bool

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


SendMessage Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.SendMessage Method
IChatService Interface See Also Send Feedback
Sends a message.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChatInteraction> SendMessage(
    IChatInteraction interaction,
    Visibility visibility,
    string message,
    MessageContentType contentType
)
Visual Basic (Declaration)
Function SendMessage ( _
    interaction As IChatInteraction, _
    visibility As Visibility, _
    message As String, _
    contentType As MessageContentType _
) As IEnvelope(Of IChatInteraction)
Visual C++
IEnvelope<IChatInteraction^>^ SendMessage(
    IChatInteraction^ interaction,
    Visibility visibility,
    String^ message,
    MessageContentType contentType
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility
visibility.
message
Type: System..::.String
the message.
contentType
Type: Genesyslab.Enterprise.Services..::.MessageContentType
The MIME type of the message.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


TransferAgent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferAgent Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
TransferAgent(IChatInteraction, String, KeyValueCollection, KeyValueCollection) | Transfers the open media interaction to the given agent.
TransferAgent(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
TransferAgent(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


TransferAgent Method (IChatInteraction, String, , )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferAgent Method (IChatInteraction, String, , )
IChatService Interface See Also Send Feedback
Transfers the open media interaction to the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferAgent(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function TransferAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferAgent(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
agent
Type: System..::.String
the agent ID (PersonId).
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
TransferAgent Overload
Genesyslab.Enterprise.Services Namespace


TransferAgent Method (IChatInteraction, String, , , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferAgent Method (IChatInteraction, String, , , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferAgent(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function TransferAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferAgent(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
TransferAgent Overload
Genesyslab.Enterprise.Services Namespace


TransferAgent Method (IChatInteraction, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferAgent Method (IChatInteraction, String, , , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferAgent(
    IChatInteraction interaction,
    string agent,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function TransferAgent ( _
    interaction As IChatInteraction, _
    agent As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferAgent(
    IChatInteraction^ interaction,
    String^ agent,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

agent
Type: System..::.String

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferAgent(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
TransferAgent Overload
Genesyslab.Enterprise.Services Namespace


TransferPlace Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferPlace Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
TransferPlace(IChatInteraction, String, KeyValueCollection, KeyValueCollection) | Transfers the given open media interaction to a place.
TransferPlace(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
TransferPlace(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


TransferPlace Method (IChatInteraction, String, , )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferPlace Method (IChatInteraction, String, , )
IChatService Interface See Also Send Feedback
Transfers the given open media interaction to a place.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferPlace(
    IChatInteraction interaction,
    string place,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function TransferPlace ( _
    interaction As IChatInteraction, _
    place As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferPlace(
    IChatInteraction^ interaction,
    String^ place,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
place
Type: System..::.String
the place name.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

IEnvelope<IOpenMediaInteraction>

See Also

IChatService Interface
TransferPlace Overload
Genesyslab.Enterprise.Services Namespace


TransferPlace Method (IChatInteraction, String, , , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferPlace Method (IChatInteraction, String, , , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferPlace(
    IChatInteraction interaction,
    string place,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function TransferPlace ( _
    interaction As IChatInteraction, _
    place As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferPlace(
    IChatInteraction^ interaction,
    String^ place,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
TransferPlace Overload
Genesyslab.Enterprise.Services Namespace


TransferPlace Method (IChatInteraction, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferPlace Method (IChatInteraction, String, , , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferPlace(
    IChatInteraction interaction,
    string place,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function TransferPlace ( _
    interaction As IChatInteraction, _
    place As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferPlace(
    IChatInteraction^ interaction,
    String^ place,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

place
Type: System..::.String

[Missing <param name="place"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferPlace(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
TransferPlace Overload
Genesyslab.Enterprise.Services Namespace


TransferQueue Method

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferQueue Method
IChatService Interface See Also Send Feedback

Overload List

Name | Description
TransferQueue(IChatInteraction, String, KeyValueCollection, KeyValueCollection) | Transfers the given open media interaction to a queue.
TransferQueue(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32) |
TransferQueue(IChatInteraction, String, KeyValueCollection, KeyValueCollection, Int32, String) |

See Also

IChatService Interface
IChatService Members
Genesyslab.Enterprise.Services Namespace


TransferQueue Method (IChatInteraction, String, , )

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferQueue Method (IChatInteraction, String, , )
IChatService Interface See Also Send Feedback
Transfers the given open media interaction to a queue.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferQueue(
    IChatInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function TransferQueue ( _
    interaction As IChatInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferQueue(
    IChatInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
queue
Type: System..::.String
the queue name.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

IEnvelope<IOpenMediaInteraction>

See Also

IChatService Interface
TransferQueue Overload
Genesyslab.Enterprise.Services Namespace


TransferQueue Method (IChatInteraction, String, , , Int32)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferQueue Method (IChatInteraction, String, , , Int32)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferQueue(
    IChatInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout
)
Visual Basic (Declaration)
Function TransferQueue ( _
    interaction As IChatInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferQueue(
    IChatInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32)"]

See Also

IChatService Interface
TransferQueue Overload
Genesyslab.Enterprise.Services Namespace


TransferQueue Method (IChatInteraction, String, , , Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TransferQueue Method (IChatInteraction, String, , , Int32, String)
IChatService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IOpenMediaInteraction> TransferQueue(
    IChatInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function TransferQueue ( _
    interaction As IChatInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of IOpenMediaInteraction)
Visual C++
IEnvelope<IOpenMediaInteraction^>^ TransferQueue(
    IChatInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String

[Missing <param name="queue"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

reason
Type: KeyValueCollection

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

extensions
Type: KeyValueCollection

[Missing <param name="extensions"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

correlatorData
Type: System..::.String

[Missing <param name="correlatorData"/> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IChatService.TransferQueue(Genesyslab.Enterprise.Model.Interaction.IChatInteraction,System.String,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

See Also

IChatService Interface
TransferQueue Overload
Genesyslab.Enterprise.Services Namespace


TypingStarted Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TypingStarted Method
IChatService Interface See Also Send Feedback
Starts typing notification.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChatInteraction> TypingStarted(
    IChatInteraction interaction,
    Visibility visibility
)
Visual Basic (Declaration)
Function TypingStarted ( _
    interaction As IChatInteraction, _
    visibility As Visibility _
) As IEnvelope(Of IChatInteraction)
Visual C++
IEnvelope<IChatInteraction^>^ TypingStarted(
    IChatInteraction^ interaction,
    Visibility visibility
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
the chat interaction.
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility
visibility.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


TypingStopped Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.TypingStopped Method
IChatService Interface See Also Send Feedback
Stops typing notification.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChatInteraction> TypingStopped(
    IChatInteraction interaction,
    Visibility visibility
)
Visual Basic (Declaration)
Function TypingStopped ( _
    interaction As IChatInteraction, _
    visibility As Visibility _
) As IEnvelope(Of IChatInteraction)
Visual C++
IEnvelope<IChatInteraction^>^ TypingStopped(
    IChatInteraction^ interaction,
    Visibility visibility
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
the Chat interaction.
visibility
Type: Genesyslab.Enterprise.Model.ComponentModel..::.Visibility
visibility.

Return Value

IEnvelope<IChatInteraction>

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IChatService..::.UnRegisterFilter<(Of <(T>)>) Method
IChatService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChatService UnRegisterFilter<T>(
    IChatInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As IChatInteraction, _
    filter As T _
) As IChatService
Visual C++
generic<typename T>
IChatService^ UnRegisterFilter(
    IChatInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IChatInteraction
interaction.
filter
Type: T
filter.

Type Parameters

T
type of data for the filter instance.

Return Value

IChatService.

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


IChatService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IChatService Properties
IChatService Interface See Also Send Feedback

The IChatService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IChatService Interface
Genesyslab.Enterprise.Services Namespace


IContactService Interface

[image]

Enterprise SDK 8.0 Reference API
IContactService Interface
Members See Also Send Feedback
Manages information related to contacts such as interaction history, attachments, interaction content, and standard responses.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactService
Visual Basic (Declaration)
Public Interface IContactService
Visual C++
public interface class IContactService

See Also

IContactService Members
Genesyslab.Enterprise.Services Namespace


IContactService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService Members
IContactService Interface Methods Properties Events See Also Send Feedback

The IContactService type exposes the following members.

Methods

Name | Description
AddAgentStdRespFavorite | Adds a Standard Response to the Favorites of the given agent.
AddAttachment | Overloaded.
AddStdRespUsage | Add the standard response usage for the specified interaction.
BeginGetIndexProperties |
BeginRenderFieldCodes | Overloaded.
CheckStandardResponsesForUpdates | Returns true if the standard responses of the given tenant have been updated since the given date and time provided as a timestamp.
DeleteAgentStdRespFavorite | Removes a Standard Response from the Favorites of the given agent.
DeleteInteraction | Deletes the interaction from UCS.
EndGetIndexProperties |
EndRenderFieldCodes |
GetAgentStdRespFavorites | Gets the list of the Standard Response Favorites for the given agent.
GetAllCategories | Overloaded.
GetAttachment | Overloaded.
GetAttachments | Returns the attachments of the given interaction.
GetCategory | Overloaded.
GetContact | Returns the given contact with the given specific set of attributes.
GetContacts | Returns a specific range of contacts based on search and sort criterias.
GetCountInteractions | Gets the number of interactions that match the given query (criteria).
GetIndexProperties | Get the index properties for Universal Contact Server.
GetInteractionContent | Overloaded.
GetInteractionsForContact | Returns the interaction history associated with the given contact as a list of interactions. Interactions contain only attributes from the Interaction table. Additional attributes specific to media servers or open media interactions should be retrieved in separated requests.
GetRootCategories | Returns the root categories of the given tenant.
GetStandardResponse | Overloaded.
GetStandardResponses | Returns the standard responses of the given category.
InsertInteraction | Creates a new interaction in UCS.
RemoveAttachment | Removes the given document from the interaction's attachments. Note: The document is not removed from the DB.
RemoveDocument | Removes the document and all its links to the interactions' attachments.
RenderFieldCodes | Overloaded.
SearchSRLs | Searches for the standard responses which match the string-based queries provided in parameter. For details about creating these queries, refer to the Apache Lucene Query Parser Syntax documentation (http://lucene.apache.org/java/2_4_0/queryparsersyntax.html). Search results rely on the UCS indexing service, which can be configured to parse and index the content of UCS entries. UCS indexing should be event-based and scheduled during off-hours, to ensure that modified properties will be re-indexed. Note: This type of search is not performed in the UCS database. The search results cannot be used to update UCS documents. Once a desired UCS document is identified using this request, then a query must be sent to the DB to process further updates.
StopInteraction | Turns the interaction status into STOPPED in the ContactServer, and if requested, deletes the interaction.
UpdateInteraction | Updates the interaction's attributes and binary content.

Properties

Name | Description
Caches |

Events

Name | Description
OnSRLUpdate |

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


IContactService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService Methods
IContactService Interface See Also Send Feedback

The IContactService type exposes the following members.

Methods

Name | Description
AddAgentStdRespFavorite | Adds a Standard Response to the Favorites of the given agent.
AddAttachment | Overloaded.
AddStdRespUsage | Add the standard response usage for the specified interaction.
BeginGetIndexProperties |
BeginRenderFieldCodes | Overloaded.
CheckStandardResponsesForUpdates | Returns true if the standard responses of the given tenant have been updated since the given date and time provided as a timestamp.
DeleteAgentStdRespFavorite | Removes a Standard Response from the Favorites of the given agent.
DeleteInteraction | Deletes the interaction from UCS.
EndGetIndexProperties |
EndRenderFieldCodes |
GetAgentStdRespFavorites | Gets the list of the Standard Response Favorites for the given agent.
GetAllCategories | Overloaded.
GetAttachment | Overloaded.
GetAttachments | Returns the attachments of the given interaction.
GetCategory | Overloaded.
GetContact | Returns the given contact with the given specific set of attributes.
GetContacts | Returns a specific range of contacts based on search and sort criterias.
GetCountInteractions | Gets the number of interactions that match the given query (criteria).
GetIndexProperties | Get the index properties for Universal Contact Server.
GetInteractionContent | Overloaded.
GetInteractionsForContact | Returns the interaction history associated with the given contact as a list of interactions. Interactions contain only attributes from the Interaction table. Additional attributes specific to media servers or open media interactions should be retrieved in separated requests.
GetRootCategories | Returns the root categories of the given tenant.
GetStandardResponse | Overloaded.
GetStandardResponses | Returns the standard responses of the given category.
InsertInteraction | Creates a new interaction in UCS.
RemoveAttachment | Removes the given document from the interaction's attachments. Note: The document is not removed from the DB.
RemoveDocument | Removes the document and all its links to the interactions' attachments.
RenderFieldCodes | Overloaded.
SearchSRLs | Searches for the standard responses which match the string-based queries provided in parameter. For details about creating these queries, refer to the Apache Lucene Query Parser Syntax documentation (http://lucene.apache.org/java/2_4_0/queryparsersyntax.html). Search results rely on the UCS indexing service, which can be configured to parse and index the content of UCS entries. UCS indexing should be event-based and scheduled during off-hours, to ensure that modified properties will be re-indexed. Note: This type of search is not performed in the UCS database. The search results cannot be used to update UCS documents. Once a desired UCS document is identified using this request, then a query must be sent to the DB to process further updates.
StopInteraction | Turns the interaction status into STOPPED in the ContactServer, and if requested, deletes the interaction.
UpdateInteraction | Updates the interaction's attributes and binary content.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


AddAgentStdRespFavorite Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.AddAgentStdRespFavorite Method
IContactService Interface See Also Send Feedback
Adds a Standard Response to the Favorites of the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddAgentStdRespFavorite(
    IClientChannel channel,
    int agentId,
    string stdRspId
)
Visual Basic (Declaration)
Sub AddAgentStdRespFavorite ( _
    channel As IClientChannel, _
    agentId As Integer, _
    stdRspId As String _
)
Visual C++
void AddAgentStdRespFavorite(
    IClientChannel^ channel,
    int agentId,
    String^ stdRspId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
agentId
Type: System..::.Int32
Agent ID.
stdRspId
Type: System..::.String
Standard Response ID.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


AddAttachment Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.AddAttachment Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
AddAttachment(IClientChannel, String, String) | Adds the given existing document to the given interaction.
AddAttachment(IClientChannel, String, String, array<Byte>[]()[], String) | Adds a new attachment to the given interaction.

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


AddAttachment Method (IClientChannel, String, String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.AddAttachment Method (IClientChannel, String, String)
IContactService Interface See Also Send Feedback
Adds the given existing document to the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AddAttachment(
    IClientChannel channel,
    string interactionID,
    string documentID
)
Visual Basic (Declaration)
Function AddAttachment ( _
    channel As IClientChannel, _
    interactionID As String, _
    documentID As String _
) As String
Visual C++
String^ AddAttachment(
    IClientChannel^ channel,
    String^ interactionID,
    String^ documentID
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interactionID
Type: System..::.String
Interaction ID.
documentID
Type: System..::.String
Document ID.

Return Value

The document ID if the document exists; otherwise, null.

See Also

IContactService Interface
AddAttachment Overload
Genesyslab.Enterprise.Services Namespace


AddAttachment Method (IClientChannel, String, String, Byte[], String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.AddAttachment Method (IClientChannel, String, String, array<Byte>[]()[], String)
IContactService Interface See Also Send Feedback
Adds a new attachment to the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AddAttachment(
    IClientChannel channel,
    string interactionID,
    string filename,
    byte[] buffer,
    string mimeType
)
Visual Basic (Declaration)
Function AddAttachment ( _
    channel As IClientChannel, _
    interactionID As String, _
    filename As String, _
    buffer As Byte(), _
    mimeType As String _
) As String
Visual C++
String^ AddAttachment(
    IClientChannel^ channel,
    String^ interactionID,
    String^ filename,
    array<unsigned char>^ buffer,
    String^ mimeType
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interactionID
Type: System..::.String
Interaction ID.
filename
Type: System..::.String
Name of the file to attach.
buffer
Type: array< System..::.Byte >[]()[]
Buffer.
mimeType
Type: System..::.String
Mime Type.

Return Value

The ID of the created document.

See Also

IContactService Interface
AddAttachment Overload
Genesyslab.Enterprise.Services Namespace


AddStdRespUsage Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.AddStdRespUsage Method
IContactService Interface See Also Send Feedback
Add the standard response usage for the specified interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddStdRespUsage(
    IClientChannel clientChannel,
    int agentId,
    string stdRespId,
    string interactionId,
    ResponseType respType
)
Visual Basic (Declaration)
Sub AddStdRespUsage ( _
    clientChannel As IClientChannel, _
    agentId As Integer, _
    stdRespId As String, _
    interactionId As String, _
    respType As ResponseType _
)
Visual C++
void AddStdRespUsage(
    IClientChannel^ clientChannel,
    int agentId,
    String^ stdRespId,
    String^ interactionId,
    ResponseType respType
)

Parameters

clientChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
agentId
Type: System..::.Int32
Agent ID.
stdRespId
Type: System..::.String
Standard Response Id.
interactionId
Type: System..::.String
Interaction Id.
respType
Type: Genesyslab.Enterprise.Model.Contact..::.ResponseType
Response Type.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


BeginGetIndexProperties Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.BeginGetIndexProperties Method
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginGetIndexProperties(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.AsyncCallback)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginGetIndexProperties(
    IClientChannel channel,
    AsyncCallback callback
)
Visual Basic (Declaration)
Function BeginGetIndexProperties ( _
    channel As IClientChannel, _
    callback As AsyncCallback _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginGetIndexProperties(
    IClientChannel^ channel,
    AsyncCallback^ callback
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginGetIndexProperties(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.AsyncCallback)"]

callback
Type: System..::.AsyncCallback

[Missing <param name="callback"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginGetIndexProperties(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.AsyncCallback)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginGetIndexProperties(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.AsyncCallback)"]

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


BeginRenderFieldCodes Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.BeginRenderFieldCodes Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
BeginRenderFieldCodes(IClientChannel, String, IInteraction, IAgent) |
BeginRenderFieldCodes(IClientChannel, String, IInteraction, IAgent, KeyValueCollection) |

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


BeginRenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.BeginRenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginRenderFieldCodes(
    IClientChannel channel,
    string text,
    IInteraction interaction,
    IAgent agent
)
Visual Basic (Declaration)
Function BeginRenderFieldCodes ( _
    channel As IClientChannel, _
    text As String, _
    interaction As IInteraction, _
    agent As IAgent _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginRenderFieldCodes(
    IClientChannel^ channel,
    String^ text,
    IInteraction^ interaction,
    IAgent^ agent
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent)"]

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent)"]

See Also

IContactService Interface
BeginRenderFieldCodes Overload
Genesyslab.Enterprise.Services Namespace


BeginRenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent, )

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.BeginRenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent, )
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAsyncResult BeginRenderFieldCodes(
    IClientChannel channel,
    string text,
    IInteraction interaction,
    IAgent agent,
    KeyValueCollection customProperties
)
Visual Basic (Declaration)
Function BeginRenderFieldCodes ( _
    channel As IClientChannel, _
    text As String, _
    interaction As IInteraction, _
    agent As IAgent, _
    customProperties As KeyValueCollection _
) As IAsyncResult
Visual C++
IAsyncResult^ BeginRenderFieldCodes(
    IClientChannel^ channel,
    String^ text,
    IInteraction^ interaction,
    IAgent^ agent,
    KeyValueCollection^ customProperties
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent

[Missing <param name="agent"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

customProperties
Type: KeyValueCollection

[Missing <param name="customProperties"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.BeginRenderFieldCodes(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Agent.IAgent,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IContactService Interface
BeginRenderFieldCodes Overload
Genesyslab.Enterprise.Services Namespace


CheckStandardResponsesForUpdates Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.CheckStandardResponsesForUpdates Method
IContactService Interface See Also Send Feedback
Returns true if the standard responses of the given tenant have been updated since the given date and time provided as a timestamp.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool CheckStandardResponsesForUpdates(
    IClientChannel channel,
    int tenantId,
    string lang,
    DateTime lastUpdate
)
Visual Basic (Declaration)
Function CheckStandardResponsesForUpdates ( _
    channel As IClientChannel, _
    tenantId As Integer, _
    lang As String, _
    lastUpdate As DateTime _
) As Boolean
Visual C++
bool CheckStandardResponsesForUpdates(
    IClientChannel^ channel,
    int tenantId,
    String^ lang,
    DateTime lastUpdate
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
tenantId
Type: System..::.Int32
Tenant ID.
lang
Type: System..::.String
Standard Responses language.
lastUpdate
Type: System..::.DateTime
Timestamp.

Return Value

true if the standard responses have been updated.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


DeleteAgentStdRespFavorite Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.DeleteAgentStdRespFavorite Method
IContactService Interface See Also Send Feedback
Removes a Standard Response from the Favorites of the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void DeleteAgentStdRespFavorite(
    IClientChannel channel,
    int agentId,
    string stdRspId
)
Visual Basic (Declaration)
Sub DeleteAgentStdRespFavorite ( _
    channel As IClientChannel, _
    agentId As Integer, _
    stdRspId As String _
)
Visual C++
void DeleteAgentStdRespFavorite(
    IClientChannel^ channel,
    int agentId,
    String^ stdRspId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
agentId
Type: System..::.Int32
Agent ID.
stdRspId
Type: System..::.String
Standard Response ID.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.DeleteInteraction Method
IContactService Interface See Also Send Feedback
Deletes the interaction from UCS.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void DeleteInteraction(
    IClientChannel channel,
    string interactionId
)
Visual Basic (Declaration)
Sub DeleteInteraction ( _
    channel As IClientChannel, _
    interactionId As String _
)
Visual C++
void DeleteInteraction(
    IClientChannel^ channel,
    String^ interactionId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interactionId
Type: System..::.String
Interaction ID.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


EndGetIndexProperties Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.EndGetIndexProperties Method
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.EndGetIndexProperties(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIndexData[] EndGetIndexProperties(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndGetIndexProperties ( _
    aResult As IAsyncResult _
) As IIndexData()
Visual C++
array<IIndexData^>^ EndGetIndexProperties(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.EndGetIndexProperties(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.EndGetIndexProperties(System.IAsyncResult)"]

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


EndRenderFieldCodes Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.EndRenderFieldCodes Method
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.EndRenderFieldCodes(System.IAsyncResult)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string EndRenderFieldCodes(
    IAsyncResult aResult
)
Visual Basic (Declaration)
Function EndRenderFieldCodes ( _
    aResult As IAsyncResult _
) As String
Visual C++
String^ EndRenderFieldCodes(
    IAsyncResult^ aResult
)

Parameters

aResult
Type: System..::.IAsyncResult

[Missing <param name="aResult"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.EndRenderFieldCodes(System.IAsyncResult)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.EndRenderFieldCodes(System.IAsyncResult)"]

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetAgentStdRespFavorites Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAgentStdRespFavorites Method
IContactService Interface See Also Send Feedback
Gets the list of the Standard Response Favorites for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse[] GetAgentStdRespFavorites(
    IClientChannel channel,
    int agentId
)
Visual Basic (Declaration)
Function GetAgentStdRespFavorites ( _
    channel As IClientChannel, _
    agentId As Integer _
) As IStandardResponse()
Visual C++
array<IStandardResponse^>^ GetAgentStdRespFavorites(
    IClientChannel^ channel,
    int agentId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
agentId
Type: System..::.Int32
Agent Id.

Return Value

Array of favorites standard responses.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetAllCategories Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAllCategories Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
GetAllCategories(IClientChannel, Int32, String) | Returns the list of the root categories for the given tenant.
GetAllCategories(IClientChannel, Int32, String, Boolean, Boolean) | Returns the list of the root categories for the given tenant.

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


GetAllCategories Method (IClientChannel, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAllCategories Method (IClientChannel, Int32, String)
IContactService Interface See Also Send Feedback
Returns the list of the root categories for the given tenant.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory[] GetAllCategories(
    IClientChannel channel,
    int tenantId,
    string lang
)
Visual Basic (Declaration)
Function GetAllCategories ( _
    channel As IClientChannel, _
    tenantId As Integer, _
    lang As String _
) As ICategory()
Visual C++
array<ICategory^>^ GetAllCategories(
    IClientChannel^ channel,
    int tenantId,
    String^ lang
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
tenantId
Type: System..::.Int32
Tenant Id.
lang
Type: System..::.String
Language.

Return Value

Array of root categories.

Remarks

This method loads all SRL Tree, it can affects application performances when loading large DataBase.

See Also

IContactService Interface
GetAllCategories Overload
Genesyslab.Enterprise.Services Namespace


GetAllCategories Method (IClientChannel, Int32, String, Boolean, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAllCategories Method (IClientChannel, Int32, String, Boolean, Boolean)
IContactService Interface See Also Send Feedback
Returns the list of the root categories for the given tenant.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory[] GetAllCategories(
    IClientChannel channel,
    int tenantId,
    string lang,
    bool associatedSRLs,
    bool fillSRLs
)
Visual Basic (Declaration)
Function GetAllCategories ( _
    channel As IClientChannel, _
    tenantId As Integer, _
    lang As String, _
    associatedSRLs As Boolean, _
    fillSRLs As Boolean _
) As ICategory()
Visual C++
array<ICategory^>^ GetAllCategories(
    IClientChannel^ channel,
    int tenantId,
    String^ lang,
    bool associatedSRLs,
    bool fillSRLs
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
tenantId
Type: System..::.Int32
Tenant Id.
lang
Type: System..::.String
Language.
associatedSRLs
Type: System..::.Boolean
true to return the list of standard responses for the child categories.
fillSRLs
Type: System..::.Boolean
true to include content of standard responses for the child categories.

Return Value

Array of root categories.

Remarks

This method loads all SRL Tree, it can affects application performances when loading large DataBase.

See Also

IContactService Interface
GetAllCategories Overload
Genesyslab.Enterprise.Services Namespace


GetAttachment Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAttachment Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
GetAttachment(IClientChannel, String) |
GetAttachment(IClientChannel, String, Int32) |

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


GetAttachment Method (IClientChannel, String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAttachment Method (IClientChannel, String)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttachment GetAttachment(
    IClientChannel channel,
    string attachmentId
)
Visual Basic (Declaration)
Function GetAttachment ( _
    channel As IClientChannel, _
    attachmentId As String _
) As IAttachment
Visual C++
IAttachment^ GetAttachment(
    IClientChannel^ channel,
    String^ attachmentId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

attachmentId
Type: System..::.String

[Missing <param name="attachmentId"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String)"]

See Also

IContactService Interface
GetAttachment Overload
Genesyslab.Enterprise.Services Namespace


GetAttachment Method (IClientChannel, String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAttachment Method (IClientChannel, String, Int32)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IAttachment GetAttachment(
    IClientChannel channel,
    string attachmentId,
    int timeout
)
Visual Basic (Declaration)
Function GetAttachment ( _
    channel As IClientChannel, _
    attachmentId As String, _
    timeout As Integer _
) As IAttachment
Visual C++
IAttachment^ GetAttachment(
    IClientChannel^ channel,
    String^ attachmentId,
    int timeout
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

attachmentId
Type: System..::.String

[Missing <param name="attachmentId"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

timeout
Type: System..::.Int32

[Missing <param name="timeout"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetAttachment(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

See Also

IContactService Interface
GetAttachment Overload
Genesyslab.Enterprise.Services Namespace


GetAttachments Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetAttachments Method
IContactService Interface See Also Send Feedback
Returns the attachments of the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IAttachment> GetAttachments(
    IClientChannel channel,
    string interactionID,
    bool includeContent
)
Visual Basic (Declaration)
Function GetAttachments ( _
    channel As IClientChannel, _
    interactionID As String, _
    includeContent As Boolean _
) As ICollection(Of IAttachment)
Visual C++
ICollection<IAttachment^>^ GetAttachments(
    IClientChannel^ channel,
    String^ interactionID,
    bool includeContent
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interactionID
Type: System..::.String
Interaction ID.
includeContent
Type: System..::.Boolean
include binary content of the attachments.

Return Value

Attachments.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetCategory Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetCategory Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
GetCategory(IClientChannel, String) | Returns the Category associated with the given category ID.
GetCategory(IClientChannel, String, Int32, Boolean) | /// Returns the Category associated with the given category ID.
GetCategory(IClientChannel, String, Int32, Boolean, Boolean) | Returns the Category associated with the given category ID.

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


GetCategory Method (IClientChannel, String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetCategory Method (IClientChannel, String)
IContactService Interface See Also Send Feedback
Returns the Category associated with the given category ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory GetCategory(
    IClientChannel channel,
    string categoryId
)
Visual Basic (Declaration)
Function GetCategory ( _
    channel As IClientChannel, _
    categoryId As String _
) As ICategory
Visual C++
ICategory^ GetCategory(
    IClientChannel^ channel,
    String^ categoryId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
categoryId
Type: System..::.String
Category Id.

Return Value

The category which matches the given ID.

See Also

IContactService Interface
GetCategory Overload
Genesyslab.Enterprise.Services Namespace


GetCategory Method (IClientChannel, String, Int32, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetCategory Method (IClientChannel, String, Int32, Boolean)
IContactService Interface See Also Send Feedback
/// Returns the Category associated with the given category ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory GetCategory(
    IClientChannel channel,
    string categoryId,
    int tenantId,
    bool associatedSRLs
)
Visual Basic (Declaration)
Function GetCategory ( _
    channel As IClientChannel, _
    categoryId As String, _
    tenantId As Integer, _
    associatedSRLs As Boolean _
) As ICategory
Visual C++
ICategory^ GetCategory(
    IClientChannel^ channel,
    String^ categoryId,
    int tenantId,
    bool associatedSRLs
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
categoryId
Type: System..::.String
Category ID.
tenantId
Type: System..::.Int32
Tenant ID of the category.
associatedSRLs
Type: System..::.Boolean
true to return the list of standard responses for the child categories.

Return Value

The category which matches the given ID.

See Also

IContactService Interface
GetCategory Overload
Genesyslab.Enterprise.Services Namespace


GetCategory Method (IClientChannel, String, Int32, Boolean, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetCategory Method (IClientChannel, String, Int32, Boolean, Boolean)
IContactService Interface See Also Send Feedback
Returns the Category associated with the given category ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory GetCategory(
    IClientChannel channel,
    string categoryId,
    int tenantId,
    bool associatedSRLs,
    bool fillSRLs
)
Visual Basic (Declaration)
Function GetCategory ( _
    channel As IClientChannel, _
    categoryId As String, _
    tenantId As Integer, _
    associatedSRLs As Boolean, _
    fillSRLs As Boolean _
) As ICategory
Visual C++
ICategory^ GetCategory(
    IClientChannel^ channel,
    String^ categoryId,
    int tenantId,
    bool associatedSRLs,
    bool fillSRLs
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
categoryId
Type: System..::.String
Category ID.
tenantId
Type: System..::.Int32
Tenant ID of the category.
associatedSRLs
Type: System..::.Boolean
true to return the list of standard responses for the child categories.
fillSRLs
Type: System..::.Boolean
true to include content of standard responses for the child categories.

Return Value

The category which matches the given ID.

See Also

IContactService Interface
GetCategory Overload
Genesyslab.Enterprise.Services Namespace


GetContact Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetContact Method
IContactService Interface See Also Send Feedback
Returns the given contact with the given specific set of attributes.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContact GetContact(
    IClientChannel channel,
    string contactId,
    AttributeList attributes
)
Visual Basic (Declaration)
Function GetContact ( _
    channel As IClientChannel, _
    contactId As String, _
    attributes As AttributeList _
) As IContact
Visual C++
IContact^ GetContact(
    IClientChannel^ channel,
    String^ contactId,
    AttributeList^ attributes
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
contactId
Type: System..::.String
Contact to return.
attributes
Type: AttributeList
Attributes to return witrhin the contact.

Return Value

The contact and the requested attributes.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetContacts Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetContacts Method
IContactService Interface Example See Also Send Feedback
Returns a specific range of contacts based on search and sort criterias.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContact[] GetContacts(
    IClientChannel channel,
    IReadQuery query,
    int tenantId
)
Visual Basic (Declaration)
Function GetContacts ( _
    channel As IClientChannel, _
    query As IReadQuery, _
    tenantId As Integer _
) As IContact()
Visual C++
array<IContact^>^ GetContacts(
    IClientChannel^ channel,
    IReadQuery^ query,
    int tenantId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IReadQuery
Query.
tenantId
Type: System..::.Int32
Tenant.

Return Value

Matching contacts.

Examples

Following code shows how to retrieve a contact based on is ContactId attribute.
CopyC#
IReadQuery query = new ReadQuery<Contact>();
            query.Filter = Expression.Equal(Expression.Member("ContactId"), Expression.Constant(Id));
 Expression Member possible string values are:
  • AccountNumber
  • ContactId
  • CustomerSegment
  • EmailAddress
  • FirstName
  • LastName
  • PhoneNumber
  • PIN
  • Title

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetCountInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetCountInteractions Method
IContactService Interface See Also Send Feedback
Gets the number of interactions that match the given query (criteria).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int GetCountInteractions(
    IClientChannel channel,
    int tenantId,
    IQuery query
)
Visual Basic (Declaration)
Function GetCountInteractions ( _
    channel As IClientChannel, _
    tenantId As Integer, _
    query As IQuery _
) As Integer
Visual C++
int GetCountInteractions(
    IClientChannel^ channel,
    int tenantId,
    IQuery^ query
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
tenantId
Type: System..::.Int32
Tenant ID.
query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IQuery
Search criteria, see also GetContacts.

Return Value

number of interactions.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetIndexProperties Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetIndexProperties Method
IContactService Interface See Also Send Feedback
Get the index properties for Universal Contact Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIndexData[] GetIndexProperties(
    IClientChannel channel
)
Visual Basic (Declaration)
Function GetIndexProperties ( _
    channel As IClientChannel _
) As IIndexData()
Visual C++
array<IIndexData^>^ GetIndexProperties(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Contact Server Channel

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetIndexProperties(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetInteractionContent Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetInteractionContent Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractionContent(IClientChannel, String) | Returns the binary content of the given interaction.
GetInteractionContent(IClientChannel, String, DataSourceType) |

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


GetInteractionContent Method (IClientChannel, String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetInteractionContent Method (IClientChannel, String)
IContactService Interface See Also Send Feedback
Returns the binary content of the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction GetInteractionContent(
    IClientChannel channel,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractionContent ( _
    channel As IClientChannel, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteractionContent(
    IClientChannel^ channel,
    String^ interactionId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interactionId
Type: System..::.String
Interaction ID.

Return Value

Interaction contents.

See Also

IContactService Interface
GetInteractionContent Overload
Genesyslab.Enterprise.Services Namespace


GetInteractionContent Method (IClientChannel, String, DataSourceType)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetInteractionContent Method (IClientChannel, String, DataSourceType)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetInteractionContent(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Services.DataSourceType)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction GetInteractionContent(
    IClientChannel channel,
    string interactionId,
    DataSourceType dataSourceType
)
Visual Basic (Declaration)
Function GetInteractionContent ( _
    channel As IClientChannel, _
    interactionId As String, _
    dataSourceType As DataSourceType _
) As IInteraction
Visual C++
IInteraction^ GetInteractionContent(
    IClientChannel^ channel,
    String^ interactionId,
    DataSourceType dataSourceType
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetInteractionContent(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Services.DataSourceType)"]

interactionId
Type: System..::.String

[Missing <param name="interactionId"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetInteractionContent(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Services.DataSourceType)"]

dataSourceType
Type: Genesyslab.Enterprise.Services..::.DataSourceType

[Missing <param name="dataSourceType"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetInteractionContent(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Services.DataSourceType)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetInteractionContent(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,Genesyslab.Enterprise.Services.DataSourceType)"]

See Also

IContactService Interface
GetInteractionContent Overload
Genesyslab.Enterprise.Services Namespace


GetInteractionsForContact Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetInteractionsForContact Method
IContactService Interface See Also Send Feedback
Returns the interaction history associated with the given contact as a list of interactions. Interactions contain only attributes from the Interaction table. Additional attributes specific to media servers or open media interactions should be retrieved in separated requests.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractionsForContact(
    IClientChannel channel,
    string contactId
)
Visual Basic (Declaration)
Function GetInteractionsForContact ( _
    channel As IClientChannel, _
    contactId As String _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractionsForContact(
    IClientChannel^ channel,
    String^ contactId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
contactId
Type: System..::.String
Contact ID.

Return Value

Array of interactions.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetRootCategories Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetRootCategories Method
IContactService Interface See Also Send Feedback
Returns the root categories of the given tenant.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICategory[] GetRootCategories(
    IClientChannel channel,
    int tenantId
)
Visual Basic (Declaration)
Function GetRootCategories ( _
    channel As IClientChannel, _
    tenantId As Integer _
) As ICategory()
Visual C++
array<ICategory^>^ GetRootCategories(
    IClientChannel^ channel,
    int tenantId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
tenantId
Type: System..::.Int32
Tenant ID.

Return Value

The root categories of the tenant.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


GetStandardResponse Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetStandardResponse Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
GetStandardResponse(IClientChannel, String) | Returns the requested standard response information.
GetStandardResponse(IClientChannel, String, Boolean) |
GetStandardResponse(IClientChannel, String, Int32) |
GetStandardResponse(IClientChannel, String, Int32, Boolean) |

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


GetStandardResponse Method (IClientChannel, String)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetStandardResponse Method (IClientChannel, String)
IContactService Interface See Also Send Feedback
Returns the requested standard response information.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse GetStandardResponse(
    IClientChannel channel,
    string stdRspDbid
)
Visual Basic (Declaration)
Function GetStandardResponse ( _
    channel As IClientChannel, _
    stdRspDbid As String _
) As IStandardResponse
Visual C++
IStandardResponse^ GetStandardResponse(
    IClientChannel^ channel,
    String^ stdRspDbid
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
stdRspDbid
Type: System..::.String
SRL ID.

Return Value

The standard response matching the SRL ID.

See Also

IContactService Interface
GetStandardResponse Overload
Genesyslab.Enterprise.Services Namespace


GetStandardResponse Method (IClientChannel, String, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetStandardResponse Method (IClientChannel, String, Boolean)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Boolean)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse GetStandardResponse(
    IClientChannel channel,
    string stdRspDbid,
    bool fillAttachments
)
Visual Basic (Declaration)
Function GetStandardResponse ( _
    channel As IClientChannel, _
    stdRspDbid As String, _
    fillAttachments As Boolean _
) As IStandardResponse
Visual C++
IStandardResponse^ GetStandardResponse(
    IClientChannel^ channel,
    String^ stdRspDbid,
    bool fillAttachments
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Boolean)"]

stdRspDbid
Type: System..::.String

[Missing <param name="stdRspDbid"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Boolean)"]

fillAttachments
Type: System..::.Boolean

[Missing <param name="fillAttachments"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Boolean)"]

See Also

IContactService Interface
GetStandardResponse Overload
Genesyslab.Enterprise.Services Namespace


GetStandardResponse Method (IClientChannel, String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetStandardResponse Method (IClientChannel, String, Int32)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse GetStandardResponse(
    IClientChannel channel,
    string stdRspDbid,
    int tenantId
)
Visual Basic (Declaration)
Function GetStandardResponse ( _
    channel As IClientChannel, _
    stdRspDbid As String, _
    tenantId As Integer _
) As IStandardResponse
Visual C++
IStandardResponse^ GetStandardResponse(
    IClientChannel^ channel,
    String^ stdRspDbid,
    int tenantId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

stdRspDbid
Type: System..::.String

[Missing <param name="stdRspDbid"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

tenantId
Type: System..::.Int32

[Missing <param name="tenantId"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32)"]

See Also

IContactService Interface
GetStandardResponse Overload
Genesyslab.Enterprise.Services Namespace


GetStandardResponse Method (IClientChannel, String, Int32, Boolean)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetStandardResponse Method (IClientChannel, String, Int32, Boolean)
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32,System.Boolean)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse GetStandardResponse(
    IClientChannel channel,
    string stdRspDbid,
    int tenantId,
    bool fillAttachments
)
Visual Basic (Declaration)
Function GetStandardResponse ( _
    channel As IClientChannel, _
    stdRspDbid As String, _
    tenantId As Integer, _
    fillAttachments As Boolean _
) As IStandardResponse
Visual C++
IStandardResponse^ GetStandardResponse(
    IClientChannel^ channel,
    String^ stdRspDbid,
    int tenantId,
    bool fillAttachments
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32,System.Boolean)"]

stdRspDbid
Type: System..::.String

[Missing <param name="stdRspDbid"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32,System.Boolean)"]

tenantId
Type: System..::.Int32

[Missing <param name="tenantId"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32,System.Boolean)"]

fillAttachments
Type: System..::.Boolean

[Missing <param name="fillAttachments"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32,System.Boolean)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.GetStandardResponse(Genesyslab.Enterprise.Model.Channel.IClientChannel,System.String,System.Int32,System.Boolean)"]

See Also

IContactService Interface
GetStandardResponse Overload
Genesyslab.Enterprise.Services Namespace


GetStandardResponses Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.GetStandardResponses Method
IContactService Interface See Also Send Feedback
Returns the standard responses of the given category.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse[] GetStandardResponses(
    IClientChannel channel,
    string categoryId
)
Visual Basic (Declaration)
Function GetStandardResponses ( _
    channel As IClientChannel, _
    categoryId As String _
) As IStandardResponse()
Visual C++
array<IStandardResponse^>^ GetStandardResponses(
    IClientChannel^ channel,
    String^ categoryId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
categoryId
Type: System..::.String
Category ID.

Return Value

Array of the standard responses which belong to the given category.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


InsertInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.InsertInteraction Method
IContactService Interface See Also Send Feedback
Creates a new interaction in UCS.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string InsertInteraction(
    IClientChannel channel,
    IInteraction interaction,
    int tenantId
)
Visual Basic (Declaration)
Function InsertInteraction ( _
    channel As IClientChannel, _
    interaction As IInteraction, _
    tenantId As Integer _
) As String
Visual C++
String^ InsertInteraction(
    IClientChannel^ channel,
    IInteraction^ interaction,
    int tenantId
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to create in the UCS.
tenantId
Type: System..::.Int32
Tenant ID.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IContactService.InsertInteraction(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.Int32)"]

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


RemoveAttachment Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.RemoveAttachment Method
IContactService Interface See Also Send Feedback
Removes the given document from the interaction's attachments. Note: The document is not removed from the DB.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveAttachment(
    IClientChannel channel,
    string interactionID,
    string documentID
)
Visual Basic (Declaration)
Sub RemoveAttachment ( _
    channel As IClientChannel, _
    interactionID As String, _
    documentID As String _
)
Visual C++
void RemoveAttachment(
    IClientChannel^ channel,
    String^ interactionID,
    String^ documentID
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interactionID
Type: System..::.String
Interaction ID.
documentID
Type: System..::.String
Document to remove from the attachments.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


RemoveDocument Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.RemoveDocument Method
IContactService Interface See Also Send Feedback
Removes the document and all its links to the interactions' attachments.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveDocument(
    IClientChannel channel,
    string documentID
)
Visual Basic (Declaration)
Sub RemoveDocument ( _
    channel As IClientChannel, _
    documentID As String _
)
Visual C++
void RemoveDocument(
    IClientChannel^ channel,
    String^ documentID
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
documentID
Type: System..::.String
Document ID.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


RenderFieldCodes Method

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService..::.RenderFieldCodes Method
IContactService Interface See Also Send Feedback

Overload List

Name | Description
RenderFieldCodes(IClientChannel, String, IInteraction, IAgent) | Replaces the field codes of the given template text with the data information of the given interaction and agent.
RenderFieldCodes(IClientChannel, String, IInteraction, IAgent, KeyValueCollection) | Replaces the field codes of the given template text with the data information of the given interaction, agent, and custom properties.

See Also

IContactService Interface
IContactService Members
Genesyslab.Enterprise.Services Namespace


RenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent)

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.RenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent)
IContactService Interface See Also Send Feedback
Replaces the field codes of the given template text with the data information of the given interaction and agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string RenderFieldCodes(
    IClientChannel channel,
    string text,
    IInteraction interaction,
    IAgent agent
)
Visual Basic (Declaration)
Function RenderFieldCodes ( _
    channel As IClientChannel, _
    text As String, _
    interaction As IInteraction, _
    agent As IAgent _
) As String
Visual C++
String^ RenderFieldCodes(
    IClientChannel^ channel,
    String^ text,
    IInteraction^ interaction,
    IAgent^ agent
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
text
Type: System..::.String
The template text to render.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction used to replace the interaction field codes in the template text.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent used to replace the agent field codes in the template text.

Return Value

The rendered text.

See Also

IContactService Interface
RenderFieldCodes Overload
Genesyslab.Enterprise.Services Namespace


RenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent, )

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.RenderFieldCodes Method (IClientChannel, String, IInteraction, IAgent, )
IContactService Interface See Also Send Feedback
Replaces the field codes of the given template text with the data information of the given interaction, agent, and custom properties.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string RenderFieldCodes(
    IClientChannel channel,
    string text,
    IInteraction interaction,
    IAgent agent,
    KeyValueCollection customProperties
)
Visual Basic (Declaration)
Function RenderFieldCodes ( _
    channel As IClientChannel, _
    text As String, _
    interaction As IInteraction, _
    agent As IAgent, _
    customProperties As KeyValueCollection _
) As String
Visual C++
String^ RenderFieldCodes(
    IClientChannel^ channel,
    String^ text,
    IInteraction^ interaction,
    IAgent^ agent,
    KeyValueCollection^ customProperties
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
text
Type: System..::.String
The template text to render.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction used to replace the interaction field codes in the template text.
agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent used to replace the agent field codes in the template text.
customProperties
Type: KeyValueCollection
Custom properties used to replace the field codes in the template text.

Return Value

The rendered text.

See Also

IContactService Interface
RenderFieldCodes Overload
Genesyslab.Enterprise.Services Namespace


SearchSRLs Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.SearchSRLs Method
IContactService Interface See Also Send Feedback
Searches for the standard responses which match the string-based queries provided in parameter. For details about creating these queries, refer to the Apache Lucene Query Parser Syntax documentation (http://lucene.apache.org/java/2_4_0/queryparsersyntax.html).
Search results rely on the UCS indexing service, which can be configured to parse and index the content of UCS entries.
UCS indexing should be event-based and scheduled during off-hours, to ensure that modified properties will be re-indexed. Note: This type of search is not performed in the UCS database. The search results cannot be used to update UCS documents. Once a desired UCS document is identified using this request, then a query must be sent to the DB to process further updates.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IStandardResponse[] SearchSRLs(
    IClientChannel channel,
    string query,
    int maxResults
)
Visual Basic (Declaration)
Function SearchSRLs ( _
    channel As IClientChannel, _
    query As String, _
    maxResults As Integer _
) As IStandardResponse()
Visual C++
array<IStandardResponse^>^ SearchSRLs(
    IClientChannel^ channel,
    String^ query,
    int maxResults
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
query
Type: System..::.String
The search query which fulfills Apache Lucene Query Parser Syntax, see http://lucene.apache.org/java/2_4_0/queryparsersyntax.html.
maxResults
Type: System..::.Int32
Maximum number of returned result.

Return Value

The matching SRLs.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


StopInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.StopInteraction Method
IContactService Interface See Also Send Feedback
Turns the interaction status into STOPPED in the ContactServer, and if requested, deletes the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void StopInteraction(
    IClientChannel channel,
    IInteraction interaction,
    string reason,
    bool delete
)
Visual Basic (Declaration)
Sub StopInteraction ( _
    channel As IClientChannel, _
    interaction As IInteraction, _
    reason As String, _
    delete As Boolean _
)
Visual C++
void StopInteraction(
    IClientChannel^ channel,
    IInteraction^ interaction,
    String^ reason,
    bool delete
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to add to UCS.
reason
Type: System..::.String

[Missing <param name="reason"/> documentation for "M:Genesyslab.Enterprise.Services.IContactService.StopInteraction(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Interaction.IInteraction,System.String,System.Boolean)"]

delete
Type: System..::.Boolean
True to delete the interaction once stopped.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


UpdateInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.UpdateInteraction Method
IContactService Interface See Also Send Feedback
Updates the interaction's attributes and binary content.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void UpdateInteraction(
    IClientChannel channel,
    IInteraction interaction
)
Visual Basic (Declaration)
Sub UpdateInteraction ( _
    channel As IClientChannel, _
    interaction As IInteraction _
)
Visual C++
void UpdateInteraction(
    IClientChannel^ channel,
    IInteraction^ interaction
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
ContactServer Channel.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to update in the UCS.

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


IContactService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService Properties
IContactService Interface See Also Send Feedback

The IContactService type exposes the following members.

Properties

Name | Description
Caches |

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


Caches Property

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.Caches Property
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.IContactService.Caches"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<int, IContactCache> Caches { get; }
Visual Basic (Declaration)
ReadOnly Property Caches As IDictionary(Of Integer, IContactCache)
Visual C++
property IDictionary<int, IContactCache^>^ Caches {
    IDictionary<int, IContactCache^>^ get ();
}

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


IContactService Events

[image] [image]

Enterprise SDK 8.0 Reference API
IContactService Events
IContactService Interface See Also Send Feedback

The IContactService type exposes the following members.

Events

Name | Description
OnSRLUpdate |

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


OnSRLUpdate Event

[image]

Enterprise SDK 8.0 Reference API
IContactService..::.OnSRLUpdate Event
IContactService Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Services.IContactService.OnSRLUpdate"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event SRLUpdateHandler OnSRLUpdate
Visual Basic (Declaration)
Event OnSRLUpdate As SRLUpdateHandler
Visual C++
 event SRLUpdateHandler^ OnSRLUpdate {
    void add (SRLUpdateHandler^ value);
    void remove (SRLUpdateHandler^ value);
}

See Also

IContactService Interface
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Interface
Members See Also Send Feedback
Manages device data.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDeviceDomain : IStrategyManager<IDevice>
Visual Basic (Declaration)
Public Interface IDeviceDomain _
    Implements IStrategyManager(Of IDevice)
Visual C++
public interface class IDeviceDomain : IStrategyManager<IDevice^>

See Also

IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Members
IDeviceDomain Interface Methods See Also Send Feedback

The IDeviceDomain type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group.
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel.
GetDevices | Returns the all devices associated with the given DN name / tenant.
ListDevices | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the given device from the given group.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


IDeviceDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain Methods
IDeviceDomain Interface See Also Send Feedback

The IDeviceDomain type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group.
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel.
GetDevices | Returns the all devices associated with the given DN name / tenant.
ListDevices | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the given device from the given group.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


AddDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.AddDevice Method
IDeviceDomain Interface See Also Send Feedback
Adds the given device to the given group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain AddDevice(
    IDevice device,
    IDevice group,
    bool allowEvents
)
Visual Basic (Declaration)
Function AddDevice ( _
    device As IDevice, _
    group As IDevice, _
    allowEvents As Boolean _
) As IDeviceDomain
Visual C++
IDeviceDomain^ AddDevice(
    IDevice^ device,
    IDevice^ group,
    bool allowEvents
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to add to the group
group
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Group of devices
allowEvents
Type: System..::.Boolean
true to enable event reporting for the given device.

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateDevice(String, DeviceType) | Obsolete. Creates a device with a specific name and type (see CME).
CreateDevice(String, IClientChannel, array<IDevice>[]()[]) | Obsolete.
CreateDevice(String, DeviceType, Object) | Obsolete. Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, SwitchConfig, array<IDevice>[]()[]) | Obsolete. Creates a virtual device based on the given configuration. Default tenant is used
CreateDevice(String, String, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, IClientChannel, array<IDevice>[]()[]) | Creates a virtual device from a list of devices, based on the switch abstraction defined in the given channel.
CreateDevice(String, String, DeviceType, Object) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, SwitchModelType, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy.
CreateDevice(String, String, SwitchConfig, array<IDevice>[]()[]) | Creates a virtual device based on the given configuration.
CreateDevice(String, String, Int32, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant, tenant DbId and type makes a unique entry in CME
CreateDevice(String, String, String, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy.
CreateDevice(String, String, DeviceType, Object, SwitchModelType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, DeviceType, Object, String) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME
CreateDevice(String, String, SwitchModelType, SwitchConfig, array<IDevice>[]()[]) | Create de virtual device from its switch policy and input model
CreateDevice(String, String, Int32, IClientChannel, DeviceType) | Obsolete. Creates a place virtual device from a list of devices, based on the switch abstraction defined in the given channel.
CreateDevice(String, String, String, SwitchConfig, array<IDevice>[]()[]) | Create de virtual device from its switch policy and input model

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with a specific name and type (see CME).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice CreateDevice(
    string name,
    DeviceType deviceType
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    deviceType As DeviceType _
) As IDevice
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
IDevice^ CreateDevice(
    String^ name,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.

Return Value

Created device.

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, IClientChannel, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, IClientChannel, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice[] CreateDevice(
    string name,
    IClientChannel channel,
    IDevice[] list
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    channel As IClientChannel, _
    list As IDevice() _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    IClientChannel^ channel,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Model.Device.IDevice[])"]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, DeviceType, Object)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, DeviceType, Object)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice CreateDevice(
    string name,
    DeviceType deviceType,
    Object stateController
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    deviceType As DeviceType, _
    stateController As Object _
) As IDevice
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
IDevice^ CreateDevice(
    String^ name,
    DeviceType deviceType,
    Object^ stateController
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.
stateController
Type: System..::.Object
Controller object

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, SwitchConfig, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, SwitchConfig, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given configuration. Default tenant is used

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")]
IDevice[] CreateDevice(
    string name,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use CreateDevice() with tenant parameter instead")> _
Function CreateDevice ( _
    name As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use CreateDevice() with tenant parameter instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
config
Type: Genesyslab.Enterprise.SwitchAbstraction..::.SwitchConfig
Configuration structure.
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized according to the config template

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Device Type.

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, IClientChannel, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, IClientChannel, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device from a list of devices, based on the switch abstraction defined in the given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    IClientChannel channel,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    channel As IClientChannel, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    IClientChannel^ channel,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created.
tenant
Type: System..::.String
Name of related tenant to which the device belongs to.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to evaluate as a virtual (global) device according to the channel switch rules

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type.
stateController
Type: System..::.Object
State controller.

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, SwitchModelType, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, SwitchModelType, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given switch policy.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    SwitchModelType switchType,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    switchType As SwitchModelType, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    SwitchModelType switchType,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

switchType
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, SwitchConfig, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, SwitchConfig, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given configuration.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
tenant
Type: System..::.String
Name of related tenant to which device belongd to
config
Type: Genesyslab.Enterprise.SwitchAbstraction..::.SwitchConfig
Configuration structure.
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized according to the config template

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, Int32, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, Int32, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant, tenant DbId and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    int tenantId,
    DeviceType deviceType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    tenantId As Integer, _
    deviceType As DeviceType _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    int tenantId,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Unique name. Must match a CME configuration entry.
tenant
Type: System..::.String
Must match a tenant name in CME
tenantId
Type: System..::.Int32
Tenant DbId in CME
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Device Type.

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, String, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, String, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Creates a virtual device based on the given switch policy.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    string switchType,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    switchType As String, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    String^ switchType,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String
Name of device to be created
tenant
Type: System..::.String
Name of related tenant to which device belongd to
switchType
Type: System..::.String
Switch policy
list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]
List of devices to be virtualized according to the switch policy rules

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object, SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object, SwitchModelType)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController,
    SwitchModelType switchType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object, _
    switchType As SwitchModelType _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController,
    SwitchModelType switchType
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType

[Missing <param name="deviceType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

stateController
Type: System..::.Object

[Missing <param name="stateController"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

switchType
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,Genesyslab.Enterprise.Model.Protocol.SwitchModelType)"]

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, DeviceType, Object, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, DeviceType, Object, String)
IDeviceDomain Interface See Also Send Feedback
Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice CreateDevice(
    string name,
    string tenant,
    DeviceType deviceType,
    Object stateController,
    string switchType
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    deviceType As DeviceType, _
    stateController As Object, _
    switchType As String _
) As IDevice
Visual C++
IDevice^ CreateDevice(
    String^ name,
    String^ tenant,
    DeviceType deviceType,
    Object^ stateController,
    String^ switchType
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType

[Missing <param name="deviceType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

stateController
Type: System..::.Object

[Missing <param name="stateController"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

switchType
Type: System..::.String

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Device.DeviceType,System.Object,System.String)"]

Return Value

IDevice

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, SwitchModelType, SwitchConfig, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, SwitchModelType, SwitchConfig, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Create de virtual device from its switch policy and input model

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    SwitchModelType switchModel,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    switchModel As SwitchModelType, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    SwitchModelType switchModel,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

switchModel
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType

[Missing <param name="switchModel"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

config
Type: Genesyslab.Enterprise.SwitchAbstraction..::.SwitchConfig

[Missing <param name="config"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,Genesyslab.Enterprise.Model.Protocol.SwitchModelType,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, Int32, IClientChannel, DeviceType)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, Int32, IClientChannel, DeviceType)
IDeviceDomain Interface See Also Send Feedback
Creates a place virtual device from a list of devices, based on the switch abstraction defined in the given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Use method  IDevice CreateDevice(string name, string tenant, int tenantId, DeviceType deviceType) instead")]
IDevice[] CreateDevice(
    string name,
    string tenant,
    int tenantID,
    IClientChannel channel,
    DeviceType deviceType
)
Visual Basic (Declaration)
<ObsoleteAttribute("Use method  IDevice CreateDevice(string name, string tenant, int tenantId, DeviceType deviceType) instead")> _
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    tenantID As Integer, _
    channel As IClientChannel, _
    deviceType As DeviceType _
) As IDevice()
Visual C++
[ObsoleteAttribute(L"Use method  IDevice CreateDevice(string name, string tenant, int tenantId, DeviceType deviceType) instead")]
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    int tenantID,
    IClientChannel^ channel,
    DeviceType deviceType
)

Parameters

name
Type: System..::.String
Name of device to be created.
tenant
Type: System..::.String
Name of related tenant to which the device belongs to.
tenantID
Type: System..::.Int32
ID of related tenant to which the device belongs to.
channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Channel
deviceType
Type: Genesyslab.Enterprise.Model.Device..::.DeviceType
Type of the device, must be DeviceType.Place.

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


CreateDevice Method (String, String, String, SwitchConfig, IDevice[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.CreateDevice Method (String, String, String, SwitchConfig, array<IDevice>[]()[])
IDeviceDomain Interface See Also Send Feedback
Create de virtual device from its switch policy and input model

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] CreateDevice(
    string name,
    string tenant,
    string switchType,
    SwitchConfig config,
    IDevice[] list
)
Visual Basic (Declaration)
Function CreateDevice ( _
    name As String, _
    tenant As String, _
    switchType As String, _
    config As SwitchConfig, _
    list As IDevice() _
) As IDevice()
Visual C++
array<IDevice^>^ CreateDevice(
    String^ name,
    String^ tenant,
    String^ switchType,
    SwitchConfig config,
    array<IDevice^>^ list
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,System.String,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

tenant
Type: System..::.String

[Missing <param name="tenant"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,System.String,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

switchType
Type: System..::.String

[Missing <param name="switchType"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,System.String,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

config
Type: Genesyslab.Enterprise.SwitchAbstraction..::.SwitchConfig

[Missing <param name="config"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,System.String,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

list
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.Services.IDeviceDomain.CreateDevice(System.String,System.String,System.String,Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig,Genesyslab.Enterprise.Model.Device.IDevice[])"]

Return Value

IDevice[]

See Also

IDeviceDomain Interface
CreateDevice Overload
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
DeleteDevice(IDevice) | Deletes a device.
DeleteDevice(String, String, String) | Deletes the given device.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method (IDevice)
IDeviceDomain Interface See Also Send Feedback
Deletes a device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain DeleteDevice(
    IDevice device
)
Visual Basic (Declaration)
Function DeleteDevice ( _
    device As IDevice _
) As IDeviceDomain
Visual C++
IDeviceDomain^ DeleteDevice(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to delete.

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
DeleteDevice Overload
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method (String, String, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.DeleteDevice Method (String, String, String)
IDeviceDomain Interface See Also Send Feedback
Deletes the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void DeleteDevice(
    string name,
    string tenant,
    string channel
)
Visual Basic (Declaration)
Sub DeleteDevice ( _
    name As String, _
    tenant As String, _
    channel As String _
)
Visual C++
void DeleteDevice(
    String^ name,
    String^ tenant,
    String^ channel
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
Tenant name
channel
Type: System..::.String
Channel name

See Also

IDeviceDomain Interface
DeleteDevice Overload
Genesyslab.Enterprise.Services Namespace


GetDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.GetDevice Method
IDeviceDomain Interface See Also Send Feedback
Returns the device associated with the given DN name / tenant / Channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice GetDevice(
    string name,
    string tenant,
    string channel
)
Visual Basic (Declaration)
Function GetDevice ( _
    name As String, _
    tenant As String, _
    channel As String _
) As IDevice
Visual C++
IDevice^ GetDevice(
    String^ name,
    String^ tenant,
    String^ channel
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
tenant name
channel
Type: System..::.String
Channel name

Return Value

IDevice

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


GetDevices Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.GetDevices Method
IDeviceDomain Interface See Also Send Feedback
Returns the all devices associated with the given DN name / tenant.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] GetDevices(
    string name,
    string tenant
)
Visual Basic (Declaration)
Function GetDevices ( _
    name As String, _
    tenant As String _
) As IDevice()
Visual C++
array<IDevice^>^ GetDevices(
    String^ name,
    String^ tenant
)

Parameters

name
Type: System..::.String
Device name
tenant
Type: System..::.String
tenant name

Return Value

Created devices.

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method
IDeviceDomain Interface See Also Send Feedback

Overload List

Name | Description
ListDevices()()() | Lists all Devices registered
ListDevices(IDevice) | Lists all the devices which compose the given device or which are stored in the service.
ListDevices(String) | Lists all the devices which are part of a channel
ListDevices(IDevice, String) | Lists all the devices which compose the given device or which are stored in the service.

See Also

IDeviceDomain Interface
IDeviceDomain Members
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method
IDeviceDomain Interface See Also Send Feedback
Lists all Devices registered

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] ListDevices()
Visual Basic (Declaration)
Function ListDevices As IDevice()
Visual C++
array<IDevice^>^ ListDevices()

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (IDevice)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which compose the given device or which are stored in the service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] ListDevices(
    IDevice device
)
Visual Basic (Declaration)
Function ListDevices ( _
    device As IDevice _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device name, or null to get all the devices of the service.

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (String)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which are part of a channel

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] ListDevices(
    string channel
)
Visual Basic (Declaration)
Function ListDevices ( _
    channel As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    String^ channel
)

Parameters

channel
Type: System..::.String
channel name

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


ListDevices Method (IDevice, String)

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.ListDevices Method (IDevice, String)
IDeviceDomain Interface See Also Send Feedback
Lists all the devices which compose the given device or which are stored in the service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] ListDevices(
    IDevice device,
    string channel
)
Visual Basic (Declaration)
Function ListDevices ( _
    device As IDevice, _
    channel As String _
) As IDevice()
Visual C++
array<IDevice^>^ ListDevices(
    IDevice^ device,
    String^ channel
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device name, or null to get all the devices of the service.
channel
Type: System..::.String
channel

Return Value

IDevice []

See Also

IDeviceDomain Interface
ListDevices Overload
Genesyslab.Enterprise.Services Namespace


RemoveDevice Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceDomain..::.RemoveDevice Method
IDeviceDomain Interface See Also Send Feedback
Removes the given device from the given group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain RemoveDevice(
    IDevice device,
    IDevice group
)
Visual Basic (Declaration)
Function RemoveDevice ( _
    device As IDevice, _
    group As IDevice _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RemoveDevice(
    IDevice^ device,
    IDevice^ group
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device to remove from the specified group
group
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Group

Return Value

IDeviceDomain

See Also

IDeviceDomain Interface
Genesyslab.Enterprise.Services Namespace


IDeviceService Interface

[image]

Enterprise SDK 8.0 Reference API
IDeviceService Interface
Members Example See Also Send Feedback
Manages handlers and filters on devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDeviceService : IDeviceDomain,
    IStrategyManager<IDevice>
Visual Basic (Declaration)
Public Interface IDeviceService _
    Implements IDeviceDomain, IStrategyManager(Of IDevice)
Visual C++
public interface class IDeviceService : IDeviceDomain,
    IStrategyManager<IDevice^>

Examples

The following code snippet shows how to register a handler on a device. First, retrieve an instance of the service.
CopyC#
IEnterpriseServiceProvider EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager), null);
IDeviceService deviceService = EsdkService.Resolve<IDeviceService>("deviceService");
 Then, registers a handler on a device, of type extension for instance.
CopyC#
IDevice deviceA = deviceService.CreateDevice("Device name", DeviceType.Extension);
deviceService.RegisterEvents(deviceA, new Action<IEnvelope<IDN>>(DeviceEvent));
 Also, declare your event handler.
CopyC#
protected void DeviceEvent(IEnvelope<IDN> tsp)
{
    if (tsp != null)
    {
        int referenceId = tsp.Header.CorrelationId;
        string dn = tsp.Body.Name;
        //...
     }
}

See Also

IDeviceService Members
Genesyslab.Enterprise.Services Namespace


IDeviceService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService Members
IDeviceService Interface Methods See Also Send Feedback

The IDeviceService type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group. (Inherited from IDeviceDomain.)
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel. (Inherited from IDeviceDomain.)
GetDevices | Returns the all devices associated with the given DN name / tenant. (Inherited from IDeviceDomain.)
ListDevices | Overloaded.
ListFilter<(Of <(T>)>) | Returns the list of filters for the given device.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers an event filter for the given device.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the given device from the given group. (Inherited from IDeviceDomain.)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Overloaded.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given device.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


IDeviceService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService Methods
IDeviceService Interface See Also Send Feedback

The IDeviceService type exposes the following members.

Methods

Name | Description
AddDevice | Adds the given device to the given group. (Inherited from IDeviceDomain.)
CreateDevice | Overloaded.
DeleteDevice | Overloaded.
GetDevice | Returns the device associated with the given DN name / tenant / Channel. (Inherited from IDeviceDomain.)
GetDevices | Returns the all devices associated with the given DN name / tenant. (Inherited from IDeviceDomain.)
ListDevices | Overloaded.
ListFilter<(Of <(T>)>) | Returns the list of filters for the given device.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers an event filter for the given device.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the given device from the given group. (Inherited from IDeviceDomain.)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Overloaded.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given device.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


CreateDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.CreateDevice Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
CreateDevice(String, DeviceType) | Obsolete. Creates a device with a specific name and type (see CME). (Inherited from IDeviceDomain.)
CreateDevice(String, IClientChannel, array<IDevice>[]()[]) | Obsolete. (Inherited from IDeviceDomain.)
CreateDevice(String, DeviceType, Object) | Obsolete. Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, SwitchConfig, array<IDevice>[]()[]) | Obsolete. Creates a virtual device based on the given configuration. Default tenant is used (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, IClientChannel, array<IDevice>[]()[]) | Creates a virtual device from a list of devices, based on the switch abstraction defined in the given channel. (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, SwitchModelType, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy. (Inherited from IDeviceDomain.)
CreateDevice(String, String, SwitchConfig, array<IDevice>[]()[]) | Creates a virtual device based on the given configuration. (Inherited from IDeviceDomain.)
CreateDevice(String, String, Int32, DeviceType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant, tenant DbId and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, String, array<IDevice>[]()[]) | Creates a virtual device based on the given switch policy. (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object, SwitchModelType) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, DeviceType, Object, String) | Creates a device with the given name, type, and custom behaviour. Device name, tenant and type makes a unique entry in CME (Inherited from IDeviceDomain.)
CreateDevice(String, String, SwitchModelType, SwitchConfig, array<IDevice>[]()[]) | Create de virtual device from its switch policy and input model (Inherited from IDeviceDomain.)
CreateDevice(String, String, Int32, IClientChannel, DeviceType) | Obsolete. Creates a place virtual device from a list of devices, based on the switch abstraction defined in the given channel. (Inherited from IDeviceDomain.)
CreateDevice(String, String, String, SwitchConfig, array<IDevice>[]()[]) | Create de virtual device from its switch policy and input model (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


DeleteDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.DeleteDevice Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
DeleteDevice(IDevice) | Deletes a device. (Inherited from IDeviceDomain.)
DeleteDevice(String, String, String) | Deletes the given device. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


ListDevices Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.ListDevices Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
ListDevices()()() | Lists all Devices registered (Inherited from IDeviceDomain.)
ListDevices(IDevice) | Lists all the devices which compose the given device or which are stored in the service. (Inherited from IDeviceDomain.)
ListDevices(String) | Lists all the devices which are part of a channel (Inherited from IDeviceDomain.)
ListDevices(IDevice, String) | Lists all the devices which compose the given device or which are stored in the service. (Inherited from IDeviceDomain.)

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.ListFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Returns the list of filters for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IDevice device
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    device As IDevice _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.

Type Parameters

T
Type for the returned filters.

Return Value

Filters for this device.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>)) | Registers the given handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDevice>)>)>)>)) | Registers the given handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers the given event handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers the given event handler for the given device.
RegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers the given event handler for the given device.

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)))

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>))
IDeviceService Interface See Also Send Feedback
Registers the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler method.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDevice)))

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDevice>)>)>)>))
IDeviceService Interface See Also Send Feedback
Registers the given handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDevice>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDevice)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDevice^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDevice >)>)>)>)
Handler method.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), IStrategy[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to register.
strategyList
Type: array< Genesyslab.Enterprise.Model.Strategy..::.IStrategy >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},Genesyslab.Enterprise.Model.Strategy.IStrategy[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Event handler to register.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategies.
filterList
Type: array< System..::.Attribute >[]()[]
Filters.

Return Value

the IDeviceService.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IDevice, Action(IEnvelope(IDN)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
IDeviceService Interface See Also Send Feedback
Registers the given event handler for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceService RegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IDeviceService
Visual C++
IDeviceService^ RegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to register.
strategyList
Type: array< System..::.String >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IDeviceService.RegisterEvents(Genesyslab.Enterprise.Model.Device.IDevice,System.Action{Genesyslab.Enterprise.Model.Envelope.IEnvelope{Genesyslab.Enterprise.Core.IDN}},System.String[],Genesyslab.Enterprise.Model.ComponentModel.IFilter[])"]

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.RegisterFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Registers an event filter for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceService RegisterFilter<T>(
    IDevice device,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    device As IDevice, _
    filter As T _
) As IDeviceService
Visual C++
generic<typename T>
IDeviceService^ RegisterFilter(
    IDevice^ device,
    T filter
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
filter
Type: T
Filter to register.

Type Parameters

T
Filter type.

Return Value

the IDeviceService.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterEvents Method
IDeviceService Interface See Also Send Feedback

Overload List

Name | Description
UnRegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>)) | Unregisters the given handler for the specified device.
UnRegisterEvents(IDevice, Action<(Of <(IEnvelope<(Of <(IDevice>)>)>)>)) | Unregisters the given handler for the specified device.

See Also

IDeviceService Interface
IDeviceService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method (IDevice, Action(IEnvelope(IDN)))

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDN>)>)>)>))
IDeviceService Interface See Also Send Feedback
Unregisters the given handler for the specified device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain UnRegisterEvents(
    IDevice device,
    Action<IEnvelope<IDN>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDN)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ UnRegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDN^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDN >)>)>)>)
Handler to unregister.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
UnRegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method (IDevice, Action(IEnvelope(IDevice)))

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterEvents Method (IDevice, Action<(Of <(IEnvelope<(Of <(IDevice>)>)>)>))
IDeviceService Interface See Also Send Feedback
Unregisters the given handler for the specified device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceDomain UnRegisterEvents(
    IDevice device,
    Action<IEnvelope<IDevice>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    device As IDevice, _
    handler As Action(Of IEnvelope(Of IDevice)) _
) As IDeviceDomain
Visual C++
IDeviceDomain^ UnRegisterEvents(
    IDevice^ device,
    Action<IEnvelope<IDevice^>^>^ handler
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IDevice >)>)>)>)
Handler to unregister.

Return Value

Domain.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
UnRegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDeviceService..::.UnRegisterFilter<(Of <(T>)>) Method
IDeviceService Interface See Also Send Feedback
Unregisters a filter for the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeviceService UnRegisterFilter<T>(
    IDevice device,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    device As IDevice, _
    filter As T _
) As IDeviceService
Visual C++
generic<typename T>
IDeviceService^ UnRegisterFilter(
    IDevice^ device,
    T filter
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.
filter
Type: T
Filter to unregister.

Type Parameters

T
Filter type.

Return Value

the IDeviceService.

Remarks

See the example section of the service description.

See Also

IDeviceService Interface
Genesyslab.Enterprise.Services Namespace


IEmailDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IEmailDomain Interface
Members See Also Send Feedback
Enables your application to manage the e-mail interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEmailDomain : IStrategyManager<IEmailInteraction>
Visual Basic (Declaration)
Public Interface IEmailDomain _
    Implements IStrategyManager(Of IEmailInteraction)
Visual C++
public interface class IEmailDomain : IStrategyManager<IEmailInteraction^>

Remarks

You can find code snippets for interaction creation in the [!:CreateInteraction] methods.

See Also

IEmailDomain Members
Genesyslab.Enterprise.Services Namespace


IEmailDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailDomain Members
IEmailDomain Interface Methods See Also Send Feedback

The IEmailDomain type exposes the following members.

Methods

Name | Description
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetContactServerChannel | Sets the channel for the Contact Server.
SetContactService | Sets the Contact Service.
SetInteractionServerChannel | Sets the nteraction Server's channel.
SetOpenMediaService | Sets the OpenMedia Service.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IEmailDomain Interface
Genesyslab.Enterprise.Services Namespace


IEmailDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailDomain Methods
IEmailDomain Interface See Also Send Feedback

The IEmailDomain type exposes the following members.

Methods

Name | Description
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetContactServerChannel | Sets the channel for the Contact Server.
SetContactService | Sets the Contact Service.
SetInteractionServerChannel | Sets the nteraction Server's channel.
SetOpenMediaService | Sets the OpenMedia Service.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IEmailDomain Interface
Genesyslab.Enterprise.Services Namespace


SetContactServerChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEmailDomain..::.SetContactServerChannel Method
IEmailDomain Interface See Also Send Feedback
Sets the channel for the Contact Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailDomain SetContactServerChannel(
    IClientChannel contactServerChannel
)
Visual Basic (Declaration)
Function SetContactServerChannel ( _
    contactServerChannel As IClientChannel _
) As IEmailDomain
Visual C++
IEmailDomain^ SetContactServerChannel(
    IClientChannel^ contactServerChannel
)

Parameters

contactServerChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the Contact Server's channel.

Return Value

IEmailDomain

See Also

IEmailDomain Interface
Genesyslab.Enterprise.Services Namespace


SetContactService Method

[image]

Enterprise SDK 8.0 Reference API
IEmailDomain..::.SetContactService Method
IEmailDomain Interface See Also Send Feedback
Sets the Contact Service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailDomain SetContactService(
    IContactService contactService
)
Visual Basic (Declaration)
Function SetContactService ( _
    contactService As IContactService _
) As IEmailDomain
Visual C++
IEmailDomain^ SetContactService(
    IContactService^ contactService
)

Parameters

contactService
Type: Genesyslab.Enterprise.Services..::.IContactService
the Contact Service.

Return Value

IEmailDomain

See Also

IEmailDomain Interface
Genesyslab.Enterprise.Services Namespace


SetInteractionServerChannel Method

[image]

Enterprise SDK 8.0 Reference API
IEmailDomain..::.SetInteractionServerChannel Method
IEmailDomain Interface See Also Send Feedback
Sets the nteraction Server's channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailDomain SetInteractionServerChannel(
    IClientChannel interactionServerChannel
)
Visual Basic (Declaration)
Function SetInteractionServerChannel ( _
    interactionServerChannel As IClientChannel _
) As IEmailDomain
Visual C++
IEmailDomain^ SetInteractionServerChannel(
    IClientChannel^ interactionServerChannel
)

Parameters

interactionServerChannel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the Interaction Server channel.

Return Value

IEmailDomain

See Also

IEmailDomain Interface
Genesyslab.Enterprise.Services Namespace


SetOpenMediaService Method

[image]

Enterprise SDK 8.0 Reference API
IEmailDomain..::.SetOpenMediaService Method
IEmailDomain Interface See Also Send Feedback
Sets the OpenMedia Service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailDomain SetOpenMediaService(
    IOpenMediaService openMediaService
)
Visual Basic (Declaration)
Function SetOpenMediaService ( _
    openMediaService As IOpenMediaService _
) As IEmailDomain
Visual C++
IEmailDomain^ SetOpenMediaService(
    IOpenMediaService^ openMediaService
)

Parameters

openMediaService
Type: Genesyslab.Enterprise.Services..::.IOpenMediaService
the OpenMedia service.

Return Value

IEmailDomain

See Also

IEmailDomain Interface
Genesyslab.Enterprise.Services Namespace


IEmailService Interface

[image]

Enterprise SDK 8.0 Reference API
IEmailService Interface
Members See Also Send Feedback
Manages the callback and filters related to the e-mail interaction events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEmailService : IEmailDomain,
    IStrategyManager<IEmailInteraction>, IEventManager<IEmailService, IEnvelope<IInteraction>>,
    IChannelMonitor<IEmailService>, IBrokerSubscriber<IEnvelope<IInteraction>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IEmailInteraction>
Visual Basic (Declaration)
Public Interface IEmailService _
    Implements IEmailDomain, IStrategyManager(Of IEmailInteraction),  _
    IEventManager(Of IEmailService, IEnvelope(Of IInteraction)), IChannelMonitor(Of IEmailService),  _
    IBrokerSubscriber(Of IEnvelope(Of IInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IEmailInteraction)
Visual C++
public interface class IEmailService : IEmailDomain,
    IStrategyManager<IEmailInteraction^>, IEventManager<IEmailService^, IEnvelope<IInteraction^>^>,
    IChannelMonitor<IEmailService^>, IBrokerSubscriber<IEnvelope<IInteraction^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IEmailInteraction^>

See Also

IEmailService Members
Genesyslab.Enterprise.Services Namespace


IEmailService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService Members
IEmailService Interface Methods Properties See Also Send Feedback

The IEmailService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
Delete | Deletes the given draft of an outbound e-mail interaction from both the Interaction Server and the Contact database. Note: If the inbound e-mail interaction is already stopped, the relationship with the associated customer interaction is lost.
DeleteEmail | Deletes the given draft of an outbound e-mail interaction from the contact database. Note: If the e-mail inbound interaction is already stopped, the relationship with the associated customer interaction is lost.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
LoadEmail | Overloaded.
MakeEmail | Creates and submits an e-mail interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers the given filter for the given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Reply | Overloaded.
Save | Overloaded.
Send | Sends the e-mail-out interaction and stops processing the on-desktop associated email-in interaction (if any).
SetContactServerChannel | Sets the channel for the Contact Server. (Inherited from IEmailDomain.)
SetContactService | Sets the Contact Service. (Inherited from IEmailDomain.)
SetInteractionServerChannel | Sets the nteraction Server's channel. (Inherited from IEmailDomain.)
SetOpenMediaService | Sets the OpenMedia Service. (Inherited from IEmailDomain.)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
StopEmail | Stops the e-mail in the Contact Server. This method changes the interaction status into STOPPED in the Contact Server.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.
Update | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


IEmailService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService Methods
IEmailService Interface See Also Send Feedback

The IEmailService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
Delete | Deletes the given draft of an outbound e-mail interaction from both the Interaction Server and the Contact database. Note: If the inbound e-mail interaction is already stopped, the relationship with the associated customer interaction is lost.
DeleteEmail | Deletes the given draft of an outbound e-mail interaction from the contact database. Note: If the e-mail inbound interaction is already stopped, the relationship with the associated customer interaction is lost.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
LoadEmail | Overloaded.
MakeEmail | Creates and submits an e-mail interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers the given filter for the given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Reply | Overloaded.
Save | Overloaded.
Send | Sends the e-mail-out interaction and stops processing the on-desktop associated email-in interaction (if any).
SetContactServerChannel | Sets the channel for the Contact Server. (Inherited from IEmailDomain.)
SetContactService | Sets the Contact Service. (Inherited from IEmailDomain.)
SetInteractionServerChannel | Sets the nteraction Server's channel. (Inherited from IEmailDomain.)
SetOpenMediaService | Sets the OpenMedia Service. (Inherited from IEmailDomain.)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
StopEmail | Stops the e-mail in the Contact Server. This method changes the interaction status into STOPPED in the Contact Server.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.
Update | Overloaded.

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Delete Method
IEmailService Interface See Also Send Feedback
Deletes the given draft of an outbound e-mail interaction from both the Interaction Server and the Contact database. Note: If the inbound e-mail interaction is already stopped, the relationship with the associated customer interaction is lost.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Delete(
    IEmailInteraction interaction,
    KeyValueCollection reason,
    bool deleteEmail
)
Visual Basic (Declaration)
Sub Delete ( _
    interaction As IEmailInteraction, _
    reason As KeyValueCollection, _
    deleteEmail As Boolean _
)
Visual C++
void Delete(
    IEmailInteraction^ interaction,
    KeyValueCollection^ reason,
    bool deleteEmail
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the outbound e-mail interaction.
reason
Type: KeyValueCollection
the reason.
deleteEmail
Type: System..::.Boolean
true if the e-mail in the contact server is deleted; otherwise, the e-mail is stopped in the interaction server only.

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


DeleteEmail Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.DeleteEmail Method
IEmailService Interface See Also Send Feedback
Deletes the given draft of an outbound e-mail interaction from the contact database. Note: If the e-mail inbound interaction is already stopped, the relationship with the associated customer interaction is lost.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void DeleteEmail(
    IEmailInteraction interaction
)
Visual Basic (Declaration)
Sub DeleteEmail ( _
    interaction As IEmailInteraction _
)
Visual C++
void DeleteEmail(
    IEmailInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the outbound e-mail interaction.

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService..::.GetList Method
IEmailService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IEmailService Interface
IEmailService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.ListFilter<(Of <(T>)>) Method
IEmailService Interface See Also Send Feedback
Lists the filters registered for the given interaction instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IEmailInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As IEmailInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IEmailInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the interaction.

Type Parameters

T
the type of data handled in filter object

Return Value

Filters.

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


LoadEmail Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService..::.LoadEmail Method
IEmailService Interface See Also Send Feedback

Overload List

Name | Description
LoadEmail(IEmailInteraction) | Loads the e-mail attributes from the contact server.
LoadEmail(IEmailInteraction, DataSourceType) | Loads the e-mail attributes from the contact server.

See Also

IEmailService Interface
IEmailService Members
Genesyslab.Enterprise.Services Namespace


LoadEmail Method (IEmailInteraction)

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.LoadEmail Method (IEmailInteraction)
IEmailService Interface See Also Send Feedback
Loads the e-mail attributes from the contact server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailInteraction LoadEmail(
    IEmailInteraction interaction
)
Visual Basic (Declaration)
Function LoadEmail ( _
    interaction As IEmailInteraction _
) As IEmailInteraction
Visual C++
IEmailInteraction^ LoadEmail(
    IEmailInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the interaction.

Return Value

IEmailInteraction

See Also

IEmailService Interface
LoadEmail Overload
Genesyslab.Enterprise.Services Namespace


LoadEmail Method (IEmailInteraction, DataSourceType)

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.LoadEmail Method (IEmailInteraction, DataSourceType)
IEmailService Interface See Also Send Feedback
Loads the e-mail attributes from the contact server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailInteraction LoadEmail(
    IEmailInteraction interaction,
    DataSourceType dataSourceType
)
Visual Basic (Declaration)
Function LoadEmail ( _
    interaction As IEmailInteraction, _
    dataSourceType As DataSourceType _
) As IEmailInteraction
Visual C++
IEmailInteraction^ LoadEmail(
    IEmailInteraction^ interaction,
    DataSourceType dataSourceType
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the interaction.
dataSourceType
Type: Genesyslab.Enterprise.Services..::.DataSourceType
The data source type (could be Main or Archive)

Return Value

IEmailInteraction

See Also

IEmailService Interface
LoadEmail Overload
Genesyslab.Enterprise.Services Namespace


MakeEmail Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.MakeEmail Method
IEmailService Interface See Also Send Feedback
Creates and submits an e-mail interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IEmailInteraction> MakeEmail(
    IDevice devicePlace,
    string interactionID,
    MediaDirectionType direction,
    string interactionSubtype,
    string parentInteractionID,
    string queue,
    KeyValueCollection inputQueues,
    KeyValueCollection outputQueues,
    KeyValueCollection userData,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function MakeEmail ( _
    devicePlace As IDevice, _
    interactionID As String, _
    direction As MediaDirectionType, _
    interactionSubtype As String, _
    parentInteractionID As String, _
    queue As String, _
    inputQueues As KeyValueCollection, _
    outputQueues As KeyValueCollection, _
    userData As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IEnvelope(Of IEmailInteraction)
Visual C++
IEnvelope<IEmailInteraction^>^ MakeEmail(
    IDevice^ devicePlace,
    String^ interactionID,
    MediaDirectionType direction,
    String^ interactionSubtype,
    String^ parentInteractionID,
    String^ queue,
    KeyValueCollection^ inputQueues,
    KeyValueCollection^ outputQueues,
    KeyValueCollection^ userData,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the place device linked to the interaction.
interactionID
Type: System..::.String
an interaction ID or null.
direction
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaDirectionType
the direction of the email interaction.
interactionSubtype
Type: System..::.String
the subtype of the email interaction
parentInteractionID
Type: System..::.String
the related interaction parent ID, ore null if none.
queue
Type: System..::.String
the queue where to put the created interaction.
inputQueues
Type: KeyValueCollection
the workflow input queues.
outputQueues
Type: KeyValueCollection
the workflow output queues.
userData
Type: KeyValueCollection
the user data.
extensions
Type: KeyValueCollection
the extensions of the interaction.
correlatorData
Type: System..::.String
the correlator data.

Return Value

IEnvelope.

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService..::.RegisterEvents Method
IEmailService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IEmailService Interface
IEmailService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.RegisterFilter<(Of <(T>)>) Method
IEmailService Interface See Also Send Feedback
Registers the given filter for the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailService RegisterFilter<T>(
    IEmailInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As IEmailInteraction, _
    filter As T _
) As IEmailService
Visual C++
generic<typename T>
IEmailService^ RegisterFilter(
    IEmailInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the interaction.
filter
Type: T
the filter type.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.IEmailService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IEmailInteraction,``0)"]

Return Value

IEmailService

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


Reply Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Reply Method
IEmailService Interface See Also Send Feedback

Overload List

Name | Description
Reply(IDevice, String, String, Boolean, String) | Creates an outbound e-mail interaction in response to the given inbound e-mail interaction.
Reply(IDevice, IEmailInteraction, String, KeyValueCollection, Boolean, String) | Creates an EmailInteraction (outbound) in reply to an EmailInteraction (inbound).
Reply(IDevice, String, String, Boolean, String, DataSourceType) | Creates an outbound e-mail interaction in response to the given inbound e-mail interaction.

See Also

IEmailService Interface
IEmailService Members
Genesyslab.Enterprise.Services Namespace


Reply Method (IDevice, String, String, Boolean, String)

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Reply Method (IDevice, String, String, Boolean, String)
IEmailService Interface See Also Send Feedback
Creates an outbound e-mail interaction in response to the given inbound e-mail interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IEmailInteraction> Reply(
    IDevice devicePlace,
    string interactionID,
    string queue,
    bool replyToAll,
    string correlatorData
)
Visual Basic (Declaration)
Function Reply ( _
    devicePlace As IDevice, _
    interactionID As String, _
    queue As String, _
    replyToAll As Boolean, _
    correlatorData As String _
) As IEnvelope(Of IEmailInteraction)
Visual C++
IEnvelope<IEmailInteraction^>^ Reply(
    IDevice^ devicePlace,
    String^ interactionID,
    String^ queue,
    bool replyToAll,
    String^ correlatorData
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place linked to the interaction.
interactionID
Type: System..::.String
the inbound e-mail interaction ID.
queue
Type: System..::.String
the queue where the e-mail outbound interaction will be placed.
replyToAll
Type: System..::.Boolean
true if the reply method must fill the e-mail response header with all the parties involved in the inbound e-mail.
correlatorData
Type: System..::.String
the correlator data.

Return Value

IEnvelope.

See Also

IEmailService Interface
Reply Overload
Genesyslab.Enterprise.Services Namespace


Reply Method (IDevice, IEmailInteraction, String, , Boolean, String)

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Reply Method (IDevice, IEmailInteraction, String, , Boolean, String)
IEmailService Interface See Also Send Feedback
Creates an EmailInteraction (outbound) in reply to an EmailInteraction (inbound).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IEmailInteraction> Reply(
    IDevice devicePlace,
    IEmailInteraction interaction,
    string queue,
    KeyValueCollection userData,
    bool replyToAll,
    string correlatorData
)
Visual Basic (Declaration)
Function Reply ( _
    devicePlace As IDevice, _
    interaction As IEmailInteraction, _
    queue As String, _
    userData As KeyValueCollection, _
    replyToAll As Boolean, _
    correlatorData As String _
) As IEnvelope(Of IEmailInteraction)
Visual C++
IEnvelope<IEmailInteraction^>^ Reply(
    IDevice^ devicePlace,
    IEmailInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ userData,
    bool replyToAll,
    String^ correlatorData
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the place device linked to the interaction.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
Email inbound interaction.
queue
Type: System..::.String
the queue where to put the Email outbound interaction.
userData
Type: KeyValueCollection
the additional user data.
replyToAll
Type: System..::.Boolean
true if the reply method must fulfilled the header of Email outbound interaction with all parties involved in Email inbound interaction.
correlatorData
Type: System..::.String
the correlator data.

Return Value

IEnvelope.

See Also

IEmailService Interface
Reply Overload
Genesyslab.Enterprise.Services Namespace


Reply Method (IDevice, String, String, Boolean, String, DataSourceType)

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Reply Method (IDevice, String, String, Boolean, String, DataSourceType)
IEmailService Interface See Also Send Feedback
Creates an outbound e-mail interaction in response to the given inbound e-mail interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IEmailInteraction> Reply(
    IDevice devicePlace,
    string interactionID,
    string queue,
    bool replyToAll,
    string correlatorData,
    DataSourceType dataSourceType
)
Visual Basic (Declaration)
Function Reply ( _
    devicePlace As IDevice, _
    interactionID As String, _
    queue As String, _
    replyToAll As Boolean, _
    correlatorData As String, _
    dataSourceType As DataSourceType _
) As IEnvelope(Of IEmailInteraction)
Visual C++
IEnvelope<IEmailInteraction^>^ Reply(
    IDevice^ devicePlace,
    String^ interactionID,
    String^ queue,
    bool replyToAll,
    String^ correlatorData,
    DataSourceType dataSourceType
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place linked to the interaction.
interactionID
Type: System..::.String
the inbound e-mail interaction ID.
queue
Type: System..::.String
the queue where the e-mail outbound interaction will be placed.
replyToAll
Type: System..::.Boolean
true if the reply method must fill the e-mail response header with all the parties involved in the inbound e-mail.
correlatorData
Type: System..::.String
the correlator data.
dataSourceType
Type: Genesyslab.Enterprise.Services..::.DataSourceType
The data source type (could be main or archive).

Return Value

IEnvelope.

See Also

IEmailService Interface
Reply Overload
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Save Method
IEmailService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IEmailService Interface
IEmailService Members
Genesyslab.Enterprise.Services Namespace


Send Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Send Method
IEmailService Interface See Also Send Feedback
Sends the e-mail-out interaction and stops processing the on-desktop associated email-in interaction (if any).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IEmailInteraction> Send(
    IEmailInteraction interaction,
    string queue,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    bool endEmailInteractionIn,
    string correlatorData
)
Visual Basic (Declaration)
Function Send ( _
    interaction As IEmailInteraction, _
    queue As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    endEmailInteractionIn As Boolean, _
    correlatorData As String _
) As IEnvelope(Of IEmailInteraction)
Visual C++
IEnvelope<IEmailInteraction^>^ Send(
    IEmailInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    bool endEmailInteractionIn,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
interaction to send.
queue
Type: System..::.String
the queue.
reason
Type: KeyValueCollection
the reason.
extensions
Type: KeyValueCollection
extensions.
endEmailInteractionIn
Type: System..::.Boolean
true: stops the on-desktop associated email-in interaction.
correlatorData
Type: System..::.String
Correlator Data.

Return Value

IEnvelope

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


StopEmail Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.StopEmail Method
IEmailService Interface See Also Send Feedback
Stops the e-mail in the Contact Server. This method changes the interaction status into STOPPED in the Contact Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void StopEmail(
    IEmailInteraction interaction,
    KeyValueCollection reason
)
Visual Basic (Declaration)
Sub StopEmail ( _
    interaction As IEmailInteraction, _
    reason As KeyValueCollection _
)
Visual C++
void StopEmail(
    IEmailInteraction^ interaction,
    KeyValueCollection^ reason
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the interaction.
reason
Type: KeyValueCollection
the reason.

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.UnRegisterFilter<(Of <(T>)>) Method
IEmailService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailService UnRegisterFilter<T>(
    IEmailInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As IEmailInteraction, _
    filter As T _
) As IEmailService
Visual C++
generic<typename T>
IEmailService^ UnRegisterFilter(
    IEmailInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
the interaction.
filter
Type: T
the filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IEmailService

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


Update Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Update Method
IEmailService Interface See Also Send Feedback

Overload List

Name | Description
Update(IEmailInteraction) | Updates the e-mail interaction, and saves its properties in the Contact Server.
Update(IEmailInteraction, KeyValueCollection) | Updates the e-mail interaction, and saves its properties and attached data in Interaction Server and Contact Server.

See Also

IEmailService Interface
IEmailService Members
Genesyslab.Enterprise.Services Namespace


Update Method (IEmailInteraction)

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Update Method (IEmailInteraction)
IEmailService Interface See Also Send Feedback
Updates the e-mail interaction, and saves its properties in the Contact Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailService Update(
    IEmailInteraction interaction
)
Visual Basic (Declaration)
Function Update ( _
    interaction As IEmailInteraction _
) As IEmailService
Visual C++
IEmailService^ Update(
    IEmailInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
interaction.

Return Value

IEmailService.

See Also

IEmailService Interface
Update Overload
Genesyslab.Enterprise.Services Namespace


Update Method (IEmailInteraction, )

[image]

Enterprise SDK 8.0 Reference API
IEmailService..::.Update Method (IEmailInteraction, )
IEmailService Interface See Also Send Feedback
Updates the e-mail interaction, and saves its properties and attached data in Interaction Server and Contact Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia.Email (in Genesyslab.Enterprise.Services.Multimedia.Email.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEmailService Update(
    IEmailInteraction interaction,
    KeyValueCollection attachedData
)
Visual Basic (Declaration)
Function Update ( _
    interaction As IEmailInteraction, _
    attachedData As KeyValueCollection _
) As IEmailService
Visual C++
IEmailService^ Update(
    IEmailInteraction^ interaction,
    KeyValueCollection^ attachedData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
The email interaction.
attachedData
Type: KeyValueCollection
The attached data to save.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IEmailService.Update(Genesyslab.Enterprise.Model.Interaction.IEmailInteraction,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection)"]

See Also

IEmailService Interface
Update Overload
Genesyslab.Enterprise.Services Namespace


IEmailService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IEmailService Properties
IEmailService Interface See Also Send Feedback

The IEmailService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IEmailService Interface
Genesyslab.Enterprise.Services Namespace


IEntityDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain Interface
Members See Also Send Feedback
Manages entities and identities for groups and persons.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEntityDomain : IAliasManager
Visual Basic (Declaration)
Public Interface IEntityDomain _
    Implements IAliasManager
Visual C++
public interface class IEntityDomain : IAliasManager

See Also

IEntityDomain Members
Genesyslab.Enterprise.Services Namespace


IEntityDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain Members
IEntityDomain Interface Methods See Also Send Feedback

The IEntityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddRole | Adds a Role.
CreatePerson | Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.
DeletePerson | Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListPersons | Lists the Identities (group) for the specified group.
ListRoles | Lists the roles.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RemoveAlias | Overloaded.
RemovePerson | Removes an Identity from and existing object Group.
RemoveRole | Removes the specified Role.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


IEntityDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain Methods
IEntityDomain Interface See Also Send Feedback

The IEntityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddRole | Adds a Role.
CreatePerson | Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.
DeletePerson | Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListPersons | Lists the Identities (group) for the specified group.
ListRoles | Lists the roles.
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RemoveAlias | Overloaded.
RemovePerson | Removes an Identity from and existing object Group.
RemoveRole | Removes the specified Role.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


AddRole Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.AddRole Method
IEntityDomain Interface See Also Send Feedback
Adds a Role.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEntityDomain AddRole(
    IRole role
)
Visual Basic (Declaration)
Function AddRole ( _
    role As IRole _
) As IEntityDomain
Visual C++
IEntityDomain^ AddRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role to add.

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


CreatePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.CreatePerson Method
IEntityDomain Interface See Also Send Feedback
Creates a new person identity with the specified name (this person is not a group). Note: Names must be unique across both group identities and person identities. Names must be unique across types within a namespace.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity CreatePerson(
    string name
)
Visual Basic (Declaration)
Function CreatePerson ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ CreatePerson(
    String^ name
)

Parameters

name
Type: System..::.String
Name to create.

Return Value

Created identity.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


DeletePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.DeletePerson Method
IEntityDomain Interface See Also Send Feedback
Deletes the specified object and all related data. Upon successful completion, aliases, profiles, and preferences are deleted from the system. The object is also removed from all the groups to which it belonged.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEntityDomain DeletePerson(
    IEntity group
)
Visual Basic (Declaration)
Function DeletePerson ( _
    group As IEntity _
) As IEntityDomain
Visual C++
IEntityDomain^ DeletePerson(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
Group

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListPersons Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.ListPersons Method
IEntityDomain Interface See Also Send Feedback
Lists the Identities (group) for the specified group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEntity[] ListPersons(
    IEntity group
)
Visual Basic (Declaration)
Function ListPersons ( _
    group As IEntity _
) As IEntity()
Visual C++
array<IEntity^>^ ListPersons(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
the specified group.

Return Value

Array of IEntity.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.ListRoles Method
IEntityDomain Interface See Also Send Feedback
Lists the roles.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRole[] ListRoles()
Visual Basic (Declaration)
Function ListRoles As IRole()
Visual C++
array<IRole^>^ ListRoles()

Return Value

the array of roles.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemoveAlias Method
IEntityDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IEntityDomain Interface
IEntityDomain Members
Genesyslab.Enterprise.Services Namespace


RemovePerson Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemovePerson Method
IEntityDomain Interface See Also Send Feedback
Removes an Identity from and existing object Group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEntityDomain RemovePerson(
    IEntity group
)
Visual Basic (Declaration)
Function RemovePerson ( _
    group As IEntity _
) As IEntityDomain
Visual C++
IEntityDomain^ RemovePerson(
    IEntity^ group
)

Parameters

group
Type: Genesyslab.Enterprise.Model.Identity..::.IEntity
the identity to remove.

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveRole Method

[image]

Enterprise SDK 8.0 Reference API
IEntityDomain..::.RemoveRole Method
IEntityDomain Interface See Also Send Feedback
Removes the specified Role.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEntityDomain RemoveRole(
    IRole role
)
Visual Basic (Declaration)
Function RemoveRole ( _
    role As IRole _
) As IEntityDomain
Visual C++
IEntityDomain^ RemoveRole(
    IRole^ role
)

Parameters

role
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IRole
the role to remove.

Return Value

the IEntityDomain.

See Also

IEntityDomain Interface
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Interface

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Interface
Members See Also Send Feedback
Event Manager.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IEventManager<D, T> : IChannelMonitor<D>
Visual Basic (Declaration)
Public Interface IEventManager(Of D, T) _
    Implements IChannelMonitor(Of D)
Visual C++
generic<typename D, typename T>
public interface class IEventManager : IChannelMonitor<D>

Type Parameters

D
the type of service (return type)
T
the type of data to handle in the service

See Also

IEventManager<(Of <(D, T>)>) Members
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Members
IEventManager<(Of <(D, T>)>) Interface Methods See Also Send Feedback

The IEventManager<(Of <(D, T>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


IEventManager(D, T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>) Methods
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback

The IEventManager<(Of <(D, T>)>) type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers a callback method on the given channel with attribute filters.
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters.

See Also

IEventManager<(Of <(D, T>)>) Interface
IEventManager<(Of <(D, T>)>) Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T))

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>))
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method for the given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T) _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), IStrategy[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<IStrategy>[]()[], array<IFilter>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.
strategyList
Type: array< Genesyslab.Enterprise.Model.Strategy..::.IStrategy >[]()[]
The strategies to apply with filters. Strategy must be of filter type.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Array of filters.

Return Value

ISupervisorService

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with attribute filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.
strategyList
Type: array< System..::.Attribute >[]()[]
Array of strategies attribute. Strategy must be of filter type
filterList
Type: array< System..::.Attribute >[]()[]
Array of filters attributes (defined within the code).

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IClientChannel, Action(T), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.RegisterEvents Method (IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[])
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Registers a callback method on the given channel with filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D RegisterEvents(
    IClientChannel channel,
    Action<T> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T), _
    strategyList As String(), _
    filterList As IFilter() _
) As D
Visual C++
D RegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method.
strategyList
Type: array< System..::.String >[]()[]
Names of the strategies to apply with the filters. Strategy must be of IFilter type.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
List of filters.

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IEventManager<(Of <(D, T>)>)..::.UnRegisterEvents Method
IEventManager<(Of <(D, T>)>) Interface See Also Send Feedback
Unregisters a specific handler for a given channel.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
D UnRegisterEvents(
    IClientChannel channel,
    Action<T> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    channel As IClientChannel, _
    handler As Action(Of T) _
) As D
Visual C++
D UnRegisterEvents(
    IClientChannel^ channel,
    Action<T>^ handler
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
Event source.
handler
Type: System..::.Action <(Of <( T >)>)
Callback method to unregister.

Return Value

the data.

See Also

IEventManager<(Of <(D, T>)>) Interface
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Interface
Members See Also Send Feedback
Manages the identity domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIdentityDomain : IStrategyManager<IIdentity>,
    IAliasManager, IRoleManager<IIdentity>
Visual Basic (Declaration)
Public Interface IIdentityDomain _
    Implements IStrategyManager(Of IIdentity), IAliasManager,  _
    IRoleManager(Of IIdentity)
Visual C++
public interface class IIdentityDomain : IStrategyManager<IIdentity^>,
    IAliasManager, IRoleManager<IIdentity^>

See Also

IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Members
IIdentityDomain Interface Methods See Also Send Feedback

The IIdentityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group.
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity.
GetIdentities | Returns all the registered identity intances.
GetIdentity | Retrieves the identity associated with the given name.
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component).
ListRoles | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the device from the given identity instance.
RemoveIdentity | Removes the Identity from the given Identity Group.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetDevice | Associates a device with an identity instance.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


IIdentityDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain Methods
IIdentityDomain Interface See Also Send Feedback

The IIdentityDomain type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group.
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity.
GetIdentities | Returns all the registered identity intances.
GetIdentity | Retrieves the identity associated with the given name.
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component).
ListRoles | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the device from the given identity instance.
RemoveIdentity | Removes the Identity from the given Identity Group.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetDevice | Associates a device with an identity instance.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


AddIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.AddIdentity Method
IIdentityDomain Interface See Also Send Feedback
Adds the Identity to the given Identity group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityDomain AddIdentity(
    IIdentity identity,
    IIdentity group,
    bool allowEvents
)
Visual Basic (Declaration)
Function AddIdentity ( _
    identity As IIdentity, _
    group As IIdentity, _
    allowEvents As Boolean _
) As IIdentityDomain
Visual C++
IIdentityDomain^ AddIdentity(
    IIdentity^ identity,
    IIdentity^ group,
    bool allowEvents
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity to add.
group
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Group of identities.
allowEvents
Type: System..::.Boolean
True to allow event propagation to the upper layer.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateIdentity(String) | Creates a new non-group Identity with the specified name.
CreateIdentity(String, Object) | Creates a new non-composite Identity with the specified name and controller.

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method (String)
IIdentityDomain Interface See Also Send Feedback
Creates a new non-group Identity with the specified name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity CreateIdentity(
    string name
)
Visual Basic (Declaration)
Function CreateIdentity ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ CreateIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
the name of the identity.

Return Value

IIdentity

See Also

IIdentityDomain Interface
CreateIdentity Overload
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method (String, Object)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.CreateIdentity Method (String, Object)
IIdentityDomain Interface See Also Send Feedback
Creates a new non-composite Identity with the specified name and controller.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity CreateIdentity(
    string name,
    Object controller
)
Visual Basic (Declaration)
Function CreateIdentity ( _
    name As String, _
    controller As Object _
) As IIdentity
Visual C++
IIdentity^ CreateIdentity(
    String^ name,
    Object^ controller
)

Parameters

name
Type: System..::.String
Name of the new identity.
controller
Type: System..::.Object
Controller.

Return Value

IIdentity

See Also

IIdentityDomain Interface
CreateIdentity Overload
Genesyslab.Enterprise.Services Namespace


DeleteIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.DeleteIdentity Method
IIdentityDomain Interface See Also Send Feedback
Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityDomain DeleteIdentity(
    IIdentity identity
)
Visual Basic (Declaration)
Function DeleteIdentity ( _
    identity As IIdentity _
) As IIdentityDomain
Visual C++
IIdentityDomain^ DeleteIdentity(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetActionsRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role. (Inherited from IRoleManager<(Of <(T>)>).)
GetActionsRole<(Of <(U>)>)(PartyType) | Gets the actions of a role profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


GetDevices Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetDevices Method
IIdentityDomain Interface See Also Send Feedback
Returns all the devices associated with this identity.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice[] GetDevices(
    IIdentity identity
)
Visual Basic (Declaration)
Function GetDevices ( _
    identity As IIdentity _
) As IDevice()
Visual C++
array<IDevice^>^ GetDevices(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
identity instance

Return Value

IDevice[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetIdentities Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetIdentities Method
IIdentityDomain Interface See Also Send Feedback
Returns all the registered identity intances.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity[] GetIdentities()
Visual Basic (Declaration)
Function GetIdentities As IIdentity()
Visual C++
array<IIdentity^>^ GetIdentities()

Return Value

IIdentity[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetIdentity Method
IIdentityDomain Interface See Also Send Feedback
Retrieves the identity associated with the given name.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity GetIdentity(
    string name
)
Visual Basic (Declaration)
Function GetIdentity ( _
    name As String _
) As IIdentity
Visual C++
IIdentity^ GetIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
Name.

Return Value

IIdentity

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.GetObjectRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
GetObjectRole(T, PartyType) | Gets the Role for an object according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.HasRole Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, PartyType) | Gets the Role availability for an object type according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, Type) | Gets the Role availability for an object type according to the action. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
IsIdentity(IIdentity) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities.
IsIdentity(String) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method (IIdentity)
IIdentityDomain Interface See Also Send Feedback
Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsIdentity(
    IIdentity identity
)
Visual Basic (Declaration)
Function IsIdentity ( _
    identity As IIdentity _
) As Boolean
Visual C++
bool IsIdentity(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity to check.

Return Value

true if the given identity is not composite.

See Also

IIdentityDomain Interface
IsIdentity Overload
Genesyslab.Enterprise.Services Namespace


IsIdentity Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.IsIdentity Method (String)
IIdentityDomain Interface See Also Send Feedback
Returns true if the given identity is not composite, or false if this identity is a composite group of identities.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsIdentity(
    string name
)
Visual Basic (Declaration)
Function IsIdentity ( _
    name As String _
) As Boolean
Visual C++
bool IsIdentity(
    String^ name
)

Parameters

name
Type: System..::.String
the identity name to check.

Return Value

true if the given identity is not composite.

See Also

IIdentityDomain Interface
IsIdentity Overload
Genesyslab.Enterprise.Services Namespace


ListIdentities Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.ListIdentities Method
IIdentityDomain Interface See Also Send Feedback
Lists all the identities that belong to an identity group (which is a composite component).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentity[] ListIdentities(
    IIdentity identity
)
Visual Basic (Declaration)
Function ListIdentities ( _
    identity As IIdentity _
) As IIdentity()
Visual C++
array<IIdentity^>^ ListIdentities(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity to search.

Return Value

IIdentity[]

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.ListRoles Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role. (Inherited from IRoleManager<(Of <(T>)>).)
ListRoles(T) | Gets the list of Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveAlias Method
IIdentityDomain Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IIdentityDomain Interface
IIdentityDomain Members
Genesyslab.Enterprise.Services Namespace


RemoveDevice Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveDevice Method
IIdentityDomain Interface See Also Send Feedback
Removes the device from the given identity instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityDomain RemoveDevice(
    IIdentity identity,
    IDevice device
)
Visual Basic (Declaration)
Function RemoveDevice ( _
    identity As IIdentity, _
    device As IDevice _
) As IIdentityDomain
Visual C++
IIdentityDomain^ RemoveDevice(
    IIdentity^ identity,
    IDevice^ device
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity target instance.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to be linked.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


RemoveIdentity Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.RemoveIdentity Method
IIdentityDomain Interface See Also Send Feedback
Removes the Identity from the given Identity Group.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityDomain RemoveIdentity(
    IIdentity identity,
    IIdentity group
)
Visual Basic (Declaration)
Function RemoveIdentity ( _
    identity As IIdentity, _
    group As IIdentity _
) As IIdentityDomain
Visual C++
IIdentityDomain^ RemoveIdentity(
    IIdentity^ identity,
    IIdentity^ group
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity to remove.
group
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Target group.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


SetDevice Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityDomain..::.SetDevice Method
IIdentityDomain Interface See Also Send Feedback
Associates a device with an identity instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityDomain SetDevice(
    IIdentity identity,
    IDevice device
)
Visual Basic (Declaration)
Function SetDevice ( _
    identity As IIdentity, _
    device As IDevice _
) As IIdentityDomain
Visual C++
IIdentityDomain^ SetDevice(
    IIdentity^ identity,
    IDevice^ device
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
the identity.
device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device.

Return Value

IIdentityDomain

See Also

IIdentityDomain Interface
Genesyslab.Enterprise.Services Namespace


IIdentityService Interface

[image]

Enterprise SDK 8.0 Reference API
IIdentityService Interface
Members Example See Also Send Feedback
Manages the identities.
Note: To use an agent with a device, create a link between these objects with the IIdentityService.SetDevice() method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIdentityService : IIdentityDomain,
    IStrategyManager<IIdentity>, IAliasManager, IRoleManager<IIdentity>
Visual Basic (Declaration)
Public Interface IIdentityService _
    Implements IIdentityDomain, IStrategyManager(Of IIdentity),  _
    IAliasManager, IRoleManager(Of IIdentity)
Visual C++
public interface class IIdentityService : IIdentityDomain,
    IStrategyManager<IIdentity^>, IAliasManager, IRoleManager<IIdentity^>

Examples

Associate an Agent with a Device and monitor Agent Events.
CopyC#
IIdentityService identityService = EsdkService.Resolve<IIdentityService>("identityService");
            if (identityService != null)
            {
               //Create Agent
               agent = identityService.CreateIdentity("Lucent_1000") as IAgent;

               //Associate the Agent with a Device
               identityService.SetDevice(agent, device);

               //Register a handler
               identityService.RegisterEvents(agentA, new Action<IEnvelope<IAgent>>(AgentEvent));
               //...
            }
 To make this snippet work, you need to declare an AgentEvent() method:
CopyC#
[EnterpriseAgentEvent()]
protected void AgentEvent(IEnvelope<IAgent> tsp)
{
    int referenceId = tsp.Header.CorrelationId;
    //...
}

See Also

IIdentityService Members
Genesyslab.Enterprise.Services Namespace


IIdentityService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService Members
IIdentityService Interface Methods See Also Send Feedback

The IIdentityService type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group. (Inherited from IIdentityDomain.)
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation. (Inherited from IIdentityDomain.)
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity. (Inherited from IIdentityDomain.)
GetIdentities | Returns all the registered identity intances. (Inherited from IIdentityDomain.)
GetIdentity | Retrieves the identity associated with the given name. (Inherited from IIdentityDomain.)
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListFilter<(Of <(T>)>) | Returns the filters registered for the given agent.
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component). (Inherited from IIdentityDomain.)
ListRoles | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given agent.
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the device from the given identity instance. (Inherited from IIdentityDomain.)
RemoveIdentity | Removes the Identity from the given Identity Group. (Inherited from IIdentityDomain.)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetDevice | Associates a device with an identity instance. (Inherited from IIdentityDomain.)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters for the events of the given agent.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given agent.
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


IIdentityService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService Methods
IIdentityService Interface See Also Send Feedback

The IIdentityService type exposes the following members.

Methods

Name | Description
AddAlias | Adds an alias. (Inherited from IAliasManager.)
AddIdentity | Adds the Identity to the given Identity group. (Inherited from IIdentityDomain.)
CreateIdentity | Overloaded.
DeleteIdentity | Deletes the specified identity and all its related data. Upon successful completion, associated Aliases, Profiles and Preferences are deleted from the system The identity is also removed from all the groups to which the identity belonged before this operation. (Inherited from IIdentityDomain.)
GetActionsRole | Overloaded.
GetDevices | Returns all the devices associated with this identity. (Inherited from IIdentityDomain.)
GetIdentities | Returns all the registered identity intances. (Inherited from IIdentityDomain.)
GetIdentity | Retrieves the identity associated with the given name. (Inherited from IIdentityDomain.)
GetObjectRole | Overloaded.
HasRole | Overloaded.
IsIdentity | Overloaded.
ListAliases | Returns the list of aliases asscoiated with the given identity. (Inherited from IAliasManager.)
ListFilter<(Of <(T>)>) | Returns the filters registered for the given agent.
ListIdentities | Lists all the identities that belong to an identity group (which is a composite component). (Inherited from IIdentityDomain.)
ListRoles | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
LookupByAlias | Searches for an alias. (Inherited from IAliasManager.)
RegisterActionsForRole | Registers actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given agent.
RegisterObjectRole | Registers Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)
RemoveAlias | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveDevice | Removes the device from the given identity instance. (Inherited from IIdentityDomain.)
RemoveIdentity | Removes the Identity from the given Identity Group. (Inherited from IIdentityDomain.)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetDevice | Associates a device with an identity instance. (Inherited from IIdentityDomain.)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnregisterActionsForRole | Unregisters actions available for a role. (Inherited from IRoleManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters for the events of the given agent.
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given agent.
UnregisterObjectRole | Unregisters Role. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


CreateIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.CreateIdentity Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
CreateIdentity(String) | Creates a new non-group Identity with the specified name. (Inherited from IIdentityDomain.)
CreateIdentity(String, Object) | Creates a new non-composite Identity with the specified name and controller. (Inherited from IIdentityDomain.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


GetActionsRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.GetActionsRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
GetActionsRole<(Of <(U>)>)(IRole) | Gets the actions of a role. (Inherited from IRoleManager<(Of <(T>)>).)
GetActionsRole<(Of <(U>)>)(PartyType) | Gets the actions of a role profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


GetObjectRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.GetObjectRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
GetObjectRole(T, IRole) | Gets the Role for an object according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
GetObjectRole(T, PartyType) | Gets the Role for an object according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


HasRole Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.HasRole Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
HasRole(T, IRole) | Gets the Role availability for an object type according to the role. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, PartyType) | Gets the Role availability for an object type according to the profile type. (Inherited from IRoleManager<(Of <(T>)>).)
HasRole(T, Type) | Gets the Role availability for an object type according to the action. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


IsIdentity Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.IsIdentity Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
IsIdentity(IIdentity) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities. (Inherited from IIdentityDomain.)
IsIdentity(String) | Returns true if the given identity is not composite, or false if this identity is a composite group of identities. (Inherited from IIdentityDomain.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.ListFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Returns the filters registered for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IIdentity agent
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    agent As IIdentity _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IIdentity^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent

Type Parameters

T
Filter type.

Return Value

Filters of the agent.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


ListRoles Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.ListRoles Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
ListRoles()()() | Gets the list of Role. (Inherited from IRoleManager<(Of <(T>)>).)
ListRoles(T) | Gets the list of Role available for an object type. (Inherited from IRoleManager<(Of <(T>)>).)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>)) | Registers an event handler for the given agent.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[]) | Registers for agent events with a handler, a strategy list, and a filter list.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[]) | Registers for agent events with a handler, and arrays of attributes for strategies and filters.
RegisterEvents(IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers for agent events with a handler, a list of strategy IDs, and a filter list.

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)))

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>))
IIdentityService Interface Example See Also Send Feedback
Registers an event handler for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)) _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler method to register.

Return Value

the IIdentityService.

Examples

CopyC#
IIdentityService identityService = EsdkService.Resolve<IIdentityService>("identityService");
            if (identityService != null)
            {
               //Create Agent
               agent = identityService.CreateIdentity("Lucent_1000") as IAgent;

               //Associate the Agent with a Device
               identityService.SetDevice(agent, device);

               //Register a handler
               identityService.RegisterEvents(agentA, new Action<IEnvelope<IAgent>>(AgentEvent));
               //...
            }
 To make this snippet work, you need to declare an AgentEvent() method:
CopyC#
[EnterpriseAgentEvent()]
protected void AgentEvent(IEnvelope<IAgent> tsp)
{
    int referenceId = tsp.Header.CorrelationId;
    //...
}

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), IStrategy[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<IStrategy>[]()[], array<IFilter>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, a strategy list, and a filter list.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    IStrategy[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As IStrategy(), _
    filterList As IFilter() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<IStrategy^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to register.
strategyList
Type: array< Genesyslab.Enterprise.Model.Strategy..::.IStrategy >[]()[]
Strategies.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), Attribute[], Attribute[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<Attribute>[]()[], array<Attribute>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, and arrays of attributes for strategies and filters.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    Attribute[] strategyList,
    Attribute[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As Attribute(), _
    filterList As Attribute() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<Attribute^>^ strategyList,
    array<Attribute^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler method to register.
strategyList
Type: array< System..::.Attribute >[]()[]
Strategy attributes
filterList
Type: array< System..::.Attribute >[]()[]
Filter attributes.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method (IIdentity, Action(IEnvelope(IAgent)), String[], IFilter[])

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterEvents Method (IIdentity, Action<(Of <(IEnvelope<(Of <(IAgent>)>)>)>), array<String>[]()[], array<IFilter>[]()[])
IIdentityService Interface See Also Send Feedback
Registers for agent events with a handler, a list of strategy IDs, and a filter list.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService RegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler,
    string[] strategyList,
    IFilter[] filterList
)
Visual Basic (Declaration)
Function RegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)), _
    strategyList As String(), _
    filterList As IFilter() _
) As IIdentityService
Visual C++
IIdentityService^ RegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler,
    array<String^>^ strategyList,
    array<IFilter^>^ filterList
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to register.
strategyList
Type: array< System..::.String >[]()[]
Strategy IDs.
filterList
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IFilter >[]()[]
Filters.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
RegisterEvents Overload
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RegisterFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Registers a filter for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService RegisterFilter<T>(
    IIdentity agent,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    agent As IIdentity, _
    filter As T _
) As IIdentityService
Visual C++
generic<typename T>
IIdentityService^ RegisterFilter(
    IIdentity^ agent,
    T filter
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
filter
Type: T
Registers the filter for the given agent.

Type Parameters

T
Type for the filter.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


RemoveAlias Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.RemoveAlias Method
IIdentityService Interface See Also Send Feedback

Overload List

Name | Description
RemoveAlias(IAlias) | Removes an alias. (Inherited from IAliasManager.)
RemoveAlias(String) | Removes an alias. (Inherited from IAliasManager.)

See Also

IIdentityService Interface
IIdentityService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterEvents Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.UnRegisterEvents Method
IIdentityService Interface See Also Send Feedback
Unregisters for the events of the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService UnRegisterEvents(
    IIdentity agent,
    Action<IEnvelope<IAgent>> handler
)
Visual Basic (Declaration)
Function UnRegisterEvents ( _
    agent As IIdentity, _
    handler As Action(Of IEnvelope(Of IAgent)) _
) As IIdentityService
Visual C++
IIdentityService^ UnRegisterEvents(
    IIdentity^ agent,
    Action<IEnvelope<IAgent^>^>^ handler
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
handler
Type: System..::.Action <(Of <( IEnvelope <(Of <( IAgent >)>)>)>)
Handler to unregister.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IIdentityService..::.UnRegisterFilter<(Of <(T>)>) Method
IIdentityService Interface See Also Send Feedback
Unregisters a filter for the given agent.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IIdentityService UnRegisterFilter<T>(
    IIdentity agent,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    agent As IIdentity, _
    filter As T _
) As IIdentityService
Visual C++
generic<typename T>
IIdentityService^ UnRegisterFilter(
    IIdentity^ agent,
    T filter
)

Parameters

agent
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Agent.
filter
Type: T
The filter to unregister.

Type Parameters

T
Type.

Return Value

the IIdentityService.

See Also

IIdentityService Interface
Genesyslab.Enterprise.Services Namespace


IIMDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IIMDomain Interface
Members See Also Send Feedback
Manages Instant Messaging data.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMDomain : IStrategyManager<IIMInteraction>
Visual Basic (Declaration)
Public Interface IIMDomain _
    Implements IStrategyManager(Of IIMInteraction)
Visual C++
public interface class IIMDomain : IStrategyManager<IIMInteraction^>

See Also

IIMDomain Members
Genesyslab.Enterprise.Services Namespace


IIMDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain Members
IIMDomain Interface Methods See Also Send Feedback

The IIMDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new interaction associated with a set of devices.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


IIMDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain Methods
IIMDomain Interface See Also Send Feedback

The IIMDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new interaction associated with a set of devices.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.CreateInteraction Method
IIMDomain Interface Example See Also Send Feedback
Uses an existing interaction to create a new interaction associated with a set of devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction CreateInteraction(
    IInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    currentInteraction As IInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
)

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current instance of the interaction.
deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices to associate with the new interaction.

Return Value

IInteraction

Examples

The following example shows how to make an Asynchronous Activate command.
CopyC#
IInteraction interaction = interactionService.CreateInteraction(previousInteraction, deviceList);
if (interaction != null)
{
    ISubscriber<IEnvelope<IRequest>> subscriber = interaction as ISubscriber<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.DeleteInteraction Method
IIMDomain Interface See Also Send Feedback
Deletes the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionDomain DeleteInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function DeleteInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IInteractionDomain

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.DeleteInteractions Method
IIMDomain Interface See Also Send Feedback
Delete all interactions

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionDomain DeleteInteractions()
Visual Basic (Declaration)
Function DeleteInteractions As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteractions()

Return Value

IInteractionDomain

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetAttachedData Method
IIMDomain Interface See Also Send Feedback
Returns the user defined attached data of this interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IDictionary<string, Object>

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteraction Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteraction Method (IAgent, String)
IIMDomain Interface See Also Send Feedback
Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
the agent.
interactionId
Type: System..::.String
the interaction ID.

Return Value

IInteraction

See Also

IIMDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDN, String)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteraction Method (IDN, String)
IIMDomain Interface See Also Send Feedback
Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction GetInteraction(
    IDN dn,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    dn As IDN, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IDN^ dn,
    String^ interactionId
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device linked to the interaction
interactionId
Type: System..::.String
Unique Id of the interaction

Return Value

IInteraction

See Also

IIMDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions.
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists.
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists.
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method
IIMDomain Interface See Also Send Feedback
Returns all the existing interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions()

Return Value

IInteraction []

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method (IAgent)
IIMDomain Interface See Also Send Feedback
Retrieves the interactions associated with an Agent, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Function GetInteractions ( _
    agent As IAgent _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IAgent^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent.

Return Value

IInteraction []

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDN)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method (IDN)
IIMDomain Interface See Also Send Feedback
Retrieves the interactions associated with a device, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions(
    IDN dn
)
Visual Basic (Declaration)
Function GetInteractions ( _
    dn As IDN _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IDN^ dn
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device.

Return Value

IInteraction[]

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.GetInteractions Method (String)
IIMDomain Interface See Also Send Feedback
Returns the existing interaction(s) associated with an interaction ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractions ( _
    interactionId As String _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction.

Return Value

IInteraction []

See Also

IIMDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.RemoveAttachedData Method
IIMDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.
key
Type: System..::.String
the key of the attached data.

Return Value

IInteraction

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SaveAttachedData Method
IIMDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
IInteraction^ SaveAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IInteraction.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SaveInteraction Method
IIMDomain Interface See Also Send Feedback
Saves the interaction in the service's repository. All data are synchronized with the back-end servers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionDomain SaveInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ SaveInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

this IInteractionDomain.

See Also

IIMDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method
IIMDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically.
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

See Also

IIMDomain Interface
IIMDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, )

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method (IInteraction, )
IIMDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.
data
Type: KeyValueCollection
the KeyValueCollection data.

Return Value

IInteraction

See Also

IIMDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IIMDomain..::.SetAttachedData Method (IInteraction, String, Object)
IIMDomain Interface See Also Send Feedback
Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

IInteraction

See Also

IIMDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IIMService Interface

[image]

Enterprise SDK 8.0 Reference API
IIMService Interface
Members Example See Also Send Feedback
Manages the instant messaging features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIMService : IIMDomain,
    IStrategyManager<IIMInteraction>, IBrokerSubscriber<IEnvelope<IIMInteraction>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IIMInteraction>
Visual Basic (Declaration)
Public Interface IIMService _
    Implements IIMDomain, IStrategyManager(Of IIMInteraction),  _
    IBrokerSubscriber(Of IEnvelope(Of IIMInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IIMInteraction)
Visual C++
public interface class IIMService : IIMDomain,
    IStrategyManager<IIMInteraction^>, IBrokerSubscriber<IEnvelope<IIMInteraction^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IIMInteraction^>

Examples

As a start, you need to get a reference on the ESDK instance of the Instant Messaging Service.
CopyC#
IIMService imService = EsdkService.Resolve<IIMService>("IMService");
 To start a new instant messaging session, follow these steps:
  • Connect a channel and register a device on a switch which handles Instant Messaging. (See IChannelService and IDeviceService).
  • Login an agent on a device.
  • Start a session on this device with the IM service as shown in the following code snippet.
CopyC#
IAsyncResult asyncResult = imService.BeginMakeCall(deviceA, channel, OtherDN, Genesyslab.Enterprise.Model.Interaction.MakeCallType.Regular, null, userData, null, null, null, null);
IEnvelope<IInteraction> env = imService.EndMakeCall(asyncResult);
IIMInteraction ixn = (IIMInteraction) env.Body;
imService.SendMessage(ixn, "message", "text/html");
IParty[] colParties = ixn.Parties;
 Above, our code starts asynchronously the IM session. Once started, this session corresponds to a new IIMInteraction which is used till the session ends. Then, you can use the IVoiceService to monitor status changes and new instant messages. You need to register an interaction event handler to receive the instant messages (see the IVoiceService for further details.) The following code snippet retrieves the last instant message of the updated interaction.
CopyC#
 [EnterpriseInteractionEvent("TServerSIPChannel")]
 protected void InteractionEvent(IEnvelope<IInteraction> tsp)
 {
    if (tsp != null)
    {
        if ( (tsp.Header != null) && (tsp.Body != null))
        {
            if (tsp.Header.CurrentContext.ContextState == ContextStateType.Updated)
            {
                IIMInteraction interaction = (IIMInteraction) tsp.Body;
                if (interaction != null)
                {
                    if (interaction.IMEvent != null)
                    {
                        // Use IMEvent field to update your application with the last event received.
                    }
                }
            }
        }
    }
}
 To stop the session, use the IVoiceService.releaseCall() method.

See Also

IIMService Members
Genesyslab.Enterprise.Services Namespace


IIMService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Members
IIMService Interface Methods Properties See Also Send Feedback

The IIMService type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new interaction associated with a set of devices. (Inherited from IIMDomain.)
DeleteInteraction | Deletes the given interaction. (Inherited from IIMDomain.)
DeleteInteractions | Delete all interactions (Inherited from IIMDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IIMDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IIMDomain.)
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


IIMService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Methods
IIMService Interface See Also Send Feedback

The IIMService type exposes the following members.

Methods

Name | Description
CreateInteraction | Uses an existing interaction to create a new interaction associated with a set of devices. (Inherited from IIMDomain.)
DeleteInteraction | Deletes the given interaction. (Inherited from IIMDomain.)
DeleteInteractions | Delete all interactions (Inherited from IIMDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IIMDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IIMDomain.)
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetInteraction Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists. (Inherited from IIMDomain.)
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetInteractions Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions. (Inherited from IIMDomain.)
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists. (Inherited from IIMDomain.)
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists. (Inherited from IIMDomain.)
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.GetList Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.Save Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService..::.SetAttachedData Method
IIMService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically. (Inherited from IIMDomain.)

See Also

IIMService Interface
IIMService Members
Genesyslab.Enterprise.Services Namespace


IIMService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIMService Properties
IIMService Interface See Also Send Feedback

The IIMService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IIMService Interface
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Interface
Members See Also Send Feedback
Enables your application to manage interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IInteractionDomain : IStrategyManager<IInteraction>
Visual Basic (Declaration)
Public Interface IInteractionDomain _
    Implements IStrategyManager(Of IInteraction)
Visual C++
public interface class IInteractionDomain : IStrategyManager<IInteraction^>

Remarks

You can find code snippets for interaction creation in the CreateInteraction(IEnumerable<(Of <(IDevice>)>)) methods.

See Also

IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Members
IInteractionDomain Interface Methods See Also Send Feedback

The IInteractionDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


IInteractionDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain Methods
IInteractionDomain Interface See Also Send Feedback

The IInteractionDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Delete all interactions
GetAttachedData | Returns the user defined attached data of this interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID.
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method (IEnumerable<(Of <(IDevice>)>))
IInteractionDomain Interface See Also Send Feedback
Creates a new interaction associated with a set of devices and a unique ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction CreateInteraction(
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IEnumerable<IDevice^>^ deviceList
)

Parameters

deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices associated with the interaction.

Return Value

IInteraction

Remarks

The following example shows how to make an Asynchronous Activate command. ///
CopyC#
IInteraction interaction = interactionService.CreateInteraction(deviceList);
if (interaction != null)
{
    ISubscribeable<IEnvelope>IRequest subscriber = interaction as ISubscribeable<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IInteractionDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IInteraction, IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.CreateInteraction Method (IInteraction, IEnumerable<(Of <(IDevice>)>))
IInteractionDomain Interface Example See Also Send Feedback
Uses an existing interaction to create a new interaction associated with a set of devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction CreateInteraction(
    IInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    currentInteraction As IInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IInteraction
Visual C++
IInteraction^ CreateInteraction(
    IInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
)

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current instance of the interaction.
deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices to associate with the new interaction.

Return Value

IInteraction

Examples

The following example shows how to make an Asynchronous Activate command.
CopyC#
IInteraction interaction = interactionService.CreateInteraction(previousInteraction, deviceList);
if (interaction != null)
{
    ISubscriber<IEnvelope<IRequest>> subscriber = interaction as ISubscriber<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IInteractionDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.DeleteInteraction Method
IInteractionDomain Interface See Also Send Feedback
Deletes the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionDomain DeleteInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function DeleteInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

IInteractionDomain

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.DeleteInteractions Method
IInteractionDomain Interface See Also Send Feedback
Delete all interactions

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionDomain DeleteInteractions()
Visual Basic (Declaration)
Function DeleteInteractions As IInteractionDomain
Visual C++
IInteractionDomain^ DeleteInteractions()

Return Value

IInteractionDomain

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Returns the user defined attached data of this interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection GetAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction

Return Value

IDictionary<string, Object>

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method (IAgent, String)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
the agent.
interactionId
Type: System..::.String
the interaction ID.

Return Value

IInteraction

See Also

IInteractionDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDN, String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteraction Method (IDN, String)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction GetInteraction(
    IDN dn,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    dn As IDN, _
    interactionId As String _
) As IInteraction
Visual C++
IInteraction^ GetInteraction(
    IDN^ dn,
    String^ interactionId
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device linked to the interaction
interactionId
Type: System..::.String
Unique Id of the interaction

Return Value

IInteraction

See Also

IInteractionDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions.
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists.
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists.
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method
IInteractionDomain Interface See Also Send Feedback
Returns all the existing interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions()

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (IAgent)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interactions associated with an Agent, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Function GetInteractions ( _
    agent As IAgent _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IAgent^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent.

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDN)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (IDN)
IInteractionDomain Interface See Also Send Feedback
Retrieves the interactions associated with a device, or null if no interaction exists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions(
    IDN dn
)
Visual Basic (Declaration)
Function GetInteractions ( _
    dn As IDN _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    IDN^ dn
)

Parameters

dn
Type: Genesyslab.Enterprise.Core..::.IDN
Device.

Return Value

IInteraction[]

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.GetInteractions Method (String)
IInteractionDomain Interface See Also Send Feedback
Returns the existing interaction(s) associated with an interaction ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractions ( _
    interactionId As String _
) As IInteraction()
Visual C++
array<IInteraction^>^ GetInteractions(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction.

Return Value

IInteraction []

See Also

IInteractionDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.RemoveAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction RemoveAttachedData(
    IInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IInteraction, _
    key As String _
) As IInteraction
Visual C++
IInteraction^ RemoveAttachedData(
    IInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.
key
Type: System..::.String
the key of the attached data.

Return Value

IInteraction

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SaveAttachedData Method
IInteractionDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction SaveAttachedData(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IInteraction _
) As IInteraction
Visual C++
IInteraction^ SaveAttachedData(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction.

Return Value

this IInteraction.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SaveInteraction Method
IInteractionDomain Interface See Also Send Feedback
Saves the interaction in the service's repository. All data are synchronized with the back-end servers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteractionDomain SaveInteraction(
    IInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IInteraction _
) As IInteractionDomain
Visual C++
IInteractionDomain^ SaveInteraction(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

this IInteractionDomain.

See Also

IInteractionDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method
IInteractionDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically.
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

See Also

IInteractionDomain Interface
IInteractionDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, )

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method (IInteraction, )
IInteractionDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    data As KeyValueCollection _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
the interaction to modify.
data
Type: KeyValueCollection
the KeyValueCollection data.

Return Value

IInteraction

See Also

IInteractionDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IInteractionDomain..::.SetAttachedData Method (IInteraction, String, Object)
IInteractionDomain Interface See Also Send Feedback
Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInteraction SetAttachedData(
    IInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IInteraction, _
    key As String, _
    value As Object _
) As IInteraction
Visual C++
IInteraction^ SetAttachedData(
    IInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

IInteraction

See Also

IInteractionDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IInteractionQueueService Interface

[image]

Enterprise SDK 8.0 Reference API
IInteractionQueueService Interface
Members See Also Send Feedback
Manages the Workbin features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IInteractionQueueService : IStrategyManager<IInteractionQueueSnapshot>,
    IEventManager<IInteractionQueueService, IEnvelope<IInteractionQueueSnapshot>>, IChannelMonitor<IInteractionQueueService>,
    IBrokerSubscriber<IEnvelope<IInteractionQueueSnapshot>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface IInteractionQueueService _
    Implements IStrategyManager(Of IInteractionQueueSnapshot), IEventManager(Of IInteractionQueueService, IEnvelope(Of IInteractionQueueSnapshot)),  _
    IChannelMonitor(Of IInteractionQueueService), IBrokerSubscriber(Of IEnvelope(Of IInteractionQueueSnapshot)),  _
    IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class IInteractionQueueService : IStrategyManager<IInteractionQueueSnapshot^>,
    IEventManager<IInteractionQueueService^, IEnvelope<IInteractionQueueSnapshot^>^>, IChannelMonitor<IInteractionQueueService^>,
    IBrokerSubscriber<IEnvelope<IInteractionQueueSnapshot^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>

See Also

IInteractionQueueService Members
Genesyslab.Enterprise.Services Namespace


IInteractionQueueService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueService Members
IInteractionQueueService Interface Methods Properties See Also Send Feedback

The IInteractionQueueService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IInteractionQueueService Interface
Genesyslab.Enterprise.Services Namespace


IInteractionQueueService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueService Methods
IInteractionQueueService Interface See Also Send Feedback

The IInteractionQueueService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IInteractionQueueService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueService..::.GetList Method
IInteractionQueueService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IInteractionQueueService Interface
IInteractionQueueService Members
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueService..::.RegisterEvents Method
IInteractionQueueService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IInteractionQueueService Interface
IInteractionQueueService Members
Genesyslab.Enterprise.Services Namespace


IInteractionQueueService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInteractionQueueService Properties
IInteractionQueueService Interface See Also Send Feedback

The IInteractionQueueService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IInteractionQueueService Interface
Genesyslab.Enterprise.Services Namespace


IMonitorService Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorService Interface
Members See Also Send Feedback
Connects to the Statistics Server to monitor the objects' presence. With this service, your application can determine if an agent is available or if a media is in a given status.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitorService : IEventManager<IMonitorService, IEnvelope<IMonitorEventStatus>>,
    IChannelMonitor<IMonitorService>, IBrokerSubscriber<IEnvelope<IMonitorEventStatus>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface IMonitorService _
    Implements IEventManager(Of IMonitorService, IEnvelope(Of IMonitorEventStatus)),  _
    IChannelMonitor(Of IMonitorService), IBrokerSubscriber(Of IEnvelope(Of IMonitorEventStatus)),  _
    IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class IMonitorService : IEventManager<IMonitorService^, IEnvelope<IMonitorEventStatus^>^>,
    IChannelMonitor<IMonitorService^>, IBrokerSubscriber<IEnvelope<IMonitorEventStatus^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>

See Also

IMonitorService Members
Genesyslab.Enterprise.Services Namespace


IMonitorService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorService Members
IMonitorService Interface Methods Properties See Also Send Feedback

The IMonitorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
PeekAndSubscribeStatus | Obsolete.
PeekStatus | Obsolete. Peeks the CurrentState status of the given object in the Statistics Server.
PeekStatusEx | Obsolete. Peeks the CurrentTargetState status of the object in the Statistics Server.
PeekStatusFull | Obsolete. Peeks and consolidates the CurrentState and the CurrentTargetState status of an object in the Statistics Server.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
SubscribePresenceView | Peeks and subscribes to the notification presence through the Statistics Consolidation of the following subjects: CurrentState, CurrentTargetState, CurrentStateReasons.
SubscribeReasonStatus | Obsolete. Subscribes to the reason status of the given object in the Statistics Server.
SubscribeStatus | Obsolete. Subscribes to the status of an object in the Statistics Server.
SubscribeStatusEx | Obsolete. Subscribes to the extended status of the given object in the Statistics Server.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnsubscribePresenceView | Unsubscribes to the notification presence.
UnsubscribeReasonStatus | Obsolete. Unsubscribes to the reason status of the given object in the Statistics Server.
UnsubscribeStatus | Obsolete. Unsubscribe to the Status of the given object in the Statistics Server.
UnsubscribeStatusEx | Obsolete. Unsubscribes to the extended status of the given object in the Statistics Server.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


IMonitorService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorService Methods
IMonitorService Interface See Also Send Feedback

The IMonitorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
PeekAndSubscribeStatus | Obsolete.
PeekStatus | Obsolete. Peeks the CurrentState status of the given object in the Statistics Server.
PeekStatusEx | Obsolete. Peeks the CurrentTargetState status of the object in the Statistics Server.
PeekStatusFull | Obsolete. Peeks and consolidates the CurrentState and the CurrentTargetState status of an object in the Statistics Server.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
SubscribePresenceView | Peeks and subscribes to the notification presence through the Statistics Consolidation of the following subjects: CurrentState, CurrentTargetState, CurrentStateReasons.
SubscribeReasonStatus | Obsolete. Subscribes to the reason status of the given object in the Statistics Server.
SubscribeStatus | Obsolete. Subscribes to the status of an object in the Statistics Server.
SubscribeStatusEx | Obsolete. Subscribes to the extended status of the given object in the Statistics Server.
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnsubscribePresenceView | Unsubscribes to the notification presence.
UnsubscribeReasonStatus | Obsolete. Unsubscribes to the reason status of the given object in the Statistics Server.
UnsubscribeStatus | Obsolete. Unsubscribe to the Status of the given object in the Statistics Server.
UnsubscribeStatusEx | Obsolete. Unsubscribes to the extended status of the given object in the Statistics Server.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.GetList Method
IMonitorService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IMonitorService Interface
IMonitorService Members
Genesyslab.Enterprise.Services Namespace


PeekAndSubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.PeekAndSubscribeStatus Method
IMonitorService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus> PeekAndSubscribeStatus(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function PeekAndSubscribeStatus ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus^>^ PeekAndSubscribeStatus(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType

[Missing <param name="objectType"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

objectId
Type: System..::.String

[Missing <param name="objectId"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantName
Type: System..::.String

[Missing <param name="tenantName"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

tenantPassword
Type: System..::.String

[Missing <param name="tenantPassword"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode

[Missing <param name="notificationMode"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

notificationValue
Type: System..::.Int32

[Missing <param name="notificationValue"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

listener
Type: MonitorMethodDelegate

[Missing <param name="listener"/> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IMonitorService.PeekAndSubscribeStatus(Genesyslab.Enterprise.Model.Channel.IClientChannel,Genesyslab.Enterprise.Services.MonitorObjectType,System.String,System.String,System.String,Genesyslab.Enterprise.Services.MonitorNotificationMode,System.Int32,Genesyslab.Enterprise.Services.MonitorMethodDelegate)"]

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


PeekStatus Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.PeekStatus Method
IMonitorService Interface See Also Send Feedback
Peeks the CurrentState status of the given object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus> PeekStatus(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function PeekStatus ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus^>^ PeekStatus(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


PeekStatusEx Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.PeekStatusEx Method
IMonitorService Interface See Also Send Feedback
Peeks the CurrentTargetState status of the object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus> PeekStatusEx(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function PeekStatusEx ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus^>^ PeekStatusEx(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


PeekStatusFull Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.PeekStatusFull Method
IMonitorService Interface See Also Send Feedback
Peeks and consolidates the CurrentState and the CurrentTargetState status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus> PeekStatusFull(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function PeekStatusFull ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
IEnvelope<IMonitorEventStatus^>^ PeekStatusFull(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.RegisterEvents Method
IMonitorService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IMonitorService Interface
IMonitorService Members
Genesyslab.Enterprise.Services Namespace


SubscribePresenceView Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.SubscribePresenceView Method
IMonitorService Interface See Also Send Feedback
Peeks and subscribes to the notification presence through the Statistics Consolidation of the following subjects: CurrentState, CurrentTargetState, CurrentStateReasons.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IMonitorEventStatus> SubscribePresenceView(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue
)
Visual Basic (Declaration)
Function SubscribePresenceView ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
IEnvelope<IMonitorEventStatus^>^ SubscribePresenceView(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the Statistics Server channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
the notification mode.
notificationValue
Type: System..::.Int32
the notification value according to the notification mode.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


SubscribeReasonStatus Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.SubscribeReasonStatus Method
IMonitorService Interface See Also Send Feedback
Subscribes to the reason status of the given object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
bool SubscribeReasonStatus(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function SubscribeReasonStatus ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
bool SubscribeReasonStatus(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel to which the protocol belongs to.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the statistic object type to be retrieved.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
the notification mode.
notificationValue
Type: System..::.Int32
the notification value according to the notification mode.
listener
Type: MonitorMethodDelegate
the callback for receiving result.

Return Value

true if the subscribe request succeeded; otherwise, false otherwise.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


SubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.SubscribeStatus Method
IMonitorService Interface See Also Send Feedback
Subscribes to the status of an object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
bool SubscribeStatus(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function SubscribeStatus ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
bool SubscribeStatus(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
the notification mode.
notificationValue
Type: System..::.Int32
Notification value according to the notification mode.
listener
Type: MonitorMethodDelegate
the callback for receiving result.

Return Value

true if the subscribe request succeeded; otherwise, false.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


SubscribeStatusEx Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.SubscribeStatusEx Method
IMonitorService Interface See Also Send Feedback
Subscribes to the extended status of the given object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")]
bool SubscribeStatusEx(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    string tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the SubscribePresenceView method")> _
Function SubscribeStatusEx ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    tenantPassword As String, _
    notificationMode As MonitorNotificationMode, _
    notificationValue As Integer, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the SubscribePresenceView method")]
bool SubscribeStatusEx(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    String^ tenantPassword,
    MonitorNotificationMode notificationMode,
    int notificationValue,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
tenantPassword
Type: System..::.String
the tenant password.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
the notification mode.
notificationValue
Type: System..::.Int32
the notification value according to the notification mode.
listener
Type: MonitorMethodDelegate
the callback for receiving result.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


UnsubscribePresenceView Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.UnsubscribePresenceView Method
IMonitorService Interface See Also Send Feedback
Unsubscribes to the notification presence.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IMonitorEventStatus> UnsubscribePresenceView(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorNotificationMode notificationMode
)
Visual Basic (Declaration)
Function UnsubscribePresenceView ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    notificationMode As MonitorNotificationMode _
) As IEnvelope(Of IMonitorEventStatus)
Visual C++
IEnvelope<IMonitorEventStatus^>^ UnsubscribePresenceView(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorNotificationMode notificationMode
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the Statistics Server channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
notificationMode
Type: Genesyslab.Enterprise.Services..::.MonitorNotificationMode
the notification mode.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


UnsubscribeReasonStatus Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.UnsubscribeReasonStatus Method
IMonitorService Interface See Also Send Feedback
Unsubscribes to the reason status of the given object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the UnsubscribePresenceView method")]
bool UnsubscribeReasonStatus(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the UnsubscribePresenceView method")> _
Function UnsubscribeReasonStatus ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the UnsubscribePresenceView method")]
bool UnsubscribeReasonStatus(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
listener
Type: MonitorMethodDelegate
the result callback.

Return Value

true if the subscribe request succeeded; otherwise, false.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


UnsubscribeStatus Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.UnsubscribeStatus Method
IMonitorService Interface See Also Send Feedback
Unsubscribe to the Status of the given object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the UnsubscribePresenceView method")]
bool UnsubscribeStatus(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the UnsubscribePresenceView method")> _
Function UnsubscribeStatus ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the UnsubscribePresenceView method")]
bool UnsubscribeStatus(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
listener
Type: MonitorMethodDelegate
the result callback.

Return Value

true if the subscribe request succeeded; otherwise, false.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


UnsubscribeStatusEx Method

[image]

Enterprise SDK 8.0 Reference API
IMonitorService..::.UnsubscribeStatusEx Method
IMonitorService Interface See Also Send Feedback
Unsubscribes to the extended status of the given object in the Statistics Server.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the UnsubscribePresenceView method")]
bool UnsubscribeStatusEx(
    IClientChannel channel,
    MonitorObjectType objectType,
    string objectId,
    string tenantName,
    MonitorMethodDelegate listener
)
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the UnsubscribePresenceView method")> _
Function UnsubscribeStatusEx ( _
    channel As IClientChannel, _
    objectType As MonitorObjectType, _
    objectId As String, _
    tenantName As String, _
    listener As MonitorMethodDelegate _
) As Boolean
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the UnsubscribePresenceView method")]
bool UnsubscribeStatusEx(
    IClientChannel^ channel,
    MonitorObjectType objectType,
    String^ objectId,
    String^ tenantName,
    MonitorMethodDelegate^ listener
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
objectType
Type: Genesyslab.Enterprise.Services..::.MonitorObjectType
the type of statistic object to retrieve.
objectId
Type: System..::.String
the object ID.
tenantName
Type: System..::.String
the tenant ID.
listener
Type: MonitorMethodDelegate
the result callback.

Return Value

the envelope which contains the statistic result.

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


IMonitorService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorService Properties
IMonitorService Interface See Also Send Feedback

The IMonitorService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IMonitorService Interface
Genesyslab.Enterprise.Services Namespace


IOpenMediaDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain Interface
Members See Also Send Feedback
Manages the data of open media interactions. Open media interactions are used for the customization of your application with other media than chat, voice, and e-mail.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOpenMediaDomain : IStrategyManager<IOpenMediaInteraction>
Visual Basic (Declaration)
Public Interface IOpenMediaDomain _
    Implements IStrategyManager(Of IOpenMediaInteraction)
Visual C++
public interface class IOpenMediaDomain : IStrategyManager<IOpenMediaInteraction^>

Remarks

You can find code snippets for interaction creation in the CreateInteraction(IEnumerable<(Of <(IDevice>)>)) methods.

See Also

IOpenMediaDomain Members
Genesyslab.Enterprise.Services Namespace


IOpenMediaDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain Members
IOpenMediaDomain Interface Methods See Also Send Feedback

The IOpenMediaDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Deletes all the interactions.
GetAttachedData | Returns the user defined attached data of the given interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. Asyenchronous operation
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


IOpenMediaDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain Methods
IOpenMediaDomain Interface See Also Send Feedback

The IOpenMediaDomain type exposes the following members.

Methods

Name | Description
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction.
DeleteInteractions | Deletes all the interactions.
GetAttachedData | Returns the user defined attached data of the given interaction.
GetInteraction | Overloaded.
GetInteractions | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. Asyenchronous operation
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically.
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers.
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.CreateInteraction Method
IOpenMediaDomain Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID.
CreateInteraction(IOpenMediaInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices.

See Also

IOpenMediaDomain Interface
IOpenMediaDomain Members
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.CreateInteraction Method (IEnumerable<(Of <(IDevice>)>))
IOpenMediaDomain Interface See Also Send Feedback
Creates a new interaction associated with a set of devices and a unique ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction CreateInteraction(
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    deviceList As IEnumerable(Of IDevice) _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ CreateInteraction(
    IEnumerable<IDevice^>^ deviceList
)

Parameters

deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices associated with the interaction.

Return Value

The created open media interaction.

Remarks

The following example shows how to make an Asynchronous Activate command.
CopyC#
IInteraction interaction = interactionService.CreateInteraction(deviceList);
if (interaction != null)
{
    ISubscribeable<IEnvelope>IRequest subscriber = interaction as ISubscribeable<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IOpenMediaDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method (IOpenMediaInteraction, IEnumerable(IDevice))

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.CreateInteraction Method (IOpenMediaInteraction, IEnumerable<(Of <(IDevice>)>))
IOpenMediaDomain Interface Example See Also Send Feedback
Uses an existing interaction to create a new interaction associated with a set of devices.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction CreateInteraction(
    IOpenMediaInteraction currentInteraction,
    IEnumerable<IDevice> deviceList
)
Visual Basic (Declaration)
Function CreateInteraction ( _
    currentInteraction As IOpenMediaInteraction, _
    deviceList As IEnumerable(Of IDevice) _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ CreateInteraction(
    IOpenMediaInteraction^ currentInteraction,
    IEnumerable<IDevice^>^ deviceList
)

Parameters

currentInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
Current instance of the interaction.
deviceList
Type: System.Collections.Generic..::.IEnumerable <(Of <( IDevice >)>)
List of devices to associate with the new interaction.

Return Value

The created open media interaction.

Examples

The following example shows how to make an Asynchronous Activate command.
CopyC#
IInteraction interaction = interactionService.CreateInteraction(previousInteraction, deviceList);
if (interaction != null)
{
    ISubscriber<IEnvelope<IRequest>> subscriber = interaction as ISubscriber<IEnvelope<IRequest>>;
    if (subscriber != null)
    {
       subscriber.Handle(envelope);
    }
}

See Also

IOpenMediaDomain Interface
CreateInteraction Overload
Genesyslab.Enterprise.Services Namespace


DeleteInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.DeleteInteraction Method
IOpenMediaDomain Interface See Also Send Feedback
Deletes the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaDomain DeleteInteraction(
    IOpenMediaInteraction interaction
)
Visual Basic (Declaration)
Function DeleteInteraction ( _
    interaction As IOpenMediaInteraction _
) As IOpenMediaDomain
Visual C++
IOpenMediaDomain^ DeleteInteraction(
    IOpenMediaInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
The interaction.

Return Value

The domain.

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.DeleteInteractions Method
IOpenMediaDomain Interface See Also Send Feedback
Deletes all the interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaDomain DeleteInteractions()
Visual Basic (Declaration)
Function DeleteInteractions As IOpenMediaDomain
Visual C++
IOpenMediaDomain^ DeleteInteractions()

Return Value

The domain.

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


GetAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetAttachedData Method
IOpenMediaDomain Interface See Also Send Feedback
Returns the user defined attached data of the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
KeyValueCollection GetAttachedData(
    IOpenMediaInteraction interaction
)
Visual Basic (Declaration)
Function GetAttachedData ( _
    interaction As IOpenMediaInteraction _
) As KeyValueCollection
Visual C++
KeyValueCollection^ GetAttachedData(
    IOpenMediaInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
the interaction

Return Value

The collection of key-value pairs.

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteraction Method
IOpenMediaDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with the given agent based on the given ID; if the interaction is not associated with this agent, the method returns null.
GetInteraction(IDevice, String) | Retrieves the interaction associated with the given device, or null if no interaction exists or if the interaction is not associated with the device.

See Also

IOpenMediaDomain Interface
IOpenMediaDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IAgent, String)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteraction Method (IAgent, String)
IOpenMediaDomain Interface See Also Send Feedback
Retrieves the interaction associated with the given agent based on the given ID; if the interaction is not associated with this agent, the method returns null.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction GetInteraction(
    IAgent agent,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    agent As IAgent, _
    interactionId As String _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ GetInteraction(
    IAgent^ agent,
    String^ interactionId
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
The agent.
interactionId
Type: System..::.String
The interaction ID.

Return Value

The open media interaction associated with the agent; null if no interaction.

See Also

IOpenMediaDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteraction Method (IDevice, String)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteraction Method (IDevice, String)
IOpenMediaDomain Interface See Also Send Feedback
Retrieves the interaction associated with the given device, or null if no interaction exists or if the interaction is not associated with the device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction GetInteraction(
    IDevice device,
    string interactionId
)
Visual Basic (Declaration)
Function GetInteraction ( _
    device As IDevice, _
    interactionId As String _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ GetInteraction(
    IDevice^ device,
    String^ interactionId
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device place linked to the interaction.
interactionId
Type: System..::.String
Unique ID of the interaction.

Return Value

The associated interaction; null if no interaction exists or if the interaction is not associated with the device.

See Also

IOpenMediaDomain Interface
GetInteraction Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteractions Method
IOpenMediaDomain Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions.
GetInteractions(IAgent) | Retrieves the interactions associated with the given Agent if any; otherwise null.
GetInteractions(IDevice) | Retrieves the interactions associated with the given device, or null if there is no interaction available.
GetInteractions(String) | Returns the existing interaction(s) associated with the given interaction ID.

See Also

IOpenMediaDomain Interface
IOpenMediaDomain Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteractions Method
IOpenMediaDomain Interface See Also Send Feedback
Returns all the existing interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As IOpenMediaInteraction()
Visual C++
array<IOpenMediaInteraction^>^ GetInteractions()

Return Value

The open media interactions as an array.

See Also

IOpenMediaDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IAgent)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteractions Method (IAgent)
IOpenMediaDomain Interface See Also Send Feedback
Retrieves the interactions associated with the given Agent if any; otherwise null.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction[] GetInteractions(
    IAgent agent
)
Visual Basic (Declaration)
Function GetInteractions ( _
    agent As IAgent _
) As IOpenMediaInteraction()
Visual C++
array<IOpenMediaInteraction^>^ GetInteractions(
    IAgent^ agent
)

Parameters

agent
Type: Genesyslab.Enterprise.Agent..::.IAgent
Agent.

Return Value

The array of the interactions associated with the agent; null if no interaction.

See Also

IOpenMediaDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteractions Method (IDevice)
IOpenMediaDomain Interface See Also Send Feedback
Retrieves the interactions associated with the given device, or null if there is no interaction available.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction[] GetInteractions(
    IDevice device
)
Visual Basic (Declaration)
Function GetInteractions ( _
    device As IDevice _
) As IOpenMediaInteraction()
Visual C++
array<IOpenMediaInteraction^>^ GetInteractions(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device.

Return Value

Array of the interactions associated with the device; null if no interaction.

See Also

IOpenMediaDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


GetInteractions Method (String)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.GetInteractions Method (String)
IOpenMediaDomain Interface See Also Send Feedback
Returns the existing interaction(s) associated with the given interaction ID.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction[] GetInteractions(
    string interactionId
)
Visual Basic (Declaration)
Function GetInteractions ( _
    interactionId As String _
) As IOpenMediaInteraction()
Visual C++
array<IOpenMediaInteraction^>^ GetInteractions(
    String^ interactionId
)

Parameters

interactionId
Type: System..::.String
Unique identifier of the interaction.

Return Value

The open media interactions as an array.

See Also

IOpenMediaDomain Interface
GetInteractions Overload
Genesyslab.Enterprise.Services Namespace


RemoveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.RemoveAttachedData Method
IOpenMediaDomain Interface See Also Send Feedback
Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. Asyenchronous operation

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction RemoveAttachedData(
    IOpenMediaInteraction interaction,
    string key
)
Visual Basic (Declaration)
Function RemoveAttachedData ( _
    interaction As IOpenMediaInteraction, _
    key As String _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ RemoveAttachedData(
    IOpenMediaInteraction^ interaction,
    String^ key
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
The interaction.
key
Type: System..::.String
The key of the attached data.

Return Value

The modified interaction.

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveAttachedData Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.SaveAttachedData Method
IOpenMediaDomain Interface See Also Send Feedback
Saves the modifications of the attached data. The update in the back-end server is performed automatically.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction SaveAttachedData(
    IOpenMediaInteraction interaction
)
Visual Basic (Declaration)
Function SaveAttachedData ( _
    interaction As IOpenMediaInteraction _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ SaveAttachedData(
    IOpenMediaInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
The interaction.

Return Value

This IInteraction.

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


SaveInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.SaveInteraction Method
IOpenMediaDomain Interface See Also Send Feedback
Saves the interaction in the service's repository. All data are synchronized with the back-end servers.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaDomain SaveInteraction(
    IOpenMediaInteraction interaction
)
Visual Basic (Declaration)
Function SaveInteraction ( _
    interaction As IOpenMediaInteraction _
) As IOpenMediaDomain
Visual C++
IOpenMediaDomain^ SaveInteraction(
    IOpenMediaInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
Interaction.

Return Value

This domain.

See Also

IOpenMediaDomain Interface
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.SetAttachedData Method
IOpenMediaDomain Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IOpenMediaInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. Asynchronous operation
SetAttachedData(IOpenMediaInteraction, String, Object) | Sets the user defined data as a key-value pair. The update in the back-end server is performed automatically. Asynchronous operation

See Also

IOpenMediaDomain Interface
IOpenMediaDomain Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IOpenMediaInteraction, )

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.SetAttachedData Method (IOpenMediaInteraction, )
IOpenMediaDomain Interface See Also Send Feedback
Attaches several key-value pairs at once. The update in the back-end server is performed automatically. Asynchronous operation

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction SetAttachedData(
    IOpenMediaInteraction interaction,
    KeyValueCollection data
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IOpenMediaInteraction, _
    data As KeyValueCollection _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ SetAttachedData(
    IOpenMediaInteraction^ interaction,
    KeyValueCollection^ data
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
The interaction to modify.
data
Type: KeyValueCollection
The KeyValueCollection data.

Return Value

The modified interaction.

See Also

IOpenMediaDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method (IOpenMediaInteraction, String, Object)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaDomain..::.SetAttachedData Method (IOpenMediaInteraction, String, Object)
IOpenMediaDomain Interface See Also Send Feedback
Sets the user defined data as a key-value pair. The update in the back-end server is performed automatically. Asynchronous operation

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaInteraction SetAttachedData(
    IOpenMediaInteraction interaction,
    string key,
    Object value
)
Visual Basic (Declaration)
Function SetAttachedData ( _
    interaction As IOpenMediaInteraction, _
    key As String, _
    value As Object _
) As IOpenMediaInteraction
Visual C++
IOpenMediaInteraction^ SetAttachedData(
    IOpenMediaInteraction^ interaction,
    String^ key,
    Object^ value
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
Interaction to modify.
key
Type: System..::.String
Key of the pair.
value
Type: System..::.Object
Value of the pair.

Return Value

The modified interaction.

See Also

IOpenMediaDomain Interface
SetAttachedData Overload
Genesyslab.Enterprise.Services Namespace


IOpenMediaService Interface

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService Interface
Members See Also Send Feedback
Manages callback and filters related to open media interaction events.
  • ReasonName Key associated with a string value.
  • ReasonDescription Key associated with a string value.
  • ReasonCode Key associated with an integer value (deprecated in interaction server).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOpenMediaService : IOpenMediaDomain,
    IStrategyManager<IOpenMediaInteraction>, IEventManager<IOpenMediaService, IEnvelope<IInteraction>>,
    IEventManager<IOpenMediaService, IEnvelope<IOpenMediaInteraction>>, IEventManager<IOpenMediaService, IEnvelope<IMonitoredInteraction>>,
    IEventManager<IOpenMediaService, IEnvelope<IMonitoredInfo>>, IChannelMonitor<IOpenMediaService>,
    IBrokerSubscriber<IEnvelope<IInteraction>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>,
    IPersistable<IOpenMediaInteraction>
Visual Basic (Declaration)
Public Interface IOpenMediaService _
    Implements IOpenMediaDomain, IStrategyManager(Of IOpenMediaInteraction),  _
    IEventManager(Of IOpenMediaService, IEnvelope(Of IInteraction)), IEventManager(Of IOpenMediaService, IEnvelope(Of IOpenMediaInteraction)),  _
    IEventManager(Of IOpenMediaService, IEnvelope(Of IMonitoredInteraction)), IEventManager(Of IOpenMediaService, IEnvelope(Of IMonitoredInfo)),  _
    IChannelMonitor(Of IOpenMediaService), IBrokerSubscriber(Of IEnvelope(Of IInteraction)),  _
    IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)), IPersistable(Of IOpenMediaInteraction)
Visual C++
public interface class IOpenMediaService : IOpenMediaDomain,
    IStrategyManager<IOpenMediaInteraction^>, IEventManager<IOpenMediaService^, IEnvelope<IInteraction^>^>,
    IEventManager<IOpenMediaService^, IEnvelope<IOpenMediaInteraction^>^>, IEventManager<IOpenMediaService^, IEnvelope<IMonitoredInteraction^>^>,
    IEventManager<IOpenMediaService^, IEnvelope<IMonitoredInfo^>^>, IChannelMonitor<IOpenMediaService^>,
    IBrokerSubscriber<IEnvelope<IInteraction^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>,
    IPersistable<IOpenMediaInteraction^>

See Also

IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


IOpenMediaService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService Members
IOpenMediaService Interface Methods Properties See Also Send Feedback

The IOpenMediaService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IOpenMediaDomain.)
DeleteInteractions | Deletes all the interactions. (Inherited from IOpenMediaDomain.)
GetAttachedData | Returns the user defined attached data of the given interaction. (Inherited from IOpenMediaDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
MakeInteraction | Creates and submits an Open Media Interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Pull | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. Asyenchronous operation (Inherited from IOpenMediaDomain.)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IOpenMediaDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IOpenMediaDomain.)
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


IOpenMediaService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService Methods
IOpenMediaService Interface See Also Send Feedback

The IOpenMediaService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IOpenMediaDomain.)
DeleteInteractions | Deletes all the interactions. (Inherited from IOpenMediaDomain.)
GetAttachedData | Returns the user defined attached data of the given interaction. (Inherited from IOpenMediaDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
MakeInteraction | Creates and submits an Open Media Interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Pull | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. Asyenchronous operation (Inherited from IOpenMediaDomain.)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IOpenMediaDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IOpenMediaDomain.)
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.CreateInteraction Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID. (Inherited from IOpenMediaDomain.)
CreateInteraction(IOpenMediaInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices. (Inherited from IOpenMediaDomain.)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.GetInteraction Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with the given agent based on the given ID; if the interaction is not associated with this agent, the method returns null. (Inherited from IOpenMediaDomain.)
GetInteraction(IDevice, String) | Retrieves the interaction associated with the given device, or null if no interaction exists or if the interaction is not associated with the device. (Inherited from IOpenMediaDomain.)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.GetInteractions Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions. (Inherited from IOpenMediaDomain.)
GetInteractions(IAgent) | Retrieves the interactions associated with the given Agent if any; otherwise null. (Inherited from IOpenMediaDomain.)
GetInteractions(IDevice) | Retrieves the interactions associated with the given device, or null if there is no interaction available. (Inherited from IOpenMediaDomain.)
GetInteractions(String) | Returns the existing interaction(s) associated with the given interaction ID. (Inherited from IOpenMediaDomain.)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.GetList Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.ListFilter<(Of <(T>)>) Method
IOpenMediaService Interface See Also Send Feedback
Lists the filters registered for the given interaction instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IOpenMediaInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As IOpenMediaInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IOpenMediaInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
Target interaction object.

Type Parameters

T
Type of data handled in filter object

Return Value

IEnumerable<T>

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


MakeInteraction Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.MakeInteraction Method
IOpenMediaService Interface See Also Send Feedback
Creates and submits an Open Media Interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaService MakeInteraction(
    IClientChannel channel,
    IDevice devicePlace,
    string interactionID,
    string mediaType,
    MediaDirectionType direction,
    string interactionSubtype,
    string parentInteractionID,
    string queue,
    KeyValueCollection inputQueues,
    KeyValueCollection outputQueues,
    KeyValueCollection userData,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function MakeInteraction ( _
    channel As IClientChannel, _
    devicePlace As IDevice, _
    interactionID As String, _
    mediaType As String, _
    direction As MediaDirectionType, _
    interactionSubtype As String, _
    parentInteractionID As String, _
    queue As String, _
    inputQueues As KeyValueCollection, _
    outputQueues As KeyValueCollection, _
    userData As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IOpenMediaService
Visual C++
IOpenMediaService^ MakeInteraction(
    IClientChannel^ channel,
    IDevice^ devicePlace,
    String^ interactionID,
    String^ mediaType,
    MediaDirectionType direction,
    String^ interactionSubtype,
    String^ parentInteractionID,
    String^ queue,
    KeyValueCollection^ inputQueues,
    KeyValueCollection^ outputQueues,
    KeyValueCollection^ userData,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel where the interaction should be created.
devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device of type place related to the interaction.
interactionID
Type: System..::.String
An interaction ID or null.
mediaType
Type: System..::.String
The media type of the interaction.
direction
Type: Genesyslab.Enterprise.Model.Protocol..::.MediaDirectionType
The direction of the interaction.
interactionSubtype
Type: System..::.String
The subtype of the interaction
parentInteractionID
Type: System..::.String
The related interaction parent ID, ore null if none.
queue
Type: System..::.String
The queue where to put the created interaction.
inputQueues
Type: KeyValueCollection
The workflow input queues.
outputQueues
Type: KeyValueCollection
The workflow output queues.
userData
Type: KeyValueCollection
The user data.
extensions
Type: KeyValueCollection
The extensions of the interaction.

Return Value

This IOpenMediaService.

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


Pull Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.Pull Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
Pull(IClientChannel, IDevice, String, KeyValueCollection, KeyValueCollection) | Pulls the given multimedia interaction from a queue or a workbin. The interaction is opened on the agent's place.
Pull(IClientChannel, IDevice, String, KeyValueCollection, KeyValueCollection, String) | Pulls the multimedia interaction from a queue or a workbin. The interaction multimedia is opened on the agent place.

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


Pull Method (IClientChannel, IDevice, String, , )

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.Pull Method (IClientChannel, IDevice, String, , )
IOpenMediaService Interface See Also Send Feedback
Pulls the given multimedia interaction from a queue or a workbin. The interaction is opened on the agent's place.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaService Pull(
    IClientChannel channel,
    IDevice placeDevice,
    string interactionID,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Pull ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    interactionID As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IOpenMediaService
Visual C++
IOpenMediaService^ Pull(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    String^ interactionID,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
interactionID
Type: System..::.String
the multimedia interaction identifier.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

This IOpenMediaService.

See Also

IOpenMediaService Interface
Pull Overload
Genesyslab.Enterprise.Services Namespace


Pull Method (IClientChannel, IDevice, String, , , String)

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.Pull Method (IClientChannel, IDevice, String, , , String)
IOpenMediaService Interface See Also Send Feedback
Pulls the multimedia interaction from a queue or a workbin. The interaction multimedia is opened on the agent place.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaService Pull(
    IClientChannel channel,
    IDevice placeDevice,
    string interactionID,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Pull ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    interactionID As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IOpenMediaService
Visual C++
IOpenMediaService^ Pull(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    String^ interactionID,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
interactionID
Type: System..::.String
the multimedia interaction identifier.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.
correlatorData
Type: System..::.String
the correlator data.

Return Value

This IOpenMediaService.

See Also

IOpenMediaService Interface
Pull Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.RegisterEvents Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.RegisterFilter<(Of <(T>)>) Method
IOpenMediaService Interface See Also Send Feedback
Registers a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaService RegisterFilter<T>(
    IOpenMediaInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As IOpenMediaInteraction, _
    filter As T _
) As IOpenMediaService
Visual C++
generic<typename T>
IOpenMediaService^ RegisterFilter(
    IOpenMediaInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
Interaction.
filter
Type: T

[Missing <param name="filter"/> documentation for "M:Genesyslab.Enterprise.Services.IOpenMediaService.RegisterFilter``1(Genesyslab.Enterprise.Model.Interaction.IOpenMediaInteraction,``0)"]

Type Parameters

T
Filter type.

Return Value

IOpenMediaService

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.Save Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.SetAttachedData Method
IOpenMediaService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IOpenMediaInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. Asynchronous operation (Inherited from IOpenMediaDomain.)
SetAttachedData(IOpenMediaInteraction, String, Object) | Sets the user defined data as a key-value pair. The update in the back-end server is performed automatically. Asynchronous operation (Inherited from IOpenMediaDomain.)

See Also

IOpenMediaService Interface
IOpenMediaService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IOpenMediaService..::.UnRegisterFilter<(Of <(T>)>) Method
IOpenMediaService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOpenMediaService UnRegisterFilter<T>(
    IOpenMediaInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As IOpenMediaInteraction, _
    filter As T _
) As IOpenMediaService
Visual C++
generic<typename T>
IOpenMediaService^ UnRegisterFilter(
    IOpenMediaInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IOpenMediaService

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


IOpenMediaService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IOpenMediaService Properties
IOpenMediaService Interface See Also Send Feedback

The IOpenMediaService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IOpenMediaService Interface
Genesyslab.Enterprise.Services Namespace


IOutboundDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain Interface
Members See Also Send Feedback
Manages the data of outbound contacts.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOutboundDomain : IStrategyManager<IChainRecord>
Visual Basic (Declaration)
Public Interface IOutboundDomain _
    Implements IStrategyManager(Of IChainRecord)
Visual C++
public interface class IOutboundDomain : IStrategyManager<IChainRecord^>

See Also

IOutboundDomain Members
Genesyslab.Enterprise.Services Namespace


IOutboundDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundDomain Members
IOutboundDomain Interface Methods See Also Send Feedback

The IOutboundDomain type exposes the following members.

Methods

Name | Description
CreateOutboundField | Creates an OutboundField instance.
CreateRecord | Creates a Record instance.
GetASMCallProcessingPort | Gets the collection of Call Processing Port.
GetOutboundMediaList | Gets the collection of media that are used for outbound preview management. Default is: [outboundpreview]
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetASMCallProcessingPort | Sets ASM Call Processing Port Collection.
SetOutboundMediaList | Sets the list of media that are used for outbound preview management.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


IOutboundDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundDomain Methods
IOutboundDomain Interface See Also Send Feedback

The IOutboundDomain type exposes the following members.

Methods

Name | Description
CreateOutboundField | Creates an OutboundField instance.
CreateRecord | Creates a Record instance.
GetASMCallProcessingPort | Gets the collection of Call Processing Port.
GetOutboundMediaList | Gets the collection of media that are used for outbound preview management. Default is: [outboundpreview]
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetASMCallProcessingPort | Sets ASM Call Processing Port Collection.
SetOutboundMediaList | Sets the list of media that are used for outbound preview management.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateOutboundField Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain..::.CreateOutboundField Method
IOutboundDomain Interface See Also Send Feedback
Creates an OutboundField instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOutboundField CreateOutboundField()
Visual Basic (Declaration)
Function CreateOutboundField As IOutboundField
Visual C++
IOutboundField^ CreateOutboundField()

Return Value

IRecord

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateRecord Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain..::.CreateRecord Method
IOutboundDomain Interface See Also Send Feedback
Creates a Record instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IRecord CreateRecord(
    IChainRecord chainRecord
)
Visual Basic (Declaration)
Function CreateRecord ( _
    chainRecord As IChainRecord _
) As IRecord
Visual C++
IRecord^ CreateRecord(
    IChainRecord^ chainRecord
)

Parameters

chainRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IChainRecord

[Missing <param name="chainRecord"/> documentation for "M:Genesyslab.Enterprise.Services.IOutboundDomain.CreateRecord(Genesyslab.Enterprise.Model.Interaction.IChainRecord)"]

Return Value

IRecord

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


GetASMCallProcessingPort Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain..::.GetASMCallProcessingPort Method
IOutboundDomain Interface See Also Send Feedback
Gets the collection of Call Processing Port.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> GetASMCallProcessingPort()
Visual Basic (Declaration)
Function GetASMCallProcessingPort As ICollection(Of String)
Visual C++
ICollection<String^>^ GetASMCallProcessingPort()

Return Value

Collection of Call Processing Port.

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


GetOutboundMediaList Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain..::.GetOutboundMediaList Method
IOutboundDomain Interface See Also Send Feedback
Gets the collection of media that are used for outbound preview management. Default is: [outboundpreview]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<string> GetOutboundMediaList()
Visual Basic (Declaration)
Function GetOutboundMediaList As ICollection(Of String)
Visual C++
ICollection<String^>^ GetOutboundMediaList()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundDomain.GetOutboundMediaList"]

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


SetASMCallProcessingPort Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain..::.SetASMCallProcessingPort Method
IOutboundDomain Interface See Also Send Feedback
Sets ASM Call Processing Port Collection.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void SetASMCallProcessingPort(
    ICollection<string> asmCPPs
)
Visual Basic (Declaration)
Sub SetASMCallProcessingPort ( _
    asmCPPs As ICollection(Of String) _
)
Visual C++
void SetASMCallProcessingPort(
    ICollection<String^>^ asmCPPs
)

Parameters

asmCPPs
Type: System.Collections.Generic..::.ICollection <(Of <( String >)>)
List of Call Processing Port.

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


SetOutboundMediaList Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundDomain..::.SetOutboundMediaList Method
IOutboundDomain Interface See Also Send Feedback
Sets the list of media that are used for outbound preview management.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void SetOutboundMediaList(
    ICollection<string> mediaList
)
Visual Basic (Declaration)
Sub SetOutboundMediaList ( _
    mediaList As ICollection(Of String) _
)
Visual C++
void SetOutboundMediaList(
    ICollection<String^>^ mediaList
)

Parameters

mediaList
Type: System.Collections.Generic..::.ICollection <(Of <( String >)>)
Collection of media.

See Also

IOutboundDomain Interface
Genesyslab.Enterprise.Services Namespace


IOutboundService Interface

[image]

Enterprise SDK 8.0 Reference API
IOutboundService Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.IOutboundService"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IOutboundService : IOutboundDomain,
    IStrategyManager<IChainRecord>, IEventManager<IOutboundService, IEnvelope<IChainRecord>>,
    IChannelMonitor<IOutboundService>, IBrokerSubscriber<IEnvelope<IChainRecord>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IChainRecord>
Visual Basic (Declaration)
Public Interface IOutboundService _
    Implements IOutboundDomain, IStrategyManager(Of IChainRecord),  _
    IEventManager(Of IOutboundService, IEnvelope(Of IChainRecord)), IChannelMonitor(Of IOutboundService),  _
    IBrokerSubscriber(Of IEnvelope(Of IChainRecord)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IChainRecord)
Visual C++
public interface class IOutboundService : IOutboundDomain,
    IStrategyManager<IChainRecord^>, IEventManager<IOutboundService^, IEnvelope<IChainRecord^>^>,
    IChannelMonitor<IOutboundService^>, IBrokerSubscriber<IEnvelope<IChainRecord^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IChainRecord^>

See Also

IOutboundService Members
Genesyslab.Enterprise.Services Namespace


IOutboundService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService Members
IOutboundService Interface Methods Properties See Also Send Feedback

The IOutboundService type exposes the following members.

Methods

Name | Description
AddChannel
Enables the monitoring of the given channel. Note: This method does not fire events.
(Inherited from IChannelMonitor<(Of <(D>)>).)
AddCustomFields
AddRecord | Overloaded.
AddSystemFields
CancelRecord | Overloaded.
CreateOutboundField
Creates an OutboundField instance.
(Inherited from IOutboundDomain.)
CreateRecord
Creates a Record instance.
(Inherited from IOutboundDomain.)
DoNotCallRecord | Overloaded.
GetAllCustomFields
Gets all the Custom Fields of all Calling List.
GetAllSystemFields
Gets all the System Fields of all Calling Lists.
GetASMCallProcessingPort
Gets the collection of Call Processing Port.
(Inherited from IOutboundDomain.)
GetChainedRecords | Overloaded.
GetChainRecord | Overloaded.
GetChainRecordsByCampaignName
Gets all the chained records related to a campaign.
GetCustomFields
Gets the Custom Fields of the a Calling List.
GetList | Overloaded.
GetOutboundMediaList
Gets the collection of media that are used for outbound preview management. Default is: [outboundpreview]
(Inherited from IOutboundDomain.)
GetPreviewRecord
Gets PreviewRecord from outbound service or from campaign service.
GetSystemFields
Gets the System Fields of the Calling List.
Handle
Processes a publishing event.
(Inherited from ISubscribeable<(Of <(T>)>).)
IsASM
Returns true if the interaction is an ASM call.

Remarks

If true, records may not be already available. As soon as you receive an ATTACHED DATA CHANGED interaction record which contains the Chain ID, you can call the GetChainRecord(IInteraction) or the GetChainedRecords(IInteraction, IRecord, KeyValueCollection, String)method to retrieve the records.
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>)
Lists the filters registered for the given chain instance.
ListStrategies
Gets the list of strategies for an object.
(Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>)
Publishes an object to listening subscribers.
(Inherited from IBrokerPublisher.)
RecordProcessed | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>)
Registers a filter for a given chain.
RejectRecord | Overloaded.
RemoveAllStrategies
Removes all strategies.
(Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel
Removes the given channel from the monitoring list. No events are received anymore for this channel.
(Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveCustomFields
Removes Custom Fields from a Calling List.
RemoveStrategy
Removes a strategy of an object.
(Inherited from IStrategyManager<(Of <(T>)>).)
RemoveSystemFields
Removes System Fields of a Calling List.
RescheduledRecord | Overloaded.
Save | Overloaded.
SetASMCallProcessingPort
Sets ASM Call Processing Port Collection.
(Inherited from IOutboundDomain.)
SetOutboundMediaList
Sets the list of media that are used for outbound preview management.
(Inherited from IOutboundDomain.)
SetStrategy
Sets a strategy to an object.
(Inherited from IStrategyManager<(Of <(T>)>).)
SubscribeTopic
Subscribes to outbound event topics for multimedia outbound interactions.

Remarks

This method enables you to receives outbound events from the Interaction Server in response to commands modifying the interaction's attached data; for instance, AddRecord, AcceptRecord, RejectRecord, and so on.
UnRegisterEvents
Unregisters a specific handler for a given channel.
(Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>)
Unregisters a filter for a given chaine.
UnsubscribeTopic
Unsubscribes to outbound event topic.
UpdateRecord | Overloaded.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


IOutboundService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService Methods
IOutboundService Interface See Also Send Feedback

The IOutboundService type exposes the following members.

Methods

Name | Description
AddChannel
Enables the monitoring of the given channel. Note: This method does not fire events.
(Inherited from IChannelMonitor<(Of <(D>)>).)
AddCustomFields
AddRecord | Overloaded.
AddSystemFields
CancelRecord | Overloaded.
CreateOutboundField
Creates an OutboundField instance.
(Inherited from IOutboundDomain.)
CreateRecord
Creates a Record instance.
(Inherited from IOutboundDomain.)
DoNotCallRecord | Overloaded.
GetAllCustomFields
Gets all the Custom Fields of all Calling List.
GetAllSystemFields
Gets all the System Fields of all Calling Lists.
GetASMCallProcessingPort
Gets the collection of Call Processing Port.
(Inherited from IOutboundDomain.)
GetChainedRecords | Overloaded.
GetChainRecord | Overloaded.
GetChainRecordsByCampaignName
Gets all the chained records related to a campaign.
GetCustomFields
Gets the Custom Fields of the a Calling List.
GetList | Overloaded.
GetOutboundMediaList
Gets the collection of media that are used for outbound preview management. Default is: [outboundpreview]
(Inherited from IOutboundDomain.)
GetPreviewRecord
Gets PreviewRecord from outbound service or from campaign service.
GetSystemFields
Gets the System Fields of the Calling List.
Handle
Processes a publishing event.
(Inherited from ISubscribeable<(Of <(T>)>).)
IsASM
Returns true if the interaction is an ASM call.

Remarks

If true, records may not be already available. As soon as you receive an ATTACHED DATA CHANGED interaction record which contains the Chain ID, you can call the GetChainRecord(IInteraction) or the GetChainedRecords(IInteraction, IRecord, KeyValueCollection, String)method to retrieve the records.
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>)
Lists the filters registered for the given chain instance.
ListStrategies
Gets the list of strategies for an object.
(Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>)
Publishes an object to listening subscribers.
(Inherited from IBrokerPublisher.)
RecordProcessed | Overloaded.
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>)
Registers a filter for a given chain.
RejectRecord | Overloaded.
RemoveAllStrategies
Removes all strategies.
(Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel
Removes the given channel from the monitoring list. No events are received anymore for this channel.
(Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveCustomFields
Removes Custom Fields from a Calling List.
RemoveStrategy
Removes a strategy of an object.
(Inherited from IStrategyManager<(Of <(T>)>).)
RemoveSystemFields
Removes System Fields of a Calling List.
RescheduledRecord | Overloaded.
Save | Overloaded.
SetASMCallProcessingPort
Sets ASM Call Processing Port Collection.
(Inherited from IOutboundDomain.)
SetOutboundMediaList
Sets the list of media that are used for outbound preview management.
(Inherited from IOutboundDomain.)
SetStrategy
Sets a strategy to an object.
(Inherited from IStrategyManager<(Of <(T>)>).)
SubscribeTopic
Subscribes to outbound event topics for multimedia outbound interactions.

Remarks

This method enables you to receives outbound events from the Interaction Server in response to commands modifying the interaction's attached data; for instance, AddRecord, AcceptRecord, RejectRecord, and so on.
UnRegisterEvents
Unregisters a specific handler for a given channel.
(Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>)
Unregisters a filter for a given chaine.
UnsubscribeTopic
Unsubscribes to outbound event topic.
UpdateRecord | Overloaded.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


AddCustomFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.AddCustomFields Method
IOutboundService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddCustomFields(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.Interaction.IOutboundField})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddCustomFields(
    string callingListName,
    IDictionary<string, IOutboundField> customFields
)
Visual Basic (Declaration)
Sub AddCustomFields ( _
    callingListName As String, _
    customFields As IDictionary(Of String, IOutboundField) _
)
Visual C++
void AddCustomFields(
    String^ callingListName,
    IDictionary<String^, IOutboundField^>^ customFields
)

Parameters

callingListName
Type: System..::.String

[Missing <param name="callingListName"/> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddCustomFields(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.Interaction.IOutboundField})"]

customFields
Type: System.Collections.Generic..::.IDictionary <(Of <( String, IOutboundField >)>)

[Missing <param name="customFields"/> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddCustomFields(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.Interaction.IOutboundField})"]

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


AddRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.AddRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
AddRecord(IDevice, IRecord, KeyValueCollection, String) | Adds a record to the current chain.
AddRecord(IInteraction, IRecord, KeyValueCollection, String) | Adds a record to the current interaction.
AddRecord(IDevice, IRecord, KeyValueCollection, String, Int32) | Adds a record to the current chain.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


AddRecord Method (IDevice, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.AddRecord Method (IDevice, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Adds a record to the current chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddRecord(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub AddRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void AddRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The record created with CreateRecord method.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
AddRecord Overload
Genesyslab.Enterprise.Services Namespace


AddRecord Method (IInteraction, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.AddRecord Method (IInteraction, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Adds a record to the current interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddRecord(
    IInteraction interaction,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub AddRecord ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void AddRecord(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
AddRecord Overload
Genesyslab.Enterprise.Services Namespace


AddRecord Method (IDevice, IRecord, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.AddRecord Method (IDevice, IRecord, , String, Int32)
IOutboundService Interface See Also Send Feedback
Adds a record to the current chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> AddRecord(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function AddRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ AddRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The record created with CreateRecord method.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddRecord(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
AddRecord Overload
Genesyslab.Enterprise.Services Namespace


AddSystemFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.AddSystemFields Method
IOutboundService Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddSystemFields(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.Interaction.IOutboundField})"]

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddSystemFields(
    string callingListName,
    IDictionary<string, IOutboundField> customFields
)
Visual Basic (Declaration)
Sub AddSystemFields ( _
    callingListName As String, _
    customFields As IDictionary(Of String, IOutboundField) _
)
Visual C++
void AddSystemFields(
    String^ callingListName,
    IDictionary<String^, IOutboundField^>^ customFields
)

Parameters

callingListName
Type: System..::.String

[Missing <param name="callingListName"/> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddSystemFields(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.Interaction.IOutboundField})"]

customFields
Type: System.Collections.Generic..::.IDictionary <(Of <( String, IOutboundField >)>)

[Missing <param name="customFields"/> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.AddSystemFields(System.String,System.Collections.Generic.IDictionary{System.String,Genesyslab.Enterprise.Model.Interaction.IOutboundField})"]

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


CancelRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.CancelRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
CancelRecord(IDevice, IRecord, Boolean, KeyValueCollection, String) | Cancels the record of the chain.
CancelRecord(IInteraction, IRecord, Boolean, KeyValueCollection, String) | Cancels the record of the chain.
CancelRecord(IDevice, IRecord, Boolean, KeyValueCollection, String, Int32) | Cancels the record of the chain.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


CancelRecord Method (IDevice, IRecord, Boolean, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.CancelRecord Method (IDevice, IRecord, Boolean, , String)
IOutboundService Interface See Also Send Feedback
Cancels the record of the chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void CancelRecord(
    IDevice device,
    IRecord dataRecord,
    bool applyToChain,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub CancelRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    applyToChain As Boolean, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void CancelRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    bool applyToChain,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
applyToChain
Type: System..::.Boolean
True if applied to chain, false only to the record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
CancelRecord Overload
Genesyslab.Enterprise.Services Namespace


CancelRecord Method (IInteraction, IRecord, Boolean, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.CancelRecord Method (IInteraction, IRecord, Boolean, , String)
IOutboundService Interface See Also Send Feedback
Cancels the record of the chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void CancelRecord(
    IInteraction interaction,
    IRecord dataRecord,
    bool applyToChain,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub CancelRecord ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    applyToChain As Boolean, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void CancelRecord(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    bool applyToChain,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
applyToChain
Type: System..::.Boolean
True if applied to chain, false only to the record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
CancelRecord Overload
Genesyslab.Enterprise.Services Namespace


CancelRecord Method (IDevice, IRecord, Boolean, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.CancelRecord Method (IDevice, IRecord, Boolean, , String, Int32)
IOutboundService Interface See Also Send Feedback
Cancels the record of the chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> CancelRecord(
    IDevice device,
    IRecord dataRecord,
    bool applyToChain,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function CancelRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    applyToChain As Boolean, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ CancelRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    bool applyToChain,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
applyToChain
Type: System..::.Boolean
True if applied to chain, false only to the record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.CancelRecord(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,System.Boolean,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
CancelRecord Overload
Genesyslab.Enterprise.Services Namespace


DoNotCallRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.DoNotCallRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
DoNotCallRecord(IDevice, IRecord, String, Boolean, KeyValueCollection, String) | Marks the record of the chain as Do Not Call.
DoNotCallRecord(IInteraction, IRecord, String, Boolean, KeyValueCollection, String) | Marks the record of the chain as Do Not Call.
DoNotCallRecord(IDevice, IRecord, String, Boolean, KeyValueCollection, String, Int32) | Marks the record of the chain as Do Not Call.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


DoNotCallRecord Method (IDevice, IRecord, String, Boolean, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.DoNotCallRecord Method (IDevice, IRecord, String, Boolean, , String)
IOutboundService Interface See Also Send Feedback
Marks the record of the chain as Do Not Call.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void DoNotCallRecord(
    IDevice device,
    IRecord dataRecord,
    string reason,
    bool applyToChain,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub DoNotCallRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    reason As String, _
    applyToChain As Boolean, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void DoNotCallRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    String^ reason,
    bool applyToChain,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
reason
Type: System..::.String
The reason.
applyToChain
Type: System..::.Boolean
True if applied to chain, false only to the record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
DoNotCallRecord Overload
Genesyslab.Enterprise.Services Namespace


DoNotCallRecord Method (IInteraction, IRecord, String, Boolean, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.DoNotCallRecord Method (IInteraction, IRecord, String, Boolean, , String)
IOutboundService Interface See Also Send Feedback
Marks the record of the chain as Do Not Call.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void DoNotCallRecord(
    IInteraction interaction,
    IRecord dataRecord,
    string reason,
    bool applyToChain,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub DoNotCallRecord ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    reason As String, _
    applyToChain As Boolean, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void DoNotCallRecord(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    String^ reason,
    bool applyToChain,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
reason
Type: System..::.String
The reason.
applyToChain
Type: System..::.Boolean
True if applied to chain, false only to the record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
DoNotCallRecord Overload
Genesyslab.Enterprise.Services Namespace


DoNotCallRecord Method (IDevice, IRecord, String, Boolean, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.DoNotCallRecord Method (IDevice, IRecord, String, Boolean, , String, Int32)
IOutboundService Interface See Also Send Feedback
Marks the record of the chain as Do Not Call.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> DoNotCallRecord(
    IDevice device,
    IRecord dataRecord,
    string reason,
    bool applyToChain,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function DoNotCallRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    reason As String, _
    applyToChain As Boolean, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ DoNotCallRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    String^ reason,
    bool applyToChain,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
reason
Type: System..::.String
The reason.
applyToChain
Type: System..::.Boolean
True if applied to chain, false only to the record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time out.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.DoNotCallRecord(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,System.String,System.Boolean,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
DoNotCallRecord Overload
Genesyslab.Enterprise.Services Namespace


GetAllCustomFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetAllCustomFields Method
IOutboundService Interface See Also Send Feedback
Gets all the Custom Fields of all Calling List.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDictionary<string, IOutboundField>> GetAllCustomFields()
Visual Basic (Declaration)
Function GetAllCustomFields As IDictionary(Of String, IDictionary(Of String, IOutboundField))
Visual C++
IDictionary<String^, IDictionary<String^, IOutboundField^>^>^ GetAllCustomFields()

Return Value

All the Custom Fields of Calling List.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


GetAllSystemFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetAllSystemFields Method
IOutboundService Interface See Also Send Feedback
Gets all the System Fields of all Calling Lists.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDictionary<string, IOutboundField>> GetAllSystemFields()
Visual Basic (Declaration)
Function GetAllSystemFields As IDictionary(Of String, IDictionary(Of String, IOutboundField))
Visual C++
IDictionary<String^, IDictionary<String^, IOutboundField^>^>^ GetAllSystemFields()

Return Value

All the Custom Fields of Calling Lists.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


GetChainedRecords Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainedRecords Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
GetChainedRecords(IDevice, IRecord, KeyValueCollection, String) | Gets the chained records of this given record.
GetChainedRecords(IInteraction, IRecord, KeyValueCollection, String) | Gets the chained records of this given record.
GetChainedRecords(IDevice, IRecord, KeyValueCollection, String, Int32) | Gets the chained records of this given record.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


GetChainedRecords Method (IDevice, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainedRecords Method (IDevice, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Gets the chained records of this given record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void GetChainedRecords(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub GetChainedRecords ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void GetChainedRecords(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
GetChainedRecords Overload
Genesyslab.Enterprise.Services Namespace


GetChainedRecords Method (IInteraction, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainedRecords Method (IInteraction, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Gets the chained records of this given record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void GetChainedRecords(
    IInteraction interaction,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub GetChainedRecords ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void GetChainedRecords(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
GetChainedRecords Overload
Genesyslab.Enterprise.Services Namespace


GetChainedRecords Method (IDevice, IRecord, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainedRecords Method (IDevice, IRecord, , String, Int32)
IOutboundService Interface See Also Send Feedback
Gets the chained records of this given record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> GetChainedRecords(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function GetChainedRecords ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ GetChainedRecords(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.GetChainedRecords(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
GetChainedRecords Overload
Genesyslab.Enterprise.Services Namespace


GetChainRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name Description
GetChainRecord(IInteraction)
Gets the ChainRecord of the interaction if it exists. To get more than one chained record, see GetChainedRecords(IInteraction, IRecord, KeyValueCollection, String).

Remarks

You can use this method on any ASM call to check if it is an outbound progressive or predictive call.
GetChainRecord(IInteraction, KeyValueCollection)
Gets the ChainRecord of the interaction if it exists with another root collection of attached data. Uses this method only for consultation purpose. This method does not manage outbound record life cycle.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


GetChainRecord Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainRecord Method (IInteraction)
IOutboundService Interface See Also Send Feedback
Gets the ChainRecord of the interaction if it exists. To get more than one chained record, see GetChainedRecords(IInteraction, IRecord, KeyValueCollection, String).

Remarks

You can use this method on any ASM call to check if it is an outbound progressive or predictive call.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChainRecord GetChainRecord(
    IInteraction interaction
)
Visual Basic (Declaration)
Function GetChainRecord ( _
    interaction As IInteraction _
) As IChainRecord
Visual C++
IChainRecord^ GetChainRecord(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction that contains outbound record.

Return Value

A ChainRecord or null if it does not part of an outbound call.

See Also

IOutboundService Interface
GetChainRecord Overload
Genesyslab.Enterprise.Services Namespace


GetChainRecord Method (IInteraction, )

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainRecord Method (IInteraction, )
IOutboundService Interface See Also Send Feedback
Gets the ChainRecord of the interaction if it exists with another root collection of attached data. Uses this method only for consultation purpose. This method does not manage outbound record life cycle.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChainRecord GetChainRecord(
    IInteraction interaction,
    KeyValueCollection attachedData
)
Visual Basic (Declaration)
Function GetChainRecord ( _
    interaction As IInteraction, _
    attachedData As KeyValueCollection _
) As IChainRecord
Visual C++
IChainRecord^ GetChainRecord(
    IInteraction^ interaction,
    KeyValueCollection^ attachedData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction that contains outbound record.
attachedData
Type: KeyValueCollection
Another root collection of attached data (sub-list of attached data from interaction).

Return Value

A ChainRecord or null if it does not part of an outbound call.

See Also

IOutboundService Interface
GetChainRecord Overload
Genesyslab.Enterprise.Services Namespace


GetChainRecordsByCampaignName Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetChainRecordsByCampaignName Method
IOutboundService Interface See Also Send Feedback
Gets all the chained records related to a campaign.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IChainRecord[] GetChainRecordsByCampaignName(
    string campaignName
)
Visual Basic (Declaration)
Function GetChainRecordsByCampaignName ( _
    campaignName As String _
) As IChainRecord()
Visual C++
array<IChainRecord^>^ GetChainRecordsByCampaignName(
    String^ campaignName
)

Parameters

campaignName
Type: System..::.String
Campaign name

Return Value

IChainRecord[]

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


GetCustomFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetCustomFields Method
IOutboundService Interface See Also Send Feedback
Gets the Custom Fields of the a Calling List.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IOutboundField> GetCustomFields(
    string callingListName
)
Visual Basic (Declaration)
Function GetCustomFields ( _
    callingListName As String _
) As IDictionary(Of String, IOutboundField)
Visual C++
IDictionary<String^, IOutboundField^>^ GetCustomFields(
    String^ callingListName
)

Parameters

callingListName
Type: System..::.String
The Calling List name.

Return Value

The Custom Fields of this Calling List.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetList Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


GetPreviewRecord Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetPreviewRecord Method
IOutboundService Interface See Also Send Feedback
Gets PreviewRecord from outbound service or from campaign service.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void GetPreviewRecord(
    ICampaign campaign,
    string correlatorData
)
Visual Basic (Declaration)
Sub GetPreviewRecord ( _
    campaign As ICampaign, _
    correlatorData As String _
)
Visual C++
void GetPreviewRecord(
    ICampaign^ campaign,
    String^ correlatorData
)

Parameters

campaign
Type: Genesyslab.Enterprise.Model.Interaction..::.ICampaign
The Campaign info.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


GetSystemFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.GetSystemFields Method
IOutboundService Interface See Also Send Feedback
Gets the System Fields of the Calling List.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IOutboundField> GetSystemFields(
    string callingListName
)
Visual Basic (Declaration)
Function GetSystemFields ( _
    callingListName As String _
) As IDictionary(Of String, IOutboundField)
Visual C++
IDictionary<String^, IOutboundField^>^ GetSystemFields(
    String^ callingListName
)

Parameters

callingListName
Type: System..::.String
The Calling List name.

Return Value

The Custom Fields of this Calling List.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


IsASM Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.IsASM Method
IOutboundService Interface See Also Send Feedback
Returns true if the interaction is an ASM call.

Remarks

If true, records may not be already available. As soon as you receive an ATTACHED DATA CHANGED interaction record which contains the Chain ID, you can call the GetChainRecord(IInteraction) or the GetChainedRecords(IInteraction, IRecord, KeyValueCollection, String)method to retrieve the records.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsASM(
    IInteraction interaction
)
Visual Basic (Declaration)
Function IsASM ( _
    interaction As IInteraction _
) As Boolean
Visual C++
bool IsASM(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.IsASM(Genesyslab.Enterprise.Model.Interaction.IInteraction)"]

Return Value

true if ASM is engaging.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.ListFilter<(Of <(T>)>) Method
IOutboundService Interface See Also Send Feedback
Lists the filters registered for the given chain instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IChainRecord chain
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    chain As IChainRecord _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IChainRecord^ chain
)

Parameters

chain
Type: Genesyslab.Enterprise.Model.Interaction..::.IChainRecord
Target chaine object.

Type Parameters

T
Type of data handled in filter object.

Return Value

IEnumerable<T>

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


RecordProcessed Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RecordProcessed Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
RecordProcessed(IDevice, IRecord, KeyValueCollection, String) | Marks the record as processed. Call Result is set in the record.
RecordProcessed(IInteraction, IRecord, KeyValueCollection, String) | Marks the record as processed. Call Result is set in the record.
RecordProcessed(IDevice, IRecord, KeyValueCollection, String, Int32) | Marks the record as processed. Call Result is set in the record.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


RecordProcessed Method (IDevice, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RecordProcessed Method (IDevice, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Marks the record as processed. Call Result is set in the record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RecordProcessed(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RecordProcessed ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RecordProcessed(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
RecordProcessed Overload
Genesyslab.Enterprise.Services Namespace


RecordProcessed Method (IInteraction, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RecordProcessed Method (IInteraction, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Marks the record as processed. Call Result is set in the record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RecordProcessed(
    IInteraction interaction,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RecordProcessed ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RecordProcessed(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
RecordProcessed Overload
Genesyslab.Enterprise.Services Namespace


RecordProcessed Method (IDevice, IRecord, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RecordProcessed Method (IDevice, IRecord, , String, Int32)
IOutboundService Interface See Also Send Feedback
Marks the record as processed. Call Result is set in the record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> RecordProcessed(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function RecordProcessed ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ RecordProcessed(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time out.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.RecordProcessed(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
RecordProcessed Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RegisterEvents Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RegisterFilter<(Of <(T>)>) Method
IOutboundService Interface See Also Send Feedback
Registers a filter for a given chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOutboundService RegisterFilter<T>(
    IChainRecord chain,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    chain As IChainRecord, _
    filter As T _
) As IOutboundService
Visual C++
generic<typename T>
IOutboundService^ RegisterFilter(
    IChainRecord^ chain,
    T filter
)

Parameters

chain
Type: Genesyslab.Enterprise.Model.Interaction..::.IChainRecord
The Chain Record.
filter
Type: T
The Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IOutboundService

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


RejectRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RejectRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
RejectRecord(IDevice, IRecord, KeyValueCollection, String) | Rejects the Record.
RejectRecord(IInteraction, IRecord, KeyValueCollection, String) | Rejects the Record.
RejectRecord(IDevice, IRecord, KeyValueCollection, String, Int32) | Rejects the Record.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


RejectRecord Method (IDevice, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RejectRecord Method (IDevice, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Rejects the Record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RejectRecord(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RejectRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RejectRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
RejectRecord Overload
Genesyslab.Enterprise.Services Namespace


RejectRecord Method (IInteraction, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RejectRecord Method (IInteraction, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Rejects the Record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RejectRecord(
    IInteraction interaction,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RejectRecord ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RejectRecord(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
RejectRecord Overload
Genesyslab.Enterprise.Services Namespace


RejectRecord Method (IDevice, IRecord, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RejectRecord Method (IDevice, IRecord, , String, Int32)
IOutboundService Interface See Also Send Feedback
Rejects the Record.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> RejectRecord(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function RejectRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ RejectRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.RejectRecord(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
RejectRecord Overload
Genesyslab.Enterprise.Services Namespace


RemoveCustomFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RemoveCustomFields Method
IOutboundService Interface See Also Send Feedback
Removes Custom Fields from a Calling List.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveCustomFields(
    string callingListName
)
Visual Basic (Declaration)
Sub RemoveCustomFields ( _
    callingListName As String _
)
Visual C++
void RemoveCustomFields(
    String^ callingListName
)

Parameters

callingListName
Type: System..::.String
The Calling List name.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


RemoveSystemFields Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RemoveSystemFields Method
IOutboundService Interface See Also Send Feedback
Removes System Fields of a Calling List.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveSystemFields(
    string callingListName
)
Visual Basic (Declaration)
Sub RemoveSystemFields ( _
    callingListName As String _
)
Visual C++
void RemoveSystemFields(
    String^ callingListName
)

Parameters

callingListName
Type: System..::.String
The Calling List name.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


RescheduledRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RescheduledRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
RescheduledRecord(IDevice, IRecord, DateTime, CallBackType, KeyValueCollection, String) | Re-schedules the record of chain.
RescheduledRecord(IInteraction, IRecord, DateTime, CallBackType, KeyValueCollection, String) | Re-schedules the record of chain.
RescheduledRecord(IDevice, IRecord, DateTime, CallBackType, KeyValueCollection, String, Int32) | Re-schedules the record of chain.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


RescheduledRecord Method (IDevice, IRecord, DateTime, CallBackType, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RescheduledRecord Method (IDevice, IRecord, DateTime, CallBackType, , String)
IOutboundService Interface See Also Send Feedback
Re-schedules the record of chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RescheduledRecord(
    IDevice device,
    IRecord dataRecord,
    DateTime scheduledDate,
    CallBackType callback,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RescheduledRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    scheduledDate As DateTime, _
    callback As CallBackType, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RescheduledRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    DateTime scheduledDate,
    CallBackType callback,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
scheduledDate
Type: System..::.DateTime
The scheduled date.
callback
Type: Genesyslab.Enterprise.Services..::.CallBackType
The callback type.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
RescheduledRecord Overload
Genesyslab.Enterprise.Services Namespace


RescheduledRecord Method (IInteraction, IRecord, DateTime, CallBackType, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RescheduledRecord Method (IInteraction, IRecord, DateTime, CallBackType, , String)
IOutboundService Interface See Also Send Feedback
Re-schedules the record of chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RescheduledRecord(
    IInteraction interaction,
    IRecord dataRecord,
    DateTime scheduledDate,
    CallBackType callback,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub RescheduledRecord ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    scheduledDate As DateTime, _
    callback As CallBackType, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void RescheduledRecord(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    DateTime scheduledDate,
    CallBackType callback,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
scheduledDate
Type: System..::.DateTime
The scheduled date.
callback
Type: Genesyslab.Enterprise.Services..::.CallBackType
The callback type.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
RescheduledRecord Overload
Genesyslab.Enterprise.Services Namespace


RescheduledRecord Method (IDevice, IRecord, DateTime, CallBackType, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.RescheduledRecord Method (IDevice, IRecord, DateTime, CallBackType, , String, Int32)
IOutboundService Interface See Also Send Feedback
Re-schedules the record of chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> RescheduledRecord(
    IDevice device,
    IRecord dataRecord,
    DateTime scheduledDate,
    CallBackType callback,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function RescheduledRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    scheduledDate As DateTime, _
    callback As CallBackType, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ RescheduledRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    DateTime scheduledDate,
    CallBackType callback,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
scheduledDate
Type: System..::.DateTime
The scheduled date.
callback
Type: Genesyslab.Enterprise.Services..::.CallBackType
The callback type.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.RescheduledRecord(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,System.DateTime,Genesyslab.Enterprise.Services.CallBackType,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
RescheduledRecord Overload
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.Save Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


SubscribeTopic Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.SubscribeTopic Method
IOutboundService Interface See Also Send Feedback
Subscribes to outbound event topics for multimedia outbound interactions.

Remarks

This method enables you to receives outbound events from the Interaction Server in response to commands modifying the interaction's attached data; for instance, AddRecord, AcceptRecord, RejectRecord, and so on.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void SubscribeTopic(
    IClientChannel channel,
    IDevice place,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub SubscribeTopic ( _
    channel As IClientChannel, _
    place As IDevice, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void SubscribeTopic(
    IClientChannel^ channel,
    IDevice^ place,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The Open Media Channel.
place
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Place device.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.UnRegisterFilter<(Of <(T>)>) Method
IOutboundService Interface See Also Send Feedback
Unregisters a filter for a given chaine.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IOutboundService UnRegisterFilter<T>(
    IChainRecord chain,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    chain As IChainRecord, _
    filter As T _
) As IOutboundService
Visual C++
generic<typename T>
IOutboundService^ UnRegisterFilter(
    IChainRecord^ chain,
    T filter
)

Parameters

chain
Type: Genesyslab.Enterprise.Model.Interaction..::.IChainRecord
The Chain Record.
filter
Type: T
The Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IOutboundService

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


UnsubscribeTopic Method

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.UnsubscribeTopic Method
IOutboundService Interface See Also Send Feedback
Unsubscribes to outbound event topic.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void UnsubscribeTopic(
    IClientChannel channel,
    IDevice place,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub UnsubscribeTopic ( _
    channel As IClientChannel, _
    place As IDevice, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void UnsubscribeTopic(
    IClientChannel^ channel,
    IDevice^ place,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The Open Media Channel.
place
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Place device.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


UpdateRecord Method

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.UpdateRecord Method
IOutboundService Interface See Also Send Feedback

Overload List

Name | Description
UpdateRecord(IDevice, IRecord, KeyValueCollection, String) | Updates the record of the chain.
UpdateRecord(IInteraction, IRecord, KeyValueCollection, String) | Updates the record of the chain.
UpdateRecord(IDevice, IRecord, KeyValueCollection, String, Int32) | Updates the record of the chain.

See Also

IOutboundService Interface
IOutboundService Members
Genesyslab.Enterprise.Services Namespace


UpdateRecord Method (IDevice, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.UpdateRecord Method (IDevice, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Updates the record of the chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void UpdateRecord(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub UpdateRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void UpdateRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
UpdateRecord Overload
Genesyslab.Enterprise.Services Namespace


UpdateRecord Method (IInteraction, IRecord, , String)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.UpdateRecord Method (IInteraction, IRecord, , String)
IOutboundService Interface See Also Send Feedback
Updates the record of the chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void UpdateRecord(
    IInteraction interaction,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData
)
Visual Basic (Declaration)
Sub UpdateRecord ( _
    interaction As IInteraction, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String _
)
Visual C++
void UpdateRecord(
    IInteraction^ interaction,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The Interaction (Voice or OpenMedia).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.

See Also

IOutboundService Interface
UpdateRecord Overload
Genesyslab.Enterprise.Services Namespace


UpdateRecord Method (IDevice, IRecord, , String, Int32)

[image]

Enterprise SDK 8.0 Reference API
IOutboundService..::.UpdateRecord Method (IDevice, IRecord, , String, Int32)
IOutboundService Interface See Also Send Feedback
Updates the record of the chain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<IChainRecord> UpdateRecord(
    IDevice device,
    IRecord dataRecord,
    KeyValueCollection extension,
    string correlatorData,
    int timeOut
)
Visual Basic (Declaration)
Function UpdateRecord ( _
    device As IDevice, _
    dataRecord As IRecord, _
    extension As KeyValueCollection, _
    correlatorData As String, _
    timeOut As Integer _
) As IEnvelope(Of IChainRecord)
Visual C++
IEnvelope<IChainRecord^>^ UpdateRecord(
    IDevice^ device,
    IRecord^ dataRecord,
    KeyValueCollection^ extension,
    String^ correlatorData,
    int timeOut
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The Device (DN or Place).
dataRecord
Type: Genesyslab.Enterprise.Model.Interaction..::.IRecord
The Record.
extension
Type: KeyValueCollection
The extension.
correlatorData
Type: System..::.String
The Correlator data.
timeOut
Type: System..::.Int32
The request time.

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.IOutboundService.UpdateRecord(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Model.Interaction.IRecord,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.String,System.Int32)"]

See Also

IOutboundService Interface
UpdateRecord Overload
Genesyslab.Enterprise.Services Namespace


IOutboundService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IOutboundService Properties
IOutboundService Interface See Also Send Feedback

The IOutboundService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IOutboundService Interface
Genesyslab.Enterprise.Services Namespace


IPreviewDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewDomain Interface
See Also Send Feedback
Preview Interaction domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPreviewDomain
Visual Basic (Declaration)
Public Interface IPreviewDomain
Visual C++
public interface class IPreviewDomain

See Also

Genesyslab.Enterprise.Services Namespace


IPreviewService Interface

[image]

Enterprise SDK 8.0 Reference API
IPreviewService Interface
Members See Also Send Feedback
Manages the Preview Interaction features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPreviewService : IPreviewDomain,
    IBrokerPublisher
Visual Basic (Declaration)
Public Interface IPreviewService _
    Implements IPreviewDomain, IBrokerPublisher
Visual C++
public interface class IPreviewService : IPreviewDomain,
    IBrokerPublisher

See Also

IPreviewService Members
Genesyslab.Enterprise.Services Namespace


IPreviewService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewService Members
IPreviewService Interface Methods See Also Send Feedback

The IPreviewService type exposes the following members.

Methods

Name | Description
Accept | Accepts to preview the interaction.
Decline | Declines to preview the interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


IPreviewService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPreviewService Methods
IPreviewService Interface See Also Send Feedback

The IPreviewService type exposes the following members.

Methods

Name | Description
Accept | Accepts to preview the interaction.
Decline | Declines to preview the interaction.
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


Accept Method

[image]

Enterprise SDK 8.0 Reference API
IPreviewService..::.Accept Method
IPreviewService Interface See Also Send Feedback
Accepts to preview the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Accept(
    IInteraction interaction
)
Visual Basic (Declaration)
Sub Accept ( _
    interaction As IInteraction _
)
Visual C++
void Accept(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Preview Interaction. An interaction in InteractionStateType.Preview state.

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


Decline Method

[image]

Enterprise SDK 8.0 Reference API
IPreviewService..::.Decline Method
IPreviewService Interface See Also Send Feedback
Declines to preview the interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Decline(
    IInteraction interaction
)
Visual Basic (Declaration)
Sub Decline ( _
    interaction As IInteraction _
)
Visual C++
void Decline(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Preview Interaction. This interaction is in InteractionStateType.Preview state.

See Also

IPreviewService Interface
Genesyslab.Enterprise.Services Namespace


IPSTService Interface

[image]

Enterprise SDK 8.0 Reference API
IPSTService Interface
Members See Also Send Feedback
Provides Possible State Transition (PST) information. The isPossible methods of this service use the loaded stategies and the given objects' data (including its own status and strategies) to determine whether a requested action can be processed. The isCapable methods of this service use the loaded strategies to indicate whether the feature is available regardless of the object status. For instance, if your switch does not provide a mute feature, the isCapable methods return false for the ProtocolAction.MuteOn action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IPSTService
Visual Basic (Declaration)
Public Interface IPSTService
Visual C++
public interface class IPSTService

Remarks

Make sure that you do not pass deprecated references when calling the methods of this service. On events, ESDK updates core objects (interactions, agents, DNs, and so on.) and provides your application with a new copy of the updated object, but ESDK does not update this copy with further events. As a result, if you pass a reference on an old copy instead of the most recent one to this service, it returns deprecated results instead of the current possible state transitions for this object.

See Also

IPSTService Members
Genesyslab.Enterprise.Services Namespace


IPSTService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService Members
IPSTService Interface Methods See Also Send Feedback

Methods

Name | Description
AreCapable | Overloaded.
ArePossible | Overloaded.
IsCapable | Overloaded.
IsPossible | Overloaded.

See Also

IPSTService Interface
Genesyslab.Enterprise.Services Namespace


IPSTService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService Methods
IPSTService Interface See Also Send Feedback

Methods

Name | Description
AreCapable | Overloaded.
ArePossible | Overloaded.
IsCapable | Overloaded.
IsPossible | Overloaded.

See Also

IPSTService Interface
Genesyslab.Enterprise.Services Namespace


AreCapable Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
AreCapable(IClientChannel) | Returns the list of actions that the given channel supports as a table of bool values.
AreCapable(String) | Returns the list of actions that the given channel supports as a table of bool values.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


AreCapable Method (IClientChannel)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method (IClientChannel)
IPSTService Interface See Also Send Feedback
Returns the list of actions that the given channel supports as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool[] AreCapable(
    IClientChannel channel
)
Visual Basic (Declaration)
Function AreCapable ( _
    channel As IClientChannel _
) As Boolean()
Visual C++
array<bool>^ AreCapable(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel object.

Return Value

null in case of error, or an array of bool values; true for each action that the channel supports, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
AreCapable Overload
Genesyslab.Enterprise.Services Namespace


AreCapable Method (String)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.AreCapable Method (String)
IPSTService Interface See Also Send Feedback
Returns the list of actions that the given channel supports as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool[] AreCapable(
    string ID
)
Visual Basic (Declaration)
Function AreCapable ( _
    ID As String _
) As Boolean()
Visual C++
array<bool>^ AreCapable(
    String^ ID
)

Parameters

ID
Type: System..::.String
The channel ID.

Return Value

null in case of error, or an array of bool values; true for each action that the channel supports, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
AreCapable Overload
Genesyslab.Enterprise.Services Namespace


ArePossible Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
ArePossible(IDevice) | Returns the list of actions that your application can request for the given device as a table of bool values.
ArePossible(IInteraction) | Returns the list of actions that your application can request for the given interaction as a table of bool values.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


ArePossible Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method (IDevice)
IPSTService Interface See Also Send Feedback
Returns the list of actions that your application can request for the given device as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool[] ArePossible(
    IDevice device
)
Visual Basic (Declaration)
Function ArePossible ( _
    device As IDevice _
) As Boolean()
Visual C++
array<bool>^ ArePossible(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.

Return Value

null in case of error, or an array of bool values; true for each permitted action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
ArePossible Overload
Genesyslab.Enterprise.Services Namespace


ArePossible Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.ArePossible Method (IInteraction)
IPSTService Interface See Also Send Feedback
Returns the list of actions that your application can request for the given interaction as a table of bool values.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool[] ArePossible(
    IInteraction interaction
)
Visual Basic (Declaration)
Function ArePossible ( _
    interaction As IInteraction _
) As Boolean()
Visual C++
array<bool>^ ArePossible(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction object.

Return Value

null in case of error, or an array of bool values, true for each permitted action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
ArePossible Overload
Genesyslab.Enterprise.Services Namespace


IsCapable Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
IsCapable(IClientChannel, ProtocolAction) | Returns true if the channel is capable to perform this action.
IsCapable(String, ProtocolAction) | Returns true if the channel is capable to perform this action.

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


IsCapable Method (IClientChannel, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method (IClientChannel, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the channel is capable to perform this action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsCapable(
    IClientChannel channel,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsCapable ( _
    channel As IClientChannel, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsCapable(
    IClientChannel^ channel,
    ProtocolAction action
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
The channel object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The action.

Return Value

true if the channel is capable of the action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsCapable Overload
Genesyslab.Enterprise.Services Namespace


IsCapable Method (String, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsCapable Method (String, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if the channel is capable to perform this action.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsCapable(
    string ID,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsCapable ( _
    ID As String, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsCapable(
    String^ ID,
    ProtocolAction action
)

Parameters

ID
Type: System..::.String
The channel ID.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
the action

Return Value

true if the channel is capable of the action, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsCapable Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method

[image] [image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method
IPSTService Interface See Also Send Feedback

Overload List

Name | Description
IsPossible(IDevice, DeviceAction) | Returns true if the given action is available on the given device.
IsPossible(IInteraction, ProtocolAction) | Returns true if you can process the given protocol action on the given interaction.
IsPossible(IDevice, AgentAction, WorkMode) | Returns true if the given action is available on the given device with the specified mode
IsPossible(IDevice, ForwardAction, ForwardModeType) | Returns true if the given action is available on the given device with the specified mode
IsPossible(IInteraction, AgentAction, WorkMode) | Returns true if the given action is available on the given device with the specified mode
IsPossible(IInteraction, ForwardAction, ForwardModeType) | Returns true if the given action is available on the given device with the specified mode

See Also

IPSTService Interface
IPSTService Members
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, DeviceAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, DeviceAction)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsPossible(
    IDevice device,
    DeviceAction action
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As DeviceAction _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    DeviceAction action
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
The device object.
action
Type: Genesyslab.Enterprise.Services..::.DeviceAction
The action.

Return Value

true if the action can be invoked according to the device status, false otherwise

Remarks

See the remark section in this service description

Remarks

See the remark section in this service description

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, ProtocolAction)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, ProtocolAction)
IPSTService Interface See Also Send Feedback
Returns true if you can process the given protocol action on the given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    ProtocolAction action
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As ProtocolAction _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    ProtocolAction action
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
The interaction object.
action
Type: Genesyslab.Enterprise.Services..::.ProtocolAction
The requested action.

Return Value

true if the action can be invoked according to the interaction status, false otherwise.

Remarks

See the remark section in this service description.

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, AgentAction, WorkMode)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, AgentAction, WorkMode)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsPossible(
    IDevice device,
    AgentAction action,
    WorkMode mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As AgentAction, _
    mode As WorkMode _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    AgentAction action,
    WorkMode mode
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

action
Type: Genesyslab.Enterprise.Services..::.AgentAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

mode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IDevice, ForwardAction, ForwardModeType)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IDevice, ForwardAction, ForwardModeType)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsPossible(
    IDevice device,
    ForwardAction action,
    ForwardModeType mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    device As IDevice, _
    action As ForwardAction, _
    mode As ForwardModeType _
) As Boolean
Visual C++
bool IsPossible(
    IDevice^ device,
    ForwardAction action,
    ForwardModeType mode
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

action
Type: Genesyslab.Enterprise.Services..::.ForwardAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

mode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, AgentAction, WorkMode)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, AgentAction, WorkMode)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    AgentAction action,
    WorkMode mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As AgentAction, _
    mode As WorkMode _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    AgentAction action,
    WorkMode mode
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

action
Type: Genesyslab.Enterprise.Services..::.AgentAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

mode
Type: Genesyslab.Enterprise.Model.Identity..::.WorkMode

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.AgentAction,Genesyslab.Enterprise.Model.Identity.WorkMode)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


IsPossible Method (IInteraction, ForwardAction, ForwardModeType)

[image]

Enterprise SDK 8.0 Reference API
IPSTService..::.IsPossible Method (IInteraction, ForwardAction, ForwardModeType)
IPSTService Interface See Also Send Feedback
Returns true if the given action is available on the given device with the specified mode

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsPossible(
    IInteraction interaction,
    ForwardAction action,
    ForwardModeType mode
)
Visual Basic (Declaration)
Function IsPossible ( _
    interaction As IInteraction, _
    action As ForwardAction, _
    mode As ForwardModeType _
) As Boolean
Visual C++
bool IsPossible(
    IInteraction^ interaction,
    ForwardAction action,
    ForwardModeType mode
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction

[Missing <param name="interaction"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

action
Type: Genesyslab.Enterprise.Services..::.ForwardAction

[Missing <param name="action"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

mode
Type: Genesyslab.Enterprise.Model.Device..::.ForwardModeType

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.Services.IPSTService.IsPossible(Genesyslab.Enterprise.Model.Interaction.IInteraction,Genesyslab.Enterprise.Services.ForwardAction,Genesyslab.Enterprise.Model.Device.ForwardModeType)"]

Return Value

bool

See Also

IPSTService Interface
IsPossible Overload
Genesyslab.Enterprise.Services Namespace


ISMSDomain Interface

[image]

Enterprise SDK 8.0 Reference API
ISMSDomain Interface
Members See Also Send Feedback
Interface for the SMS domain.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISMSDomain
Visual Basic (Declaration)
Public Interface ISMSDomain
Visual C++
public interface class ISMSDomain

See Also

ISMSDomain Members
Genesyslab.Enterprise.Services Namespace


ISMSDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSDomain Members
ISMSDomain Interface Methods See Also Send Feedback

The ISMSDomain type exposes the following members.

Methods

Name | Description
GetInteractions | Gets the SMS interactions.

See Also

ISMSDomain Interface
Genesyslab.Enterprise.Services Namespace


ISMSDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSDomain Methods
ISMSDomain Interface See Also Send Feedback

The ISMSDomain type exposes the following members.

Methods

Name | Description
GetInteractions | Gets the SMS interactions.

See Also

ISMSDomain Interface
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image]

Enterprise SDK 8.0 Reference API
ISMSDomain..::.GetInteractions Method
ISMSDomain Interface See Also Send Feedback
Gets the SMS interactions.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISMSInteraction[] GetInteractions()
Visual Basic (Declaration)
Function GetInteractions As ISMSInteraction()
Visual C++
array<ISMSInteraction^>^ GetInteractions()

Return Value

The SMS interaction list.

See Also

ISMSDomain Interface
Genesyslab.Enterprise.Services Namespace


ISMSService Interface

[image]

Enterprise SDK 8.0 Reference API
ISMSService Interface
Members See Also Send Feedback
Manages callback and filters related to chat interaction events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISMSService : ISMSDomain
Visual Basic (Declaration)
Public Interface ISMSService _
    Implements ISMSDomain
Visual C++
public interface class ISMSService : ISMSDomain

See Also

ISMSService Members
Genesyslab.Enterprise.Services Namespace


ISMSService Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSService Members
ISMSService Interface Methods See Also Send Feedback

The ISMSService type exposes the following members.

Methods

Name | Description
Delete | Delete an SMS Synchronous method
GetInteractions | Gets the SMS interactions. (Inherited from ISMSDomain.)
MakeSms | Create a new SMS Synchronous method
MakeSmsInfo | Overloaded.
SendSms | Send an sms Synchronous method
UpdateSms | Overloaded.

See Also

ISMSService Interface
Genesyslab.Enterprise.Services Namespace


ISMSService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSService Methods
ISMSService Interface See Also Send Feedback

The ISMSService type exposes the following members.

Methods

Name | Description
Delete | Delete an SMS Synchronous method
GetInteractions | Gets the SMS interactions. (Inherited from ISMSDomain.)
MakeSms | Create a new SMS Synchronous method
MakeSmsInfo | Overloaded.
SendSms | Send an sms Synchronous method
UpdateSms | Overloaded.

See Also

ISMSService Interface
Genesyslab.Enterprise.Services Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.Delete Method
ISMSService Interface See Also Send Feedback
Delete an SMS Synchronous method

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Delete(
    IEmailInteraction interaction,
    KeyValueCollection reasons,
    int timeOut,
    string correlatorData
)
Visual Basic (Declaration)
Sub Delete ( _
    interaction As IEmailInteraction, _
    reasons As KeyValueCollection, _
    timeOut As Integer, _
    correlatorData As String _
)
Visual C++
void Delete(
    IEmailInteraction^ interaction,
    KeyValueCollection^ reasons,
    int timeOut,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IEmailInteraction
Interaction to end
reasons
Type: KeyValueCollection
Collection of reasons
timeOut
Type: System..::.Int32
Timeout in milliseconds
correlatorData
Type: System..::.String
User data linked to the command

See Also

ISMSService Interface
Genesyslab.Enterprise.Services Namespace


MakeSms Method

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.MakeSms Method
ISMSService Interface See Also Send Feedback
Create a new SMS Synchronous method

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<ISMSInteraction> MakeSms(
    IDevice devicePlace,
    string interactionSubtype,
    string parentInteractionID,
    string SourceNumber,
    string DestinationNumber,
    string Text,
    EncodingType Encoding,
    string queue,
    ICollection<string> inputQueues,
    ICollection<string> outputQueues,
    KeyValueCollection userData,
    KeyValueCollection extensions,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function MakeSms ( _
    devicePlace As IDevice, _
    interactionSubtype As String, _
    parentInteractionID As String, _
    SourceNumber As String, _
    DestinationNumber As String, _
    Text As String, _
    Encoding As EncodingType, _
    queue As String, _
    inputQueues As ICollection(Of String), _
    outputQueues As ICollection(Of String), _
    userData As KeyValueCollection, _
    extensions As KeyValueCollection, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISMSInteraction)
Visual C++
IEnvelope<ISMSInteraction^>^ MakeSms(
    IDevice^ devicePlace,
    String^ interactionSubtype,
    String^ parentInteractionID,
    String^ SourceNumber,
    String^ DestinationNumber,
    String^ Text,
    EncodingType Encoding,
    String^ queue,
    ICollection<String^>^ inputQueues,
    ICollection<String^>^ outputQueues,
    KeyValueCollection^ userData,
    KeyValueCollection^ extensions,
    int timeout,
    String^ correlatorData
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device Place involved
interactionSubtype
Type: System..::.String
Interaction sub type
parentInteractionID
Type: System..::.String
Parent Id if related interaction
SourceNumber
Type: System..::.String
Phone Number of the sender
DestinationNumber
Type: System..::.String
Phone number for Destination
Text
Type: System..::.String
Message to send
Encoding
Type: Genesyslab.Enterprise.Model.Interaction..::.EncodingType

[Missing <param name="Encoding"/> documentation for "M:Genesyslab.Enterprise.Services.ISMSService.MakeSms(Genesyslab.Enterprise.Model.Device.IDevice,System.String,System.String,System.String,System.String,System.String,Genesyslab.Enterprise.Model.Interaction.EncodingType,System.String,System.Collections.Generic.ICollection{System.String},System.Collections.Generic.ICollection{System.String},Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,Genesyslab.Enterprise.Commons.Collections.KeyValueCollection,System.Int32,System.String)"]

queue
Type: System..::.String
Output queue for sending
inputQueues
Type: System.Collections.Generic..::.ICollection <(Of <( String >)>)
Input queues for wokflow if required
outputQueues
Type: System.Collections.Generic..::.ICollection <(Of <( String >)>)
Output queues for worflow is required
userData
Type: KeyValueCollection
User data collection
extensions
Type: KeyValueCollection
Extensions data collection
timeout
Type: System..::.Int32
Timout in milliseconds
correlatorData
Type: System..::.String
Correlator data

Return Value

IEnvelope<ISMSInteraction>

See Also

ISMSService Interface
Genesyslab.Enterprise.Services Namespace


MakeSmsInfo Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSService..::.MakeSmsInfo Method
ISMSService Interface See Also Send Feedback

Overload List

Name | Description
MakeSmsInfo(KeyValueCollection) | Create an SMS object based on properties in user data No back end object is created Mainly used for History purpose
MakeSmsInfo(KeyValueCollection) | Create an SMS object based on properties in user data No back end object is created Mainly used for History purpose

See Also

ISMSService Interface
ISMSService Members
Genesyslab.Enterprise.Services Namespace


MakeSmsInfo Method ()

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.MakeSmsInfo Method ()
ISMSService Interface See Also Send Feedback
Create an SMS object based on properties in user data No back end object is created Mainly used for History purpose

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISMSInfo MakeSmsInfo(
    KeyValueCollection userData
)
Visual Basic (Declaration)
Function MakeSmsInfo ( _
    userData As KeyValueCollection _
) As ISMSInfo
Visual C++
ISMSInfo^ MakeSmsInfo(
    KeyValueCollection^ userData
)

Parameters

userData
Type: KeyValueCollection
ESDK User data collection

Return Value

ISMSInfo

See Also

ISMSService Interface
MakeSmsInfo Overload
Genesyslab.Enterprise.Services Namespace


MakeSmsInfo Method ()

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.MakeSmsInfo Method ()
ISMSService Interface See Also Send Feedback
Create an SMS object based on properties in user data No back end object is created Mainly used for History purpose

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISMSInfo MakeSmsInfo(
    KeyValueCollection userData
)
Visual Basic (Declaration)
Function MakeSmsInfo ( _
    userData As KeyValueCollection _
) As ISMSInfo
Visual C++
ISMSInfo^ MakeSmsInfo(
    KeyValueCollection^ userData
)

Parameters

userData
Type: KeyValueCollection
PSDK User data collection

Return Value

ISMSInfo

See Also

ISMSService Interface
MakeSmsInfo Overload
Genesyslab.Enterprise.Services Namespace


SendSms Method

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.SendSms Method
ISMSService Interface See Also Send Feedback
Send an sms Synchronous method

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<ISMSInteraction> SendSms(
    ISMSInteraction interaction,
    string queue,
    KeyValueCollection reasons,
    KeyValueCollection extensions,
    bool endSmsInteractionIn,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function SendSms ( _
    interaction As ISMSInteraction, _
    queue As String, _
    reasons As KeyValueCollection, _
    extensions As KeyValueCollection, _
    endSmsInteractionIn As Boolean, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISMSInteraction)
Visual C++
IEnvelope<ISMSInteraction^>^ SendSms(
    ISMSInteraction^ interaction,
    String^ queue,
    KeyValueCollection^ reasons,
    KeyValueCollection^ extensions,
    bool endSmsInteractionIn,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ISMSInteraction
Interaction to send
queue
Type: System..::.String
Final queue to send to
reasons
Type: KeyValueCollection
Collection of reasons
extensions
Type: KeyValueCollection
Colelctions of extensions
endSmsInteractionIn
Type: System..::.Boolean
True to end parent interaction if any
timeout
Type: System..::.Int32
Timeout in milliseconds
correlatorData
Type: System..::.String
User data linked to the command

Return Value

IEnvelope<ISMSInteraction>

See Also

ISMSService Interface
Genesyslab.Enterprise.Services Namespace


UpdateSms Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISMSService..::.UpdateSms Method
ISMSService Interface See Also Send Feedback

Overload List

Name | Description
UpdateSms(ISMSInteraction, IDictionary<(Of <(SmsProperty, String>)>), Int32, String) | Update SMS with multiple values Synchronous method
UpdateSms(ISMSInteraction, SmsProperty, String, Int32, String) | Update SMS properties with single value Synchronous method

See Also

ISMSService Interface
ISMSService Members
Genesyslab.Enterprise.Services Namespace


UpdateSms Method (ISMSInteraction, IDictionary(SmsProperty, String), Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.UpdateSms Method (ISMSInteraction, IDictionary<(Of <(SmsProperty, String>)>), Int32, String)
ISMSService Interface See Also Send Feedback
Update SMS with multiple values Synchronous method

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<ISMSInteraction> UpdateSms(
    ISMSInteraction interaction,
    IDictionary<SmsProperty, string> data,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function UpdateSms ( _
    interaction As ISMSInteraction, _
    data As IDictionary(Of SmsProperty, String), _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISMSInteraction)
Visual C++
IEnvelope<ISMSInteraction^>^ UpdateSms(
    ISMSInteraction^ interaction,
    IDictionary<SmsProperty, String^>^ data,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ISMSInteraction
interaction to be updated
data
Type: System.Collections.Generic..::.IDictionary <(Of <( SmsProperty, String >)>)
Collection of properties/values to be modified
timeout
Type: System..::.Int32
timeout in milliseconds
correlatorData
Type: System..::.String
User data linked to the request

Return Value

IEnvelope<ISMSInteraction>

See Also

ISMSService Interface
UpdateSms Overload
Genesyslab.Enterprise.Services Namespace


UpdateSms Method (ISMSInteraction, SmsProperty, String, Int32, String)

[image]

Enterprise SDK 8.0 Reference API
ISMSService..::.UpdateSms Method (ISMSInteraction, SmsProperty, String, Int32, String)
ISMSService Interface See Also Send Feedback
Update SMS properties with single value Synchronous method

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnvelope<ISMSInteraction> UpdateSms(
    ISMSInteraction interaction,
    SmsProperty property,
    string value,
    int timeout,
    string correlatorData
)
Visual Basic (Declaration)
Function UpdateSms ( _
    interaction As ISMSInteraction, _
    property As SmsProperty, _
    value As String, _
    timeout As Integer, _
    correlatorData As String _
) As IEnvelope(Of ISMSInteraction)
Visual C++
IEnvelope<ISMSInteraction^>^ UpdateSms(
    ISMSInteraction^ interaction,
    SmsProperty property,
    String^ value,
    int timeout,
    String^ correlatorData
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.ISMSInteraction
interaction to be updated
property
Type: Genesyslab.Enterprise.Services..::.SmsProperty
Property to be modified
value
Type: System..::.String
New value to be set
timeout
Type: System..::.Int32
timeout in milliseconds
correlatorData
Type: System..::.String
User data linked to the request

Return Value

IEnvelope<ISMSInteraction>

See Also

ISMSService Interface
UpdateSms Overload
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Interface
Members See Also Send Feedback
Actions part of the monitoring domain

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISupervisorDomain : IStrategyManager<ISupervisorInfo>
Visual Basic (Declaration)
Public Interface ISupervisorDomain _
    Implements IStrategyManager(Of ISupervisorInfo)
Visual C++
public interface class ISupervisorDomain : IStrategyManager<ISupervisorInfo^>

See Also

ISupervisorDomain Members
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Members
ISupervisorDomain Interface Methods See Also Send Feedback

The ISupervisorDomain type exposes the following members.

Methods

Name | Description
IsMonitored | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain Methods
ISupervisorDomain Interface See Also Send Feedback

The ISupervisorDomain type exposes the following members.

Methods

Name | Description
IsMonitored | Overloaded.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

ISupervisorDomain Interface
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method
ISupervisorDomain Interface See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Returns true if the given device is monitored.
IsMonitored(IIdentity) | Returns true if the given identity is monitored.
IsMonitored(IInteraction) | Returns true if the given interaction is monitored.

See Also

ISupervisorDomain Interface
ISupervisorDomain Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IDevice)
ISupervisorDomain Interface See Also Send Feedback
Returns true if the given device is monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsMonitored(
    IDevice device
)
Visual Basic (Declaration)
Function IsMonitored ( _
    device As IDevice _
) As Boolean
Visual C++
bool IsMonitored(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
Device instance to evaluate

Return Value

bool

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IIdentity)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IIdentity)
ISupervisorDomain Interface See Also Send Feedback
Returns true if the given identity is monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsMonitored(
    IIdentity identity
)
Visual Basic (Declaration)
Function IsMonitored ( _
    identity As IIdentity _
) As Boolean
Visual C++
bool IsMonitored(
    IIdentity^ identity
)

Parameters

identity
Type: Genesyslab.Enterprise.Model.Identity..::.IIdentity
Identity instance

Return Value

bool

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


IsMonitored Method (IInteraction)

[image]

Enterprise SDK 8.0 Reference API
ISupervisorDomain..::.IsMonitored Method (IInteraction)
ISupervisorDomain Interface See Also Send Feedback
Returns true if the given interaction is monitored.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsMonitored(
    IInteraction interaction
)
Visual Basic (Declaration)
Function IsMonitored ( _
    interaction As IInteraction _
) As Boolean
Visual C++
bool IsMonitored(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction instance

Return Value

bool

See Also

ISupervisorDomain Interface
IsMonitored Overload
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Interface
Members See Also Send Feedback
Describes the monitoring information of the object which is identified by the Id member. The MonitorObject member identifies the type of the monitored object (possible types are enumerated in SupervisorObjectType: agent, interaction, device, and so on.)

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISupervisorInfo : ISerializable
Visual Basic (Declaration)
Public Interface ISupervisorInfo _
    Implements ISerializable
Visual C++
public interface class ISupervisorInfo : ISerializable

See Also

ISupervisorInfo Members
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Members
ISupervisorInfo Interface Methods Properties See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

Properties

Name | Description
Id | Returns the ID of the monitored object.
Media | Returns the media type of the monitored object.
MonitorObject | Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).
MonitorState | Returns the monitoring status for the associated object (On, Off).

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Methods
ISupervisorInfo Interface See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Methods

Name | Description
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorInfo Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo Properties
ISupervisorInfo Interface See Also Send Feedback

The ISupervisorInfo type exposes the following members.

Properties

Name | Description
Id | Returns the ID of the monitored object.
Media | Returns the media type of the monitored object.
MonitorObject | Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).
MonitorState | Returns the monitoring status for the associated object (On, Off).

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


Id Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.Id Property
ISupervisorInfo Interface See Also Send Feedback
Returns the ID of the monitored object.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


Media Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.Media Property
ISupervisorInfo Interface See Also Send Feedback
Returns the media type of the monitored object.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MediaType Media { get; }
Visual Basic (Declaration)
ReadOnly Property Media As MediaType
Visual C++
property MediaType Media {
    MediaType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


MonitorObject Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.MonitorObject Property
ISupervisorInfo Interface See Also Send Feedback
Returns the type of object which is monitored. (For example, agent, interaction, device, and so on).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
SupervisorObjectType MonitorObject { get; }
Visual Basic (Declaration)
ReadOnly Property MonitorObject As SupervisorObjectType
Visual C++
property SupervisorObjectType MonitorObject {
    SupervisorObjectType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


MonitorState Property

[image]

Enterprise SDK 8.0 Reference API
ISupervisorInfo..::.MonitorState Property
ISupervisorInfo Interface See Also Send Feedback
Returns the monitoring status for the associated object (On, Off).

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
SupervisorStateType MonitorState { get; }
Visual Basic (Declaration)
ReadOnly Property MonitorState As SupervisorStateType
Visual C++
property SupervisorStateType MonitorState {
    SupervisorStateType get ();
}

See Also

ISupervisorInfo Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Interface

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService Interface
Members Example See Also Send Feedback
Manages actions and events related to monitoring events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISupervisorService : IEventManager<ISupervisorService, IEnvelope<ISupervisorInfo>>,
    IChannelMonitor<ISupervisorService>, ISupervisorDomain, IStrategyManager<ISupervisorInfo>,
    IBrokerSubscriber<IEnvelope<ISupervisorInfo>>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface ISupervisorService _
    Implements IEventManager(Of ISupervisorService, IEnvelope(Of ISupervisorInfo)),  _
    IChannelMonitor(Of ISupervisorService), ISupervisorDomain, IStrategyManager(Of ISupervisorInfo),  _
    IBrokerSubscriber(Of IEnvelope(Of ISupervisorInfo)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class ISupervisorService : IEventManager<ISupervisorService^, IEnvelope<ISupervisorInfo^>^>,
    IChannelMonitor<ISupervisorService^>, ISupervisorDomain, IStrategyManager<ISupervisorInfo^>,
    IBrokerSubscriber<IEnvelope<ISupervisorInfo^>^>, IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>

Examples

The following code sample registers a handler for a given interaction.
CopyC#
 EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager));
ISupervisorService monitorService = EsdkService.Resolve<ISupervisorService>("monitorService");
interactionService.RegisterEvents<IEnvelope<ISupervisorInfo>>(channel, new Action<IEnvelope<ISupervisorInfo>>(MonitorEvent));
 To make this snippet work, you must also declare an InteractionEvent method.
CopyC#
//Filter sample and declaration of the handler
[EnterpriseMonitorEvent("TServerSIPChannel")]
     protected void MonitorEvent(IEnvelope<ISupervisorInfo> tsp)
     {
     }

See Also

ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


ISupervisorService Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Members
ISupervisorService Interface Methods Properties See Also Send Feedback

The ISupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) | Lists the filters registered for the given supervision instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given supervision
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given supervision

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Methods
ISupervisorService Interface See Also Send Feedback

The ISupervisorService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsMonitored | Overloaded.
ListFilter<(Of <(T>)>) | Lists the filters registered for the given supervision instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for the given supervision
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for the given supervision

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.GetList Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


IsMonitored Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.IsMonitored Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
IsMonitored(IDevice) | Returns true if the given device is monitored. (Inherited from ISupervisorDomain.)
IsMonitored(IIdentity) | Returns true if the given identity is monitored. (Inherited from ISupervisorDomain.)
IsMonitored(IInteraction) | Returns true if the given interaction is monitored. (Inherited from ISupervisorDomain.)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.ListFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Lists the filters registered for the given supervision instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    ISupervisorInfo context
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    context As ISupervisorInfo _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    ISupervisorInfo^ context
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
Target interaction object.

Type Parameters

T
Type of data handled in filter object.

Return Value

IEnumerable<T>

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.RegisterEvents Method
ISupervisorService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

ISupervisorService Interface
ISupervisorService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.RegisterFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Registers a filter for the given supervision

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISupervisorService RegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
generic<typename T>
ISupervisorService^ RegisterFilter(
    ISupervisorInfo^ context,
    T filter
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
ISupervisorInfo.
filter
Type: T
Filter instance.

Type Parameters

T
Filter type.

Return Value

ISupervisorService

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
ISupervisorService..::.UnRegisterFilter<(Of <(T>)>) Method
ISupervisorService Interface See Also Send Feedback
Unregisters a filter for the given supervision

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISupervisorService UnRegisterFilter<T>(
    ISupervisorInfo context,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    context As ISupervisorInfo, _
    filter As T _
) As ISupervisorService
Visual C++
generic<typename T>
ISupervisorService^ UnRegisterFilter(
    ISupervisorInfo^ context,
    T filter
)

Parameters

context
Type: Genesyslab.Enterprise.Services..::.ISupervisorInfo
ISupervisorInfo
filter
Type: T
Filter instance

Type Parameters

T
Type of data for the filter instance.

Return Value

ISupervisorService

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


ISupervisorService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISupervisorService Properties
ISupervisorService Interface See Also Send Feedback

The ISupervisorService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

ISupervisorService Interface
Genesyslab.Enterprise.Services Namespace


IVoiceService Interface

[image]

Enterprise SDK 8.0 Reference API
IVoiceService Interface
Members Example See Also Send Feedback
Manages callback and filters related to interaction events.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IVoiceService : IInteractionDomain,
    IStrategyManager<IInteraction>, IEventManager<IVoiceService, IEnvelope<IInteraction>>,
    IChannelMonitor<IVoiceService>, IBrokerSubscriber<IEnvelope<IInteraction>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>, IPersistable<IInteraction>
Visual Basic (Declaration)
Public Interface IVoiceService _
    Implements IInteractionDomain, IStrategyManager(Of IInteraction),  _
    IEventManager(Of IVoiceService, IEnvelope(Of IInteraction)), IChannelMonitor(Of IVoiceService),  _
    IBrokerSubscriber(Of IEnvelope(Of IInteraction)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest)),  _
    IPersistable(Of IInteraction)
Visual C++
public interface class IVoiceService : IInteractionDomain,
    IStrategyManager<IInteraction^>, IEventManager<IVoiceService^, IEnvelope<IInteraction^>^>,
    IChannelMonitor<IVoiceService^>, IBrokerSubscriber<IEnvelope<IInteraction^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>, IPersistable<IInteraction^>

Examples

The following code sample registers a handler for a given interaction.
CopyC#
EsdkService = new EnterpriseServiceProvider(new UnityContainer(), typeof(GlobalThreadLifeTimeManager));
IVoiceService interactionService = EsdkService.Resolve<IVoiceService>("voiceService");
interactionService.RegisterEvents<IEnvelope<IInteraction>>(channel, new Action<IEnvelope<IInteraction>>(InteractionEvent));
 To make this snippet work, you must also declare an InteractionEvent method.
CopyC#
//Filter sample and declaration of the handler
[EnterpriseInteractionEvent("TServerSIPChannel")]
     protected void InteractionEvent(IEnvelope<IInteraction> tsp)
     {
     }

See Also

IVoiceService Members
Genesyslab.Enterprise.Services Namespace


IVoiceService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService Members
IVoiceService Interface Methods Properties See Also Send Feedback

The IVoiceService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IInteractionDomain.)
DeleteInteractions | Delete all interactions (Inherited from IInteractionDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IInteractionDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IInteractionDomain.)
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


IVoiceService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService Methods
IVoiceService Interface See Also Send Feedback

The IVoiceService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CreateInteraction | Overloaded.
DeleteInteraction | Deletes the given interaction. (Inherited from IInteractionDomain.)
DeleteInteractions | Delete all interactions (Inherited from IInteractionDomain.)
GetAttachedData | Returns the user defined attached data of this interaction. (Inherited from IInteractionDomain.)
GetInteraction | Overloaded.
GetInteractions | Overloaded.
GetList | Overloaded.
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
IsDirty | (Inherited from IPersistable<(Of <(T>)>).)
ListFilter<(Of <(T>)>) | Lists the filters registered for the given interaction instance.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
RegisterEvents | Overloaded.
RegisterFilter<(Of <(T>)>) | Registers a filter for a given interaction.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAttachedData | Removes the attached data identified by the given key from the given interaction. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Save | Overloaded.
SaveAttachedData | Saves the modifications of the attached data. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SaveInteraction | Saves the interaction in the service's repository. All data are synchronized with the back-end servers. (Inherited from IInteractionDomain.)
SetAttachedData | Overloaded.
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnRegisterFilter<(Of <(T>)>) | Unregisters a filter for a given interaction.

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


CreateInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.CreateInteraction Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
CreateInteraction(IEnumerable<(Of <(IDevice>)>)) | Creates a new interaction associated with a set of devices and a unique ID. (Inherited from IInteractionDomain.)
CreateInteraction(IInteraction, IEnumerable<(Of <(IDevice>)>)) | Uses an existing interaction to create a new interaction associated with a set of devices. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


GetInteraction Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.GetInteraction Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
GetInteraction(IAgent, String) | Retrieves the interaction associated with an agent from its unique Id, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteraction(IDN, String) | Retrieves the interaction associated with a device from its unique Id, or null if no interaction exists. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


GetInteractions Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.GetInteractions Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
GetInteractions()()() | Returns all the existing interactions. (Inherited from IInteractionDomain.)
GetInteractions(IAgent) | Retrieves the interactions associated with an Agent, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteractions(IDN) | Retrieves the interactions associated with a device, or null if no interaction exists. (Inherited from IInteractionDomain.)
GetInteractions(String) | Returns the existing interaction(s) associated with an interaction ID. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.GetList Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


ListFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.ListFilter<(Of <(T>)>) Method
IVoiceService Interface See Also Send Feedback
Lists the filters registered for the given interaction instance.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> ListFilter<T>(
    IInteraction interaction
)
Visual Basic (Declaration)
Function ListFilter(Of T) ( _
    interaction As IInteraction _
) As IEnumerable(Of T)
Visual C++
generic<typename T>
IEnumerable<T>^ ListFilter(
    IInteraction^ interaction
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Target interaction object.

Type Parameters

T
Type of data handled in filter object

Return Value

Filters.

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.RegisterEvents Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


RegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.RegisterFilter<(Of <(T>)>) Method
IVoiceService Interface See Also Send Feedback
Registers a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IVoiceService RegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function RegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IVoiceService
Visual C++
generic<typename T>
IVoiceService^ RegisterFilter(
    IInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Filter type.

Return Value

IVoiceService

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


Save Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.Save Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
Save(T) | Saves the object into the Contact Server. (Inherited from IPersistable<(Of <(T>)>).)
Save(T, IStrategy) | Save data by executing the specified strategy (Inherited from IPersistable<(Of <(T>)>).)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


SetAttachedData Method

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.SetAttachedData Method
IVoiceService Interface See Also Send Feedback

Overload List

Name | Description
SetAttachedData(IInteraction, KeyValueCollection) | Attaches several key-value pairs at once. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)
SetAttachedData(IInteraction, String, Object) | Sets the user defined data as attached key-value pair. The update in the back-end server is performed automatically. (Inherited from IInteractionDomain.)

See Also

IVoiceService Interface
IVoiceService Members
Genesyslab.Enterprise.Services Namespace


UnRegisterFilter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IVoiceService..::.UnRegisterFilter<(Of <(T>)>) Method
IVoiceService Interface See Also Send Feedback
Unregisters a filter for a given interaction.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IVoiceService UnRegisterFilter<T>(
    IInteraction interaction,
    T filter
)
Visual Basic (Declaration)
Function UnRegisterFilter(Of T) ( _
    interaction As IInteraction, _
    filter As T _
) As IVoiceService
Visual C++
generic<typename T>
IVoiceService^ UnRegisterFilter(
    IInteraction^ interaction,
    T filter
)

Parameters

interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Interaction.
filter
Type: T
Filter instance.

Type Parameters

T
Type of data for the filter instance.

Return Value

IVoiceService

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


IVoiceService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IVoiceService Properties
IVoiceService Interface See Also Send Feedback

The IVoiceService type exposes the following members.

Properties

Name Description
ContactServerId
Returns the internal Contact Server ID. This is provided for use with an external CRM only. Please use
CopyC#
GetUID()
 in all other cases.
(Inherited from IPersistable<(Of <(T>)>).)
Count
Gets the number of subscribers.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription
Gets the subscriber object of type T.
(Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter
Returns the filter predicate which indicates whether publishing event should be processed or ignored.
(Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IVoiceService Interface
Genesyslab.Enterprise.Services Namespace


IWorkbinDomain Interface

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain Interface
Members See Also Send Feedback
Enables your application to manage workbins.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IWorkbinDomain : IStrategyManager<IWorkbin>
Visual Basic (Declaration)
Public Interface IWorkbinDomain _
    Implements IStrategyManager(Of IWorkbin)
Visual C++
public interface class IWorkbinDomain : IStrategyManager<IWorkbin^>

See Also

IWorkbinDomain Members
Genesyslab.Enterprise.Services Namespace


IWorkbinDomain Members

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain Members
IWorkbinDomain Interface Methods See Also Send Feedback

The IWorkbinDomain type exposes the following members.

Methods

Name | Description
CreateWorkbin | Creates a new workbin, general method.
DeleteWorkbin | Deletes the given workbin.
DeleteWorkbins | Deletes all the workbins.
GetWorkbin | Overloaded.
GetWorkbinsConfiguration | Gets the workbin's configuration.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IWorkbinDomain Interface
Genesyslab.Enterprise.Services Namespace


IWorkbinDomain Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain Methods
IWorkbinDomain Interface See Also Send Feedback

The IWorkbinDomain type exposes the following members.

Methods

Name | Description
CreateWorkbin | Creates a new workbin, general method.
DeleteWorkbin | Deletes the given workbin.
DeleteWorkbins | Deletes all the workbins.
GetWorkbin | Overloaded.
GetWorkbinsConfiguration | Gets the workbin's configuration.
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)

See Also

IWorkbinDomain Interface
Genesyslab.Enterprise.Services Namespace


CreateWorkbin Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.CreateWorkbin Method
IWorkbinDomain Interface See Also Send Feedback
Creates a new workbin, general method.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbin CreateWorkbin(
    IDevice devicePlace,
    WorkbinType type,
    string workbinName,
    string workbinParameter,
    string workbinCondition
)
Visual Basic (Declaration)
Function CreateWorkbin ( _
    devicePlace As IDevice, _
    type As WorkbinType, _
    workbinName As String, _
    workbinParameter As String, _
    workbinCondition As String _
) As IWorkbin
Visual C++
IWorkbin^ CreateWorkbin(
    IDevice^ devicePlace,
    WorkbinType type,
    String^ workbinName,
    String^ workbinParameter,
    String^ workbinCondition
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
type
Type: Genesyslab.Enterprise.Services..::.WorkbinType
the type of workbin.
workbinName
Type: System..::.String
the workbin name.
workbinParameter
Type: System..::.String
the workbin parameter.
workbinCondition
Type: System..::.String
the workbin condition.

Return Value

IWorkbin

See Also

IWorkbinDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteWorkbin Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.DeleteWorkbin Method
IWorkbinDomain Interface See Also Send Feedback
Deletes the given workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinDomain DeleteWorkbin(
    IWorkbin workbin
)
Visual Basic (Declaration)
Function DeleteWorkbin ( _
    workbin As IWorkbin _
) As IWorkbinDomain
Visual C++
IWorkbinDomain^ DeleteWorkbin(
    IWorkbin^ workbin
)

Parameters

workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.

Return Value

IWorkbinDomain

See Also

IWorkbinDomain Interface
Genesyslab.Enterprise.Services Namespace


DeleteWorkbins Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.DeleteWorkbins Method
IWorkbinDomain Interface See Also Send Feedback
Deletes all the workbins.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinDomain DeleteWorkbins()
Visual Basic (Declaration)
Function DeleteWorkbins As IWorkbinDomain
Visual C++
IWorkbinDomain^ DeleteWorkbins()

Return Value

IWorkbinDomain

See Also

IWorkbinDomain Interface
Genesyslab.Enterprise.Services Namespace


GetWorkbin Method

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.GetWorkbin Method
IWorkbinDomain Interface See Also Send Feedback

Overload List

Name | Description
GetWorkbin(String) | Gets the workbin.
GetWorkbin(IDevice, WorkbinType, String, String) | Gets the workbin.

See Also

IWorkbinDomain Interface
IWorkbinDomain Members
Genesyslab.Enterprise.Services Namespace


GetWorkbin Method (String)

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.GetWorkbin Method (String)
IWorkbinDomain Interface See Also Send Feedback
Gets the workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbin GetWorkbin(
    string ID
)
Visual Basic (Declaration)
Function GetWorkbin ( _
    ID As String _
) As IWorkbin
Visual C++
IWorkbin^ GetWorkbin(
    String^ ID
)

Parameters

ID
Type: System..::.String
the ESDK workbin ID (see the Workbin ID property).

Return Value

the existing workbin; otherwise null.

See Also

IWorkbinDomain Interface
GetWorkbin Overload
Genesyslab.Enterprise.Services Namespace


GetWorkbin Method (IDevice, WorkbinType, String, String)

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.GetWorkbin Method (IDevice, WorkbinType, String, String)
IWorkbinDomain Interface See Also Send Feedback
Gets the workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbin GetWorkbin(
    IDevice devicePlace,
    WorkbinType type,
    string workbinName,
    string workbinParameter
)
Visual Basic (Declaration)
Function GetWorkbin ( _
    devicePlace As IDevice, _
    type As WorkbinType, _
    workbinName As String, _
    workbinParameter As String _
) As IWorkbin
Visual C++
IWorkbin^ GetWorkbin(
    IDevice^ devicePlace,
    WorkbinType type,
    String^ workbinName,
    String^ workbinParameter
)

Parameters

devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
type
Type: Genesyslab.Enterprise.Services..::.WorkbinType
the workbin type.
workbinName
Type: System..::.String
the workbin name.
workbinParameter
Type: System..::.String
the workbin parameter.

Return Value

Returns the existing workbin or null if it don't exist.

See Also

IWorkbinDomain Interface
GetWorkbin Overload
Genesyslab.Enterprise.Services Namespace


GetWorkbinsConfiguration Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinDomain..::.GetWorkbinsConfiguration Method
IWorkbinDomain Interface See Also Send Feedback
Gets the workbin's configuration.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<IWorkbin> GetWorkbinsConfiguration(
    IClientChannel channel,
    IDevice devicePlace,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function GetWorkbinsConfiguration ( _
    channel As IClientChannel, _
    devicePlace As IDevice, _
    extensions As KeyValueCollection _
) As ICollection(Of IWorkbin)
Visual C++
ICollection<IWorkbin^>^ GetWorkbinsConfiguration(
    IClientChannel^ channel,
    IDevice^ devicePlace,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the interaction server's channel.
devicePlace
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
extensions
Type: KeyValueCollection
the extensions.

Return Value

All the Interaction Server's workbins; otherwise null.

See Also

IWorkbinDomain Interface
Genesyslab.Enterprise.Services Namespace


IWorkbinService Interface

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService Interface
Members See Also Send Feedback
Manages the Workbin features.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IWorkbinService : IWorkbinDomain,
    IStrategyManager<IWorkbin>, IEventManager<IWorkbinService, IEnvelope<IWorkbin>>,
    IChannelMonitor<IWorkbinService>, IBrokerSubscriber<IEnvelope<IWorkbin>>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest>>
Visual Basic (Declaration)
Public Interface IWorkbinService _
    Implements IWorkbinDomain, IStrategyManager(Of IWorkbin),  _
    IEventManager(Of IWorkbinService, IEnvelope(Of IWorkbin)), IChannelMonitor(Of IWorkbinService),  _
    IBrokerSubscriber(Of IEnvelope(Of IWorkbin)), IBrokerPublisher, ISubscribeable(Of IEnvelope(Of IRequest))
Visual C++
public interface class IWorkbinService : IWorkbinDomain,
    IStrategyManager<IWorkbin^>, IEventManager<IWorkbinService^, IEnvelope<IWorkbin^>^>,
    IChannelMonitor<IWorkbinService^>, IBrokerSubscriber<IEnvelope<IWorkbin^>^>,
    IBrokerPublisher, ISubscribeable<IEnvelope<IRequest^>^>

See Also

IWorkbinService Members
Genesyslab.Enterprise.Services Namespace


IWorkbinService Members

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService Members
IWorkbinService Interface Methods Properties See Also Send Feedback

The IWorkbinService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CreateWorkbin | Creates a new workbin, general method. (Inherited from IWorkbinDomain.)
DeleteWorkbin | Deletes the given workbin. (Inherited from IWorkbinDomain.)
DeleteWorkbins | Deletes all the workbins. (Inherited from IWorkbinDomain.)
GetList | Overloaded.
GetWorkbin | Overloaded.
GetWorkbinContent | Gets all the multimedia interactions from the given workbin.
GetWorkbinsConfiguration | Gets the workbin's configuration. (Inherited from IWorkbinDomain.)
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Pull | Overloaded.
Put | Overloaded.
RegisterEvents | Overloaded.
RegisterNotifications | Registers the notifications from the given workbin.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnregisterNotifications | Unregisters the notifications from the given workbin.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IWorkbinService Interface
Genesyslab.Enterprise.Services Namespace


IWorkbinService Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService Methods
IWorkbinService Interface See Also Send Feedback

The IWorkbinService type exposes the following members.

Methods

Name | Description
AddChannel | Enables the monitoring of the given channel. Note: This method does not fire events. (Inherited from IChannelMonitor<(Of <(D>)>).)
CreateWorkbin | Creates a new workbin, general method. (Inherited from IWorkbinDomain.)
DeleteWorkbin | Deletes the given workbin. (Inherited from IWorkbinDomain.)
DeleteWorkbins | Deletes all the workbins. (Inherited from IWorkbinDomain.)
GetList | Overloaded.
GetWorkbin | Overloaded.
GetWorkbinContent | Gets all the multimedia interactions from the given workbin.
GetWorkbinsConfiguration | Gets the workbin's configuration. (Inherited from IWorkbinDomain.)
Handle | Processes a publishing event. (Inherited from ISubscribeable<(Of <(T>)>).)
ListStrategies | Gets the list of strategies for an object. (Inherited from IStrategyManager<(Of <(T>)>).)
Publish<(Of <(T>)>) | Publishes an object to listening subscribers. (Inherited from IBrokerPublisher.)
Pull | Overloaded.
Put | Overloaded.
RegisterEvents | Overloaded.
RegisterNotifications | Registers the notifications from the given workbin.
RemoveAllStrategies | Removes all strategies. (Inherited from IStrategyManager<(Of <(T>)>).)
RemoveChannel | Removes the given channel from the monitoring list. No events are received anymore for this channel. (Inherited from IChannelMonitor<(Of <(D>)>).)
RemoveStrategy | Removes a strategy of an object. (Inherited from IStrategyManager<(Of <(T>)>).)
SetStrategy | Sets a strategy to an object. (Inherited from IStrategyManager<(Of <(T>)>).)
UnRegisterEvents | Unregisters a specific handler for a given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
UnregisterNotifications | Unregisters the notifications from the given workbin.

See Also

IWorkbinService Interface
Genesyslab.Enterprise.Services Namespace


GetList Method

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.GetList Method
IWorkbinService Interface See Also Send Feedback

Overload List

Name | Description
GetList<(Of <(U>)>)(ItemLocation) | Gets the list of subscribers according to location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
GetList(Type, ItemLocation) | Gets the list of subscribers according to target and location flag. (Inherited from IBrokerSubscriber<(Of <(T>)>).)

See Also

IWorkbinService Interface
IWorkbinService Members
Genesyslab.Enterprise.Services Namespace


GetWorkbin Method

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.GetWorkbin Method
IWorkbinService Interface See Also Send Feedback

Overload List

Name | Description
GetWorkbin(String) | Gets the workbin. (Inherited from IWorkbinDomain.)
GetWorkbin(IDevice, WorkbinType, String, String) | Gets the workbin. (Inherited from IWorkbinDomain.)

See Also

IWorkbinService Interface
IWorkbinService Members
Genesyslab.Enterprise.Services Namespace


GetWorkbinContent Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.GetWorkbinContent Method
IWorkbinService Interface See Also Send Feedback
Gets all the multimedia interactions from the given workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService GetWorkbinContent(
    IClientChannel channel,
    IDevice placeDevice,
    IWorkbin workbin,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function GetWorkbinContent ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    workbin As IWorkbin, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IWorkbinService
Visual C++
IWorkbinService^ GetWorkbinContent(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IWorkbin^ workbin,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Genesyslab.Enterprise.Services Namespace


Pull Method

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.Pull Method
IWorkbinService Interface See Also Send Feedback

Overload List

Name | Description
Pull(IClientChannel, IDevice, IWorkbin, String, KeyValueCollection, KeyValueCollection) | Pulls (removes) the given multimedia interaction from the given workbin. The interaction is opened on the agent's place.
Pull(IClientChannel, IDevice, IWorkbin, String, KeyValueCollection, KeyValueCollection, String) | Pulls (removes) the multimedia interaction from the given workbin. The interaction multimedia is opened on the agent place.

See Also

IWorkbinService Interface
IWorkbinService Members
Genesyslab.Enterprise.Services Namespace


Pull Method (IClientChannel, IDevice, IWorkbin, String, , )

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.Pull Method (IClientChannel, IDevice, IWorkbin, String, , )
IWorkbinService Interface See Also Send Feedback
Pulls (removes) the given multimedia interaction from the given workbin. The interaction is opened on the agent's place.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService Pull(
    IClientChannel channel,
    IDevice placeDevice,
    IWorkbin workbin,
    string interactionID,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Pull ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    workbin As IWorkbin, _
    interactionID As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IWorkbinService
Visual C++
IWorkbinService^ Pull(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IWorkbin^ workbin,
    String^ interactionID,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.
interactionID
Type: System..::.String
the multimedia interaction identifier.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Pull Overload
Genesyslab.Enterprise.Services Namespace


Pull Method (IClientChannel, IDevice, IWorkbin, String, , , String)

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.Pull Method (IClientChannel, IDevice, IWorkbin, String, , , String)
IWorkbinService Interface See Also Send Feedback
Pulls (removes) the multimedia interaction from the given workbin. The interaction multimedia is opened on the agent place.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService Pull(
    IClientChannel channel,
    IDevice placeDevice,
    IWorkbin workbin,
    string interactionID,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Pull ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    workbin As IWorkbin, _
    interactionID As String, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IWorkbinService
Visual C++
IWorkbinService^ Pull(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IWorkbin^ workbin,
    String^ interactionID,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.
interactionID
Type: System..::.String
the multimedia interaction identifier.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.
correlatorData
Type: System..::.String
the correlator data.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Pull Overload
Genesyslab.Enterprise.Services Namespace


Put Method

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.Put Method
IWorkbinService Interface See Also Send Feedback

Overload List

Name | Description
Put(IClientChannel, IDevice, IOpenMediaInteraction, IWorkbin, KeyValueCollection, KeyValueCollection) | Puts the given multimedia interaction into the given workbin.
Put(IClientChannel, IDevice, IOpenMediaInteraction, IWorkbin, KeyValueCollection, KeyValueCollection, String) | Puts the given multimedia interaction into the given workbin.

See Also

IWorkbinService Interface
IWorkbinService Members
Genesyslab.Enterprise.Services Namespace


Put Method (IClientChannel, IDevice, IOpenMediaInteraction, IWorkbin, , )

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.Put Method (IClientChannel, IDevice, IOpenMediaInteraction, IWorkbin, , )
IWorkbinService Interface See Also Send Feedback
Puts the given multimedia interaction into the given workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService Put(
    IClientChannel channel,
    IDevice placeDevice,
    IOpenMediaInteraction interaction,
    IWorkbin workbin,
    KeyValueCollection reason,
    KeyValueCollection extensions
)
Visual Basic (Declaration)
Function Put ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    interaction As IOpenMediaInteraction, _
    workbin As IWorkbin, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection _
) As IWorkbinService
Visual C++
IWorkbinService^ Put(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IOpenMediaInteraction^ interaction,
    IWorkbin^ workbin,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the multimedia channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
the multimedia interaction.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Put Overload
Genesyslab.Enterprise.Services Namespace


Put Method (IClientChannel, IDevice, IOpenMediaInteraction, IWorkbin, , , String)

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.Put Method (IClientChannel, IDevice, IOpenMediaInteraction, IWorkbin, , , String)
IWorkbinService Interface See Also Send Feedback
Puts the given multimedia interaction into the given workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService Put(
    IClientChannel channel,
    IDevice placeDevice,
    IOpenMediaInteraction interaction,
    IWorkbin workbin,
    KeyValueCollection reason,
    KeyValueCollection extensions,
    string correlatorData
)
Visual Basic (Declaration)
Function Put ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    interaction As IOpenMediaInteraction, _
    workbin As IWorkbin, _
    reason As KeyValueCollection, _
    extensions As KeyValueCollection, _
    correlatorData As String _
) As IWorkbinService
Visual C++
IWorkbinService^ Put(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IOpenMediaInteraction^ interaction,
    IWorkbin^ workbin,
    KeyValueCollection^ reason,
    KeyValueCollection^ extensions,
    String^ correlatorData
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the multimedia channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
interaction
Type: Genesyslab.Enterprise.Model.Interaction..::.IOpenMediaInteraction
the multimedia interaction.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.
reason
Type: KeyValueCollection
the reason as described in IOpenMediaService.
extensions
Type: KeyValueCollection
the extensions.
correlatorData
Type: System..::.String
the correlator data.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Put Overload
Genesyslab.Enterprise.Services Namespace


RegisterEvents Method

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.RegisterEvents Method
IWorkbinService Interface See Also Send Feedback

Overload List

Name | Description
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) |
RegisterEvents(IClientChannel, Action<(Of <(T>)>)) | Registers a callback method for the given channel. (Inherited from IEventManager<(Of <(D, T>)>).)
RegisterEvents(IClientChannel, Action<(Of <(T>)>), array<String>[]()[], array<IFilter>[]()[]) | Registers a callback method on the given channel with filters. (Inherited from IEventManager<(Of <(D, T>)>).)

See Also

IWorkbinService Interface
IWorkbinService Members
Genesyslab.Enterprise.Services Namespace


RegisterNotifications Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.RegisterNotifications Method
IWorkbinService Interface See Also Send Feedback
Registers the notifications from the given workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService RegisterNotifications(
    IClientChannel channel,
    IDevice placeDevice,
    IWorkbin workbin
)
Visual Basic (Declaration)
Function RegisterNotifications ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    workbin As IWorkbin _
) As IWorkbinService
Visual C++
IWorkbinService^ RegisterNotifications(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IWorkbin^ workbin
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the multimedia channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Genesyslab.Enterprise.Services Namespace


UnregisterNotifications Method

[image]

Enterprise SDK 8.0 Reference API
IWorkbinService..::.UnregisterNotifications Method
IWorkbinService Interface See Also Send Feedback
Unregisters the notifications from the given workbin.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IWorkbinService UnregisterNotifications(
    IClientChannel channel,
    IDevice placeDevice,
    IWorkbin workbin
)
Visual Basic (Declaration)
Function UnregisterNotifications ( _
    channel As IClientChannel, _
    placeDevice As IDevice, _
    workbin As IWorkbin _
) As IWorkbinService
Visual C++
IWorkbinService^ UnregisterNotifications(
    IClientChannel^ channel,
    IDevice^ placeDevice,
    IWorkbin^ workbin
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel
the multimedia channel.
placeDevice
Type: Genesyslab.Enterprise.Model.Device..::.IDevice
the device of type place.
workbin
Type: Genesyslab.Enterprise.Model.Interaction..::.IWorkbin
the workbin.

Return Value

the workbin service.

See Also

IWorkbinService Interface
Genesyslab.Enterprise.Services Namespace


IWorkbinService Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IWorkbinService Properties
IWorkbinService Interface See Also Send Feedback

The IWorkbinService type exposes the following members.

Properties

Name | Description
Count | Gets the number of subscribers. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
EventSubscription | Gets the subscriber object of type T. (Inherited from IBrokerSubscriber<(Of <(T>)>).)
Filter | Returns the filter predicate which indicates whether publishing event should be processed or ignored. (Inherited from ISubscribeable<(Of <(T>)>).)

See Also

IWorkbinService Interface
Genesyslab.Enterprise.Services Namespace


MessageContentType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MessageContentType Enumeration
See Also Send Feedback
Enumerates the content type of the message.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MessageContentType
Visual Basic (Declaration)
Public Enumeration MessageContentType
Visual C++
public enum class MessageContentType

Members

Member name | Description
TextPlain | Textual data; Defined in RFC 2046 and RFC 3676. text/plain
TextHTML | Content HTML; Defined in RFC 2854. text/html

See Also

Genesyslab.Enterprise.Services Namespace


MonitorNotificationMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorNotificationMode Enumeration
See Also Send Feedback
Statistics Notification mode. Event notification mode for subscribed statistics.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MonitorNotificationMode
Visual Basic (Declaration)
Public Enumeration MonitorNotificationMode
Visual C++
public enum class MonitorNotificationMode

Members

Member name | Description
ChangesBased | Based on statistics changes.
TimeBased | Based on time.

See Also

Genesyslab.Enterprise.Services Namespace


MonitorObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
MonitorObjectType Enumeration
See Also Send Feedback
Enumerates the statistics object types.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum MonitorObjectType
Visual Basic (Declaration)
Public Enumeration MonitorObjectType
Visual C++
public enum class MonitorObjectType

Members

Member name | Description
Agent | Agent type.
AgentGroup | AgentGroup type.

See Also

Genesyslab.Enterprise.Services Namespace


PhoneType Enumeration

[image]

Enterprise SDK 8.0 Reference API
PhoneType Enumeration
See Also Send Feedback
Enumerates for the outbound phone type.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum PhoneType
Visual Basic (Declaration)
Public Enumeration PhoneType
Visual C++
public enum class PhoneType

Members

Member name | Description
NO_TYPE | No Contact Type.
HOME_PHONE | Home Phone.
DIRECT_BUSINESS_PHONE | Direct Business Phone.
BUSINESS_WITH_EXTENSION | Business With Extension.
MOBILE | Mobile.
VACATION_PHONE | Vacation Phone.
PAGER | Pager.
MODEM | Modem.
VOICE_MAIL | Voice Mail.
PIN_PAGER | PIN Pager.
EMAIL_ADDRESS | Email Address.
INSTANT_MESSAGING | Instant Messaging.

See Also

Genesyslab.Enterprise.Services Namespace


ProtocolAction Enumeration

[image]

Enterprise SDK 8.0 Reference API
ProtocolAction Enumeration
See Also Send Feedback
Enumerates the actions that are possible on this interaction. To be used in the methods of IsPossible.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ProtocolAction
Visual Basic (Declaration)
Public Enumeration ProtocolAction
Visual C++
public enum class ProtocolAction

Members

Member name | Description
Alternate | Places the active call on hold and connects the call that was held.
AnswerCall | Answers the ringing call.
AttachUserData | Attach User Data to the current call.
CancelForward | Sets the Forwarding feature to Off.
CompleteConference | Completes a conference previously initiated.
CompleteTransfer | Completes the two-step transfer.
InitConference | Initiates a conference. Holds the current call and dials a consultation call with another agent.
DeleteFromConference | Deletes a party from the conference.
DeleteUserData | Delete User Data from the current call.
Hold | Places the call on hold.
InitTransfer | Initiates a two-step transfer. Holds the current call and dials a consultation call with another agent.
ListenDisconnect | Sets the Deaf mode for the specified party.
ListenReconnect | Cancels Deaf mode for the specified party.
Login | Login this device.
Logout | Logout this device.
MakeCall | Makes a regular call.
MuteOff | Cancels the Mute mode for the specified party.
MuteOn | Sets the Mute mode for the specified party.
MuteTransfer | Transfers this call in one blind step to the destination.
NotReady | Sets not ready this device.
Ready | Sets this device ready.
Reconnect | Releases the active call and retrieves the previously held call.
RedirectCall | Redirects the call, without an answer.
ReleaseCall | Releases the call.
Retrieve | Retrieves the call placed on hold.
SendDTMF | Sends digits to an Interactive Voice Response (IVR) system.
SetDNDOff | Deactivates the Do-Not-Disturb (DND) mode.
SetDNDOn | Activates the Do-Not-Disturb (DND) mode.
SetForward | Sets the Forwarding feature to On.
SingleStepConference | Adds a new party to an existing call and creates a conference.
SingleStepTransfer | Transfers this call in one step to the destination.
UpdateUserData | Update User Data of the current call.

See Also

Genesyslab.Enterprise.Services Namespace


RecordStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
RecordStatus Enumeration
See Also Send Feedback
Enumerates for the outbound record status.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum RecordStatus
Visual Basic (Declaration)
Public Enumeration RecordStatus
Visual C++
public enum class RecordStatus

Members

Member name | Description
NORECORD_STATUS | No Record Status.
READY | Ready.
RETRIEVED | Retrieved.
UPDATED | Updated.
STALE | Stale.
CANCELLED | Cancelled.
AGENTERROR | Agent Error.
CHAINUPDATED | Chain Updated.
MISSEDCALLBACK | Missed Callback.

See Also

Genesyslab.Enterprise.Services Namespace


RecordType Enumeration

[image]

Enterprise SDK 8.0 Reference API
RecordType Enumeration
See Also Send Feedback
Enumerates for the outbound record types.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum RecordType
Visual Basic (Declaration)
Public Enumeration RecordType
Visual C++
public enum class RecordType

Members

Member name | Description
NORECORDTYPE | No Record Type.
UNKNOWN | Unknown.
GENERAL | General.
CAMPAIGN_RESCHEDULED | Campaign Rescheduled.
PERSONAL_RESCHEDULED | Personal Rescheduled.
PERSONAL_CALLBACK | Personal Callback.
CAMPAIGN_CALLBACK | Campaign Callback.
NOCALL | No Call.

See Also

Genesyslab.Enterprise.Services Namespace


SmsProperty Enumeration

[image]

Enterprise SDK 8.0 Reference API
SmsProperty Enumeration
See Also Send Feedback
List of properties that can be accessed within an SMS object

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum SmsProperty
Visual Basic (Declaration)
Public Enumeration SmsProperty
Visual C++
public enum class SmsProperty

Members

Member name | Description
DestinationNumber | Destination number
SourceNumber | Sender number
Transcript | Message to be sent with the SMS
Subject | Sms subject
EncodingType | Type of encosing message

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorModeType Enumeration
See Also Send Feedback
Enumerates the monitor modes.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum SupervisorModeType
Visual Basic (Declaration)
Public Enumeration SupervisorModeType
Visual C++
public enum class SupervisorModeType

Members

Member name | Description
Single | Monitor once call.
All | Monitor all calls until explicitely canceled.

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorObjectType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorObjectType Enumeration
See Also Send Feedback
Enumerates the types of objects involved in monitoring.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum SupervisorObjectType
Visual Basic (Declaration)
Public Enumeration SupervisorObjectType
Visual C++
public enum class SupervisorObjectType

Members

Member name | Description
Agent |
Device |
Interaction |

See Also

Genesyslab.Enterprise.Services Namespace


SupervisorStateType Enumeration

[image]

Enterprise SDK 8.0 Reference API
SupervisorStateType Enumeration
See Also Send Feedback
Enumerates the monitor statuses.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services (in Genesyslab.Enterprise.Services.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum SupervisorStateType
Visual Basic (Declaration)
Public Enumeration SupervisorStateType
Visual C++
public enum class SupervisorStateType

Members

Member name | Description
Unknown |
On |
Off |

See Also

Genesyslab.Enterprise.Services Namespace


Treatment Enumeration

[image]

Enterprise SDK 8.0 Reference API
Treatment Enumeration
See Also Send Feedback
Enumerates for the outbound treatment types.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Outbound (in Genesyslab.Enterprise.Services.Outbound.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum Treatment
Visual Basic (Declaration)
Public Enumeration Treatment
Visual C++
public enum class Treatment

Members

Member name | Description
PERSONAL | Personal.
CAMPAIGN | Campaign.

See Also

Genesyslab.Enterprise.Services Namespace


WorkbinType Enumeration

[image]

Enterprise SDK 8.0 Reference API
WorkbinType Enumeration
See Also Send Feedback
Enumerates the workbin types.

Namespace: Genesyslab.Enterprise.Services
Assembly: Genesyslab.Enterprise.Services.Multimedia (in Genesyslab.Enterprise.Services.Multimedia.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum WorkbinType
Visual Basic (Declaration)
Public Enumeration WorkbinType
Visual C++
public enum class WorkbinType

Members

Member name | Description
Agent | Agent workbin type.
AgentGroup | AgentGroup workbin type.
Place | Place workbin type.
PlaceGroup | PlaceGroup workbin type.

See Also

Genesyslab.Enterprise.Services Namespace


Genesyslab.Enterprise.Services.Common Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Common Namespace
Send Feedback

Structures

Structure | Description
Entry<(Of <(TKey, TValue>)>) |

Interfaces

Interface | Description
IAdapterFactory |
IDataManager |
IDataProvider |
IDataProvider<(Of <(T>)>) |


Entry(TKey, TValue) Structure

[image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>) Structure
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Entry`2"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public struct Entry<TKey, TValue>
Visual Basic (Declaration)
Public Structure Entry(Of TKey, TValue)
Visual C++
generic<typename TKey, typename TValue>
public value class Entry

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "T:Genesyslab.Enterprise.Services.Common.Entry`2"]

TValue

[Missing <typeparam name="TValue"/> documentation for "T:Genesyslab.Enterprise.Services.Common.Entry`2"]

See Also

Entry<(Of <(TKey, TValue>)>) Members
Genesyslab.Enterprise.Services.Common Namespace


Entry(TKey, TValue) Members

[image] [image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>) Members
Entry<(Of <(TKey, TValue>)>) Structure Constructors Methods Fields See Also Send Feedback

The Entry<(Of <(TKey, TValue>)>) type exposes the following members.

Constructors

Name | Description
Entry<(Of <(TKey, TValue>)>) |

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Key |
Value |

See Also

Entry<(Of <(TKey, TValue>)>) Structure
Genesyslab.Enterprise.Services.Common Namespace


Entry(TKey, TValue) Constructor

[image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>) Constructor
Entry<(Of <(TKey, TValue>)>) Structure See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Entry`2.#ctor(`0,`1)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public Entry(
    TKey key,
    TValue value
)
Visual Basic (Declaration)
Public Sub New ( _
    key As TKey, _
    value As TValue _
)
Visual C++
public:
Entry(
    TKey key,
    TValue value
)

Parameters

key
Type: TKey

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Entry`2.#ctor(`0,`1)"]

value
Type: TValue

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Entry`2.#ctor(`0,`1)"]

See Also

Entry<(Of <(TKey, TValue>)>) Structure
Genesyslab.Enterprise.Services.Common Namespace


Entry(TKey, TValue) Fields

[image] [image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>) Fields
Entry<(Of <(TKey, TValue>)>) Structure See Also Send Feedback

The Entry<(Of <(TKey, TValue>)>) type exposes the following members.

Fields

Name | Description
Key |
Value |

See Also

Entry<(Of <(TKey, TValue>)>) Structure
Genesyslab.Enterprise.Services.Common Namespace


Key Field

[image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>)..::.Key Field
Entry<(Of <(TKey, TValue>)>) Structure See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.Services.Common.Entry`2.Key"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public TKey Key
Visual Basic (Declaration)
Public Key As TKey
Visual C++
public:
TKey Key

See Also

Entry<(Of <(TKey, TValue>)>) Structure
Genesyslab.Enterprise.Services.Common Namespace


Value Field

[image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>)..::.Value Field
Entry<(Of <(TKey, TValue>)>) Structure See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.Services.Common.Entry`2.Value"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public TValue Value
Visual Basic (Declaration)
Public Value As TValue
Visual C++
public:
TValue Value

See Also

Entry<(Of <(TKey, TValue>)>) Structure
Genesyslab.Enterprise.Services.Common Namespace


Entry(TKey, TValue) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
Entry<(Of <(TKey, TValue>)>) Methods
Entry<(Of <(TKey, TValue>)>) Structure See Also Send Feedback

The Entry<(Of <(TKey, TValue>)>) type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

Entry<(Of <(TKey, TValue>)>) Structure
Genesyslab.Enterprise.Services.Common Namespace


IAdapterFactory Interface

[image]

Enterprise SDK 8.0 Reference API
IAdapterFactory Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.IAdapterFactory"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IAdapterFactory
Visual Basic (Declaration)
Public Interface IAdapterFactory
Visual C++
public interface class IAdapterFactory

See Also

IAdapterFactory Members
Genesyslab.Enterprise.Services.Common Namespace


IAdapterFactory Members

[image] [image]

Enterprise SDK 8.0 Reference API
IAdapterFactory Members
IAdapterFactory Interface Methods See Also Send Feedback

The IAdapterFactory type exposes the following members.

Methods

Name | Description
AddAdapter |
ClearCache |
GetAdapter | Overloaded.

See Also

IAdapterFactory Interface
Genesyslab.Enterprise.Services.Common Namespace


IAdapterFactory Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IAdapterFactory Methods
IAdapterFactory Interface See Also Send Feedback

The IAdapterFactory type exposes the following members.

Methods

Name | Description
AddAdapter |
ClearCache |
GetAdapter | Overloaded.

See Also

IAdapterFactory Interface
Genesyslab.Enterprise.Services.Common Namespace


AddAdapter Method

[image]

Enterprise SDK 8.0 Reference API
IAdapterFactory..::.AddAdapter Method
IAdapterFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.AddAdapter(System.Type,Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddAdapter(
    Type type,
    IDataAdapter adapter
)
Visual Basic (Declaration)
Sub AddAdapter ( _
    type As Type, _
    adapter As IDataAdapter _
)
Visual C++
void AddAdapter(
    Type^ type,
    IDataAdapter^ adapter
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.AddAdapter(System.Type,Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter)"]

adapter
Type: Genesyslab.Enterprise.Services.Common.Linq..::.IDataAdapter

[Missing <param name="adapter"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.AddAdapter(System.Type,Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter)"]

See Also

IAdapterFactory Interface
Genesyslab.Enterprise.Services.Common Namespace


ClearCache Method

[image]

Enterprise SDK 8.0 Reference API
IAdapterFactory..::.ClearCache Method
IAdapterFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.ClearCache"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void ClearCache()
Visual Basic (Declaration)
Sub ClearCache
Visual C++
void ClearCache()

See Also

IAdapterFactory Interface
Genesyslab.Enterprise.Services.Common Namespace


GetAdapter Method

[image] [image]

Enterprise SDK 8.0 Reference API
IAdapterFactory..::.GetAdapter Method
IAdapterFactory Interface See Also Send Feedback

Overload List

Name | Description
GetAdapter<(Of <(T>)>)()()() |
GetAdapter(Type) |

See Also

IAdapterFactory Interface
IAdapterFactory Members
Genesyslab.Enterprise.Services.Common Namespace


GetAdapter(T) Method

[image]

Enterprise SDK 8.0 Reference API
IAdapterFactory..::.GetAdapter<(Of <(T>)>) Method
IAdapterFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.GetAdapter``1"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDataAdapter<T> GetAdapter<T>()
Visual Basic (Declaration)
Function GetAdapter(Of T) As IDataAdapter(Of T)
Visual C++
generic<typename T>
IDataAdapter<T>^ GetAdapter()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.GetAdapter``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.GetAdapter``1"]

See Also

IAdapterFactory Interface
GetAdapter Overload
Genesyslab.Enterprise.Services.Common Namespace


GetAdapter Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IAdapterFactory..::.GetAdapter Method (Type)
IAdapterFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.GetAdapter(System.Type)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDataAdapter GetAdapter(
    Type type
)
Visual Basic (Declaration)
Function GetAdapter ( _
    type As Type _
) As IDataAdapter
Visual C++
IDataAdapter^ GetAdapter(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.GetAdapter(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IAdapterFactory.GetAdapter(System.Type)"]

See Also

IAdapterFactory Interface
GetAdapter Overload
Genesyslab.Enterprise.Services.Common Namespace


IDataManager Interface

[image]

Enterprise SDK 8.0 Reference API
IDataManager Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.IDataManager"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDataManager
Visual Basic (Declaration)
Public Interface IDataManager
Visual C++
public interface class IDataManager

See Also

IDataManager Members
Genesyslab.Enterprise.Services.Common Namespace


IDataManager Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataManager Members
IDataManager Interface Methods Properties See Also Send Feedback

The IDataManager type exposes the following members.

Methods

Name | Description
DeleteEntity<(Of <(T>)>) |
GetEntities<(Of <(T>)>) |
InsertEntity<(Of <(T>)>) |
UpdateEntity<(Of <(T>)>) |

Properties

Name | Description
ServiceProxy |

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


IDataManager Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataManager Methods
IDataManager Interface See Also Send Feedback

The IDataManager type exposes the following members.

Methods

Name | Description
DeleteEntity<(Of <(T>)>) |
GetEntities<(Of <(T>)>) |
InsertEntity<(Of <(T>)>) |
UpdateEntity<(Of <(T>)>) |

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


DeleteEntity(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDataManager..::.DeleteEntity<(Of <(T>)>) Method
IDataManager Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.DeleteEntity``1(``0)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool DeleteEntity<T>(
    T item
)
Visual Basic (Declaration)
Function DeleteEntity(Of T) ( _
    item As T _
) As Boolean
Visual C++
generic<typename T>
bool DeleteEntity(
    T item
)

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.DeleteEntity``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.DeleteEntity``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.DeleteEntity``1(``0)"]

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


GetEntities(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDataManager..::.GetEntities<(Of <(T>)>) Method
IDataManager Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.GetEntities``1(System.Linq.Expressions.Expression)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IQueryable<T> GetEntities<T>(
    Expression expression
)
Visual Basic (Declaration)
Function GetEntities(Of T) ( _
    expression As Expression _
) As IQueryable(Of T)
Visual C++
generic<typename T>
IQueryable<T>^ GetEntities(
    Expression^ expression
)

Parameters

expression
Type: System.Linq.Expressions..::.Expression

[Missing <param name="expression"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.GetEntities``1(System.Linq.Expressions.Expression)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.GetEntities``1(System.Linq.Expressions.Expression)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.GetEntities``1(System.Linq.Expressions.Expression)"]

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


InsertEntity(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDataManager..::.InsertEntity<(Of <(T>)>) Method
IDataManager Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.InsertEntity``1(``0)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool InsertEntity<T>(
    T item
)
Visual Basic (Declaration)
Function InsertEntity(Of T) ( _
    item As T _
) As Boolean
Visual C++
generic<typename T>
bool InsertEntity(
    T item
)

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.InsertEntity``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.InsertEntity``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.InsertEntity``1(``0)"]

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


UpdateEntity(T) Method

[image]

Enterprise SDK 8.0 Reference API
IDataManager..::.UpdateEntity<(Of <(T>)>) Method
IDataManager Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.UpdateEntity``1(``0)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool UpdateEntity<T>(
    T item
)
Visual Basic (Declaration)
Function UpdateEntity(Of T) ( _
    item As T _
) As Boolean
Visual C++
generic<typename T>
bool UpdateEntity(
    T item
)

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.UpdateEntity``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.UpdateEntity``1(``0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataManager.UpdateEntity``1(``0)"]

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


IDataManager Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDataManager Properties
IDataManager Interface See Also Send Feedback

The IDataManager type exposes the following members.

Properties

Name | Description
ServiceProxy |

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


ServiceProxy Property

[image]

Enterprise SDK 8.0 Reference API
IDataManager..::.ServiceProxy Property
IDataManager Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.IDataManager.ServiceProxy"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
LockingQueryServiceProxy ServiceProxy { get; }
Visual Basic (Declaration)
ReadOnly Property ServiceProxy As LockingQueryServiceProxy
Visual C++
property LockingQueryServiceProxy^ ServiceProxy {
    LockingQueryServiceProxy^ get ();
}

See Also

IDataManager Interface
Genesyslab.Enterprise.Services.Common Namespace


IDataProvider Interface

[image]

Enterprise SDK 8.0 Reference API
IDataProvider Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.IDataProvider"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDataProvider
Visual Basic (Declaration)
Public Interface IDataProvider
Visual C++
public interface class IDataProvider

See Also

IDataProvider Members
Genesyslab.Enterprise.Services.Common Namespace


IDataProvider Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider Members
IDataProvider Interface Methods See Also Send Feedback

The IDataProvider type exposes the following members.

Methods

Name | Description
Delete |
GetEntities |
Insert |
Update |

See Also

IDataProvider Interface
Genesyslab.Enterprise.Services.Common Namespace


IDataProvider Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider Methods
IDataProvider Interface See Also Send Feedback

The IDataProvider type exposes the following members.

Methods

Name | Description
Delete |
GetEntities |
Insert |
Update |

See Also

IDataProvider Interface
Genesyslab.Enterprise.Services.Common Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
IDataProvider..::.Delete Method
IDataProvider Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Delete(Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Delete(
    IDeleteQuery query
)
Visual Basic (Declaration)
Function Delete ( _
    query As IDeleteQuery _
) As Boolean
Visual C++
bool Delete(
    IDeleteQuery^ query
)

Parameters

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IDeleteQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Delete(Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Delete(Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

See Also

IDataProvider Interface
Genesyslab.Enterprise.Services.Common Namespace


GetEntities Method

[image]

Enterprise SDK 8.0 Reference API
IDataProvider..::.GetEntities Method
IDataProvider Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.GetEntities(Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable GetEntities(
    IReadQuery query
)
Visual Basic (Declaration)
Function GetEntities ( _
    query As IReadQuery _
) As IEnumerable
Visual C++
IEnumerable^ GetEntities(
    IReadQuery^ query
)

Parameters

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IReadQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.GetEntities(Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.GetEntities(Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

See Also

IDataProvider Interface
Genesyslab.Enterprise.Services.Common Namespace


Insert Method

[image]

Enterprise SDK 8.0 Reference API
IDataProvider..::.Insert Method
IDataProvider Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Insert(Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Insert(
    IInsertQuery query
)
Visual Basic (Declaration)
Function Insert ( _
    query As IInsertQuery _
) As Boolean
Visual C++
bool Insert(
    IInsertQuery^ query
)

Parameters

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IInsertQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Insert(Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Insert(Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

See Also

IDataProvider Interface
Genesyslab.Enterprise.Services.Common Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
IDataProvider..::.Update Method
IDataProvider Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Update(Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Update(
    IUpdateQuery query
)
Visual Basic (Declaration)
Function Update ( _
    query As IUpdateQuery _
) As Boolean
Visual C++
bool Update(
    IUpdateQuery^ query
)

Parameters

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IUpdateQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Update(Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider.Update(Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

See Also

IDataProvider Interface
Genesyslab.Enterprise.Services.Common Namespace


IDataProvider(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>) Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.IDataProvider`1"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDataProvider<T> : IDataProvider
Visual Basic (Declaration)
Public Interface IDataProvider(Of T) _
    Implements IDataProvider
Visual C++
generic<typename T>
public interface class IDataProvider : IDataProvider

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.Common.IDataProvider`1"]

See Also

IDataProvider<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common Namespace


IDataProvider(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>) Members
IDataProvider<(Of <(T>)>) Interface Methods See Also Send Feedback

Methods

Name | Description
Delete | Overloaded.
GetEntities | Overloaded.
Insert | Overloaded.
Update | Overloaded.

See Also

IDataProvider<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common Namespace


IDataProvider(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>) Methods
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
Delete | Overloaded.
GetEntities | Overloaded.
Insert | Overloaded.
Update | Overloaded.

See Also

IDataProvider<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common Namespace


Delete Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.Delete Method
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Delete(IDeleteQuery) | (Inherited from IDataProvider.)
Delete(DeleteQuery<(Of <(T>)>)) |

See Also

IDataProvider<(Of <(T>)>) Interface
IDataProvider<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common Namespace


Delete Method ((T))

[image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.Delete Method (<(Of <(T>)>))
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Delete(Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Delete(
    DeleteQuery<T> query
)
Visual Basic (Declaration)
Function Delete ( _
    query As DeleteQuery(Of T) _
) As Boolean
Visual C++
bool Delete(
    DeleteQuery<T>^ query
)

Parameters

query
Type: DeleteQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Delete(Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Delete(Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

See Also

IDataProvider<(Of <(T>)>) Interface
Delete Overload
Genesyslab.Enterprise.Services.Common Namespace


GetEntities Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.GetEntities Method
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
GetEntities(IReadQuery) | (Inherited from IDataProvider.)
GetEntities(ReadQuery<(Of <(T>)>)) |

See Also

IDataProvider<(Of <(T>)>) Interface
IDataProvider<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common Namespace


GetEntities Method ((T))

[image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.GetEntities Method (<(Of <(T>)>))
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.GetEntities(Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> GetEntities(
    ReadQuery<T> query
)
Visual Basic (Declaration)
Function GetEntities ( _
    query As ReadQuery(Of T) _
) As IEnumerable(Of T)
Visual C++
IEnumerable<T>^ GetEntities(
    ReadQuery<T>^ query
)

Parameters

query
Type: ReadQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.GetEntities(Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.GetEntities(Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

See Also

IDataProvider<(Of <(T>)>) Interface
GetEntities Overload
Genesyslab.Enterprise.Services.Common Namespace


Insert Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.Insert Method
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Insert(IInsertQuery) | (Inherited from IDataProvider.)
Insert(InsertQuery<(Of <(T>)>)) |

See Also

IDataProvider<(Of <(T>)>) Interface
IDataProvider<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common Namespace


Insert Method ((T))

[image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.Insert Method (<(Of <(T>)>))
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Insert(Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Insert(
    InsertQuery<T> query
)
Visual Basic (Declaration)
Function Insert ( _
    query As InsertQuery(Of T) _
) As Boolean
Visual C++
bool Insert(
    InsertQuery<T>^ query
)

Parameters

query
Type: InsertQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Insert(Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Insert(Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

See Also

IDataProvider<(Of <(T>)>) Interface
Insert Overload
Genesyslab.Enterprise.Services.Common Namespace


Update Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.Update Method
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Update(IUpdateQuery) | (Inherited from IDataProvider.)
Update(UpdateQuery<(Of <(T>)>)) |

See Also

IDataProvider<(Of <(T>)>) Interface
IDataProvider<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common Namespace


Update Method ((T))

[image]

Enterprise SDK 8.0 Reference API
IDataProvider<(Of <(T>)>)..::.Update Method (<(Of <(T>)>))
IDataProvider<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Update(Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Update(
    UpdateQuery<T> query
)
Visual Basic (Declaration)
Function Update ( _
    query As UpdateQuery(Of T) _
) As Boolean
Visual C++
bool Update(
    UpdateQuery<T>^ query
)

Parameters

query
Type: UpdateQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Update(Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.IDataProvider`1.Update(Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

See Also

IDataProvider<(Of <(T>)>) Interface
Update Overload
Genesyslab.Enterprise.Services.Common Namespace


Genesyslab.Enterprise.Services.Common.Linq Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Common.Linq Namespace
Send Feedback

Interfaces

Interface | Description
IDataAdapter |
IDataAdapter<(Of <(T>)>) |
INotifyEntityChanged |

Enumerations

Enumeration | Description
ObjectState |


IDataAdapter Interface

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDataAdapter
Visual Basic (Declaration)
Public Interface IDataAdapter
Visual C++
public interface class IDataAdapter

See Also

IDataAdapter Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter Members
IDataAdapter Interface Methods Properties See Also Send Feedback

The IDataAdapter type exposes the following members.

Methods

Name | Description
Delete |
Insert |
Read |
Update |

Properties

Name | Description
DataService |

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter Methods
IDataAdapter Interface See Also Send Feedback

The IDataAdapter type exposes the following members.

Methods

Name | Description
Delete |
Insert |
Read |
Update |

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter..::.Delete Method
IDataAdapter Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Delete(
    UUID uuid,
    Object item
)
Visual Basic (Declaration)
Function Delete ( _
    uuid As UUID, _
    item As Object _
) As Boolean
Visual C++
bool Delete(
    UUID^ uuid,
    Object^ item
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


Insert Method

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter..::.Insert Method
IDataAdapter Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Insert(
    UUID uuid,
    Object item
)
Visual Basic (Declaration)
Function Insert ( _
    uuid As UUID, _
    item As Object _
) As Boolean
Visual C++
bool Insert(
    UUID^ uuid,
    Object^ item
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


Read Method

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter..::.Read Method
IDataAdapter Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IQueryable Read(
    UUID uuid,
    Expression expression
)
Visual Basic (Declaration)
Function Read ( _
    uuid As UUID, _
    expression As Expression _
) As IQueryable
Visual C++
IQueryable^ Read(
    UUID^ uuid,
    Expression^ expression
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

expression
Type: System.Linq.Expressions..::.Expression

[Missing <param name="expression"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter..::.Update Method
IDataAdapter Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Update(
    UUID uuid,
    Object item
)
Visual Basic (Declaration)
Function Update ( _
    uuid As UUID, _
    item As Object _
) As Boolean
Visual C++
bool Update(
    UUID^ uuid,
    Object^ item
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Object)"]

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter Properties
IDataAdapter Interface See Also Send Feedback

The IDataAdapter type exposes the following members.

Properties

Name | Description
DataService |

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


DataService Property

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter..::.DataService Property
IDataAdapter Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter.DataService"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDataManager DataService { get; }
Visual Basic (Declaration)
ReadOnly Property DataService As IDataManager
Visual C++
property IDataManager^ DataService {
    IDataManager^ get ();
}

See Also

IDataAdapter Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>) Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDataAdapter<T> : IDataAdapter
Visual Basic (Declaration)
Public Interface IDataAdapter(Of T) _
    Implements IDataAdapter
Visual C++
generic<typename T>
public interface class IDataAdapter : IDataAdapter

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1"]

See Also

IDataAdapter<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>) Members
IDataAdapter<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IDataAdapter<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Delete | Overloaded.
Insert | Overloaded.
Read | Overloaded.
Update | Overloaded.

Properties

Name | Description
DataService | (Inherited from IDataAdapter.)

See Also

IDataAdapter<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>) Methods
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
Delete | Overloaded.
Insert | Overloaded.
Read | Overloaded.
Update | Overloaded.

See Also

IDataAdapter<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


Delete Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Delete Method
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Delete(UUID, Object) | (Inherited from IDataAdapter.)
Delete(UUID, T) |

See Also

IDataAdapter<(Of <(T>)>) Interface
IDataAdapter<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


Delete Method (, T)

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Delete Method (, T)
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Delete(
    UUID uuid,
    T item
)
Visual Basic (Declaration)
Function Delete ( _
    uuid As UUID, _
    item As T _
) As Boolean
Visual C++
bool Delete(
    UUID^ uuid,
    T item
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

item
Type: T

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

See Also

IDataAdapter<(Of <(T>)>) Interface
Delete Overload
Genesyslab.Enterprise.Services.Common.Linq Namespace


Insert Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Insert Method
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Insert(UUID, Object) | (Inherited from IDataAdapter.)
Insert(UUID, T) |

See Also

IDataAdapter<(Of <(T>)>) Interface
IDataAdapter<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


Insert Method (, T)

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Insert Method (, T)
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Insert(
    UUID uuid,
    T item
)
Visual Basic (Declaration)
Function Insert ( _
    uuid As UUID, _
    item As T _
) As Boolean
Visual C++
bool Insert(
    UUID^ uuid,
    T item
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

item
Type: T

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

See Also

IDataAdapter<(Of <(T>)>) Interface
Insert Overload
Genesyslab.Enterprise.Services.Common.Linq Namespace


Read Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Read Method
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Read(UUID, Expression) | (Inherited from IDataAdapter.)
Read(UUID, Expression) |

See Also

IDataAdapter<(Of <(T>)>) Interface
IDataAdapter<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


Read Method (, Expression)

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Read Method (, Expression)
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IQueryable<T> Read(
    UUID uuid,
    Expression expression
)
Visual Basic (Declaration)
Function Read ( _
    uuid As UUID, _
    expression As Expression _
) As IQueryable(Of T)
Visual C++
IQueryable<T>^ Read(
    UUID^ uuid,
    Expression^ expression
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

expression
Type: System.Linq.Expressions..::.Expression

[Missing <param name="expression"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Read(Genesyslab.Enterprise.Services.Common.Locking.UUID,System.Linq.Expressions.Expression)"]

See Also

IDataAdapter<(Of <(T>)>) Interface
Read Overload
Genesyslab.Enterprise.Services.Common.Linq Namespace


Update Method

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Update Method
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Update(UUID, Object) | (Inherited from IDataAdapter.)
Update(UUID, T) |

See Also

IDataAdapter<(Of <(T>)>) Interface
IDataAdapter<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


Update Method (, T)

[image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>)..::.Update Method (, T)
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Update(
    UUID uuid,
    T item
)
Visual Basic (Declaration)
Function Update ( _
    uuid As UUID, _
    item As T _
) As Boolean
Visual C++
bool Update(
    UUID^ uuid,
    T item
)

Parameters

uuid
Type: UUID

[Missing <param name="uuid"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

item
Type: T

[Missing <param name="item"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Linq.IDataAdapter`1.Update(Genesyslab.Enterprise.Services.Common.Locking.UUID,`0)"]

See Also

IDataAdapter<(Of <(T>)>) Interface
Update Overload
Genesyslab.Enterprise.Services.Common.Linq Namespace


IDataAdapter(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDataAdapter<(Of <(T>)>) Properties
IDataAdapter<(Of <(T>)>) Interface See Also Send Feedback

The IDataAdapter<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
DataService | (Inherited from IDataAdapter.)

See Also

IDataAdapter<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


INotifyEntityChanged Interface

[image]

Enterprise SDK 8.0 Reference API
INotifyEntityChanged Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Linq.INotifyEntityChanged"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface INotifyEntityChanged
Visual Basic (Declaration)
Public Interface INotifyEntityChanged
Visual C++
public interface class INotifyEntityChanged

See Also

INotifyEntityChanged Members
Genesyslab.Enterprise.Services.Common.Linq Namespace


INotifyEntityChanged Members

[image] [image]

Enterprise SDK 8.0 Reference API
INotifyEntityChanged Members
INotifyEntityChanged Interface Events See Also Send Feedback

The INotifyEntityChanged type exposes the following members.

Events

Name | Description
EntityChanged |

See Also

INotifyEntityChanged Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


INotifyEntityChanged Events

[image] [image]

Enterprise SDK 8.0 Reference API
INotifyEntityChanged Events
INotifyEntityChanged Interface See Also Send Feedback

The INotifyEntityChanged type exposes the following members.

Events

Name | Description
EntityChanged |

See Also

INotifyEntityChanged Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


EntityChanged Event

[image]

Enterprise SDK 8.0 Reference API
INotifyEntityChanged..::.EntityChanged Event
INotifyEntityChanged Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Services.Common.Linq.INotifyEntityChanged.EntityChanged"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event EntityChangedEventHandler EntityChanged
Visual Basic (Declaration)
Event EntityChanged As EntityChangedEventHandler
Visual C++
 event EntityChangedEventHandler^ EntityChanged {
    void add (EntityChangedEventHandler^ value);
    void remove (EntityChangedEventHandler^ value);
}

See Also

INotifyEntityChanged Interface
Genesyslab.Enterprise.Services.Common.Linq Namespace


ObjectState Enumeration

[image]

Enterprise SDK 8.0 Reference API
ObjectState Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Linq.ObjectState"]

Namespace: Genesyslab.Enterprise.Services.Common.Linq
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ObjectState
Visual Basic (Declaration)
Public Enumeration ObjectState
Visual C++
public enum class ObjectState

Members

Member name | Description
Unchanged |
Changed |
Inserted |
Deleted |

See Also

Genesyslab.Enterprise.Services.Common.Linq Namespace


Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace
Send Feedback

Interfaces

Interface | Description
IStrategyHandler |
IStrategyHandler<(Of <(T>)>) |


IStrategyHandler Interface

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStrategyHandler
Visual Basic (Declaration)
Public Interface IStrategyHandler
Visual C++
public interface class IStrategyHandler

See Also

IStrategyHandler Members
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler Members
IStrategyHandler Interface Methods Properties See Also Send Feedback

The IStrategyHandler type exposes the following members.

Methods

Name | Description
Delete |
Insert |
Read |
Update |

Properties

Name | Description
Strategy |

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler Methods
IStrategyHandler Interface See Also Send Feedback

The IStrategyHandler type exposes the following members.

Methods

Name | Description
Delete |
Insert |
Read |
Update |

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Delete Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler..::.Delete Method
IStrategyHandler Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Delete(
    Session session,
    IDeleteQuery query
)
Visual Basic (Declaration)
Function Delete ( _
    session As Session, _
    query As IDeleteQuery _
) As Boolean
Visual C++
bool Delete(
    Session^ session,
    IDeleteQuery^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IDeleteQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery)"]

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Insert Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler..::.Insert Method
IStrategyHandler Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Insert(
    Session session,
    IInsertQuery query
)
Visual Basic (Declaration)
Function Insert ( _
    session As Session, _
    query As IInsertQuery _
) As Boolean
Visual C++
bool Insert(
    Session^ session,
    IInsertQuery^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IInsertQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IInsertQuery)"]

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Read Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler..::.Read Method
IStrategyHandler Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable Read(
    Session session,
    IReadQuery query
)
Visual Basic (Declaration)
Function Read ( _
    session As Session, _
    query As IReadQuery _
) As IEnumerable
Visual C++
IEnumerable^ Read(
    Session^ session,
    IReadQuery^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IReadQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IReadQuery)"]

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Update Method

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler..::.Update Method
IStrategyHandler Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Update(
    Session session,
    IUpdateQuery query
)
Visual Basic (Declaration)
Function Update ( _
    session As Session, _
    query As IUpdateQuery _
) As Boolean
Visual C++
bool Update(
    Session^ session,
    IUpdateQuery^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

query
Type: Genesyslab.Enterprise.Services.Common.Query..::.IUpdateQuery

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery)"]

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler Properties
IStrategyHandler Interface See Also Send Feedback

The IStrategyHandler type exposes the following members.

Properties

Name | Description
Strategy |

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Strategy Property

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler..::.Strategy Property
IStrategyHandler Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler.Strategy"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
OptimisticLockingStrategy Strategy { get; set; }
Visual Basic (Declaration)
Property Strategy As OptimisticLockingStrategy
Visual C++
property OptimisticLockingStrategy^ Strategy {
    OptimisticLockingStrategy^ get ();
    void set (OptimisticLockingStrategy^ value);
}

See Also

IStrategyHandler Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>) Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IStrategyHandler<T> : IStrategyHandler
Visual Basic (Declaration)
Public Interface IStrategyHandler(Of T) _
    Implements IStrategyHandler
Visual C++
generic<typename T>
public interface class IStrategyHandler : IStrategyHandler

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1"]

See Also

IStrategyHandler<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>) Members
IStrategyHandler<(Of <(T>)>) Interface Methods Properties See Also Send Feedback

The IStrategyHandler<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Delete | Overloaded.
Insert | Overloaded.
Read | Overloaded.
Update | Overloaded.

Properties

Name | Description
Strategy | (Inherited from IStrategyHandler.)

See Also

IStrategyHandler<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>) Methods
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

Methods

Name | Description
Delete | Overloaded.
Insert | Overloaded.
Read | Overloaded.
Update | Overloaded.

See Also

IStrategyHandler<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Delete Method

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Delete Method
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Delete(Session, IDeleteQuery) | (Inherited from IStrategyHandler.)
Delete(Session, DeleteQuery<(Of <(T>)>)) |

See Also

IStrategyHandler<(Of <(T>)>) Interface
IStrategyHandler<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Delete Method (, (T))

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Delete Method (, <(Of <(T>)>))
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Delete(
    Session session,
    DeleteQuery<T> query
)
Visual Basic (Declaration)
Function Delete ( _
    session As Session, _
    query As DeleteQuery(Of T) _
) As Boolean
Visual C++
bool Delete(
    Session^ session,
    DeleteQuery<T>^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

query
Type: DeleteQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Delete(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.DeleteQuery{`0})"]

See Also

IStrategyHandler<(Of <(T>)>) Interface
Delete Overload
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Insert Method

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Insert Method
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Insert(Session, IInsertQuery) | (Inherited from IStrategyHandler.)
Insert(Session, InsertQuery<(Of <(T>)>)) |

See Also

IStrategyHandler<(Of <(T>)>) Interface
IStrategyHandler<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Insert Method (, (T))

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Insert Method (, <(Of <(T>)>))
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Insert(
    Session session,
    InsertQuery<T> query
)
Visual Basic (Declaration)
Function Insert ( _
    session As Session, _
    query As InsertQuery(Of T) _
) As Boolean
Visual C++
bool Insert(
    Session^ session,
    InsertQuery<T>^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

query
Type: InsertQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Insert(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.InsertQuery{`0})"]

See Also

IStrategyHandler<(Of <(T>)>) Interface
Insert Overload
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Read Method

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Read Method
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Read(Session, IReadQuery) | (Inherited from IStrategyHandler.)
Read(Session, ReadQuery<(Of <(T>)>)) |

See Also

IStrategyHandler<(Of <(T>)>) Interface
IStrategyHandler<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Read Method (, (T))

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Read Method (, <(Of <(T>)>))
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IEnumerable<T> Read(
    Session session,
    ReadQuery<T> query
)
Visual Basic (Declaration)
Function Read ( _
    session As Session, _
    query As ReadQuery(Of T) _
) As IEnumerable(Of T)
Visual C++
IEnumerable<T>^ Read(
    Session^ session,
    ReadQuery<T>^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

query
Type: ReadQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Read(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.ReadQuery{`0})"]

See Also

IStrategyHandler<(Of <(T>)>) Interface
Read Overload
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Update Method

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Update Method
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

Overload List

Name | Description
Update(Session, IUpdateQuery) | (Inherited from IStrategyHandler.)
Update(Session, UpdateQuery<(Of <(T>)>)) |

See Also

IStrategyHandler<(Of <(T>)>) Interface
IStrategyHandler<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Update Method (, (T))

[image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>)..::.Update Method (, <(Of <(T>)>))
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

Namespace: Genesyslab.Enterprise.Services.Common.Locking.Optimistic
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Update(
    Session session,
    UpdateQuery<T> query
)
Visual Basic (Declaration)
Function Update ( _
    session As Session, _
    query As UpdateQuery(Of T) _
) As Boolean
Visual C++
bool Update(
    Session^ session,
    UpdateQuery<T>^ query
)

Parameters

session
Type: Session

[Missing <param name="session"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

query
Type: UpdateQuery<(Of <( T >)>)

[Missing <param name="query"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Locking.Optimistic.IStrategyHandler`1.Update(Genesyslab.Enterprise.Services.Common.Locking.Session,Genesyslab.Enterprise.Services.Common.Query.UpdateQuery{`0})"]

See Also

IStrategyHandler<(Of <(T>)>) Interface
Update Overload
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


IStrategyHandler(T) Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IStrategyHandler<(Of <(T>)>) Properties
IStrategyHandler<(Of <(T>)>) Interface See Also Send Feedback

The IStrategyHandler<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Strategy | (Inherited from IStrategyHandler.)

See Also

IStrategyHandler<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Locking.Optimistic Namespace


Genesyslab.Enterprise.Services.Common.Query Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Common.Query Namespace
Send Feedback

Interfaces

Interface | Description
IDeleteQuery |
IInsertQuery |
IQuery |
IQuery<(Of <(T>)>) |
IQueryFactory |
IReadQuery |
IReadQueryFactory |
IUpdateQuery |

Enumerations

Enumeration | Description
ExpressionType |


ExpressionType Enumeration

[image]

Enterprise SDK 8.0 Reference API
ExpressionType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.ExpressionType"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ExpressionType
Visual Basic (Declaration)
Public Enumeration ExpressionType
Visual C++
public enum class ExpressionType

Members

Member name | Description
Unary |
Binary |
Constant |
Member |

See Also

Genesyslab.Enterprise.Services.Common.Query Namespace


IDeleteQuery Interface

[image]

Enterprise SDK 8.0 Reference API
IDeleteQuery Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IDeleteQuery : IQuery
Visual Basic (Declaration)
Public Interface IDeleteQuery _
    Implements IQuery
Visual C++
public interface class IDeleteQuery : IQuery

See Also

IDeleteQuery Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IDeleteQuery Members

[image] [image]

Enterprise SDK 8.0 Reference API
IDeleteQuery Members
IDeleteQuery Interface Methods Properties See Also Send Feedback

The IDeleteQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

Properties

Name | Description
Item |

See Also

IDeleteQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IDeleteQuery Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IDeleteQuery Methods
IDeleteQuery Interface See Also Send Feedback

The IDeleteQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

See Also

IDeleteQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IDeleteQuery Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IDeleteQuery Properties
IDeleteQuery Interface See Also Send Feedback

The IDeleteQuery type exposes the following members.

Properties

Name | Description
Item |

See Also

IDeleteQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IDeleteQuery..::.Item Property
IDeleteQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IDeleteQuery.Item"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Item { get; set; }
Visual Basic (Declaration)
Property Item As Object
Visual C++
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}

See Also

IDeleteQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IInsertQuery Interface

[image]

Enterprise SDK 8.0 Reference API
IInsertQuery Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IInsertQuery"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IInsertQuery : IQuery
Visual Basic (Declaration)
Public Interface IInsertQuery _
    Implements IQuery
Visual C++
public interface class IInsertQuery : IQuery

See Also

IInsertQuery Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IInsertQuery Members

[image] [image]

Enterprise SDK 8.0 Reference API
IInsertQuery Members
IInsertQuery Interface Methods Properties See Also Send Feedback

The IInsertQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

Properties

Name | Description
Item |

See Also

IInsertQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IInsertQuery Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IInsertQuery Methods
IInsertQuery Interface See Also Send Feedback

The IInsertQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

See Also

IInsertQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IInsertQuery Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IInsertQuery Properties
IInsertQuery Interface See Also Send Feedback

The IInsertQuery type exposes the following members.

Properties

Name | Description
Item |

See Also

IInsertQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IInsertQuery..::.Item Property
IInsertQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IInsertQuery.Item"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Item { get; set; }
Visual Basic (Declaration)
Property Item As Object
Visual C++
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}

See Also

IInsertQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IQuery Interface

[image]

Enterprise SDK 8.0 Reference API
IQuery Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IQuery"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IQuery
Visual Basic (Declaration)
Public Interface IQuery
Visual C++
public interface class IQuery

See Also

IQuery Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IQuery Members

[image] [image]

Enterprise SDK 8.0 Reference API
IQuery Members
IQuery Interface Methods See Also Send Feedback

The IQuery type exposes the following members.

Methods

Name | Description
GetEntityType |

See Also

IQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IQuery Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IQuery Methods
IQuery Interface See Also Send Feedback

The IQuery type exposes the following members.

Methods

Name | Description
GetEntityType |

See Also

IQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


GetEntityType Method

[image]

Enterprise SDK 8.0 Reference API
IQuery..::.GetEntityType Method
IQuery Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQuery.GetEntityType"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Type GetEntityType()
Visual Basic (Declaration)
Function GetEntityType As Type
Visual C++
Type^ GetEntityType()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQuery.GetEntityType"]

See Also

IQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IQuery(T) Interface

[image]

Enterprise SDK 8.0 Reference API
IQuery<(Of <(T>)>) Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IQuery`1"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IQuery<T> : IQuery
Visual Basic (Declaration)
Public Interface IQuery(Of T) _
    Implements IQuery
Visual C++
generic<typename T>
public interface class IQuery : IQuery

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IQuery`1"]

See Also

IQuery<(Of <(T>)>) Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IQuery(T) Members

[image] [image]

Enterprise SDK 8.0 Reference API
IQuery<(Of <(T>)>) Members
IQuery<(Of <(T>)>) Interface Methods See Also Send Feedback

The IQuery<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

See Also

IQuery<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IQuery(T) Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IQuery<(Of <(T>)>) Methods
IQuery<(Of <(T>)>) Interface See Also Send Feedback

The IQuery<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

See Also

IQuery<(Of <(T>)>) Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IQueryFactory Interface

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IQueryFactory : IReadQueryFactory
Visual Basic (Declaration)
Public Interface IQueryFactory _
    Implements IReadQueryFactory
Visual C++
public interface class IQueryFactory : IReadQueryFactory

See Also

IQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IQueryFactory Members

[image] [image]

Enterprise SDK 8.0 Reference API
IQueryFactory Members
IQueryFactory Interface Methods See Also Send Feedback

Methods

Name | Description
GetDeleteQuery | Overloaded.
GetInsertQuery | Overloaded.
GetReadQuery | Overloaded.
GetUpdateQuery | Overloaded.

See Also

IQueryFactory Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IQueryFactory Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IQueryFactory Methods
IQueryFactory Interface See Also Send Feedback

Methods

Name | Description
GetDeleteQuery | Overloaded.
GetInsertQuery | Overloaded.
GetReadQuery | Overloaded.
GetUpdateQuery | Overloaded.

See Also

IQueryFactory Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


GetDeleteQuery Method

[image] [image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetDeleteQuery Method
IQueryFactory Interface See Also Send Feedback

Overload List

Name | Description
GetDeleteQuery<(Of <(T>)>)()()() |
GetDeleteQuery(Type) |

See Also

IQueryFactory Interface
IQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


GetDeleteQuery(T) Method

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetDeleteQuery<(Of <(T>)>) Method
IQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetDeleteQuery``1"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DeleteQuery<T> GetDeleteQuery<T>()
Visual Basic (Declaration)
Function GetDeleteQuery(Of T) As DeleteQuery(Of T)
Visual C++
generic<typename T>
DeleteQuery<T>^ GetDeleteQuery()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetDeleteQuery``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetDeleteQuery``1"]

See Also

IQueryFactory Interface
GetDeleteQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetDeleteQuery Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetDeleteQuery Method (Type)
IQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetDeleteQuery(System.Type)"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDeleteQuery GetDeleteQuery(
    Type type
)
Visual Basic (Declaration)
Function GetDeleteQuery ( _
    type As Type _
) As IDeleteQuery
Visual C++
IDeleteQuery^ GetDeleteQuery(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetDeleteQuery(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetDeleteQuery(System.Type)"]

See Also

IQueryFactory Interface
GetDeleteQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetInsertQuery Method

[image] [image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetInsertQuery Method
IQueryFactory Interface See Also Send Feedback

Overload List

Name | Description
GetInsertQuery<(Of <(T>)>)()()() |
GetInsertQuery(Type) |

See Also

IQueryFactory Interface
IQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


GetInsertQuery(T) Method

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetInsertQuery<(Of <(T>)>) Method
IQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetInsertQuery``1"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
InsertQuery<T> GetInsertQuery<T>()
Visual Basic (Declaration)
Function GetInsertQuery(Of T) As InsertQuery(Of T)
Visual C++
generic<typename T>
InsertQuery<T>^ GetInsertQuery()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetInsertQuery``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetInsertQuery``1"]

See Also

IQueryFactory Interface
GetInsertQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetInsertQuery Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetInsertQuery Method (Type)
IQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetInsertQuery(System.Type)"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IInsertQuery GetInsertQuery(
    Type type
)
Visual Basic (Declaration)
Function GetInsertQuery ( _
    type As Type _
) As IInsertQuery
Visual C++
IInsertQuery^ GetInsertQuery(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetInsertQuery(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetInsertQuery(System.Type)"]

See Also

IQueryFactory Interface
GetInsertQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetReadQuery Method

[image] [image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetReadQuery Method
IQueryFactory Interface See Also Send Feedback

Overload List

Name | Description
GetReadQuery<(Of <(T>)>)()()() | (Inherited from IReadQueryFactory.)
GetReadQuery<(Of <(T>)>)(Object) | (Inherited from IReadQueryFactory.)
GetReadQuery(Type) | (Inherited from IReadQueryFactory.)
GetReadQuery(Type, Object) | (Inherited from IReadQueryFactory.)

See Also

IQueryFactory Interface
IQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


GetUpdateQuery Method

[image] [image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetUpdateQuery Method
IQueryFactory Interface See Also Send Feedback

Overload List

Name | Description
GetUpdateQuery<(Of <(T>)>)()()() |
GetUpdateQuery(Type) |

See Also

IQueryFactory Interface
IQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


GetUpdateQuery(T) Method

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetUpdateQuery<(Of <(T>)>) Method
IQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetUpdateQuery``1"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
UpdateQuery<T> GetUpdateQuery<T>()
Visual Basic (Declaration)
Function GetUpdateQuery(Of T) As UpdateQuery(Of T)
Visual C++
generic<typename T>
UpdateQuery<T>^ GetUpdateQuery()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetUpdateQuery``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetUpdateQuery``1"]

See Also

IQueryFactory Interface
GetUpdateQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetUpdateQuery Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IQueryFactory..::.GetUpdateQuery Method (Type)
IQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetUpdateQuery(System.Type)"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IUpdateQuery GetUpdateQuery(
    Type type
)
Visual Basic (Declaration)
Function GetUpdateQuery ( _
    type As Type _
) As IUpdateQuery
Visual C++
IUpdateQuery^ GetUpdateQuery(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetUpdateQuery(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IQueryFactory.GetUpdateQuery(System.Type)"]

See Also

IQueryFactory Interface
GetUpdateQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQuery Interface

[image]

Enterprise SDK 8.0 Reference API
IReadQuery Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IReadQuery"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IReadQuery : IQuery
Visual Basic (Declaration)
Public Interface IReadQuery _
    Implements IQuery
Visual C++
public interface class IReadQuery : IQuery

See Also

IReadQuery Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQuery Members

[image] [image]

Enterprise SDK 8.0 Reference API
IReadQuery Members
IReadQuery Interface Methods Properties See Also Send Feedback

The IReadQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

Properties

Name | Description
Attributes |
Filter |
IndexOfFirst |
MaxCount |
Parent |
SortConditions |

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQuery Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IReadQuery Methods
IReadQuery Interface See Also Send Feedback

The IReadQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQuery Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IReadQuery Properties
IReadQuery Interface See Also Send Feedback

The IReadQuery type exposes the following members.

Properties

Name | Description
Attributes |
Filter |
IndexOfFirst |
MaxCount |
Parent |
SortConditions |

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Attributes Property

[image]

Enterprise SDK 8.0 Reference API
IReadQuery..::.Attributes Property
IReadQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IReadQuery.Attributes"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
AttributeList Attributes { get; set; }
Visual Basic (Declaration)
Property Attributes As AttributeList
Visual C++
property AttributeList^ Attributes {
    AttributeList^ get ();
    void set (AttributeList^ value);
}

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Filter Property

[image]

Enterprise SDK 8.0 Reference API
IReadQuery..::.Filter Property
IReadQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IReadQuery.Filter"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Expression Filter { get; set; }
Visual Basic (Declaration)
Property Filter As Expression
Visual C++
property Expression^ Filter {
    Expression^ get ();
    void set (Expression^ value);
}

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IndexOfFirst Property

[image]

Enterprise SDK 8.0 Reference API
IReadQuery..::.IndexOfFirst Property
IReadQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IReadQuery.IndexOfFirst"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> IndexOfFirst { get; set; }
Visual Basic (Declaration)
Property IndexOfFirst As Nullable(Of Integer)
Visual C++
property Nullable<int> IndexOfFirst {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


MaxCount Property

[image]

Enterprise SDK 8.0 Reference API
IReadQuery..::.MaxCount Property
IReadQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IReadQuery.MaxCount"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Nullable<int> MaxCount { get; set; }
Visual Basic (Declaration)
Property MaxCount As Nullable(Of Integer)
Visual C++
property Nullable<int> MaxCount {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Parent Property

[image]

Enterprise SDK 8.0 Reference API
IReadQuery..::.Parent Property
IReadQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IReadQuery.Parent"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Parent { get; set; }
Visual Basic (Declaration)
Property Parent As Object
Visual C++
property Object^ Parent {
    Object^ get ();
    void set (Object^ value);
}

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


SortConditions Property

[image]

Enterprise SDK 8.0 Reference API
IReadQuery..::.SortConditions Property
IReadQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IReadQuery.SortConditions"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
SortConditionsCollection SortConditions { get; set; }
Visual Basic (Declaration)
Property SortConditions As SortConditionsCollection
Visual C++
property SortConditionsCollection^ SortConditions {
    SortConditionsCollection^ get ();
    void set (SortConditionsCollection^ value);
}

See Also

IReadQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQueryFactory Interface

[image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IReadQueryFactory
Visual Basic (Declaration)
Public Interface IReadQueryFactory
Visual C++
public interface class IReadQueryFactory

See Also

IReadQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQueryFactory Members

[image] [image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory Members
IReadQueryFactory Interface Methods See Also Send Feedback

Methods

Name | Description
GetReadQuery | Overloaded.

See Also

IReadQueryFactory Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IReadQueryFactory Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory Methods
IReadQueryFactory Interface See Also Send Feedback

Methods

Name | Description
GetReadQuery | Overloaded.

See Also

IReadQueryFactory Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


GetReadQuery Method

[image] [image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory..::.GetReadQuery Method
IReadQueryFactory Interface See Also Send Feedback

Overload List

Name | Description
GetReadQuery<(Of <(T>)>)()()() |
GetReadQuery<(Of <(T>)>)(Object) |
GetReadQuery(Type) |
GetReadQuery(Type, Object) |

See Also

IReadQueryFactory Interface
IReadQueryFactory Members
Genesyslab.Enterprise.Services.Common.Query Namespace


GetReadQuery(T) Method

[image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory..::.GetReadQuery<(Of <(T>)>) Method
IReadQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ReadQuery<T> GetReadQuery<T>()
Visual Basic (Declaration)
Function GetReadQuery(Of T) As ReadQuery(Of T)
Visual C++
generic<typename T>
ReadQuery<T>^ GetReadQuery()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1"]

See Also

IReadQueryFactory Interface
GetReadQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetReadQuery(T) Method (Object)

[image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory..::.GetReadQuery<(Of <(T>)>) Method (Object)
IReadQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1(System.Object)"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ReadQuery<T> GetReadQuery<T>(
    Object parent
)
Visual Basic (Declaration)
Function GetReadQuery(Of T) ( _
    parent As Object _
) As ReadQuery(Of T)
Visual C++
generic<typename T>
ReadQuery<T>^ GetReadQuery(
    Object^ parent
)

Parameters

parent
Type: System..::.Object

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1(System.Object)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1(System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery``1(System.Object)"]

See Also

IReadQueryFactory Interface
GetReadQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetReadQuery Method (Type)

[image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory..::.GetReadQuery Method (Type)
IReadQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type)"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IReadQuery GetReadQuery(
    Type type
)
Visual Basic (Declaration)
Function GetReadQuery ( _
    type As Type _
) As IReadQuery
Visual C++
IReadQuery^ GetReadQuery(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type)"]

See Also

IReadQueryFactory Interface
GetReadQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


GetReadQuery Method (Type, Object)

[image]

Enterprise SDK 8.0 Reference API
IReadQueryFactory..::.GetReadQuery Method (Type, Object)
IReadQueryFactory Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type,System.Object)"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IReadQuery GetReadQuery(
    Type type,
    Object parent
)
Visual Basic (Declaration)
Function GetReadQuery ( _
    type As Type, _
    parent As Object _
) As IReadQuery
Visual C++
IReadQuery^ GetReadQuery(
    Type^ type,
    Object^ parent
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type,System.Object)"]

parent
Type: System..::.Object

[Missing <param name="parent"/> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type,System.Object)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Common.Query.IReadQueryFactory.GetReadQuery(System.Type,System.Object)"]

See Also

IReadQueryFactory Interface
GetReadQuery Overload
Genesyslab.Enterprise.Services.Common.Query Namespace


IUpdateQuery Interface

[image]

Enterprise SDK 8.0 Reference API
IUpdateQuery Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IUpdateQuery : IQuery
Visual Basic (Declaration)
Public Interface IUpdateQuery _
    Implements IQuery
Visual C++
public interface class IUpdateQuery : IQuery

See Also

IUpdateQuery Members
Genesyslab.Enterprise.Services.Common.Query Namespace


IUpdateQuery Members

[image] [image]

Enterprise SDK 8.0 Reference API
IUpdateQuery Members
IUpdateQuery Interface Methods Properties See Also Send Feedback

The IUpdateQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

Properties

Name | Description
Item |
Original |

See Also

IUpdateQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IUpdateQuery Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IUpdateQuery Methods
IUpdateQuery Interface See Also Send Feedback

The IUpdateQuery type exposes the following members.

Methods

Name | Description
GetEntityType | (Inherited from IQuery.)

See Also

IUpdateQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


IUpdateQuery Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IUpdateQuery Properties
IUpdateQuery Interface See Also Send Feedback

The IUpdateQuery type exposes the following members.

Properties

Name | Description
Item |
Original |

See Also

IUpdateQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Item Property

[image]

Enterprise SDK 8.0 Reference API
IUpdateQuery..::.Item Property
IUpdateQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery.Item"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Item { get; set; }
Visual Basic (Declaration)
Property Item As Object
Visual C++
property Object^ Item {
    Object^ get ();
    void set (Object^ value);
}

See Also

IUpdateQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Original Property

[image]

Enterprise SDK 8.0 Reference API
IUpdateQuery..::.Original Property
IUpdateQuery Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Common.Query.IUpdateQuery.Original"]

Namespace: Genesyslab.Enterprise.Services.Common.Query
Assembly: Genesyslab.Enterprise.Services.Common (in Genesyslab.Enterprise.Services.Common.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Original { get; set; }
Visual Basic (Declaration)
Property Original As Object
Visual C++
property Object^ Original {
    Object^ get ();
    void set (Object^ value);
}

See Also

IUpdateQuery Interface
Genesyslab.Enterprise.Services.Common.Query Namespace


Genesyslab.Enterprise.Services.Contact Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Contact Namespace
Send Feedback

Interfaces

Interface | Description
IContactCache |
IFieldData |
IIndexData |


IContactCache Interface

[image]

Enterprise SDK 8.0 Reference API
IContactCache Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Contact.IContactCache"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IContactCache
Visual Basic (Declaration)
Public Interface IContactCache
Visual C++
public interface class IContactCache

See Also

IContactCache Members
Genesyslab.Enterprise.Services.Contact Namespace


IContactCache Members

[image] [image]

Enterprise SDK 8.0 Reference API
IContactCache Members
IContactCache Interface Methods Properties Events See Also Send Feedback

The IContactCache type exposes the following members.

Methods

Name | Description
Add |
AddRootCategory |
ChannelEvent |
Contains |
Flush |
Get |
GetRootCategories |
Remove |
RemoveRootCategory |

Properties

Name | Description
CacheRefreshInterval |
Channel |
ContactService |
ExpirationTime |
IsFullyInitiliazed |

Events

Name | Description
Updated |

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


IContactCache Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IContactCache Methods
IContactCache Interface See Also Send Feedback

The IContactCache type exposes the following members.

Methods

Name | Description
Add |
AddRootCategory |
ChannelEvent |
Contains |
Flush |
Get |
GetRootCategories |
Remove |
RemoveRootCategory |

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Add Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Add Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Add(System.String,Genesyslab.Enterprise.Model.Contact.IContactObject)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Add(
    string key,
    IContactObject value
)
Visual Basic (Declaration)
Sub Add ( _
    key As String, _
    value As IContactObject _
)
Visual C++
void Add(
    String^ key,
    IContactObject^ value
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Add(System.String,Genesyslab.Enterprise.Model.Contact.IContactObject)"]

value
Type: Genesyslab.Enterprise.Model.Contact..::.IContactObject

[Missing <param name="value"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Add(System.String,Genesyslab.Enterprise.Model.Contact.IContactObject)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


AddRootCategory Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.AddRootCategory Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.AddRootCategory(System.String)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void AddRootCategory(
    string key
)
Visual Basic (Declaration)
Sub AddRootCategory ( _
    key As String _
)
Visual C++
void AddRootCategory(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.AddRootCategory(System.String)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


ChannelEvent Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.ChannelEvent Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.ChannelEvent(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void ChannelEvent(
    IClientChannel channel
)
Visual Basic (Declaration)
Sub ChannelEvent ( _
    channel As IClientChannel _
)
Visual C++
void ChannelEvent(
    IClientChannel^ channel
)

Parameters

channel
Type: Genesyslab.Enterprise.Model.Channel..::.IClientChannel

[Missing <param name="channel"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.ChannelEvent(Genesyslab.Enterprise.Model.Channel.IClientChannel)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Contains Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Contains Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Contains(System.String)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool Contains(
    string key
)
Visual Basic (Declaration)
Function Contains ( _
    key As String _
) As Boolean
Visual C++
bool Contains(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Contains(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Contains(System.String)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Flush Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Flush Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Flush"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Flush()
Visual Basic (Declaration)
Sub Flush
Visual C++
void Flush()

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Get Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Get Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Get(System.String)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object Get(
    string key
)
Visual Basic (Declaration)
Function Get ( _
    key As String _
) As Object
Visual C++
Object^ Get(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Get(System.String)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Get(System.String)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


GetRootCategories Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.GetRootCategories Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.GetRootCategories"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
List<string> GetRootCategories()
Visual Basic (Declaration)
Function GetRootCategories As List(Of String)
Visual C++
List<String^>^ GetRootCategories()

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.GetRootCategories"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Remove Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Remove Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Remove(System.String)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void Remove(
    string key
)
Visual Basic (Declaration)
Sub Remove ( _
    key As String _
)
Visual C++
void Remove(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.Remove(System.String)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


RemoveRootCategory Method

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.RemoveRootCategory Method
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.RemoveRootCategory(System.String)"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
void RemoveRootCategory(
    string key
)
Visual Basic (Declaration)
Sub RemoveRootCategory ( _
    key As String _
)
Visual C++
void RemoveRootCategory(
    String^ key
)

Parameters

key
Type: System..::.String

[Missing <param name="key"/> documentation for "M:Genesyslab.Enterprise.Services.Contact.IContactCache.RemoveRootCategory(System.String)"]

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


IContactCache Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IContactCache Properties
IContactCache Interface See Also Send Feedback

The IContactCache type exposes the following members.

Properties

Name | Description
CacheRefreshInterval |
Channel |
ContactService |
ExpirationTime |
IsFullyInitiliazed |

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


CacheRefreshInterval Property

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.CacheRefreshInterval Property
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IContactCache.CacheRefreshInterval"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
double CacheRefreshInterval { get; set; }
Visual Basic (Declaration)
Property CacheRefreshInterval As Double
Visual C++
property double CacheRefreshInterval {
    double get ();
    void set (double value);
}

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Channel Property

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Channel Property
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IContactCache.Channel"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IClientChannel Channel { get; set; }
Visual Basic (Declaration)
Property Channel As IClientChannel
Visual C++
property IClientChannel^ Channel {
    IClientChannel^ get ();
    void set (IClientChannel^ value);
}

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


ContactService Property

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.ContactService Property
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IContactCache.ContactService"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IContactService ContactService { get; set; }
Visual Basic (Declaration)
Property ContactService As IContactService
Visual C++
property IContactService^ ContactService {
    IContactService^ get ();
    void set (IContactService^ value);
}

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


ExpirationTime Property

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.ExpirationTime Property
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IContactCache.ExpirationTime"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int ExpirationTime { get; set; }
Visual Basic (Declaration)
Property ExpirationTime As Integer
Visual C++
property int ExpirationTime {
    int get ();
    void set (int value);
}

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


IsFullyInitiliazed Property

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.IsFullyInitiliazed Property
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IContactCache.IsFullyInitiliazed"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsFullyInitiliazed { get; set; }
Visual Basic (Declaration)
Property IsFullyInitiliazed As Boolean
Visual C++
property bool IsFullyInitiliazed {
    bool get ();
    void set (bool value);
}

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


IContactCache Events

[image] [image]

Enterprise SDK 8.0 Reference API
IContactCache Events
IContactCache Interface See Also Send Feedback

The IContactCache type exposes the following members.

Events

Name | Description
Updated |

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


Updated Event

[image]

Enterprise SDK 8.0 Reference API
IContactCache..::.Updated Event
IContactCache Interface See Also Send Feedback

[Missing <summary> documentation for "E:Genesyslab.Enterprise.Services.Contact.IContactCache.Updated"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
event CheckUpdateHandler Updated
Visual Basic (Declaration)
Event Updated As CheckUpdateHandler
Visual C++
 event CheckUpdateHandler^ Updated {
    void add (CheckUpdateHandler^ value);
    void remove (CheckUpdateHandler^ value);
}

See Also

IContactCache Interface
Genesyslab.Enterprise.Services.Contact Namespace


IFieldData Interface

[image]

Enterprise SDK 8.0 Reference API
IFieldData Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Contact.IFieldData"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IFieldData
Visual Basic (Declaration)
Public Interface IFieldData
Visual C++
public interface class IFieldData

See Also

IFieldData Members
Genesyslab.Enterprise.Services.Contact Namespace


IFieldData Members

[image] [image]

Enterprise SDK 8.0 Reference API
IFieldData Members
IFieldData Interface Properties See Also Send Feedback

The IFieldData type exposes the following members.

Properties

Name | Description
FieldName |
IsSearchable |
IsStored |

See Also

IFieldData Interface
Genesyslab.Enterprise.Services.Contact Namespace


IFieldData Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IFieldData Properties
IFieldData Interface See Also Send Feedback

The IFieldData type exposes the following members.

Properties

Name | Description
FieldName |
IsSearchable |
IsStored |

See Also

IFieldData Interface
Genesyslab.Enterprise.Services.Contact Namespace


FieldName Property

[image]

Enterprise SDK 8.0 Reference API
IFieldData..::.FieldName Property
IFieldData Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IFieldData.FieldName"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FieldName { get; }
Visual Basic (Declaration)
ReadOnly Property FieldName As String
Visual C++
property String^ FieldName {
    String^ get ();
}

See Also

IFieldData Interface
Genesyslab.Enterprise.Services.Contact Namespace


IsSearchable Property

[image]

Enterprise SDK 8.0 Reference API
IFieldData..::.IsSearchable Property
IFieldData Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IFieldData.IsSearchable"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsSearchable { get; }
Visual Basic (Declaration)
ReadOnly Property IsSearchable As Boolean
Visual C++
property bool IsSearchable {
    bool get ();
}

See Also

IFieldData Interface
Genesyslab.Enterprise.Services.Contact Namespace


IsStored Property

[image]

Enterprise SDK 8.0 Reference API
IFieldData..::.IsStored Property
IFieldData Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IFieldData.IsStored"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsStored { get; }
Visual Basic (Declaration)
ReadOnly Property IsStored As Boolean
Visual C++
property bool IsStored {
    bool get ();
}

See Also

IFieldData Interface
Genesyslab.Enterprise.Services.Contact Namespace


IIndexData Interface

[image]

Enterprise SDK 8.0 Reference API
IIndexData Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.Services.Contact.IIndexData"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IIndexData
Visual Basic (Declaration)
Public Interface IIndexData
Visual C++
public interface class IIndexData

See Also

IIndexData Members
Genesyslab.Enterprise.Services.Contact Namespace


IIndexData Members

[image] [image]

Enterprise SDK 8.0 Reference API
IIndexData Members
IIndexData Interface Properties See Also Send Feedback

The IIndexData type exposes the following members.

Properties

Name | Description
Description |
Fields |
IndexName |

See Also

IIndexData Interface
Genesyslab.Enterprise.Services.Contact Namespace


IIndexData Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IIndexData Properties
IIndexData Interface See Also Send Feedback

The IIndexData type exposes the following members.

Properties

Name | Description
Description |
Fields |
IndexName |

See Also

IIndexData Interface
Genesyslab.Enterprise.Services.Contact Namespace


Description Property

[image]

Enterprise SDK 8.0 Reference API
IIndexData..::.Description Property
IIndexData Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IIndexData.Description"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Description { get; }
Visual Basic (Declaration)
ReadOnly Property Description As String
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IIndexData Interface
Genesyslab.Enterprise.Services.Contact Namespace


Fields Property

[image]

Enterprise SDK 8.0 Reference API
IIndexData..::.Fields Property
IIndexData Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IIndexData.Fields"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IFieldData[] Fields { get; }
Visual Basic (Declaration)
ReadOnly Property Fields As IFieldData()
Visual C++
property array<IFieldData^>^ Fields {
    array<IFieldData^>^ get ();
}

See Also

IIndexData Interface
Genesyslab.Enterprise.Services.Contact Namespace


IndexName Property

[image]

Enterprise SDK 8.0 Reference API
IIndexData..::.IndexName Property
IIndexData Interface See Also Send Feedback

[Missing <summary> documentation for "P:Genesyslab.Enterprise.Services.Contact.IIndexData.IndexName"]

Namespace: Genesyslab.Enterprise.Services.Contact
Assembly: Genesyslab.Enterprise.Services.Contact (in Genesyslab.Enterprise.Services.Contact.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string IndexName { get; }
Visual Basic (Declaration)
ReadOnly Property IndexName As String
Visual C++
property String^ IndexName {
    String^ get ();
}

See Also

IIndexData Interface
Genesyslab.Enterprise.Services.Contact Namespace


Genesyslab.Enterprise.Services.Model Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.Services.Model Namespace
Send Feedback

Interfaces

Interface | Description
IMonitorAgentGroupStatus | AgentGroup status.
IMonitorAgentStatus | Interface for Agent Status Monitoring.
IMonitorEventStatus | Interface for Event Status Monitoring.
IMonitorMediaStatus | Interface for Media status monitoring.

Enumerations

Enumeration | Description
AgentGroupStatus | Enumerate for Agent Group statistics object type.
AgentStatus | Enumerate for Agent statistics object type.
MediaStatus | Enumerate for Media statistics object type.


AgentGroupStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentGroupStatus Enumeration
See Also Send Feedback
Enumerate for Agent Group statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[SerializableAttribute]
public enum AgentGroupStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration AgentGroupStatus
Visual C++
[SerializableAttribute]
public enum class AgentGroupStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |

See Also

Genesyslab.Enterprise.Services.Model Namespace


AgentStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
AgentStatus Enumeration
See Also Send Feedback
Enumerate for Agent statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[SerializableAttribute]
public enum AgentStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration AgentStatus
Visual C++
[SerializableAttribute]
public enum class AgentStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |
CallConsult |
CallOnHold |

See Also

Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Interface
Members See Also Send Feedback
AgentGroup status.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitorAgentGroupStatus : IMonitorEventStatus,
    ISerializable, IShallowCopy<IMonitorEventStatus>, IDeepCopy<IMonitorEventStatus>
Visual Basic (Declaration)
Public Interface IMonitorAgentGroupStatus _
    Implements IMonitorEventStatus, ISerializable, IShallowCopy(Of IMonitorEventStatus),  _
    IDeepCopy(Of IMonitorEventStatus)
Visual C++
public interface class IMonitorAgentGroupStatus : IMonitorEventStatus,
    ISerializable, IShallowCopy<IMonitorEventStatus^>, IDeepCopy<IMonitorEventStatus^>

See Also

IMonitorAgentGroupStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Members
IMonitorAgentGroupStatus Interface Methods Properties See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
AgentCount | Returns the number of agents of the agent group associated with this event.
AgentStatuses | Returns the agent statuses of the agent group.
GroupID | Returns the identifier of the group.
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus). (Inherited from IMonitorEventStatus.)
Status | Returns the new status of this agent group.

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Methods
IMonitorAgentGroupStatus Interface See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentGroupStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus Properties
IMonitorAgentGroupStatus Interface See Also Send Feedback

The IMonitorAgentGroupStatus type exposes the following members.

Properties

Name | Description
AgentCount | Returns the number of agents of the agent group associated with this event.
AgentStatuses | Returns the agent statuses of the agent group.
GroupID | Returns the identifier of the group.
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus). (Inherited from IMonitorEventStatus.)
Status | Returns the new status of this agent group.

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentCount Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.AgentCount Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the number of agents of the agent group associated with this event.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
int AgentCount { get; }
Visual Basic (Declaration)
ReadOnly Property AgentCount As Integer
Visual C++
property int AgentCount {
    int get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentStatuses Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.AgentStatuses Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the agent statuses of the agent group.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IMonitorAgentStatus> AgentStatuses { get; }
Visual Basic (Declaration)
ReadOnly Property AgentStatuses As IDictionary(Of String, IMonitorAgentStatus)
Visual C++
property IDictionary<String^, IMonitorAgentStatus^>^ AgentStatuses {
    IDictionary<String^, IMonitorAgentStatus^>^ get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


GroupID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.GroupID Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the identifier of the group.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string GroupID { get; }
Visual Basic (Declaration)
ReadOnly Property GroupID As String
Visual C++
property String^ GroupID {
    String^ get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentGroupStatus..::.Status Property
IMonitorAgentGroupStatus Interface See Also Send Feedback
Returns the new status of this agent group.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
AgentGroupStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As AgentGroupStatus
Visual C++
property AgentGroupStatus Status {
    AgentGroupStatus get ();
}

See Also

IMonitorAgentGroupStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Interface
Members See Also Send Feedback
Interface for Agent Status Monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitorAgentStatus : IMonitorEventStatus,
    ISerializable, IShallowCopy<IMonitorEventStatus>, IDeepCopy<IMonitorEventStatus>
Visual Basic (Declaration)
Public Interface IMonitorAgentStatus _
    Implements IMonitorEventStatus, ISerializable, IShallowCopy(Of IMonitorEventStatus),  _
    IDeepCopy(Of IMonitorEventStatus)
Visual C++
public interface class IMonitorAgentStatus : IMonitorEventStatus,
    ISerializable, IShallowCopy<IMonitorEventStatus^>, IDeepCopy<IMonitorEventStatus^>

See Also

IMonitorAgentStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Members
IMonitorAgentStatus Interface Methods Properties See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
AgentID | returns the Agent ID.
LoginID | returns the Login ID of the Agent.
MediaCapacities | Returns the Media capacities of the agent. Only available with Statistics Extended and SubscribePresenceView methods.
MediaMaxCapacities | Returns the Media Maximum capacities of the agent. Only available with Statistics Extended and SubscribePresenceView methods.
MediaReasons | Returns the NotReady/Ready Reasons dictionary of the agent. Only available with SubscribePresenceView methods. The key of the first dictionary is the media name. The key of the second dictionary is: * the name of the action code for voice media * "ReasonsCode" for multimedia The value of the second dictionary is the code of the action code.
MediaStatuses | returns the DN statuses of the agent.
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus). (Inherited from IMonitorEventStatus.)
PlaceID | returns the Place ID of the Agent.
Reasons | Obsolete. Returns the NotReady/Ready Reasons dictionary of the agent. The key is the name of the action code. The value is the code of the action code.
Status | returns the status of the agent.

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Methods
IMonitorAgentStatus Interface See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorAgentStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus Properties
IMonitorAgentStatus Interface See Also Send Feedback

The IMonitorAgentStatus type exposes the following members.

Properties

Name | Description
AgentID | returns the Agent ID.
LoginID | returns the Login ID of the Agent.
MediaCapacities | Returns the Media capacities of the agent. Only available with Statistics Extended and SubscribePresenceView methods.
MediaMaxCapacities | Returns the Media Maximum capacities of the agent. Only available with Statistics Extended and SubscribePresenceView methods.
MediaReasons | Returns the NotReady/Ready Reasons dictionary of the agent. Only available with SubscribePresenceView methods. The key of the first dictionary is the media name. The key of the second dictionary is: * the name of the action code for voice media * "ReasonsCode" for multimedia The value of the second dictionary is the code of the action code.
MediaStatuses | returns the DN statuses of the agent.
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus). (Inherited from IMonitorEventStatus.)
PlaceID | returns the Place ID of the Agent.
Reasons | Obsolete. Returns the NotReady/Ready Reasons dictionary of the agent. The key is the name of the action code. The value is the code of the action code.
Status | returns the status of the agent.

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


AgentID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.AgentID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Agent ID.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string AgentID { get; }
Visual Basic (Declaration)
ReadOnly Property AgentID As String
Visual C++
property String^ AgentID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


LoginID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.LoginID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Login ID of the Agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string LoginID { get; }
Visual Basic (Declaration)
ReadOnly Property LoginID As String
Visual C++
property String^ LoginID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaCapacities Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaCapacities Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the Media capacities of the agent. Only available with Statistics Extended and SubscribePresenceView methods.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, int> MediaCapacities { get; }
Visual Basic (Declaration)
ReadOnly Property MediaCapacities As IDictionary(Of String, Integer)
Visual C++
property IDictionary<String^, int>^ MediaCapacities {
    IDictionary<String^, int>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaMaxCapacities Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaMaxCapacities Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the Media Maximum capacities of the agent. Only available with Statistics Extended and SubscribePresenceView methods.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, int> MediaMaxCapacities { get; }
Visual Basic (Declaration)
ReadOnly Property MediaMaxCapacities As IDictionary(Of String, Integer)
Visual C++
property IDictionary<String^, int>^ MediaMaxCapacities {
    IDictionary<String^, int>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaReasons Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaReasons Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the NotReady/Ready Reasons dictionary of the agent. Only available with SubscribePresenceView methods. The key of the first dictionary is the media name. The key of the second dictionary is: * the name of the action code for voice media * "ReasonsCode" for multimedia The value of the second dictionary is the code of the action code.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IDictionary<string, string>> MediaReasons { get; }
Visual Basic (Declaration)
ReadOnly Property MediaReasons As IDictionary(Of String, IDictionary(Of String, String))
Visual C++
property IDictionary<String^, IDictionary<String^, String^>^>^ MediaReasons {
    IDictionary<String^, IDictionary<String^, String^>^>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaStatuses Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.MediaStatuses Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the DN statuses of the agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<string, IMonitorMediaStatus> MediaStatuses { get; }
Visual Basic (Declaration)
ReadOnly Property MediaStatuses As IDictionary(Of String, IMonitorMediaStatus)
Visual C++
property IDictionary<String^, IMonitorMediaStatus^>^ MediaStatuses {
    IDictionary<String^, IMonitorMediaStatus^>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


PlaceID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.PlaceID Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the Place ID of the Agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string PlaceID { get; }
Visual Basic (Declaration)
ReadOnly Property PlaceID As String
Visual C++
property String^ PlaceID {
    String^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Reasons Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.Reasons Property
IMonitorAgentStatus Interface See Also Send Feedback
Returns the NotReady/Ready Reasons dictionary of the agent. The key is the name of the action code. The value is the code of the action code.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[ObsoleteAttribute("Do not use in 8.1 version, use the MediaReasons property")]
IDictionary<string, string> Reasons { get; }
Visual Basic (Declaration)
<ObsoleteAttribute("Do not use in 8.1 version, use the MediaReasons property")> _
ReadOnly Property Reasons As IDictionary(Of String, String)
Visual C++
[ObsoleteAttribute(L"Do not use in 8.1 version, use the MediaReasons property")]
property IDictionary<String^, String^>^ Reasons {
    IDictionary<String^, String^>^ get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorAgentStatus..::.Status Property
IMonitorAgentStatus Interface See Also Send Feedback
returns the status of the agent.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
AgentStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As AgentStatus
Visual C++
property AgentStatus Status {
    AgentStatus get ();
}

See Also

IMonitorAgentStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Interface
Members See Also Send Feedback
Interface for Event Status Monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitorEventStatus : ISerializable,
    IShallowCopy<IMonitorEventStatus>, IDeepCopy<IMonitorEventStatus>
Visual Basic (Declaration)
Public Interface IMonitorEventStatus _
    Implements ISerializable, IShallowCopy(Of IMonitorEventStatus),  _
    IDeepCopy(Of IMonitorEventStatus)
Visual C++
public interface class IMonitorEventStatus : ISerializable,
    IShallowCopy<IMonitorEventStatus^>, IDeepCopy<IMonitorEventStatus^>

See Also

IMonitorEventStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Members
IMonitorEventStatus Interface Methods Properties See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus).

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Methods
IMonitorEventStatus Interface See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorEventStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus Properties
IMonitorEventStatus Interface See Also Send Feedback

The IMonitorEventStatus type exposes the following members.

Properties

Name | Description
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus).

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


ObjectType Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorEventStatus..::.ObjectType Property
IMonitorEventStatus Interface See Also Send Feedback
Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus).

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MonitorObjectType ObjectType { get; }
Visual Basic (Declaration)
ReadOnly Property ObjectType As MonitorObjectType
Visual C++
property MonitorObjectType ObjectType {
    MonitorObjectType get ();
}

See Also

IMonitorEventStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorMediaStatus Interface

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus Interface
Members See Also Send Feedback
Interface for Media status monitoring.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IMonitorMediaStatus : IMonitorEventStatus,
    ISerializable, IShallowCopy<IMonitorEventStatus>, IDeepCopy<IMonitorEventStatus>
Visual Basic (Declaration)
Public Interface IMonitorMediaStatus _
    Implements IMonitorEventStatus, ISerializable, IShallowCopy(Of IMonitorEventStatus),  _
    IDeepCopy(Of IMonitorEventStatus)
Visual C++
public interface class IMonitorMediaStatus : IMonitorEventStatus,
    ISerializable, IShallowCopy<IMonitorEventStatus^>, IDeepCopy<IMonitorEventStatus^>

See Also

IMonitorMediaStatus Members
Genesyslab.Enterprise.Services.Model Namespace


IMonitorMediaStatus Members

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus Members
IMonitorMediaStatus Interface Methods Properties See Also Send Feedback

The IMonitorMediaStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

Properties

Name | Description
DNID | gets the DN ID.
DNType | gets the type of the DN
MediaActions | gets the collection of actions on this media.
MediaType | gets the Media Type.
Name | gets the ID of the DN.
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus). (Inherited from IMonitorEventStatus.)
Status | gets the status of the DN.
SwitchID | gets the switch ID.

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorMediaStatus Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus Methods
IMonitorMediaStatus Interface See Also Send Feedback

The IMonitorMediaStatus type exposes the following members.

Methods

Name | Description
DeepCopy | Full copy of an object. (Inherited from IDeepCopy<(Of <(T>)>).)
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
ShallowCopy | Partial copy of an object. (Inherited from IShallowCopy<(Of <(T>)>).)

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


IMonitorMediaStatus Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus Properties
IMonitorMediaStatus Interface See Also Send Feedback

The IMonitorMediaStatus type exposes the following members.

Properties

Name | Description
DNID | gets the DN ID.
DNType | gets the type of the DN
MediaActions | gets the collection of actions on this media.
MediaType | gets the Media Type.
Name | gets the ID of the DN.
ObjectType | Gets the type of the statistics to be able to cast event on the rigth type (IMonitorAgentGroupStatus, IMonitorAgentStatus). (Inherited from IMonitorEventStatus.)
Status | gets the status of the DN.
SwitchID | gets the switch ID.

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


DNID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.DNID Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the DN ID.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string DNID { get; }
Visual Basic (Declaration)
ReadOnly Property DNID As String
Visual C++
property String^ DNID {
    String^ get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


DNType Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.DNType Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the type of the DN

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DeviceType DNType { get; }
Visual Basic (Declaration)
ReadOnly Property DNType As DeviceType
Visual C++
property DeviceType DNType {
    DeviceType get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaActions Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.MediaActions Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the collection of actions on this media.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<DnAction> MediaActions { get; }
Visual Basic (Declaration)
ReadOnly Property MediaActions As ICollection(Of DnAction)
Visual C++
property ICollection<DnAction^>^ MediaActions {
    ICollection<DnAction^>^ get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaType Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.MediaType Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the Media Type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string MediaType { get; }
Visual Basic (Declaration)
ReadOnly Property MediaType As String
Visual C++
property String^ MediaType {
    String^ get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Name Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.Name Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the ID of the DN.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


Status Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.Status Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the status of the DN.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
MediaStatus Status { get; }
Visual Basic (Declaration)
ReadOnly Property Status As MediaStatus
Visual C++
property MediaStatus Status {
    MediaStatus get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


SwitchID Property

[image]

Enterprise SDK 8.0 Reference API
IMonitorMediaStatus..::.SwitchID Property
IMonitorMediaStatus Interface See Also Send Feedback
gets the switch ID.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SwitchID { get; }
Visual Basic (Declaration)
ReadOnly Property SwitchID As String
Visual C++
property String^ SwitchID {
    String^ get ();
}

See Also

IMonitorMediaStatus Interface
Genesyslab.Enterprise.Services.Model Namespace


MediaStatus Enumeration

[image]

Enterprise SDK 8.0 Reference API
MediaStatus Enumeration
See Also Send Feedback
Enumerate for Media statistics object type.

Namespace: Genesyslab.Enterprise.Services.Model
Assembly: Genesyslab.Enterprise.Services.Presence (in Genesyslab.Enterprise.Services.Presence.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
[SerializableAttribute]
public enum MediaStatus
Visual Basic (Declaration)
<SerializableAttribute> _
Public Enumeration MediaStatus
Visual C++
[SerializableAttribute]
public enum class MediaStatus

Members

Member name | Description
LoggedOut |
Ready |
NotReady |
AfterCallWork |
CallInbound |
CallInternal |
CallOutbound |
NotMonitored |
Monitored |
CallConsult |
CallOnHold |

See Also

Genesyslab.Enterprise.Services.Model Namespace


Genesyslab.Enterprise.SwitchAbstraction Namespace

[image]

Enterprise SDK 8.0 Reference API
Genesyslab.Enterprise.SwitchAbstraction Namespace
Send Feedback

Structures

Structure | Description
SwitchConfig |

Interfaces

Interface | Description
IProtocolRule |
ISwitchProfile | Interface for handling switch abstraction

Enumerations

Enumeration | Description
ActionMode |
DeviceModeType |
HandleNameEnum |


ActionMode Enumeration

[image]

Enterprise SDK 8.0 Reference API
ActionMode Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.SwitchAbstraction.ActionMode"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum ActionMode
Visual Basic (Declaration)
Public Enumeration ActionMode
Visual C++
public enum class ActionMode

Members

Member name | Description
Unknown |
Send |
Receive |
Ignore |
Done |

See Also

Genesyslab.Enterprise.SwitchAbstraction Namespace


DeviceModeType Enumeration

[image]

Enterprise SDK 8.0 Reference API
DeviceModeType Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum DeviceModeType
Visual Basic (Declaration)
Public Enumeration DeviceModeType
Visual C++
public enum class DeviceModeType

Members

Member name | Description
None |
Action |
Event |

See Also

Genesyslab.Enterprise.SwitchAbstraction Namespace


HandleNameEnum Enumeration

[image]

Enterprise SDK 8.0 Reference API
HandleNameEnum Enumeration
See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.SwitchAbstraction.HandleNameEnum"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public enum HandleNameEnum
Visual Basic (Declaration)
Public Enumeration HandleNameEnum
Visual C++
public enum class HandleNameEnum

Members

Member name | Description
FirstConferenceParty |
OtherDN |
ANI |
DNIS |
ThisDN |
ThirdPartyDN |
CallParticipants |

See Also

Genesyslab.Enterprise.SwitchAbstraction Namespace


IProtocolRule Interface

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule Interface
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.SwitchAbstraction.IProtocolRule"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface IProtocolRule
Visual Basic (Declaration)
Public Interface IProtocolRule
Visual C++
public interface class IProtocolRule

See Also

IProtocolRule Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


IProtocolRule Members

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRule Members
IProtocolRule Interface Methods Properties See Also Send Feedback

The IProtocolRule type exposes the following members.

Methods

Name | Description
GetConfigurationProfile | Get raw switch configuration (as defined in SPL)
GetSwitchConfig | Overloaded.
GetSwitchProfile | Get switch rules
ListRawSwitches | List switch names as defined in SPL

Properties

Name | Description
PolicyService | Get switch policy (SPL) SPl is injected at object creation time
SwitchType | Get type of switch

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


IProtocolRule Methods

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRule Methods
IProtocolRule Interface See Also Send Feedback

The IProtocolRule type exposes the following members.

Methods

Name | Description
GetConfigurationProfile | Get raw switch configuration (as defined in SPL)
GetSwitchConfig | Overloaded.
GetSwitchProfile | Get switch rules
ListRawSwitches | List switch names as defined in SPL

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetConfigurationProfile Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.GetConfigurationProfile Method
IProtocolRule Interface See Also Send Feedback
Get raw switch configuration (as defined in SPL)

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
DeviceType[] GetConfigurationProfile()
Visual Basic (Declaration)
Function GetConfigurationProfile As DeviceType()
Visual C++
array<DeviceType>^ GetConfigurationProfile()

Return Value

DeviceType[]

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetSwitchConfig Method

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.GetSwitchConfig Method
IProtocolRule Interface See Also Send Feedback

Overload List

Name | Description
GetSwitchConfig(SwitchModelType) | Get switch configuration, based on specified switch model type
GetSwitchConfig(String) | Get switch configuration, based on specified switch name

See Also

IProtocolRule Interface
IProtocolRule Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetSwitchConfig Method (SwitchModelType)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.GetSwitchConfig Method (SwitchModelType)
IProtocolRule Interface See Also Send Feedback
Get switch configuration, based on specified switch model type

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
SwitchConfig[] GetSwitchConfig(
    SwitchModelType switchType
)
Visual Basic (Declaration)
Function GetSwitchConfig ( _
    switchType As SwitchModelType _
) As SwitchConfig()
Visual C++
array<SwitchConfig>^ GetSwitchConfig(
    SwitchModelType switchType
)

Parameters

switchType
Type: Genesyslab.Enterprise.Model.Protocol..::.SwitchModelType
Type of switch as defined in ESDK

Return Value

SwitchConfig[]

See Also

IProtocolRule Interface
GetSwitchConfig Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetSwitchConfig Method (String)

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.GetSwitchConfig Method (String)
IProtocolRule Interface See Also Send Feedback
Get switch configuration, based on specified switch name

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
SwitchConfig[] GetSwitchConfig(
    string switchName
)
Visual Basic (Declaration)
Function GetSwitchConfig ( _
    switchName As String _
) As SwitchConfig()
Visual C++
array<SwitchConfig>^ GetSwitchConfig(
    String^ switchName
)

Parameters

switchName
Type: System..::.String
Name of switch type as defined in SPL

Return Value

SwitchConfig[]

See Also

IProtocolRule Interface
GetSwitchConfig Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetSwitchProfile Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.GetSwitchProfile Method
IProtocolRule Interface See Also Send Feedback
Get switch rules

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISwitchProfile GetSwitchProfile()
Visual Basic (Declaration)
Function GetSwitchProfile As ISwitchProfile
Visual C++
ISwitchProfile^ GetSwitchProfile()

Return Value

ISwitchProfile

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


ListRawSwitches Method

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.ListRawSwitches Method
IProtocolRule Interface See Also Send Feedback
List switch names as defined in SPL

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string[] ListRawSwitches()
Visual Basic (Declaration)
Function ListRawSwitches As String()
Visual C++
array<String^>^ ListRawSwitches()

Return Value

string[]

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


IProtocolRule Properties

[image] [image]

Enterprise SDK 8.0 Reference API
IProtocolRule Properties
IProtocolRule Interface See Also Send Feedback

The IProtocolRule type exposes the following members.

Properties

Name | Description
PolicyService | Get switch policy (SPL) SPl is injected at object creation time
SwitchType | Get type of switch

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


PolicyService Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.PolicyService Property
IProtocolRule Interface See Also Send Feedback
Get switch policy (SPL) SPl is injected at object creation time

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ISwitchPolicyService PolicyService { get; }
Visual Basic (Declaration)
ReadOnly Property PolicyService As ISwitchPolicyService
Visual C++
property ISwitchPolicyService^ PolicyService {
    ISwitchPolicyService^ get ();
}

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


SwitchType Property

[image]

Enterprise SDK 8.0 Reference API
IProtocolRule..::.SwitchType Property
IProtocolRule Interface See Also Send Feedback
Get type of switch

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string SwitchType { get; }
Visual Basic (Declaration)
ReadOnly Property SwitchType As String
Visual C++
property String^ SwitchType {
    String^ get ();
}

See Also

IProtocolRule Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


ISwitchProfile Interface

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile Interface
Members See Also Send Feedback
Interface for handling switch abstraction

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public interface ISwitchProfile
Visual Basic (Declaration)
Public Interface ISwitchProfile
Visual C++
public interface class ISwitchProfile

See Also

ISwitchProfile Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


ISwitchProfile Members

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchProfile Members
ISwitchProfile Interface Methods Properties See Also Send Feedback

The ISwitchProfile type exposes the following members.

Methods

Name | Description
FindParties |
FindVirtualDevice | Overloaded.
FindVirtualInstruction | Overloaded.
FindVirtualProperty | Find a usable property based on the message type and a property type
GetFunctionHandlingContext | Overloaded.
IsFunctionAvailable | Evaluate if a function is allowed in a given context

Properties

Name | Description
Rules | Get custom switch rules

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


ISwitchProfile Methods

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchProfile Methods
ISwitchProfile Interface See Also Send Feedback

The ISwitchProfile type exposes the following members.

Methods

Name | Description
FindParties |
FindVirtualDevice | Overloaded.
FindVirtualInstruction | Overloaded.
FindVirtualProperty | Find a usable property based on the message type and a property type
GetFunctionHandlingContext | Overloaded.
IsFunctionAvailable | Evaluate if a function is allowed in a given context

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindParties Method

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindParties Method
ISwitchProfile Interface See Also Send Feedback

[Missing <summary> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindParties(Genesyslab.Platform.Commons.Protocols.IMessage)"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDictionary<HandleNameEnum, Object> FindParties(
    IMessage message
)
Visual Basic (Declaration)
Function FindParties ( _
    message As IMessage _
) As IDictionary(Of HandleNameEnum, Object)
Visual C++
IDictionary<HandleNameEnum, Object^>^ FindParties(
    IMessage^ message
)

Parameters

message
Type: IMessage

[Missing <param name="message"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindParties(Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindParties(Genesyslab.Platform.Commons.Protocols.IMessage)"]

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualDevice Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualDevice Method
ISwitchProfile Interface See Also Send Feedback

Overload List

Name | Description
FindVirtualDevice(IController, array<IDevice>[]()[], DeviceModeType, IMessage) | Find a suitable device based on a context
FindVirtualDevice(array<IController>[]()[], array<IDevice>[]()[], DeviceModeType, IMessage) | Find a suitable device based on a context

See Also

ISwitchProfile Interface
ISwitchProfile Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualDevice Method (IController, IDevice[], DeviceModeType, )

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualDevice Method (IController, array<IDevice>[]()[], DeviceModeType, )
ISwitchProfile Interface See Also Send Feedback
Find a suitable device based on a context

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice FindVirtualDevice(
    IController controller,
    IDevice[] listDevices,
    DeviceModeType mode,
    IMessage msg
)
Visual Basic (Declaration)
Function FindVirtualDevice ( _
    controller As IController, _
    listDevices As IDevice(), _
    mode As DeviceModeType, _
    msg As IMessage _
) As IDevice
Visual C++
IDevice^ FindVirtualDevice(
    IController^ controller,
    array<IDevice^>^ listDevices,
    DeviceModeType mode,
    IMessage^ msg
)

Parameters

controller
Type: Genesyslab.Enterprise.Model.ComponentModel..::.IController

[Missing <param name="controller"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController,Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

listDevices
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="listDevices"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController,Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

mode
Type: Genesyslab.Enterprise.SwitchAbstraction..::.DeviceModeType

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController,Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController,Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

IDevice

See Also

ISwitchProfile Interface
FindVirtualDevice Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualDevice Method (IController[], IDevice[], DeviceModeType, )

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualDevice Method (array<IController>[]()[], array<IDevice>[]()[], DeviceModeType, )
ISwitchProfile Interface See Also Send Feedback
Find a suitable device based on a context

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
IDevice FindVirtualDevice(
    IController[] controllers,
    IDevice[] listDevices,
    DeviceModeType mode,
    IMessage msg
)
Visual Basic (Declaration)
Function FindVirtualDevice ( _
    controllers As IController(), _
    listDevices As IDevice(), _
    mode As DeviceModeType, _
    msg As IMessage _
) As IDevice
Visual C++
IDevice^ FindVirtualDevice(
    array<IController^>^ controllers,
    array<IDevice^>^ listDevices,
    DeviceModeType mode,
    IMessage^ msg
)

Parameters

controllers
Type: array< Genesyslab.Enterprise.Model.ComponentModel..::.IController >[]()[]

[Missing <param name="controllers"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController[],Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

listDevices
Type: array< Genesyslab.Enterprise.Model.Device..::.IDevice >[]()[]

[Missing <param name="listDevices"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController[],Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

mode
Type: Genesyslab.Enterprise.SwitchAbstraction..::.DeviceModeType

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController[],Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualDevice(Genesyslab.Enterprise.Model.ComponentModel.IController[],Genesyslab.Enterprise.Model.Device.IDevice[],Genesyslab.Enterprise.SwitchAbstraction.DeviceModeType,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

IDevice

See Also

ISwitchProfile Interface
FindVirtualDevice Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualInstruction Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualInstruction Method
ISwitchProfile Interface See Also Send Feedback

Overload List

Name | Description
FindVirtualInstruction(Object, IMessage, IMessage%, ActionMode%) | Find a usable instruction based on the request and guidance policy NO input context
FindVirtualInstruction(Object, Object, IMessage, IMessage%, ActionMode%) | Find a usable instruction based on the request and guidance policy

See Also

ISwitchProfile Interface
ISwitchProfile Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualInstruction Method (Object, , , ActionMode)

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualInstruction Method (Object, , %, ActionMode%)
ISwitchProfile Interface See Also Send Feedback
Find a usable instruction based on the request and guidance policy NO input context

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object FindVirtualInstruction(
    Object guider,
    IMessage request,
    out IMessage response,
    ref ActionMode mode
)
Visual Basic (Declaration)
Function FindVirtualInstruction ( _
    guider As Object, _
    request As IMessage, _
    <OutAttribute> ByRef response As IMessage, _
    ByRef mode As ActionMode _
) As Object
Visual C++
Object^ FindVirtualInstruction(
    Object^ guider,
    IMessage^ request,
    [OutAttribute] IMessage^% response,
    ActionMode% mode
)

Parameters

guider
Type: System..::.Object

[Missing <param name="guider"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualInstruction(System.Object,Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Platform.Commons.Protocols.IMessage@,Genesyslab.Enterprise.SwitchAbstraction.ActionMode@)"]

request
Type: IMessage

[Missing <param name="request"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualInstruction(System.Object,Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Platform.Commons.Protocols.IMessage@,Genesyslab.Enterprise.SwitchAbstraction.ActionMode@)"]

response
Type: IMessage %

[Missing <param name="response"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualInstruction(System.Object,Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Platform.Commons.Protocols.IMessage@,Genesyslab.Enterprise.SwitchAbstraction.ActionMode@)"]

mode
Type: Genesyslab.Enterprise.SwitchAbstraction..::.ActionMode %

[Missing <param name="mode"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualInstruction(System.Object,Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Platform.Commons.Protocols.IMessage@,Genesyslab.Enterprise.SwitchAbstraction.ActionMode@)"]

Return Value

object

See Also

ISwitchProfile Interface
FindVirtualInstruction Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualInstruction Method (Object, Object, , , ActionMode)

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualInstruction Method (Object, Object, , %, ActionMode%)
ISwitchProfile Interface See Also Send Feedback
Find a usable instruction based on the request and guidance policy

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object FindVirtualInstruction(
    Object guider,
    Object context,
    IMessage request,
    out IMessage response,
    ref ActionMode mode
)
Visual Basic (Declaration)
Function FindVirtualInstruction ( _
    guider As Object, _
    context As Object, _
    request As IMessage, _
    <OutAttribute> ByRef response As IMessage, _
    ByRef mode As ActionMode _
) As Object
Visual C++
Object^ FindVirtualInstruction(
    Object^ guider,
    Object^ context,
    IMessage^ request,
    [OutAttribute] IMessage^% response,
    ActionMode% mode
)

Parameters

guider
Type: System..::.Object
Guidance object. If null, one will be created
context
Type: System..::.Object
Call context
request
Type: IMessage
Message to evaluate
response
Type: IMessage %
Message to send
mode
Type: Genesyslab.Enterprise.SwitchAbstraction..::.ActionMode %
Action to perform

Return Value

object

See Also

ISwitchProfile Interface
FindVirtualInstruction Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


FindVirtualProperty Method

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.FindVirtualProperty Method
ISwitchProfile Interface See Also Send Feedback
Find a usable property based on the message type and a property type

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
string FindVirtualProperty(
    IMessage msg,
    HandleNameEnum property
)
Visual Basic (Declaration)
Function FindVirtualProperty ( _
    msg As IMessage, _
    property As HandleNameEnum _
) As String
Visual C++
String^ FindVirtualProperty(
    IMessage^ msg,
    HandleNameEnum property
)

Parameters

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualProperty(Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Enterprise.SwitchAbstraction.HandleNameEnum)"]

property
Type: Genesyslab.Enterprise.SwitchAbstraction..::.HandleNameEnum

[Missing <param name="property"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.FindVirtualProperty(Genesyslab.Platform.Commons.Protocols.IMessage,Genesyslab.Enterprise.SwitchAbstraction.HandleNameEnum)"]

Return Value

string

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetFunctionHandlingContext Method

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.GetFunctionHandlingContext Method
ISwitchProfile Interface See Also Send Feedback

Overload List

Name | Description
GetFunctionHandlingContext(IDevice) | Get context for device
GetFunctionHandlingContext(IDevice, IMessage) | Get context for device
GetFunctionHandlingContext(IInteraction, IInteraction) | Get context for interaction

See Also

ISwitchProfile Interface
ISwitchProfile Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetFunctionHandlingContext Method (IDevice)

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.GetFunctionHandlingContext Method (IDevice)
ISwitchProfile Interface See Also Send Feedback
Get context for device

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetFunctionHandlingContext(
    IDevice device
)
Visual Basic (Declaration)
Function GetFunctionHandlingContext ( _
    device As IDevice _
) As Object
Visual C++
Object^ GetFunctionHandlingContext(
    IDevice^ device
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.GetFunctionHandlingContext(Genesyslab.Enterprise.Model.Device.IDevice)"]

Return Value

object

See Also

ISwitchProfile Interface
GetFunctionHandlingContext Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetFunctionHandlingContext Method (IDevice, )

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.GetFunctionHandlingContext Method (IDevice, )
ISwitchProfile Interface See Also Send Feedback
Get context for device

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetFunctionHandlingContext(
    IDevice device,
    IMessage msg
)
Visual Basic (Declaration)
Function GetFunctionHandlingContext ( _
    device As IDevice, _
    msg As IMessage _
) As Object
Visual C++
Object^ GetFunctionHandlingContext(
    IDevice^ device,
    IMessage^ msg
)

Parameters

device
Type: Genesyslab.Enterprise.Model.Device..::.IDevice

[Missing <param name="device"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.GetFunctionHandlingContext(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.GetFunctionHandlingContext(Genesyslab.Enterprise.Model.Device.IDevice,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

object

See Also

ISwitchProfile Interface
GetFunctionHandlingContext Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


GetFunctionHandlingContext Method (IInteraction, IInteraction)

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.GetFunctionHandlingContext Method (IInteraction, IInteraction)
ISwitchProfile Interface See Also Send Feedback
Get context for interaction

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
Object GetFunctionHandlingContext(
    IInteraction activeInteraction,
    IInteraction relatedInteraction
)
Visual Basic (Declaration)
Function GetFunctionHandlingContext ( _
    activeInteraction As IInteraction, _
    relatedInteraction As IInteraction _
) As Object
Visual C++
Object^ GetFunctionHandlingContext(
    IInteraction^ activeInteraction,
    IInteraction^ relatedInteraction
)

Parameters

activeInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Current Interaction
relatedInteraction
Type: Genesyslab.Enterprise.Model.Interaction..::.IInteraction
Parent interaction

Return Value

object

See Also

ISwitchProfile Interface
GetFunctionHandlingContext Overload
Genesyslab.Enterprise.SwitchAbstraction Namespace


IsFunctionAvailable Method

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.IsFunctionAvailable Method
ISwitchProfile Interface See Also Send Feedback
Evaluate if a function is allowed in a given context

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
bool IsFunctionAvailable(
    Object context,
    IMessage msg
)
Visual Basic (Declaration)
Function IsFunctionAvailable ( _
    context As Object, _
    msg As IMessage _
) As Boolean
Visual C++
bool IsFunctionAvailable(
    Object^ context,
    IMessage^ msg
)

Parameters

context
Type: System..::.Object

[Missing <param name="context"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.IsFunctionAvailable(System.Object,Genesyslab.Platform.Commons.Protocols.IMessage)"]

msg
Type: IMessage

[Missing <param name="msg"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.ISwitchProfile.IsFunctionAvailable(System.Object,Genesyslab.Platform.Commons.Protocols.IMessage)"]

Return Value

bool

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


ISwitchProfile Properties

[image] [image]

Enterprise SDK 8.0 Reference API
ISwitchProfile Properties
ISwitchProfile Interface See Also Send Feedback

The ISwitchProfile type exposes the following members.

Properties

Name | Description
Rules | Get custom switch rules

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


Rules Property

[image]

Enterprise SDK 8.0 Reference API
ISwitchProfile..::.Rules Property
ISwitchProfile Interface See Also Send Feedback
Get custom switch rules

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
ICollection<KeyValuePair<int, Func<IController, IDevice, bool>>> Rules { get; }
Visual Basic (Declaration)
ReadOnly Property Rules As ICollection(Of KeyValuePair(Of Integer, Func(Of IController, IDevice, Boolean)))
Visual C++
property ICollection<KeyValuePair<int, Func<IController^, IDevice^, bool>^>>^ Rules {
    ICollection<KeyValuePair<int, Func<IController^, IDevice^, bool>^>>^ get ();
}

See Also

ISwitchProfile Interface
Genesyslab.Enterprise.SwitchAbstraction Namespace


SwitchConfig Structure

[image]

Enterprise SDK 8.0 Reference API
SwitchConfig Structure
Members See Also Send Feedback

[Missing <summary> documentation for "T:Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public struct SwitchConfig
Visual Basic (Declaration)
Public Structure SwitchConfig
Visual C++
public value class SwitchConfig

See Also

SwitchConfig Members
Genesyslab.Enterprise.SwitchAbstraction Namespace


SwitchConfig Members

[image] [image]

Enterprise SDK 8.0 Reference API
SwitchConfig Members
SwitchConfig Structure Constructors Methods Fields See Also Send Feedback

The SwitchConfig type exposes the following members.

Constructors

Name | Description
SwitchConfig | Build up a configuration list of device type

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | List all devices type defined in the structure (Overrides ValueType..::.ToString()()().)

Fields

Name | Description
entry |

See Also

SwitchConfig Structure
Genesyslab.Enterprise.SwitchAbstraction Namespace


SwitchConfig Constructor

[image]

Enterprise SDK 8.0 Reference API
SwitchConfig Constructor
SwitchConfig Structure See Also Send Feedback
Build up a configuration list of device type

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public SwitchConfig(
    DeviceType[] list
)
Visual Basic (Declaration)
Public Sub New ( _
    list As DeviceType() _
)
Visual C++
public:
SwitchConfig(
    array<DeviceType>^ list
)

Parameters

list
Type: array< Genesyslab.Enterprise.Model.Device..::.DeviceType >[]()[]

[Missing <param name="list"/> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig.#ctor(Genesyslab.Enterprise.Model.Device.DeviceType[])"]

See Also

SwitchConfig Structure
Genesyslab.Enterprise.SwitchAbstraction Namespace


SwitchConfig Fields

[image] [image]

Enterprise SDK 8.0 Reference API
SwitchConfig Fields
SwitchConfig Structure See Also Send Feedback

The SwitchConfig type exposes the following members.

Fields

Name | Description
entry |

See Also

SwitchConfig Structure
Genesyslab.Enterprise.SwitchAbstraction Namespace


entry Field

[image]

Enterprise SDK 8.0 Reference API
SwitchConfig..::.entry Field
SwitchConfig Structure See Also Send Feedback

[Missing <summary> documentation for "F:Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig.entry"]

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public DeviceType[] entry
Visual Basic (Declaration)
Public entry As DeviceType()
Visual C++
public:
array<DeviceType>^ entry

See Also

SwitchConfig Structure
Genesyslab.Enterprise.SwitchAbstraction Namespace


SwitchConfig Methods

[image] [image]

Enterprise SDK 8.0 Reference API
SwitchConfig Methods
SwitchConfig Structure See Also Send Feedback

The SwitchConfig type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
ToString | List all devices type defined in the structure (Overrides ValueType..::.ToString()()().)

See Also

SwitchConfig Structure
Genesyslab.Enterprise.SwitchAbstraction Namespace


ToString Method

[image]

Enterprise SDK 8.0 Reference API
SwitchConfig..::.ToString Method
SwitchConfig Structure See Also Send Feedback
List all devices type defined in the structure

Namespace: Genesyslab.Enterprise.SwitchAbstraction
Assembly: Genesyslab.Enterprise.SwitchAbstraction (in Genesyslab.Enterprise.SwitchAbstraction.dll) Version: 8.1.400.19 (8.1.400.19)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Genesyslab.Enterprise.SwitchAbstraction.SwitchConfig.ToString"]

See Also

SwitchConfig Structure
Genesyslab.Enterprise.SwitchAbstraction Namespace